ISX/ISZ13 CM2150 SN, ISF2.8 CM2220 EC/ECF2/ECCF2, ISF3.8 CM2220 AN, ISF2.8/3.8 CM2220, ISF2.8 CM2220 AN, ISB4.5/6.7 ISD4.5/6.7 CM2150 SN (Euro 4.5), ISL8.9 CM2150 SN (Euro 4.5), ISB4.5/6.7 ISD4.5/6.7 CM2150 SN (Euro 5), ISL8.9 CM2150 SN (Euro 5), ISM11 CM876 SN, ISF2.8/3.8 CM2220 AN, ISL8.9 CM2150 S

ISX/ISZ13 CM2150 SN, ISF2.8 CM2220 EC/ECF2/ECCF2, ISF3.8 CM2220 AN, ISF2.8/3.8 CM2220, ISF2.8 CM2220 AN, ISB4.5/6.7 ISD4.5/6.7 CM2150 SN (Euro 4.5), ISL8.9 CM2150 SN (Euro 4.5), ISB4.5/6.7 ISD4.5/6.7 CM2150 SN (Euro 5), ISL8.9 CM2150 SN (Euro 5), ISM11 CM876 SN, ISF2.8/3.8 CM2220 AN, ISL8.9 CM2150 SN, ISB4.5/6.7 ISD4.5/6.7 CM2150 SN, ISZ13 CM2880 SN, ISD6.7 CM2150 SN, ISB5.9/ISD6.7 CM2880 WFLD, QTR CM2350 TR102, Cummins Emission Solutions Aftertreatment, ISC8.3 CM2880 SN, ISL8.9/ISL9.5 CM2880 NS5, ISZ13 CM2150,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware failures or internal ECM voltage supply circuits. | Engine may not start.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Control Module
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Control Module
ISM11 CM876 SN - Engine Control Module

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies depending on engine model and can be mounted either on or off engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111.

Last Modified: 27-Oct-2015
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine could possibly not start.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Magnetic Speed/Position Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Magnetic Speed/Position Sensor Circuit
ISM11 CM876 SN - Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM detects the reversed sensors and continues to operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 27-Oct-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Engine power derate.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Manifold 1 Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Pressure Sensor Circuit
ISM11 CM876 SN - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • The torque output of the engine will be reduced

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with selective catalytic reduction (SCR) aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-122.

Last Modified: 29-Oct-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Engine power derate.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ ISF3.8 CM2220 AN - Intake Manifold 1 Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Pressure Sensor Circuit
ISM11 CM876 SN - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Engine power will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with selective catalytic reduction (SCR) aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-123.

Last Modified: 29-Oct-2015


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: 102 SPN: 102 FMI: 18 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Intake manifold pressure is below the minimum operating limit. | Possible reduced engine performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

If the ECM detects that the necessary charge flow into the engine is below the minimum limit for a period of time, this fault code is logged.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic only runs when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal reading is below the expected level for the present engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the engine is able to achieve the desired oxygen level necessary for complete combustion and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions. The ECM commands a charge flow command and the variable geometry turbocharger and exhaust gas recirculation valve move to meet this command. If the engine is unable to achieve the desired oxygen level necessary for complete combustion, this fault code is logged.

Possible causes of this fault are:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • A damaged intake manifold pressure sensor
  • A damaged barometric pressure sensor
  • Restriction in the charge-air cooler
  • Leaks or restrictions in the exhaust gas recirculation system plumbing
  • Fuel inlet restriction too high (normally caused by a restricted fuel filter)
  • Restriction in the air filter
  • Restriction in the exhaust system.
Refer to Troubleshooting Fault Code t05-125.

Last Modified: 28-Oct-2015


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | Severe derate in power output of the engine. Limp home power only.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Accelerator Pedal or Lever Position Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Accelerator Pedal or Lever Position Sensor Circuit
ISM11 CM876 SN - Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage higher than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Failed accelerator pedal or lever position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-131.

Last Modified: 29-Oct-2015


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | Severe derate in power output of the engine. Limp home power only.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Accelerator Pedal Position Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Accelerator Pedal Position Sensor Circuit
ISM11 CM876 SN - Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than a calibratible value for more than 1 second

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed. If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Failed accelerator pedal or lever position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-132.

Last Modified: 29-Oct-2015


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to 0 percent.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Remote Accelerator Pedal Position Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Remote Accelerator Pedal Position Sensor Circuit
ISM11 CM876 SN - Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open remote accelerator pedal or lever return circuit in the harness or connections
  • Remote accelerator supply shorted to battery
  • Failed remote accelerator pedal or lever position sensor.

The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-133.

Last Modified: 28-Oct-2015


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to 0 percent.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Remote Accelerator Pedal or Lever Position Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Remote Accelerator Pedal or Lever Position Sensor Circuit
ISM11 CM876 SN - Remote Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Validate the repair. Start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Failed remote accelerator pedal or lever position sensor
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-134.

Last Modified: 28-Oct-2015


Fault Code Path Selection

FAULT CODE 120-fc135
Fault Code Path Selection

Is the oil rifle pressure a sensor? | Go to 120-fc135sensor
Is the oil rifle pressure a switch? | Go to 120-fc135switch

Last Modified: 20-Aug-2015


Fault Code Path Selection

FAULT CODE 120-fc141
Fault Code Path Selection

Is the oil rifle pressure a sensor? | Go to 120-fc141sensor
Is the oil rifle pressure a switch? | Go to 120-fc141switch

Last Modified: 20-Aug-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P0524 SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Engine power derate.
ISL9 CM2150 SN - Engine Oil Rifle Pressure
ISM11 CM876 SN - Engine Oil Rifle Pressure
ISZ13 CM2150 - Engine Oil Rifle Pressure
ISF2.8 CM2220 AN - Engine Oil Rifle Pressure

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

If the ECM detects low signal voltage, indicating low engine oil pressure, this fault code sets.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the engine oil pressure is less than the engine protection limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM limits the power output of the engine.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code t05-143.

Last Modified: 29-Oct-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for engine coolant temperature circuit faults.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Coolant Temperature 1 Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Coolant Temperature 1 Sensor Circuit
ISM11 CM876 SN - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the coolant temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque can possibly be reduced.
  • A default value is used for the coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-144.

Last Modified: 29-Oct-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for engine coolant temperature circuit faults.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Coolant Temperature 1 Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Coolant Temperature 1 Sensor Circuit
ISM11 CM876 SN - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine coolant. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value is used for the coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

On some engines, the coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-145.

Last Modified: 29-Oct-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Power derate and possible engine shutdown if the Engine Protection Shutdown feature is enabled.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Coolant Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine coolant. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will become inactive immediately after the coolant temperature decreases below the engine protection limit.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature.

Refer to Troubleshooting Fault Code t05-146.

Last Modified: 28-Oct-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Coolant Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Coolant Temperature Sensor Circuit
ISM11 CM876 SN - Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than the maximum operating limits set in the ECM calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the coolant temperature decreases below the engine protection limit.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code t05-151.

Last Modified: 28-Oct-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for intake manifold air temperature.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Manifold 1 Temperature/Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Temperature/Pressure Sensor Circuit
ISM11 CM876 SN - Intake Manifold 1 Temperature/Pressure Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The ECM supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the intake manifold temperature signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque can possibly be reduced.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 29-Oct-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for intake manifold air temperature.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Manifold 1 Temperature/Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Temperature/Pressure Sensor Circuit
ISM11 CM876 SN - Intake Manifold 1 Temperature/Pressure Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the ECM for the engine protection system and engine emission control. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is less than 0.41-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque can possibly be reduced.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 29-Oct-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after Red Stop Lamp starts flashing.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Manifold 1 Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Pressure Sensor Circuit
ISM11 CM876 SN - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the engine control module (ECM) for the engine protection system and engine emission control. The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected the intake manifold air temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-155.

Last Modified: 29-Oct-2015


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 175

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 175 PID: S254 SPN: 3464 FMI: 3 LAMP: Red SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage has been detected at the engine intake throttle valve actuator. | Engine intake throttle valve actuator will be disabled.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Control Module

Circuit Description

The engine control module (ECM) controls the engine intake throttle actuator , opening and closing it based on various operating conditions. The engine intake throttle actuator is opened and closed by a DC motor that receives voltage from the ECM on the engine intake throttle actuator motor signal (+) and (-) circuits. To open the actuator , the motor receives voltage on the engine intake throttle actuator motor signal (+) circuit. To close the actuator , the motor receives voltage on the EGR valve motor signal (-) circuit.

Component Location

The intake throttle actuator is mounted in the intake air stream, between the charge-air cooler and the intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects a short circuit to voltage or open circuit in the intake throttle motor supply circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails. The intake throttle actuator operation will be disabled, and the actuator will default to the open position.

Conditions for Clearing the Fault Code

  • The fault code will always be inactive at key ON. To validate the repair, start and idle the engine for 1 minute. If the fault code does not become active again, the repair has been validated.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level of the circuit and logs a fault code if the voltage level indicates a short to voltage. This fault is always set inactive when the keyswitch is turned ON. If there is a failure of this circuit, the fault code will not be set active until the actuator has been actuated. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault are that the intake throttle actuator motor (+ or - ) wires can become open or shorted to a voltage source in the harness or ECM.

NOTE: Do not supply 12V to the intake throttle actuator position sensor, or short the intake throttle actuator motor wires to the intake throttle actuator position sensor. The intake throttle actuator position is rated at 5V, and sensor damage can occur.

Refer to Troubleshooting Fault Code t05-175.

Last Modified: 26-Apr-2012


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 176

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 176 PID: S254 SPN: 3464 FMI: 4 LAMP: Red SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected at the engine intake throttle actuator. | Engine intake throttle actuator actuation will be disabled.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Intake Throttle Actuator

Circuit Description

The engine control module (ECM) controls the engine intake throttle actuator, opening and closing it based on various operating conditions. The engine intake throttle actuator is opened and closed by a DC motor that receives voltage from the ECM on the engine intake throttle actuator motor signal (+) and (-) circuits. To open the valve, the motor receives voltage on the engine intake throttle actuator motor signal (+) circuit. To close the valve, the motor receives voltage on the exhaust gas recirculation (EGR) valve motor signal (-) circuit.

Component Location

The engine intake throttle actuator is mounted in the intake air stream, between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects a short circuit to ground in the engine intake throttle actuator motor supply circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails. The intake throttle actuator operation will be disabled, and the valve will default to the open position.

Conditions for Clearing the Fault Code

  • The fault code will always be inactive at key ON. To validate the repair, start and idle the engine for 1 minute. If the fault code does not become active again, the repair has been validated.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code can also be cleared with the INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level of the circuit and logs a fault code if the voltage level indicates a short to ground. This fault is always set inactive when the keyswitch is turned ON. If there is a malfunction of this circuit, the fault code will not be set active until the actuator has been actuated. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault is intake throttle actuator motor output (+ or -) leads shorted to ground in the harness, intake throttle actuator motor, or ECM.

NOTE: Do not supply 12-VDC to the engine intake throttle actuator position sensor, or short the engine intake throttle actuator motor wires to the engine intake throttle actuator position sensor. The engine intake throttle actuator position is rated at 5-VDC, and sensor damage can occur.

Refer to Troubleshooting Fault Code t05-176.

Last Modified: 26-Apr-2012


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 PID: S254 SPN: 3464 FMI: 7 LAMP: Red SRT: | Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment. The engine intake throttle actuator motor has exceeded the duty cycle limit indicating a stuck open intake throttle actuator. | Engine intake throttle actuator will be disabled.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Electronic Throttle Control Actuator

Circuit Description

The engine control module (ECM) controls the engine intake throttle actuator, opening and closing it based on various operating conditions. The engine intake throttle actuator is opened and closed by a DC motor that receives voltage from the ECM on the engine intake throttle actuator motor signal (+) and (-) circuits. To open the actuator, the motor receives voltage on the engine intake throttle actuator motor signal (+) circuit. To close the actuator, the motor receives voltage on the EGR actuator motor signal (-) circuit.

Component Location

The engine intake throttle actuator is mounted in the intake air stream, between the charge-air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is operating.

Conditions for Setting the Fault Codes

This fault code is set when the duty cycle required to open the intake throttle actuator is greater than 95 percent for 3 seconds.

The fault code will be inactive at key ON. It will only go active if the engine intake throttle actuator is commanded open and the engine intake throttle actuator is unable to move to the commanded position.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails. The engine intake throttle actuator operation will be disabled.

Conditions for Clearing the Fault Code

  • The fault code will always be inactive at key ON. To validate the repair, start and idle the engine for 1 minute. If the fault code does not become active again, the repair has been validated.

  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code can also be cleared with the INSITE™ electronic service tool.

Shop Talk

The ECM monitors the duty cycle of the actuator and logs a fault code if the duty cycle is too high. This fault is always set inactive when the keyswitch is turned ON. If there is a malfunction, the fault code will not be set active until the actuator has been actuated. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault include:

  • Malfunctioning intake throttle actuator position sensor; mechanical or electrical malfunction.
  • Intake throttle actuator assembly failure requiring a high current to operate the actuator, such as a stuck or sticking valve.

NOTE: Do not supply 12-VDC to the engine intake throttle actuator position sensor, or short the intake throttle actuator motor wires to the intake throttle actuator position sensor. The intake throttle actuator position sensor is rated at 5-VDC, and sensor damage may occur.

Refer to Troubleshooting Fault Code t05-177.

Last Modified: 26-Apr-2012


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Engine power derate.
ISM11 CM876 SN - Sensor Supply 2 Circuit

Circuit Description

The sensor supply number 2 pin of the electronic control module (ECM) provides (+) 5-VDC for the camshaft position sensor, exhaust gas pressure sensor, rail fuel pressure sensor, intake manifold pressure/temperature sensor, and crankcase pressure sensor.

Component Location

Sensor supply number 2 is located in the ECM and provides a 5-VDC SUPPLY to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 2 signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold pressure sensor.
  • The backup camshaft position sensor will not be functional.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-187.

Last Modified: 26-Apr-2012


Air Conditioner Clutch Supply Circuit

FAULT CODE 191

Air Conditioner Clutch Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 191 PID: P050 SPN: 876 FMI: 11 LAMP: SRT: | Air Conditioner Clutch Supply Circuit. Air conditioner clutch signal indicates a short to ground when commanded ON. | Can not turn on air conditioner.
Air Conditioner Clutch Supply Circuit

Circuit Description

The air conditioner clutch solenoid is a device used by the electronic control module (ECM) to control the air conditioner by sending a signal to open or close the air conditioner clutch solenoid.

Component Location

Refer to an original equipment manufacturer's (OEM) diagram for the location of the air conditioner clutch solenoid.

Shop Talk

Air conditioner clutch solenoid could be malfunctioning due to a damaged engine harness or a bad ground on the air conditioner clutch connector.

Refer to Troubleshooting Fault Code t05-191.

Last Modified: 28-Jan-2011


Fault Code Path Selection

FAULT CODE 120-fc195
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 120-fc195-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 120-fc195-3wire

Last Modified: 23-Apr-2009


Fault Code Path Selection

FAULT CODE 120-fc196
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 120-fc196-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 120-fc196-3wire

Last Modified: 30-Apr-2009


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P2560 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Engine Coolant Level Sensor Circuit
ISM11 CM876 SN - Engine Coolant Level Sensor Circuit
ISZ13 CM2150 - Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) supplies 5 volts to the coolant level signal circuit. The resistance of the engine coolant level sensor changes, based on the coolant level. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the original equipment manufacturer (OEM) service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminated the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) after 20 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after 20 seconds of detecting the correct engine coolant level.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code becomes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-197.

Last Modified: 28-Oct-2015


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the engine oil temperature circuit. | No engine protection for engine oil temperature.
ISM11 CM876 SN - Engine Oil Temperature Sensor 1 Circuit
ISX15 CM2250 - Engine Oil Temperature Sensor 1 Circuit
ISZ13 CM2150 - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature.

When the oil temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD engines.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors.

An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-212.

Last Modified: 26-Apr-2012


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P0197 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil temperature circuit. | No engine protection for engine oil temperature.
ISM11 CM876 SN - Engine Oil Temperature Sensor 1 Circuit
ISX15 CM2250 - Engine Oil Temperature Sensor 1 Circuit
ISZ13 CM2150 - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature.

When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD engines.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-213.

Last Modified: 26-Apr-2012


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature High - Data Valid But Above Normal Operating Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
ISM11 CM876 SN - Engine Oil Temperature Sensor Circuit
ISX15 CM2250 - Engine Oil Temperature Sensor Circuit
ISZ13 CM2150 - Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature is greater than 122°C [252°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the oil temperature decreases below the engine protection limi and the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code t05-214.

Last Modified: 26-Apr-2012


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Engine power derate.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Barometric Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Barometric Pressure Sensor Circuit
ISM11 CM876 SN - Barometric Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation that the engine is presently operating at. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is greater than 4.75-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately, when the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221.

Last Modified: 29-Oct-2015


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Engine power derate.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Barometric Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Barometric Pressure Sensor Circuit
ISM11 CM876 SN - Barometric Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is less 0.25-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222.

Last Modified: 29-Oct-2015


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Engine power derate.
ISM11 CM876 SN - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 of the electronic control module (ECM) provides a 5 volt supply for the accelerator position number 2 sensor, remote accelerator position sensor, engine coolant level sensor, OEM pressure sensor, and diesel exhaust fluid temperature/level sensor.

Component Location

The sensor supply 2 is located in the ECM. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 2 signal voltage is more than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas pressure sensor, intake manifold pressure sensor, and the crankcase pressure sensor is used.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code t05-227.

Last Modified: 26-Apr-2012


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Crankshaft Position Sensor and Engine Speed Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Crankshaft Position Sensor and Engine Speed Sensor Circuit
ISM11 CM876 SN - Engine Crankshaft Position Sensor and Engine Speed Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The electronic control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine speed has exceeded the calibration limit for excessive engine speed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the engine speed drops to normal operating speeds.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 28-Oct-2015


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Sensor Supply 3 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Sensor Supply 3 Circuit
ISM11 CM876 SN - Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 3 signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor 5-VDC supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible cause of this fault code is a short circuit to ground in the engine harness, sensor, or ECM.

Refer to Troubleshooting Fault Code t05-238.

Last Modified: 27-Oct-2015


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Sensor Supply 3 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Sensor Supply 3 Circuit
ISM11 CM876 SN - Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Not applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 3 signal voltage is more than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code t05-239.

Last Modified: 27-Oct-2015


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect. The ECM lost the vehicle speed signal. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise control, Gear-Down Protection, and Road Speed Governor will not work.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Vehicle Speed Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Vehicle Speed Sensor Circuit
ISM11 CM876 SN - Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion.

Conditions for Setting the Fault Codes

The ECM detects a loss of vehicle speed when other engine operating conditions indicate that the vehicle could possibly be in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle for 1 minute to validate the repair.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The ECM will turn off the Malfunction Indicator Lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault code is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault code can also become active if there is a series of clutch, service brake, or throttle movements, with no vehicle movement. The fault code is set inactive when the ECM receives a vehicle speed signal greater than zero.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not catch all malfunctions of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors, and tachographs are not fully covered under this procedure.

Refer to Troubleshooting Fault Code t05-241.

Last Modified: 28-Oct-2015


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: SPN: 84 FMI: 10 LAMP: Amber SRT: | Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Vehicle Speed Sensor Circuit
ISM11 CM876 SN - Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission.

Conditions for Running the Diagnostics

  • The adjustable parameter “VSS Anti-Tampering” must be enabled.
  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The ECM detects a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • The ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The keyswitch must be turned ON, and the vehicle speed and engine speed must be zero for 30 seconds.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.

Shop Talk

Verify the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

When the speed signal has been restored, the fault code will go inactive, once the keyswitch is on for 30 seconds and the ECM senses zero vehicle and engine speed.

Refer to Troubleshooting Fault Code t05-242.

Last Modified: 28-Oct-2015


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can possibly stay on continuously or not run at all.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - Fan Control Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN/ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Fan Control Circuit
ISL9 CM2150 SN - Fan Control Circuit
ISM11 CM876 SN - Fan Control Circuit
ISZ13 CM2150 - Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by the OEM. OEMs can use a solenoid return that is wired to the ECM or use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is getting energized or de-energized. In some cases, the diagnostics can also run at certain fixed intervals.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is not detected to be system voltage when the PWM signal is turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan will not be enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12-VDC or 24-VDC ON, or 0-VDC ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12-VDC or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12-VDC or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

Refer to Troubleshooting Fault Code t05-245.

Last Modified: 28-Oct-2015


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at ambient air temperature circuit. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor is used by the electronic control module (ECM) to monitor ambient air temperature. This can be used to sense the temperature inside the cab of a vehicle or the air temperature outside of the vehicle. The ambient air temperature signal is used by the ECM for the Idle Shutdown Ambient Air Temperature Override feature.

The ambient air temperature sensor is used by the ECM to monitor the ambient air temperature. The ambient air temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Engine torque will be reduced.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-249.

Last Modified: 29-Oct-2015


Engine Oil Level - Data Erratic, Intermittent, or Incorrect

FAULT CODE 252

Engine Oil Level - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 252 PID: SPN: 98 FMI: 2 LAMP: Amber SRT: | Engine Oil Level - Data Erratic, Intermittent, or Incorrect. An intermittent signal is being received from the oil level sensor. | Oil level sensor operation will be disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Oil Level Sensor Circuit

Circuit Description

The oil level sensor will monitor the oil fluid level in the oil pan at key ON. The oil level sensor will not monitor the oil level after the engine is started or when the engine speed is greater than 0 rpm. During engine key ON, if the oil level sensor detects a critical low oil level, then the amber CHECK ENGINE lamp will blink for 30 seconds and a fault code will be logged. If an operator observes a blinking amber CHECK ENGINE lamp at key ON, the operator must check the engine oil level with the manual dipstick.

The oil level sensor provides the electronic control module (ECM) with a pulse width modulated (PWM) signal. Within this signal, the oil level sensor transmits the engine oil level reading, oil temperature, and fault code information from the oil level sensor.

Component Location

The oil level sensor is located on the left side of the engine on the front part of the dipstick port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is in operation.

Conditions for Setting the Fault Codes

A valid PWM message is not received from the oil level sensor within the required time limits at initial key ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The oil level sensor operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable oil level sensor operation immediately after a valid PWM signal is received from the oil level sensor.

Shop Talk

Possible causes of this fault code include:

  • The oil level sensor is not receiving power from the ECM. This can be caused by an open circuit in the power supply or low voltage supplied by the primary engine ECM
  • Open return circuit on the oil level sensor circuit between the engine ECM and the oil level sensor
  • Open or short circuit on the oil level sensor signal circuit between the ECM and oil level sensor
  • A damaged oil level sensor.
Refer to Troubleshooting Fault Code 252.

Last Modified: 26-Oct-2009


Engine Oil Level - Data Valid but Below Normal Operating Range - Most Severe Level

FAULT CODE 253

Engine Oil Level - Data Valid but Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 253 PID: Not Mapped SPN: 98 FMI: 1 LAMP: Red SRT: | Engine Oil Level - Data Valid but Below Normal Operating Range - Most Severe Level. Very low oil level has been detected by the oil level sensor. | The engine may derate. Possible low oil pressure, possible severe engine damage.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Engine Oil Level Sensor Circuit

Circuit Description

An algorithm in the electronic control module (ECM) calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level falls below a certain threshold, the ECM will activate Fault Code 253.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the air intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine speed is 0 rpm.

Conditions for Setting the Fault Codes

The engine oil level is detected to be very low at key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If inactive counts of Fault Code 253 are logged in the ECM, it can be possible that the engine was running or keyed on while tilted at an angle severe enough to cause this fault to be triggered.

Other causes of Fault Code 253 can include:

  • The engine might not have been filled to proper capacity during the most recent oil change
  • External engine oil leaks (oil leaking onto the ground)
  • Internal engine oil leaks (oil leaking into the fuel system or cooling system)
  • High engine oil consumption/power cylinder failure (check for abnormally high blowby when the engine is loaded).
Refer to Troubleshooting Fault Code 253.

Last Modified: 29-Nov-2010


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: SPN: 632 FMI: 4/4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at fuel shutoff valve circuit. | Fuel shutoff valve will close. Engine will shut down.
ISM11 CM876 SN - Engine Fuel Shutoff Valve Driver Circuit

Circuit Description

The fuel shutoff valve is a device used by the electronic control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

The engine fuel shutoff valve driver circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage.

Component Location

The fuel shutoff valve is located near the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The engine will be shut down and will not restart.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not malfunctioned and pulled down the voltage on the fuel shutoff circuit. Inspect the engine-to-chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.

Possible causes for this fault include:

  • Short circuit to ground in the engine harness, connectors, or fuel shutoff valve.
Refer to Troubleshooting Fault Code 254.

Last Modified: 07-Sep-2009


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: SPN: 632 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or short to voltage source detected at fuel shutoff valve circuit. | Fuel shutoff valve may not open when keyswitch is in ON position, or may not close when keyswitch is in OFF position.
ISM11 CM876 SN - Engine Fuel Shutoff Valve Driver Circuit

Circuit Description

The fuel shutoff valve is a device used by the electronic control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

The engine fuel shutoff valve driver circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage.

Component Location

The fuel shutoff valve is located near the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit PWM signal is detected to be at system voltage when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine will be shutdown and will not restart.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

If there is an external shutdown system on the vehicle, make sure it iswired correctly and feeding voltage into the fuel shutoff supply circuit.

Possible causes of this fault include:

  • Open circuit in the engine harness, connectors, or shutoff valve.
  • Fuel shutoff valve signal wire shorted to a voltage source in the harness.
Refer to Troubleshooting Fault Code 255.

Last Modified: 07-Sep-2009


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at ambient air temperature circuit. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air to determine if heating of the selective catalytic reduction (SCR) system is required. The electronic control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The location of the ambient air temperature sensor can vary, and is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Engine torque will be reduced.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 256.

Last Modified: 29-Oct-2015


Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 257

Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 257 PID: S017 SPN: 632 FMI: 7/7 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment. Fuel shutoff valve is stuck open mechanically or is leaking. | Engine will run derated. The engine may run on for a brief period when the keyswitch is turned OFF.
ISM11 CM876 SN - Engine Fuel Shutoff Valve

Circuit Description

Voltage is supplied to the fuel shutoff valve by the electronic control module (ECM) while the engine keyswitch is ON. While the keyswitch is turned OFF, the voltage to the fuel shutoff valve is turned off by the ECM. The fuel shutoff valve closes and stops fuel from flowing to the fuel system.

Component Location

The fuel shutoff valve is located near the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned to the OFF position.

Conditions for Setting the Fault Codes

Engine speed is greater than a calibratable value after the keyswitch is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. INSITE™ electronic service tool can also be used to clear the fault code.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

Upon turning the keyswitch OFF, the ECM turns off the voltage supplied to keep the fuel shutoff valve open. The fuel control continues to fire the injectors for a short period of time as the engine speed drops off. The ECM monitors engine speed using the engine position sensor during this time. If the engine speed does not drop after the keyswitch is turned OFF, the ECM activates this fault. A possible cause of this fault code is extra wires attached to the fuel shutoff valve.

Refer to Troubleshooting Fault Code 257.

Last Modified: 07-Sep-2009


Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

FAULT CODE 269

Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 269 PID: SPN: 1195 FMI: 2 LAMP: Red SRT: | Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect. Engine ignition attempt without authorization from the immobilizer anti-theft device. | The engine will not start.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Antitheft Password Valid Indicator Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Antitheft Password Valid Indicator Circuit
ISM11 CM876 SN - Antitheft Password Valid Indicator Circuit

Circuit Description

The immobilizer antitheft device is connected to the primary engine electronic control module (ECM) through a J1939 data link network.

Messages sent from the immobilizer antitheft device are received by the ECM and used for controlling the antitheft features. The ECM and immobilizer antitheft device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and location of original equipment manufacturer (OEM) installed J1939 devices varies by OEM. The immobilizer antitheft device is installed by the OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is active when the immobilizer antitheft device has not been deactivated.

Action Taken When the Fault Code is Active

The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.

Shop Talk

This fault code is active when the immobilizer anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

Refer to Troubleshooting Fault Code 269.

Last Modified: 27-Oct-2015


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: SPN: 1347 FMI: 4 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage is detected at the fuel pump actuator circuit. | Engine will run poorly at idle. Engine will have low power. Fuel pressure will be higher than commanded.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Fuel Pump Actuator Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the electronic control module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the electronic fuel control actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on the engine-mounted fuel pump. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code becomes active when the ECM detects a short circuit in the electronic fuel control actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel control actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel control actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Fault Code 2311 can have high counts if the fault condition is or was intermittent.

Refer to Troubleshooting Fault Code 271.

Last Modified: 28-Oct-2015


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: SPN: 1347 FMI: 3 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit is detected at the fuel pump actuator circuit. | Engine will not run or engine will run poorly.
ISF2CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Fuel Pump Pressurizing Assembly 1 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Fuel Pump Pressurizing Assembly 1 Circuit

Circuit Description

The circuit is a pulse width modulation (PWM) driver in the electronic control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on the engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes. To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

  • This fault becomes active when the ECM detects an open in the fuel pump actuator circuit. Causes of this fault code are a short circuit to positive voltage or an open circuit in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. If the fault code is intermittent, look closely for causes of an intermittent open circuit such as loose pins, bad connections, or loose wire connections at the ECM connector. Also, if the fault code is intermittent, wiggle the harness while monitoring the fault code state to check for a wiring issue internal to the harness.
Refer to Troubleshooting Fault Code 272.

Last Modified: 28-Oct-2015


Engine Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 281

Engine Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 281 PID: S126 SPN: 1347 FMI: 7 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding or Out of Adjustment. Pumping imbalance between pumping plungers. | Engine will not run or possible low power.
ISL9 CM2150 SN/ISZ13 CM2150 - High Pressure Pump

Circuit Description

The fuel pump contains two barrel and plunger assemblies; each barrel and plunger assembly utilizes an intake and outlet check valve. Fuel at gear pump pressure is metered through the fuel pump actuator and unseats one of the two intake check valves as the fuel at gear pump pressure enters the pumping chamber. As the pumping plunger begins its upward motion, the pressure in the pumping chamber increases rapidly and the intake check valve is closed. As pressure reaches accumulator pressure, the outlet check valve is opened. As the plunger travels upward, fuel exits past the outlet check valve and pressurizes the fuel rail.

Component Location

The fuel pump is located on the back side of the gear housing. The barrel and plunger and check valve assemblies are part of the fuel pump head sub-assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is set active when a pumping imbalance is detected between the high-pressure plungers inside the fuel pump.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp when the ECM detects that the pumping imbalance has been corrected, and the fault code is set inactive.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Fault Code 281 will most likely come active while operating at a steady state loaded condition. At this condition, commanded fuel pressures are highest and the pump's pressure balance is affected the most.

If a high pressure seal has malfunction, pump head drain flow will be excessive. If a seal malfunction has progressed far enough, the engine may not start because of an inability to develop fuel rail pressure.

If the engine will not start, there are two indications that the pump head has failed (Use the following manual for more troubleshooting information. ISL9 CM2150 SN Service Manual, Bulletin 4022196):

  • The drain flow will be excessive. This can be measured while cranking the engine.
  • The pumping plungers are broken or mechanically stuck. This can be checked by visual inspection.

If the engine oil level is rising due and Fault Code 281 is active, the pump head has malfunction and must be replaced.

Refer to Troubleshooting Fault Code 281.

Last Modified: 28-Oct-2015


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | One or more multiplexed devices will not operate properly.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Circuit
ISF2.8 CM2220 AN - SAE J1939 Multiplexing Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Multiplexing Circuit
ISM11 CM876 SN - Multiplexing Circuit

Circuit Description

Normally, switches, accelerators and other components are connected to the electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

Not Applicable

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 285.

Last Modified: 29-Oct-2015


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Configuration
ISF2.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexing Configuration
ISM11 CM876 SN - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

Not Applicable

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM expects to receive a valid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 286.

Last Modified: 28-Oct-2015


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 287

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 2/19 LAMP: Amber SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The original equipment manufacturer (OEM) vehicle electronic control unit (VECU) detected a fault with its accelerator pedal. | Engine can only idle or engine will not accelerate to full speed.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System Circuit
ISF2.8 CM2220 AN - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System Circuit
ISL9 CM2150 SN - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System Circuit
ISM11 CM876 SN - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the secondary throttle position sensor indicates it is in the idle position.

When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the secondary throttle position sensor indicates it is not in the idle position.

The OEM VECU determines that the accelerator signal wire is shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault can occur when the OEM VECU detects an error on the accelerator. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component.

The three types of errors that can occur for this fault are:

  • When the accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the idle validation switch indicates it is in the idle position. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • The OEM VECU determines that the accelerator signal line is shorted high or shorted low.

It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® ECM, for other components, or the accelerator and idle validation switch, or if the data link is damaged. The OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. Use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 287.

Last Modified: 29-Oct-2015


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | The engine will not respond to the remote throttle. Engine could possibly only idle. The primary or cab accelerator could possibly be able to be used.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever
ISF2.8 CM2220 AN - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever
ISL9 CM2150 SN - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever
ISM11 CM876 SN - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit (ECU) in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM VECU or transmission ECU are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

Not Applicable

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The OEM VECU determines that the remote throttle signal wire is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU. This fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with the INSITE™ electronic service tool.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU. This fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. The INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code 288.

Last Modified: 29-Oct-2015


Proprietary Data Link Error (OEM/Vehicle Data Link) - Abnormal Update Rate

FAULT CODE 291

Proprietary Data Link Error (OEM/Vehicle Data Link) - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 291 PID: SPN: 625 FMI: 9 LAMP: Red SRT: | Proprietary Data Link Error (OEM/Vehicle Data Link) - Abnormal Update Rate. The immobilizer anti-theft system will not operate properly. The engine could possibly not start. | The immobilizer anti-theft system will not operate properly. The engine could possibly not start.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - OEM/Vehicle Data Link Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - OEM/Vehicle Data Link Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISZ13 CM2150 - OEM/Vehicle Data Link Circuit
ISL9 CM2150 SN - OEM/Vehicle Data Link Circuit
ISM11 CM876 SN - OEM/Vehicle Data Link Circuit

Circuit Description

The immobilizer anti-theft device is connected to the primary engine electronic control module (ECM) through a J1939 data link network.

Messages sent from the immobilizer anti-theft device are received by the Cummins® ECM and are used to control the anti-theft features. The Cummins® ECM and immobilizer anti-theft device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and location of OEM installed J1939 devices varies by OEM. The immobilizer anti-theft device is installed by the OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM is not able to communicate with the immobilizer anti-theft system via the J1939 data link.

Action Taken When the Fault Code is Active

The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.

Shop Talk

This fault can occur for the following reasons:

  • When the ECM is set up properly to receive information from an immobilizer anti-theft device, but the immobilizer anti-theft device could possibly not be transmitting the message for that component. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the immobilizer anti-theft device source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the immobilizer anti-theft device is not set up to transmit the multiplexed component message.
  • This fault can be caused by a malfunctioning J1939 data link connection between the immobilizer anti-theft device and Cummins® ECM, a malfunctioning connection between the component and the immobilizer anti-theft device, malfunctioning immobilizer anti-theft device or malfunctioning Cummins® ECM. It could be necessary to contact the OEM for proper multiplexing configuration.
Refer to Troubleshooting Fault Code 291.

Last Modified: 28-Oct-2015


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | Barometric Pressure - Data Erratic, Intermittent, or Incorrect. An error in the barometric pressure sensor signal was detected by the ECM. | Engine power derate.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Barometric Pressure Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISZ13 CM2150 - Barometric Pressure Circuit
ISL9 CM2150 SN/ISM11 CM876 SN - Barometric Pressure Circuit

Circuit Description

The barometric air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation where the engine is presently operating. The barometric air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the barometric air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The barometric air pressure sensor provides a signal to the ECM on the barometric air pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness, near the ECM.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. One part runs when the keyswitch is initially turned on before the engine is started.

The other part runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the barometric pressure reading is higher or lower than the other absolute pressure sensors on the engine, or an in-range malfunction of the sensor has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value is used for the barometric pressure reading.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range barometric pressure sensor reading
  • High resistance in the barometric pressure sensor signal or return lines.
Refer to Troubleshooting Fault Code 295.

Last Modified: 29-Oct-2015


Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 311

Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 PID: S001 SPN: 651 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 1 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length; one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code 311.

Last Modified: 06-Sep-2009


Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 312

Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 PID: S0274 SPN: 655 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 5 when the voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length; one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code 312.

Last Modified: 06-Sep-2009


Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 313

Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 PID: S003 SPN: 653 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 3 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length; one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code 313.

Last Modified: 06-Sep-2009


Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 314

Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 PID: S006 SPN: 656 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 6 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length; one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code 314.

Last Modified: 06-Sep-2009


Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 315

Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 PID: S002 SPN: 652 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 2 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length; one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code 315.

Last Modified: 06-Sep-2009


Real-Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real-Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Amber (Maintenance Flashout) SRT: | Real-Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect. real-time clock lost power. | None on performance. Data in the ECM will not have accurate time and date information.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Real Time Clock Power Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Real Time Clock Power Circuit
ISM11 CM876 SN - Real Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the electronic control module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real-time clock battery is secured to the engine harness near the ECM.

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the real-time clock battery voltage is 3.3-VDC.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light and/or illuminates the malfunction indicator lamp (MIL) at initial key-on when the diagnostic runs and fails.
  • The real-time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or damaged real-time clock battery, damaged wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code 319.

Last Modified: 28-Oct-2015


Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 321

Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 PID: S004 SPN: 654 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 4 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM11 CM876 - Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length; one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to voltage source in the engine harness.
  • Short circuit to ground in the engine harness or injector.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code 321.

Last Modified: 06-Sep-2009


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S006 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 1 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - Injector Solenoid Driver Cylinder 1 Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Solenoid Driver Cylinder 1 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Cylinder 1 Circuit (4 and 6 Cylinder)
ISL9 CM 2150 SN - Injector Solenoid Driver Cylinder 1 Circuit
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 1 Circuit
ISZ13 CM2150 - Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside the ECM. The injectors for cylinder numbers 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinder numbers 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinder(s).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 322.

Last Modified: 29-Oct-2015


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 5 when voltage is turned off. | Current to the injector is shut off. The engine can possibly misfire or run rough.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Cylinder 5 Circuit
ISL9 CM2150 SN - Injector Solenoid Driver Cylinder 5 Circuit
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 5 Circuit
ISZ13 CM2150 - Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault code will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injector event for the cylinder(s) that is malfunctioning.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-323.

Last Modified: 29-Oct-2015


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S006 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. Current detected at injector Number 3 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - Injector Solenoid Driver Cylinder 3 Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Solenoid Driver Cylinder 3 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Cylinder 3 Circuit (4 cylinder engine)
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Cylinder 3 Circuit (6 cylinder engine)
ISL9 CM2150 SN - Injector Solenoid Driver Cylinder 3 Circuit
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 3 Circuit
ISZ13 CM2150 - Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside the ECM. The injectors for cylinder numbers 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinder numbers 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinder(s).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-324.

Last Modified: 29-Oct-2015


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: p0206 SPN: 656 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 6 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Cylinder 6 Circuit
ISL9 CM2150 SN - Injector Solenoid Driver Cylinder 6 Circuit
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 6 Circuit
ISZ13 CM2150 - Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return to two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that are faulty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled from the malfunctioning cylinder

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-325.

Last Modified: 29-Oct-2015


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S006 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 2 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM 2220 AN - Injector Solenoid Driver Cylinder 2 Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Solenoid Driver Cylinder 2 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Cylinder 2 Circuit (4 cylinder engine)
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Cylinder 2 Circuit (6 cylinder engine)
ISL9 CM2150 SN - Injector Solenoid Driver Cylinder 2 Circuit
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 2 Circuit
ISZ13 CM2150 - Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside the ECM. The injectors for cylinder numbers 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinder numbers 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault code will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinder(s).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and malfunctions.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-331.

Last Modified: 29-Oct-2015


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S006 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 4 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - Injector Solenoid Driver Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Solenoid Driver Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Circuit (4 cylinder engine)
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Solenoid Driver Circuit (6 cylinder engine)
ISL9 CM2150 SN - Injector Solenoid Driver Circuit
ISM11 CM876 SN - Injector Solenoid Driver Cylinder 4 Circuit
ISZ13 CM2150 - Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside the ECM. The injectors for cylinder numbers 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinder numbers 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinder(s).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinders.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

This fault code and the malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-332.

Last Modified: 29-Oct-2015


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P0116 SPN: 110 FMI: 2 LAMP: Amber SRT: | Engine Coolant Temperature - Data Erratic Intermittent or Incorrect. The engine coolant temperature reading is not changed with engine operating conditions. | The ECM will estimate engine coolant temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Coolant Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 SN/ISL9 CM2150 SN - Engine Coolant Temperature Sensor Circuit
ISM11 CM876 SN - Engine Coolant Temperature Sensor Circuit
ISZ13 CM2150 - Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

The engine must be turned off for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

If coolant temperature is found to be higher than intake manifold temperature by a calibratable value, the fault code is logged. The diagnostic also checks to make sure that coolant temperature increases during the first 10 minutes of engine operation. If coolant temperature does not increase by a calibratable value, this fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM will estimate engine coolant temperature.
  • An engine torque derate will be activated after 36 hours of engine operation with the fault code active.
  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM illminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Two different failure modes of the engine coolant temperature sensor can trigger this fault code. The engine must be turned off for period of 8 hours before this diagnostic will run. When the keyswitch is turned ON after an 8 hour cold soak, engine coolant temperature is compared to intake manifold temperature. If coolant temperature is found to be higher than intake manifold temperature by a calibratable value, the fault code is logged. The diagnostic also checks to make sure that coolant temperature increases during the first 10 minutes of engine operation. If coolant temperature does not increase by a calibratable value, this fault code is logged.

Possible causes of this fault code include:

  • Stuck in-range engine coolant temperature sensor.
  • High resistance in the engine coolant temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code 334.

Last Modified: 29-Oct-2015


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S087 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or short to voltage source detected at the idle shutdown vehicle accessory/ignition bus relay circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
ISM11 CM876 SN - Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The electronic control module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by original equipment manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

This idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The idle shutdown relay pulse width modulated (PWM) signal is detected to be at system voltage by the ECM when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded OFF, it records this fault code. This fault code can be caused by:

  • ECM Idle Shutdown feature set up incorrectly.
  • Open circuit in the idle shutdown relay, OEM harness, or connectors.
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code 338.

Last Modified: 06-Sep-2009


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S087 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the idle shutdown vehicle accessory or ignition bus relay circuit when commanded. on. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
ISM11 CM876 SN - Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The electronic control module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by original equipment manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine the grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The idle shutdown relay pulse width modulated (PWM) signal is detected by the ECM to be at 0-VDC when the PWM voltage is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded on. This fault code can be caused by a short circuit to ground in the idle shutdown relay, OEM harness, or connectors.

Refer to Troubleshooting Fault Code 339.

Last Modified: 06-Sep-2009


Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
ISF2.8 CM2220/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Unswitched Battery Supply
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Unswitched Battery Supply
ISM11 CM876 SN - Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If the unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343.

Last Modified: 28-Oct-2015


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: 253 SPN: 630 FMI: 12 LAMP: Amber SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. Invalid switch configuration adjustable parameter setting have been detected by the engine control module (ECM). | Various optional switch inputs to the ECM may not operate correctly.
Engine Control Module (ECM)

Circuit Description

The accelerator interlock switch and powertrain protection torque limit switch, clutch pedal position switch and engine protection shutdown manual override switch, idle shutdown accessory relay and engine brake lamp output, switched maximum engine operating speed and governor type switch are all outputs or switched inputs from the ECM that can be enabled or disabled using INSITE™ electronic service tool. Many of the outputs and switched inputs share a common wire on the OEM wiring harness. The following features share common wires in the OEM harness:

  • Accelerator Interlock Switch and Powertrain Protection Torque Limit Switch
  • Clutch Pedal Position Switch and Engine Protection Shutdown Manual Override Switch
  • Idle Shutdown Accessory Relay and Engine Brake Lamp Output
  • Switched Maximum Engine Operating Speed and Governor Type Switch

Component Location

The output or switched inputs to this diagnostic are found in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON only.

Conditions for Setting the Fault Codes

The ECM detects that features that share a common OEM harness input or output to the ECM are simultaneously enabled at the same time.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set. The features that are in conflict may not operate correctly.

Conditions for Clearing the Fault Code

The fault code will be set inactive at key on when the conflicting features have been adjusted correctly.

Shop Talk

Many of the outputs and switched inputs share a common wire on the OEM wiring harness. If two features that share a common OEM wire are enabled simultaneously in the ECM, this fault code will be logged. To disable the fault code, disable one of the features on the shared OEM wire. For example, if the accelerator interlock switch and powertrain protection torque limit switch are both enabled in the ECM, either disable one of the features with INSITE™ electronic service tool or configure one of the features to be multiplexed using the SAE J1939 multiplexing feature.

Refer to Troubleshooting Fault Code 346.

Last Modified: 06-Sep-2009


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 627 FMI: 12/12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible smoke, low power, engine misfire, and/or engine will not start.
ISF2.8 CM2220/ISF2.8 CM2220 AN - Injector Power Supply Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Power Supply Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Power Supply Circuit (4 cylinder engine)
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Power Supply Circuit (6 cylinder engine)
ISL9 CM2150 SN - Injector Power Supply Circuit
ISM11 CM876 SN - Injector Power Supply Circuit
ISZ13 CM2150 - Injector Power Supply Circuit

Circuit Description

Between each injection event, the electronic control module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm, the primary engine speed sensor signal is present, and the battery charge is above a minimum threshold.

Conditions for Setting the Fault Codes

The ECM detects that the measured injector power supply voltage is lower than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the measured injector power supply voltage reaches the commanded injector power supply voltage and the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • The inactive fault code will be cleared from memory after the completion of 40 warm-up cycles.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

This fault code will become active when the engine is running, the primary engine speed sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned on.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351.

Last Modified: 28-Oct-2015


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Engine power derate.
ISF2.8 CM2220 EC - Sensor Supply 1 Circuit
ISF2.8 CM2220/ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Sensor Supply 1 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Sensor Supply 1 Circuit
ISM11 CM876 SN - Sensor Supply 1 Circuit
ISZ13 CM2150 - Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 volt supply for multiple engine sensors.

Component Location

Sensor supply number 1 is located in the ECM engine harness connector and provides a 5 volt supply to various sensors. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is less than 4.75-VDC for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-352.

Last Modified: 27-Oct-2015


Engine Intake Air Mass Flow Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 356

Engine Intake Air Mass Flow Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 356 PID: SPN: 132 FMI: 3/3 LAMP: Amber SRT: | Engine Intake Air Mass Flow Sensor Circuit - Voltage Above Normal or Shorted to High Source. Mass air flow sensor reading is above the allowable maximum value. | Possible reduced engine performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Intake Air Mass Flow Sensor Circuit

Circuit Description

The mass air flow sensor is a frequency based device. A constant voltage is applied to a heated wire. This wire is positioned in the air stream and is heated by the electrical current that the voltage produces. As air flows across it, it cools down. The heated wire or film is a positive temperature coefficient (ptc) resistor. This means that the resistance drops when the temperature drops. The drop in resistance allows more current to flow through the wire in order to maintain the programmed temperature. This current is changed to a frequency which is sent to the engine control module (ECM) and interpreted as air flow. Adjustments for air temperature and humidity are taken into consideration since they also affect the temperature of the heated wire or film. The mass air flow sensor receives a 12 volt power supply from the ECM.

Component Location

The mass air flow sensor is located in the air box of the intake system.

Conditions for Running the Diagnostics

This diagnostic consists of two parts, an engine off and an engine running portion. The engine off portion runs only at initial key ON. The engine running portion runs when the EGR valve is commanded closed, and compares an estimated charge air flow value to the mass air flow sensor reading.

Conditions for Setting the Fault Codes

This diagnostic sets if the mass air flow sensor reports a value higher than what is allowable for the sensor at key ON, or when the engine is operating with the EGR valve closed.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The mass air flow sensor can not be cleaned or serviced, and must be replaced if contaminated or damaged.

Possible causes of this fault include:

  • Mass air flow sensor malfunction
  • ECM malfunction
  • Mass air flow sensor return circuit open
  • Signal circuit shorted to voltage in harness or sensor
  • Intermittent fault condition.
Refer to Troubleshooting Fault Code t05-356.

Last Modified: 26-Apr-2012


Engine Intake Air Mass Flow Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 357

Engine Intake Air Mass Flow Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 357 PID: 132 SPN: 132 FMI: 4/4 LAMP: Amber SRT: | Engine Intake Air Mass Flow Circuit - Voltage Below Normal or Shorted to Low Source. Mass air flow sensor reading is below the allowable minimum value. | Possible reduced engine performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Intake Air Mass Flow Sensor Circuit

Circuit Description

The mass air flow sensor is a frequency based device. A constant voltage is applied to a heated wire. This wire is positioned in the air stream and is heated by the electrical current that the voltage produces. As air flows across it, it cools down. The heated wire or film is a positive temperature coefficient (ptc) resistor. This means that the resistance drops when the temperature drops. The drop in resistance allows more current to flow through it in order to maintain the programmed temperature. This current is changed to a frequency which is sent to the ECM and interpreted as air flow. Adjustments for air temperature and humidity are taken into consideration since they also affect the temperature of the heated wire or film. The mass air flow sensor receives a 12 volt power supply from the ECM.

Component Location

The mass air flow sensor is located in the air box of the intake system.

Conditions for Running the Diagnostics

This diagnosic consists of two parts, an engine off and an engine running portion. The engine off portion runs only at initial key ON. The engine running portion runs when the EGR valve is commanded closed, and compares an estimated charge air flow value to the mass air flow sensor reading.

Conditions for Setting the Fault Codes

This diagnostic sets if the mass air flow sensor reports a value lower than what is allowable for the sensor at key ON, or when the engine is running with the EGR valve closed.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The mass air flow sensor can not be cleaned or serviced, and must be replaced if contaminated or damaged.

Possible causes of this fault include:

  • Mass air flow sensor malfunction
  • ECM malfunction
  • Sensor supply circuit open or shorted to ground in harness or sensor
  • Signal circuit open or shorted to ground in harness or sensor
  • Intermittent fault condition.
Refer to Troubleshooting Fault Code 357.

Last Modified: 30-Apr-2012


Engine Intake Air Mass Flow Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 358

Engine Intake Air Mass Flow Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 358 PID: S254 SPN: 132 FMI: 2/2 LAMP: Amber SRT: | Engine Intake Air Mass Flow Circuit - Data Erratic, Intermittent, or Incorrect. Mass air flow sensor reading does not match engine operating conditions. | Possible reduced engine performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Intake Air Mass Flow Circuit

Circuit Description

The mass air flow sensor is a frequency based device. A constant voltage is applied to a heated wire. This wire is positioned in the air stream and is heated by the electrical current that the voltage produces. As air flows across it, it cools down. The heated wire or film is a positive temperature coefficient (ptc) resistor. This means that the resistance drops when the temperature drops. The drop in resistance allows more current to flow through it, in order to maintain the programmed temperature. This current is changed to a frequency which is sent to the engine control module (ECM) and interpreted as air flow. Adjustments for air temperature and humidity are taken into consideration since they also affect the temperature of the heated wire or film. The mass air flow sensor receives a 12 volt power supply from the ECM.

Component Location

The mass air flow sensor is located in the air box of the intake system.

Conditions for Running the Diagnostics

This diagnostic consists of two parts, an engine off and an engine running portion. The engine off portion runs only at initial key ON. The engine running portion runs when the exhaust gas recirculation (EGR) valve is commanded closed and compares an estimated charge air flow value to the mass air flow sensor reading.

Conditions for Setting the Fault Codes

This diagnostic sets if the mass air flow sensor reports a value higher or lower than is expected for the operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The mass air flow sensor can not be cleaned or serviced, and must be replaced if contaminated or damaged.

When Fault Code 358 is active, the sensor reading will go to a default value about 1300 lbs/hr. If the sensor reading is above 1300 lbs/hr, the issue is not with the sensor circuit.

Possible causes of this fault include:

  • Mass air flow sensor malfunction
  • Mass air flow sensor contamination
  • Air filter restriction
  • Engine wiring harness or connection malfunction
  • Air leak in the intake system.
Refer to Troubleshooting Fault Code t05-358.

Last Modified: 14-Aug-2015


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Engine power derate.
ISF2.8 CM2220 EC - Sensor Supply 1 Circuit
ISF2.8 CM2220/ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Sensor Supply 1 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Sensor Supply 1 Circuit
ISM11 CM876 SN - Sensor Supply 1 Circuit
ISZ13 CM2150 - Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 volt supply for the barometric pressure sensor, fuel rail pressure sensor, intake manifold temperature/pressure combination sensor, and camshaft speed/position sensor.

Component Location

Sensor supply number 1 is located in the ECM engine harness connector and provides a 5 volt supply to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Low voltage on the 5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-386.

Last Modified: 28-Oct-2015


Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate is increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
ISF2.8 CM2220/ISF2.8 CM2220 EC /ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Oil Rifle Pressure Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Engine Oil Rifle Pressure Circuit
ISM11 CM876 SN - Engine Oil Rifle Pressure Circuit
ISZ13 CM2150 - Engine Oil Rifle Pressure Circuit

Circuit Description

The engine oil pressure switch is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the switch will open and cause Fault Code 415 to log.

The oil pressure switch is normally closed when the engine is not running and open when oil pressure is present.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is below minimum operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM limiting the power output of the engine.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure switch
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code 415.

Last Modified: 27-Oct-2015


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible loss of power, or hard starting.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF3.8 CM2220/ISF3.8 CM2220 AN - Water-in-Fuel Indicator
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Water-in-Fuel Indicator
ISM11 CM876 SN - Water-in-Fuel Indicator

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that water in the fuel filter is above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the flashing amber MAINTENANCE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the flashing amber MAINTENANCE light and the fault code will go inactive immediately after the water has been drained from the fuel filter.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 418.

Last Modified: 27-Oct-2015


Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 425

Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 425 PID: P175 SPN: 612 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect. | None on performance. The engine oil temperature is erratic.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the oil temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 10 hours before this part of the diagnostic will run.
  • The second part occurs when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature is higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) after the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 10 hours. After the 10 hour cold soak, start the engine and let it idle for up to 5 minutes.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning oil temperature sensor.
  • High resistance in the engine oil temperature signal or return circuit.
Refer to Troubleshooting Fault Code 425.

Last Modified: 10-Feb-2010


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Communication between the engine control module (ECM) and another device on the Society of Automotive Engineers (SAE) J1939 data link has been lost. | None on performance.
SAE J1939 Data Link Circuit

Circuit Description

Devices such as ABS controllers, auto shift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) (VECUs) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by original equipment manufacture (OEM) options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected a loss of communication with the OEM VECU.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault occurs when the ECM starts communicating with any other device using the SAE J1939 data link and then can no longer transmit on the data link. Possible causes could be the following: Unplugging an electronic service tool before keying off the ECM, the SAE J1939 data link having an intermittent electrical problem, and the ECM (or another SAE J1939 device) tying up communications because of an electrical problem or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code 426.

Last Modified: 12-Jun-2017


SAE J1939 Data Link - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Data Link - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | J1939 Data Link - Abnormal Update Rate. Communication between the electronic control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine speed will ramp down and remain at idle.
SAE J1939 Data Link Circuit

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) (VECUs) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1second. The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • The external OEM controlling device has malfunctioned or can no longer transmit on the data link.
Refer to Troubleshooting Fault Code 427.

Last Modified: 03-Feb-2010


Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Water-in-Fuel Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Water-in-Fuel Sensor Circuit
ISM11 CM876 SN - SAE J1939 Data Link Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor then pulls the 5 volt reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the water-in-fuel sensor signal voltage is above 4.95-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 428.

Last Modified: 27-Oct-2015


Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Water-in-Fuel Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Water-in-Fuel Sensor Circuit
ISM11 CM876 SN - Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor then pulls the 5 volt reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the water-in-fuel sensor signal voltage is below 0.05-VDC for 1second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-429.

Last Modified: 27-Oct-2015


Fault Code Path Selection

FAULT CODE 120-fc435
Fault Code Path Selection

Does the engine use an engine oil pressure sensor? | Go to 120-fc435sensor
Does the engine use an engine oil pressure switch? | Go to 120-fc435switch

Last Modified: 11-Jan-2010


Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 436

Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 436 PID: 111 SPN: 105 FMI: 2 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect. The intake manifold temperature sensor is reading an erratic value at initial key ON or while the engine is running. | The ECM will estimate engine intake manifold temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Manifold 1 Temperature/Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Temperature/Pressure Sensor Circuit
ISM11 CM876 SN - Intake Manifold 1 Temperature/Pressure Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the electronic control module (ECM) for the engine protection system and engine emission control. The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage, or a low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 8 hours before this part of the diagnostic will run. The second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine intake manifold temperature sensor reading is higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM will estimate engine intake manifold temperature.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 8 hours. After the 8 hour cold soak, turn the key to the ON position but do not start the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine intake manifold temperature sensor.
  • High resistance in the engine intake manifold temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-436.

Last Modified: 29-Oct-2015


Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine could stop running or be difficult to start.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Unswitched Battery Supply Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Unswitched Battery Supply Circuit
ISM11 CM876 SN - Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for the battery location.

Not applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is less than 6-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code and illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the fault code and amber CHECK ENGINE light, and the fault code will go inactive immediately after the battery voltage is above 6-VDC
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the ECM battery supply voltage drops below 6-VDC.

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code 441.

Last Modified: 28-Oct-2015


Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
ISF2.8 CM2220/ISF2.8 CM2220 EC /ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Unswitched Battery Supply Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Unswitched Battery Supply Circuit
ISM11 CM876 SN - Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wire to protect the original equipment manufacturers (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual for battery location.

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is greater than +36-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code and illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the fault code and amber CHECK ENGINE light, and the fault code will go inactive immediately after the battery voltage drops below +36-VDC.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the ECM battery supply voltage exceeds +36-VDC. Causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code 442.

Last Modified: 27-Oct-2015


Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: SPN: 157 FMI: 0 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the fuel rail is higher than the normal operating fuel system pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power derate.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Metering Rail 1 Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Injector Metering Rail 1 Pressure Sensor Circuit
ISZ13 CM2150 - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) monitors engine-operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure relief valve is located on the fuel rail. The fuel pump actuator is located on the engine-mounted fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure has been above the maximum pressure allowed by the fuel pressure relief valve.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails. Power derate can occur on some engines.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute. The fault code will go inactive once the fuel rail pressure returns to normal operatiing levels.
  • The ECM will turn off the amber CHECK ENGINE light immediately after diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Fault Code 449 is not used to indicate a fuel pressure relief valve opening. It is used to indicate a fuel pressure relief valve that fails to open or does not regulate pressure. Troubleshooting must be focused on inspecting the drain line path of the fuel pressure relief valve for restrictions/obstructions and checking or replacing the fuel pressure relief valve. A restriction in the fuel-drain-to-tank return line can prevent unneeded fuel from exiting the fuel system. Check the fuel drain line restriction from the fuel rail to the tank for damage.

Refer to Troubleshooting Fault Code 449.

Last Modified: 28-Oct-2015


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the rail fuel pressure sensor circuit. | Power and/or speed derate.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Metering Rail 1 Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Injector Metering Rail 1 Pressure Sensor Circuit
ISZ13 CM2150 - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel rail. The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor, using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at high rail pressures. The ECM will detect a high signal voltage during low rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the fuel rail pressure signal voltage is greater than a calibratible value for more than 1 second. This fault code will become active if there is an open circuit on any of the three pins 5 volt supply, signal, or return that connect the fuel rail pressure sensor or ECM to the wiring harness.

This fault will also be active if the signal wire is shorted to a source of voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with an airless SCR aftertreatment system:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

  • Voltage 5-VDC or higher shorted to the signal wire
  • Open circuit on the signal wire
  • Open circuit on the 5-VDC supply wire
  • Open circuit on the return wire
  • Malfunctioning sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 451.

Last Modified: 29-Oct-2015


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the rail fuel pressure sensor circuit. | Power and/or speed derate.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Metering Rail 1 Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ ISL9 CM2150 SN - Injector Metering Rail 1 Pressure Sensor Circuit
ISZ13 CM2150 - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel rail. The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a low signal voltage at high rail pressures. The ECM will detect a high signal voltage during low rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the fuel rail pressure signal voltage is less than a calibratible value for more than 1 second. This can be caused by a short circuit to ground on the 5-VDC supply or signal wire.

This fault will also become active if a device that is powered by the common 5 volt power supply is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque can possibly be reduced.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with an airless SCR aftertreatment system:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

  • Engine harness; the supply or signal wire is shorted to ground
  • Other components; any component connected to the common power supply is shorted to ground
  • Malfunctioning sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 452.

Last Modified: 29-Oct-2015


Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 465

Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 465 PID: S32 SPN: 1188 FMI: 3 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source. High Voltage deteced at Turbocharger 1 Wastegate Control Circuit. | Engine will run derated.
ISM11 CM876 SN - Turbocharger Control Valve Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The turbocharger 1 wastegate control signal is detected to be at system voltage when the voltage is turned off.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the harness
  • An open circuit in the harness, connector, or wastegaste control valve
Refer to Troubleshooting Fault Code 465.

Last Modified: 07-Sep-2009


Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 466

Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 466 PID: S32 SPN: 1188 FMI: 4 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage (short to ground) detected at the ECM. Low Voltage detected at Turbocharger 1 Wastegate Control Circuit. | Engine will run derated
ISM11 CM876 SN - Turbocharger Control Valve Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The turbocharger 1 wastegate control signal is not detected to be system voltage when the signal is turned ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Signal short circuit to ground.
Refer to Troubleshooting Fault Code 466.

Last Modified: 07-Sep-2009


Engine Oil Level - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 471

Engine Oil Level - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 471 PID: SPN: 98 FMI: 17 LAMP: Maintenance SRT: | Engine Oil Level - Data Valid but Below Normal Operating Range - Least Severe Level. Low oil level has been detected by the oil level sensor. | The engine may derate. Possible low oil pressure, possible severe engine damage.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Engine Oil Level Sensor Circuit

Circuit Description

An algorithm in the electronic control module (ECM) calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level falls below a certain threshold, the ECM will activate Fault Code 471, as well as the maintenance lamp. The maintenance lamp will flash only during a key-on event.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine speed is 0 rpm.

Conditions for Setting the Fault Codes

The engine oil level is detected to be low at key-on.

Action Taken When the Fault Code is Active

  • The amber CHECK ENGINE light will flash for 30 seconds when the keyswitch is turned on.

Conditions for Clearing the Fault Code

  • The amber CHECK ENGINE light will stop flashing at key-on and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If inactive counts of Fault Code 471 are logged in the ECM, it can be possible that the engine was running or keyed on while tilted at an angle severe enough to cause this fault to be triggered.

Other causes of Fault Code 471 can include:

  • The engine was not filled to proper capacity during the most recent oil change
  • External engine oil leaks
  • Internal engine oil leaks (oil leaking into the fuel system or cooling system)
  • High engine oil consumption/power cylinder malfunction (check for abnormally high blowby when the engine is loaded).
Refer to Troublshooting Fault Code 471.

Last Modified: 29-Nov-2010


Battery 2 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P444 SPN: 444 FMI: 1/18 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level. The voltage supply to the diesel exhaust fluid controller is lower than the electrical system voltage. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Battery 2 Voltage Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller communicates with the ECM and controls the heating, dosing, and purging of the aftertreatment diesel exhaust fluid system.

Component Location

The aftertreatment diesel exhaust fluid controller is installed on the vehicle by the OEM. Refer to the OEM Service Manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the battery supply voltage is lower than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes
  • The ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Improper battery voltage setting in INSITE™ electronic service tool
  • A damaged alternator causing low voltage
  • A weak or damaged battery.
Refer to Troubleshooting Fault Code 477.

Last Modified: 24-Apr-2012


Battery 2 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P444 SPN: 444 FMI: 0/16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level. The voltage supply to the diesel exhaust fluid controller is higher than the electrical system voltage. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN Battery 2 Voltage Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller communicates with the ECM and controls the heating, dosing, and purging of the aftertreatment diesel exhaust fluid system.

Component Location

The aftertreatment diesel exhaust fluid controller is installed on the vehicle by the OEM. Refer to the OEM Service Manual for component location.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The aftertreatment diesel exhaust fluid controller detects the battery supply voltage is greater than a threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs a passes.

The ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Improper battery voltage setting in INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code 478.

Last Modified: 24-Apr-2012


Turbocharger 2 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 491

Turbocharger 2 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 491 PID: S088 SPN: 1189 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 2 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source. High Voltage detected at Turbocharger 2 Wastegate Control Circuit. | Engine will run derated.
ISM11 CM876 SN - Turbocharger 2 Wastegate Control Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The turbocharger 2 wastegate control signal is detected to be at system voltage when the voltage is turned off.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the harness
  • An open circuit in the harness, connector, or wastegaste control valve.
Refer to Troubleshooting Fault Code 491.

Last Modified: 24-Jun-2010


Turbocharger 2 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 492

Turbocharger 2 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 492 PID: S088 SPN: 1189 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 2 Wastegate Control Circuit - Voltage below normal, or shorted to low source. Low Voltage detected at Turbocharger 2 Wastegate Control Circuit | Engine will run derated.
ISM11 CM876 SN - Turbocharger 2 Wastegate Control Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The turbocharger 2 wastegate control signal is not detected to be system voltage when the signal is turned on.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the harness.
Refer to Troubleshooting Fault Code 492.

Last Modified: 24-Jun-2010


Engine Oil Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 498

Engine Oil Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 498 PID: P98 SPN: 98 FMI: 3 LAMP: Amber SRT: | Engine Oil Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. The engine oil level sensor has detected an internal failure. | Engine oil level sensor operation will be disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Oil Level Sensor Circuit

Circuit Description

The oil level sensor will monitor the oil fluid level in the oil pan at key-on. The oil level sensor will not monitor the oil level after the engine is started or when the engine speed is greater than 0 rpm. During the engine key-on, if the oil level sensor detects a critical low oil level, the amber CHECK ENGINE light will blink for 30 seconds and a fault code will be logged. If an operator observes a blinking amber CHECK ENGINE light at key-on, the operator must check the engine oil level with the manual dipstick.

The oil level sensor provides the electronic control module (ECM) with a pulse width modulated (PWM) signal. Within this signal, the oil level sensor transmits the engine oil level reading, oil temperature, and fault code information from the oil level sensor.

Component Location

The oil level sensor is located on the left side of the engine on the front oil dipstick port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects a short circuit to battery on the signal circuit or an open return circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The oil level sensor operation will be disabled.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE light and enable oil level sensor operation immediately after a valid PWM signal is received from the oil level sensor.
  • The inactive fault code can then be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code 498.

Last Modified: 07-Sep-2009


Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 499

Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 499 PID: P98 SPN: 98 FMI: 4 LAMP: Amber SRT: | Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The engine oil level sensor has detected an internal failure. | Oil level sensor operation will be disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Oil Level Sensor Circuit

Circuit Description

The oil level sensor will monitor the oil fluid level in the oil pan at key-on. The oil level sensor will not monitor the oil level after the engine is started or when the engine speed is greater than 0 rpm. During the engine key-on, if the oil level sensor detects a critical low oil level, the amber CHECK ENGINE light will blink for 30 seconds and a fault code will be logged. If an operator observes a blinking amber CHECK ENGINE light at key-on, the operator must check the engine oil level with the manual dipstick.

The oil level sensor provides the electronic control module (ECM) with a pulse width modulated (PWM) signal. Within this signal, the oil level sensor transmits the engine oil level reading, oil temperature, and fault code information from the oil level sensor.

Component Location

The oil level sensor is located on the left side of the engine on the front oil dipstick port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The oil level sensor has detected an internal short or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The oil level sensor operation will be disabled.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE light and enable oil level sensor operation immediately after a valid PWM signal is received from the oil level sensor.
  • The inactive fault code can then be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit internally to the oil level sensor
  • A malfunctioned oil level sensor.
Refer to Troubleshooting Fault Code 499.

Last Modified: 07-Sep-2009


Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 527

Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: SPN: 702 FMI: 3 LAMP: Amber SRT: | Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source. The auxiliary input/output SIGNAL pin of the engine harness indicates an open or short circuit. | No action taken by engine control module (ECM).
Auxiliary Input/Output 2 Circuit - ISF2.8 3.8 CM2220

Circuit Description

The ECM provides a signal to the original equipment manufacturer (OEM) output control circuit to turn the OEM supplied accessory on and off. The OEM output control circuit varies by OEM. Certain OEMs can use a circuit return that is wired to the ECM or goes to the engine block or chassis ground.

Component Location

The output control circuit driver is an OEM device and the location of the circuit driver is dependant upon the OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately 0-VDC. If it detects a high voltage, this fault is recorded. If Fault Code 527 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the OEM output device for an open circuit or short to ground.

Possible causes of this fault include:

  • Open circuit in the engine harness or OEM output control solenoid
  • Short circuit to voltage source in the OEM harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-527.

Last Modified: 17-Jan-2014


Turbocharger 1 Wastegate Control - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 545

Turbocharger 1 Wastegate Control - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 545 PID: SPN: 1188 FMI: 7 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control - Mechanical System Not Responding or Out of Adjustment. The intake manifold pressure has exceeded the maximum limit for the given engine rating. | Engine power derate.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Turbocharger 1 Wastegate Control Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Turbocharger 1 Wastegate Control Circuit
ISM11 CM876 SN - Turbocharger 1 Wastegate Control Circuit

Circuit Description

The intake manifold pressure sensor is used by the engine control module (ECM) to monitor the engine intake manifold pressure.

Component Location

Not Applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code becomes active when the intake manifold pressure exceeds the maximum pressure limit for a given engine rating.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes:

  • Malfunctioning turbocharger wastegate
  • Wastegate tampering
  • Wrong turbocharger part
  • Possible tampering of the fuel system or turbocharger system.
Refer to Troubleshooting Fault Code 545.

Last Modified: 27-Oct-2015


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: 157 SPN: 157 FMI: 16 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The electronic control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load). Engine power is reduced.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Metering Rail 1 Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Injector Metering Rail 1 Pressure Sensor Circuit
ISZ13 CM2150 - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (Open the fuel pump actuator) or decrease (Close the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed in the adapter on the back of the high-pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the fuel rail pressure reading has exceeded the recommended operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

If the fuel pump actuator exhibits excessive leakage, it is possible that the fuel rail pressure will reach the opening pressure of the fuel rail pressure relief valve and Fault Code 1911 could possibly become active.

The fuel rail pressure sensor can also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it could be necessary to manually relieve the pressure from the high-pressure fuel rail.

Refer to Troubleshooting Fault Code 553.

Last Modified: 29-Oct-2015


Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 554

Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: PID: 554 SPN: 157 FMI: 2 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the fuel pressure signal is not changing. | The ECM will estimate the fuel pressure and power is reduced.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Metering Rail 1 Pressure Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Injector Metering Rail 1 Pressure Sensor Circuit
ISZ13 CM2150 - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor contains supply, signal, and return pins. The engine control module (ECM) provides 5 volt to the fuel pressure sensor. This 5 volts power supply is a shared supply. Other sensors on this circuit are the intake manifold temperature/pressure sensor, barometric air pressure sensor, and the backup engine position sensor.

Component Location

The fuel pressure sensor is located in the rail fuel on the air intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the fuel rail pressure reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails. Power derate could occur on some engines. A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code can become active any time the engine is loaded and the ECM detects the fuel pressure in the rail fuel is not changing. This fault code will become inactive when the ECM is powered down or if the ECM detects that the engine is loaded and the fuel pressure is changing normally. If there are many inactive counts of this fault code or if the fault is not repeatable, look for signs of tampering to the fuel pressure sensor circuit.

If the fault code occurs intermittently (can not be reproduced during a road test), then inspect each of the following for poor connections or damage:

  • Intake manifold temperature/pressure sensor
  • Backup engine position sensor
  • Fuel pressure sensor
  • Barometric air pressure sensor.
Refer to Troubleshooting Fault Code 554.

Last Modified: 28-Oct-2015


Crankcase Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 16/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. The crankcase breather filter requires maintenance. | None on performance.
ISM11 CM876 SN - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase filter is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light when the crankcase pressure limit is exceeded.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Crankcase pressure sensor damage
  • Malfunctioning crankcase breather filter heater, if equipped
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures.

Refer to Troubleshooting Fault Code 555.

Last Modified: 14-Mar-2017


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The crankcase breather filter requires maintenance. | None on performance.
ISM11 CM876 SN - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp when the crankcase pressure limit is exceeded.
  • The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning crankcase breather filter heater, if equipped
  • Crankcase breather filter needs to be replaced
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures.

Refer to Troubleshooting Fault Code 556.

Last Modified: 14-Mar-2017


Fault Code Path Selection

FAULT CODE 120-fc559
Fault Code Path Selection

Is the engine an ISB, ISC, or ISF? | Go to 120-fc559bdf
Is the engine an ISC, ISL, ISX, or ISZ? | Go to 120-fc559clxz

Last Modified: 23-Oct-2009


Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Starter Relay Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Starter Relay Circuit
ISM11 CM876 SN - Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It could be wired back to the ECM on some vehicles, or wired to chassis or block ground on others. Refer to the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for exact location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostic could also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code 584.

Last Modified: 28-Oct-2015


Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S039 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Starter Relay Driver Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Starter Relay Driver Circuit
ISM11 CM876 SN - Starter Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It could be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Refer to the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM troubleshooting and repair manual for exact location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostics could also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The starter lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded on, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Refer to Troubleshooting Fault Code 585.

Last Modified: 28-Oct-2015


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. High battery voltage detected by the battery voltage monitor feature. | Amber warning lamp illuminated until high battery voltage condition is corrected.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - ECM Power Supply Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - ECM Power Supply Circuit
ISM11 CM876 SN - ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is higher than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disable the Alternator Failure Warning feature to disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code 596.

Last Modified: 28-Oct-2015


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low battery voltage detected by the battery voltage monitor feature. | Amber lamp will light until low battery voltage condition is corrected.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - ECM Power Supply Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - ECM Power Supply Circuit
ISM11 CM876 SN - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disable the Alternator Failure Warning feature to disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
  • High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code 597.

Last Modified: 28-Oct-2015


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level. Very low battery voltage detected by the battery voltage monitor feature. | Red lamp illuminated until very low battery voltage condition is corrected.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - ECM Power Supply Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - ECM Power Supply Circuit
ISM11 CM876 SN - ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with each OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than 8-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle the decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disable the Alternator Failure Warning feature to disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code 598.

Last Modified: 28-Oct-2015


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Engine Oil Change Interval - Condition Exists. Change engine oil and filter. | Maintenance reminder only.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Maintenance Reminder
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Maintenance Reminder
ISM11 CM876 SN - Maintenance Reminder

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

For a detailed component location view, refer to the appropriate service manual. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Based on the programmable setting in the Maintenance Monitor feature, the ECM detects the engine oil and filter need to be changed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the maintenance condition is exceeded.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the Maintenance Monitor feature has been reset in INSITE™ electronic service tool.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in INSITE™ electronic service tool. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649.

Last Modified: 27-Oct-2015


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 686

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 686 PID: P103 SPN: 103 FMI: 2/2 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected by the ECM. | None on performance. The ECM uses an estimated turbocharger speed.
ISL9 CM2150 SN - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a turbocharger speed that is greater than the speed that is physically achievable by the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute
  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid turbocharger speed, and the diagnostic runs and passes.

Shop Talk

Usually this fault code indicates a faulty turbocharger speed sensor or incorrect speed signals from the sensor. This fault can be caused by malfunctions in the following components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM power supply or grounds
  • Electronic vehicle accessories which emit excessive electromagnetic interference.

If the fault occurs intermittently:

  • Look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).
  • Look for sources of electronic noise such as poorly installed vehicle electronic components.
  • Be sure that the vehicle chassis grounds are in good condition.
  • Be sure that the ECM power supply and ground circuits are in good condition and that this power supply is not shared with other vehicle electronics.
Refer to Troubleshooting Fault Code 686.

Last Modified: 29-Oct-2015


Turbocharger 1 Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level. Low turbocharger speed detected by the ECM. | Engine power derate. The ECM uses an estimated turbocharger speed.
ISL9 CM2150 SN - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is detected to be less than 600 rpm for more than 1 second when the engine speed is greater than 1200 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after a valid speed signal from the turbocharger speed sensor returns, and the diagnostic runs and passes.

Shop Talk

Items that can cause this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 687.

Last Modified: 30-Oct-2015


Engine Oil Level - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 688

Engine Oil Level - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 688 PID: SPN: 98 FMI: 0 LAMP: Red SRT: | Engine Oil Level - Data Valid but Above Normal Operating Range - Most Severe Level. High oil level has been detected by the oil level sensor. | Possible low power, excessive smoke, oil dilution, contamination, or severe engine damage. The engine may derate.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Engine Oil Level Sensor Circuit

Circuit Description

An algorithm in the electronic control module (ECM) calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level exceeds a certain threshold, the ECM will activate Fault Code 688.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine speed is 0 rpm.

Conditions for Setting the Fault Codes

The engine oil level is detected to be above the normal operating level at key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Causes of this fault code may include:

  • The engine may have been overfilled with oil during the most recent oil change.
  • The fuel system may be leaking into the lubricating oil system. Check for fuel system faults or use fluorescent fuel system dye to identify leaks.
  • The cooling system may be leaking into the lubricating oil system. Check for coolant in the oil.
Refer to Troublshooting Fault Code 688.

Last Modified: 29-Nov-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: 190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Loss of signal from crankshaft sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using backup speed sensor. Engine power is reduced.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Crankshaft Speed/Position Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Crankshaft Speed/Position Circuit
ISM11 CM876 SN - Engine Crankshaft Speed/Position Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor for more than 1second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the crankshaft speed/position sensor.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness
  • Damaged or failed engine speed sensor.
Refer to Troubleshooting Fault Code 689.

Last Modified: 27-Oct-2015


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Engine power derate.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Turbocharger 1 Compressor Intake Temperature Sensor Circuit
ISL9 CM2150 SN - Turbocharger 1 Compressor Intake Temperature Sensor Circuit
ISZ13 CM2150 - Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5 volts to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

Some engines use a combination ambient air temperature/pressure sensor located in the OEM intake air plumbing rather than a turbocharger compressor intake temperature sensor. Refer to the engine wiring diagram to determine which sensor this application uses.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor intake temperature signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness turbocharger compressor intake temperature sensor can be used, depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code 691.

Last Modified: 30-Oct-2015


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at turbocharger compressor intake air temperature circuit. | Engine power derate.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Turbocharger Compressor Intake Air Temperature Sensor Circuit
ISL9 CM2150 - Turbocharger Compressor Intake Air Temperature Sensor Circuit
ISZ13 CM2150 - Turbocharger Compressor Intake Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

Note: Some engines use a combination ambient air pressure/temperature sensor located in the OEM intake air plumbing rather than a turbocharger compressor intake temperature sensor. Refer to the engine wiring diagram to determine which sensor your engine has.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor intake temperature signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately when the diagnostic runs and fails.A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 692, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code 692.

Last Modified: 30-Oct-2015


Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 693

Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 693 PID: P351 SPN: 1172 FMI: 2 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect. A temperature too high or low for the operating conditions has been detected by the turbocharger compressor intake temperature sensor. | A default value will be used for the turbocharger compressor intake temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Turbocharger 1 Compressor Intake Temperature Circuit
ISL9 CM2150 SN - Turbocharger 1 Compressor Intake Temperature Circuit
ISZ13 CM2150 - Turbocharger 1 Compressor Intake Temperature Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5 volts to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

Some engines use a combination ambient air temperature/pressure sensor located in the OEM intake air plumbing rather than a turbocharger compressor intake temperature sensor. Refer to the engine wiring diagram to determine which sensor this application uses.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor intake temperature reading is too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails. A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range compressor intake temperature sensor
  • High resistance in the compressor intake temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code 693.

Last Modified: 29-Oct-2015


ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit is detected at the internal ECM temperature sensor. | None on performance.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Control Module
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Control Module
ISM11 CM876 SN - Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 697.

Last Modified: 27-Oct-2015


ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or an open circuit is detected at the internal ECM temperature sensor. | None on performance.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Control Module (ECM)
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 SM2150 SN/ISZ13 CM2150 - Engine Control Module (ECM)
ISM11 CM876 SN - Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 698.

Last Modified: 28-Oct-2015


ECM Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699

ECM Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 PID: SPN: 1136 FMI: 2 LAMP: Amber SRT: | ECM Temperature - Data Erratic, Intermittent, or Incorrect. An incorrect or inconsistent temperature reading has been detected internal to the electronic control module (ECM). | None on performance.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Control Module (ECM)
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Control Module (ECM)
ISM11 CM876 SN - Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is irrational.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If this fault code is active, the ECM must be replaced.

Refer to the Troubleshooting Fault Code 699.

Last Modified: 27-Oct-2015


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Engine will run derated. Hard start and rough idle is possible.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Magnetic Speed/Position Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Magnetic Speed/Position Circuit
ISM11 CM876 SN - Engine Magnetic Speed/Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a +5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the lobes on the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly
  • Mechanical misalignment.
Refer to Troubleshooting Fault Code 731.

Last Modified: 28-Oct-2015


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: SPN: 723 FMI: 2 LAMP: Amber SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected a loss of signal from the camshaft position sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using primary engine position sensor.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Camshaft Speed/Position Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Camshaft Speed/Position Sensor Circuit
ISM11 CM876 SN - Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the camshaft speed/position sensor for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the crankshaft speed/position sensor.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning camshaft position sensor.
Refer to Troubleshooting Fault Code 778.

Last Modified: 28-Oct-2015


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect. Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
ISM11 CM876 SN - Adaptive Cruise Control Circuit

Circuit Description

The adaptive cruise control unit communicates with the engine control module (ECM) sending and receiving vehicle speed control messages through the SAE J1939 data link.

Component Location

The location of the adaptive cruise control unit will vary by original equipment manufacturer (OEM). Refer to the OEM service manual for specific location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the adaptive cruise control module for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

If Adaptive Cruise Recovery is enabled, the driver can toggle the cruise enable switch from the OFF position to the ON position two times to get regular cruise control to operate, and Fault Code 784 will go inactive. At the next key cycle, if the Heartbeat message is still not present, Fault Code 784 will go active.

Refer to Troubleshooting Fault Code 784.

Last Modified: 25-Apr-2012


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below 6.2 VDC momentarily, or the ECM was not allowed to power down correctly. | Possible no noticeable performance effects, or engine dying, or hard starting. Fault code information, trip information, and maintenance monitor data can be inaccurate.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - ECM Power Supply Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - ECM Power Supply Circuit
ISM11 CM876 SN - ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the original equipment manufacturer (OEM) power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that primary ECM power supply dropped below a calibratible value while the keyswitch was in the ON position. The fault code will be active when the keyswitch is turned on, following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM records the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

To validate the repair, start the engine, let it idle for 1 minute, and shut it down properly. The ECM must see adequate primary ECM battery voltage when the keyswitch is turned OFF before the fault code will go inactive.

For engines equipped with selective catalytic reduction (SCR) aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn OFF the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For on-board diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code are:

  • Battery voltage below 6.2 VDC during cranking
  • High resistance in the ECM supply or return circuit
  • Use of a battery disconnect switch or any device that disconnects battery voltage to the ECM to turn the engine off or before the ECM is completely powered down.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 19-Apr-2017


EGR Valve Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1228

EGR Valve Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1228 PID: P27 SPN: 27 FMI: 2/2 LAMP: Amber SRT: | EGR Valve Position - Data Erratic, Intermittent, or Incorrect. An erratic value is being reported by the EGR valve position sensor, or the EGR valve position is not changing with engine operating conditions. | Possible reduced engine performance. EGR valve will try to close.
ISF2.8 CM2220/ISF2.8 CM2220 EC - EGR Valve Position Circuit

Circuit Description

The engine control module (ECM) uses the exhaust gas recirculation (EGR) valve position sensor to determine whether or not the EGR valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating the valve position. A fully open valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the EGR valve position sensor is reporting an erratic value, or the EGR valve position is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled, and the EGR valve will try to close.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the on position for 1 minute. The EGR valve will perform an auto-zero immediately after key ON.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Intermittent open or short in the wiring harness
  • Malfunctioning EGR valve position sensor
  • Malfunctioning ECM
  • Sticky or broken EGR valve.

NOTE: Do not supply 12 VDC to the EGR valve position sensor, or short the EGR valve motor wires to the EGR valve position sensor. The EGR valve position sensor is rated at 5-VDC, and sensor damage may occur.

Refer to Troubleshooting Fault Code t05-1228.

Last Modified: 26-Apr-2012


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Accelerator Pedal or Lever Position Sensor 2 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Accelerator Pedal or Lever Position Sensor 2 Circuit
ISM11 CM876 SN - Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5-volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5-volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1239.

Last Modified: 29-Oct-2015


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: None SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in the power output of the engine. Limp home power only.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Accelerator Pedal or Lever Position Sensor 2 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Accelerator Pedal or Lever Position Sensor 2 Circuit
ISM11 CM876 SN - Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and passes.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged accelerator pedal position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1241.

Last Modified: 29-Oct-2015


Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P091 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensor number 1 and number 2 are reading different values. | The engine will only idle.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Accelerator Pedal or Lever Position Sensor 1 and 2 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Accelerator Pedal or Lever Position Sensor 1 and 2 Circuit
ISM11 CM876 SN - Accelerator Pedal or Lever Position Sensor 1 and 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the readings between accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.

Possible causes of the fault include:

  • Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2
  • Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.
Refer to Troubleshooting Fault Code 1242.

Last Modified: 29-Oct-2015


Fault Code Path Selection

FAULT CODE 120-fc1668
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc1668air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc1668airless

Last Modified: 27-Apr-2009


Fault Code Path Selection

FAULT CODE 120-fc1669
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc1669air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc1669airless

Last Modified: 27-Apr-2009


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1671

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1671 PID: 203F SPN: 1761 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Moderately Severe Level. Low aftertreatment diesel exhaust fluid level has been detected in the aftertreatment diesel exhaust fluid tank. | None on performance.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Diesel Exhaust Fluid Tank Level Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Diesel Exhaust Fluid Tank Level Sensor Circuit
ISM11 CM876 SN - Diesel Exhaust Fluid Tank Level Sensor Circuit
ISZ13 CM2150 - Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The diesel exhaust fluid tank level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The diesel exhaust fluid tank level sensor is located in the diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Low aftertreatment diesel exhaust fluid level has been detected in the diesel exhaust fluid tank.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Fault code 1671 is triggered when low diesel exhaust fluid level has been detected in the diesel exhaust fluid tank. Add diesel exhaust fluid to the tank. This fault code is only a warning for low diesel exhaust fluid tank solution level.

Refer to Troubleshooting Fault Code 1671.

Last Modified: 27-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: P203F SPN: 1761 FMI: 1 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Most Severe Level. No aftertreatment diesel exhaust fluid has been detected in the aftertreatment diesel exhaust fluid tank. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled. immediate engine power derate.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit
ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The diesel exhaust fluid level sensor is located in the diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The aftertreatment diesel exhaust fluid level sensor has detected that the diesel exhaust fluid tank is empty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) willl start to flash when the diagnostic runs and fails.
  • An engine torque derate will be activated immediately when the fault code becomes active.

Conditions for Clearing the Fault Code

This fault code can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Fault code 1673 is triggered when the diesel exhaust fluid level sensor has detected that the diesel exhaust fluid tank is empty. Diesel exhaust fluid may still be visible inside the tank when this fault code is active. Add diesel exhaust fluid to the tank.

Refer to Troubleshooting Fault Code 1673.

Last Modified: 28-Oct-2015


Fault Code Path Selection

FAULT CODE 120-fc1677
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc1677air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc1677airless

Last Modified: 27-Apr-2009


Fault Code Path Selection

FAULT CODE 120-fc1678
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc1678air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc1678airless

Last Modified: 27-Apr-2009


Fault Code Path Selection

FAULT CODE 120-fc1679
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc1679air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc1679airless

Last Modified: 27-Apr-2009


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component

FAULT CODE 1681

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1681 PID: SPN: 3361 FMI: 12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component. An internal error has been detected in the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit
ISL9 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit communicates to the primary engine electronic control module (ECM) through the J1939 data link network. The aftertreatment diesel exhaust fluid dosing unit precisely measures the amount of aftertreatment diesel exhaust fluid to be injected into the aftertreatment system. The aftertreatment diesel exhaust fluid dosing unit has three primary cycles. A priming cycle at initial key on makes sure that aftertreatment diesel exhaust fluid is available at the aftertreatment diesel exhaust fluid dosing unit. During the dosing cycle, aftertreatment diesel exhaust fluid is being delivered to the aftertreatment dosing valve. A purge cycle occurs when the engine is turned off. The purge cycle makes sure that all the aftertreatment diesel exhaust fluid is removed from the aftertreatment line and dosing valve.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit detects an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Fault code 1681 is triggered when the aftertreatment diesel exhaust fluid dosing unit has detected an internal error.

Refer to Troubleshooting Fault Code 1681.

Last Modified: 28-Oct-2015


Fault Code Path Selection

FAULT CODE 120-fc1682
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc1682air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc1682airless

Last Modified: 08-Sep-2009


Fault Code Path Selection

FAULT CODE 120-fc1683
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc1683air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc1683airless

Last Modified: 27-Apr-2009


Fault Code Path Selection

FAULT CODE 120-fc1684
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc1684air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc1684airless

Last Modified: 27-Apr-2009


Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component

FAULT CODE 1688

Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1688 PID: SPN: 3360 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component. An internal error has been detected in the aftertreatment diesel exhaust fluid controller. | Aftertreatment diesel exhaust fluid dosing will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the selective catalytic reduction (SCR) diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. It communicates to the engine via the electronic control module (ECM) via a J1939 data link connection.

Component Location

The location of the aftertreatment diesel exhaust fluid controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or suitable rigid bracket using three or four capscrews. Refer to the OEM service manual for a more detailed component location description.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

An internal error has been detected in the aftertreatment diesel exhaust fluid controller, and has been communicated to the ECM via the data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when malfunctioning.

Refer to Troubleshooting Fault Code 1688.

Last Modified: 24-Jun-2010


Real Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1689

Real Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1689 PID: SPN: 251 FMI: 2 LAMP: Amber SRT: | Real Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect. The real-time clock power has been interrupted. | None on performance. Data in the ECM will not have accurate time and date information.
ISM11 CM876 SN - Real Time Clock Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the electronic control module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real-time clock battery is secured to the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The real-time clock in the ECM lost power.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light on the second ignition cycle when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault are weak or damaged real-time clock battery, damaged wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code 1689.

Last Modified: 26-Oct-2009


Aftertreatment Outlet NOx Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1692

Aftertreatment Outlet NOx Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1692 PID: SPN: 3234 FMI: 4 LAMP: Amber SRT: | Aftertreatment NOx Sensor - Voltage Below Normal or Shorted to Low Source. Out-of-range battery voltage has been detected by the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled. Engine will derate after operating 50 hours with the fault active.
Circuit: Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Shop Talk

The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually.

Possible causes of this fault code include:

  • The voltage supplied to the aftertreatment outlet NOx sensor is below + 18-VDC
  • The voltage supplied to the aftertreatment outlet NOx sensor is above + 32-VDC
  • The aftertreatment outlet NOx sensor has malfunctioned or is damaged
  • The aftertreatment outlet NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.

On-Board Diagnostics (OBD) information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the MIL after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1692.

Last Modified: 06-Sep-2012


Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1694

Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1694 PID: P2201 SPN: 3226 FMI: 2 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled. Engine torque will be reduced.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Outlet NOx Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Outlet NOx Sensor Circuit
ISM11 CM876 SN - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet mono-nitrogen oxides (NOx) sensor is a smart device that receives commands from the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system at the outlet of the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs only under certain engine operating conditions. Refer to the troubleshooting tree for details on running the diagnostic.

Conditions for Setting the Fault Codes

The ECM has detected that the NOx reading is higher or lower than is possible from the engine output.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails on two consecutive ignition cycles.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • Aftertreatment selective catalytic reduction (SCR) catalyst temperatures must exceed 200°C [392°F].
  • The engine must be in a motoring condition (zero fueling and negative torque) for a minimum continuous period of 25 seconds.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • The ECM has detected that the NOx reading is higher or lower than is possible from the engine output.
  • Exhaust system leaks.
  • An incorrectly installed aftertreatment outlet NOx sensor.
  • An aftertreatment outlet NOx sensor that has carbon buildup on the tip of the sensor.
  • Excessive oil consumption.
  • Possible engine misfire.
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 1694.

Last Modified: 28-Oct-2015


Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the original equipment manufacturer (OEM) harness. | Severe derate in power output of the engine. Limp home power only.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Sensor Supply 5 Circuit
ISF2.8 CM2220 ECF2 - Sensor Supply 5 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Sensor Supply 5 Circuit
ISM11 CM876 SN - Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 of the engine control module (ECM) provides a 5 volt supply for the remote accelerator, coolant level sensor, accelerator position sensor 2, and aftertreatment diesel particulate filter differential pressure sensor.

Component Location

Sensor supply number 5 is located in the ECM OEM harness connector and provides a 5 volt supply to various components in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 5 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will have limp home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the 5 volt supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-1695.

Last Modified: 27-Oct-2015


Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the original equipment manufacturer (OEM) harness. | Severe derate in power output of the engine. Limp home power only.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Sensor Supply 5 Circuit
ISF2.8 CM2220 ECF2 - Sensor Supply 5 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Sensor Supply 5 Circuit
ISM11 CM876 SN - Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 of the engine control module (ECM) provides a 5 volt supply for the remote accelerator, engine coolant level sensor, the accelerator position sensor 2, the fan speed sensor (if equipped), the aftertreatment diesel exhaust fluid tank level/temperature sensor (on some engines), and the aftertreatment diesel particulate filter differential pressure sensor (if equipped).

Component Location

Sensor supply number 5 is located in the ECM OEM harness connector and provides a 5 volt supply to various components in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 5 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will have limp home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-1696.

Last Modified: 28-Oct-2015


Air Supply Actuator - Voltage Above Normal or Shorted to High Source

FAULT CODE 1697

Air Supply Actuator - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1697 PID: SPN: 3489 FMI: 3 LAMP: Amber SRT: | Air Supply Actuator - Voltage Above Normal, or Shorted to High Source. High signal voltage has been detected at the aftertreatment diesel exhaust fluid dosing unit air solenoid circuit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Air Supply Actuator Circuit
ISM11 CM876 SN - Air Supply Actuator Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit air solenoid is used to enable and disable the truck air supply to the diesel exhaust fluid pump. The air is used to transport the diesel exhaust fluid to the diesel exhaust fluid injector.

Component Location

The aftertreatment diesel exhaust fluid dosing unit air solenoid is mounted to the back of the diesel exhaust fluid pump. The diesel exhaust fluid pump is original equipment manufacturer (OEM) mounted. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is logged when the supply voltage to the air solenoid is greater than +12-VDC.

Action Taken When the Fault Code is Active

  • The engine control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Air solenoid signal wire shorted to a voltage supply
  • Failed aftertreatment diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code 1697.

Last Modified: 28-Oct-2015


Air Supply Actuator - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1698

Air Supply Actuator - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1698 PID: SPN: 3489 FMI: 4 LAMP: Amber SRT: | Air Supply Actuator - Voltage Below Normal or Shorted to Low Source. Low signal voltage has been detected at the aftertreatment diesel exhaust fluid dosing unit air solenoid circuit. | Diesel exhaust fluid injection into the selective catalytic reduction (SCR) aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Air Supply Actuator Circuit
ISM11 CM876 SN - Air Supply Actuator Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing unit air solenoid is used to enable and disable the truck air supply to the DEF pump. The air is used to transport the DEF to the DEF injector.

Component Location

The aftertreatment DEF dosing unit air solenoid is mounted to the back of the DEF pump. The DEF pump is original equipment manufacturer (OEM) mounted. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is logged when the supply voltage to the air solenoid is greater than +12-VDC.

Action Taken When the Fault Code is Active

  • The engine control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • DEF injection into the SCR aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the air solenoid signal wire
  • Open circuit in the air solenoid return wire
  • Shorted to pin-to-pin air solenoid signal wire
  • Malfunctioning air solenoid
  • Malfunctioning DEF pump.
Refer to Troubleshooting Fault Code t05-1698.

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Abnormal Update Rate

FAULT CODE 1711

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1711 PID: SPN: 3361 FMI: 9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Abnormal Update Rate. Data link communications between the ECM and the aftertreatment diesel exhaust fluid dosing unit have been interrupted. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit
ISL9 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit communicates to the primary engine electronic control module (ECM) through the J1939 public data link network. The aftertreatment diesel exhaust fluid dosing unit also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Data link communications between the ECM and the aftertreatment diesel exhaust fluid dosing unit have been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

Possible causes of this fault code include:

  • Loss of battery voltage to the aftertreatment diesel exhaust fluid dosing unit
  • Loss of battery ground to the aftertreatment diesel exhaust fluid dosing unit
  • Loss of keyswitch input to the aftertreatment diesel exhaust fluid dosing unit
  • Shorted or open J1939 data link wiring between the aftertreatment diesel exhaust fluid dosing unit and the primary engine ECM
  • Malfunctioning aftertreatment diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code 1711.

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1712

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid but Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank heater is unable to thaw the frozen diesel exhaust fluid. | None on performance. Diesel exhaust fluid injection into the aftertreatment system may be disabled if the aftertreatment diesel exhaust fluid is frozen.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater has been on long enough to thaw the diesel exhaust fluid, but the SCR dosing system is still not able to prime.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diesel exhaust fluid tank heater is able to successfully thaw the diesel exhaust fluid tank and the diagnostic runs and passes. If a thawing cycle can not be completed, make sure the diesel exhaust fluid tank heater control valve is operating correctly by using the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restricitons in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller is unable to command tank heating.
Refer to Troubleshooting Fault Code 1712.

Last Modified: 29-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level. The DEF tank heater is continuously in the ON position. | None on performance.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment DEF Tank Heater Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment DEF Tank Heater Circuit
ISM11 CM876 SN - Aftertreatment DEF Tank Heater Circuit

Circuit Description

The aftertreatment DEF tank heater keeps the DEF from freezing in the DEF tank. The tank heater consists of an electrically powered tank heater control valve that controls the flow of engine coolant to a heating coil inside the DEF tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and then closes when heating is no longer required.

Component Location

The DEF tank heater control valve is located near the DEF tank. Specific location will vary, depending on the vehicle original equipment manfacturer (OEM). The tank heating coil is internal to the DEF tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when DEF tank heating is being commanded.

Conditions for Setting the Fault Codes

The aftertreatment DEF tank heater is determined to be in the ON position when the engine contol module (ECM) is commanding the heater to be in the OFF position. This is done by detecting when the DEF tank temperature is equal to or greater than the fault code threshold value of 77°C [170°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle until the coolant temperature is at operating temperature for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Before troubleshooting this fault code, make sure the vehicle is not equipped with an auxiliary heating device for the DEF tank. Such a device can result in overheating the DEF in the tank.

This fault code may be inactive when the vehicle is brought in for service. Even if inactive, follow the troubleshooting tree completely.

  • Reason: If there is a problem with the DEF tank heater control valve, the valve is stuck open, there is coolant leaking past the valve seat, or the valve is incorrectly installed, it can take long periods of operation at high load before the DEF tank temperature gradually increases to the fault code threshold value of 77°C [170°F]. As soon as the DEF temperature drops below 75°C [167°F] due to a stopped engine, overnight parking, reduced coolant temperature, and so forth, the fault code will go inactive, while the root cause of the issue is still present.

Possible causes of this fault code include:

  • Aftertreatment DEF tank heater control valve stuck open
  • Malfunctioning aftertreatment DEF tank heater control valve - stuck open or leakage past the valve seat.
  • Malfunctioning aftertreatment DEF controller is continuously commanding tank heating.
Refer to Troubleshooting Fault Code 1713.

Last Modified: 30-Oct-2015


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure circuit. | None on performance.
ISM11 CM876 SN - Crankcase Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the crankcase pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankcase pressure sensor provides a signal to the ECM on the crankcase pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the crankcase filter.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure signal voltage is greater than 4.75-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 25-Apr-2012


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the crankcase pressure circuit. | None on performance.
ISM11 CM876 SN - Crankcase Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the crankcase pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankcase pressure sensor provides a signal to the ECM on the crankcase pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the crankcase filter.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure signal voltage is less than 0.25-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 25-Apr-2012


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 1848

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1848 PID: P105 SPN: 105 FMI: 10 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change. The intake manifold temperature sensor is not responding to a change in engine operating conditions. | The ECM will estimate engine intake manifold temperature.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7, CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Temperature Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the ECM for the engine protection system and engine emission control. The engine control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage, a low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

The engine intake manifold temperature is monitored during engine warm-up. The ECM must not see engine speed for a period of 8 hours before this diagnostic will run.

Conditions for Setting the Fault Codes

The engine intake manifold temperature is monitored during engine warm-up. If the engine intake manifold temperature reading is not changing to match the engine operating conditions, the intake manifold temperature sensor is then determined to be stuck in-range and this fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and immediately when the diagnostic runs and fails.
  • The ECM will estimate engine intake manifold temperature.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range engine intake manifold temperature sensor reading.
  • High resistance in the engine intake manifold temperature sensor signal or return lines.

Refer to Troubleshooting Fault Code 1848.

Last Modified: 28-Oct-2015


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: SPN: 97 FMI: 16 LAMP: Amber SRT: | Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. The Water-In-Fuel Indicator indicates that the water level is above warning level. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Water-in-Fuel Indicator Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Water-in-Fuel Indicator Circuit
ISM11 CM876 SN - Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The water-in-fuel sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires, a ground wire and a signal wire.

Component Location

The water-in-fuel sensor is integrated into the bottom of the fuel filter. The filter housing location will vary with each original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Water has been detected in the fuel filter housing above the warning limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Water in the fuel can do extensive damage to the fuel system due to the tight tolerances of fuel system components.

It must be drained immediately.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1852.

Last Modified: 27-Oct-2015


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1879

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1879 PID: S324 SPN: 3251 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment differential pressure sensor circuit. | None.
ISF2.8 CM2220 ECF2 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for exact location of the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure signal voltage is greater than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.

Conditions for Clearing the Fault Code

The ECM will turn off the MIL immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1879.

Last Modified: 28-Aug-2012


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1881

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1881 PID: S324 SPN: 3251 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage or open circuit detected at the aftertreatment differential pressure sensor circuit. | None.
ISF2.8 CM2220 ECF2 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the OEM troubleshooting and repair manual for exact location of the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure signal voltage is less than 0.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the aftertreatment diesel particulate filter differential pressure is used.

Conditions for Clearing the Fault Code

The ECM will turn off the MIL immediately after the diagnostic runs and passes.

Shop Talk

Verify ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-1881.

Last Modified: 28-Aug-2012


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1883

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1883 PID: S324 SPN: 3251 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value at initial key-ON or during engine operation. | None.
ISF2.8 CM2220 ECF2 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the OEM service manual for the exact location of the aftertreatment system.

Conditions for Running the Diagnostics

  • This diagnostic runs when the keyswitch is initially turned ON.
  • The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The diagnostic runs immediately after a startup delay has elapsed. The fault code is logged at key ON if the absolute value of the differential pressure is higher than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the aftertreatment diesel particulate filter differential pressure reading.

Conditions for Clearing the Fault Code

To validate the repair, perform a key cycle and leave the key in the ON position for 1 minute. Start the engine and operate to high idle for 1 minute. It is necessary to elevate the exhaust flow for at least 30 seconds to clear this fault code. For certain applications, it may be necessary to drive the vehicle in order to achieve adequate exhaust flow for clearing the fault code.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires
  • Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.
Refer to Troubleshooting Fault Code t05-1883.

Last Modified: 14-Nov-2012


Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: P2202 SPN: 3226 FMI: 4 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | Engine may not start.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Outlet NOx Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Outlet NOx Sensor Circuit
ISM11 CM876 SN - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150°C [302°F] and the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error has been detected by in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • For 12 Volt Systems: The voltage supplied to the aftertreatment outlet NOx sensor is below + 11-VDC or above 14-VDC.
  • For 24 Volt Systems: The voltage supplied to the aftertreatment outlet NOx sensor is below + 18-VDC or above + 32-VDC.
  • The aftertreatment outlet NOx sensor has malfunctioned or is damaged
  • The aftertreatment outlet NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code t05-1887.

Last Modified: 30-Oct-2015


EGR Valve Controller - Out of Calibration

FAULT CODE 1896

EGR Valve Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1896 PID: S146 SPN: 2791 FMI: 13/13 LAMP: Amber SRT: | EGR Valve Controller - Out of Calibration. The exhaust gas recirculation (EGR) valve did not pass the automatic calibration procedure at initial key ON. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

This diagnostic runs at initial key ON and occasionally during normal engine operation after the EGR valve is commanded closed.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected the EGR valve did not pass the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails on two consecutive trips.
  • EGR valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • The inactive fault code will clear memory after 9600 hours or engine operation without a reoccurrence.

Shop Talk

When the keyswitch is initially turned ON and at various times during engine operation, the closed position of the EGR valve is checked. This diagnostic checks to make sure the EGR valve is not stuck open.

The EGR valve will close when the fault code is active. The fault code will remain active until the next key cycle.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap Acceleration Test to check for a malfunctioning diesel particulate filter.

Refer to Troubleshooting Fault Code 1896.

Last Modified: 19-Jan-2017


VGT Actuator Controller - Out of Calibration

FAULT CODE 1898

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1898 PID: SPN: 641 FMI: 13/13 LAMP: Amber SRT: | VGT Actuator Controller - Out of Calibration. The VGT has failed the automatic calibration procedure at initial key on. | Low intake manifold pressure. The VGT will be in the open position.
ISL9 CM2150 SN - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronic activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

Conditions for Setting the Fault Codes

The internal position reference is not detected during the initial power ON due to mechanical system binding or internal condition. The actual VGT actuator position is not known.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Note that the keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The ECM will turn off the amber CHECK ENGINE lamp and enable VGT operation immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when one of the following error conditions exists:

  • The gear alignment between the actuator and the turbocharger housing is misaligned.
  • Foreign material in the VGT turbocharger may prevent the sliding nozzle from moving to the desired position at key ON.
Refer to Troubleshooting Fault Code 1898.

Last Modified: 30-Oct-2015


Fault Code Path Selection

FAULT CODE 120-fc1911
Fault Code Path Selection

Is the engine an ISB, ISC, or ISF? | Go to 120-fc1911bdf
Is the engine an ISC, ISL, ISX, or ISZ? | Go to 120-fc1911clxz

Last Modified: 13-Nov-2009


ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1938

ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1938 PID: SPN: 3597 FMI: 18 LAMP: Amber SRT: | ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operating Range - Moderately Severe Level. Low battery voltage detected by the VGT actuator. | None on performance.
ISL9 CM2150 SN - VGT Battery Voltage Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fault code is set when the voltage supplied to the VGT actuator drops below +10-VDC for 10 seconds and the engine speed must be zero rpm or above 500 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The VGT actuation will continue until battery voltage drops low enough that VGT actuation can not continue.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the voltage to the VGT actuator is greater than +10-VDC and the engine speed is zero rpm or greater than 500 rpm.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the voltage to the VGT actuator drops below +10-VDC. The VGT will still continue to respond to commands from the primary engine ECM.

Refer to Troubleshooting Fault Code 1938.

Last Modified: 30-Oct-2015


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2 LAMP: Amber SRT: | Crankcase Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the crankcase pressure signal is reading an erratic value at initial key ON or during engine operation. | None on performance.
ISM11 CM876 SN - Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of this diagnostic runs at initial key ON and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure sensor is reading an erratic value at key ON, or the crankcase pressure reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 1 minute. Then start the engine and let it idle for 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a crankcase breather hose disconnected between the engine outlet and crankcase filter assembly on engines with an externally mounted crankcase filter option.

Possible causes of this fault code include:

  • Resistance in the wiring harness
  • A malfunctioning in-range pressure sensor
  • Crankcase pressure sensor is not installed correctly in the housing.
Refer to Troubleshooting Fault Code 1942.

Last Modified: 25-Apr-2012


Ambient Air Density - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 1943

Ambient Air Density - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1943 PID: SPN: 3555 FMI: 1/17 LAMP: None SRT: | Ambient Air Density - Data Valid but Below Normal Operating Range - Least Severe Level. Engine torque has been reduced because the vehicle was operating at a high altitude condition. | Possible engine derate.
ISM11 CM876 SN - Barometric Pressure Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation that the engine is currently operating at. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The engine control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure reading is lower than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Engine torque output will be limited due to the engine operating at high altitude conditions.

Conditions for Clearing the Fault Code

The ECM will return full torque to the engine and the fault code will go inactive when the vehicle is being operated within the normal altitude conditions.

Shop Talk

When the engine has been operated in a high altitude location, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating in the high altitude location to protect the turbocharger and engine from excessively high exhaust temperatures. The derate limits the torque output of the engine to keep the temperatures below the maximum temperature limits.

Note: This fault code will most likely not be active with no load in the shop. The engine must be under the same operating conditions (altitude and temperature) at the time that the fault code had originally logged.

Refer to Troubleshooting Fault Code 1943.

Last Modified: 25-Apr-2012


VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 1962

VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1962 PID: S027 SPN: 641 FMI: 0/15 LAMP: Amber SRT: | VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operating Range - Least Severe Level. High internal VGT actuator temperature has been detected. | None on performance.
ISL9 CM2150 SN - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is turned on.

Conditions for Setting the Fault Codes

The fault code will log when the internal temperature of the VGT actuator exceeds 125°C [257°F] continuously for 30 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the internal actuator temperature drops below 125°C [257°F].

Shop Talk

This fault code will be inactive when the vehicle is in the shop because the VGT actuator temperature has cooled down. Troubleshoot multiple inactive counts of this fault code as an active fault code.

Also check for exhaust leaks blowing on the VGT actuator. Repair any external leaks.

Refer to Troubleshooting Fault Code 1962.

Last Modified: 30-Oct-2015


Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1981

Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1981 PID: None SPN: 3936 FMI: 15/15 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment differential pressure has exceeded the maximum operating limits or the diesel particulate filter is plugged. | None.
ISF2.8 CM2220 ECF2 - Aftertreatment Diesel Particulate Filter

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the diesel particulate filter is plugged or that the differential pressure across the diesel particulate filter is above the maximum limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the differential pressure across the aftertreatment diesel particulate filter has dropped below the maximum severity level and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment wiring harness connectors may be connected to the wrong aftertreatment temperature sensor.
  • The aftertreatment wiring harness or aftertreatment temperature sensor connector pin installation may be incorrect.
  • The aftertreatment diesel particulate filter can be plugged with ash.
  • The engine has been operating in light load conditions that prevent exhaust gas temperatures from being high enough to actively regenerate the aftertreatment particulate trap.
  • An engine malfunction that is elevating the engine smoke output.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code t05-1981.

Last Modified: 19-Sep-2012


Aftertreatment Diesel Particulate Filter Missing - Condition Exists

FAULT CODE 1993

Aftertreatment Diesel Particulate Filter Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1993 PID: SPN: 4795 FMI: 31 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Missing - Condition Exists. The aftertreatment diesel particulate filter in the exhaust system is not present. | None.
ISF2.8 CM2220 ECF2 - Aftertreatment Diesel Particulate Filter

Circuit Description

The engine aftertreatment system monitors for the presence of the aftertreatment diesel particulate filter. This diagnostic checks to make sure that the aftertreatment diesel particulate filter is present and functioning correctly.

Component Location

The aftertreatment particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

This diagnostic monitors the aftertreatment diesel particulate filter differential pressure sensor. When the differential pressure is below a minimum value and exhaust flow rate is above a minimum flow rate, the fault code is set.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes for two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate it at high idle. It is necessary to elevate the exhaust flow for at least 3 minutes to clear this fault code. For certain applications, it may be necessary to drive the vehicle in order to achieve adequate exhaust flow.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment diesel particulate filter has been removed from the vehicle
  • The aftertreatment diesel particulate filter is cracked or broken
  • The aftertreatment diesel particulate filter differential tubes are installed incorrectly, broken, loose, or have been tampered with
  • The aftertreatment diesel particulate filter differential tubes are installed backward.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code t05-1993.

Last Modified: 19-Sep-2012


Fault Code Path Selection

FAULT CODE 120-fc2182
Fault Code Path Selection

Is it a Heavy Duty engine? | Go to 120-fc2182ism
Is it a Midrange engine? | Go to 120-fc2182mr

Last Modified: 02-Nov-2015


Fault Code Path Selection

FAULT CODE 120-fc2183
Fault Code Path Selection

Is it a Heavy Duty engine? | Go to 120-fc2183ism
Is it a Midrange engine? | Go to 120-fc2183mr

Last Modified: 02-Nov-2015


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Accelerator Pedal or Lever Position Sensor Supply
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Accelerator Pedal or Lever Position Sensor Supply
ISM11 CM876 SN - Accelerator Pedal or Lever Position Sensor Supply

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 volt supply to the accelerator pedal position sensor. The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal assembly is located in the cab. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is more than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 29-Oct-2015


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only die.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Accelerator Pedal Position Sensor Supply Voltage Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Accelerator Pedal Position Sensor Supply Voltage Circuit
ISM11 CM876 SN - Accelerator Pedal Position Sensor Supply Voltage Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 volt supply to the accelerator pedal position sensor. The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal is located in the cab. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only die.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 28-Oct-2015


VGT Actuator Driver Circuit - Root Cause Not Known

FAULT CODE 2198

VGT Actuator Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2198 PID: S027 SPN: 641 FMI: 11/11 LAMP: Amber SRT: | VGT Actuator Driver Circuit - Root Cause Not Known. Intermittent communication between the smart VGT controller and the ECM has been detected. The VGT controller is not interpreting the J1939 message from the ECM correctly. | VGT actuation will be disabled.
ISL9 CM2150 SN-VGT Actuator Driver Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The VGT actuator does not receive a valid J1939 message from the ECM for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The VGT will move to the default open position.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the VGT actuator receives a valid J1939 message from the ECM.

Shop Talk

Intermittent J1939 datalink connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the VGT actuator.

Refer to Troubleshooting Fault Code 2198.

Last Modified: 30-Oct-2015


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source. High voltage or open detected at the fuel lift pump signal circuit. | Engine can be difficult to start.
ISL9 CM2150 SN - Electric Fuel Lift Pump Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The electric fuel lift pump is located behind the ECM cooling plate on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the lift pump timer has expired 1 minute after intial key ON.

Conditions for Setting the Fault Codes

The engine fuel lift pump signal circuit is detected to be greater than 0-VDC when the signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine fuel lift pump will be disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault becomes active if the ECM detects an open circuit at key ON. Causes of this fault code include an open circuit in the electric fuel lift pump circuit.

If the fault code is intermittent, look for causes of an intermittent open circuit, such as loose pins and bad connections. This fault code can detect open circuit conditions only at key ON. The lift pump only runs at key ON and during cranking to aid in priming of the fuel pump gear pump.

The lift pump will run continuously if shorted to battery power. If the lift pump runs continuously, check for aftermarket modifications and wiring to the lift pump.

Refer to Troubleshooting Fault Code t05-2265.

Last Modified: 30-Oct-2015


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel lift pump circuit. | Engine can be difficult to start.
ISL9 CM2150 SN - Electric Fuel Lift Pump Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The electric fuel lift pump is located behind the ECM cooling plate on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs during the first minute after initial key ON, when the fuel lift pump is being commanded to run.

Conditions for Setting the Fault Codes

The engine fuel lift pump signal circuit is detected to be 0-VDC when the signal is turned on by the ECM and must be at system voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine fuel lift pump will be disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the keyswitch in the ON position for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code becomes active whenever the ECM detects a short circuit to ground or high current in the electric fuel lift pump circuit. Causes for this fault code are a short circuit to ground or low resistance (lift pump partially shorted). During cold weather, gelled fuel can plug the lift pump and cause this fault code. Listen to the lift pump to be sure it is running during cold ambient temperatures (less than -29°C [-20°F]). This fault code can possibly also become active if the lift pump rotor stalls or seizes. When the fault condition is detected, the ECM driver to the lift pump is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test for the cause of the fault code. The ECM driver is enabled at key ON. If the cause if no longer present, the fault code will become inactive and can be cleared.

Refer to Troubleshooting Fault Code t05-2266.

Last Modified: 30-Oct-2015


EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2271

EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2271 PID: P027 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR valve position sensor circuit. | EGR valve actuation will be disabled.
ISF2.8 CM2220/ISF2.8 CM2220 EC - EGR Valve Position Circuit

Circuit Description

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the EGR valve position sensor signal voltage is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The EGR valve operation will be disabled and the EGR valve will be closed.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute. The EGR valve will perform an auto-zero immediately after key ON.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with the INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open return in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply
  • Malfunctioning EGR valve position sensor
  • Malfunctioning ECM.

NOTE: Do not supply 12-VDC to the EGR valve position sensor, or short the EGR valve motor wires to the EGR valve position sensor. The EGR valve position is rated at 5-VDC, and sensor damage can occur.

Refer to Troubleshooting Fault Code t05-2271.

Last Modified: 26-Apr-2012


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P27 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage has been detected at the EGR valve position sensor circuit. | EGR valve actuation will be disabled.
ISF2.8 CM2220/ISF2.8 CM2220 EC - EGR Valve Position Circuit

Circuit Description

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the EGR valve position sensor signal voltage is less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the on position for 1 minute. The EGR valve will perform an auto-zero immediately after key-on.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault code include:

  • SIGNAL circuit open or shorted to ground
  • SUPPLY circuit open or shorted to ground
  • Sensor shorted to ground.

NOTE: Do not supply 12-V to the EGR valve position sensor, or short the EGR valve motor wires to the EGR valve position sensor. The EGR valve position sensor is rated at 5-V, and sensor damage can occur.

Refer to Troubleshooting Fault Code t05-2272.

Last Modified: 26-Apr-2012


Turbocharger 1 Speed - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 0/15 LAMP: None SRT: | Turbocharger 1 Speed - Data Valid but Above Normal Operating Range - Least Severe Level. High turbocharger speed has been detected by the ECM. | Engine power derate to lower the turbocharger speed.
ISL9 CM2150 SN - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The engine control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM will reduce torque output of the engine to reduce turbocharger speeds.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code t05-2288.

Last Modified: 30-Oct-2015


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S018 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. The fuel pump actuator circuit resistance is too high or too low, or an intermittent connection has been detected. | The engine will run rough with low power.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Electronic Fuel Injection Control Valve Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Electronic Fuel Injection Control Valve Circuit
ISZ13 CM2150 - Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump, based on engine operating conditions. The fuel pump actuator valve is a normally open valve. High circuit resistance can cause fuel pressure to be higher than commanded at light loads.

Component Location

The fuel pump actuator valve is located on the engine-mounted fuel pump housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault is set when the fuel pump actuator circuit has intermittent circuit problems, or the fuel pump actuator resistance it too high or low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If this fault code occurs during a road test, verify that all connectors are clean and free of corrosion before replacing components.

This fault code can become active for any of the following reasons:

  • Fuel pump actuator high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins at the fuel pump actuator or ECM connectors
  • Fuel pump actuator with low internal resistance
  • Fuel pump actuator or engine harness that has shorted to ground
  • Intermittent circuit malfunctions that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still faulty.

Refer to Troubleshooting Fault Code t05-2311.

Last Modified: 30-Oct-2015


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Crankshaft engine speed sensor intermittent synchronization. | The engine can exhibit misfire as control switches from the primary to the backup speed sensor. Engine power is reduced while the engine operates on the backup speed sensor.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Crankshaft Speed/Position Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Crankshaft Speed/Position Sensor Circuit
ISM11 CM876 SN - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position based on the missing tooth on the speed indicator ring.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the degraded signal from the crankshaft speed/position sensor is no longer present and the diagnostic runs and passes.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent “misfire” if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent “low power” if a “glitch” in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key-on or if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2321.

Last Modified: 30-Oct-2015


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S064 SPN: 723 FMI: 2/2 LAMP: None SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Camshaft Speed/Position Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Camshaft Speed/Position Sensor Circuit
ISM11 CM876 SN - Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the ECM detects a valid signal from the camshaft speed/position sensor.
  • This fault code can also be cleared with INSITE™ electronic service tool.

The ECM will set the fault code inactive after the ECM detects a valid signal from the camshaft speed/position sensor.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator could possibly not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key ON or if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Problems that can cause this fault:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the secondary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2322.

Last Modified: 30-Oct-2015


Fuel Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2344

Fuel Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2344 PID: SPN: 95 FMI: 2 LAMP: Amber SRT: | Fuel Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect. An error in the fuel filter differential pressure switch signal was detected by the ECM. | None on performance.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Control Module

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The location of the fuel filter differential pressure switch varies by engine model. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic will run with the key ON.

Conditions for Setting the Fault Codes

The fuel pressure switch is not installed on the suction-side filter. If it is, the switch wiring harness is not properly connected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The disconnected switch will cause the ECM to understand is has a high pressure on the line. This is not the expected behavior when the engine is turned off with only key on. Based on this assumption, the ECM declares it is a faulty switch. The possible causes of this fault code are necessarily related to electrical connection:

  • An unplugged pressure switch or unconnected wiring harness
  • Damaged connector
  • Damaged wiring harness.
Refer to Troubleshooting Fault Code t05-2344.

Last Modified: 06-Jan-2017


Turbocharger 1 Speed - Abnormal Rate of Change

FAULT CODE 2345

Turbocharger 1 Speed - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2345 PID: P103 SPN: 103 FMI: 10/10 LAMP: Amber SRT: | Turbocharger 1 Speed - Abnormal Rate of Change. The turbocharger speed sensor has detected an erroneous speed value. | None on performance. The ECM uses an estimated turbocharger speed.
ISL9 CM2150 SN - Turbocharger 1 Speed Ciircuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft passes the speed sensor, a signal is generated. The engine control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is located in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed has increased faster than physically achievable by the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

This fault code can be caused by an intermittent turbocharger speed sensor connection, incorrect turbocharger speed sensor air gap, or a malfunctioning turbocharger speed sensor.

Refer to Troubleshooting Fault Code t05-2345.

Last Modified: 28-Oct-2015


Turbocharger Turbine Intake Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2346

Turbocharger Turbine Intake Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger Turbine Intake Temperature - Data Valid but Above Normal Operating Range - Least Severe Level. Turbocharger turbine intake temperature has exceeded the engine protection limit. | Fuel is limited in an attempt to decrease the exhaust gas temperature entering the turbocharger.
ISL9 CM2150 SN - Electronic Control Module
ISM11 CM876 SN - Electronic Control Module

Circuit Description

The exhaust gas temperature is calculated by the electronic control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger and is also know as turbine intake temperature.

Some original equipment manufacturers (OEM) have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet exhaust gas temperature leaving the turbocharger and will not equal the value monitored with the exhaust gas temperature parameter with INSITE electronic service tool.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbine intake temperature is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

This fault code is an information fault code, indicating that the engine has been derated for high turbine intake temperature (exhaust temperature). No troubleshooting is necessary for this fault code. It is only an indicator that the engine power was derated to limit the exhaust temperature.

If the condition continues to exist, Fault Code 2451 will become active.

Refer to Troubleshooting Fault Code 2346.

Last Modified: 29-Oct-2015


Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2347

Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: SPN: 2629 FMI: 0/15 LAMP: None SRT: | Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operating Range - Least Severe Level. High turbocharger compressor outlet air temperature has been calculated by the engine control module (ECM). | Fuel is limited in an attempt to decrease the calculated turbocharger compressor outlet air temperature.
ISL9 CM2150 SN - Electronic Control Module
ISM11 CM876 SN - Electronic Control Module

Circuit Description

The turbocharger compressor outlet air temperature is calculated by the ECM. Turbocharger compressor outlet air temperature is derived by the ECM, based on engine operating conditions such as turbocharger compressor inlet air temperature, barometric pressure, turbocharger speed, engine speed, intake manifold air temperature, and intake manifold pressure.

Component Location

There is not a physical turbocharger compressor outlet temperature sensor in the system. The turbocharger compressor outlet air temperature is a calculation of temperature of the air after it is compressed by the turbocharger compressor, but before exhaust gas recirculation (EGR) is mixed into the system and before it enters the charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbocharger compressor outlet temperature is greater than 238°C [460°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the calculated compressor outlet temperature.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible caused of this fault code include:

  • Air intake leaks allowing hot under-hood air to enter the intake system
  • Faulty intake manifold pressure readings
  • High turbocharger speed readings
  • Malfunction of barometric pressure sensor
  • Stuck variable geometry turbocharger.

Note: Unless the fault is caused by a malfunction in the barometric pressure sensor or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the malfunction has been found and fixed.

Refer to Troubleshooting Fault Code t05-2347.

Last Modified: 03-Nov-2015


EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2351

EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2351 PID: S146 SPN: 2791 FMI: 4 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the EGR valve motor circuit. | Possible low power. Power removed from EGR valve motor.
ISF2.8 CM2220/ISF2.8 CM2220 EC - EGR Valve Position Circuit

Circuit Description

The engine control module (ECM) controls the EGR valve, opening and closing it based on various operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor signal (+) and (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor signal (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor signal (-) circuit.

Component Location

The EGR valve is located on the exhaust side of the engine and is attached to the EGR cooler, which is mounted to the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is operating.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects a short circuit to ground in the EGR motor supply circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

  • The fault code will always be inactive at key ON. To validate the repair, start and idle the engine for 1 minute. If the fault code does not become active again, the repair has been validated.
  • The ECM will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE ™ electronic service tool.

Shop Talk

The ECM monitors the voltage level of the circuit and logs a fault code if the voltage level indicates a short to ground. This fault is always set inactive when the keyswitch is turned ON. If there is a failure of this circuit, the fault code will not be set active until the valve has been actuated. For these reasons, this troubleshooting tree must be used of both active and inactive fault codes.

Possible causes of this fault are EGR valve motor output (+ or -) leads shorted to ground in the harness, EGR valve motor, or ECM.

NOTE: Do not supply 12-VDC to the EGR valve position sensor, or short the EGR valve motor wires to the EGR valve position sensor. The EGR valve position sensor is rated at 5-VDC, and sensor damage may occur.

Refer to Troubleshooting Fault Code t05-2351.

Last Modified: 26-Apr-2012


EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2352

EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2352 PID: S146 SPN: 2791 FMI: 3/3 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the EGR valve motor circuit. | Possible low power. Power removed from the EGR valve motor.
ISF2.8 CM2220/ISF2.8 CM2220 EC - EGR Valve Control Circuit

Circuit Description

The engine control module (ECM) controls the exhaust gas recirculation (EGR) valve, opening and closing it based on various operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor signal (+) and (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor signal (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor signal (-) circuit.

Component Location

The EGR valve is located on the exhaust side of the engine and is attached to the EGR cooler, which is mounted to the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects a short circuit to voltage or open circuit in the EGR motor supply circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails. The EGR valve operation will be disabled, and the valve will default to the closed position.

Conditions for Clearing the Fault Code

  • The fault code will always be inactive at key ON. To validate the repair, start and idle the engine for 1 minute. If the fault code does not become active again, the repair has been validated.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level of the circuit and logs a fault code if the voltage level indicates a short to voltage. This fault is always set inactive when the keyswitch is turned ON. If there is a failure of this circuit, the fault code will not be set active until the valve has been actuated. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault are that the EGR motor (+ or - ) wires could be open or shorted to a voltage source in the harness or ECM.

NOTE: Do not supply 12-VDC to the EGR valve position sensor, or short the EGR valve motor wires to the EGR valve position sensor. The EGR valve position sensor is rated at 5-VDC, and sensor damage can occur.

Refer to Troubleshooting Fault Code t05-2352.

Last Modified: 26-Apr-2012


EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2357

EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2357 PID: SPN: 2791 FMI: 7/7 LAMP: Amber SRT: | EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment. The EGR motor has exceeded the duty cycle limit, indicating a stuck open EGR valve. | EGR valve actuation will be disabled.
ISF2.8 CM2220/ISF2.8 CM2220 EC - EGR Valve Circuit

Circuit Description

The engine control module (ECM) controls the EGR valve, opening and closing it based on various operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor signal (+) and (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor signal (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor signal (-) circuit.

Component Location

The EGR valve is located on the exhaust side of the engine and is attached to the EGR cooler, which is mounted to the exhaust manifold. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating, and the EGR valve is being commanded to move. The ECM is programmed to do a sweep of the EGR valve at key ON, during which this diagnostic will run as well.

Conditions for Setting the Fault Codes

This fault code is set when the duty cycle required to open the EGR valve is greater than 95 percent for 3 seconds.

The fault code will be inactive at key ON. It will only go active if the EGR valve is commanded open and the EGR valve is unable to move to the commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

  • The fault code will always be inactive at key ON. To validate the repair, start and idle the engine for 1 minute. If the fault code does not become active again, the repair has been validated.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code can also be cleared with the INSITE™ electronic service tool.

Shop Talk

The ECM monitors the duty cycle of the valve and logs a fault code if the duty cycle is too high. This fault is always set inactive when the keyswitch is turned ON. If there is a failure, the fault code will not be set active until the valve has been actuated. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault include:

  • Damaged EGR valve position sensor; mechanical or electrical damage
  • EGR valve assembly damage requiring a high current to operate the valve, such as a stuck or sticking valve.

NOTE: Do not supply 12V to the EGR valve position sensor, or short the EGR valve motor wires to the EGR valve position sensor. The EGR valve position is rated at 5V, and sensor damage may occur.

Refer to Troubleshooting Fault Code t05-2357.

Last Modified: 26-Apr-2012


Fault Code Path Selection

FAULT CODE 120-fc2363
Fault Code Path Selection

Is it a Heavy Duty engine? | Go to 120-fc2363hd
Is it a Midrange engine? | Go to 120-fc2363mr

Last Modified: 07-Sep-2009


Fault Code Path Selection

FAULT CODE 120-fc2367
Fault Code Path Selection

Is it a Heavy Duty engine? | Go to 120-fc2367hd
Is it a Midrange engine? | Go to 120-fc2367mr

Last Modified: 11-May-2009


Engine (Exhaust) Brake Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2369

Engine (Exhaust) Brake Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2369 PID: SPN: 1074 FMI: 4 LAMP: Amber SRT: | Engine (Exhaust) Brake Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the exhaust brake control circuit. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF 2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine (Exhaust) Brake Driver Circuit

Circuit Description

The exhaust brake is used to retard engine speed by creating high exhaust back pressure, subsequently slowing the vehicle down and extending the life of the service brakes. This back pressure is obtained by restricting airflow through the exhaust system with a butterfly valve.

Component Location

The exhaust brake is located in the exhaust stream, after the turbocharger outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the voltage in the exhaust brake control circuit is below a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include a short circuit to ground in the engine harness, connector, or exhaust brake actuator.

Refer to Troubleshooting Fault Code t05-2369.

Last Modified: 26-Apr-2012


Engine (Exhaust) Brake Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2371

Engine (Exhaust) Brake Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2371 PID: SPN: 1074 FMI: 3 LAMP: Amber SRT: | Engine (Exhaust) Brake Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the exhaust brake control circuit. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine (Exhaust) Brake Driver Circuit

Circuit Description

The exhaust brake is used to retard engine speed by creating high exhaust back pressure, subsequently slowing the vehicle down and extending the life of the service brakes. This back pressure is obtained by restricting airflow through the exhaust system with a butterfly valve.

Component Location

The exhaust brake is located in the exhaust stream, after the turbocharger outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the voltage in the exhaust brake control circuit is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness or exhaust brake actuator
  • Short to voltage source in the engine harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2371.

Last Modified: 26-Apr-2012


Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2372

Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2372 PID: P095 SPN: 95 FMI: 0/16 LAMP: Amber SRT: | Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Fuel filter is plugged or fuel inlet restriction is high. | Possible reduced engine performance.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Control Module

Circuit Description

This fault code activates if low fuel pressure is detected by the engine control module (ECM) during high engine rpm or motoring conditions.

Component Location

This fuel filter is remotely mounted between the fuel pump and original equipment manufacturer (OEM) fuel tank. However, exact location is OEM dependent. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Fuel pressure is less than a calibratible value during high fuel flow conditions, indicating a fuel inlet restriction.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

Idle the engine for 10 seconds. The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. See the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Low fuel pressure during high engine speeds or motoring conditions indicates a fuel inlet restriction or a plugged pressure-side fuel filter. Items that can cause this fault code to activate are:

  • A plugged pressure- or suction-side fuel filter
  • Collapsed fuel inlet lines
  • An obstructed suction tube in the fuel tank
  • Sticking or worn fuel shutoff valve disc, plunger, or return spring.
Refer to Troubleshooting Fault Code t05-2372

Last Modified: 06-Jan-2017


Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas pressure circuit. | None on performance.
ISL9 CM2150 SN - Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas pressure signal voltage is greater than 4.75-VDC for more than 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the exhaust gas pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor
  • A signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2373.

Last Modified: 30-Oct-2015


Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas pressure circuit. | None on performance.
ISL9 CM2150 SN - Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas pressure signal voltage is less than .25-VDC for more than 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the exhaust gas pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-2374.

Last Modified: 30-Oct-2015


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S033 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan could stay on continuously or not run at all.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Fan Control Circuit
ISF2.8 CM2220 AN - Fan Control Circuit
ISF3.8 CM2220/ISF3.8 CM2220 AN - Fan Control Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Fan Control Circuit
ISM11 CM876 SN - Fan Control Circuit
ISZ13 CM2150 - Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A pulse width modulated (PWM) signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. Use INSITE™ electronic service tool to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or goes to the engine block or chassis ground.

Component Location

The fan clutch solenoid location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan pulse width modulated (PWM) signal is less than 100 percent and will latch active when the fan pulse width modulated (PWM) signal is 100 percent.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is detected to be greater than 0-VDC when the pulse width modulated (PWM) signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

For ON/OFF and variable speed fan, the diagnostic will clear when the fan is turned off and the diagnostic runs and passes. For all other fan types, the diagnostic will clear when the fan pulse width modulated (PWM) signal is less than 100 percent.

Shop Talk

Possible causes of this fault include:

  • An open circuit in the engine harness or fan control solenoid
  • A short circuit to voltage source in the OEM harness
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2377.

Last Modified: 28-Oct-2015


Variable Geometry Turbocharger (VGT) Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2387

Variable Geometry Turbocharger (VGT) Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2387 PID: S027 SPN: 641 FMI: 7/7 LAMP: Amber SRT: | VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment. The smart VGT controller has detected incorrect stop limits, or the VGT is unable to move to the closed position. | VGT travel may be limited.
ISL9 CM2150 SN - VGT Actuator Driver Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code will set when the actual VGT actuator position can not meet the commanded position for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The VGT actuator continuously attempts to meet commanded position, even when the CHECK ENGINE lamp is ON.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes at initial key ON.

Shop Talk

Large boost pressure leaks can also cause this fault code.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting symptom tree, if applicable. Progressive damage to the aftertreatment system may have occurred.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code t05-2387.

Last Modified: 30-Oct-2015


Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2398

Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2398 PID: SPN: 171 FMI: 2 LAMP: Amber SRT: | Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect. The ambient air temperature sensor is reading an erratic value. | The ECM will estimate the ambient air temperature.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The electronic control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of eight hours before this part of the diagnostic will run. The second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine intake manifold temperature is higher or lower than the other temperature sensors on the engine after an extended period of engine off time, or the ambient temperature is not changing over time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp MIL immediately when the diagnostic runs and fails. A default value for the ambient air temperature reading is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute. If the fault code does not go inactive, it may be necessary to perform an 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range ambient air temperature sensor.
  • High resistance in the ambient air temperature sensor SIGNAL or RETURN wires.
  • ECM malfunction.
Refer to Troubleshooting Fault Code t05-2398.

Last Modified: 29-Oct-2015


Fan Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2412

Fan Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2412 PID: P026 SPN: 1639 FMI: 2/2 LAMP: Amber SRT: | Fan Speed - Data Erratic, Intermittent, or Incorrect. The fan speed signal has been lost. | The fan will only be in the ON or OFF position.
ISX and ISM - Fan Speed Sensor

Circuit Description

The fan speed sensor is a variable resistance speed sensor. It consists of a coil of wire and an iron core. The target on the fan hub shaft is a ground flat in the center of the shaft. The engine control module (ECM) interprets this signal and converts it to a fan speed reading.

Component Location

The fan speed sensor is located in the fan hub assembly. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the fan speed signal has been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan will only be in the ON or OFF position.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The fan speed sensor is installed by the OEM. This fault code is triggered when the fan speed signal is reading 0 when the engine is running. This indicates a malfunctioning fan speed sensor or a malfunction in the OEM wiring harness.

Refer to Troubleshooting Fault Code t05-2412

Last Modified: 30-Sep-2014


Injector Solenoid Driver Cylinder 1 - Out of Calibration

FAULT CODE 2442

Injector Solenoid Driver Cylinder 1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2442 PID: SPN: 651 FMI: 13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 - Out of Calibration. Invalid injector barcode information has been entered. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves are actuated by the engine control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a SUPPLY and a RETURN wire. An electrical pulse is sent to the injector from the ECM on the SUPPLY wire and returns to the ECM on the RETURN wire, after actuating the solenoid. Each electric solenoid valve is normally open and is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injectors pass through the top of the rocker lever cover. Each injector has an external electrical connector, which connects directly to the engine harness. The engine harness links the injectors to the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the injector barcode value for cylinder 1 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code will clear immediately after the correct injector barcode values have been entered with INSITE™ electronic service tool.
  • Start and idle the engine for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code t05-2442.

Last Modified: 26-Apr-2012


Injector Solenoid Driver Cylinder 2 - Out of Calibration

FAULT CODE 2443

Injector Solenoid Driver Cylinder 2 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2443 PID: SPN: 652 FMI: 13 LAMP: Amber SRT: | Inector Solenoid Driver Cylinder 2 - Out of Calibration. Invalid injector barcode information has been entered. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves are actuated by the engine control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a SUPPLY and a RETURN wire. An electrical pulse is sent to the injector from the ECM on the SUPPLY wire and returns to the ECM on the return wire, after actuating the solenoid. Each electric solenoid valve is normally open and is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injectors pass through the top of the rocker lever cover. Each injector has an external electrical connector, which connects directly to the engine harness. The engine harness links the injectors to the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the injector barcode value for cylinder 2 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code will clear immediately after the correct injector barcode values have been entered with INSITE™ electronic service tool.
  • Start and idle the engine for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code t05-2443.

Last Modified: 26-Apr-2012


Injector Solenoid Driver Cylinder 3 - Out of Calibration

FAULT CODE 2444

Injector Solenoid Driver Cylinder 3 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2444 PID: SPN: 653 FMI: 13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 - Out of Calibration. Invalid injector barcode information has been entered. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves are actuated by the engine control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a SUPPLY and a RETURN wire. An electrical pulse is sent to the injector from the ECM on the SUPPLY wire and returns to the ECM on the return wire, after actuating the solenoid. Each electric solenoid valve is normally open and is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injectors pass through the top of the rocker lever cover. Each injector has an external electrical connector, which connects directly to the engine harness. The engine harness links the injectors to the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the injector barcode value for cylinder 3 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code will clear immediately after the correct injector barcode values have been entered with INSITE™ electronic service tool.

Start and idle the engine for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with the INSITE™ electronic service tool.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code T05-2444.

Last Modified: 26-Apr-2012


Injector Solenoid Driver Cylinder 4 - Out of Calibration

FAULT CODE 2445

Injector Solenoid Driver Cylinder 4 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2445 PID: SPN: 654 FMI: 13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 - Out of Calibration. Invalid injector barcode information has been entered. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN - Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves are actuated by the engine control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a SUPPLY and a RETURN wire. An electrical pulse is sent to the injector from the ECM on the SUPPLY wire and returns to the ECM on the RETURN wire, after actuating the solenoid. Each electric solenoid valve is normally open and is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injectors pass through the top of the rocker lever cover. Each injector has an external electrical connector, which connects directly to the engine harness. The engine harness links the injectors to the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the injector barcode value for cylinder 4 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code will clear immediately after the correct injector barcode values have been entered with INSITE™ electronic service tool.

Start and idle the engine for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code t05-2445.

Last Modified: 26-Apr-2012


Coolant Level - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P2560 SPN: 111 FMI: 17 LAMP: Maintenance SRT: | Coolant Level - Data Valid but Below Normal Operating Range - Least Severe Level. Low engine coolant level detected. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Electronic Control Module
ISM11 CM876 SN - Electronic Control Module
ISZ13 CM2150 - Electronic Control Module

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is in operation.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light at initial key ON for 30 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant. The ECM will stop flashing the amber CHECK ENGINE light at key ON when coolant has been added to the engine.

Refer to Troubleshooting Fault Code t05-2448.

Last Modified: 27-Oct-2015


VGT Actuator Controller - Out of Calibration

FAULT CODE 2449

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2449 PID: S027 SPN: 641 FMI: 13/13 LAMP: Red SRT: | VGT Actuator Controller - Out of Calibration. The VGT has failed the automatic calibration procedure at initial key ON. | Low intake manifold pressure.
ISL9 CM2150 SN - VGT Actuator Controller Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The keyswitch must be completely turned off for more than 30 seconds before this diagnostic can run at initial key ON.

Conditions for Setting the Fault Codes

The internal position reference is not detected during the VGT actuator learn process due to mechanical system binding or internal condition. The actual VGT actuator position is not known.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.

Conditions for Clearing the Fault Code

The keyswitch must be completely turned off for more than 30 seconds before this diagnostic will run at initial key ON.

The fault code will clear at key ON if the error condition no longer exists. The ECM will turn off the red STOP ENGINE light and enable VGT operation immediately after the diagnostic runs and passes.

Shop Talk

This fault code is logged when one of the following error conditions exists:

  • If the turbocharger actuator has just been replaced and this fault code is active, this usually indicates that the turbocharger actuator has not been installed correctly. The gear alignment between the actuator and the turbocharger housing is misaligned.
  • Foreign material in the VGT turbocharger can prevent the sliding nozzle from moving to the desired position at key-on.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree, if applicable. Progressive damage to the aftertreatment system may have occurred.

Refer to Troubleshooting Fault Code t05-2449.

Last Modified: 30-Oct-2015


Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2451

Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2451 PID: SPN: 2789 FMI: 0/16 LAMP: None SRT: | Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operating Range - Moderately Severe Level. Turbocharger turbine inlet temperature has exceeded the engine protection limit. | Fuel is limited in an attempt to decrease the exhaust gas temperature entering the turbocharger.
ISM11 CM876 SN - Electronic Control Module

Circuit Description

The exhaust gas temperature is calculated by the electronic control module (ECM). Exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger and is also known as turbine inlet temperature.

Note: Some original equipment manufacturers (OEMs) have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet temperature or the exhaust gas leaving the turbocharger and will not equal the value monitored with the exhaust gas temperature parameter with INSITE™ electronic service tool.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbine inlet temperature is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the exhaust gas temperature entering the turbocharger.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

The most common cause of this fault code is low boost pressure. Low boost pressure can be caused by several factors: leaking charge-air cooler, damaged charge-air cooler piping or hose, loose charge-air cooler clamps, damaged intake manifold pressure sensor, damaged variable geometry turbocharger, damaged turbocharger control valve, or damaged turbocharger control shutoff valve.

This fault code can also be caused by a turbocharger fuel control derate, which can be viewed with INSITE™ electronic service tool, under the Engine Operating State. Turbocharger fuel control derates can be caused by several factors: high exhaust temperatures, turbocharger compressor inlet temperatures, and turbocharger compressor outlet temperatures.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trip this fault code and to determine if the cause has been found and repaired. Running units on the dynamometer can sometimes cause this fault code to log, due to the stationary nature and high temperatures.

Refer to Troubleshooting Fault Code 2451.

Last Modified: 29-Nov-2010


Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2555

Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2555 PID: SPN: 729 FMI: 3 LAMP: Amber SRT: | Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the intake air heater signal circuit. | The intake air heaters can be ON or OFF all the time.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Air Heater 1 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Intake Air Heater 1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions.

The electronic control module (ECM) controls relays that switch power to the intake air heater. Air heaters on 12 volt systems will have two relays; 24 volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection to the intake manifold. The location of the intake air heater relays will vary by vehicle and engine configuration.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is activated. In some cases, the diagnostic can also run at certain fixed intervals.

Conditions for Setting the Fault Codes

The intake air heater circuit pulse width modulated (PWM) signal is detected to be greater than 0-VDC when the pulse width modulated (PWM) signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The intake air heater operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Intake air heater relay signal wire not connected to the relay
  • Intake air heater relay return wire not connected to the relay
  • Open circuit in the intake air heater relay signal wire
  • Open circuit in the intake air heater relay return wire
  • Intake air heater signal wire shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-2555.

Last Modified: 29-Oct-2015


Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2556

Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2556 PID: SPN: 729 FMI: 4 LAMP: Amber SRT: | Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the intake air heater signal circuit. | The intake air heaters can be ON or OFF all the time.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Air Heater 1 Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Intake Air Heater 1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions.

The engine control module (ECM) controls relays that switch power to the intake air heater. Air heaters on 12 volt systems will have two relays and 24 volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection to the intake manifold. The location of the intake air heater relays will vary by vehicle and engine configuration.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is activated. In some cases, the diagnostic can also run at certain fixed intervals.

Conditions for Setting the Fault Codes

The intake air heater circuit pulse width modulated (PWM) signal is not detected to be system voltage when the pulse width modulated (PWM) signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The intake air heater circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A shorted intake air heater relay
  • Intake air heater relay supply wire shorted to ground.
Refer to Troubleshooting Fault Code t05-2556.

Last Modified: 28-Oct-2015


VGT Actuator Controller - Bad Intelligent Device or Component

FAULT CODE 2634

VGT Actuator Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2634 PID: SPN: 641 FMI: 12/12 LAMP: Red SRT: | VGT Actuator Controller - Bad Intelligent Device or Component. An internal error has been detected by the smart variable geometry turbocharger controller. | Variable geometry turbocharger actuation will be disabled.
ISL9 CM2150 SN - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The VGT actuator has detected an internal error in the VGT smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • The VGT actuator will stop controlling the turbocharger.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. The diagnostic will clear at initial key ON if the error condition no longer exists.
  • The ECM will turn off the red STOP ENGINE lamp and enable VGT operation immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the VGT smart actuator detected an internal error within the VGT actuator. The VGT actuator will stop controlling the turbocharger when this fault code is active.

Fault Code 2634 will become active if the VGT actuator is removed from the turbocharger and then the keyswitch is turned to the ON position, or it may be possible for it to become active if the actuator fails the install/calibrate procedure. If this occurs, disconnect the VGT actuator from the engine harness with the keyswitch ON, and connect the VGT actuator to the engine harness. Fault Code 2634 should go inactive. Follow the VGT actuator installation procedure to install the VGT actuator.

Refer to Troubleshooting Fault Code t05-2634.

Last Modified: 30-Oct-2015


VGT Actuator Driver Circuit - Condition Exists

FAULT CODE 2635

VGT Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2635 PID: SPN: 641 FMI: 31 LAMP: Red SRT: | VGT Actuator Driver Circuit - Condition Exists. A calibration mismatch between the VGT actuator and the engine control module (ECM) has been detected. | VGT actuation will be disabled.
ISL9 CM2150 SN - Variable Geometry Turbocharger (VGT) Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary ECM. The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 datalink.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code can be activated for the following reasons:

  • The ECM has detected a calibration incompatibility between the VGT actuator and the ECM calibration.
  • The VGT actuator has detected that the system voltage is incorrect for the installed VGT actuator part number.
  • The ECM has detected an incorrect VGT actuator installed on the turbocharger.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. The diagnostic will clear at initial key-ON if the error condition no longer exists.
  • The ECM will turn off the red STOP ENGINE lamp and enable VGT operation immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the ECM has detected that an incorrect VGT actuator has been installed on the turbocharger.

Refer to Troubleshooting Fault Code t05-2635.

Last Modified: 30-Oct-2015


VGT Actuator Driver Circuit - Abnormal Update Rate

FAULT CODE 2636

VGT Actuator Driver Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2636 PID: SPN: 641 FMI: 9 LAMP: Red SRT: | VGT Actuator Driver Circuit - Abnormal Update Rate. No communications on the J1939 data link between the engine control module (ECM) and the smart VGT controller. | The VGT will move to the default open position.
ISL9 CM2150 SN - Variable Geometry Turbocharger (VGT) Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 datalink from the primary ECM. The VGT actuator performs its own diagnostics and reports failures back to the primary ECM with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The primary engine ECM does not receive a valid J1939 message from the VGT actuator for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. The diagnostic will clear immediately after a valid J1939 message is received from the VGT actuator.
  • The ECM will turn off the red STOP ENGINE lamp and enable VGT operation immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with the INSITE™ electronic service tool.

Shop Talk

Troubleshoot high inactive counts of Fault Code 2636 as an active fault code.

Possible causes of this fault code include:

  • The VGT actuator is not receiving power from the ECM. This can be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM.
  • An open return circuit on the VGT actuator circuit.
  • An open or short circuit on the J1939 data link circuit between the ECM and VGT actuator.
  • Intermittent communications between the VGT actuator and the primary engine ECM on the J1939 data link.
  • Rapid cycling of the keyswitch.
  • A damaged termination resistor in the engine data link harness.
  • A damaged engine ECM.
Refer to Troubleshooting Fault Code t05-2636.

Last Modified: 30-Oct-2015


Brake Inactivity - Condition Exists

FAULT CODE 2719

Brake Inactivity - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2719 PID: SPN: 520326 FMI: 11/31 LAMP: Amber SRT: | Brake Inactivity - Condition Exists. The engine control module has detected the vehicle has slowed down or stopped without the brakes being applied. | None on performance.
ECM

Circuit Description

The engine control module (ECM) monitors brake switches and vehicle speed. The ECM will set a fault when it has detected the vehicle speed is above a threshold for a period of time and has stopped twice without brake activity and cycling of the key switch.

Component Location

Refer to the equipment manufacturer information location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected the vehicle speed has been above 28 MPH for 5 minutes and has decreased to less than 2 MPH twice without brake activity.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails..

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city-type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the malfunction indicator lamp (MIL) for on-board diagnostics (OBD) applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning brake pedal position switch
  • A malfunctioning Vehicle Speed Sensor
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2719.

Last Modified: 12-Sep-2016


Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Abnormal Update Rate. No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Outlet NOx Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Outlet NOx Sensor Circuit
ISM11 CM876 SN - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine ECM via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment SCR catalyst. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM loses J1939 communications with the aftertreatment outlet NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurance.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment outlet NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This could be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the Aftertreatment Outlet NOx Sensor battery return.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.
  • Intermittent communications between the aftertreatment outlet NOx sensor and the primary engine ECM on the J1939 data link.
  • A damaged engine ECM.
Refer to Troubleshooting Fault Code 2771.

Last Modified: 28-Oct-2015


Fault Code Path Selection

FAULT CODE 120-fc2772
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc2772air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc2772airless

Last Modified: 29-Apr-2009


Fault Code Path Selection

FAULT CODE 120-fc2773
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc2773air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc2773airless

Last Modified: 29-Apr-2009


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Engine coolant temperature is above the engine coolant temperature engine protection warning limit. | Power derate and possible engine shutdown if the engine protection shutdown feature is enabled.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Coolant Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Engine Coolant Temperature Sensor Circuit
ISM11 CM876 SN - Engine Coolant Temperature Sensor Circuit
ISZ13 CM2150 - Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and for engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE and the torque derate will be removed immediately after the engine coolant temperature drops below a calibratible limit set in the ECM and the diagnostic runs and passes.

The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code t05-2963.

Last Modified: 28-Oct-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Manifold 1 Pressure/Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Pressure/Temperature Sensor Circuit
ISM11 CM876 SN - Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

The maximum torque output of the engine will return and the fault code will go inactive after the intake manifold temperature drops below a calibratible limit set in the ECM.

The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Plugged charge air cooler fins
  • Restricted airflow through the charge air cooler
  • An undersized charge air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2964.

Last Modified: 28-Oct-2015


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P106 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect. The intake manifold pressure sensor is reading an erratic value at initial key ON or while the engine is running. | Malfunction indicator lamp (MIL) and engine protection derate will occur.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Intake Manifold 1 Pressure/Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Intake Manifold 1 Pressure/Temperature Sensor Circuit
ISM11 CM876 SN - Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

Component Location

The intake manifold pressure/temperature 1 sensor is located in the air intake manifold.

The barometric pressure sensor can be externally mounted on the engine or can be an internal component within the ECM. Check engine wiring diagram for circuit details.

Conditions for Running the Diagnostics

This ECM diagnostic runs in two parts consisting of three separate conditions without keying off between steps:

1. Key ON - Part 1 of this diagnostic runs a sensor rationality check when the keyswitch is initially turned on. If the fault code became active at key ON only, it has failed the first check.

2. Operation - Part 2 of this diagnostic will run a pressure rationality check when the engine is running under normal conditions. The diagnostic runs a check at the following conditions:

  • >1500 rpm at 100 percent load, for 25 non-consecutive seconds.
  • <2000 rpm while motoring for 25 non-consecutive seconds with a charge-air pressure < 140kPa or 150kPa depending upon the specific ECM calibration.
  • Exhaust brake must be disabled at all times or the diagnostic will not run.

Service tips:

  • If the key ON has malfunctioned, only the key ON rationality needs to be run.
  • If the fault code became active at >1500 rpm and under load, only the >1500 rpm condition needs to be completed.
  • If the fault code became active at <2000 rpm while motoring, only the <2000 rpm motoring condition needs to be completed.

Check the ECM job image and fault code snapshot window in INSITE™ electronic service tool to see if the fault code flagged while the engine was running or at key ON. Check the load or motoring condition to help determine which part malfunctioned.

Conditions for Setting the Fault Codes

This diagnostic checks the value of the intake manifold pressure sensor at key ON and while the engine is running. If the value of the intake manifold pressure is not reading ambient pressure at key ON or is higher or lower than expected during normal engine operation, this fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MIL immediately when the diagnostic runs and fails ONE trip.
  • A significant engine de-rate will occur immediately to default OFC fuelling tables to protect the engine from damage.

Conditions for Clearing the Fault Code

  • Run the ECM diagnostic as described above.
  • Once the diagnostic has completed, the fault code will go inactive if it passes.
  • As soon as the diagnostic has completed and passed one trip, the MIL will go out immediately.
  • Once the fault code is inactive, use the “clear all faults” command from the latest version of INSITE™ electronic service tool.

Shop Talk

This diagnostic consists of two parts. At key ON, before the engine starts, the sensor readings for intake manifold pressure, barometric air pressure, and exhaust gas pressure are compared to each other. This fault code occurs if the intake manifold pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned ON. This fault can also be set active when the intake manifold pressure is too high or low for the present engine operating conditions when the engine is running. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault are:

  • A damaged intake manifold pressure sensor
  • A damaged barometric pressure sensor
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Restriction in the charge-air cooler
  • A damaged turbocharger speed sensor
  • A damaged turbocharger compressor intake temperature sensor
  • A damaged engine wiring harness can cause intermittent fault codes due to intermittent resistances. Check the wiring diagram for shared supply and return circuit on sensors. It is possible that more than one sensor could be reading incorrectly if a common supply/ground problem exists in the circuit. Use INSITE™ electronic service tool to log any fluctuation in sensor voltage/values when the harness is moved.

NOTE: In the guided steps for Fault Code 2973, gauge pressure may need to be converted to absolute pressure, depending on the engine you are troubleshooting.

Barometric pressure is approximately 29.92 in-Hg at sea level. (Absolute Pressure)

  • The intake manifold pressure is approximately 0 in-Hg when the engine is not running. (Gauge Pressure)
  • 29.92 in-Hg = 1 atmosphere = 1.013 bar

Example: If the barometric (Absolute) pressure sensor reads 31 in-Hg and the intake manifold (Gauge) pressure reads -5 in-Hg then the difference can be calculated as follows:

1. Convert the intake manifold (Gauge) pressure to Absolute pressure = (-5 + 29) = 24 in-Hg.

2. Subtract the new 24 in-Hg value from the original barometric value of 31 in-Hg. (31 – 24) =7

3. The difference is 7 in-Hg. 7 in-Hg is greater than the specification of 3 in-Hg in the troubleshooting steps and will cause the fault to become active.

4. Use the Barometric Pressure at Altitude table in the following procedure to help understand ambient pressure at different altitudes. Refer to Procedure 018-028 in Section V.

Refer to Troubleshooting Fault Code t05-2973.

Last Modified: 03-Nov-2015


Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2976

Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2976 PID: SPN: 3361 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect. An internal error has been detected in the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ ISL9 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature Circuit

Circuit Description

For an air assisted SCR system, the aftertreatment diesel exhaust fluid dosing unit communicates important system operating information (including dosing unit internal temperature) to the primary engine electronic control module (ECM) via the J1939 data link network.

For an airless SCR system, the dosing unit reports its internal temperature to the diesel exhaust fluid controller via the dosing unit signal wire, and the diesel exhaust fluid controller communicates this information to the primary engine electronic control module (ECM ) via the J1939 data link network.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual for component location information.

Conditions for Running the Diagnostics

The engine and keyswitch must be turned off for a period of 8 hours before this diagnostic will run. After an 8 hour cold soak, start and operate the engine at idle for 1 minute to run this diagnostic.

Conditions for Setting the Fault Codes

The ECM detects that the temperature reported by the aftertreatment diesel exhaust fluid dosing unit internal temperature sensor does not agree with other temperature sensors on the engine for two consecutive ignition cycles in which the diagnostic runs.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute to run the diagnostic.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Fault code 2976 is triggered when the aftertreatment diesel exhaust fluid dosing unit internal temperature sensor is reading a different value than the other temperature sensors on the engine. This indicates a problem with the internal temperature sensor of the diesel exhaust fluid dosing unit. The 8 hour cold soak is required for the diagnostic to run so that the different temperature sensors can equalize at ambient temperature.

Refer to Troubleshooting Fault Code 2976.

Last Modified: 30-Oct-2015


Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3139

Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3139 PID: SPN: 3667 FMI: 3/3 LAMP: Amber SRT: | Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the air shutoff circuit. | The engine air shutoff valve will be disabled.
Engine Air Shutoff Circuit

Circuit Description

The engine air shutoff valve is an original equipment manufacturer (OEM) installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the engine control module (ECM) supplies 12 VDC to the air shutoff solenoid. This solenoid then supplies air to the air shutoff valve and activates the valve, closing a plate over the intake.

Component Location

The engine air shutoff valve location can vary, depending on the OEM. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine air shutoff driver is shorted to voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a keycycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for On-Board Diagnostics applications..

Shop Talk

Possible causes of this fault code include:

  • Open engine air shutoff circuit
  • Short circuit to voltage in the engine air shutoff circuit
  • Malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-3139.

Last Modified: 30-Sep-2014


Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3141

Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3141 PID: P102 SPN: 3667 FMI: 4/4 LAMP: Amber SRT: | Engine Air Shutoff Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine air shutoff circuit. | The engine air shutoff valve will be disabled.
Engine Air Shutoff Sensor Circuit

Circuit Description

The air shutoff valve is an original equipment manufacturer (OEM) installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the engine control module (ECM) supplies 12 VDC to the air shutoff solenoid. This solenoid then supplies air to the air shutoff valve and activates the valve, closing a plate over the intake.

Component Location

The engine air shutoff valve location can vary depending on the OEM. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine air shutoff driver is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguished the MIL of On-Board Diagnostics applications.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to ground in the engine air shutoff circuit
  • Malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-3141.

Last Modified: 30-Sep-2014


Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3142

Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3142 PID: SPN: 4360 FMI: 3 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the SCR intake temperature sensor circuit. | Default temperature value used for SCR intake temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Intake Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment SCR Intake Temperature Sensor Circuit
ISM11 CM876 SN - Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the intake of the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the SCR intake temperature sensor signal voltage is above a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value for the aftertreatment SCR intake temperature is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 3142.

Last Modified: 28-Oct-2015


Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3143

Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3143 PID: SPN: 4360 FMI: 4 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the SCR intake temperature sensor circuit. | Default temperature value used for SCR intake temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Intake Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment SCR Intake Temperature Sensor Circuit
ISM11 CM876 SN - Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the exhaust aftertreatment system. It is located between the turbocharger outlet and the intake of the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the SCR intake temperature sensor signal voltage is below a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value for the aftertreatment SCR intake temperature is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 3143.

Last Modified: 02-Nov-2015


Aftertreatment SCR Intake Temperature - Data Erratic, Intermiitent, or Incorrect

FAULT CODE 3144

Aftertreatment SCR Intake Temperature - Data Erratic, Intermiitent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3144 PID: SPN: 4360 FMI: 2 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature - Data Erratic, Intermiitent, or Incorrect.. The SCR intake temperature sensor is not changing with engine operating conditions. | Default temperature value used for SCR intake temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Intake Temperature Sensor
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment SCR Intake Temperature Sensor
ISM11 CM876 SN - Aftertreatment SCR Intake Temperature Sensor

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the exhaust aftertreatment system. It is located between the turbocharger outlet and the intake of the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

  • This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 60°C [140°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

  • This fault code is logged if the value of the SCR catalyst intake temperature sensor does not match the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value for the aftertreatment SCR intake temperature is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range SCR intake temperature sensor
  • High resistance in the SCR intake temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code 3144.

Last Modified: 27-Oct-2015


Aftertreatment SCR Intake Temperature Sensor - Abnormal Rate of Change

FAULT CODE 3145

Aftertreatment SCR Intake Temperature Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 4360 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor - Abnormal Rate of Change. The SCR catalyst intake temperature sensor is not responding to a change in engine operating conditions. | Default temperature value used for SCR catalyst intake temperature.
ISM11 CM876 SN - Aftertreatment SCR Intake Temperature Sensor

Circuit Description

The SCR catalyst intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR catalyst intake temperature sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the catalyst unit intake in the exhaust system.

Conditions for Running the Diagnostics

The engine and keyswitch must be turned off for period of 8 hours before this diagnostic will run. This diagnostic will only run during engine warm up. After an 8 hour cold soak, start and operate the engine until the normal operating temperatures are reached.

Conditions for Setting the Fault Codes

The ECM detects that the SCR catalyst intake temperature is not changing to match engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the MIL immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated after 36 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Refer to the "Conditions for Running the Diagnostic" section for instructions on running the diagnostic.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from memory after the completion of 40 warm-up cycles.

Shop Talk

The SCR catalyst intake temperature sensor is monitored during engine warm-up. If the SCR catalyst outlet temperature reading is not changing to match the engine operating conditions, the SCR catalyst outlet temperature sensor is then determined to be stuck in-range and this fault code is logged.

Possible causes of this fault code include:

  • Stuck in-range SCR catalyst intake temperature sensor reading
  • High resistance in the SCR catalyst intake temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code 3145.

Last Modified: 24-Jun-2010


Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3146

Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3146 PID: SPN: 4363 FMI: 3 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the SCR outlet temperature sensor circuit. | Default temperature value used for SCR outlet temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Outlet Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment SCR Outlet Temperature Sensor Circuit
ISM11 CM876 SN - Aftertreatment SCR Outlet Temperature Sensor Circuit

Circuit Description

The SCR outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the exhaust aftertreatment system. It is located in the outlet of the SCR catalyst.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The ECM detects that the SCR outlet temperature sensor signal voltage is above a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value for the aftertreatment SCR outlet temperature is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The SCR outlet temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 3146.

Last Modified: 27-Oct-2015


Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3147

Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3147 PID: SPN: 4363 FMI: 4 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the SCR outlet temperature sensor circuit. | Default temperature used for SCR outlet temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Outlet Temperature Sensor Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment SCR Outlet Temperature Sensor Circuit
ISM11 CM876 SN - Aftertreatment SCR Outlet Temperature Sensor Circuit

Circuit Description

The SCR outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature exiting the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the exhaust aftertreatment system. It is located in the outlet of the SCR catalyst.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The ECM detects that the SCR outlet temperature sensor signal voltage is below a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value for the aftertreatment SCR outlet temperature is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurance.

Shop Talk

The SCR outlet temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 3147.

Last Modified: 27-Oct-2015


Aftertreatment SCR Outlet Temperature Sensor - Abnormal Rate of Change

FAULT CODE 3149

Aftertreatment SCR Outlet Temperature Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 4363 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor - Abnormal Rate of Change. The SCR catalyst outlet temperature sensor is not responding to a change in engine operating conditions. | Default temperature value used for SCR catalyst outlet temperature.
ISM11 CM876 SN - Aftertreatment SCR Outlet Temperature Sensor
ISZ13 CM2150 - Aftertreatment SCR Outlet Temperature Sensor

Circuit Description

The SCR catalyst outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR catalyst outlet temperature sensor is located in the aftertreatment system. It is located in the outlet of the SCR catalyst unit.

Conditions for Running the Diagnostics

The engine and keyswitch must be turned off for period of 8 hours before this diagnostic will run. This diagnostic will only run during engine warm up. After an 8 hour cold soak, start and operate the engine until the normal operating temperatures are reached.

Conditions for Setting the Fault Codes

The ECM detects that the SCR catalyst outlet temperature is not changing to match engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the MIL immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated after 36 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Refer to the "Conditions for Running the Diagnostic" section for instructions on running the diagnostic.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from memory after the completion of 40 warm-up cycles.

Shop Talk

The SCR catalyst outlet temperature sensor is monitored during engine warm-up. If the SCR catalyst outlet temperature reading is not changing to match the engine operating conditions, the SCR catalyst outlet temperature sensor is then determined to be stuck in-range and this fault code is logged.

Possible causes of this fault code include:

  • Stuck in-range SCR catalyst outlet temperature sensor reading
  • High resistance in the SCR catalyst outlet temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code 3149.

Last Modified: 24-Jun-2010


Aftertreatment SCR Catalyst System Missing - Condition Exists

FAULT CODE 3151

Aftertreatment SCR Catalyst System Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3151 PID: SPN: 4794 FMI: 31 LAMP: Amber SRT: | Aftertreatment SCR Catalyst System Missing - Condition Exists. The aftertreatment SCR catalyst in the exhaust system is not present. | Diesel exhaust fluid solution injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Catalyst System Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment SCR Catalyst System Circuit

Circuit Description

The aftertreatment selective catalytic reduction (SCR) catalyst is monitored by SCR intake and SCR outlet temperature sensors that are located in the aftertreatment system. The intake temperature sensor is located before the catalyst and the outlet temperature sensor is located at the outlet of the catalyst system.

Component Location

The SCR catalyst is located in the exhaust system. The location of the SCR catalyst can vary depending on the original equipment manufacturer (OEM). Refer to the OEM service manual for detailed engine and component identification.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak. The SCR catalyst intake and outlet temperature sensors must be reading ambient temperature. If the SCR catalyst temperature is above 38°C [100°F], or the SCR catalyst temperature sensors have a difference of more than 5.5°C or 10°F, the diagnostics will not run.

Conditions for Setting the Fault Codes

This fault code becomes active when the SCR intake and outlet temperature sensors do not detect the presence of an SCR catalyst in the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, refer to the "Conditions for Running the Diagnostic" section for instructions on running the diagnostic.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Incorrect calibration revision on INCAL™ CD
  • Tampering with the catalyst system, removal of the catalyst from vehicle, or a malfunctioning catalyst.
Refer to Troubleshooting Fault Code 3151.

Last Modified: 28-Oct-2015


Aftertreatment SCR Intake Temperature Sensor Swapped - Out of Calibration

FAULT CODE 3163

Aftertreatment SCR Intake Temperature Sensor Swapped - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3163 PID: SPN: 4360 FMI: 13 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction (SCR) Intake Temperature Sensor Swapped - Out of Calibration. The SCR intake and outlet temperature sensor connections are swapped. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Intake Temperature Sensor
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment SCR Intake Temperature Sensor
ISM11 CM876 SN - Aftertreatment SCR Intake Temperature Sensor

Circuit Description

The SCR temperature sensors are used to monitor the temperatures of the exhaust gas entering and exiting the SCR catalyst.

Component Location

The SCR intake and outlet exhaust temperature sensors are located in the aftertreatment system. The intake temperature sensor is located before the SCR catalyst and the outlet temperature sensor is located at the outlet of the SCR catalyst.

Conditions for Running the Diagnostics

The engine must be turned off for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The engine control module (ECM) determines that the temperature readings from the SCR intake and outlet temperature sensors are swapped.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute to run the diagnostic.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • This fault code can also be cleared with INSITE ™electronic service tool.

Shop Talk

Possible Causes for this fault code:

  • The SCR inlet and outlet sensors are swapped.
  • The harness connectors to the SCR inlet and outlet sensors are swapped.

The catalyst temperature sensors must be reading ambient temperature and the engine must be off for a period of 8 hours before this diagnostic will run.

Refer to Troubleshooting Fault Code 3163.

Last Modified: 27-Oct-2015


Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3164

Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3164 PID: SPN: 4360 FMI: 15 LAMP: None SRT: | Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. High selective catalytic reduction (SCR) intake temperature has been detected. | Possible engine derate.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Intake Temperature Sensor
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Aftertreatment SCR Intake Temperature Sensor
ISL9 CM2150 SN - Aftertreatment SCR Intake Temperature Sensor
ISM11 CM876 SN - Aftertreatment SCR Intake Temperature Sensor

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst intake is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is triggered when the temperature at the SCR intake exceeds the maximum allowable temperature for a given engine rating.

Refer to Troubleshooting Fault Code t05-3164.

Last Modified: 28-Oct-2015


Tachograph Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3186

Tachograph Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3186 PID: SPN: 1623 FMI: 9/9 LAMP: Amber SRT: | Tachograph Output Shaft Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the tachograph output shaft speed sensor. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Configuration
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Configuration
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexing Configuration
ISM11 CM876 SN - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Component values and states from components such as sensors, accelerators, and switches can then be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins Inc. ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU, or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-3186.

Last Modified: 02-Nov-2015


Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3236

Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3236 PID: SPN: 4363 FMI: 16 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High SCR outlet temperature has been detected. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment SCR Outlet Temperature Sensors
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment SCR Outlet Temperature Sensors
ISM11 CM876 SN - Aftertreatment SCR Outlet Temperature Sensors

Circuit Description

The selective catalytic reduction (SCR) outlet gas temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust gas temperature exiting the catalyst. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value.

Component Location

The SCR outlet exhaust gas temperature sensor is located in the exhaust aftertreatment system. It is located at the outlet of the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst outlet is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault is triggered when the temperature at the SCR catalyst outlet exceeds the maximum allowable temperature for a given engine rating.

Refer to Troubleshooting Fault Code 3236.

Last Modified: 27-Oct-2015


Fault Code Path Selection

FAULT CODE 120-fc3237
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc3237air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc3237airless

Last Modified: 29-Oct-2009


Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3238

Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3238 PID: SPN: 4340 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid line heater 1 relay circuit. | Diesel exhaust fluid line heater 1 will be disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 1 is controlled by the ECM, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the aftertreatment nozzle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the heater is commanded ON.

Conditions for Setting the Fault Codes

The ECM detects that the line heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded on for the diagnostic to run and the fault to go inactive.
  • Use the INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests".
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with the INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Malfunctioning line heater relay
  • Short circuit to ground in the OEM harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 3238.

Last Modified: 27-Oct-2015


Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3239

Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3239 PID: SPN: 4342 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 2 circuit. | Diesel exhaust fluid line heater 2 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 2 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the diesel exhaust fluid line heater power relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the dosing unit and the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the heater is commanded on.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust controller detects that the line heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded on for the diagnostic to run and the fault to go inactive. Use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests".
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid contoller.
Refer to Troubleshooting Fault Code 3239.

Last Modified: 07-Sep-2009


Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3242

Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3242 PID: SPN: 3363 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment. The aftertreatment diesel exhaust fluid temperature did not increase when the aftertreatment diesel exhaust fluid tank heater was commanded on. | None on performance. Diesel exhaust fluid injection into the aftertreatment system will be disabled if the aftertreatment diesel exhaust fluid is frozen.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the vehicle original equipment manufacturer (OEM). The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a short time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater is commanded on by the engine electronic control module (ECM), but no corresponding temperature increase in the aftertreatment diesel exhaust fluid tank temperature was recorded by the tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, the system must start a diesel exhaust fluid tank heating cycle and see an initial temperature rise in the diesel exhaust fluid tank.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restricitons in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller is unable to command tank heating.
Refer to Troubleshooting Fault Code 3242.

Last Modified: 02-Nov-2015


Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3258

Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3258 PID: S254 SPN: 4340 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit. Open circuit or short circuit to ground detected in the diesel exhaust fluid line heater 1. | Diesel exhaust fluid line heater 1 will be disabled.
ISF2.8 CM2220 AN/ ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 1 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater circuit is open or shorted to ground.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded on for the diagnostic to run and the fault to go inactive.
  • Use the INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests".
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater
  • Open circuit, short circuit to ground, or a blown fuse in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3258.

Last Modified: 24-Jun-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3261

Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3261 PID: S254 SPN: 4342 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit. Open circuit or short circuit to ground detected in the diesel exhaust fluid line heater 2. | Diesel exhaust fluid line heater 2 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 2 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the diesel exhaust fluid dosing unit and diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater circuit is open or shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded ON for the diagnostic to run and the fault to go inactive.
  • Use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests".
  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will go inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater
  • Open circuit, short circuit to ground, or a blown fuse in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid contoller.
Refer to Troubleshooting Fault Code 3261.

Last Modified: 10-Sep-2009


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

FAULT CODE 3326

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3326 PID: SPN: 91 FMI: 9 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate. The enigne control module (ECM) expected information from a multiplexed accelerator pedal or lever sensor but did not receive it soon enough or did not receive it at all. | Engine will only idle.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Control Module
ISM11 CM876 SN - Engine Control Module

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine ECM directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECU's or transmission ECU's are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the multiplexed accelerator pedal or lever sensor for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, bad OEM VECU or malfunctioning Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.
  • It is possible to use INSITE™ electronic service tool to monitor multiplexed components.
Refer to Troubleshooting Fault Code t05-3326.

Last Modified: 02-Nov-2015


Transmission Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3328

Transmission Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3328 PID: SPN: 191 FMI: 9/9 LAMP: Amber SRT: | Transmission Output Shaft Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the engine control module (ECM) and the transmission output shaft speed sensor. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Configuration
ISF2.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexing Configuration
ISM11 CM876 SN - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the ECM directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and are used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM didn't receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for on board diagnostic (OBD) applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-3328.

Last Modified: 02-Nov-2015


Engine Exhaust Gas Recirculation System - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3382

Engine Exhaust Gas Recirculation System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3382 PID: SPN: 3058 FMI: 18 LAMP: Amber SRT: | Engine Exhaust Gas Recirculation System - Data Valid But Below Normal Operating Range - Moderately Severe Level. Measured exhaust gas recirculation (EGR) flow is lower than commanded. | Possible reduced engine performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Exhaust Gas Recirculation System

Circuit Description

The engine control module (ECM) uses the EGR differential pressure sensor reading to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. The EGR differential pressure sensor measures the pressure drop across the EGR differential pressure orifice using two exhaust ports. The sensor outputs a voltage, which represents the pressure difference between the two ports, and the ECM correlates that voltage to an EGR flow rate. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

Component Location

The EGR differential pressure sensor is located near the fuel inlet to the integrated fuel system module. A high EGR differential pressure tube and a low EGR differential pressure tube extend from the EGR differential pressure orifice and connect to the EGR differential pressure sensor. The high EGR differential pressure tube connects to the EGR connection tube rearward of the EGR differential pressure orifice and connects to the front port of the EGR differential pressure sensor. The low EGR differential pressure tube connects to the EGR connection tube frontward of the EGR differential pressure orifice and connects to the rear port of the EGR differential pressure sensor.

Conditions for Running the Diagnostics

This diagnosic runs when the engine is operating and the engine is commanding EGR flow. The EGR valve position can be monitored using the INSITE™ electronic service tool.

Conditions for Setting the Fault Codes

The ECM determines that the actual EGR flow is lower than what is being commanded based on the current engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or MIL immediately when the diagnostic runs and fails for two consecutive drive cycles.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine for at least 5 minutes. The vehicle may need to be driven for a short distance so that enough EGR flow is being commanded to perform the diagnostic.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Leaks or restrictions in the EGR flow plumbing
  • Internally leaking EGR valve
  • Stuck closed EGR valve
  • Malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-3382.

Last Modified: 26-Apr-2012


Engine Exhaust Gas Recirculation System - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3383

Engine Exhaust Gas Recirculation System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3383 PID: P411 SPN: 3058 FMI: 0/16 LAMP: Amber SRT: | Engine Exhaust Gas Recirculation System - Data Valid But Above Normal Operating Range - Moderately Severe Level. Measured exhaust gas recirculation (EGR) flow is higher than commanded. | Possible reduced engine performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Exhaust Gas Recirculation Valve

Circuit Description

The engine control module uses the mass air flow sensor reading and calculated charge flow to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. The engine control module then compares the calculated EGR flow with the commanded EGR flow in order to control the EGR valve for correct emission levels.

Component Location

The EGR valve is located toward the rear of the engine on the exhaust side. The EGR cross over tube connects the EGR valve to the intake manifold, and crosses over the top of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating and no EGR flow is being commanded. The EGR valve position can be monitored using INSITE™ electronic service tool.

Conditions for Setting the Fault Codes

The engine control module determines that the fresh air flow is not equal to the charge flow, which means that the EGR flow is higher than expected.

Action Taken When the Fault Code is Active

The engine control module illuminates the amber CHECK ENGINE lamp and/or MIL immediately when the diagnostic runs and fails. The engine will continue to try to meet the EGR flow targets.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the engine control module determines that the commanded EGR flow target is being met.
  • Start and idle the engine.
  • The engine control module will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The engine control module will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with the INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault are:

  • Malfunctioning intake throttle actuator
  • Leaking EGR valve
  • Damaged mass air flow sensor failure.
Refer to Troubleshooting Fault Code t05-3383.

Last Modified: 26-Apr-2012


Transmission Output Shaft Speed - Received Network Data In Error

FAULT CODE 3418

Transmission Output Shaft Speed - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3418 PID: SPN: 191 FMI: 19 LAMP: Amber SRT: | Transmission Output Shaft Speed - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor. | None on performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Configuration
ISF2.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexing Configuration
ISM11 CM876 SN - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the key switch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines that there is a malfunction of the transmission output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for on board diagnostic (OBD) applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor.

Refer to Troubleshooting Fault Code t05-3418.

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3422

Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3422 PID: SPN: 4344 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 3 circuit. | Diesel exhaust fluid line heater 3 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 3 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the heater is commanded on.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded on for the diagnostic to run and the fault to go inactive. Use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests".
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid contoller.
Refer to Troubleshooting Fault Code 3422.

Last Modified: 07-Sep-2009


Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3425

Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3425 PID: S254 SPN: 4344 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit. Open circuit or short circuit to ground detected in the diesel exhaust fluid line heater 3. | Diesel exhaust fluid line heater 3 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 3 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater circuit is open or shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded on for the diagnostic to run and the fault to go inactive.
  • Use the INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests".
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater
  • Open circuit, short circuit to ground, or a blown fuse in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3425.

Last Modified: 10-Sep-2009


Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3426

Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3426 PID: SPN: 4346 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 4 circuit. | Diesel exhaust fluid line heater 4 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 4 is powered and controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater 4 is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the heater is commanded on.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated
  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded on for the diagnostic to run and the fault to go inactive. Perform a key cycle, and start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater internal to the dosing unit
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid contoller.
Refer to Troubleshooting Fault Code 3426.

Last Modified: 07-Sep-2009


Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3429

Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3429 PID: S254 SPN: 4346 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Current Below Normal or Open Circuit. Open circuit or short circuit to ground detected in the diesel exhaust fluid line heater 4. | Diesel exhaust fluid line heater 4 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 4 is powered and controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater 4 is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the heater circuit is open.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, a key cycle is required in order to get the diagnostic to run again and make the fault go inactive.
  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will go inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater internal to the dosing unit.
  • Open circuit or short circuit to ground in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3429.

Last Modified: 07-Sep-2009


Real Time Clock - Abnormal Rate of Change

FAULT CODE 3492

Real Time Clock - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3492 PID: SPN: 251 FMI: 10 LAMP: Amber SRT: | Real Time Clock - Abnormal Rate of Change. The real time clock indicates a stuck engine off timer. | None on performance.
ISB4.5, ISB6.7, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Control Module

Circuit Description

The real-time clock consists of a timing chip internal to the engine control module (ECM) which monitors engine off time, i.e. how long the engine has been shut down.

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs after initial key-on and takes approximately 15 minutes to complete.

Conditions for Setting the Fault Codes

The engine off timer is not counting correctly and does not match other timers in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will not be able to monitor engine off time accurately.

Conditions for Clearing the Fault Code

  • To validate the repair, key-off for 1 minute, then key-on for 15 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with the INSITE™ electronic service tool.

Shop Talk

Monitoring the engine off time is necessary in order to make sure that all other engine sensors and actuators are performing correctly. If the ECM is recalibrated or replaced during the repair and the fault code is no longer present, the instructions in the "Conditions for Clearing" section must be followed in order for the diagnostic to run again and validate the repair.

Potential causes of this fault code include:

  • Failed real time clock chip internal to the ECM
  • Engine calibration issue
Refer to Troubleshooting Fault Code t05-3492.

Last Modified: 29-Oct-2015


Wheel-Based Vehicle Speed - Received Network Data In Error

FAULT CODE 3525

Wheel-Based Vehicle Speed - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3525 PID: SPN: 84 FMI: 19 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor. | Engine speed limited to maximum engine speed without vehicle speed sensor (VSS) parameter value. Cruise control, gear-down protection, and road speed governor will not work.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Configuration
ISF2.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexing Configuration
ISM11 CM876 SN - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the wheel-based vehicle speed sensor.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for on board diagnostic (OBD) applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM power distribution center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code t05-3525.

Last Modified: 02-Nov-2015


Wheel-Based Vehicle Speed - Abnormal Update Rate

FAULT CODE 3526

Wheel-Based Vehicle Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3526 PID: SPN: 84 FMI: 9 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the wheel-based vehicle speed sensor. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Configuration
ISF2.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexing Configuration
ISM11 CM876 SN - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the key switch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Possible causes of this fault code include:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, a bad OEM VECU, or a bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-3526.

Last Modified: 02-Nov-2015


Accelerator Pedal or Lever Idle Validation Switch - Received Network Data In Error

FAULT CODE 3527

Accelerator Pedal or Lever Idle Validation Switch - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3527 PID: P91 SPN: 558 FMI: 19 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Switch - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch. | The engine will only idle.
QSX15 CM2250 ECF/QSX11.9 CM2250 ECF/QSB6.7 CM2250/QSL9 CM2250 - Accelerator Pedal or Lever Idle Validation Switch

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM Vehicle Electronic Control Unit (VECU) or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswith is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines that there is a malfunction fo the accelerator pedal or lever idle validation switch.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch.

Refer to Troubleshooting Fault Code t05-3527.

Last Modified: 19-May-2015


Ambient Air Temperature - Received Network Data In Error

FAULT CODE 3532

Ambient Air Temperature - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3532 PID: SPN: 171 FMI: 19/19 LAMP: Amber SRT: | Ambient Air Temperature - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the ambient air temperature sensor. | Diesel exhaust fluid injection into the aftertreatment system may be disabled.
ISM11 CM876 SN - J1939 Multiplexing

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® ECM over the Society of Automotive Engineers (SAE) J1939 data link. Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® ECM and used for controlling the engine. The Cummins Inc. ECM and OEM VECU must be configured correctly so proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. See equipment manufacturer service information for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the key switch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines there is a malfunction of the ambient air temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the ambient air temperature sensor.

See the appropriate OEM wiring diagram when troubleshooting circuits utilizing wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM power distribution center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 3532.

Last Modified: 02-Mar-2015


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3539

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3539 PID: SPN: 51 FMI: 3 LAMP: Amber SRT: | Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine intake throttle actuator position sensor circuit. | Possible low power. Power will be removed from the engine intake throttle actuator motor.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Intake Throttle Actuator Position Sensor Circuit

Circuit Description

The engine control module uses the engine intake throttle actuator position sensor to determine whether or not the actuator is meeting the commanded position. The engine control module supplies 5 Volts to the engine intake throttle actuator position signal circuit, and the engine throttle actuator position sensor outputs a voltage signal to the engine control module based on the actuator position. The engine control module converts this signal into a percentage value, 0 to 100, indicating actuator position. A fully open actuator is equivalent to 100 percent.

Component Location

The engine throttle actuator position sensor is internal to the engine throttle actuator assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The engine control module detects that the engine throttle actuator position sensor signal voltage is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The engine control module illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine intake throttle actuator operation will be disabled, and the intake throttle actuator will be opened.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the on position for 1 minute. The intake throttle actuator will perform an auto-zero immediately after key-on.
  • The engine control module will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The engine control module will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open return in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply
  • Malfunctioning intake throttle actuator position sensor
  • Malfunctioning engine control module.

NOTE: Do not supply 12-VDC the intake throttle actuator position sensor, or short the intake throttle actuator motor wires to the intake throttle actuator position sensor. The intake throttle actuator position sensor and at 5-VDC, and sensor damage can occur.

Refer to Troubleshooting Fault Code t05-3539.

Last Modified: 26-Apr-2012


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3541

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3541 PID: SPN: 51 FMI: 4 LAMP: Amber SRT: | Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine intake throttle actuator position sensor circuit. | Possible low power. Power will be removed from the engine intake throttle actuator motor.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Intake Throttle Actuator Position Sensor Circuit

Circuit Description

The engine control module uses the engine intake throttle actuator position sensor to determine whether or not the actuator is meeting the commanded position. The engine control module supplies 5 volts to the engine intake throttle actuator position signal circuit, and the engine intake throttle actuator position sensor outputs a voltage signal to the engine control module based on the actuator position. The engine control module converts this signal into a percentage value, 0 to 100, indicating actuator position. A fully open actuator is equivalent to 100 percent.

Component Location

The intake throttle actuator position sensor is internal to the intake throttle actuator assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module detects that the engine intake air throttle actuator position sensor signal voltage is less than a calibratible value.

Action Taken When the Fault Code is Active

  • The engine control module illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Intake air throttle actuator operation will be disabled, and the intake air throttle actuator will be opened.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the on position for 1 minute. The intake throttle actuator will perform an auto-zero immediately after key-on.
  • The engine control module will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The engine control module will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault code include:

  • SIGNAL circuit open or shorted to ground
  • SUPPLY circuit open or shorted to ground
  • Sensor shorted to ground.

NOTE: Do not supply 12-VDC to the intake throttle actuator position sensor, or short the intake throttle actuator motor wires to the intake throttle actuator position sensor. The intake throttle actuator position sensor is rated at 5-VDC, and sensor damage can occur.

Refer to Troubleshooting Fault Code t05-3541.

Last Modified: 26-Apr-2012


Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3542

Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3542 PID: SPN: 51 FMI: 2 LAMP: Amber SRT: | Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect. An erratic value is being reported by the engine intake throttle actuator position sensor, or the engine intake throttle actuator position is not changing with engine operating conditions. | Possible reduced engine performance.
ISF2.8 CM2220/ISF2.8 CM2220 EC - Engine Intake Throttle Actuator Position Sensor

Circuit Description

The engine control module (ECM) uses the engine intake throttle actuator position sensor to determine whether or not the actuator is meeting the commanded position. The ECM supplies 5 volts to the engine intake throttle actuator position signal circuit, and the engine intake throttle actuator position sensor outputs a voltage signal to the ECM based on the actuator position. The ECM converts this signal into a percentage value, 0 to 100, indicating actuator position. A fully open actuator is equivalent to 100 percent.

Component Location

The engine intake throttle actuator position sensor is internal to the intake throttle actuator assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine intake throttle actuator position sensor is reporting an erratic value, or the intake throttle actuator position is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Intake air throttle actuator operation will be disabled and the intake air throttle actuator will be opened.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute. The intake throttle actuator will perform an auto-zero immediately after key-on.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Frozen, plugged, or restricted engine intake air throttle
  • Intermittent open or short in the wiring harness
  • Malfunctioning intake throttle actuator position sensor
  • Malfunctioning ECM
  • Sticky or broken intake throttle actuator.

NOTE: Do not supply 12V to the intake throttle actuator position sensor, or short the intake throttle actuator motor wires to the intake throttle actuator position sensor. The intake throttle actuator position is rated at 5V, and sensor damage can occur.

Refer to Troubleshooting Fault Code t05-3542.

Last Modified: 05-Nov-2014


Aftertreatment Diesel Exhaust Fluid Dosing Unit Loss of Prime - Condition Exists

FAULT CODE 3548

Aftertreatment Diesel Exhaust Fluid Dosing Unit Loss of Prime - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3548 PID: SPN: 5392 FMI: 31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Loss of Prime - Condition Exists. The dosing unit is unable to prime. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Dosing Unit
ISM11 CM876 SM - Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

For an air-assisted SCR aftertreatment system, the aftertreatment diesel exhaust fluid dosing unit requires air pressure from the OEM air tanks in order to prime and help carry the diesel exhuast fluid from the dosing unit to the aftertreatment nozzle. The diesel exhaust fluid dosing unit precisely measures the amount of diesel exhaust fluid to be injected into the aftertreatment system. The diesel exhaust fluid dosing unit has three primary cycles: priming, dosing, and purging. The priming cycle occurs at initial engine start makes sure that diesel exhaust fluid is available at the diesel exhaust fluid dosing unit. During the dosing cycle, the diesel exhaust fluid is being delivered to the aftertreatment nozzle. A purge cycle occurs when the engine is turned off. The purge cycle confirms that all the diesel exhaust fluid is removed from the diesel exhaust fluid lines and aftertreatment nozzle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is started and runs while the dosing unit is in the priming state, which could last up to 12 minutes after initial key-on.

Conditions for Setting the Fault Codes

  • The dosing unit will attempt to prime every 30 seconds for 20 attempts.
  • If the dosing unit has been unable to prime after completing all attempts, this fault code will become active.
  • The dosing unit can take up to 12 minutes to complete the priming cycle before a fault code will become active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, it is necessary to use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test. Reference Procedure 019-440 in the appropriate service manual.
  • Make sure the diesel exhaust fluid dosing unit cycles through all phases successfully (priming, dosing, and purging) and diesel exhaust fluid flows evenly from the aftertreatment nozzle.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

The diesel exhaust fluid dosing unit system consists of three phases. These phases occur in the following sequence: Priming, dosing, and purging. This fault code is set when the dosing unit is unable to prime.

Fault Code 3548 is triggered by the following external failure modes:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • Low air pressure is detected at the dosing control unit
  • Plugged or restricted inline air filter
  • Blocked, restricted, frozen, or leaking dosing unit supply line
  • Diesel exhaust fluid dosing unit drawing in air through loose or damaged lines or connectors.

Fault Code 3548 is triggered by the following internal diesel exhaust fluid dosing unit failure modes:

  • Build up of DEF crystals in the dosing unit restricts air flow to the aftertreatment nozzle
  • Internal pressure sensor or poppet valve failure causing the diesel exhaust fluid dosing unit to fail to prime. This will cause diesel exhaust fluid to flow from the aftertreatment nozzle during priming.

If blocked diesel exhaust fluid lines due to build-ups are detected, make sure the dosing unit is purging correctly at key-off. Incomplete purge counts can be viewed using the Data Monitor/Logger menu in the aftertreatment section of INSITE™ electronic service tool. If the vehicle is equipped with a battery isolation switch, it should have a built-in delay device to prevent power down of the dosing unit until the purge sequence is complete.

Refer to Troubleshooting Fault Code 3548.

Last Modified: 02-Nov-2015


Engine Wait to Start Lamp - Abnormal Update Rate

FAULT CODE 3555

Engine Wait to Start Lamp - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3555 PID: SPN: 1081 FMI: 9/9 LAMP: Amber SRT: | Engine Wait to Start Lamp - Abnormal Update Rate. A loss of communication has been detected. | None on performance.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit or transmission electronic control unit in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM vehicle engine control unit to the Cummins® ECM over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of communication with the Engine Wait to Start Lamp.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect terminating resistance of the SAE J1939 data link circuit
  • Incorrect feature and parameter settings
  • A malfunctioning SAE J1939 data link circuit.
Refer to Troubleshooting Fault Code t05-3555

Last Modified: 06-May-2015


Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3557

Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3557 PID: SPN: 3360 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid controller has detected a reading too high or low on one of the connections to the dosing unit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the selective catalytic reduction (SCR) diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. The diesel exhaust fluid controller communicates to the electronic control module (ECM) via the J1939 data link connection.

Component Location

The location of the aftertreatment diesel exhaust fluid controller varies by application and original equipment manufacturer (OEM). The controller will typically be mounted to the vehicle frame or suitable rigid bracket using 3 or 4 capscrews. Refer to the OEM service manual for a more detailed component location description.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

A reading that is too high or too low for the operating conditions has been detected on the sensor supply circuit between the diesel exhaust fluid controller and the dosing unit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • This fault code cannot be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced upon determination of a component malfunction.

Refer to Troubleshooting Fault Code 3557.

Last Modified: 08-Sep-2009


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3558

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3558 PID: SPN: 3361 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhasut Fluid Dosing Unit Circuit

Circuit Description

The diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines using a pump to allow for dosing. The diesel exhaust fluid controller provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The controller also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes based on the diesel exhaust fluid pressure being commanded..

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the aftertreatment diesel exhaust fluid dosing unit voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid dosing unit
  • Short to battery voltage in the diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3558.

Last Modified: 25-Sep-2009


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3559

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3559 PID: SPN: 3361 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines using a pump to allow for dosing. The diesel exhaust fluid controller provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The controller also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual for more infomation.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the aftertreatment diesel exhaust fluid dosing unit voltage is below a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • Short to ground in the diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3559.

Last Modified: 25-Sep-2009


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

FAULT CODE 3561

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3561 PID: SPN: 3361 FMI: 5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit. Open circuit detected at the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate aftertreatment diesel exhaust fluid pressure in the lines using a pump to allow for dosing. The aftertreatment diesel exhaust fluid controller provides a battery voltage supply and a ground to the aftertreatment diesel exhaust fluid dosing unit. The controller also supplies a signal to the dosing unit to control the aftertreatment diesel exhaust fluid output. This signal changes based on the aftertreatment diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust fluid controller detects that the diesel exhaust dosing unit circuit is open.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the aftertreatment diesel exhaust fluid dosing unit
  • Open circuit in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3561.

Last Modified: 25-Sep-2009


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

FAULT CODE 3562

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3562 PID: SPN: 5491 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater relay. | Diesel exhaust fluid line heaters 1, 2, and 3 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay provides the power supply to line heaters 1, 2, and 3. It is controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust fluid controller detects that the voltage in the diesel exhaust fluid line heater relay circuit is above a calibratible value.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the MIL immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid line heater relay circuit.
  • Short to battery voltage in the diesel exhaust fluid controller harness.
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3562.

Last Modified: 25-Sep-2009


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3563

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3563 PID: SPN: 5491 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid line heater relay. | Diesel exhaust fluid line heaters 1, 2, and 3 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay provides the power supply to line heaters 1, 2, and 3. It is controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs at key off. The fault will be active at the next key-on event.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust fluid controller detects that the voltage in the diesel exhaust fluid line heater relay circuit is below a calibratible value.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the INSITE electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the aftertreatment diesel exhaust fluid line heater relay circuit.
  • Short to ground in the aftertreatment diesel exhaust fluid controller harness.
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3563.

Last Modified: 25-Sep-2009


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Current Below Normal or Open Circuit

FAULT CODE 3564

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3564 PID: SPN: 5491 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Current Below Normal or Open Circuit. Open circuit detected at the diesel exhaust fluid line heater relay. | Diesel exhaust fluid line heaters 1, 2, and 3 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay provides the power supply to line heaters 1, 2, and 3. It is controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswtich is ON.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust fluid controller detects that the diesel exhaust fluid line heater relay circuit is open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the aftertreatment diesel exhaust fluid line heater relay circuit
  • Open circuit in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3564.

Last Modified: 11-Jan-2010


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3565

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3565 PID: SPN: 5394 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing valve. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing valve is controlled by the aftertreatment DEF controller. When the engine electronic control module (ECM) commands DEF dosing, the DEF controller sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the SCR catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust fluid controller detects that the diesel exhaust fluid dosing valve voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, diesel exhaust fluid dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid dosing valve
  • Short to battery voltage in the diesel exhaust fluid controller harness
  • Malfunctioning diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 00-t05-3565.

Last Modified: 24-Jun-2010


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3566

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3566 PID: SPN: 5394 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid dosing valve. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing valve is controlled by the aftertreatment DEF controller. When the engine electronic control module (ECM) commands DEF dosing, the DEF controller sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust fluid controller detects that the diesel exhaust fluid dosing valve voltage is below a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, diesel exhaust fluid dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing valve
  • Short to ground in the diesel exhaust fluid controller harness
  • Malfunctioning diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3566.

Last Modified: 24-Jun-2010


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit

FAULT CODE 3567

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3567 PID: SPN: 5394 FMI: 5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit. Open signal voltage detected at the diesel exhaust fluid dosing valve. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing valve is controlled by the aftertreatment DEF controller. When the engine electronic control module (ECM) commands DEF dosing, the DEF controller sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the diesel exhaust fluid dosing valve circuit is open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, the diesel exhaust fluid dosing valve must be commanded on in order for all diagnostics to run. This can be done by performing the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test in INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • Open circuit in the diesel exhaust fluid controller harness
  • Malfunctioning diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3567.

Last Modified: 24-Jun-2010


Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Repsonding or Out of Adjustment

FAULT CODE 3568

Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Repsonding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3568 PID: SPN: 5394 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Responding or Out of adjustment. A mechanical failure has been detected in the DEF dosing valve. | DEF injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN - Aftertreatment DEF Dosing Valve Circuit
ISF3.8 CM2220 AN - Aftertreatment DEF Dosing Valve Circuit

Circuit Description

The aftertreatment DEF dosing valve is controlled by the aftertreatment DEF controller. When the engine ECM commands DEF dosing, the DEF controller sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment DEF dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the Selective Catalytic Reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the DEF dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The DEF controller has detected a mechanical malfunction of the DEF dosing valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, the DEF dosing valve must be commanded on in order for all diagnostics to run. This can be done by performing the Aftertreatment Diesel Exhaust Fluid (DEF) Doser Pump Override test in INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reccurrence.

Shop Talk

This fault detects a mechanical malfunction of the DEF dosing valve, or a pin-to-pin short in the DEF dosing valve circuit.

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code t05-3568.

Last Modified: 02-Jan-2012


Fault Code Path Selection

FAULT CODE 120-fc3569
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc3569air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc3569airless

Last Modified: 23-Oct-2009


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 3571

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3571 PID: SPN: 4334 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the aftertreatment diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The afterteatment diesel exhaust fluid controller will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the aftertreatment diesel exhaust fluid pressure sensor signal voltage is more than a calibratible value for 1 second.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails
  • An engine torque derate will be activated.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurrence

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or battery voltage
  • Malfunctioning aftertreatment diesel exhaust fluid controller
  • Malfunctioning aftertreatment diesel exhaust fluid controller harness.
Refer to Troubleshooting Fault Code 3571.

Last Modified: 24-Jun-2010


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3572

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3572 PID: SPN: 4334 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the aftertreatment diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The aftertreatment diesel exhaust fluid controller will detect a low signal voltage at low aftertreatment diesel exhaust fluid pressures, and high signal voltage at high aftertreatment diesel exhaust fluid pressures. The aftertreatment diesel exhaust fluid pressure sensor reading is communicated to the electronic control module (ECM) via the engine data link.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the aftertreatment diesel exhaust fluid pressure sensor signal voltage is less than a calibratible value for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to ground
  • Malfunctioning aftertreatment diesel exhaust fluid controller
  • Malfunctioning aftertreatment diesel exhaust fluid controller harness.
Refer to Troubleshooting Fault Code 3572.

Last Modified: 24-Jun-2010


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3574

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3574 PID: SPN: 4334 FMI: 18/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing unit. | Diesel exhaust fluid injection into the aftertreatment system may be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN Diesel Exhaust Fluid Components

Circuit Description

The diesel exhaust fluid controller provides a 5 volt supply and a ground to the diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes, based on the diesel exhaust fluid pressure supplied by the dosing unit. The diesel exhaust fluid controller will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures. The aftertreatment diesel exhaust fluid pressure sensor reading is communicated to the ECM via the engine data link.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the dosing unit is unable to build or maintain adequate diesel exhaust fluid line pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool
  • To validate the repair, use INSITE™ to perform the "Diesel Exhaust Fluid Doser Override Test" under the "ECM Diagnostics Test" menu..
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Malfunctioning diesel exhaust fluid dosing unit
  • Contaminated diesel exhaust fluid.
Refer to Troubleshooting Fault Code 3574.

Last Modified: 29-Nov-2010


Fault Code Path Selection

FAULT CODE 120-fc3575
Fault Code Path Selection

Is the selective catalytic reduction (SCR) dosing system air-assisted? | Go to 120-fc3575air
Is the selective catalytic reduction (SCR) dosing system airless? | Go to 120-fc3575airless

Last Modified: 16-Sep-2009


Aftertreatment Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit

FAULT CODE 3576

Aftertreatment Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3576 PID: SPN: 3363 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit. Open circuit detected at the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heating will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Heater Control Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve that controls the flow of engine coolant to a heating coil inside the diesel exhaust tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The aftertreatment diesel exhaust fluid tank heater control valve is located near the aftertreatment diesel exhaust fluid tank. Specific location will vary, depending on the vehicle original equipment manufacturer (OEM). The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the diesel exhaust fluid tank heater circuit is open.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid tank heating will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The aftertreatment diesel exhaust fluid tank heater control valve may be powered by an OEM suppied power relay, which is connected to the aftertreatment diesel exhaust fluid controller harness. When troubleshooting wiring harness issues, it may be necessary to include the optional line heater relay.

Possible causes of this fault code include:

  • Open circuit in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3576.

Last Modified: 10-Sep-2009


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3577

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3577 PID: SPN: 4376 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid return valve. | Aftertreatment diesel exhaust fluid return valve will be disabled. Selective catalytic reduction (SCR) system will not purge.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the aftertreatment diesel exhaust fluid controller. The return valve position determines where afterteatment diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is energized, the dosing system will purge and return the aftertreatment diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the aftertreatment diesel exhaust fluid return valve voltage is more than a calibratible value for 1 second.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with the INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use the INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be aftertreatment diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, lines can freeze and the SCR system can become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code 3577.

Last Modified: 10-Sep-2009


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3578

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3578 PID: SPN: 4376 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid return valve. | Diesel exhaust fluid return valve will be disabled. SCR system will not purge.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the aftertreatment diesel exhaust fluid controller.The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit.When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the diesel exhaust fluid return valve voltage is less than a calibratible value for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use the INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, lines could freeze and become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code 3578.

Last Modified: 29-Nov-2010


Aftertreatment Diesel Exhaust Fluid Return Valve - Current Below Normal or Open Circuit

FAULT CODE 3579

Aftertreatment Diesel Exhaust Fluid Return Valve - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3579 PID: SPN: 4376 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Current Below Normal or Open Circuit. Open circuit detected at the diesel exhaust fluid return valve. | Diesel exhaust fluid return valve will be disabled. SCR system will not purge.
ISF2.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit
ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the aftertreatment diesel exhaust fluid controller. The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the diesel exhaust fluid return valve circuit is open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, the lines could freeze and become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code 3579.

Last Modified: 15-Sep-2009


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3596

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3596 PID: SPN: 4334 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The diesel exhaust fluid controller provides a 5 volt supply and a ground to the diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes based on the diesel exhaust fluid pressure supplied by the dosing unit. The diesel exhaust fluid controller will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures. The aftertreatment diesel exhaust fluid pressure sensor reading is communicated to the ECM via the engine data link.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when diesel exhaust fluid dosing unit is fully primed, and is actively maintaining diesel exhaust fluid pressure in the dosing system.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit is unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the diesel exhaust fluid dosing system must be fully primed. This can be done by performing the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test in INSITE™ electronic service tool.
  • To validate the repair, start the engine and make sure the SCR dosing system is fully primed.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Leaking diesel exhaust fluid lines
  • Malfunctioning diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code 3596.

Last Modified: 10-Sep-2009


Aftertreatment Diesel Exhaust Fluid Controller - Abnormal Update Rate

FAULT CODE 3597

Aftertreatment Diesel Exhaust Fluid Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3597 PID: S254 SPN: 3360 FMI: 9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Abnormal Update Rate. Data link communications between the ECM and the aftertreatment diesel exhaust fluid controller have been interrupted. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Controller

Circuit Description

The aftertreatment diesel exhaust fluid controller communicates to the primary engine Electronic Control Module (ECM) through the J1939 public data link network. The aftertreatment diesel exhaust fluid controller also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The aftertreatment diesel exhaust fluid controller location is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Data link communications between the ECM and the aftertreatment diesel exhaust fluid controller have been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Loss of battery voltage to the aftertreatment diesel exhaust fluid controller
  • Loss of battery ground to the aftertreatment diesel exhaust fluid controller
  • Loss of keyswitch input to the aftertreatment diesel exhaust fluid controller
  • Shorted or open J1939 data link wiring between the aftertreatment diesel exhaust fluid controller and the primary engine ECM
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 3597.

Last Modified: 24-Jun-2010


Aftertreatment Diesel Exhaust Fluid Controller - Received Network Data In Error

FAULT CODE 3598

Aftertreatment Diesel Exhaust Fluid Controller - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3598 PID: SPN: 3360 FMI: 19/19 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Received Network Data In Error. The data being sent from the ECM to aftertreatment diesel exhaust fluid controller is unreadable or missing. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Controller

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the aftertreatment diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. It communicates to the engine ECM via a J1939 data link connection.

Component Location

The location of the aftertreatment diesel exhaust fluid controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or suitable rigid bracket using 3 or 4 capscrews. Refer to the OEM service manual for a more detailed component location description.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller was expecting to see valid J1939 data link messages from the engine ECM, but the actual data received was unreadable or missing.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • This fault code will go inactive immediately when normal communication between the ECM and diesel exhaust fluid controller are restored.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning engine ECM
  • Corrupted engine calibration
  • Malfunctioning diesel exhaust fluid controller
  • Corrupted diesel exhaust fluid controller calibration
  • Active fault codes for engine or aftertreatemnt sensors that provide inputs to the SCR system for dosing.
Refer to Troubleshooting Fault Code 3598.

Last Modified: 10-Sep-2009


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3612

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3612 PID: SPN: 3361 FMI: 7/7 LAMP: None SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Mechanical System Not Responding or Out of Adjustment. An incomplete powerdown has been detected by the SCR system. | None on performance.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Controller

Circuit Description

The diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines using a pump to allow for dosing. The diesel exhaust fluid controller provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The controller also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that an incomplete powerdown purge cycle has occurred.

Action Taken When the Fault Code is Active

  • The fault code will be set active immediately when the diagnostic runs and fails. This is a no-lamp fault.

Conditions for Clearing the Fault Code

  • This fault code will go inactive upon successful completion of a powerdown and purge cycle of the SCR dosing system.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The SCR system is programmed to automatically purge itself after the engine has shut down. Immediately following key OFF, the diesel exhuast fluid (DEF) return valve will be actuated and the dosing unit will pump any DEF left in the lines and dosing unit back to the DEF tank. The purge cycle can take up to 60 Seconds.

This is an information only fault code that indicates that something is not allowing the diesel exhaust fluid dosing unit to fully complete its purge cycle. Failure to complete the purge cycle could lead to deposits forming in the diesel exhaust fluid system or damage to the dosing unit caused by freezing of the diesel exhaust fluid. Make sure the battery power is not being removed from the SCR system immediately after engine shutdown via a main battery disconnect switch.

Refer to Troubleshooting Fault Code t05-3612.

Last Modified: 10-Jan-2011


Engine Variable Geometyry Turbocharger (VGT) Nozzle Position - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3616

Engine Variable Geometyry Turbocharger (VGT) Nozzle Position - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3616 PID: SPN: 2633 FMI: 7 LAMP: None SRT: | Engine VGT Nozzle Position - Mechanical System Not Responding or Out of Adjustment. The smart VGT controller has detected incorrect stop limits or the VGT is unable to move to the closed position. | VGT travel can be limited.
ISL9 CM2150 SN - VGT Actuator Driver Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is initially turned to the ON position and periodically when the engine is running.

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

Conditions for Setting the Fault Codes

This fault code is set when the actual VGT actuator position does not meet the commanded position for more than 10 seconds, and the coolant temperature is below a calibrated value.

Action Taken When the Fault Code is Active

  • This is a no-lamp fault. The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The VGT actuator will continue to attempt to meet the commanded position.

Conditions for Clearing the Fault Code

  • The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The fault code will clear at key ON if the error condition no longer exists.

Shop Talk

This fault code is an information fault code indicating that the VGT turbocharger sliding nozzle was unable to go to the desired position. No troubleshooting is necessary for this fault code. It is only an indicator that the engine power can be limited due to a stuck VGT turbocharger sliding nozzle. If the condition continues to exist, Fault Code 2387 will become active. It is also possible for large boost pressure leaks to also cause this fault code to become active.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code t05-3616.

Last Modified: 02-Nov-2015


Aftertreatment Diesel Exhaust Fluid Controller Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3648

Aftertreatment Diesel Exhaust Fluid Controller Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3648 PID: S254 SPN: 5480 FMI: 16/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The internal temperature of the diesel exhaust fluid controller is above the warning limits. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Controller Temperature

Circuit Description

The aftertreatment diesel exhaust fluid controller is air cooled, and is equipped with an internal temperature sensor, which monitors the temperature inside the controller during opertion. The diesel exhaust fluid controller communicates this temperature reading to the engine ECM via a J1939 datalink connection.

Component Location

The aftertreatment diesel exhaust fluid controller in equipped with an internal temperature sensor, which monitors the temperature inside the controller during opertion. This temperature sensor is internal to the diesel exhaust fluid controller and cannot be service separately.

Conditions for Running the Diagnostics

This diagnostic runs during normal operation when dosing is being commanded by the SCR system.

Conditions for Setting the Fault Codes

The internal temperature of the diesel exhaust fluid controller is above the warning limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • This fault code will go inactive immediately when the diesel exhaust fluid controller internal temperature falls below the warning limits
  • To validate the repair, start the engine and let it idle for 1 minute after the controller has adequately cooled.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Troubleshoot high inactive counts of Fault Code 3648 as an active fault code.

Possible causes of this fault code include:

  • Inadequate air flow to cool diesel exhaust fluid controller
  • Improper mounting of diesel exhaust fluid controller
  • Malfunctioning diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3648.

Last Modified: 24-Apr-2012


Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3651

Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3651 PID: S254 SPN: 3031 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid tank temperature is unable to reach its set point. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Temperature

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the diesel exhaust fluid controller to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The diesel exhaust fluid controller monitors the voltage on the signal pin, converts this to a temperature value, and communicates that value to the ECM via the engine datalink.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid tank temperature is being maintained by using the diesel exhaust fluid tank heater or when line heating is being requested.

Conditions for Setting the Fault Codes

This fault code is set when the diesel exhaust fluid tank temperature has been at normal operating levels, but is no longer able to maintain the proper temperature and is in danger of freezing.

This fault code can also be set when heating of the diesel exhust fluid lines, tank, or dosing unit, cannot be achieved.

Action Taken When the Fault Code is Active

  • The diesel exhaust fluid dosing unit will purge itself, and diesel exhaust fluid injection into the aftertreatment system is disabled.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Turn the keyswitch to the OFF position for 2 minutes to allow the system to completely powerdown. Turn the keyswitch to the ON position.
  • The fault code status in INSITE™ electronic service tool will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in INSITE™ electronic service tool to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can also set if heating of the aftertreatment DEF lines can not be achieved. Troubleshoot all line heater fault codes prior to Fault Code 3651.

Possible causes of this fault code include:

  • Blocked or restricted coolant flow to the diesel exhaust fluid tank heater
  • Disconnected or broken tank heater coolant supply hose
  • Malfunctioning or stuck closed diesel exhaust fluid tank heater control valve
  • Malfunctioning or stuck aftertreatment diesel exhaust fluid tank temperature sensor
  • Operation in extremely cold ambient conditions.
Refer to Troubleshooting Fault Code t05-3651.

Last Modified: 24-Apr-2012


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Root Cause Not Known

FAULT CODE 3679

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3679 PID: SPN: 3361 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Root Cause Not Known. The diesel exhaust fluid dosing unit has failed to initialize. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The diesel exhaust fluid dosing unit monitors its internal temperature and reports it back to the diesel exhaust fluid controller at initial key-ON via the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature wire. After the temperature message has been sent from the dosing unit to the controller, this shared wire is switched over to be used for dosing unit pump control.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM troubleshooting manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs at initial key-ON.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit and the diesel exhaust fluid controller are not able to acknowledge each other at key-ON, and can not initialize.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code cannot be cleared with INSITE™ electronic service tool.
  • Upon completion of the repair, a key cycle is required in order to get the diagnostic to run again and make the fault go inactive.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Short or open circuit in the aftertreatment wiring harness
  • Malfunctioning diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code t05-3679.

Last Modified: 24-Apr-2012


Aftertreatment Outlet NOx Sensor Power Supply - Data Erratic, Intermittent or Incorrect

FAULT CODE 3681

Aftertreatment Outlet NOx Sensor Power Supply - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: P411 SPN: 3228 FMI: 0/2 LAMP: Amber SRT: | Aftertreatment outlet NOx sensor power supply - Data erratic, intermittent, or incorrect. The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Aftertreatment Outlet NOx Sensor Power Supply

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhasut gas temperature at the aftertreatment outlet NOx sensor is above 150°C [302°F].

Conditions for Setting the Fault Codes

The ECM has detected that the power supply to the outlet NOx sensor is above or below a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 10 minutes to allow the NOx sensor to warm up.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code include:

  • Short to battery or ground in the OEM harness
  • Internal malfunction of the outlet NOx sensor
Refer to Troubleshooting Fault Code t05-3681.

Last Modified: 24-Apr-2012


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S254 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Calibration Memory - Bad Intelligent Device or Component. Error internal to the ECM related to engine software failures. | Engine may not start.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Control Module

Circuit Description

The engine control module (ECM) has internal diagnostics that continuously run and check for software errors or incompatibilities.

Component Location

The ECM mounting location varies, depending on engine model, and may be mounted either on or off engine.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a software or calbration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A malfunction of the ECM software or calibration error.
Refer to Troubleshooting Fault Code t05-3697.

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3713

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3713 PID: S254 SPN: 5491 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Mechanical system not responding or out of adjustment. A short circuit to battery has been detected on the diesel exhaust fluid line heater power supply circuit. | Diesel exhaust fluid heaters 1, 2, and 3 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay provides the power supply to line heaters 1, 2, and 3. It is controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

.The aftertreatment diesel exhaust fluid line heater relay location is OEM dependent. Refer to the OEM troubleshooting manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and diesel exhaust fluid line heating is not being commanded.

Conditions for Setting the Fault Codes

Battery voltage has been detected at the diesel exhaust fluid line heaters when the line heater relay is commanded off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid line heating will be disabled.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, a key cycle is required in order to get the diagnostic to run again and make the fault go inactive.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Switch side of line heater relay stuck closed
  • Short to battery voltage in the wire between the relay and line heater elements.
Refer to Troubleshooting Fault Code 3713.

Last Modified: 10-Sep-2009


Fault Code Path Selection

FAULT CODE 80-fc115
Fault Code Path Selection

Do you have a VP-30 fuel system? | Go to 80-fc115vp30
Do you have a VP-44 fuel system? | Go to 80-fc115vp44

Last Modified: 10-Nov-2015


Instrument Cluster Control Module - Abnormal Update Rate

FAULT CODE 3731

Instrument Cluster Control Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3731 PID: SPN: 5110 FMI: 9 LAMP: Amber SRT: | Instrument Cluster Control Module - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the instrument cluster control module. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Potential causes of this fault code include:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, a bad OEM VECU, or a bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 3731.

Last Modified: 14-Jun-2016


Engine Auxiliary Governor Switch - Abnormal Update Rate

FAULT CODE 3735

Engine Auxiliary Governor Switch - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3735 PID: SPN: 2884 FMI: 9 LAMP: None SRT: | Engine Auxiliary Governor Switch - Abnormal Update Rate. Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine speed will ramp down and remain at idle.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Multiplexing Circuit

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) (VECUs) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than one second. The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status will change to INACTIVE in INSITE™ electronic service tool immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • The external OEM controlling device has malfunctioned or can no longer transmit on the data link.
Refer to Troubleshooting Fault Code t05-3735.

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known

FAULT CODE 3736

Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3736 PID: S254 SPN: 3360 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known. Unexpected data link communications between the ECM and the aftertreatment diesel exhaust fluid controller have occurred. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Controller

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the SCR diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. It communicates to the engine via ECM via a J1939 data link connection.

Component Location

The location of the aftertreatment diesel exhaust fluid controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or suitable rigid bracket using 3 or 4 capscrews. Refer to the OEM service manual for a more detailed component location description.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

An unexpected data link message was sent from the ECM to the diesel exhaust fluid controller, and was unable to be interpreted.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • This fault code cannot be cleared with INSITE™ electronic service tool.
  • This fault code will go inactive immediately when normal communication between the ECM and diesel exhaust fluid controller are restored.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code include:

  • Incorrect data link termination resistance
  • Open or short circuit on J1939 data link
  • Malfunctioning engine ECM
  • Corrupted engine calibration
  • Malfunctioning diesel exhaust fluid controller
  • Corrupted diesel exhaust fluid controller calibration
Refer to Troubleshooting Fault Code t05-3736.

Last Modified: 24-Apr-2012


Engine Starter Mode Overcrank Protection - Condition Exists

FAULT CODE 3737

Engine Starter Mode Overcrank Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3737 PID: S115 SPN: 1675 FMI: 11/31 LAMP: None SRT: | Engine Starter Mode Overcrank Protection - Condition Exists. The starter motor has been temporarily disabled in order to prevent starter damage. | Starter operation is prohibited until the starter motor has adequately cooled.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Control Module
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Engine Control Module
ISM11 CM876 SN - Engine Control Module

Circuit Description

The overcrank protection feature (or starter lockout) is designed to prevent damage to the starter motor during hard start conditions. Excessive cranking of the engine can cause the starter motor to overheat, resulting in permanent damage. When excessive engine cranking is detected, the overcrank protection feature locks out the starter until the starter motor has adequately cooled, and is safe to operate again.

Component Location

The overcrank protection feature is controlled by the engine control module (ECM), and can not be modified.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The ECM detects the starter motor was engaged for a long enough period of time that continued cranking can cause starter damage. This cumulative time includes continuous cranking and/or a series of shorter cranking attempts within a certain time window.

Action Taken When the Fault Code is Active

  • The starter is locked out and the engine can not be cranked over until the starter motor has adequately cooled.

Conditions for Clearing the Fault Code

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the malfunction indicator lamp (MIL) for on-board diagnostics (OBD) applications.

Shop Talk

This is an information only fault code, and does not indicate an issue with the starter.

Refer to Troubleshooting Fault Code 3737.

Last Modified: 01-Nov-2016


Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3738

Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3738 PID: SPN: 3489 FMI: 18 LAMP: Amber SRT: | Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level. The air or diesel exhaust fluid supply to the dosing unit has been lost. | Diesel exhaust fluid injection into the selective catalytic reduction (SCR) aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Air Supply Actuator Circuit
ISM11 CM876 SN - Air Supply Actuator Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit air solenoid is used to enable and disable the truck air supply to the diesel exhaust fluid dosing unit. The air is used to transport the diesel exhaust fluid to the aftertreatment nozzle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit air solenoid is mounted to the back of the diesel exhaust fluid dosing unit. The mounting location of the diesel exhaust fluid dosing unit is OEM specific.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the Selective Catalytic Reduction (SCR) system is dosing diesel exhaust fluid into the aftertreatment system.

Conditions for Setting the Fault Codes

The dosing unit detects that the air supply has been lost while dosing diesel exhaust fluid into the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, it is necessary to use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test.
  • Make sure that the diesel exhaust fluid dosing unit is able to successfully cycle through all phases (priming, dosing, and purging) and that diesel exhaust fluid flows evenly from the aftertreatment nozzle.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code include:

  • OEM air supply tubing damaged or leaking
  • Malfunctioning air solenoid
  • Malfunctioning aftertreatment diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code t05-3738.

Last Modified: 28-Oct-2015


Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3749

Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3749 PID: S254 SPN: 3226 FMI: 20 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High. The aftertreatment outlet NOx sensor readings are not changing with engine operating conditions. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM with the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatreatment system.

Component Location

The Aftertreatment Outlet NOx Sensor location can vary, depending on the engine application. It is usually located in the exhaust system at the outlet of the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating and the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150° C [302° F].

Conditions for Setting the Fault Codes

The ECM has detected that the outlet NOx sensor reading is not changing to match the present engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool. It is necessary to drive or operate the vehicle on a chassis dynamometer in order to validate the repair and for the fault code to go inactive.
  • The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150° C [302° F] before the sensor can run its internal diagnostics.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment outlet NOx sensor has been removed or tampered with
  • Malfunctioning aftertreatment outlet NOx sensor.
Refer to Troubleshooting Fault Code t05-3749.

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 3866

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3866 PID: SPN: 3364 FMI: 1 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Most Severe Level. The diesel exhaust fluid (DEF) has been detected to be below a critical threshold. | Engine torque will automatically be reduced after 36 hours.
ISB6.7 CM2150 SQ - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

  • For tank mounted sensors, this diagnostic runs continuously after the DEF tank is thawed.
  • For in-line mounted sensors, this diagnostic runs continuously after the system has successfully primed.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

NOTE: This fault can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle until the DEF system is thawed and primed.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9,600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code can include:

  • Improper DEF in the tank
  • Malfunctioning DEF quality sensor
  • Diesel fuel in DEF tank.
Refer to Troubleshooting Fault Code t05-3866.

Last Modified: 24-Apr-2012


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3867

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3867 PID: SPN: 3364 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid (DEF) has been detected to be below a critical threshold. | Engine torque will automatically be reduced after 36 hours.
ISB6.7 CM2150 SQ - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

  • For tank mounted sensors, this diagnostic runs continuously after the DEF tank is thawed.
  • For in-line mounted sensors, this diagnostic runs continuously after the system has successfully primed.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated in this condition for 36 hours.

Conditions for Clearing the Fault Code

NOTE: This fault can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle until the DEF system is thawed and primed.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9,600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code may include:

  • Improper DEF in the tank
  • Malfunctioning DEF quality sensor.
Refer to Troubleshooting Fault Code t05-3867.

Last Modified: 24-Apr-2012


Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

FAULT CODE 3868

Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3868 PID: SPN: 3364 FMI: 9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate. No communications on the J1939 data link between the engine control module (ECM) and the diesel exhaust fluid (DEF) quality sensor. | Engine torque will automatically be reduced.
ISB6.7 CM2150 SQ - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when they keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the ECM loses J1939 communications with the DEF quality sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

NOTE: This fault can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle until the DEF system is thawed and primed.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9,600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code can include:

  • The DEF quality sensor is not receiving power from the battery supply circuit in the OEM harness. This could be caused by an open circuit in the power SUPPLY wire, blown fuse, or low voltage supplied by the battery.
  • Open return circuit on the DEF quality sensor battery return.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and DEF quality sensor.
  • Intermittent communications between the DEF quality sensor and the primary engine ECM on the J1939 data link.
Refer to Troubleshooting Fault Code t05-3868.

Last Modified: 24-Apr-2012


Aftertreatment Diesel Exhaust Fluid Quality - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3876

Aftertreatment Diesel Exhaust Fluid Quality - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3876 PID: SPN: 3364 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Mechanical System Not Responding or Out of Adjustment. The diesel exhaust fluid (DEF) quality sensor is not detecting contact with DEF. | Engine torque will automatically be reduced after 36 hours.
ISB6.7 CM2150 SQ - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the ECM via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The DEF quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF sensor is typically mounted in the DEf tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

  • For tank-mounted sensors, this diagnostic runs continuously after the DEF tank is thawed.
  • For in-line-mounted sensors, this diagnostic runs continuously after the system has successfully primed.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the sensing element is not in contact with the DEF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is run in this condition for 36 hours.

Conditions for Clearing the Fault Code

NOTE: This fault code can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle until the DEF system is thawed and primed.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9,600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code can include:

  • Improperly installed DEF quality sensor
  • Low DEF tank level
  • Malfunctioning DEF quality sensor
  • DEF contaminated with other fluids (i.e. diesel, coolant, oil, etc.)
  • DEF tank filled with water
  • DEF temperature is beyond the measurement range of the DEF quality sensor.
Refer to Troublshooting Fault Code t05-3876.

Last Modified: 24-Apr-2012


Aftertreatment Diesel Exhaust Fluid Quality - Bad Intelligent Device or Component

FAULT CODE 3877

Aftertreatment Diesel Exhaust Fluid Quality - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3877 PID: SPN: 3364 FMI: 12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Bad Intelligent Device or Component. An internal error has been detected by the diesel exhaust fluid (DEF) quality sensor. | Engine torque will automatically be reduced.
ISB6.7 CM2150 SQ - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine engine control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

  • For tank-mounted sensors, this diagnostic runs continuously after the DEF tank is thawed.
  • For in-line-mounted sensors, this diagnostic runs continuously after the system has successfully primed.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the sensing element is broken or there is no communication between the sensing element and the electronics.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

NOTE: This fault code can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle until the DEF system is thawed and primed.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9,600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code may include:

  • Damaged DEF quality sensor element
  • Dirty or malfunctioning DEF quality sensor.
Refer to Troubleshooting Fault Code t05-3877.

Last Modified: 24-Apr-2012


Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3878

Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3878 PID: SPN: 3364 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid (DEF) quality sensor has detected an over temperature condition. | Engine torque will automatically be reduced.
ISB6.7 CM2150 SQ - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine engine control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

  • For tank-mounted sensors, this diagnostic runs continuously after the DEF tank is thawed.
  • For in-line-mounted sensors, this diagnostic runs continuously after the system has successfully primed.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125°C.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • The DEF quality sensor electronics will go into safety mode.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

NOTE: This fault code can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle until the DEF system is thawed and primed.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9,600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code can include:

  • Excessive ambient and/or operating temperature
  • Malfunctioning DEF quality sensor.
Refer to Troubleshooting Fault Code t05-3878.

Last Modified: 24-Apr-2012


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3879

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3879 PID: SPN: 3364 FMI: 0 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Most Severe Level. The DEF concentration has been detected to be above a threshold. | Engine torque will automatically be reduced.
ISB6.7 CM2150 SQ - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine engine control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

  • For tank mounted sensors, this diagnostic runs continuously after the DEF tank is thawed.
  • For in-line mounted sensors, this diagnostic runs continuously after the system has successfully primed.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has risen above a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

NOTE: This fault code can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle until the DEF system is thawed and primed.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9,600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code can include:

  • Improper DEF in the tank
  • Malfunctioning DEF quality sensor.
Refer to Troubleshooting Fault Code t05-3879.

Last Modified: 24-Apr-2012


Security Device - Abnormal Update Rate

FAULT CODE 4138

Security Device - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4138 PID: SPN: 1746 FMI: 9/9 LAMP: Amber SRT: | Security Device - Abnormal Update Rate. The engine control module (ECM) lost communication with the security device. | Engine may not start.
ISM11 CM876 SN - Engine Control Module

Circuit Description

The original equipment manufacturer (OEM) security device is an optional device connected to the primary ECM through a J1939 data link network. Messages sent from the security device are received by the Cummins® ECM and are used to control the anti-theft features. The Cummins® ECM and security device must be configured properly so that proper operation of the system will occur

Component Location

The J1939 data link wiring and location of OEM installed J1939 devices varies by OEM. See equipment manufacturer service information for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected a loss of communication with the OEM security device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault can occur for the following reasons:

  • When the ECM is set up to receive information from an OEM device, but the OEM device is not transmitting the message for that component.
  • When a multiplexed component is enabled in the Cummins® ECM, but the source address of the OEM device transmitting the component message is incorrect in the Cummins® ECM.
Refer to Troubleshooting Fault Code t05-4138.

Last Modified: 29-Apr-2014


Security Device - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4139

Security Device - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4139 PID: SPN: 1746 FMI: 2/2 LAMP: Amber SRT: | Security Device - Data Erratic, Intermittent, or Incorrect. Engine ignition attemp without authorization from the original equipment manufacturer (OEM) security device. | Engine will not start.
ISM11 CM876 SN - Engine Control Module

Circuit Description

The OEM security device is an optional device connected to the primary engine control module (ECM) through a J1939 data link network. Messages sent from the security device are received by the Cummins® ECM and are used to control the anti-theft features. The Cummins® ECM and security device must be configured properly so that proper operation of the system will occur.

Component Location

The J1939 data link wiring and location of OEM installed J1939 devices varies by OEM. See equipment manufacturer service information for component location

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is active when the OEM security device has not been deactivated.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is active when the anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

Refer to Troubleshooting Fault Code t05-4139.

Last Modified: 29-Apr-2014


Desired Engine Fueling State - Abnormal Update Rate

FAULT CODE 4284

Desired Engine Fueling State - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4284 PID: SPN: 5793 FMI: 9/9 LAMP: Amber SRT: | Desired Engine Fueling State - Abnormal Update Rate. A valid message from the transmission ECU has not been received. | Engine may not start or may be difficult to start.
ISF2.8 CM2220/ISF2.8 CM2220 EC - SAE J1939 Multiplexing Configuration
ISF2.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISF3.8 CM2220/ISF3.8 CM2220 AN - SAE J1939 Multiplexing Configuration
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - SAE J1939 Multiplexing Configuration
ISM11 CM876 SN - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

The first part of the diagnostic runs continuously while the keyswitch is in the ON posistion or the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for on board diagnostic (OBD) applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning transmission ECU.

  • Incorrect ECM software for this application.
  • A malfunctioning SAE J1939 datalink circuit.
Refer to Troubleshooting Fault Code t05-3525.

Last Modified: 28-Oct-2015


Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4484

Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4484 PID: SPN: 3667 FMI: 7/7 LAMP: RED SRT: | Engine Air Shutoff Circuit - Mechanical System Not Responding or Out of Adjustment. Engine air shutoff failed to close during test mode. | The engine air shutoff valve will be disabled.
ISX12/ISX11.9 CM2250/ISB6.7 CM2250/ISC8.3 and ISL9 CM2250/ISX15 CM2250 - Engine Air Shutoff Sensor Circuit

Circuit Description

The air shutoff valve is either an original equipment manufacturer (OEM) or Cummins® installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the engine control module (ECM) supplies 12 VDC to the air shutoff solenoid. This solenoid then activates the valve, closing a plate over the intake.

Component Location

The air shutoff valve is either an OEM or Cummins® installed component, and is usually located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic only runs during an Air Shutoff Valve Test.

Conditions for Setting the Fault Codes

The ECM detects that the air shutoff valve has not closed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use INSITE™ electronic service tool to calibrate the ECM.

NOTE: The engine must be calibrated again to clear the fault code. This is done because of the hazardous operating environment and safety considerations.

  • To validate the repair, the Air Shutoff Valve Test must be performed again and successfully passed.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning air shutoff valve solenoid
  • Malfunctioning air shutoff valve
  • Broken or disconnected air shutoff position switch SIGNAL wire
  • Broken or disconnected air shutoff position switch RETURN wire.
Refer to Troubleshooting Fault Code t05-4484.

Last Modified: 08-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

FAULT CODE 4572

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4572 PID: SPN: 3031 FMI: 9 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate | Default temperature value used for catalyst solution temperature.
ISM 11 CM876 SN - Engine Control Module

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic unit or transmission electronic control unit in the cab. Then, component values and states from components, such as sensors, accelerators, and switches, can be transmitted from the OEM vehicle electronic control unit to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM vehicle electronic control units are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM vehicle electronic control unit(s) must be configured properly so proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and vehicle electronic control unit locations vary by OEM. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the multiplexed aftertreatment 1 diesel exhaust fluid tank temperature sensor for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM vehicle electronic control unit source addressed correctly) to receive information from an OEM vehicle electronic control unit, but the OEM vehicle electronic control unit is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM vehicle electronic control unit source address of the vehicle electronic control unit transmitting the component message is incorrect in the Cummins® ECM or the OEM vehicle electronic control unit is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning J1939 data link connection between the OEM vehicle electronic control unit and Cummins® ECM, a malfunctioning connection between the component and the OEM vehicle electronic control unit, or a bad OEM vehicle electronic control unit or malfunctioning Cummins® ECM. It can be necessary to contact the OEM for proper multiplexing configuration.
  • It is possible to use INSITE™ electronic service tool to monitor multiplexed components.
Refer to Troubleshooting Fault Code t05-4572

Last Modified: 04-Feb-2015


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4642

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4642 PID: SPN: 97 FMI: 0 LAMP: Amber SRT: | Water-in-Fuel Indicator - Data Valid But Above Normal Operating Rage - Moderately Sever Level. The water-in-fuel indicator indicates the water level is above warning leve. | Progressive power and/or speed derate increasing in severity from the time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5 VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the original equipment manufacturer (OEM) supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and ianctive faults, as well as extinguish the MIL for On-Board Diagnostics applications.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components. The engine will be derated for protection purposes.

The fuel filter must be drained immediately.

If this fault code is active and there is no water in the fuel filter, a malfunctioning water-in-fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-4642.

Last Modified: 08-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

FAULT CODE 4731

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4731 PID: SPN: 3031 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration. The received data link message was not valid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is original equipment manufacturer (OEM) dependent. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects the SAE J1939 data link message received from the aftertreatment diesel exhaust fluid tank temperature sensor was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed in INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor.
Refer to Troubleshooting Fault Code t05-4731.

Last Modified: 30-Sep-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

FAULT CODE 4732

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4732 PID: SPN: 1761 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration. The received data link message was not valid. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is original equipment manufacturer (OEM) dependent. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects the SAE J1939 data link message received from the aftertreatment diesel exhaust fluid tank level sensor was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor.
Refer to Troubleshooting Fault Code t05-4732.

Last Modified: 30-Sep-2014


Aftertreatment 1 Diesel Exahust Fluid Tank Temperature - Root Cause Not Known

FAULT CODE 4737

Aftertreatment 1 Diesel Exahust Fluid Tank Temperature - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4737 PID: SPN: 3031 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank temperature sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the aftertreatment diesel exhaust fluid temperature inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and temperature sensor is original equipment manufacturer (OEM) dependent. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects the SAE J1939 data link message received from the aftertreatment diesel exhaust fluid tank temperature sensor was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor.
Refer to Troubleshooting Fault Code t05-4737.

Last Modified: 30-Sep-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

FAULT CODE 4739

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4739 PID: SPN: 1761 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is original equipment manufacturer (OEM) dependent. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The engine control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor.
Refer to Troubleshooting Fault Code t05-4739

Last Modified: 19-Sep-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

FAULT CODE 4739

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4739 PID: SPN: 1761 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is original equipment manufacturer (OEM) dependent. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The engine control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor.
Refer to Troubleshooting Fault Code t05-4739

Last Modified: 27-May-2015


Performance Bias Selection Switch Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at performance bias selection circuit.

FAULT CODE 4948

Performance Bias Selection Switch Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at performance bias selection circuit.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4948 PID: SPN: 6874 FMI: 3/3 LAMP: Amber SRT: | Performance Bias Selection Switch Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at performance bias selection circuit. | Performance Bias Selection switch will probably not work. Possible reduced engine performance.
ISM CM876 SN-Performance Bias Selection Switch Circuit

Circuit Description

The User Adjustable Fuel Economy feature provides three different engine operation modes through a three positon switch. The driver can balance fuel economy and vehicle power performance by running on different engine operation modes.

Component Location

The performance bias selection switch is installed in the dashboard or any other place in the cab that the driver can easily get access.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the performance bias selection switch signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Possible causes of this fault code include:

  • An open circuit in the engine harness
  • A malfunctioning performance bias selection switch.
Refer to Troubleshooting Fault Code t05-4948.

Last Modified: 26-Jun-2016


Performance Bias Selection Switch - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4949

Performance Bias Selection Switch - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4949 PID: SPN: 6874 FMI: 4/4 LAMP: Amber SRT: | Performance Bias Selection Switch - Voltage Below Normal or Shorted to Low Source. Low voltage detected at performance bias selection circuit. | Performance bias selection switch will probably not work. Possible reduced engine performance.
ISM CM876 SN-Performance Bias Selection Switch Circuit

Circuit Description

The User Adjustable Fuel Economy feature provides three different engine operation modes through a three positon switch. The driver can balance fuel economy and vehicle power performance by running on different engine operation modes.

Component Location

The performance bias selection switch is installed in the dashboard or any other place in the cab that the driver can easily get access.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the performance bias selection switch signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Possible causes of this fault code include:

  • A short circuit to ground
  • A malfunctioning performance bias selection switch.
Refer to Troubleshooting Fault Code t05-4949.

Last Modified: 29-Jun-2017


Engine Air Shutoff Status - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5221

Engine Air Shutoff Status - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5221 PID: SPN: 3667 FMI: 2 LAMP: Red SRT: | Engine Air Shutoff - Data Erratic, Intermittent, or Incorrect | The engine air shutoff valve will be disabled.
Engine Air Shutoff Sensor Circuit

Circuit Description

The air shutoff valve position switch is located inside the air shutoff valve. During testing, the engine is accelerated and the air shutoff valve closes at a predetermined engine speed. When the air shutoff valve closes, the position switch closes. The engine control module (ECM) monitors the air shutoff valve position signal circuit for a change indicating the switch closed.

Component Location

The air shutoff valve position switch is located inside the air shutoff valve. The air shutoff valve is either an original equipment manufacturer (OEM) or Cummins® installed component and is usually located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic only runs during an Air Shutoff Valve Test.

Conditions for Setting the Fault Codes

The ECM detects the air shutoff valve position switch has not closed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To clear the fault code and validate the repair, the air shutoff valve must be reset. The Air Shutoff Valve Test must be performed and the ECM must see the air shutoff valve position switch close.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning air shutoff valve position solenoid
  • Malfunctioning air shutoff valve
  • Malfunctioning air shutoff valve position switch
  • Broken or disconnected air shutoff position switch SIGNAL wire
  • Broken or disconnected air shutoff position switch RETURN wire.
Refer to Troubleshooting Fault Code t05-5221.

Last Modified: 08-Dec-2014


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135sensor

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
ISM11 CM876 SN - Engine Oil Rifle Pressure 1 Circuit
ISZ13 CM2150 SN - Engine Oil Rifle Pressure 1 Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is greater than 4.75 VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the oil pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135sensor.

Last Modified: 26-Aug-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135switch

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
ISL9 CM2150 SN - Engine Oil Rifle Pressure 1 Circuit
ISF2.8 CM2220 – Engine Oil Rifle Pressure 1 Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure switch on the sensor supply circuit. The ECM also provides a ground on the switch return circuit. The engine oil pressure switch provides a signal to the ECM on the engine oil pressure switch signal circuit. This switch signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower.

Component Location

The engine oil pressure switch is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is greater than .25 VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the oil pressure switch shares SUPPLY and RETURN wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or switch
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135switch.

Last Modified: 29-Oct-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141sensor

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P0522 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
ISM11 CM876 SN - Engine Oil Rifle Pressure 1 Sensor Circuit
ISZ13 CM2150 - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is less than 0.25 VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used of the engine oil pressure reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the oil pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141sensor.

Last Modified: 20-Aug-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141switch

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P0522 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
ISL9 CM2150 SN - Engine Oil Rifle Pressure 1 Switch Circuit
ISF2.8 CM2220 - Engine Oil Rifle Pressure 1 Switch Circuit

Circuit Description

The engine control module (ECM) provides a battery supply to the engine oil pressure switch on the sensor supply circuit. The ECM also provides a ground on the switch return circuit. The engine oil pressure switch provides a signal to the ECM on the engine oil pressure switch signal circuit. This switch signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower.

Component Location

The engine oil pressure switch is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure switch voltage is less than 0.25 VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the engine oil pressure readign is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the oil pressure switch shares SUPPLY and RETURN wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or switch.
Refer to Troubleshooting Fault Code t05-141switch.

Last Modified: 29-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: P203C SPN: 1761 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit
ISL9 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit
ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank. The aftertreatment diesel exhaust fluid tanks level sensor is a combination sensor with the aftertreatment diesel exhaust fluid temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank level sensor signal voltage dropped below a calibratible value while the keyswitch was in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1668, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code 1668 (Air-assisted).

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668 (Airless)

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: P203C SPN: 1761 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank. The aftertreatment diesel exhaust fluid tanks level sensor is a combination sensor with the aftertreatment diesel exhaust fluid temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank level sensor signal voltage dropped below a calibratible value while the keyswitch was in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1668 (Aireless), check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code 1668 (Airless).

Last Modified: 08-Jan-2010


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: P203D SPN: 1761 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage above normal or shorted to high source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit
ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank. The aftertreatment diesel exhaust fluid tank level sensor is a combination sensor with the aftertreatment diesel exhaust fluid temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank level sensor signal voltage is above a calibratible value while the keyswitch was in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

This fault code can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1669, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1669 (Air-assisted).

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669 (Airless)

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: P203D SPN: 1761 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank. The aftertreatment diesel exhaust fluid tanks level sensor is a combination sensor with the aftertreatment diesel exhaust fluid temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank level sensor signal voltage is above a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1669, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1669 (Airless).

Last Modified: 11-Jan-2010


Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: P205C SPN: 3031 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank temperature sensor circuit. | Default temperature value used for aftertreatment diesel exhaust fluid tank temperature.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Catalyst Solution Temperature Sensor Circuit
ISM11 CM876 SN - Catalyst Solution Temperature Sensor Circuit
ISZ13 CM2150 - Catalyst Solution Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The ECM detects that the aftertreatment diesel exhaust fluid tank temperature sensor signal voltage dropped below a calibratible value while the keyswitch was in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 1677, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 1677 (Air-assisted).

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677 (Airless)

Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: P205C SPN: 3031 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the catalyst solution temperature sensor circuit. | Default temperature value used for aftertreatment diesel exhaust fluid tank temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank temperature sensor signal voltage dropped below a calibratible value while the keyswitch was in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 1677, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 1677 (Airless).

Last Modified: 08-Jan-2010


Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: P205D SPN: 3031 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank temperature sensor circuit. | Default temperature value used for aftertreatment diesel exhaust fluid tank temperature.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit
ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The ECM detects that the aftertreatment diesel exhaust fluid tank temperature sensor signal voltage is above a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 1678 (Air-assisted).

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678 (Airless)

Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: P205D SPN: 3031 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the catalyst tank temperature sensor circuit | Default temperature value used for aftertreatment diesel exhaust fluid tank temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust inside the diesel exhaust fluid tank. The diesel exhaust fluid controller monitors the voltage on the signal pin, converts this to a temperature value, and communicates this value to the engine ECM.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank temperature sensor signal voltage is above a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

The aftertreatment diesel exhaust fluid temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 1678 (Airless).

Last Modified: 08-Jan-2010


Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Default temperature value used for catalyst solution temperature.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor
ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs at initial key on and continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank temperature does not match the ambient temperature sensor reading at initial key-on, or the tank temperature does not increase after an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • In-range failure of the diesel exhaust fluid tank temperature
  • Damaged wiring harness
  • Failed aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 1679 (Air-assisted).

Last Modified: 27-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679 (Airless)

Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Default temperature value used for aftertreatment diesel exhaust fluid tank temperature.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs at initial key on and continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank temperature does not match the ambient temperature sensor reading at initial key-on, or the tank temperature does not increase after an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the diesel exhaust fluid tank temperature
  • Damaged wiring harness
  • Damaged aftertreatment diesel exhaust fluid controller
Refer to Troubleshooting Fault Code 1679 (Airless).

Last Modified: 11-Jan-2010


Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. An error has been detected by the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Dosing System
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Dosing System

Circuit Description

For an air assisted SCR aftertreatment system, the aftertreatment diesel exhaust fluid dosing unit requires air pressure from the OEM air tanks. The diesel exhaust fluid dosing unit precisely measures the amount of diesel exhaust fluid (DEF or Urea) to be injected into the aftertreatment system. The diesel exhaust fluid dosing unit has three primary cycles. A priming cycle at initial engine start makes sure that diesel exhaust fluid is available at the diesel exhaust fluid dosing unit. During the dosing cycle, the diesel exhaust fluid is being delivered to the aftertreatment nozzle. A purge cycle occurs when the engine is turned off. The purge cycle makes sure that all the diesel exhaust fluid is removed from the diesel exhaust fluid line and aftertreatment nozzle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic consists of multiple parts, which run when the engine is first started, and make take up to 12 minutes to complete.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit is not able to provide the correct dosing rate to the aftertreatment nozzle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • The “Active” fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, it is necessary to use the INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test. Reference Procedure 019-440 in Section 19 in the appropriate service manual.
  • Make sure that the diesel exhaust fluid dosing unit is able to successfully to cycle through all phases (priming, dosing, and purging) and that diesel exhaust fluid flows evenly from the aftertreatment nozzle.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

The diesel exhaust fluid dosing unit system consists of three phases which occur in the following sequence: Priming, dosing, and purging.

Priming:

  • The dosing unit will attempt to prime every 30 seconds for 20 attempts. The attempts can be counted by listening for the air solenoid to click every 30 seconds.
  • The diesel exhaust fluid dosing unit can take up to 12 minutes to complete the priming cycle before a fault code will become active
  • During priming, the dosing unit will pump diesel exhaust fluid through the supply and return lines, and back to the tank.
  • Under most conditions, the system will prime within 3 or 4 attempts
  • If priming is not successful, the diesel exhaust fluid dosing unit will be disabled and fault code 1682 will be activated.

Dosing:

  • Immediately after successful priming the system will enter dosing mode. At this point the air solenoid will stop clicking and a constant flow of air will flow through the aftertreatment nozzle, which helps transport the diesel exhaust fluid and keep the aftertreatment nozzle clear.
  • The air flow will remain constant until the system reaches all dosing conditions before diesel exhaust fluid is delivered to the aftertreatment system (catalyst temperature greater than 200°C [392°F], engine speed and load conditions met, etc.)

Purging

  • After the engine is stopped and the keyswitch is turned off, the dosing unit enters the purging cycle, which clears any diesel exhaust fluid left in the line and aftertreatment nozzle after operation.
  • Purging consists of flowing compressed air through the aftertreatment nozzle and diesel exhaust fluid line for 30 seconds.
  • If the full purge time is not completed, it is possible to leave diesel exhaust fluid in the line, leading to a build up of hard urea crystals, resulting in a blocked diesel exhaust fluid line or aftertreatment nozzle.
  • If the vehicle is equipped with a battery isolation switch, it should have a built-in delay device to prevent power down of the dosing unit until the purge sequence is complete.
  • Incomplete purge events are recorded in the ECM and will be incremented at the next key on event.
  • Incomplete purge counts can be viewed using the Data Monitor/Logger menu in the aftertreatment section of INSITE™ electronic service tool.

Fault Code 1682 is triggered by the following external failure modes:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank.
  • Low air pressure is detected at the dosing control unit.
  • Air pressure is cycling below the minimum limit required by the dosing control unit.
  • Blocked or restricted aftertreatment nozzle Blocked, restricted, or frozen diesel exhaust fluid lines.
  • Plugged or restricted inline air filter.

Fault Code 1682 is triggered by the following internal diesel exhaust fluid dosing unit failure modes:

  • Diesel exhaust fluid dosing unit fails to initialize on keyswitch ON (fault code will be active immediately after keyswitch ON)
  • Build up of DEF crystals in the dosing unit restricts air flow to the aftertreatment nozzle, and possibly leads to build-ups and restrictions in the aftertreatment nozzle itself.
  • Internal pressure sensor failure causing the diesel exhaust fluid dosing unit to fail to prime. This will cause diesel exhaust fluid to flow from the aftertreatment nozzle when the air solenoid operates during priming. (fault code will be active after 12 minutes of consecutive prime attempts)
  • Internal poppet valve failure causing failure to prime. This will cause diesel exhaust fluid to flow continuously during priming. (fault code will be active after 12 minutes of failed prime attempts)
  • Contamination in the dosing unit inlet check valve from an external source, such as the diesel exhaust fluid line or tank
  • Diesel exhaust fluid dosing unit drawing in air through loose or damaged lines or connectors.
  • Plugged or restricted dosing unit inlet connector strainer.
Refer to Troubleshooting Fault Code 1682 (Air-assisted).

Last Modified: 30-Oct-2015


Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682 (Airless)

Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | The diesel exhaust fluid dosing unit will be unable to inject diesel exhaust fluid into the SCR aftertreatment system.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The diesel exhaust fluid dosing unit input lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and diesel exhaust fluid tank. These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on aftertreatment architecture and OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit has been unable to successfully prime itself for a calibratible number of attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser Override Test" under the "ECM Diagnostics Test" menu
  • The ECM will turn off the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

This fault indicates that the diesel exhaust fluid dosing unit was unable to successfully build pressure or prime after multiple attempts. If fault code 3612 is also stored in the ECM, the dosing unit might have failed to purge on multiple occasions, and dosing unit damage could possibly have occurred. Troubleshoot Fault Code 3612 after this fault code has been resolved.

Fault Code 1682 is triggered by the following failure modes:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code 1682 (Airless).

Last Modified: 08-Jan-2010


Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: P202C SPN: 3363 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater relay sensor circuit. | High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater relay sensor circuit.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The heating element is powered by the diesel exhaust fluid tank heater relay.

Component Location

The diesel exhaust fluid tank heater is located in the diesel exhaust fluid tank. The location of the diesel exhaust fluid tank heater relays will vary by OEM. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Circuit error between the ECM and the diesel exhaust fluid tank heater relay has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the MIL immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code can not detect any circuit failures on the heater side of the relay. Only circuit errors between the ECM and the relay can be detected by this fault code.

Possible causes of this fault code include:

  • Diesel exhaust fluid tank heater relay signal wire not connected to the relay
  • Diesel exhaust fluid tank heater relay return wire not connected to the relay
  • Malfunctioning diesel exhaust fluid tank heater relay
  • Open circuit in the diesel exhaust fluid tank heater relay signal wire
  • Open circuit in the diesel exhaust fluid tank heater relay return wire
  • Diesel exhaust fluid tank heater signal wire shorted to a voltage source.
Refer to Troubleshooting Fault Code 1683 (Air-assisted).

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683 (Airless)

Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: P202C SPN: 3363 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source. High supply voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | The aftertreatment diesel exhaust fluid tank heater will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary, depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller has detected high supply voltage at the diesel exhaust fluid tank heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails. Diesel exhaust fluid tank heating will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The diesel exhaust fluid tank heater control valve may be powered by an OEM suppied power relay, which is connected to the aftertreatment diesel exhaust fluid controller harness. When troubleshooting wiring harness issues, it may be necessary to include the optional line heater relay.

Possible causes of this fault code include:

  • Short to voltage in the aftertreatment diesel exhaust fluid controller harness
  • Diesel exhaust fluid tank heater signal wire and return wire shorted together
  • Malfunctioning diesel exhaust fluid tank heater control valve
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1683 (Airless).

Last Modified: 07-Sep-2009


Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: P205B SPN: 3363 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank heater relay sensor circuit. | The aftertreatment diesel exhaust fluid tank heater will be disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank, and will also thaw a frozen diesel exhaust fluid tank. The heating element is powered by the diesel exhaust fluid tank heater relay.

Component Location

The aftertreatment diesel exhaust fluid tank heater is located in the aftertreatment diesel exhaust fluid tank. The location of the aftertreatment diesel exhaust fluid tank heater relays will vary by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

A circuit error has been detected between the ECM and the diesel exhaust fluid tank heater relay.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code cannot detect any circuit failures on the heater side of the relay. Only circuit errors between the ECM and the relay can be detected by this fault code.

Possible causes of this fault code include:

  • A shorted aftertreatment diesel exhaust fluid tank heater relay
  • Aftertreatment diesel exhaust fluid tank heater signal wire shorted to ground.
Refer to Troubleshooting Fault Code 1684 (Air-assisted).

Last Modified: 28-Oct-2015


Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684 (Airless)

Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: P202B SPN: 3363 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal, or Shorted to Low Source. Low supply voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | The aftertreatment diesel exhaust fluid tank heater will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary, depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller has detected low supply voltage or a short circuit to ground at the diesel exhaust fluid tank heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid tank heating will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The diesel exhaust fluid tank heater control valve may be powered by an OEM suppied power relay, which is connected to the aftertreatment diesel exhaust fluid controller harness. When troubleshooting wiring harness issues, it may be necessary to include the optional line heater relay.

Possible causes of this fault code include:

  • Short to ground in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troublesooting Fault Code 1684 (Airless).

Last Modified: 07-Sep-2009


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1911 (ISB, ISD, ISF)

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: P157 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the rail fuel was higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power interruption associated with high-pressure relief valve reset.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Metering Rail 1 Pressure Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Metering Rail 1 Pressure Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump. The high-pressure relief valve is located on the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM has verified that the fuel rail pressure has exceeded the fuel pressure relief valve limiting pressure, and the fuel pressure relief valve opened.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Possible engine torque derate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

In normal engine operation, the ECM calibration varies the flow commanded to the fuel pump actuator to achieve the correct fuel rail pressure. System malfunctions that cause loss of pressure control can cause the fuel rail pressure relief valve to open. The fuel rail pressure relief valve acts to protect the high-pressure components from over-pressurization. If the ECM detects that the fuel rail pressure relief valve is open without detection of a fuel pump actuator circuit error, Fault Code 1911 will become active. On certain applications, the ECM will attempt to reset automatically, causing a momentary loss of power (less than 1 second).

Conditions that can cause Fault Code 1911:

  • Purging air through the fuel system can cause a pressure overshoot, and cause Fault Code 1911 to log. A few bubbles exiting the line during the air in fuel test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, refer to Procedure 006-020 in the Associated Procedures Table. The source of air entry should be isolated to one of the following: Suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).
  • Sustained periods of very low pressure under load, followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters (Fault Code 559 and 2372).
  • A tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.
  • If an intermittent electrical circuit problem with the fuel pump actuator circuit exists, it is possible for Fault Code 1911 to become active, then inactive during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to inspect for bad connectors or harness issues for Fault Code 1911 if no other fault codes exist. An electric fuel control actuator with excessive leakage will result in high rail fuel pressures at idle or light load.
  • Other conditions include large disturbances of system voltages. These may be caused by the following examples: ECM wiring harness issues, poor grounds, electrical noise, irregular alternator output, poor grounding of hybrid power generator systems, battery voltage spikes as when jump starting or activating a large electrical load.
  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.
Refer to Troubleshooting Fault Code 1911 (ISB, ISD, ISF).

Last Modified: 04-May-2012


Injector Metering Rail 1 Pressure Circuit - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 1911 (ISC, ISL, ISX, ISZ)

Injector Metering Rail 1 Pressure Circuit - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: P157 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the rail fuel is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power interruption associated with dump valve reset.
ISL9 CM2150 SN - Injector Metering Rail 1 Pressure Circuit
ISZ13 CM2150 - Injector Metering Rail 1 Pressure Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump. The high-pressure relief valve is located on the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure is above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

In normal engine operation, the ECM calibration varies the flow commanded to the fuel pump actuator to achieve the correct fuel rail pressure. System failures that cause loss of pressure control can cause the fuel rail pressure relief valve to open. The fuel rail pressure relief valve acts to protect the high-pressure components from over-pressurization. If the ECM detects that the fuel rail pressure relief valve is open without detection of a fuel pump actuator circuit error, Fault Code 1911 will become active. On certain applications, the ECM will attempt to reset automatically causing a momentary loss of power for less than 1 second.

Conditions that can cause Fault Code 1911:

  • Purging air through the fuel system can cause a pressure overshoot, therefore causing Fault Code 1911 to log. A few bubbles exiting the line during the air in fuel test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry should be isolated to one of the following: Suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).
  • Sustained periods of very low pressure under load followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters (Fault Code 559).
  • A tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.
  • If an intermittent electrical circuit problem with the fuel pump actuator circuit exists, it is possible for Fault Code 1911 to become active, then inactive, during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to inspect for bad connectors or harness issues for Fault Code 1911 if no other fault codes exist. A fuel pump actuator with excessive leakage will result in high rail fuel pressures at idle or light load.
  • Other conditions include ECM wiring harness issues such as poor grounds, battery voltage spikes, electrical noise, low alternator output, and large disturbances of battery voltage, as when jump-starting the vehicle.
  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.
Refer to Troubleshooting Fault Code 1911 (ISC, ISL, ISX, ISZ).

Last Modified: 30-Oct-2015


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 (2-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P2559 SPN: 111 FMI: 3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISZ13 CM2150 - Engine Coolant Level Sensor - 2 Wire Circuit
ISM11 CM876 SN - Engine Coolant Level Sensor - 2 Wire Circuit
ISZ13 CM2150 - Engine Coolant Level Sensor - 2 Wire Circuit

Circuit Description

The electronic control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes, based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continously when the keyswitch is in the ON position, or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195 (2-Wire Sensor).

Last Modified: 26-Apr-2012


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Engine Coolant Level Sensor 1 - 3 Wire Circuit
ISM11 CM876 SN - Engine Coolant Level Sensor 1 - 3 Wire Circuit
ISZ13 CM2150 - Engine Coolant Level Sensor 1 - 3 Wire Circuit

Circuit Description

The electronic control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195 (3-Wire Sensor).

Last Modified: 27-Oct-2015


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 (2-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P2558 SPN: 111 FMI: 4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Engine Coolant Level Sensor - 2 Wire Circuit
ISM11 CM876 SN - Engine Coolant Level Sensor - 2 Wire Circuit
ISZ13 CM2150 - Engine Coolant Level Sensor - 2 Wire Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the harness, sensor or connectors
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196 (2-Wire Sensor).

Last Modified: 26-Apr-2012


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P2558 SPN: 111 FMI: 4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Engine Coolant Level Sensor 1- 3 Wire Circuit
ISM11 CM876 SN - Engine Coolant Level Sensor 1- 3 Wire Circuit
ISZ13 CM2150 - Engine Coolant Level Sensor 1 - 3 Wire Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the engine harness, connector, or sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196 (3-Wire Sensor).

Last Modified: 27-Oct-2015


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: P0478 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Engine Brake Solenoid Number 1 Signal Circuit
ISL9 CM2150 SN - Engine Brake Solenoid Number 1 Signal Circuit
ISM11 CM876 SN - Engine Brake Solenoid Number 1 Signal Circuit
ISZ13 CM2150 - Engine Brake Solenoid Number 1 Signal Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The engine control module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 1 circuit pulse width modulated signal is detected to be greater than 0 volts when the pulse width modulated signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illumines the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 2182.

Last Modified: 02-Nov-2015


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: PO477 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Engine Brake Actuator Driver 1 Circuit
ISL9 CM2150 SN - Engine Brake Actuator Driver 1 Circuit
ISM11 CM876 SN - Engine Brake Actuator Driver 1 Circuit
ISZ13 CM2150 - Engine Brake Actuator Driver 1 Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The engine control module (ECM) controls engine brakes on cylinders 1, 2, and 3, by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the pulse width modulated device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 1 circuit pulse width modulated signal is not detected to be system voltage when the pulse width modulated signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include a short circuit to ground in the engine harness, connector, or engine brake solenoids.

Refer to Troubleshooting Fault Code 2183.

Last Modified: 02-Nov-2015


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363 (Heavy Duty)

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S080 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brakes on cylinders number 4, 5, and 6 can not be activated.
ISM11 CM876 SN - Engine Brake Solenoid Number 2 Signal Circuit
ISZ13 CM2150 - Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack™ connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is being energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes for this fault include:

  • A short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • A damaged ECM.
Refer to Troubleshooting Fault Code t05-2363 (Heavy Duty).

Last Modified: 26-Apr-2012


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363 (Midrange)

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S029 SPN: 1073 FMI: 4 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders 4, 5, and 6 can not be activated.
ISL9 CM2150 SN - Engine Brake Actuator Driver Output 2 Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack™ connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the vehicle so that the engine brakes are activated. This will allow the diagnostics to run and pass.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes, or at the next key cycle.
  • This fault code can also be cleared with the INSITE electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an active or inactive fault code.

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2363 (Midrange).

Last Modified: 30-Oct-2015


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367 (Heavy Duty)

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S080 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid Number 2 signal circuit. | Engine brakes on cylinders 4, 5, and 6 can not be deactivated, or can not be activated.
ISM11 CM876 SN - Engine Brake Solenoid Number 2 Signal Circuit
ISZ13 CM2150 - Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack™ connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is being energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is detected to be system voltage when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the MIL immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 can not be energized.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault include:

  • An open circuit in the engine harness, brake harness, or engine brake solenoids.
  • A short to voltage source in the engine harness.
  • A damaged ECM.
Refer to Troubleshooting Fault Code t05-2367 (Heavy Duty).

Last Modified: 26-Apr-2012


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367 (Midrange)

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S80 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders 4, 5, and 6 can not be activated.
ISL9 CM2150 SN - Engine Brake Actuator Driver Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is being energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is detected to be system voltage when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 can not be energized.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the vehicle so that the engine brakes are ativated. This will allow the diagnostics to run and pass.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes, or at the next key cycle.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an active or inactive fault code.

Possible causes of this fault code include:

  • An open circuit in the engine harness, brake harness, or engine brake solenoids
  • A short to voltage source in the engine harness
  • A damaged ECM.
Refer to Troubleshooting Fault Code t05-2367 (Midrange).

Last Modified: 30-Oct-2015


Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2772 (Air-assisted)

Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2772 PID: SPN: 3226 FMI: 15 LAMP: Amber SRT: | Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level. The engine NOx output is higher than recommended levels. | None on performance.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Outlet NOx Sensor Circuit
ISM11 CM876 SN - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device that communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system, at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. The NOx sensor gathers data over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the NOx output is higher than a calibratible value for two consecutive ignition cycles.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL).

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool. It is necessary to drive or operate the vehicle on a chassis dynamometer in order to validate the repair and for the fault code to go inactive.
  • Connect INSITE™ electronic service tool, and start the "Aftertreatment High NOx Reset" test from the "ECM Diagnostic Tests" screen. Operate the vehicle per the instructions on the screen. If the completion status of the NOx reset test slows or stops advancing, vary the engine speed and load until the NOx reset test completes data collection and a decision is made. See below for additional tips to assist in operating the diagnostic.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurrence.

Tips for conducting the diagnostic:

  • Aftertreatment selective catalytic reduction (SCR) catalyst intake and outlet temperatures should be above 240°C [464°F].
  • Load the engine by operating at approximately 1000 rpm while in high gear.
  • Apply the throttle at greater than 60 percent to allow the dosing percentage to be over 100 percent.
  • Vary the engine speed between 1000 and 1500 rpm.
  • Try to achieve a dosing value of just over 100 percent with as little throttle as possible.

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid quality is not within specification
  • External leaks in the diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines
  • Aftertreatment nozzle has malfunctioned
  • Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged
  • Sulfur content of the diesel fuel is too high, fouling the SCR catalyst and resulting in high NOx output
  • Aftertreatment nozzle is partially or completely plugged.
Refer to Troubleshooting Fault Code 2772 (Air-assisted).

Last Modified: 30-Oct-2015


Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2772 (Airless)

Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2772 PID: SPN: 3226 FMI: 15 LAMP: Amber SRT: | Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level. The engine NOx output is higher than recommended levels. | Aftertreatment Outlet NOx Sensor operation will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device that receives commands from the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system, at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. The NOx sensor gathers data over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the NOx output is higher than a calibratible value for two consecutive ignition cycles.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL).

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool. It is necessary to drive or operate the vehicle on a chassis dynamometer in order to validate the repair and for the fault code to go inactive.
  • Use the INSITE™ electronic service tool to connect to the engine, and start the "Aftertreatment High NOx Reset" test from the "ECM Diagnostic Tests" screen. Operate the vehicle per the instructions on the screen. If the completion status of the reset test slows or stops advancing, vary the engine speed and load until the reset test completes and a decision is made.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurrence..

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid quality is not within specification
  • External leaks in the diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines
  • Diesel exhaust fluid dosing valve has malfunctioned
  • Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged
  • Sulfur content of the diesel fuel is too high, fouling the selective catalytic reduction (SCR) catalyst and resulting in high NOx output
  • Diesel exhaust fluid dosing valve is partially or completely plugged.
Refer to Troubleshooting Fault Code 2772 (Airless).

Last Modified: 14-May-2012


Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 2773 (Air-assisted)

Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2773 PID: SPN: 3226 FMI: 0 LAMP: Amber SRT: | Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level. The engine NOx output is higher than recommended levels. | Aftertreatment outlet NOx sensor operation will be disabled. Engine will derate the next time the vehicle is at zero vehicle speed.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Outlet NOx Sensor Circuit
ISM11 CM876 SN - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. The NOx sensor gathers data over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the NOx output is higher than a calibratible value for two consecutive ignition cycles.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL).
  • An engine torque derate will be activated immediately when the fault code becomes active.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool. It is necessary to drive or operate the vehicle on a chassis dynamometer in order to validate the repair and for the fault code to go inactive.
  • Connect INSITE™ electronic service tool, and start the "Aftertreatment High NOx Reset" test from the "ECM Diagnostic Tests" screen. Operate the vehicle per the instructions on the screen. If the completion status of the NOx reset test slows or stops advancing, vary the engine speed and load until the NOx reset test completes data collection and a decision is made. See below for additional tips to assist in operating the diagnostic:
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occrance.

Tips for running the diagnostic:

  • Load the engine by operating at approximately 1000 rpm while in high gear.
  • Apply the throttle at greater than 60 percent to allow the dosing percentage to be over 100 percent.
  • Vary the engine speed between 1000 and 1500 rpm.
  • Try to achieve a dosing value of just over 100 percent with as little throttle as possible.

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid quality is not within specification
  • External leaks in the diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines
  • Sulfur content of the diesel fuel is too high, fouling the SCR catalyst and resulting in high NOx content
  • Aftertreatment nozzle has malfunctioned
  • Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged
  • Aftertreatment nozzle is partially or completely plugged
  • Aftertreatment SCR catalyst is damaged or missing.
Refer to Troubleshooting Fault Code 2773 (Air-assisted).

Last Modified: 30-Oct-2015


Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 2773 (Airless)

Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2773 PID: SPN: 3226 FMI: 0 LAMP: Amber SRT: | Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level. The engine NOx output is higher than recommended levels. | Aftertreatment outlet NOx sensor operation will be disabled. Engine will derate the next time the vehicle is at zero vehicle speed.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. The NOx sensor gathers data over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the NOx output is higher than a calibratible value for two consecutive ignition cycles.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL).
  • An engine torque derate will be activated immediately when the fault code becomes active.

Conditions for Clearing the Fault Code

  • This fault code cannot be cleared with INSITE™ electronic service tool. It is necessary to drive or operate the vehicle on a chassis dynamometer in order to validate the repair and for the fault code to go inactive.
  • Connect to the engine with INSITE™ electronic service tool, and start the "Aftertreatment High NOx Reset Test" from the "ECM Diagnostic Tests" screen. Operate the vehicle per the instructions on the screen. If the completion status of the reset test slows or stops advancing, vary the engine speed and load until the reset test completes and a decision is made.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after the completion of 9600 hours of engine operation without a re-occurrence.

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid quality is not within specification
  • External leaks in diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines
  • Sulfur content of the diesel fuel is too high, fouling the SCR catalyst and resulting in high NOx
  • Diesel exhaust fluid dosing valve has malfunctioned
  • Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged
  • Diesel exhaust fluid dosing valve is partially or completely plugged.
  • Aftertreatment SCR catalyst is damaged or missing.
Refer to Troubleshooting Fault Code 2773 (Airless).

Last Modified: 05-Jan-2011


Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3237 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3237 PID: S254 SPN: 4340 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Diesel exhaust fluid line heater 1 will be disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 1 is controlled by the ECM, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the aftertreatment nozzle.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the heater is commanded on.

Conditions for Setting the Fault Codes

The ECM detects that the line heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails
  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded on for the diagnostic to run and the fault to go inactive
  • Use the INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests".
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Short circuit to battery in the OEM wiring harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 3237 (Air-assisted).

Last Modified: 27-Oct-2015


Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3237 (Airless)

Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3237 PID: S254 SPN: 4340 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Diesel exhaust fluid line heater 1 will be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 1 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line, between the diesel exhaust fluid dosing unit and diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the heater is commanded ON.

Conditions for Setting the Fault Codes

The aftereatment diesel exhaust fluid controller detects that the line heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • Upon completion of the repair, the heater must be commanded ON for the diagnostic to run and the fault to go inactive.
  • Use the INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests".
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE ™ electronic service tool.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller
Refer to Troubleshooting Fault Code 3237 (Airless).

Last Modified: 24-Sep-2009


Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3569 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3569 PID: SPN: 3362 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Lines - Mechanical System Not Responding or Out of Adjustment. An issue with diesel exhaust fluid (DEF) delivery has been detected. | System will be unable to spray DEF into the aftertreatment system.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The DEF dosing unit supplies DEF to the aftertreatment nozzle through the nozzle supply line.

Component Location

There are three DEF lines. One line is between the dosing unit and aftertreatment nozzle, and the other two lines are between the dosing unit and DEF tank. These lines can be partially hidden from view by the selective catalytic reduction (SCR) system and other vehicle components. Line routing will vary, based on aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously while the SCR system is dosing DEF into the aftertreatment system.

Conditions for Setting the Fault Codes

The DEF dosing unit has detected a blockage in the nozzle supply line (between the dosing unit and the aftertreatment nozzle).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • The “active” fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, it is necessary to use the INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test. Refer to Procedure 019-440 in Section 19.
  • Make sure that the diesel exhaust fluid dosing unit is able to successfully cycle through all phases (priming, dosing, and purging) and that diesel exhaust fluid flows evenly from the aftertreatment nozzle.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

This fault indicates that the diesel exhaust fluid dosing unit was able to build pressure, but not able to spray diesel exhaust fluid into the exhaust stream.

Possible causes of this fault code are:

  • Blocked or restricted aftertreatment nozzle
  • Blocked or restricted aftertreatment nozzle supply line
  • Malfunctioning diesel exhaust fluid dosing unit.

Some crystal build up occurs naturally during normal operation, but can be accelerated by incomplete purging. If blocked diesel exhaust fluid lines due to buildups are detected, make sure that the dosing unit is purging correctly at key OFF. Incomplete purge counts can be viewed using the Data Monitor/Logger menu in the aftertreatment section of INSITE™ electronic service tool. Incomplete purge counts are not necessarily detrimental to operation, but can be used as an indicator to assist in troubleshooting purge effectiveness. If the vehicle is equipped with a battery isolation switch, it should have a built-in delay device to prevent powering down of the dosing unit until the purge sequence is complete.

Refer to Troubleshooting Fault Code 3569 (Air-assisted).

Last Modified: 02-Feb-2016


Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3569 (Airless)

Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3569airless PID: SPN: 3362 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment. An issue with diesel exhaust fluid delivery has been detected. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Dosing Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and diesel exhaust fluid tank. These lines can be partially hidden from view by the Selective Catalytic Reduction (SCR) system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and dosing is being commanded.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller has detected a mechanical failure of the dosing input lines, and diesel exhaust fluid is not being delivered to the dosing valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code cannot be cleared with INSITE™ electronic service tool.
  • To validate the repair, use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser Override Test" under the "ECM Diagnostics Test" menu.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

This fault indicates that the diesel exhaust fluid dosing unit was able to build pressure, but could not complete the priming cycle. Troubleshoot all other active SCR related faults before this fault.

Possible causes of this fault code are:

  • Blocked or restricted aftertreatment dosing valve.
  • Blocked or restricted aftertreatment dosing valve supply line

Refer to Troubleshooting Fault Code 3569 (Airless).

Last Modified: 26-Oct-2009


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575 (Air-assisted)

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level. Pressure has been detected in the diesel exhaust fluid dosing system when no pressure was expected. | System will be unable to spray diesel exhaust fluid into the aftertreatment system.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit
ISM11 CM876 SN - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The diesel exhaust fluid dosing unit returns diesel exhaust fluid to the tank through the return line.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and aftertreatment nozzle, and the other two lines are between the dosing unit and diesel exhaust fluid tank. These lines can be partially hidden from view by the Selective Catalytic Reduction (SCR) system and other vehicle components. Line routing will vary, based on aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is initially started and the SCR system is priming.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit has detected a blockage in the return line (between the dosing unit and the tank).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, it is necessary to start and idle the engine for up to 5 minutes to allow the diagnostic to run.
  • Make sure that the diesel exhaust fluid dosing unit is able to successfully prime.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

This fault indicates that the diesel exhaust fluid dosing unit was unable to return diesel exhaust fluid to the tank.

Possible causes of this fault code include:

  • Blocked or restricted diesel exhaust fluid return line
  • Malfunctioning diesel exhaust fluid dosing unit.

If diesel exhaust fluid lines blocked by buildup are detected, make sure that the dosing unit is purging correctly at key OFF. Incomplete purging of the dosing unit can also result in dosing unit damage caused by the freezing of the leftover diesel exhaust fluid in the system. Incomplete purge counts can be viewed using the Data Monitor/Logger menu in the aftertreatment section of INSITE™ electronic service tool. If the vehicle is equipped with a battery isolation switch, it must have a built-in delay device to prevent powering down of the dosing unit until the purge sequence is complete. If an OEM issue is identified as the cause of the malfunction, it must be documented and reported to the OEM as appropriate.

Refer to Troubleshooting Fault Code 3575 (Air-assisted).

Last Modified: 02-Nov-2015


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575 (Airless)

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing unit has detected a blockage in the diesel exhaust fluid return flow. | Diesel exhaust fluid injection into the aftertreatment system can be disabled.
ISF2.8 CM2220 AN/ISF3.8 CM2220 AN - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The diesel exhaust fluid controller provides a 5 volt supply and a ground to the diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes based on the diesel exhaust fluid pressure supplied by the dosing unit. The diesel exhaust fluid controller will detect a low signal voltage at low diesel exhaust fluid pressures, and high signal voltage at high diesel exhaust fluid pressures. The aftertreatment diesel exhaust fluid pressure sensor reading is communicated to the engine control module (ECM) via the engine data link.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and cannot be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The pressure sensor in the diesel exhaust fluid dosing unit has detected pressure, when no diesel exhaust fluid pressure is expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test found under ECM Diagnostic Tests in INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Refer to Troubleshooting Fault Code t05-3575airless.

Last Modified: 20-Nov-2012


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435 (Sensor)

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. The engine oil pressure sensor is reading an erratic value at key-on. | None on performance. No engine protection for oil pressure.
ISM11 CM876 SN - Engine Oil Pressure Circuit
ISZ13 CM2150 - Engine Oil Pressure Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the sensor will open and cause Fault Code 435 to log.

The oil pressure sensor is normally closed when the engine is not operating and open when oil pressure is present.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

This fault code is logged when an open circuit is detected for five consecutive key cycles when the ECM expected a closed circuit at key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include.

  • Damaged engine oil pressure sensor
  • Open circuit in the engine oil pressure sensor signal wire
  • Damaged ECM
  • Short circuit in the engine oil pressure sensor signal wire to a voltage source.
Refer to Troubleshooting Fault Code 435 (Sensor).

Last Modified: 03-Feb-2010


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435 (Switch)

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. An error in the engine oil pressure switch signal was detected by the ECM. | None on performance. No engine protection for oil pressure.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Engine Oil Pressure Switch Circuit
ISL9 CM2150 SN, ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Engine Oil Pressure Switch Circuit

Circuit Description

The engine oil pressure switch is used by the electric control module (ECM) to monitor the lubricating oil pressure. The oil pressure switch is normally closed when the engine is not operating and open when the engine is in operation and oil pressure is present.

Component Location

The location of the oil pressure switch varies by engine model.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure switch is indicating that oil pressure is present (switch is open) at intial key-ON for two consecutive key cycles, when the ECM expected to see no oil pressure (switch closed) at key-ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Turn the key to the ON position but do not start the engine.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with the INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine oil pressure switch
  • Open circuit in the engine oil pressure switch signal wire
  • Damaged ECM
  • Short circuit in the enigne oil pressure switch signal wire to a voltage source.
Refer to Troubleshooting Fault Code 435 (Switch).

Last Modified: 28-Oct-2015


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: SPN: 157 FMI: 18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start or low power. Engine could possibly not start.
ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Injector Metering Rail 1 Pressure Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN - Injector Metering Rail 1 Pressure Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The engine control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM has detected the measured fuel rail pressure is below the commanded fuel rail pressure by at least 250 bar [3625 psi] for 7 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will go inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Before performing troubleshooting work, verify the vehicle's system voltage by monitoring battery voltage in INSITE™ electronic service tool data monitor or by connecting a digital volt ohm meter to the batteries. This will help identify a potential system voltage issue. Refer to the OEM service manual for the specified voltage range and troubleshooting procedures.

If the engine will not start and Fault Code 559 comes active during cranking, but no speed sensor fault codes exist, monitor rail pressure with INSITE™ electronic service tool. The procedures referred to in this troubleshooting tree will also have checks for engine no start conditions.

Before servicing any fuel system components, (such as fuel lines, fuel pump, injectors, and so forth), which would expose the fuel system or internal engine components to potential contaminants prior to disassembly, clean the fittings, mounting hardware, and the area around the component to be removed. Dirt or contaminants can be introduced into the fuel system and engine if the surrounding areas are not cleaned, resulting in damage to the fuel system and engine. Use Procedure 000-009 in Section 0.

If fuel pressure is low, check the following:

  • Fuel system prime (make sure that there is fuel in the tanks and that the system is primed)
  • Fuel gear pump pressure.

If fuel gear pump pressure is correct, test for system leakage:

  • High-pressure pump leakage
  • Injector leakage
  • Fuel rail pressure relief valve.

If Fault Code 559 is inactive and there are no existing performance complaints, it is possible that the vehicle was run out of fuel or that the fault came active if the engine was not primed following fuel filter replacement. Clear the inactive fault code.

Fault Code 559 sets when the engine is running and measured rail fuel pressure remains at least 100 Bar [1450 psi] less than commanded pressure. Once detected, Fault Code 559 will remain active until the engine is turned off or until the measured rail fuel pressure matches the commanded rail fuel pressure. When a condition exists that causes Fault Code 559 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

When Fault Code 559 occurs, the fuel system has lost its ability to maintain rail fuel pressure. Causes of this fault include:

  • Fuel inlet restrictions
  • Fuel filter plugging
  • Fuel gear pump output low
  • Fuel gear pump pressure regulator sticking or leaking
  • High-pressure pump capacity decay (high leakage to drain from the high pressure pump)
  • Fuel rail pressure relief valve leaks to drain
  • Fuel rail pressure relief valve opens at too low a pressure
  • Injector fuel circuit leaks to drain
  • Pressure sensor reads more than 100 bar [1450 psi] lower than actual pressure
  • Air in the fuel.

A few bubbles exiting the line during the test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry can be isolated to one of the following:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipe(s) in the fuel tank(s).

The fuel rail pressure sensor can be checked. When checking the fuel rail pressure sensor accuracy, make certain the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system, to allow the pressure to decrease to a lower level. There can be a significant amount of time waiting on the rail to depressurize to zero. It might become be necessary to manually relieve the pressure from the high-pressure fuel rail.

Intermittent ECM power supply connections can cause Fault Code 559. If the engine is running with an active Fault Code 559 and Fault Codes 449, 1911, or 2311 are not present, check the ECM power supply for intermittent connections or battery issues. Fault Code 1117 can also be active if this fault condition exits.

Inactive Fault Code/Exhausted Troubleshooting Tree:

Troubleshooting inactive Fault Code 559 can be very difficult. The fault code must be active for any of the outlined procedures in which the engine is operated during the test. For engines with high counts of inactive Fault Code 559 or if the troubleshooting tree has been exhausted, operate the engine on a chassis dynamometer or a diagnostic road test to duplicate the fault code. The most common causes of intermittent Fault Code 559 that are difficult to create are leaking high-pressure connectors that only leak when the engine and the fuel are hot, intermittent fuel supply restrictions, (such as debris floating in the fuel tank), and a fuel pressure relief valve that opens prematurely. Check the High Pressure Connector (HPC) and connector torque, and torque to specification if necessary. Operate the engine on a chassis dynamometer or conduct a diagnostic road test to duplicate the fault code. Use INSITE™ electronic service tool to log fuel system parameters during testing.

Refer to Troubleshooting Fault Code 559.

Last Modified: 25-Apr-2012


Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke. Engine could possibly not start.
Fuel Flow
ISZ13 CM2150 - Injector Metering Rail 1 Pressure

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The electronic control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

The fuel rail pressure sensor is mounted to the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM has detected the measured fuel rail pressure is below the commanded fuel rail pressure by a calibratable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Before performing troubleshooting work, verify the vehicle's system voltage by monitoring battery voltage in INSITE™ electronic service tool data monitor or connecting a digital volt ohm meter to the batteries. This will help identify a potential system voltage issue. Refer to the OEM service manual for specified voltage range and troubleshooting procedures.

If the engine will not start and Fault Code 559 becomes active during cranking, but no speed sensor fault codes exist, monitor rail pressure with INSITE™ electronic service tool. The procedures referred to in this troubleshooting tree will also have checks for engine no-start conditions.

Before servicing any fuel system components, (such as fuel lines, fuel pump, injectors, etc.) which would expose the fuel system or internal engine component to potential contaminants prior to disassembly, clean the fittings, mounting hardware, and the area around the component to be removed. Dirt or contaminants can be introduced into the fuel system and engine if the surrounding areas are not cleaned, resulting in damage to the fuel system and engine. Refer to Procedure 000-009 in Section 0. This procedure is found in the ISC and ISL CM2150 Service Manual, Bulletin 4021569 and in the ISLe CM2150 Service Manual, Bulletin 4021630.

If rail pressure is low, check the following:

  • Fuel system prime (make sure there is fuel in the tanks and the system is primed)
  • Fuel lift pump pressure
  • Fuel gear pump pressure.

If gear pump pressure is OK, test for system leakage:

  • High-pressure pump leakage
  • Injector leakage
  • Fuel rail pressure relief valve.

If Fault Code 559 is inactive and there are no existing performance complaints, it is possible the vehicle was run out of fuel or the fault came active if the engine was not primed following fuel filter replacement. Clear the inactive fault code.

Fault Code 559 sets when the engine is operating and measured rail fuel pressure remains at least 100 bar [1450 psi] less than commanded pressure. Once detected, Fault Code 559 will remain active until the engine is turned off or until the measured rail fuel pressure matches the commanded rail fuel pressure. When a condition exists that causes Fault Code 559 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

When Fault Code 559 occurs, the fuel system has lost its ability to maintain rail fuel pressure.

Causes of this fault include:

  • Fuel inlet restrictions
  • Fuel filter plugging
  • Fuel gear pump output low
  • Fuel gear pump pressure actuator sticking or leaking
  • High pressure pump capacity decay (high leakage to drain from the high-pressure pump)
  • Fuel rail pressure relief valve leaks to drain
  • Fuel rail pressure relief valve opens at too low a pressure
  • Injector fuel circuit leaks to drain
  • Pressure sensor reads more than 100 bar [1450 psi] lower than actual pressure
  • Air in the fuel.

A few bubbles exiting the line during the test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry can be isolated to one of the following; suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).

The fuel rail pressure sensor can also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Once the engine is keyed OFF, there could be a significant amount of time waiting on the fuel to depressurize to 0. It is necessary to manually relieve the pressure from the high-pressure fuel rail by loosening the pump to rail line at the rail.

Intermittent ECM power supply connections can cause Fault Code 559. If the engine is operating with an active Fault Code 559 and Fault Codes 449, 1911, or 2311 are not present, check the ECM power supply for intermittent connections. Fault Code 1117 can also be active if this fault condition exists.

Inactive Fault Code/Exhausted Troubleshooting Tree:

Troubleshooting inactive Fault Code 559 can be very difficult. The fault code must be active for any of the outlined procedures in which the engine is operated during the test. For engines with high counts of inactive Fault Code 559, or if the troubleshooting tree has been exhausted, operate the engine on a chassis dynamometer or a diagnostic road test to duplicate the fault code. The most common causes of intermittent Fault Code 559 that are difficult to create are leaking high-pressure connectors that only leak when the engine and the fuel are hot, intermittent fuel supply restrictions, such as debris floating in the fuel tank, and a fuel pressure relief valve that opens prematurely. Check the High Pressure Connector (HPC) and connector torque, and tighten to specification if necessary. Operate the engine on a chassis dynamometer or conduct a diagnostic road test to duplicate the fault code. Use INSITE™ electronic service tool to log fuel system parameters during testing.

Refer to Troubleshooting Fault Code 559.

Last Modified: 29-Nov-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 115. | Active or inactive counts of Fault Code 115?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 115.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 115?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete.

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Feb-2017


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | IF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | IF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | Signature™ ISX and QSX15 | 3666259
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310840
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 40221704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367219
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | Signature™ ISX and QSX15 | 3666259
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310840
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367219
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Signature™ ISX and QSX15 | 3666259
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete.

Last Modified: 28-Apr-2017


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 43367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB.ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310840
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367219
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 volt SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 or 1696 active?
 | STEP 1B. Check for an active fault code. | Fault Code 133 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 or 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Codes 1695 and/or 1696.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit supply voltage and return circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal position sensor +5 volt SUPPLY pin to the remote accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal or lever has been detected.

Replace the remote accelerator pedal or lever. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever RETURN pin and the OEM harness remote accelerator pedal RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 134 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal position +5 volt SUPPLY pin to the remote accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the remote accelerator pedal position +5 volt SUPPLY pin and the remote accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal has been detected.

Replace the remote accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SUPPLY pin and the OEM harness remote accelerator pedal or lever connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SIGNAL pin and the OEM harness remote accelerator pedal connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Jul-2017


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High in Section TS, in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2013


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate faultcode troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISV5.0 CM3230 V104 | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for QSK78, QSK23, and ISV5.0 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4327291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for ISV5.0 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except IISV5.0 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISM/QSM11 CM570 | 3666266
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in the appropriate service manual.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for all engines except QSM11 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.
  • Use the following procedure for QSM11 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 175 - Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 175 active?
STEP 2. | Check the intake throttle actuator motor and circuit. |
 | STEP 2A. Inspect the intake throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake throttle actuator motor. | Less than 15 ohms?
 | STEP 2B-1. Check for an open circuit in the intake throttle actuator motor. |
 | STEP 2B-2. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to a voltage source. | Less than 1.5-VDC?
 | STEP 3C. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 175 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 175 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake throttle actuator motor and circuit.

Guided Step 2A - Inspect the intake throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake throttle actuator from the engine harness.

Action

Inspect the intake throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake throttle actuator motor circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake throttle actuator to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the intake throttle actuator motor circuit.

  • Measure the resistance between the intake throttle actuator motor connector SIGNAL (+) pin and the intake throttle actuator motor connector SIGNAL (-) pin at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B-1

Guided Step 2B-1 - Check for an open circuit in the intake throttle actuator motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake throttle actuator from the engine harness.

Action

Check for an open circuit in the intake throttle actuator motor.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin and the intake throttle actuator motor SIGNAL (-) pin at the intake throttle actuator motor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

An open circuit has been detected in the intake throttle actuator motor circuit.

Replace the intake throttle actuator assembly.

Go to 2B-2

Go to 4A

Guided Step 2B-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.

Action

Check for an open circuit in the engine harness. Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (+) pin at the intake throttle actuator connector of the engine harness.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (-) pin at the intake throttle actuator connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit to voltage has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 175 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Feb-2017


FAULT CODE 176 - Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F101 | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISD6.7 CM2880 D101 | 5411372
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F129 | 5411325
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 176 active?
STEP 2. | Check the engine intake throttle actuator motor and circuit. |
 | STEP 2A. Inspect the engine intake throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the engine intake throttle actuator motor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin to pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 176 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 176 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator motor and circuit.

Guided Step 2A - Inspect the engine intake throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator motor from the engine harness.

Action

Inspect the engine harness and the engine intake throttle actuator motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the engine intake throttle actuator motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Check for a short circuit to ground in the engine intake throttle actuator motor.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine intake throttle actuator. Refer to Procedure 010-140 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine intake throttle actuator.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine intake throttle actuator.

Action

Check for a short circuit from pin to pin in the engine harness.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 176 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jan-2017


FAULT CODE 177 - Electronic Throttle Control Actuator Driver Circuit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220, ISF2.8 CM2220 EC, ISF2.8 CM2220 ECF2, ISF2.8 CM2220 AN, ISF2.8 CM2220 IAN | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F101 | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220, ISF2.8 CM2220 EC, ISF2.8 CM2220 ECF2, ISF2.8 CM2220 AN, ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 177 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the engine intake throttle. |
 | STEP 2A. Check for a restricted engine intake throttle. | Restriction or debris blocking the engine intake throttle?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine intake throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3C. Inspect the engine intake throttle actuator motor connector pins. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 177 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the engine intake throttle.

Guided Step 2A - Check for a restricted engine intake throttle.

Conditions

  • Turn keyswitch OFF.

Action

Check for a restricted engine intake throttle.

  • Inspect the engine intake throttle for a restriction or debris blocking the throttle plate. Refer to Procedure 010-140 in the Associated Procedures Table.

Restriction or debris blocking the engine intake throttle?
YES NO

Remove the restriction or debris. Refer to Procedure 010-140 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine intake throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine intake throttle actuator motor from the engine harness.

Action

Inspect the engine intake throttle actuator motor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an open circuit.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (+) pin at the intake throttle actuator connector of the engine harness.
  • Measure the resistance between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (-) pin at the intake throttle actuator connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioning engine intake throttle has been detected.

Replace the engine intake throttle. Refer to Procedure 010-140 in the Associated Procedures Table.

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete

Escalate or call for assistance.

Last Modified: 26-May-2017


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM3250 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISM11 CM876 SN | 4022196
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISZ13 CM2150 | 4022133
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 ECF | 2883557
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12 CM2350 X102 | 4310646
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2350 X101 | 4310641
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K116 | 4367444
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K117 | 4367449
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 SN | 4310736
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK95 CM2350 K111 | 4358519
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK23 CM2250 K109 | 4367358
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G110 | 4367323
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2250 K112 | 4367454
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 X115 | 4388739
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X114B | 5411181
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X116B | 5411186
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G113 | 5467252
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signalcircuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISM11 CM876 SN | 4022196
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISZ13 CM2150 | 4022133
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 ECF | 2883557
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12 CM2350 X102 | 4310646
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2350 X101 | 4310641
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 SN | 4310736
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK95 CM2350 K111 | 4358519
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G110 | 4367323
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K116 | 4367444
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K117 | 4367449
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK23 CM2250 K109 | 4367358
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2250 K112 | 4367454
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 X115 | 4388739
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X114B | 5411181
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X116B | 5411186
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G113 | 5467252
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Fault Code 214 active or inactive with more than one count logged in the last 25 hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active or inactive with more than one count logged in the last 25 hours?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2017


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Do not operate a diesel engine where there are or can be combustible vapors. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to the application, is operating in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. The equipment owner and operator are responsible for safe operation in a hostile environment. Contact a Cummins® Authorized Repair Location for further information.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring down hill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring down hill?
YES NO
No Repair

Check for engine damage.

  • Electronics are ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is operating.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Troubleshoot Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not operating above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or the vessel in a sea trail to determine if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-May-2017


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K117 | 4367449
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 L121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 L121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the ECM. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the vehicle settings in INSITE™ electronic service tool.

Guided Step 1A - Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Repair the damaged connector pins.
  • Repair or replace the engine harness with the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector and engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor circuit.

  • Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

Extra devices?
YES NO

Remove the device or see equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Check for the gear slipping.

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

Gear or tone wheel damaged or slips?
YES NO

See equipment manufacturer service information to repair or replace the gear or tone wheel.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Nov-2015


FAULT CODE 242 - Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are correct. |
 | STEP 1A. Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled. | Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
 | STEP 1B. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | Setting in INSITE™ electronic service tool matches the speed sensor type on vehicle?
 | STEP 1C. Verify that the Anti-Tampering Sensitivity Level is set correctly for the application. | Sensitivity level set correctly?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering evidence, incorrect installation, or external device present?
 | STEP 2B. Check for open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal. | INSITE™ electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed is accurate?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify that the feature settings are correct.

Guided Step 1A - Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled.

Action

Verify that the customer wants Vehicle Speed Sensor Anti-Tampering feature enabled.

Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Vehicle Speed Sensor Anti-Tampering feature.

Go to 1B

Go to 4A

Guided Step 1B - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

Setting in INSITE™ electronic service tool matches the speed sensor type on vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1C

Go to 4A

Guided Step 1C - Verify that the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level set correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 2A

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering evidence, incorrect installation, or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use INSITE™ to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is 0 when the vehicle is stationary and the engine is operating.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed reading by INSITE™ electronic service tool to the speedometer on the dash.

INSITE™ electronic service tool readout and the vehicle speedometer match?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Vehicle moving.

Action

Use INSITE™ electronic service tool to verify that the speed reported is accurate or reasonable for the present gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data.)

Vehicle speed is accurate?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Mar-2017


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60.8 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5411484

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and supply wire. | Greater than 5 VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

See equipment manufacturer service information.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage and supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 249 - Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 249 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 256 active and Fault Code 249 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 249 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and the ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the ambient air temperature SIGNAL pin and the ambient air temperature RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active and Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES NO

A damaged ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Use a wiring diagram for pin identificaton and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 252 - Engine Oil Level - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Lubricating Oil Level Sensor | Refer to Procedure 019-056 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 252 inactive?
STEP 2. | Check the oil level sensor circuit. |
 | STEP 2A. Inspect the oil level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the oil level sensor. | 4.75-VDC to 5.25-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the oil level sensor voltage at the ECM. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open circuit in the oil level sensor signal circuit. |
 | STEP 3B-2. Check for a short circuit in the oil level sensor signal circuit. |
 | STEP 3B-3. Check for a short circuit to ground in the oil level sensor signal circuit. |
 | STEP 3B-4. Check the fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 252 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil level sensor and circuit.

Guided Step 2A - Inspect the oil level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.

Action

Inspect the engine harness and oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection tecniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the oil level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil level sensor +5 volt SUPPLY pin to the oil level sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the oil level sensor voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil level sensor +5 volt SUPPLY pin to the oil level sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO

An open circuit in the oil level sensor power SUPPLY or RETURN circuit has been detected in the engine harness.

Replace the engine harness.

Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 252 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or short has been detected in the engine harness on the oil level sensor +5 volt SUPPLY or RETURN circuit.

Repair or replace the engine harness. Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open circuit in the oil level sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the oil level sensor signal circuit.

  • Measure the resistance between the oil level sensor SIGNAL pin at the oil level sensor engine harness connector and the oil level sensor SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the oil level sensor signal circuit.

Repair or replace the engine harness. Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for a short circuit in the oil level sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the oil level sensor signal circuit.

  • Measure the resistance between the oil level sensor SIGNAL pin at the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the oil level sensor signal circuit.

Repair or replace the engine harness. Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for a short circuit to ground in the oil level sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the oil level sensor signal circuit.

  • Measure the resistance between the between the oil level sensor SIGNAL pin at the ECM engine harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the oil level sensor signal circuit.

Repair or replace the engine harness. Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

Go to 3B-4

Go to 4A

Guided Step 3E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 252 active?
YES NO

Replace the oil level sensor. Refer to Procedure 019-056 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-May-2012


FAULT CODE 253 - Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Lubricating Oil System | Refer to Procedure 007-037 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Lubricating Oil Level Sensor | Refer to Procedure 019-056 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 253 active?
STEP 2. | Check the engine lubricating oil level. |
 | STEP 2A. Verify the engine lubricating oil level. | Engine lubricating oil level correct?
STEP 3. | Check ECM calibration and clear fault codes |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify engine oil temperature is near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 253 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the engine lubricating oil level.

Guided Step 2A - Verify the engine lubricating oil level.

Conditions

  • Turn keyswitch OFF.

Action

Verify the engine lubricating oil level using the oil dipstick.

–

Is the engine lubricating oil level correct?
YES NO

Replace the lubricating oil level sensor. Refer to Procedure 019-056 in the Associated Procedures Table.

Low engine lubricating oil level has been detected.

Add engine lubricating oil to the engine. Refer to Procedure 007-037 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-May-2012


FAULT CODE 256 - Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 256 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 256 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

Replace the ambient air temperature sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 257 - Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Shutoff Valve | Refer to Procedure 019-050 | ISM11 CM876 SN | 4022196

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault status. |
 | STEP 1A. Check for active Fault Code 255 or high inactive counts. | Fault Code 255 active?
STEP 2. | Check for extra wires. |
 | STEP 2A. Check for extra wires attached to the fuel shutoff valve solenoid. | Extra wires?
STEP 3. | Check for proper fuel shutoff valve circuit operation. |
 | STEP 3A. Check for proper fuel shutoff valve circuit operation. | Is voltage available at the fuel shutoff valve greater than 11-VDC with the keyswitch ON, and less than 0.5-VDC with the keyswitch OFF?
STEP 4. | Check the fuel shutoff valve actuator disc. |
 | STEP 4A. Check the fuel shutoff valve actuator disc. | Debris or damage found on the valve disc, valve seat, or actuator disc?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault status.

Guided Step 1A - Check for active Fault Code 255 or high inactive counts.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES | NO
No Repair | No Repair

Reference Fault Code 255

Go to 2A

Guided Step 2 - Check for extra wires.

Guided Step 2A - Check for extra wires attached to the fuel shutoff valve solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires.

  • Check for extra wires attached to the fuel shutoff valve solenoid.

Extra wires?
YES NO

Remove the extra wires attached to the fuel shutoff valve solenoid.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check for proper fuel shutoff valve circuit operation.

Guided Step 3A - Check for proper fuel shutoff valve circuit operation.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve circuit operation.

  • Verify the voltage available at the fuel shutoff valve is greater than 11-VDC.
  • Turn keyswitch OFF.
  • Verify the voltage available at the fuel shutoff valve is less than 0.5-VDC.

Is voltage available at the fuel shutoff valve greater than 11-VDC with the keyswitch ON, and less than 0.5-VDC with the keyswitch OFF?

YES NO
No Repair

See the following procedure Engine Performance Tree to diagnose the fuel shutoff valve circuit in Service Manual, ISM11 CM876 SN, Bulletin 4022196.

Go to 4A

Go to 5A

Guided Step 4 - Check the fuel shutoff valve actuator disc.

Guided Step 4A - Check the fuel shutoff valve actuator disc.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check the fuel shutoff valve actuator disc.

  • Check the housing, valve disc, valve seat, and actuator disc for dirt, debris, metal parts, bonding separation, corrosion, cracks, or wear.

Debris or damage found on the valve disc, valve seat, or actuator disc?
YES NO

Replace the damaged fuel shutoff valve component.

Refer to Procedure 019-050 in the Associated Procedures Table.

Assemble the fuel shutoff valve.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jan-2012


FAULT CODE 269 - Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 269 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for the immobilizer anti-theft device fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 269 active?
YES NO

The immobilizer anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

See equipment manufacturer service information for immobilizer anti-theft device operation.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Nov-2015


FAULT CODE 271 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harnes | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Actuator | Refer to Procedure 019-117 | ISZ13 CM2150 | 4022133
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2250 | 4022254
Fuel Pump Actuator | Refer to Procedure 019-117 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2250 GX CM2250 | 4022250
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine QSB6.7 CM2250 | 4310611
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2250 | 4022256
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 | 4022255
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 EC | 2883621
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX11.9 CM2250 ECF | 2883561
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2250 ECF | 2883557
Fuel Pump Actuator | Refer to Procedure 019-117 | PowerGen QSX15 CM2250 ECF | 4310661
Fuel Pump Actuator | Refer to Procedure 019-117 | PowerGen QSX15 CM2250 | 4310664
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB3.3 CM2250 EC | 2883647
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B101 | 2883567
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L101 | 4310787
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX12 CM2350 X102 | 4310646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2350 X101 | 4310641
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2250 SN | 4310736
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F101 | 4310846
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F103 | 4310839
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5 CM2350 B104 | 4332646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B103 | 4332641
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B105 | 4332778
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L102 | 4332796
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD4.5 CM2150 B119 | 4358465
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD6.7 CM2150 B120 | 4358470
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 L110 | 4358475
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F110 | 4358480
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 M CM2250 L106 | 4358343
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L111 | 4367223
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z101 | 4358364
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z102 | 4358369
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F105 | 4358561
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2350 F109 | 4367218
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F107 | 4367316
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B106 | 4367376
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G110 | 4367323
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F114 | 4383734
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F117 | 4388578
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L107 | 4367386
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 B128 | 4388601
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2250 L115 | 4388626
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L118 | 4388673
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B130 | 4388668
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F116 | 4383664
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F119 | 4388703
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F118 | 4388708
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B122 | 4388767
Fuel Pump Actuator | Refer to Procedure 019-117 | QSC8.3 CM2880 C102 | 4388785
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F126 | 5411159
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2250 B131 | 4388774
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB3.3 CM2250 B137 | 5411058
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B142 | 5411131
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2250 X115 | 4388739
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X114B | 5411181
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X116B | 5411186
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B121B | 5411223
Fuel Pump Actuator | Refer to Procedure 019-117 | F3.8 CM2350 F120B | 5411237
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L116B | 5411330
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B129B | 5411247
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B147B | 5411252
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B135B | 5411257
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B148B | 5411262
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L119B | 5411267
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B145 | 5411273
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L122 | 5411278
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B144 | 5411382
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L123B | 5411465
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F131 | 5411489
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2350 X118 | 5467247
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G113 | 5467252
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F125 | 5411494
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F124 | 5411484
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF4.5 CM2220 F123 | 5411320
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Check for a signal-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2B. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check the fault codes | Fault Code 271 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair Complete

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Check for a signal-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

  • Inspect the ECM pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 3

Guided Step 2B - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module (ECM) connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness fuel pump actuator connector and fuel pump actuator RETURN pin in the engine harness fuel pump actuator connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.”

Repair complete

Escalate or call for assistance

Last Modified: 13-May-2017


FAULT CODE 272 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Actuator | Refer to Procedure 019-117 | ISZ13 CM2150 | 4022133
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B101 | 2883567
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L101 | 4310787
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX12 CM2350 X102 | 4310646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2350 X101 | 4310641
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F101 | 4310846
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F103 | 4310839
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5 CM2350 B104 | 4332646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B103 | 4332641
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B105 | 4332778
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L102 | 4332796
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD4.5 CM2150 B119 | 4358465
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD6.7 CM2150 B120 | 4358470
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 L110 | 4358475
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F110 | 4358480
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L111 | 4367223
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z101 | 4358364
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z102 | 4358369
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F105 | 4358561
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2350 F109 | 4367218
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F107 | 4367316
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B106 | 4367376
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G110 | 4367323
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F114 | 4383734
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F117 | 4388578
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L107 | 4367386
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L118 | 4388673
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B130 | 4388668
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F116 | 4383664
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F119 | 4388703
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F118 | 4388708
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B122 | 4388767
Fuel Pump Actuator | Refer to Procedure 019-117 | QSC8.3 CM2880 C102 | 4388785
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F126 | 5411159
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2250 B131 | 4388774
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB3.3 CM2250 B137 | 5411058
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B142 | 5411131
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X114B | 5411181
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X116B | 5411186
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B121B | 5411223
Fuel Pump Actuator | Refer to Procedure 019-117 | F3.8 CM2350 F120B | 5411237
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L116B | 5411330
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B129B | 5411247
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B147B | 5411252
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B135B | 5411257
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B148B | 5411262
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L119B | 5411267
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B145 | 5411273
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L122 | 5411278
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B144 | 5411382
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L123B | 5411465
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F131 | 5411489
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2350 X118 | 5467247
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G113 | 5467252
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F125 | 5411494
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F124 | 5411484
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active or inactive fuel pump actuator fault code. | Fault Code 271 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 2B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 2C. Check the fault codes. | Fault Code 272 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active or inactive fuel pump actuator fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 2A

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

  • Inspect the ECM pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19. Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the fuel pump actuator.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Connect the engine harness to the ECM connector.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 281 - Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISZ13 CM2150 | 4022133
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISX15 CM2250 GX CM2250 | 4022250
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Pump Gear Pump | Refer to Procedure 005-025 | QSL9 CM2250 | 4022256
Fuel Pump Gear Pump | Refer to Procedure 005-025 | PowerGen QSX15 CM2250 ECF | 4310661
Fuel Pump Gear Pump | Refer to Procedure 005-025 | PowerGen QSX15 CM2250 | 4310664
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISL9 CM2350 L111 | 4367223
Fuel Pump Gear Pump | Refer to Procedure 005-025 | QSZ13 CM2150 Z101 | 4358364
Fuel Pump Gear Pump | Refer to Procedure 005-025 | QSZ13 CM2150 Z102 | 4358369
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISL8.9 CM2880 L112 | 4358493
Fuel Pump Gear Pump | Refer to Procedure 005-025 | QSL9 CM2250 L115 | 4388626
Fuel Pump Gear Pump | Refer to Procedure 005-025 | QSB6.7 CM2250 B128 | 4388601
Fuel Pump Gear Pump | Refer to Procedure 005-025 | QSX15 CM2250 X115 | 4388739
Fuel Pump Gear Pump | Refer to Procedure 005-025 | L9 CM2350 L119B | 5411267
Fuel Pump Head | Refer to Procedure 005-227 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Head | Refer to Procedure 005-227 | ISZ13 CM2150 | 4022133
Fuel Pump Head | Refer to Procedure 005-227 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Pump Head | Refer to Procedure 005-227 | ISX15 CM2250 GX CM2250 | 4022250
Fuel Pump Head | Refer to Procedure 005-227 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Pump Head | Refer to Procedure 005-227 | QSL9 CM2250 | 4022256
Fuel Pump Head | Refer to Procedure 005-227 | PowerGen QSX15 CM2250 ECF | 4310661
Fuel Pump Head | Refer to Procedure 005-227 | PowerGen QSX15 CM2250 | 4310664
Fuel Pump Head | Refer to Procedure 005-227 | ISL9 CM2350 L111 | 4367223
Fuel Pump Head | Refer to Procedure 005-227 | QSZ13 CM2150 Z101 | 4358364
Fuel Pump Head | Refer to Procedure 005-227 | QSZ13 CM2150 Z102 | 4358369
Fuel Pump Head | Refer to Procedure 005-227 | QSX15 CM2250 X115 | 4388739
Fuel Pump Head | Refer to Procedure 005-227 | L9 CM2350 L119B | 5411267
Fuel System Diagnostics | Refer to Procedure 005-236 | ISZ13 CM2150 | 4022133
Fuel System Diagnostics | Refer to Procedure 005-236 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel System Diagnostics | Refer to Procedure 005-236 | ISX15 CM2250 GX CM2250 | 4022250
Fuel System Diagnostics | Refer to Procedure 005-236 | ISX12/ISX11.9 CM2250 | 2883445
Fuel System Diagnostics | Refer to Procedure 005-236 | QSL9 CM2250 | 4022256
Fuel System Diagnostics | Refer to Procedure 005-236 | QSB6.7 CM2250 | 4022255
Fuel System Diagnostics | Refer to Procedure 005-236 | QSB6.7 CM2250 EC | 2883621
Fuel System Diagnostics | Refer to Procedure 005-236 | PowerGen QSX15 CM2250 ECF | 4310661
Fuel System Diagnostics | Refer to Procedure 005-236 | PowerGen QSX15 CM2250 | 4310664
Fuel System Diagnostics | Refer to Procedure 005-236 | ISL9 CM2350 L111 | 4367223
Fuel System Diagnostics | Refer to Procedure 005-236 | QSZ13 CM2150 Z101 | 4358364
Fuel System Diagnostics | Refer to Procedure 005-236 | QSZ13 CM2150 Z102 | 4358369
Fuel System Diagnostics | Refer to Procedure 005-236 | ISL8.9 CM2880 L112 | 4358493
Fuel System Diagnostics | Refer to Procedure 005-236 | QSL9 CM2250 L115 | 4388626
Fuel System Diagnostics | Refer to Procedure 005-236 | QSB6.7 CM2250 B128 | 4388601
Fuel System Diagnostics | Refer to Procedure 005-236 | QSX15 CM2250 X115 | 4388739
Fuel System Diagnostics | Refer to Procedure 005-236 | L9 CM2350 L119B | 5411267
Air in Fuel | Refer to Procedure 006-003 | ISL8.9 CM2150 SN | 4022190
Air in Fuel | Refer to Procedure 006-003 | ISZ13 CM2150 | 4022133
Air in Fuel | Refer to Procedure 006-003 | ISC8.3 and ISL9 CM2250 | 4022257
Air in Fuel | Refer to Procedure 006-003 | ISX15 CM2250 GX CM2250 | 4022250
Air in Fuel | Refer to Procedure 006-003 | ISX12/ISX11.9 CM2250 | 2883445
Air in Fuel | Refer to Procedure 006-003 | QSL9 CM2250 | 4022256
Air in Fuel | Refer to Procedure 006-003 | QSB6.7 CM2250 | 4022255
Air in Fuel | Refer to Procedure 006-003 | QSB6.7 CM2250 EC | 2883621
Air in Fuel | Refer to Procedure 006-003 | PowerGen QSX15 CM2250 ECF | 4310661
Air in Fuel | Refer to Procedure 006-003 | PowerGen QSX15 CM2250 | 4310664
Air in Fuel | Refer to Procedure 006-003 | ISL9 CM2350 L111 | 4367223
Air in Fuel | Refer to Procedure 006-003 | QSZ13 CM2150 Z101 | 4358364
Air in Fuel | Refer to Procedure 006-003 | QSZ13 CM2150 Z102 | 4358369
Air in Fuel | Refer to Procedure 006-003 | ISL8.9 CM2880 L112 | 4358493
Air in Fuel | Refer to Procedure 006-003 | QSL9 CM2250 L115 | 4388626
Air in Fuel | Refer to Procedure 006-003 | QSB6.7 CM2250 B128 | 4388601
Air in Fuel | Refer to Procedure 006-003 | QSX15 CM2250 X115 | 4388739
Air in Fuel | Refer to Procedure 006-003 | L9 CM2350 L119B | 5411267
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISL8.9 CM2150 SN | 4022190
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISZ13 CM2150 | 4022133
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISX15 CM2250 GX CM2250 | 4022250
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSL9 CM2250 | 4022256
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSB6.7 CM2250 | 4022255
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSB6.7 CM2250 EC | 2883621
Fuel Inlet Restriction | Refer to Procedure 006-020 | PowerGen QSX15 CM2250 ECF | 4310661
Fuel Inlet Restriction | Refer to Procedure 006-020 | PowerGen QSX15 CM2250 | 4310664
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISL9 CM2350 L111 | 4367223
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSZ13 CM2150 Z101 | 4358364
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSZ13 CM2150 Z102 | 4358369
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISL8.9 CM2880 L112 | 4358493
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSL9 CM2250 L115 | 4388626
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSB6.7 CM2250 B128 | 4388601
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSX15 CM2250 X115 | 4388739
Fuel Inlet Restriction | Refer to Procedure 006-020 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 281 is active or has more than 1 inactive count?
STEP 2. | Preliminary fuel system checks. |
 | STEP 2A. Measure the fuel pump gear pump pressure. | Is the fuel gear pump pressure greater than the specifications outlined in Procedure 005-025 in Section 5?
 | STEP 2B. Check for air in the fuel. | Is air in the fuel?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear all inactive fault codes.
  • Operate the engine at the steady state loaded condition.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 281 is active or has more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate fault code troubleshooting tree

Guided Step 2 - Preliminary fuel system checks.

Guided Step 2A - Measure the fuel pump gear pump pressure.

Conditions

  • Turn keyswitch ON.
  • Engine operating.

Action

Measure the fuel gear pump pressure.

  • For the ISL8.9 CM2150 SN engine, Refer to Procedure 005-025 in the Associated Procedures Table.
  • For all other engines, Refer to Procedure 005-236 in the Associated Procedures Table.

If the engine will not start, perform this test while cranking the engine. Refer to Procedure 005-236 in the Associated Procedures Table.

Is the fuel gear pump pressure greater than the specifications outlined in Procedure 005-236 in Section 5?
YES NO
No Repair

Replace the fuel gear pump module.

  • Refer to Procedure 005-025 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Engine operating.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Is air in the fuel?
YES NO

Bubbles are an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

Refer to Procedure 006-020 in the Associated Procedures Table.

If fuel inlet restriction is not excessive, the source of air entry should be isolated to one of the following:

  • Suction fuel lines.
  • OEM fuel lines.
  • Suction-side fuel filter assemblies.
  • Stand-pipe(s) in the fuel tank(s).

Replace the high pressure fuel pump head.

  • Refer to Procedure 005-227 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM. Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Oct-2016


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the equipment manufacturer service information, vehicle electronic control unit (VECU), and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the equipment manufacturer service information, VECU, and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper original equipment manufacturer (OEM) VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the equipment manufacturer service information. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 287 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 287 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle equipment control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of 0?
 | STEP 3B. Determine if the accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than 0?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 287 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

Note: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the throttle is released, the Throttle Status/Idle Validation parameter must display “released” and Percent Throttle parameter must display a value of 0.

Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of 0?
YES NO
No Repair

There is an OEM issue with the accelerator or idle validation switch or OEM VECU.

  • See equipment manufacturer service information.
  • Refer to Procedure 019-054 in Section 19.
  • Refer to Procedure 019-085 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display “depressed” and Percent Throttle parameter must display a value greater than 0.

Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than 0?

YES NO
No Repair

There is an OEM issue with the idle validation switch or the accelerator or with the OEM VECU.

  • See equipment manufacturer service information.
  • Refer to Procedure 019-054 in Section 19.
  • Refer to Procedure 019-085 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Mar-2017


FAULT CODE 288 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 288 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 288 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the ECM and compare to the engine ECM configuration

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Status/Idle Validation

Monitor parameters can possibly notappear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter mustdisplay ON and the Percent Throttle parameter mustdisplay a value of 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or the OEM VECU. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Switch Status

Monitor parameters can possibly notappear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter mustdisplay ON and the Percent Throttle parameter mustdisplay a value greater than 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or the OEM VECU. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Mar-2017


FAULT CODE 291 - Proprietary Datalink Error (OEM/Vehicle Datalink) - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 291 active?
STEP 2. | Check the immobilizer anti-theft device for proper configuration. |
 | STEP 2A. Determine if the immobilizer anti-theft device is configured correctly. | Immobilizer anti-theft device is configured correctly?
STEP 3. | Check the service data link harness |
 | STEP 3A. Inspect the immobilizer anti-theft device and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open or short circuit in the J1939 data link harness. | Resistance between 50 and 70 ohms?
STEP 4. | Check the original equipment manufacturer (OEM) harness |
 | STEP 4A. Check the engine control module (ECM) and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the ECM J1939 data link harness. | Resistance between 50 and 70 ohms?
 | STEP 4C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 291 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the immobilizer anti-theft device for proper configuration.

Guided Step 2A - Determine if the immobilizer anti-theft device is configured correctly.

Conditions

  • Turn keyswitch ON.

Action

Check the immobilizer anti-theft device for the following:

  • Correct power supply and ground connections.
  • Proper connections to the J1939 data link.
  • Correct electronic configuration of the immobilizer anti-theft device.

Immobilizer anti-theft device is configured correctly?
YES NO
No Repair

Reference the immobilizer anti-theft installation instructions provided by the OEM.

Go to 3A

See equipment manufacturer service information.

Guided Step 3 - Check the service data link harness

Guided Step 3A - Inspect the immobilizer anti-theft device and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the immobilizer anti-theft device from the J1939 data link.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the immobilizer anti-theft device from the J1939 data link.

Action

Check for an open or short circuit:

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 Data Link (-) wire on the service data link connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness

Guided Step 4A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit:

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit:

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 Data Link (+) and the SAE J1939 Data Link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Refer to the No Communication Symptom Tree in the appropriate service manual.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2016


FAULT CODE 295 - Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 AN | 4022178
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL8.9 CM2150 SN | 4022190
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISM11 CM876 SN | 4022196
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISZ13 CM2150 | 4022133
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSZ13 CM2150 Z101 | 4358364
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSZ13 CM2150 Z102 | 4358369
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 F116 | 4383664
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | F3.8 CM2350 F120B | 5411237
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | Marine QSB6.7 CM2250 | 4310611

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 221 and Fault Code 222. | Fault Code 221 or Fault Code 222 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active?
 | STEP 2C. Check the circuit response. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 222 active?
 | STEP 3C. Check the circuit response. | Fault Code 221 active?
STEP 4. | Check ECM calibration and clear fault codes.. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 221 and Fault Code 222.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 or Fault Code 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

An in-range malfunction of the barometric pressure sensor has been detected.

  • Refer to Procedure 019-004 in the Associated Procedures Table.
  • Use the following procedure for Marine QSB6.7 CM2250 engines. Refer to Procedure 019-466 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 311 - Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 311 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 311 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jun-2012


FAULT CODE 312 - Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 312 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 312 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jun-2012


FAULT CODE 313 - Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 313 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 313 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jun-2012


FAULT CODE 314 - Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 314 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 314 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jun-2012


FAULT CODE 315 - Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 315 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 315 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jun-2012


FAULT CODE 319 - Real Time Clock - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 F103 | 4310839
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL8.9 CM2150 SN | 4022190
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB/ISD4.5 CM2150 B119 | 4358465
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB/ISD6.7 CM2150 B120 | 4358470
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL8.9 CM2150 L110 | 4358475
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 F110 | 4358480
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL9 CM2350 L111 | 4367223
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2350 F109 | 4367218
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 F117 | 4388578
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 F126 | 5411159
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB6.7 CM2350 B142 | 5411131
Real-Time Clock Battery | Refer to Procedure 019-311 | F3.8 CM2350 F120B | 5411237
Real-Time Clock Battery | Refer to Procedure 019-311 | B4.5 CM2350 B129B | 5411247
Real-Time Clock Battery | Refer to Procedure 019-311 | B4.5 CM2350 B147B | 5411252
Real-Time Clock Battery | Refer to Procedure 019-311 | B6.7 CM2350 B135B | 5411257
Real-Time Clock Battery | Refer to Procedure 019-311 | B6.7 CM2350 B148B | 5411262
Real-Time Clock Battery | Refer to Procedure 019-311 | L9 CM2350 L119B | 5411267
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery and connections. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the real-time clock battery voltage at the ECM harness connector. | Between 3.2 and 4.0 VDC??
 | STEP 1B-1. Inspect the real-time clock battery and engine wire harness connector pins. |
 | STEP 1B-2. Check the real-time clock battery voltage at the battery module connector. |
STEP 2. | Check the battery module harness. |
 | STEP 2A. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the real-time clock battery and connections.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab..

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the real-time clock battery voltage at the ECM harness connector.

Conditions

  • Engine equipped with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 3.2 and 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the real-time clock battery and engine wire harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the real-time clock battery or engine harness.

  • Repair or replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B-2

Guided Step 1B-2 - Check the real-time clock battery voltage at the battery module connector.

Conditions

  • Engine equipped with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 3.2 and 4.0 VDC?
YES NO
No Repair

Replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Check for an open circuit in the engine harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 27-Apr-2017


FAULT CODE 321 - Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 321 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure Refer to Procedure019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 321 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jun-2012


FAULT CODE 334 - Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Thermostat | Refer to Procedure 008-013 | ISF2.8 CM2220 AN | 4022178
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 AN | 4021708
Coolant Thermostat | Refer to Procedure 008-013 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2150 SN | 4022190
Coolant Thermostat | Refer to Procedure 008-013 | ISM11 CM876 SN | 4022196
Coolant Thermostat | Refer to Procedure 008-013 | ISZ13 CM2150 | 4022133
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2250 | 4022254
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B105 | 4332778
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L102 | 4332796
Coolant Thermostat | Refer to Procedure 008-013 | ISC8.3 and ISL9 CM2250 | 4022257
Coolant Thermostat | Refer to Procedure 008-013 | ISX15 CM2250 and GX CM2250 | 4022250
Coolant Thermostat | Refer to Procedure 008-013 | ISX12/ISX11.9 CM2250 | 2883445
Coolant Thermostat | Refer to Procedure 008-013 | ISL9 CM2350 L101 | 4310787
Coolant Thermostat | Refer to Procedure 008-013 | ISX12 CM2350 X102 | 4310646
Coolant Thermostat | Refer to Procedure 008-013 | ISX15 CM2350 X101 | 4310641
Coolant Thermostat | Refer to Procedure 008-013 | ISB4.5 CM2350 B104 | 4332646
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2350 B103 | 4332641
Coolant Thermostat | Refer to Procedure 008-013 | ISV5.0 CM3230 V104 | 4367291
Coolant Thermostat | Refer to Procedure 008-013 | ISL9 CM2350 L111 | 4367223
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2350 F109 | 4367218
Coolant Thermostat | Refer to Procedure 008-013 | QSF3.8 CM2350 F107 | 4367316
Coolant Thermostat | Refer to Procedure 008-013 | QSB4.5 CM2350 B106 | 4367376
Coolant Thermostat | Refer to Procedure 008-013 | QSG12 CM2350 G110 | 4367323
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 F110 | 4358480
Coolant Thermostat | Refer to Procedure 008-013 | ISG11 CM2880 G106 | 4332695
Coolant Thermostat | Refer to Procedure 008-013 | ISG12 CM2880 G106 | 4332690
Coolant Thermostat | Refer to Procedure 008-013 | ISB5.9 CM2880 B127 | 4383645
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2880 L112 | 4388493
Coolant Thermostat | Refer to Procedure 008-013 | ISL9.5 CM2150 SN | 4310608
Coolant Thermostat | Refer to Procedure 008-013 | ISB3.9 CM2220 B107 | 4310792
Coolant Thermostat | Refer to Procedure 008-013 | ISB/ISD4.5 CM2150 B119 | 4358465
Coolant Thermostat | Refer to Procedure 008-013 | ISB/ISD6.7 CM2150 B120 | 4358470
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2150 L110 | 4358475
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 F116 | 4383664
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B130 | 4388668
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L118 | 4388673
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2350 B142 | 5411131
Coolant Thermostat | Refer to Procedure 008-013 | F3.8 CM2350 F120B | 5411237
Coolant Thermostat | Refer to Procedure 008-013 | X15 CM2350 X114B | 5411181
Coolant Thermostat | Refer to Procedure 008-013 | X15 CM2350 X116B | 5411186
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B121B | 5411223
Coolant Thermostat | Refer to Procedure 008-013 | B4.5 CM2350 B129B | 5411247
Coolant Thermostat | Refer to Procedure 008-013 | B4.5 CM2350 B147B | 5411252
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B135B | 5411257
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B148B | 5411262
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L119B | 5411267
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L116B | 5411330
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B145 | 5411273
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L122 | 5411278
Coolant Thermostat | Refer to Procedure 008-013 | QSB4.5 CM2350 B144 | 5411382
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L123B | 5411465
Coolant Thermostat | Refer to Procedure 008-013 | QSX15 CM2350 X118 | 5467247
Coolant Thermostat | Refer to Procedure 008-013 | QSG12 CM2350 G113 | 5467252
Coolant Thermostat | Refer to Procedure 008-013 | QSF3.8 CM2350 F125 | 5411494
Coolant Thermostat | Refer to Procedure 008-013 | ISF4.5 CM2220 F123 | 5411320
Coolant Thermostat | Refer to Procedure 008-013 | ISF2.8 CM2220 F101 | 4310846
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 AN | 4021704
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 AN | 4022178
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4388493
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2880 SN | 4310608
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM28880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM28880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4388493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4388493
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 144 and 145. | Fault Code 144 or 145 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the thermostat. |
 | STEP 2A. Check the thermostat. | Thermostat operate correctly?
STEP 3. | Check the engine coolant temperature sensor and circuit. |
 | STEP 3A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 144 active?
 | STEP 3C. Check the circuit response. | Fault Code 145 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 144 active?
 | STEP 4C. Check the circuit response. | Fault Code 145 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 or 145 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to Fault Code 144 or 145 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the thermostat.

Guided Step 2A - Check the thermostat.

Conditions

  • Turn keyswitch OFF.

Action

Check the thermostat for correct operation.

Refer to Procedure 008-013 in the Associated Procedures Table.

Thermostat operate correctly?
YES NO
No Repair

Replace the thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine coolant temperature sensor and circuit.

Guided Step 3A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 23-May-2017


FAULT CODE 338 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for active fault codes. | Fault Code 338 active?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the idle shutdown relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 338 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic setting.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the idle shutdown relay. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the idle shutdown relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Use the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector idle shutdown relay RETURN pin and the OEM harness idle shutdown relay connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the idle shutdown SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 339 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for active fault codes. | Fault Code 339 active?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the idle shutdown relay. |
 | STEP 2C. Check the idle shutdown relay diagnostic supply voltage, supply line, and return circuit. | Greater than 3.75 VDC?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 339 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic settings.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the idle shutdown relay.

See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the idle shutdown relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the idle shutdown relay SIGNAL pin and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the idle shutdown relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the idle shutdown relay diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the idle shutdown relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Use the OEM wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than three inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Recalibrate the ECM. |
 | STEP 4A. Recalibrate the ECM. | Fault Code 343 active after recalibrating the ECM?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries. See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Recalibrate the ECM.

Guided Step 4A - Recalibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 343 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 346 - Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 346 active?
STEP 2. | Check the adjustable parameter settings. |
 | STEP 2A. Check for correct adjustable parameter settings. | Are both accelerator interlock and powertrain protection torque limit switch features enabled, and are both the accelerator interlock switch and powertrain protection torque limit switch features disabled in the SAE J1939 multiplexing feature?
 | STEP 2B. Check for correct adjustable parameter settings. | Are both clutch pedal position switch and engine protection shutdown manual override switch features enabled, and are both the clutch pedal position switch and engine protection shutdown manual override switch disabled in the SAE J1939 multiplexing feature?
 | STEP 2C. Check for correct adjustable parameter settings. | Are both idle shutdown accessory relay and engine brake lamp output features enabled?
 | STEP 2D. Check for correct adjustable parameter settings. | Are both switched maximum engine operating speed switch and governor type switch features enabled?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the adjustable parameter settings.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for accelerator interlock switch and powertrain protection torque limit switch.

Are both accelerator interlock and powertrain protection torque limit switch features enabled, and are both the accelerator interlock switch and powertrain protection torque limit switch features disabled in the SAE J1939 multiplexing feature?

YES NO

Use INSITE™ electronic service tool to disable either the accelerator interlock switch or the powertrain protection torque limit switch features.

Configuring either the accelerator interlock switch or the powertrain protection torque limit switch to be multiplexed using the SAE J1939 data link will also clear the fault code.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for clutch pedal position switch and engine protection shutdown manual override switch.

Are both clutch pedal position switch and engine protection shutdown manual override switch features enabled, and are both the clutch pedal position switch and engine protection shutdown manual override switch disabled in the SAE J1939 multiplexing feature?

YES NO

Use INSITE™ electronic service tool to disable either the clutch pedal position switch or the engine protection shutdown manual override switch features.

Configuring either the clutch pedal position switch or the engine protection shutdown manual override switch to be multiplexed using the SAE J1939 multiplexing feature will also clear the fault code.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for idle shutdown accessory relay and engine brake lamp output.

Are both idle shutdown accessory relay and engine brake lamp output features enabled?
YES NO

Use INSITE™ electronic service tool to disable either the idle shutdown accessory relay or the engine brake lamp output features.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings switched maximum engine operating speed switch and governor type switch.

Are both switched maximum engine operating speed switch and governor type switch features enabled?
YES NO

Use INSITE™ electronic service tool to disable either the switched maximum engine operating speed switch or the governor type switch features.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jun-2012


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L109 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2880 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358365
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358370
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358375
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358380
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L109 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 active or inactive?
 | STEP 1B. Operate the engine. | Will engine start?
 | STEP 1C. Read the fault codes. | Fault Code 351 active?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate engine and determine if fault code condition exists. | Fault Code 351 occurs during engine operation?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 active or inactive?
YES NO

Troubleshoot Fault Code 441 first.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Operate the engine.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Operate the engine.

Will engine start?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES NO

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

 No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Inspect the ECM power supply and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the battery terminals.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit in the ECM ground circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle with no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 occurs during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 356 - Engine Intake Air Mass Flow Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Mass Air Flow Sensor | Refer to Procedure 019-460 | ISF2.8 CM2220 E | 4022178
Mass Air Flow Sensor | Refer to Procedure 019-460 | QSB3.3 CM2250 EC | 2883647
Mass Air Flow Sensor | Refer to Procedure 019-460 | ISF2.8 CM2220 F101 | 4310846
Mass Air Flow Sensor | Refer to Procedure 019-460 | ISF2.8 CM2220 F117 | 4388578
Mass Air Flow Sensor | Refer to Procedure 019-460 | QSB4.5 CM2250 B131 | 4388774
Mass Air Flow Sensor | Refer to Procedure 019-460 | QSB3.3 CM2250 B137 | 5411058

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 356 inactive?
 | STEP 1B. Check for intake throttle actuator fault codes. | Fault Codes 175, 176, 177, 3539, 3541, or 3542 active?
STEP 2. | Inspect intake and exhaust systems. |
 | STEP 2A. Check for restrictions on the intake or exhaust systems. | Any blockage or damage found on intake or exhaust systems?
STEP 3. | Check the supply voltage and circuit response at the sensor. |
 | STEP 3A. Inspect the mass air flow sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor supply voltage at the sensor connector. | Voltage within 1-VDC of battery voltage?
 | STEP 3C. Check the circuit response. | Fault Code 356 active and Fault Code 357 inactive?
STEP 4. | Check the sensor supply voltage at the ECM. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the sensor supply voltage at the ECM. | Voltage within 1-VDC of battery voltage?
STEP 5. | Check the circuit response at the ECM. |
 | STEP 5A. Check the circuit response. | Fault Code 357 active and Fault Code 356 inactive?
 | STEP 5B. Check the ECM response. | Fault Code 357 active and Fault Code 356 inactive?
STEP 6. | Check the ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 356 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for intake throttle actuator fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check intake throttle actuator fault codes.

  • Use INSITE™ electronic service tool to check for other active faults related to the intake throttle actuator.

Fault Codes 175, 176, 177, 3539, 3541, or 3542 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect intake and exhaust systems.

Guided Step 2A - Check for restrictions on the intake or exhaust systems.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Inspect the intake and exhaust systems for blockage or restrictions.

  • Inspect the air filter for excessive dirt, soiling or other problems that can cause restricted air flow.
  • Inspect the charge air cooler hoses/tubes and connections.
  • Inspect all air intake, crankcase vent and turbocharger related hoses/tubes and connections for damage, air leaks, or blockage.
  • Check charge air cooler restriction. Refer to Procedure 010-027 in the Associated Procedures Table.
  • Inspect the exhaust system for damaged components that could cause exhaust flow blockage.

Any blockage or damage found on intake or exhaust systems?
YES NO

Repair or replace damaged or restricted component.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the supply voltage and the circuit response at the sensor.

Guided Step 3A - Inspect the mass air flow sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.
  • Disconnect the mass air flow sensor from engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the sensor supply voltage at the sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Reconnect the engine harness to the ECM connector.
  • Disconnect mass air flow sensor from engine harness connector.
  • Turn keyswitch ON.

Action

Use a digital multimeter to measure the voltage between the mass air flow sensor SUPPLY pin and the mass air flow sensor RETURN pin at the engine harness.

Reference the engine wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mass air flow sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 357 active and Fault Code 356 inactive?
YES NO

A damaged sensor has been detected.

Replace the mass air flow sensor. Refer to Procedure 019-460 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 4 - Check the sensor supply voltage at the ECM.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the sensor supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Use a digital multimeter to measure the voltage between the mass air flow sensor SUPPLY pin and the mass air flow sensor RETURN pin at the ECM.

Reference the engine wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1-VDC of battery voltage?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 5 - Check the circuit response at the ECM.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Reference the engine wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 357 active and Fault Code 356 inactive?
YES NO

A short to voltage or open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Jun-2016


FAULT CODE 357 - Engine Intake Air Mass Flow Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge Air Cooler | Refer to Procedure 010-027 | ISF2.8 CM2220 E | 4022178
Charge Air Cooler | Refer to Procedure 010-027 | QSB3.3 CM2250 EC | 2883647
Charge Air Cooler | Refer to Procedure 010-027 | ISF2.8 CM2220 F101 | 4310846
Charge Air Cooler | Refer to Procedure 010-027 | QSB4.5 CM2250 B131 | 4388774
Charge Air Cooler | Refer to Procedure 010-027 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 357 inactive?
 | STEP 1B. Check for intake throttle actuator fault codes. | Fault Codes 175, 176, 177, 3539, 3541, or 3542 active?
STEP 2. | Inspect intake and exhaust systems. |
 | STEP 2A. Check for restrictions on the intake or exhaust systems. | Any blockage or damage found on intake or exhaust systems?
STEP 3. | Check the supply voltage and circuit response at the sensor |
 | STEP 3A. Inspect the mass air flow sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor supply voltage at sensor connector. | Voltage within 1-VDC of battery voltage?
 | STEP 3C. Check the circuit response. | Fault Code 356 active and Fault Code 357 inactive?
STEP 4. | Check the sensor supply voltage at the ECM. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the sensor supply voltage at the ECM. | Voltage within 1-VDC of battery voltage?
STEP 5. | Check the circuit response at the ECM. |
 | STEP 5A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the ECM response. | Fault Code 356 active and Fault Code 357 inactive?
STEP 6. | Check the ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 357 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for intake throttle actuator fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check intake throttle actuator fault codes.

  • Use INSITE™ electronic service tool to check for other active faults related to the intake throttle actuator.

Fault Codes 175, 176, 177, 3539, 3541, or 3542 active?
YES | NO
No Repair | No Repair

Reference the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect intake and exhaust systems

Guided Step 2A - Check for restrictions on the intake or exhaust systems.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Inspect the intake and exhaust systems for blockage or restrictions.

  • Inspect the air filter for excessive dirt, soiling or other problems that can cause restricted air flow.
  • Inspect the charge-air cooler hoses/tubes and connections.
  • Inspect all air intake, crankcase vent and turbocharger related hoses/tubes and connections for damage, air leaks, or blockage.
  • Check charge-air cooler restriction. Refer to Procedure 010-027 in the Associated Procedures Table.
  • Inspect the exhaust system for damaged components that could cause exhaust flow blockage.

Any blockage or damage found on intake or exhaust systems?
YES NO

Repair or replace damaged or restricted component.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the supply voltage and circuit response at the sensor.

Guided Step 3A - Inspect the mass air flow sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.
  • Disconnect the mass air flow sensor from engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the sensor supply voltage at sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Reconnect the engine harness to the ECM connector.
  • Disconnect mass air flow sensor from engine harness connector.
  • Turn keyswitch ON.

Action

Use a digital multimeter to measure the voltage between the mass air flow sensor SUPPLY pin and the mass air flow sensor RETURN pin at the engine harness.

Reference the engine wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mass air flow sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the mass air flow sensor SUPPLY pin and the mass air flow sensor SIGNAL pin at the mass air flow sensor harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 356 active and Fault Code 357 inactive?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5A

Guided Step 4 - Check the supply voltage at the ECM.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the sensor supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Use a digital multimeter to measure the voltage between the mass air flow sensor SUPPLY pin and the mass air flow sensor RETURN pin at the ECM.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Reference the engine wiring diagram for connector pin identification.

Voltage within 1-VDC of battery voltage?
YES NO

An open return circuit has been detected in the engine harness. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 5 - Check the circuit response at the ECM.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the mass air flow sensor SUPPLY pin and the mass air flow sensor SIGNAL pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the engine wiring diagram for connector pin identification.

Fault Code 356 active and Fault Code 357 inactive?
YES NO

A short to voltage or open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Jun-2016


FAULT CODE 358 - Engine Intake Air Mass Flow - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Cleaner Element | Refer to Procedure 010-014 | QSB4.5 CM2220 EC | 4310575
Air Cleaner Element | Refer to Procedure 010-014 | QSB3.3 CM2250 EC | 2883647
Air Cleaner Element | Refer to Procedure 010-014 | QSB4.5 CM2250 EC | 4310575
Air Cleaner Element | Refer to Procedure 010-014 | QSB4.5 CM2250 B131 | 4388774
Air Cleaner Element | Refer to Procedure 010-014 | QSB3.3 CM2250 B137 | 5411058
Air Intake Restriction | Refer to Procedure 010-031 | QSB3.3 CM2250 EC | 2883647
Air Intake Restriction | Refer to Procedure 010-031 | QSB4.5 CM2250 EC | 4310575
Air Intake Restriction | Refer to Procedure 010-031 | QSB4.5 CM2250 B131 | 4388774
Air Intake Restriction | Refer to Procedure 010-031 | QSB3.3 CM2250 B137 | 5411058
Mass Air Flow Sensor | Refer to Procedure 019-460 | ISF2.8 CM2220 E | 4022178
Mass Air Flow Sensor | Refer to Procedure 019-460 | QSB3.3 CM2250 EC | 2883647
Mass Air Flow Sensor | Refer to Procedure 019-460 | QSB4.5 CM2250 EC | 4310575
Mass Air Flow Sensor | Refer to Procedure 019-460 | QSB4.5 CM2250 B131 | 4388774
Mass Air Flow Sensor | Refer to Procedure 019-460 | QSB3.3 CM2250 B137 | 5411058

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 358 active?
STEP 2. | Inspect the air intake system. |
 | STEP 2A. Check for air intake system leaks | Leaks found in the air intake system?
 | STEP 2B. Check primary and secondary air filter condition. | Air filter damaged, restricted, or installed incorrectly?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 358 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Inspect the air intake system

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.

Action

Check for an air intake leak between the air box and the intake manifold.

  • Check all clamps and connectors for tightness.
  • Check for disconnected or damaged air pipes.
  • Perform a pressurized leak test of the system, if possible.

Leaks found in the air intake system?
YES NO

Repair or replace leaking component(s).

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check primary and secondary air filter condition

Conditions

  • Turn keyswitch OFF.

Action

Check the intake air filter for excessive build-up and restriction.

  • Check the filter restriction monitor gauge, if equipped. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Remove the primary air filter, if necessary, and inspect for excessive debris build-up or filter media damage.
  • Remove the secondary air filter, if necessary, and inspect for excessive debris build-up or filter media damage. Refer to Procedure 010-014 in the Associated Procedures Table.
  • Make sure the filter was installed properly.

Air filter damaged, restricted, or installed incorrectly?
YES NO

Clean and replace the primary or secondary air filter and inlet piping as necessary. Refer to Procedure 010-014 in the Associated Procedures Table.

Refer to equipment manufacturer service information.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Jun-2016


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the appropriate service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Jan-2016


FAULT CODE 418 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 428 or 429 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for Fault Code 418. | Fault Code 418 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 or 429 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Drain the water from the fuel filter.

If Fault Code 418 remains active, a malfunction in the sensor and/or connector may have occurred. Repair or replace the sensor and/or connector, as necessary.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 12-Jun-2017


FAULT CODE 425 - Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISZ13 CM2150 | 4022133
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12 CM2350 X102 | 4310646
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2350 X101 | 4310641
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 SN | 4310736
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G110 | 4367323
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X114B | 5411181
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X116B | 5411186
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G113 | 5467252
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 212 and 213. | Fault Code 212 or 213 active?
STEP 2. | Check the oil temperature sensor and circuit. |
 | STEP 2A. Inspect the oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check circuit response. | Fault Code 212 active?
 | STEP 2C. Check circuit response. | Fault Code 213 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check circuit response. | Fault Code 212 active?
 | STEP 3C. Check circuit response. | Fault Code 213 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 212 and 213.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 or 213 active?
YES | NO
No Repair | No Repair

Fault Code 212 or 213 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the oil temperature sensor and circuit.

Guided Step 2A - Inspect the oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil temperature SIGNAL pin and the oil temperature RETURN pin at the oil temperature connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

Replace the oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil temperature SIGNAL pin and oil temperature RETURN pin at the ECM engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair complete.

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 427 - SAE J1939 Data Link - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3163151 - ECM bench calibration harness Part Number 3164185 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Cummins® INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using a Cummins® INLINE™ II data link adapter (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM service manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has ben detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect Cummins® INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an Cummins® INLINE™ II data link adapter (J1939) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM service manual.

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TS.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2012


FAULT CODE 428 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Water in Fuel Sensor | Refer to Procedure 019-127 | ISV5.0 CM3230 V104 | 4367291
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F103 | 4310839
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 SN | 4022190
Water in Fuel Sensor | Refer to Procedure 019-127 | ISM11 CM876 SN | 4022196
Water in Fuel Sensor | Refer to Procedure 019-127 | ISZ13 CM2150 | 4022133
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2250 | 4022254
Water in Fuel Sensor | Refer to Procedure 019-127 | ISC8.3 and ISL9 CM2250 | 4022257
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 GX CM2250 | 4022250
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12/ISX11.9 CM2250 | 2883445
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 | 4022256
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 | 4022255
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 EC | 2883621
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX11.9 CM2250 ECF | 2883561
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 ECF | 2883557
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 ECF | 4310661
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 | 4310664
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 EC | 2883647
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B101 | 2883567
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L101 | 4310787
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B105 | 4332778
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L102 | 4332796
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L107 | 4367386
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12 CM2350 X102 | 4310646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2350 X101 | 4310641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 SN | 4310736
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F101 | 4310846
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5 CM2350 B104 | 4332646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B103 | 4332641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD4.5 CM2150 B119 | 4358465
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2150 B120 | 4358470
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 L110 | 4358475
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F110 | 4358480
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L111 | 4367223
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z101 | 4358364
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z102 | 4358369
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F107 | 4367316
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B106 | 4367376
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B112 | 4358498
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2350 F109 | 4367218
Water in Fuel Sensor | Refer to Procedure 019-127 | F3.8 CM2350 F120B | 5411237
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G110 | 4367323
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F114 | 4383734
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 B128 | 4388601
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 L115 | 4388626
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F117 | 4388578
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F118 | 4388708
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK3.8 CM2350 F119 | 4388703
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B130 | 4388668
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L118 | 4388673
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B122 | 4388767
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 X115 | 4388739
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2250 B131 | 4388774
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 B137 | 5411058
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F126 | 5411159
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X114B | 5411181
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X116B | 5411186
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B121B | 5411223
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B142 | 5411131
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B129B | 5411247
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B147B | 5411252
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B135B | 5411257
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B148B | 5411262
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L119B | 5411267
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L116B | 5411330
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B145 | 5411273
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L122 | 5411278
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B144 | 5411382
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L123B | 5411465
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F131 | 5411489
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G113 | 5467252
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2350 X118 | 5467247
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F125 | 5411494
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water in fuel sensor and circuit. |
 | STEP 2A. Inspect the water in fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 3.87 Mega-ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor and circuit.

Guided Step 2A - Inspect the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water in fuel sensor.

Action

Inspect the engine harness, and water in fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water in fuel SIGNAL pin and the water in fuel RETURN pin at the water in fuel sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.87 Mega-ohms?
YES NO

Replace the water in fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water in fuel sensor RETURN pin and the engine harness water in fuel sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water in fuel sensor SIGNAL pin and the engine water in fuel sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 429 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 L110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F103 | 4310839
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Water in Fuel Sensor | Refer to Procedure 019-127 | ISV5.0 CM3230 V104 | 4367291
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 SN | 4022190
Water in Fuel Sensor | Refer to Procedure 019-127 | ISM11 CM876 SN | 4022196
Water in Fuel Sensor | Refer to Procedure 019-127 | ISZ13 CM2150 | 4022133
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2250 | 4022254
Water in Fuel Sensor | Refer to Procedure 019-127 | ISC8.3 and ISL9 CM2250 | 4022257
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 GX CM2250 | 4022250
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12/ISX11.9 CM2250 | 2883445
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 | 4022256
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 | 4022255
Water in Fuel Sensor | Refer to Procedure 019-127 | Marine QSB6.7 CM2250 | 4310611
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 EC | 2883621
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B105 | 4332778
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L102 | 4332796
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L107 | 4367386
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX11.9 CM2250 ECF | 2883561
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 ECF | 2883557
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 ECF | 4310661
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 | 4310664
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 EC | 2883647
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12 CM2350 X102 | 4310646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2350 X101 | 4310641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 SN | 4310736
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F101 | 4310846
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5 CM2350 B104 | 4332646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B103 | 4332641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD4.5 CM2150 B119 | 4358465
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2150 B120 | 4358470
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 L110 | 4358475
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F110 | 4358480
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L111 | 4367223
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z101 | 4358364
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z102 | 4358369
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F107 | 4367316
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B106 | 4367376
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B112 | 4358498
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G110 | 4367323
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F114 | 4383734
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F117 | 4388578
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 B128 | 4388601
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 L115 | 4388626
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F118 | 4388708
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK3.8 CM2350 F119 | 4388703
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B130 | 4388668
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L118 | 4388673
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B122 | 4388767
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 X1152 | 4388739
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2250 B131 | 4388774
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 B137 | 5411058
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F126 | 5411159
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X114B | 5411181
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X116B | 5411186
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B121B | 5411223
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B142 | 5411131
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B129B | 5411247
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B147B | 5411252
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B135B | 5411257
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B148B | 5411262
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L119B | 5411267
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B145 | 5411273
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L122 | 5411278
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B144 | 5411382
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F131 | 5411489
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2350 X118 | 5467247
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G113 | 5467252
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F125 | 5411494
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F124 | 5411484
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the water in fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES NO

A damaged sensor has been detected.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 for Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water-in-fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-ampere fuse is installed correctly.

  • Inspect the 30-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turnkeyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the battery system. |
 | STEP 2A. Check the battery connection. | Batteries connected properly for the system voltage required?
 | STEP 2B. Check the alternator. | Alternator charging within equipment manufacturers specifications?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the battery system.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check to make sure batteries are installed correctly.

Batteries connected properly for the system voltage required?
YES NO
No Repair

Install the battery system correctly. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an original equipment manufacturer (OEM) ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within equipment manufacturers specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the equipment manufacturers wiring to the alternator.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Apr-2017


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 AN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B101 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L101 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358370
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358575
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358580
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | GSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | GSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 AN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B101 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L101 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | GSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | GSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 AN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 EC | 4310575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332687
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K105 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358570
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358580
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 | 4367444
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test leadPart Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 or 515 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 or 515 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 volt SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 IAN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2220 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 GX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 EC | 2883647
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332778
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K104 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K108 | 4332823
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358470
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358475
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358480
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSb4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F116 | 4383664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 516 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 516 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 465 - Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test leadPart Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 465 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Resistance greater than 100k ohms?
 | STEP 2C. Check for a short circuit to the battery. | Less than 1.5-VDC?
 | STEP 2D. Check for an active fault code. | Fault Code 465 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes.
Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the wastegate actuator number 1.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the wastegate actuator number 1 SIGNAL (+) pin at the ECM connector to all other pin in the connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram for pin identification and the following procdure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to the battery.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Check for a short circuit to the battery.

  • Measure the voltage from the wastegate actuator 1 SIGNAL (+) pin at the wastegate actuator connector and engine block ground.
  • Measure the voltage from the wastegate actuator 1 SIGNAL (+) pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Less than 1.5-VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 active?
YES NO

Replace the turbocharger wastegate actuator number 1.

None. The removal and installation of the connector corrected the fault.

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available..

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jan-2012


FAULT CODE 471 - Engine Oil Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil System | Refer to Procedure 007-037 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Lubricating Oil System | Refer to Procedure 007-037 | QSB7 CM2880 B117 | 4358390

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 471 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine oil temperature near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 471 active?
YES NO

Low engine lubricating oil level has been detected.

Add engine lubricating oil to the engine. Refer to Procedure 007-037 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 477 - Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 477 is active?
 | STEP 1B. Check for active fault codes. | Fault Codes 441, 597, or 598 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller. |
 | STEP 2A. Inspect the aftertreatment DEF controller and harness. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF controller. | Voltage is within 1-VDC of battery voltage?
 | STEP 2C. Check for the correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine CPL?
STEP 3. | Check the battery. |
 | STEP 3A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 3B. Verify that the fuse is installed correctly. | Good fuse installed correctly?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 is active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF controller.

Guided Step 2A - Inspect aftertreatment DEF controller and harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller connector from the aftertreatment DEF controller.

Action

Inspect the OEM harness and Aftertreatment DEF controller 53-pin connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the controller or harness connector.

Repair the damaged harness, connector or pins, if possibe.

  • Flush the dirt, debris, or moisture from the connector pins. Us electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM wiring harness.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the Aftertreatment DEF controller.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller from the OEM wiring harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuits to the Aftertreatment DEF controller.

  • Measure the voltage between the Aftertreatment DEF controller Battery Voltage SUPPLY circuit and the Aftertreatment DEF controller Battery Voltage RETURN circuit at the OEM harness 53-pin connector

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 4A

Go to 4A

Guided Step 3 - Check the battery.

Guided Step 3A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuse is installed correctly and is not blown.

  • Inspect the fuse for correct installation and check to see if its blown.

Good fuse installed correctly?
YES NO
No Repair

Install the fuse correctly or replace the blown fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all aftertreatment DEF controller battery SUPPLY (+) pins, one at a time, in the 53-pin OEM harness connector.
  • Measure the resistance from the negative (-) battery terminal post to all aftertreatment DEF controller battery RETURN (-) pins, one at a time, in the in the 53-pin OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the power harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller OEM harness connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the aftertreatment DEF controller battery SUPPLY (+) pins in the 53-pin OEM harness connector to the aftertreatment DEF controller battery RETURN (-) pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller OEM harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the aftertreatment DEF controller battery SUPPLY (+) pins in the 53-pin OEM harness connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller OEM harness connector.
  • Disconnect the 86-pin aftertreatment DEF controller OEM harness connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the aftertreatment DEF controller battery SUPPLY (+) pins in the 53-pin OEM harness connector to all pins in the 53-pin and 86-pin OEM harness connectors.
  • Measure the resistance from one of the aftertreatment DEF controller battery RETURN (-) pins in the 53-pin OEM harness connector to all pins in the 53-pin and 86-pin OEM harness connectors.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • The current ECM code and revision number in the ECM can be found using the INSITE™ service tool. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Feb-2015


FAULT CODE 478 - Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 478 is active?
 | STEP 1B. Check for active fault codes. | Fault Codes 442 or 596 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid controller and harness. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment diesel exhaust fluid controller. | Less than +18-VDC for 12-volt system and less than +32-VDC for 24-volt system?
 | STEP 2C. Check for the correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine CPL?
STEP 3. | Check the alternator. |
 | STEP 3A. Check the alternator. | Alternator charging within OEM specifications?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Connect INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 is active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch O.N
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 442 or 596 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid controller.

Guided Step 2A - Inspect aftertreatment diesel exhaust fluid controller and harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the 53-pin aftertreatment diesel exhaust fluid controller connector from the aftertreatment diesel exhaust fluid controller.

Action

Inspect the OEM harness and Aftertreatment diesel exhaust fluid controller 53-pin connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins if possible.

  • Flush the dirt, debris. or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment diesel exhaust fluid controller.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller from the OEM harness
  • Turn keyswitch ON.

Action

Check the power supply and return circuits to the aftertreatment diesel exhaust fluid controller.

  • Measure the voltage between the aftertreatment diesel exhaust fluid controller battery voltage SUPPLY circuit and the Aftertreatment diesel exhaust fluid controller battery voltage RETURN circuit at the OEM harness 53-pin connector.

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Less than +18-VDC for 12-volt system and less than +32-VDC for 24-volt system?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for the correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 4A

Go to 4A

Guided Step 3 - Check the alternator.

Guided Step 3A - Check the alternator.

Conditions

  • Turn keyswitch OFF
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Note: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the INSITE™ service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2011


FAULT CODE 498 - Engine Oil Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Lubricating Oil Level Sensor | Refer to Procedure 019-056 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 498 inactive?
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the oil level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the oil level sensor. | Damage found to the oil level sensor body or connector?
 | STEP 2C. Check the fault codes. | Fault Code 498 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 498 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the oil level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level

Action

Inspect the engine harness and oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the oil level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Remove the engine oil level sensor. Refer to Procedure 019-056 in the Associated Procedures Table.

Action

Visually inspect the lubricating oil level sensor for damage to the wiring or body.

  • Inspect the o-rings for damage.

Damage found to the oil level sensor body or connector?
YES NO

Replace the oil level sensor. Refer to Procedure 019-056 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 498 active?
YES NO

Replace the oil level sensor. Refer to Procedure 019-056 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 499 - Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Lubricating Oil Level Sensor | Refer to Procedure 019-056 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Lubricating Oil Level Sensor | Refer to Procedure 019-056 | VTA903 CM2250 V105 | 4332841

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 499 inactive?
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the lubricating oil level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the lubricating oil level sensor. | Damage found to the lubricating oil level sensor body or connector?
 | STEP 2C. Check the fault codes. | Fault Code 499 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 499 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the lubricating oil level sensor.

Guided Step 2A - Inspect the lubricating oil level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil level sensor.

Action

Inspect the engine harness and lubricating oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the oil level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil level sensor from the engine harness.
  • Remove the lubricating oil level sensor. Refer to Procedure 019-056 in the Associated Procedures Table.

Action

Inspect the lubricating oil level sensor for damage to the wiring or body.

  • Inspect the o-rings for damage.

Damage found to the oil level sensor body or connector?
YES NO

Replace the lubricating oil level sensor. Refer to Procedure 019-056 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 499 active?
YES NO

Replace the lubricating oil level sensor. Refer to Procedure 019-056 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2014


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF3.8 CM2220 F103 | 4310839
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL8.9 CM2150 SN | 4022190
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB6.7 CM2250 | 4022254
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISX15 CM2250 GX CM2250 | 4022250
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISZ13 CM2150 | 4022133
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSL9 CM2250 | 4022256
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB6.7 CM2250 | 4022255
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB6.7 CM2250 EC | 2883621
Fuel Drain Line Restriction | Refer to Procedure 006-012 | Marine QSB6.7 CM2250 | 4310611
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSX11.9 CM2250 ECF | 2883561
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSX15 CM2250 ECF | 2883557
Fuel Drain Line Restriction | Refer to Procedure 006-012 | PowerGen QSX15 CM2250 ECF | 4310661
Fuel Drain Line Restriction | Refer to Procedure 006-012 | PowerGen QSX15 CM2250 | 4310664
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB3.3 CM2250 EC | 2883647
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB6.7 CM2350 B101 | 2883567
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL9 CM2350 L101 | 4310787
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISX12 CM2350 X102 | 4310646
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISX15 CM2350 X101 | 4310641
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISX15 CM2250 SN | 4310736
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF2.8 CM2220 F101 | 4310846
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB4.5 CM2350 B104 | 4332646
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB6.7 CM2350 B103 | 4332641
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB3.9 CM2220 B107 | 4310792
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK78 CM2220 K104 | 4332682
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSL9 M CM2250 L106 | 4358343
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB/ISD4.5 CM2150 B119 | 4358465
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB/ISD6.7 CM2150 B120 | 4358470
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL8.9 CM2150 L110 | 4358475
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF3.8 CM2220 F110 | 4358480
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSZ13 CM2150 Z101 | 4358364
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSZ13 CM2150 Z102 | 4358369
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL8.9 CM2880 L112 | 4358493
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF3.8 CM2350 F109 | 4367218
Fuel Drain Line Restriction | Refer to Procedure 006-012 | F3.8 CM2350 F120B | 5411237
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL9 CM2350 L111 | 4367223
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSG12 CM2350 G110 | 4367323
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB6.7 CM2250 B128 | 4388601
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSL9 CM2250 L115 | 4388626
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF2.8 CM2220 F117 | 4388578
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF3.8 CM2220 F116 | 4383664
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB4.5 CM2350 B122 | 4388767
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB4.5 CM2250 B131 | 4388774
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB3.3 CM2250 B137 | 5411058
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF2.8 CM2220 F126 | 5411159
Fuel Drain Line Restriction | Refer to Procedure 006-012 | X15 CM2350 X114B | 5411181
Fuel Drain Line Restriction | Refer to Procedure 006-012 | X15 CM2350 X116B | 5411186
Fuel Drain Line Restriction | Refer to Procedure 006-012 | B6.7 CM2350 B121B | 5411223
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB6.7 CM2350 B142 | 5411131
Fuel Drain Line Restriction | Refer to Procedure 006-012 | B4.5 CM2350 B129B | 5411247
Fuel Drain Line Restriction | Refer to Procedure 006-012 | B4.5 CM2350 B147B | 5411252
Fuel Drain Line Restriction | Refer to Procedure 006-012 | B6.7 CM2350 B135B | 5411257
Fuel Drain Line Restriction | Refer to Procedure 006-012 | B6.7 CM2350 B148B | 5411262
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSX15 CM2250 X115 | 4388739
Fuel Drain Line Restriction | Refer to Procedure 006-012 | L9 CM2350 L116B | 5411330
Fuel Drain Line Restriction | Refer to Procedure 006-012 | L9 CM2350 L123B | 5411465
Fuel Drain Line Restriction | Refer to Procedure 006-012 | L9 CM2350 L119B | 5411267
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSG12 CM2350 G113 | 5467252
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSX15 CM2350 X118 | 5467247
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2220 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 GX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 EC | 2883647
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB3.9 CM2220 B107 | 4310792
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K104 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358470
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358475
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358480
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2880 L112 | 4358493
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G10 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F116 | 4383664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F103 | 4310839
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2250 | 4022254
Fuel Pump Actuator | Refer to Procedure 019-117 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2250 GX CM2250 | 4022250
Fuel Pump Actuator | Refer to Procedure 019-117 | ISZ13 CM2150 | 4022133
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2250 | 4022256
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 | 4022255
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 EC | 2883621
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine QSB6.7 CM2250 | 4310611
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX11.9 CM2250 ECF | 2883561
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2250 ECF | 2883557
Fuel Pump Actuator | Refer to Procedure 019-117 | PowerGen QSX15 CM2250 ECF | 4310661
Fuel Pump Actuator | Refer to Procedure 019-117 | PowerGen QSX15 CM2250 | 4310664
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB3.3 CM2250 EC | 2883647
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B101 | 2883567
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L101 | 4310787
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX12 CM2350 X102 | 4310646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2350 X101 | 4310641
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F101 | 4310846
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2250 SN | 4310736
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5 CM2350 B104 | 4332646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B103 | 4332641
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB3.9 CM2220 B107 | 4310792
Fuel Pump Actuator | Refer to Procedure 019-117 | QSK78 CM2220 K104 | 4332682
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 M CM2250 L106 | 4358343
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD4.5 CM2150 B119 | 4358465
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD6.7 CM2150 B120 | 4358470
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 L110 | 4358475
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F110 | 4358480
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z101 | 4358364
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z102 | 4358369
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2880 L112 | 4358493
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2350 F109 | 4367218
Fuel Pump Actuator | Refer to Procedure 019-117 | F3.8 CM2350 F120B | 5411237
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L111 | 4367223
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G110 | 4367323
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 B128 | 4388601
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 B128 | 4388601
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F117 | 4388578
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F116 | 4383664
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B122 | 4388767
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2250 B131 | 4388774
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB3.3 CM2250 B137 | 5411058
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F126 | 5411159
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X114B | 5411181
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X116B | 5411186
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B121B | 5411223
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B142 | 5411131
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B129B | 5411247
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B147B | 5411252
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B135B | 5411257
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B148B | 5411262
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2250 X115 | 4388739
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L116B | 5411330
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L123B | 5411465
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L119B | 5411267
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G113 | 5467252
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2350 X118 | 5467247
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 449, or 2311 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Correct fuel rail pressure sensor installed for the engine control parts list (CPL)?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012 in the Associated Procedures Table?
STEP 4. | Check the fuel pump actuator. |
 | STEP 4A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel pump actuator resistance. | Fuel pump actuator resistance within the specifications outlined in Procedure 019-117 in the Associated Procedures Table?
 | STEP 4C. Monitor the fuel rail pressure at idle. | Measured Fuel Rail Pressure deviate from Commanded Fuel Rail Pressure by more than 100 bar [1450 psi] and surge at idle?
 | STEP 4D. Inspect the fuel pump actuator for damage. | Fuel pump actuator damaged?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control (EFC) actuator shorted low or high.

Fault Code 271, 272, 449, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Verify fuel rail pressure sensor part number.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Check the fuel rail pressure sensor and make sure it is correct for the engine CPL.

Correct fuel rail pressure sensor installed for the engine CPL?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012 in the Associated Procedures Table?
YES NO
No Repair

Repair the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the fuel pump actuator.

Guided Step 4A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in the Associated Procedures Table.

Fuel pump actuator resistance within the specifications outlined in Procedure 019-117 in the Associated Procedures Table?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Measured Fuel Rail Pressure deviate from Commanded Fuel Rail Pressure by more than 100 bar [1450 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in the Associated Procedures Table.

Fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 554 - Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2220 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 AN | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2220 K104 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 AN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K104 | 4332682

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 451 and 452. | Fault Code 451 or 452 active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 451 active?
 | STEP 2C. Check the circuit response. | Fault Code 452 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pin?
 | STEP 3B. Check the circuit response. | Fault Code 451 active?
 | STEP 3C. Check the circuit response. | Fault Code 452 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 451 and 452.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 or 452 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the rail fuel pressure connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active?
YES NO

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 452 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Aug-2015


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L102 | 4332796
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2250 | 4022254
Crankcase Breather (External) | Refer to Procedure 003-001 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather (External) | Refer to Procedure 003-001 | ISM11 CM876 SN | 4022196
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 | 4022256
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 | 4022255
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L101 | 4310787
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L111 | 4367223
Crankcase Breather (External) | Refer to Procedure 003-001 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L115 | 4388626
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L118 | 4388673
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L107 | 4367386
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L116B | 5411330
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L123B | 5411465
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2250 | 4022254
Crankcase Breather Tube | Refer to Procedure 003-018 | Marine QSB6.7 CM2250 | 4310611
Crankcase Breather Tube | Refer to Procedure 003-018 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 | 4022256
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 | 4022255
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather Tube | Refer to Procedure 003-018 | QSX11.9 CM2250 | 2883561
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Tube | Refer to Procedure 003-018 | B6.7 CM2350 B121B | 5411223
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L119B | 5411267
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L116B | 5411330
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L116B | 5411330
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B105 | 4332778
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L102 | 4332796
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2250 | 4022254
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine QSB6.7 CM2250 | 4310611
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISM11 CM876 SN | 4022196
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 | 4022256
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 | 4022255
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 EC | 2883621
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX11.9 CM2250 ECF | 2883561
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 ECF | 2883557
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 | 4310664
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 EC | 2883647
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B101 | 2883567
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 B101 | 4310787
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12 CM2350 X102 | 4310646
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2350 X102 | 4310641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B103 | 4332641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B112 | 4358498
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B106 | 4367376
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 L111 | 4367223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISV5.0 CM3230 V104 | 4367291
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B128 | 4388601
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L115 | 4388626
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B130 | 4388668
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L118 | 4388673
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L107 | 4367386
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B122 | 4388767
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2250 B131 | 4388774
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 B137 | 5411058
Crankcase Blowby, Measure | Refer to Procedure 014-010 | B6.7 CM2350 B121B | 5411223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 X115 | 4388739
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B145 QSL9 CM2350 L122 | 5411273 5411278
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L119B | 5411267
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L116B | 5411330
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L123B | 5411465
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 555 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?
 | STEP 2B. Verify crankcase breather type and maintenance history. | Filter below the maintenance interval or fitted with maintenance free element?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tube, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate engine.

Action

Use the INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Verify crankcase breather type and maintenance history.

Conditions

  • Determine if crankcase breather system is fitted with filter element or maintenance free breather insert.

Action

Check mileage / hours on the crankcase breather filter since last maintenance, if equipped.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance intervals for specific engine application.

Filter below the maintenance interval or fitted with maintenance free element?
YES NO
No Repair

Replace the crankcase breather filter element. Refer to Procedure 003-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Inspect the crankcase breather element and clean or replace as necessary.

Refer to Procedure 003-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Do not operate engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

Measure the crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Crankcase blowby measurement within specification?
YES NO

Inspect the crankcase breather element and clean or replace as necessary. Refer to Procedure 003-019 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

  • Reference the Crankcase Gases (Blowby) Excessive symptom tree in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 14-Mar-2017


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L102 | 4332796
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2250 | 4022254
Crankcase Breather (External) | Refer to Procedure 003-001 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather (External) | Refer to Procedure 003-001 | ISM11 CM876 SN | 4022196
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 | 4022256
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 | 4022255
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L101 | 4310787
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L111 | 4367223
Crankcase Breather (External) | Refer to Procedure 003-001 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L115 | 4388626
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L118 | 4388673
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L107 | 4367386
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2250 | 4022254
Crankcase Breather Tube | Refer to Procedure 003-018 | Marine QSB6.7 CM2250 | 4310611
Crankcase Breather Tube | Refer to Procedure 003-018 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 | 4022256
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 | 4022255
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather Tube | Refer to Procedure 003-018 | QSX11.9 CM2250 | 2883561
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Tube | Refer to Procedure 003-018 | B6.7 CM2350 B121B | 5411223
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B105 | 4332778
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B101 | 2883567
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B103 | 4332641
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 | 4358498
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B106 | 4367376
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B128 | 4388601
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B130 | 4388668
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B122 | 4388767
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 B131 | 4388774
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB3.3 CM2250 B137 | 5411058
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B121B | 5411223
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B145 | 5411273
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B105 | 4332778
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L102 | 4332796
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2250 | 4022254
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine QSB6.7 CM2250 | 4310611
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISM11 CM876 SN | 4022196
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 | 4022256
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 | 4022255
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 EC | 2883621
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX11.9 CM2250 ECF | 2883561
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 ECF | 2883557
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 | 4310664
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 EC | 2883647
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B101 | 2883567
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 B101 | 4310787
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12 CM2350 X102 | 4310646
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2350 X102 | 4310641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B103 | 4332641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B112 | 4358498
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B106 | 4367376
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 L111 | 4367223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISV5.0 CM3230 V104 | 4367291
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B128 | 4388601
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L115 | 4388626
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B130 | 4388668
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L118 | 4388673
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L107 | 4367386
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B122 | 4388767
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2250 B131 | 4388774
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 B137 | 5411058
Crankcase Blowby, Measure | Refer to Procedure 014-010 | B6.7 CM2350 B121B | 5411223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 X115 | 4388739
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B145 QSL9 CM2350 L122 | 5411273 5411278
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L119B | 5411267
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 556 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?
 | STEP 2B. Very crankcase breather type and maintenance history. | Filter below the maintenance interval or fitted with maintenance free element?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tubes, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check for progressive damage. |
 | STEP 4A. Check for progressive damage. | Progressive damage found due to high crankcase pressure?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate engine.

Action

Use INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Verify crankcase breather type and maintenance history.

Conditions

  • Determine if crankcase breather system is fitted with filter element or maintenance free breather insert.

Action

Check mileage / hours on the crankcase ventilation filter since last maintenance, if equipped.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance interval for a specific engine application.

Filter below the maintenance interval or fitted with maintenance free element?
YES NO
No Repair

Replace the crankcase breather filter element.

Refer to Procedure 003-019 in the Associated Procedures Table.

For QSB6.7 CM2250 B128 engines: Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Inspect the crankcase breather element and clean or replace as necessary.

Refer to Procedure 003-019 in the Associated Procedures Table.

For QSB6.7 CM2250 B128 and ISL9 CM2250 L115 engines: Refer to Procedure 003-021 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tubes, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tubes, or oil separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engines equipped with automatic transmissions only.
  • Measure the crankcase blowby.

Refer to Procedure 014-010 in the Associated Procedures Table.

It may be necessary to disable the fault code in order to operate the engine at rated speed. Use INSITE™ electronic service tool to verify the fault code is inactive.

Crankcase blowby measurement within specification?
YES NO

Inspect the crankcase breather element and clean or replace, as necessary. Refer to Procedure 003-019 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Check for progressive damage.

Guided Step 4A - Check for progressive damage.

Action

Check for progressive damage:

  • Check for progressive damage to the engine due to the high crankcase pressure.
  • Check for oil leaking from gaskets and seals.

Reference the appropriate service manual for a specific engine application.

Progressive damage found due to high crankcase pressure?
YES NO

Replace the damaged gasket, seal, or other component.

Troubleshoot the possible causes for excessive crankcase gases. Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS in the appropriate service manual for a specific engine application.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. See equipment manufacturer service information.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 14-Mar-2017


FAULT CODE 584 - Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 F | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Resistance between 30 - 130 ohms (12V systems) or 200 - 400 ohms (24V systems)?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay pin 85 and the starter lockout relay pin 86.

Reference the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 30 - 130 ohms (12V systems) or 200 - 400 ohms (24V systems)?
YES NO
No Repair

A malfunctioning starter lockout relay has been detected.

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Reference the OEM wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the connection malfunction.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None.

The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 585 - Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the starter lockout relay resistance. | Resistance between 30 - 130 ohms for 12V systems or 200 - 400 ohms for 24V systems?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, supply line and return circuit. | Greater than 3.75 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check starter lockout relay and circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay pin 85 and the relay pin 86.

Reference the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 30 - 130 ohms for 12V systems or 200 - 400 ohms for 24V systems?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 596 - Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12 VDC (volts of direct current) under normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Is the alternator charging within original equipment manufacturer (OEM) specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion.
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Are the voltages at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging rate within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2014


FAULT CODE 597 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Is the battery voltage at least (+) 12 VDC (volts of direct current) under normal conditions and at least (+) 6 VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Is the alternator charging within original equipment manufacturer (OEM) specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Any damaged wires?
 | STEP 2E. Check for a short circuit in the power harness. | More than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Is the battery voltage at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging rate within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness. See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the SUPPLY wire to the engine block.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM Battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2014


FAULT CODE 598 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12 VDC (volts of direct current) during normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the alternator and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the alternator. | Is the alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the power harness. | More than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes.. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion.
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Are the voltages at least (+) 12 VDC during normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and OEM harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (ampere).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the battery power connector.

For location and procedure, see equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ECM battery SUPPLY (+) pins and all other pins of the power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit at the SUPPLY wire to the engine block ground.

Damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2014


FAULT CODE 649 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Change the engine lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Feb-2013


FAULT CODE 686 - Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL8.9 CM2150 SN | 4022190
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2250 | 4022254
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B101 | 2883567

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an intermittent fault condition. |
 | STEP 1A. Operate the engine at idle and high idle to check for fault activation. | Did Fault Code 686 come active during engine operation?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 686 come active during engine operation?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for an intermittent fault condition.

Guided Step 1A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool and clear inactive fault codes.
  • Start the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Check for fault activation.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

Does Fault Code 686 come active during engine operation?
YES NO
No Repair

An intermittent fault condition exists. The problem can possibly be with the turbocharger speed sensor circuit; however, the intermittent fault condition can possibly be due to electrical noise that is caused by other devices or faulty grounds.

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for a malfunctioning turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the connector or pigtail harness damaged?
YES NO

Repair or replace the damaged connector, or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

NOTE: The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within 10 ohms of the sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

NOTE: This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Does Fault Code 686 come active during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

An intermittent fault condition exists. The problem may exist in the turbocharger speed sensor circuit or it may exist with other vehicle electronic components. The problem may have been corrected when the harness connections were re-connected.

Be certain that the ECM and chassis grounds are in good condition.

Go to 5A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 687 - Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L102 | 4332796
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL8.9 CM2150 SN | 4022190
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2250 | 4022254
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2250 | 4022256
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 | 4022255
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 EC | 2883621
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2250 ECF | 2883557
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L101 | 4310787
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12 CM2350 X102 | 4310646
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2350 X101 | 4310641
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L111 | 4367223
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2250 L115 | 4388626
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L118 | 4388673
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L107 | 4367386
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2250 X115 | 4388739
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B4.5 CM2350 B129B | 5411247
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B4.5 CM2350 B147B | 5411252
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B6.7 CM2350 B135B | 5411257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B6.7 CM2350 B148B | 5411262
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L119B | 5411267
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L122 | 5411278
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L116B | 5411330
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 122, 123, 221, or 222 active?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Continuity within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disabel the fault code. | Fault code inactive?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for a malfunction in the turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the turbocharger speed sensor connector or speed sensor.

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Continuity within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed SIGNAL (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

The turbocharger speed sensor has malfunctioned.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Replace the turbocharger speed sensor. Refer to Procedure 019-030 in the Associated Procedures Table.

A short has been detected in the engine harness.

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 688 - Engine Oil Level - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Lubricating Oil System | Refer to Procedure 007-037 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 688 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine oil temperature near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 688 active?
YES NO

High engine lubricating oil level has been detected.

Correct the engine lubricating oil level condition.

Refer to Procedure 007-037 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jan-2012


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 691 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK50 CM2350 K108 | 4332823
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISL8.9 CM2150 SN | 4022190
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSX15 CM2250 ECF | 2883557
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK19 CM2350 K105 | 4326157
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z101 | 4358364
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z102 | 4358369
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K116 | 4367444
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K121 | 4388645
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F107 | 4367316
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F105 | 4358561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2250 | 4022254
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L102 | 4332796
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 | 4022256
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 | 4022255
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L118 | 4388673
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 L115 | 4388626
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F118 | 4388708
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F119 | 4388703
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L122 | 5411278
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F124 | 5411484
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F131 | 5411489
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F125 | 5411494

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 active?
STEP 3. | Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness or OEM harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness or OEM harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and the turbocharger compressor intake temperature RETURN pin at the turbocharger compressor intake temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?

YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • For engines equipped with a turbocharger compressor intake air temperature sensor: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM, engine harness, or OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM, engine harness, or OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, engine harness, or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake air temperature sensor SIGNAL pin and the turbocharger compressor intake air temperature sensor RETURN pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor RETURN pin and the engine harness turbocharger compressor intake air temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor SIGNAL pin and the engine harness turbocharger compressor intake air temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 692 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK50 CM2350 K108 | 4332823
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISL8.9 CM2150 SN | 4022190
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSL9 CM2250 | 4022256
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSB6.7 CM2250 | 4022255
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSX15 CM2250 ECF | 2883557
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK19 CM2350 K105 | 4326157
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z101 | 4358364
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z102 | 4358369
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K116 | 4367444
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K121 | 4388645
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F105 | 4358561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F107 | 4367316
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 L115 | 4388626
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L118 | 4388673
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F118 | 4388708
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F119 | 4388703
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L122 | 5411278
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F124 | 5411484
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F131 | 5411489
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F125 | 5411494
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2350 F124 | 5411484

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 active?
STEP 3. | Check the engine control module (ECM), engine harness, or original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • Use the following procedure for engines equipped with a turbocharger compresssor intake air temperature sensor. Refer to Procedure 019-395 in the Associated Procedures Table.
  • Use the following procedure for engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, engine harness, or OEM harness.

Guided Step 3A - Inspect the ECM and engine harness, and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple unrelated faults will become active at this time as well. These can be temporarily ignored.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine turbocharger compressor intake temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 693 - Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC and ISL CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC and ISL CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wirng Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411247
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 693 active?
 | STEP 1B. Check for Fault Codes 691 and 692. | Fault Code 691 or 692 active?
STEP 2. | Check the turbocharger compressor intake temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 691 active?
 | STEP 2C. Check the circuit response. | Fault Code 692 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 691 active?
 | STEP 3C. Check the circuit response. | Fault Code 692 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 693 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for Fault Codes 691 and 692.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 or 692 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and the turbocharger compressor intake temperature RETURN pin at the turbocharger compressor intake temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

An in-range malfunction of the turbocharger compressor intake temperature sensor has been detected.

Replace the turbocharger compressor intake temperature sensor.

  • For engines equipped with turbocharger compressor intake air temperature sensors: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with turbocharger compressor intake pressure/temperature sensors: Refer to Procedure 019-466 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) power harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and turbocharger compressor intake temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 697 - ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V014 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 698 - Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 699 - ECM Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harnes | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 SN | 4022190
Camshaft Position Sensor | Refer to Procedure 019-363 | ISZ13 CM2150 | 4022133
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2250 | 4022254
Camshaft Position Sensor | Refer to Procedure 019-363 | ISC8.3 and ISL9 CM2250 | 4022257
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 GX CM2250 | 4022250
Camshaft Position Sensor | Refer to Procedure 019-363 | Westport HD CM2250 | 4021560
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12/ISX11.9 CM2250 | 2883445
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 | 4022256
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 | 4022255
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 EC | 2883621
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX11.9 CM2250 ECF | 2883561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 ECF | 2883557
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 ECF | 4310661
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 | 4310664
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 EC | 2883647
Camshaft Position Sensor | Refer to Procedure 019-363 | Marine QSB6.7 CM2250 | 4310611
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B101 | 2883567
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L101 | 4310787
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12 CM2350 X102 | 4310646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2350 X101 | 4310641
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 SN | 4310736
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F101 | 4310846
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F103 | 4310839
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5 CM2350 B104 | 4332646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B103 | 4332641
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B105 | 4332778
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4332796
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD4.5 CM2150 B119 | 4358465
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2150 B120 | 4358470
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4358475
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4358480
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 M CM2250 L106 | 4358343
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L111 | 4367223
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B112 | 4358498
Camshaft Position Sensor | Refer to Procedure 019-363 | QSZ13 CM2150 Z101 | 4358364
Camshaft Position Sensor | Refer to Procedure 019-363 | QSZ13 CM2150 Z102 | 4358369
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F105 | 4358561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F114 | 4383734
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F107 | 4367316
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2350 F109 | 4367218
Camshaft Position Sensor | Refer to Procedure 019-363 | F3.8 CM2350 F120B | 5411237
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B106 | 4367376
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2350 G110 | 4367323
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 B128 | 4388601
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 L115 | 4388626
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L107 | 4367386
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F117 | 4388578
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B130 | 4388668
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L118 | 4388673
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F118 | 4388708
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F119 | 4388703
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B122 | 4388767
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F126 | 5411159
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2250 B131 | 4388774
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 B137 | 5411058
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X114B | 5411181
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X116B | 5411186
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B121B | 5411223
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B142 | 5411131
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 X115 | 4388739
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B129B | 5411247
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B147B | 5411252
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B135B | 5411257
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B148B | 5411262
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L119B | 5411267
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L116B | 5411330
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B145 | 5411273
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L122 | 5411278
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B144 | 5411382
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F124 | 5411484
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F125 | 5411494
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L123B | 5411465
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F131 | 5411489
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2350 G113 | 5467252
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2350 X118 | 5467247
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for fault code. | Fault Code 778 active or inactive?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Verify adequate camshaft position sensor air gap. |
 | STEP 3B-4. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify camshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault coe Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear housing. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed then inspect the camshaft gear and related components. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the camshaft position sensor from the gear housing and measure the air gap at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify camshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

For QSB6.7 CM2250 B128 and QSL9 CM2250 L115 engines: If necessary, calibrate the ECM. See equipment manufacturer service information.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 784 - Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the adaptive cruise control hardware. |
 | STEP 1A. Check for installed adaptive cruise control hardware. | Is adaptive cruise control hardware installed on vehicle?
STEP 2. | Check SAE J1939 communication. |
 | STEP 2A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the adaptive cruise control hardware.

Guided Step 1A - Check for installed adaptive cruise control hardware.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle for installed adaptive cruise control hardware.

Is adaptive cruise control hardware installed on the vehicle?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Adaptive Cruise feature.

Go to 2A

Go to 3A

Guided Step 2 - Check SAE J1939 communications.

Guided Step 2A - Check for ECM communication with INSITE™

Conditions

  • Turn keyswitch ON.
  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool.
  • Select INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the adaptive cruise control unit and the vehicle SAE J1939 network.

No Repair

See equipment manufacturer service information.

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter to the ECM bench calibration harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM. Use an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

See equipment manufacturer service information.

Reference the Communication Error - Electronic Service Tool or Control Device Symptom Troubleshooting Tree

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2014


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]. During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]

During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or battery supply connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the battery supply connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the battery supply connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the battery supply connector and the negative battery connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch wire.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 3E

Go to 4A

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete

Go to 1A

Last Modified: 05-Apr-2017


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
STEP 2. | Check the accelerator pedal position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location.

Replace the accelerator pedal or lever. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1241 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1241 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position 5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Codes 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 inactive?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 both active?
YES NO
No Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Appropriate fault code troubleshooting tree

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 132 troubleshooting tree.

Go to 2D

Fault Code 132 troubleshooting tree

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

Measure the voltage from the accelerator pedal position 2 sensor +5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 1241 troubleshooting tree.

Go to 2E

Fault Code 1241 troubleshooting tree

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. See equipment manufacturer service information.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Apr-2017


FAULT CODE 1689 - Real Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2150 F110 | 4358480
Real Time Clock Battery | Refer to Procedure 019-311 | ISM11 CM876 SN | 4022196
Real Time Clock Battery | Refer to Procedure 019-311 | ISB/ISD4.5 CM2150 B119 | 4358465
Real Time Clock Battery | Refer to Procedure 019-311 | ISB/ISD6.7 CM2150 B120 | 4358470
Real Time Clock Battery | Refer to Procedure 019-311 | ISL8.9 CM2150 L110 | 4358475
Real Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2150 F110 | 4358480

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real time clock battery and connections. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the real time clock battery voltage at the ECM harness connector. | Between 3.3-VDC and 3.6-VDC?
 | STEP 1C. Inspect the real time clock battery and engine wire harness connector pins. | Dirty or damaged pins?
 | STEP 1D. Check the real time clock battery voltage at the battery module connector. | Between 3.3-VDC and 3.6-VDC?
STEP 2. | Check the battery module harness. |
 | STEP 2A. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Disable the fault code. | Check if an ECM calibration update is available.
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the real time clock battery and connections.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor harness connector.

Clean the connector and pins.

Repair the damaged pins harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the real time clock battery voltage at the ECM harness connector.

Conditions

  • Engine equipped with optional real time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Measure the voltage between the real time clock battery SUPPLY pin and the real time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 3.3-VDC and 3.6-VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1C

Guided Step 1C - Inspect the real time clock battery and engine wire harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine harness.

Action

Inspect the real time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the real time clock battery or engine harness.

Refer to Procedure 019-311 in the Associated Procedures Table.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1D

Guided Step 1D - Check the real time clock battery voltage at the battery module connector.

Conditions

  • Engine equipped with optional real time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Measure the voltage between the real time clock battery SUPPLY pin and the real time clock battery RETURN (-) pin at the real time clock battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 3.3-VDC and 3.6-VDC?
YES NO
No Repair

Replace the real time clock battery.

Refer to Procedure 019-311 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Measure the following resistance:

  • The resistance between the real time clock battery SUPPLY pin at the battery connector of the engine harness to the real time clock battery SUPPLY pin at the ECM harness connector.
  • The resistance between the real time clock battery RETURN (-) pin at the battery connector of the engine harness to the real time clock battery RETURN (-) pin at the ECM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the real time clock battery from the engine harness.

Action

Use a multimeter to measure the resistance from the real time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the real time clock battery from the engine harness.

Action

Use a multimeter to measure the resistance from the real time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Sep-2014


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411186
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor +5 volt SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor +5 volt SUPPLY pin to the crankcase pressure sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2250 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2250 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B1O6 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411186
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2250 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Datapate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion. Clean or replace the connector or sensor, as necessary.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Oct-2015


FAULT CODE 1879 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 2. | Check the aftertreatment DPF differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1881 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1879 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DPF differential pressure sensor SUPPLY pin and the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal an installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM harness aftertreatment DPF differential pressure sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 1881 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF differential pressure sensor and electronic connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1879 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1881 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DPF differential pressure SUPPLY pin and the aftertreatment DPF differential pressure RETURN pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF differential pressure sensor SUPPLY pin and the aftertreatment DPF differential pressure sensor SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SUPPLY pin and the OEM harness aftertreatment DPF differential pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF differential pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting steps need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 1883 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Trap Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | PowerGen QSX15 CM2250 ECF | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 ECF2 | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1879 and 1881. | Fault Code 1879 or 1881 active?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor tubes. |
 | STEP 2A. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes damaged, disconnected, or blocked?
 | STEP 2B. Monitor the aftertreatment DPF differential pressure sensor voltage. | Aftertreatment DPF differential pressure sensor voltage within specifications?
STEP 3. | Check the aftertreatment DPF differential pressure sensor and circuit. |
 | STEP 3A. Inspect the aftertreatment DPF differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1881 active?
 | STEP 3C. Check the circuit response. | Fault Code 1879 active?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect ECM and OEM harness connector pins. | Dirty or damaged?
 | STEP 4B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 4E. Check the aftertreatment differential pressure sensor voltage value. | Value change?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1879 and 1881.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 or 1881 active?
YES | NO
No Repair | No Repair

Fault Code 1879 or 1881 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor tubes.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes.

  • Make sure the tubes are installed correctly (not reversed).
  • Make sure both ends of the tubes are securely connected.
  • Inspect the tubes for leaks or damage.
  • Inspect the tubes for blockage. Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor tubes damaged, disconnected, or blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Monitor the aftertratment DPF differential pressure sensor voltage.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Do not operate engine.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment DPF differential pressure sensor voltage with an electronic service tool.

An exhaust ventilation system connected to the exhaust can cause the differential pressure sensor to read incorrectly. Make sure to remove any ventilation or vacuum equipment from the exhaust before reading the differential pressure sensor value with INSITE™ electronic service tool.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor voltage reading within specifications?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 3A - Inspect the aftertreatment DPF differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF differential pressure 5 volt SUPPLY pin and the aftertreatment DPF differential pressure SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1879 active?
YES NO

An in-range malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF differential pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the signal circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check the aftertreatment differential pressure sensor voltage value.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for a change in the voltage value.

  • Use INSITE™ electronic service tool to monitor the aftertreatment differential pressure sensor voltage.
  • Perform a snap acceleration test.

Value change?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 1938 - ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B121B | 5411223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal conditions?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator and circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the VGT actuator. | Voltage greater than 10 VDC?
STEP 3. | Check the sensor supply voltage at the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor supply voltage at the ECM. |
STEP 4. | Check if an ECM calibration and clear fault codes. |
 | STEP 4A. Compare ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable and clear fault code. |

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery terminals for corrosion or loose connections.

  • Inspect the battery terminal connections on both positive (+) and negative (-) terminals.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code tree

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage.

Normal Conditions:

  • At least 12 VDC (12 VDC systems)
  • At least 24 VDC (24 VDC systems).

Battery voltage acceptable in normal conditions?
YES NO
No Repair

Charge or replace the batteries.

See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the VGT actuator and circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the VGT actuator or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the VGT actuator: Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator voltage SUPPLY pin and the VGT actuator RETURN pin at the VGT actuator wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10 VDC?
YES NO

A malfunctioning VGT actuator has been detected.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the supply voltage at the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Use a digital multimeter to measure the voltage between the VGT actuator SUPPLY pin and the VGT actuator RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Voltage greater than 10 VDC?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 1942 - Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 G CM2180 EJ | 4310682
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X114B | 5411181
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X116B | 5411186
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L116B | 5411330
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L123B | 5411465
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L116B | 5411330
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 M2350 B103 | 4332641
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B106 | 4367376
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B122 | 4388767
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISV5.0 CM3230 V104 | 4367291
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B128 | 4388601
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B130 | 4388668
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISL G CM2180 | 4021649
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 B131 | 4388774
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB3.3 CM2250 B137 | 5411058
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B142 | 5411131
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B121B | 5411330
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B135B | 5411257
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B148B | 5411262
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B144 | 5411382
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411189
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332541
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411189
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1843 and 1844. | Fault Code 1843 or 1844 active?
 | STEP 1B. Check the oil fill cap. | Oil fill cap properly installed?
 | STEP 1C. Check the crankcase filter tube, if equipped. | Crankcase breather hose connected properly and free of restrictions?
 | STEP 1D. Check the crankcase breather element, if equipped. | Crankcase breather element installed correctly?
 | STEP 1E. Check the mileage/hours on the crankcase ventilation filter since last maintenance. | Filter below maintenance interval?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1844 active?
 | STEP 3C. Check the circuit response. | Fault Code 1843 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1843 and 1844.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 or 1844 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the oil fill cap.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil fill cap.

  • Check the oil fill cap for proper installation.

Oil fill cap properly installed?
YES NO
No Repair

Install the oil fill cap properly.

Go to 1C

Go to 1C

Guided Step 1C - Check the crankcase filter tube, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Skip to Step 1D, if the engine is not equipped with a crankcase filter tube.

Action

Check the crankcase breather tube between the engine and the crankcase filter assembly.

Make sure the breather tube is properly connected and there are no kinks or other restrictions present.

Crankcase breather hose connected properly and free of restrictions?
YES NO
No Repair

Properly connect the crankcase breather hose.

Go to 1D

Go to 4A

Guided Step 1D - Check the crankcase breather element, if equipped.

Conditions

  • Turn keyswitch OFF.

Action

Check that the crankcase breather element is correctly installed.

Use the procedure(s) appropriate for your application.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.
  • Refer to Procedure 003-001 in the Associated Procedures Table.

Crankcase breather element installed correctly?
YES NO
No Repair

Install the crankcase breather element correctly.

Use the procedure(s) appropriate for your application.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.
  • Refer to Procedure 003-001 in the Associated Procedures Table.

Go to 1E

Repair complete.

Guided Step 1E - Check the mileage/hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Locate the maintenance record (miles/hours) of the latest crankcase breather filter replacement.

Action

Check the filter maintenance record.

  • Check the mileage/hours on the crankcase breather filter since the last maintenance.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase breather filter.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2A

Go to 4A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin at the crankcase pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

An in-range malfunction of the crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin on the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 1943 - Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 F101 | 4310846
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISM11 CM876 SN | 4022196
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX12 CM2350 X102 | 4310646
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX15 CM2250 GX CM2250 | 4022250
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX15 CM2350 X101 | 4310641
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSG12 CM2350 G110 | 4367323
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 F126 | 5411159
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB3.3 CM2250 B137 | 5411058
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | X15 CM2350 X114B | 5411181
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | X15 CM2350 X116B | 5411186
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSX15 CM2350 X118 | 5467247
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSG12 CM2350 G113 | 5467252
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2250 X115 | 4388739
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 221 or 249 inactive?
 | STEP 1C. Check the barometric pressure sensor reading. | Is the value for the barometric pressure ± 25.4 mm Hg [± 1.0 in Hg]?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 221 or 249 inactive?
YES | NO
No Repair | No Repair

Fault Code 221 or 249

Go to 1C

Guided Step 1C - Check the barometric pressure sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor reading.

  • Use INSITE™ electronic service tool to read the value for the barometric pressure.
  • Use the chart in the following procedure for barometric pressure values.

Is the value for the barometric pressure within ± 25.4 mm Hg [± 1 in Hg]?
YES NO
No Repair

Replace the barometric pressure sensor.

  • Use the following procedure for ISM and ISX applications. Refer to Procedure 019-004 in the Associated Procedures Table.
  • Use the following procedure for B6.7, ISB, QSB, and ISC applications. Refer to Procedure 019-004 in the Associated Procedures Table. Refer to Procedure 019-466 in Section 19.
  • Use the following procedure for ISF2.8 CM2220 F101 and ISF2.8 CM2220 F117 applications. Refer to Procedure 019-004 in the Associated Procedures Table.
  • Use the following procedure for X15 CM2350 X114B applications. Refer to Procedure 019-004 in the Associated Procedures Table.
  • Use the following procedure for X115B applications. Refer to Procedure 019-466 in the Associated Procedures Table.
  • Use the following procedure for QSX11.9 CM2250 ECF engines. Refer to Procedure 019-466 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jun-2017


FAULT CODE 1962 - VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISF2.8 CM2220 F101 | 4310846
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB6.7 CM2250 | 4022254
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2250 | 4022255
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2250 EC | 2883621
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISL8.9 CM2220 SN | 4022190
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISL9 CM2350 L101 | 4310787
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2250 | 4022256
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISX12 CM2350 X102 | 4310646
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISX15 CM2350 X101 | 4310641
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSX15 CM2250 ECF | 2883557
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2350 L102 | 4332796
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISL9 CM2350 L111 | 4367223
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2350 L107 | 4367386
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2250 L115 | 4388626
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2350 L118 | 4388673
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSX15 CM2250 X115 | 4388739
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | B4.5 CM2350 B129B | 5411247
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | B6.7 CM2350 B135B | 5411257
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | B4.5 CM2350 B147B | 5411252
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | B6.7 CM2350 B148B | 5411262
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2350 L122 | 5411278
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | L9 CM2350 L119B | 5411267
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the variable geometry turbocharger (VGT) actuator cooling system. |
 | STEP 1A. Check for active fault codes. | Fault codes related to high coolant temperature active or high count or inactive coolant temperature related faults?
 | STEP 1B. Inspect VGT actuator coolant lines. | Blockages found in the VGT actuator cooling plate or coolant lines?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the VGT actuator cooling system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to high coolant temperature are active or high count or inactive coolant temperature related faults?
YES NO

The VGT actuator internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Inspect VGT actuator coolant lines.

Action

Inspect the VGT actuator coolant lines for kinks and blockages.

  • Blow shop air in reverse flow through the VGT actuator cooling plate and associated coolant lines to check blockages.

Blockages found in the VGT actuator cooling plate or coolant lines?
YES NO

Repair or replace the blocked coolant line.

  • Refer to Procedure 010-041 in the Associated Procedures Table.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Feb-2017


FAULT CODE 1993 - Aftertreatment 1 Diesel Particulate Filter Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure. |
 | STEP 2A. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes installed correctly?
STEP 3. | Check the pressure of the DPF. |
 | STEP 3A. Inspect the aftertreatment DPF. | Tampering or removal of the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes for the following:

  • Leaks or cracks in the differential pressure sensor tubes.
  • Loose fittings on the differential pressure sensor tubes.
  • Missing or broken differential pressure sensor tubes.
  • Plugged tubes.
  • Make sure the differential pressure sensor tubes are installed correctly. It is possible the differential pressure tubes are connected backwards at the rubber tubes at the sensor connection. Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes installed correctly?
YES NO
No Repair

Repair or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table

Go to 3A

Go to 4A

Guided Step 3 - Check the presence of the aftertreatment DPF.

Guided Step 3A - Inspect the aftertreatment DPF.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.
  • ISF2.8 CM2220 ECF2 and ISF3.8 CM2220 F103 engines only: Remove the aftertreatment diesel oxidation catalyst (DOC). Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF.

Inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with or has been removed from the exhaust system.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Tampering or removal of the aftertreatment system detected?
YES NO

Install the correct aftertreatment system for the vehicle.

  • Refer to the Procedure 011-041 in the Associated Procedures Table.
  • ISF2.8 CM2220 ECF2 and ISF3.8 CM2220 F103 engines only: Refer to Procedure 011-049 in the Associated Procedures Table.

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure Refer to Procedure 019-443 in the Asscociated Procedure Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5,ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2150 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Check for a short circuit to battery in the OEM harness. | Greater than 100k ohms?
 | STEP 2B. Check for a short circuit to keyswitch power in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Check for a short circuit to battery in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to battery.

  • Measure the resistance and check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM battery SUPPLY (+) pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to keyswitch power in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to keyswitch power.

  • Check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM keyswitch SIGNAL pin in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ and test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Apr-2017


FAULT CODE 2198 - VGT Actuator Driver Circuit - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.6 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L101 | 4310787
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B121B | 5411223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2250 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2250 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | ISC8.6 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.6 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2636 or 1894 active?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2636 or 1894 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2198 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 2198 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 1894 active?
YES | NO
No Repair | No Repair

Fault Code 2636 or 1894 troubleshooting tree

Go to 2A

Guided Step 2 - Check the VGT actuator circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 1894 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the VGT actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 active?
YES NO

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Feb-2017


FAULT CODE 2288 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2288. | Active or inactive counts of Fault Code 2288?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2288.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive counts of Fault Code 2288.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2288?
YES NO

The engine has been derated due to turbocharger high speed conditions. This is normal operation, but a torque derate was used to protect the engine from exceeding turbocharger high speed limits.

No repair action is necessary.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2014


FAULT CODE 2321 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | 6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has a high number of inactive counts?
STEP 2. | Check the primary speed sensor circuit (crankshaft sensor). |
 | STEP 2A. Inspect the primary speed sensor connector pins (crankshaft sensor). | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness engine control module (ECM) connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or has a high number of inactive counts?
YES NO

If Fault Code 689 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

No Repair

Fault Code 689 troubleshooting tree

Go to 2A

Guided Step 2 - Check the primary speed sensor circuit (crankshaft sensor).

Guided Step 2A - Inspect the primary speed sensor connector pins (crankshaft sensor).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the primary speed sensor.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Remove the primary engine speed sensor (crankshaft) from the engine block and measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2322 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F101 | 4310846
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F103 | 4310839
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2350 F109 | 4367218
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B101 | 2883567
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 SN | 4022190
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L101 | 4310787
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12 CM2350 X102 | 4310646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISZ13 CM2150 | 4022133
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2250 | 4022254
Camshaft Position Sensor | Refer to Procedure 019-363 | ISC8.3 and ISL9 CM2250 | 4022257
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 GX CM2250 | 4022250
Camshaft Position Sensor | Refer to Procedure 019-363 | Westport HD CM2250 | 4021560
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12/ISX11.9 CM2250 | 2883445
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 EC | 2883647
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 | 4022256
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 | 4022255
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 EC | 2883621
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX11.9 CM2250 ECF | 2883561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 ECF | 2883557
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 ECF | 4310661
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 | 4310664
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2350 X101 | 4310641
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5 CM2350 B104 | 4332646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B103 | 4332641
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 M CM2250 L106 | 4358343
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B105 | 4332778
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4332796
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD4.5 CM2150 B119 | 4358465
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2150 B120 | 4358470
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 L110 | 4358475
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F110 | 4358480
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B112 | 4358498
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F107 | 4367316
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L111 | 4367223
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F105 | 4358561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F114 | 4383734
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B106 | 4367376
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F117 | 4388578
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 B128 | 4388601
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 L115 | 4388626
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B130 | 4388668
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L118 | 4388626
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2250 B131 | 4388774
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 B137 | 5411058
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F126 | 5411159
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X114B | 5411181
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X116B | 5411186
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B121B | 5411223
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B142 | 5411131
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 X115 | 4388739
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L116B | 5411330
Camshaft Position Sensor | Refer to Procedure 019-363 | F3.8 CM2350 F120B | 5411237
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B129B | 5411247
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B135B | 5411257
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B147B | 5411252
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B148B | 5411262
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L119B | 5411267
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L122 | 5411278
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B144 | 5411382
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B145 | 5411273
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F124 | 5411484
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F131 | 5411489
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F125 | 5411494
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L123B | 5411465
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 778 active or has a high number of inactive counts?
STEP 2. | Check the secondary speed sensor circuit (camshaft sensor). |
 | STEP 2A. Inspect the secondary speed sensor (camshaft sensor) connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or has a high number of inactive counts?
YES NO

If Fault Code 778 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

No Repair

Fault Code 778.

Go to 2A

Guided Step 2 - Check the secondary speed sensor circuit (camshaft sensor).

Guided Step 2A - Inspect the secondary speed sensor (camshaft sensor) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the secondary speed sensor.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the secondary speed sensor (camshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backward from the ECM connector toward the engine speed sensor connector.

Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2345 - Turbocharger 1 Speed - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL8.9 CM2150 SN | 4022190

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for additional fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 686 and/or 687 active or inactive?
STEP 2. | Check the turbocharger. |
 | STEP 2A. Inspect the turbocharger speed sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Inspect the turbocharger speed sensor. | Turbocharger speed sensor damage found?
 | STEP 2C. Check for an inactive fault code. | Fault Code 2345 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for additional fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 686 and/or 687 active or inactive?
YES NO

Troubleshoot fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting steps

Go to 2A

Guided Step 2 - Check the turbocharger.

Guided Step 2A - Inspect the turbocharger speed sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the engine harness and turbocharger speed sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Remove the turbocharger speed sensor from the turbocharger housing. Refer to Procedure 019-390 in the Associated Procedures Table.

Action

Inspect the nose of the turbocharger speed sensor for the following:

  • Cuts or scratches on the nose of the sensor
  • Cuts or scratches on the sensor body
  • A cracked sensor mounting boss.

Turbocharger speed sensor damage found?
YES NO

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2345 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 3A

Follow Fault Code 686 troubleshooting tree.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jan-2012


FAULT CODE 2346 - Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2346 active or high inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2346 active or high inactive counts?
YES NO

The engine power output was derated to limit the exhaust temperatures. This is normal operation. No repairs are necessary.

 No Repair

Reference Fault Code 2451 troubleshooting procedures.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Jun-2014


FAULT CODE 2373 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119 | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL8.9 CM2150 SN | 4022190
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF3.8 CM2350 F109 | 4367218
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332968
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F118 | 4388708
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F119 | 4388703
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | F3.8 CM2350 F120B | 5411237
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F125 | 5411494
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2373 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active and Fault Code 2373 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2373 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to the Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2374 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM3250 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM3250 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISL8.9 CM2150 SN | 4022190
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISF3.8 CM2350 F109 | 4367218
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F118 | 4388708
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F119 | 4388703
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2250 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM3250 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | F3.8 CM2350 F120B | 5411237
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F125 | 5411494
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP :1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2374 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active and Fault Code 2374 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2374 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure sensor SUPPLY pin to the exhaust gas pressure sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310849
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10 ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply wire, and return circuit. | Greater than 5 VDC?
 | STEP 2D. Check for an open circuit in the fan control solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, supply wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the OEM harness and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Use the following procedure for the ISF2.8 CM2220 E, ISF2.8 CM2220 EN, ISF2.8 CM2220 IAN engines: Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2442 - Injector Solenoid Driver Cylinder 1 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2442 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2442.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2442 active?
YES NO

The injector bar code adjustable parameter for cylinder 1 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Apr-2017


FAULT CODE 2443 - Injector Solenoid Driver Cylinder 2 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2443 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2443.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2443 active?
YES NO

The injector bar code adjustable parameter for cylinder 2 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Apr-2017


FAULT CODE 2444 - Injector Solenoid Driver Cylinder 3 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2444 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2444.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2444 active?
YES NO

The injector bar code adjustable parameter for cylinder 3 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Apr-2017


FAULT CODE 2445 - Injector Solenoid Driver Cylinder 4 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2445 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2445.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2445 active?
YES NO

The injector bar code adjustable parameter for cylinder 4 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Apr-2017


FAULT CODE 2448 - Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Cooling System | Refer to Procedure 008-018 | ISM11 CM876 SN | 4022196
Cooling System | Refer to Procedure 008-018 | ISZ13 CM2150 | 4022133
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 EC | 2883647
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 SN | 4310736
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | ISB/ISD4.5 CM2150 B119 | 4358465
Cooling System | Refer to Procedure 008-018 | ISB/ISD6.7 CM2150 B120 | 4358470
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 L110 | 4358475
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F110 | 4358480
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F116 | 4383664
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2250 B131 | 4388774
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 B137 | 5411058
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine.

Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 2448 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Mar-2017


FAULT CODE 2449 - VGT Actuator Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F101 | 4310846
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Turbocharger | Refer to Procedure 010-033 | ISL8.9 CM2150 SN | 4022190
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 | 4022256
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 | 4022255
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 EC | 2883621
Turbocharger | Refer to Procedure 010-033 | QSX11.9 CM2250 ECF | 2883561
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 ECF | 2883557
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 | 4310664
Turbocharger | Refer to Procedure 010-033 | ISB4.5 CM2350 B104 | 4332646
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B103 | 4332641
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L111 | 4367223
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 B128 | 4388601
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 L115 | 4388626
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB4.5 CM2350 B104 | 4332646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2449 active?
 | STEP 1B. Check for previous variable geometry turbocharger (VGT) actuator removals. | VGT actuator has just been removed or replaced?
 | STEP 1C. Check for active fault codes. | Fault Code 1938 or 2636 active?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Use the sector gear gauge. Nozzle movement meet the requirements according to Procedure 010-134?
 | STEP 2D. Check the VGT output gear for correct calibration. | VGT actuator gear moves when connected to the engine wiring harness?
 | STEP 2D-1. Check the VGT output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 2449. | Fault Code 2449 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Cycle the keyswitch several times. Wait 30 seconds between each key cycle to see if Fault Code 2449 goes active.

Fault Code 2449 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 2449 is active. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous VGT actuator removals.

Action

Determine if the actuator has just been removed or replaced and Fault Code 2449 is active.

VGT actuator has just been removed or replaced?
YES NO

Remove the actuator and install it in the correct position.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Repace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear is broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

Note: It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Use the sector gear gauge. Does the nozzle movement meet the requirements according to Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect base engine components for signs of damage.

Replace the turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear should rotate.

The VGT actuator output gear will exhibit one of the following movements, depending on the ECM calibration. Make sure to closely observe the VGT actuator gear when the VGT actuator is connected to the engine wiring harness.

  • The actuator output gear could possibly rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the VGT actuator is connected to the engine wiring harness.
  • If the VGT actuator gear does not move, disconnect the VGT actuator from the engine wiring harness for 1 second and then reconnect.
  • Repeat the above procedure three times, checking for VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

VGT actuator gear moves when connected to the engine wiring harness?
YES NO

Install the VGT actuator back on the turbocharger. Be sure the theft actuator install and calibrate procedues are performed.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

Do not use pliers or any other tool to turn the gear. Only rotate the gear by hand.

VGT actuator output gear rotates by hand?
YES NO

Install the VGT actuator back on the turbocharger. Be sure the theft actuator install and calibrate procedues are performed.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 2449.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2449 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jun-2016


FAULT CODE 2451 - Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISM11 CM876 SN | 4022196
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISB6.7 CM2250 | 4022254
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISC8.3 and ISL9 CM2250 | 4022257
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX15 CM2250 GX CM2250 | 4022250
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX12/ISX11.9 CM2250 | 2883445
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSX11.9 CM2250 ECF | 2883561
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSX15 CM2250 ECF | 2883557
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX12 CM2350 X102 | 4310646
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX15 CM2350 X101 | 4310641
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISF2.8 CM2220 F101 | 4310846
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISF2.8 CM2220 F117 | 4388578
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISF2.8 CM2220 F126 | 5411159
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | X15 CM2350 X114B | 5411181
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | X15 CM2350 X116B | 5411186
Turbocharger | Refer to Procedure 010-033 | ISM11 CM876 SN | 4022196
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | QSX11.9 CM2250 ECF | 2883561
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 ECF | 2883557
Turbocharger | Refer to Procedure 010-033 | ISX12 CM2350 X102 | 4310646
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2350 X101 | 4310641
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F101 | 4310846
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F117 | 4388578
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F126 | 5411159
Turbocharger | Refer to Procedure 010-033 | X15 CM2350 X114B | 5411181
Turbocharger | Refer to Procedure 010-033 | X15 CM2350 X116B | 5411186

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2634, 2449, or 2387 active?
 | STEP 1B. Check for fault codes. | Active or inactive counts of Fault Code 2973?
 | STEP 1C. Expand and read Fault Code 2451 snapshot data. | Value for the Engine Operating State set to Turbocharger Fueling Control State?
 | STEP 1D. Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 2451 snapshot data. | Values for Turbocharger Compressor Inlet Temperature greater than 14°C or 25°F above the Ambient Air Temperature logged in the snapshot data or Turbocharger Compressor Outlet Temperature (Calculated) above 227°C [440°F]?
 | STEP 1E. Check the exhaust temperature in the Fault Code 2451 snapshot data. | Value for Exhaust Temperature (Calculated) above 760°C [1400°F]?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the charge-air cooler, clamps, hoses, and piping. | Air leaks present or clamps loose?
 | STEP 2B. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 2C. Check for air leaks in the exhaust gas recirculation (EGR) system. | Leaks found in the EGR connection tubing?
 | STEP 2D. Check the air intake system sealing surface between the air filter and the hood air plenum. | Excessive wear or ineffective sealing?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2634, 2449, or 2387 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2973?
YES | NO
No Repair | No Repair

Fault Code 2973 troubleshooting tree.

Go to 1C

Guided Step 1C - Expand and read Fault Code 2451 snapshot data.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Expand and read Fault Code 2451 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.
  • Check the values for the Engine Operating State parameter.

Value for the Engine Operating State set to Turbocharger Fueling Control State?
YES | NO
No Repair | No Repair

Go to 1D

Go to 2A

Guided Step 1D - Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 2451 snapshot data.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Expand and read Fault Code 2451 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.
  • Check the values for the parameters Turbocharger Compressor Inlet Temperature and Turbocharger Compressor Outlet Temperature.

Values for Turbocharger Compressor Inlet Temperature greater than 14°C or 25°F above the Ambient Air Temperature logged in the snapshot data or Turbocharger Compressor Outlet Temperature (Calculated) above 227°C [440°F]?

YES | NO
No Repair | No Repair

Refer to the OEM service manual or contact a Cummins® Authorized Repair Location.

Go to 1E

Guided Step 1E - Check the exhaust temperature in the Fault Code 2451 snapshot data.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Expand and read Fault Code 2451 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data
  • Check the values for the parameter: Exhaust Gas Temperature (Calculated).

Value for Exhaust Gas Temperature (Calculated) above 760° [1400° F]?
YES | NO
No Repair | No Repair

Refer to the OEM service manual or contact a Cummins® Authorized Repair Location.

Go to 2A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the charge-air cooler, clamps, hoses, and piping.

Conditions

  • Turn keyswitch OFF.

Action

Check the charge-air cooler, hoses, and piping for leaks.

Check the clamps for adequate torque.

Refer to Procedure 010-024 in the Associated Procedures Table.

Air leaks present or clamps loose?
YES NO

Repair or replace the leaking component.

Tighten any loose clamps.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for air leaks in the EGR system.

Conditions

  • Turn keyswitch OFF.

Action

Check for air leaks in the EGR system.

Check for air leaks in the EGR connection tubing and connections.

Soot streaks are noticeable where leaks are present.

Leaks found in the EGR connection tubing?
YES NO

Repair any leaks in the EGR system.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the air intake system sealing surface between the air filter and the hood air plenum.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake system sealing surface between the air filter and the hood air plenum.

  • Inspect the surface between the air filter and the hood air plenum.
  • Check for excessive wear, ineffective sealing, and proper fit.

Excessive wear or ineffective sealing?
YES NO

Repair the sealing surfaces(s).

No repair. All engine causes have been eliminated.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jun-2016


FAULT CODE 2555 - Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake air heater relay. | Less than 100 ohms?
 | STEP 2C. Check the intake air heater diagnostic voltage, supply wire, and return circuit. | Greater than 3.75 VDC?
 | STEP 2D. Check for an open circuit in the intake air heater relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake air heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check the intake air heater relay resistance.

  • Measure the resistance between the intake air heater SIGNAL pin and the intake air heater RETURN pin at the intake air heater relay.

For 12 volt systems, both relays must be checked.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the intake air heater relay.

Replace the intake air heater relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the intake air heater diagnostic voltage, supply wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the intake air heater supply voltage and return circuit.

  • Measure the voltage between the intake air heater relay SIGNAL wire and the intake air heater relay RETURN wire at the intake air heater relay connector of the OEM harness.

For 12 volt systems, both leads must be tested.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the intake air heater relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake air heater relay RETURN pin at the intake air heater relay connector to ground.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness, if possible. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intake air heater relay SIGNAL pin and the OEM harness intake air heater relay connector SIGNAL pin.

For 12 volt systems, both leads must be tested.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open intake air heater relay signal; circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 06-May-2017


FAULT CODE 2556 - Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM3250 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2555 active and Fault Code 2556 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2556 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 active and Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake air heater relay to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 active?
YES NO

A damaged intake air heater relay has been detected.

Replace the intake air heater relay. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and ground.

For 12 volt systems, both leads must be tested.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the intake air heater relay wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 06-May-2017


FAULT CODE 2635 - VGT Actuator Driver Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Check the ECM calibration. | ECM code correct for the engine control parts list (CPL)?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Check the ECM calibration.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM calibration and make sure it is correct for the engine CPL.

  • Make sure the ECM code calibration voltage is correct for the application. A 24 volt calibration downloaded into a 12 volt system can cause this fault code.

ECM code correct for the engine control parts list (CPL)?
YES NO

An incorrect variable geometry turbocharger actuator for the voltage application has been detected.

Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Download the correct ECM code for the engine CPL.

2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GX15 CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F114 | 4383734
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature. |
 | STEP 1A. Monitor coolant temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature.

Guided Step 1A - Monitor coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2964 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSF2.8 CM2880 F114 | 4383734
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSF2.8 CM2880 F131 | 5411489
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 CM2350 X102 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2350 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Monitor intake manifold temperature. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manifold temperature.

Guided Step 1A - Monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature.

  • Use INSITE™ electronic service tool to monitor the intake manifold temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Replace the intake manifold temperature sensor. Use the following procedure for all except QSF2.8 CM2880 F114, QSF2.8 CM2880 F131, ISV5.0 CM3230 V104, and L9 CM2350 L123B applications. Refer to Procedure 019-159 in the Associated Procedures Table.

Use Procedure 019-059 for QSF2.8 CM2880 F114, QSF2.8 CM2880 F131, ISV5.0 CM3230 V104, and L9 CM2350 L123B applications. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 3163 - Aftertreatment SCR Intake Temperature Sensor Swapped - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 3142, 3143, 3144, 3146, 3147, or 3148 active?
STEP 2. | Check the temperature sensor configuration. |
 | STEP 2A. Check the circuit response. | Fault Code 3142 active?
 | STEP 2B. Check the circuit response. | Fault Code 3146 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142, 3143, 3144, 3146, 3147, or 3148 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the temperature sensor configuration.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the SCR intake temperature sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO

The SCR intake temperature and SCR outlet temperature sensor connectors are swapped.

Swap the wiring harness connections to the SCR intake temperature and SCR outlet temperature sensor.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the SCR intake temperature sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES NO

The SCR intake temperature and SCR outlet temperature sensor connections are swapped.

Swap the wiring harness connections to the SCR intake temperature sensor and SCR outlet temperature sensor.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jan-2012


FAULT CODE 3164 - Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title
Procedure Number
Service Model Name
Bulletin Number
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISF2.8 CM2220 AN
ISF2.8 CM2220 IAN
4022178
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISF2.8 CM2220 F122
5467376
5467376Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISF3.8 CM2220 AN
ISF3.8 CM2220 IAN
4021704
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN
4022188
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISL8.9 CM2150 SN
4022190
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISM11 CM876 SN
4022196
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISB6.7 CM2250
4022254
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISC8.3 and ISL9 CM2250
4022257
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISX15 CM2250
GX CM2250
4022250
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISX12/ISX11.9 CM2250
2883445
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
QSL9 CM2250
4022256
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
QSB6.7 CM2250
4022255
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISX15 CM2250 SN
4310736
Turbocharger
Refer to Procedure 010-033
ISF2.8 CM2220 AN
ISF2.8 CM2220 IAN
4022178
Turbocharger
Refer to Procedure 010-033
ISF2.8 CM2220 F122
5467376
5467376
Refer to Procedure 010-033
ISF3.8 CM2220 AN
ISF3.8 CM2220 IAN
4021704
Turbocharger
Refer to Procedure 010-033
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN
4022188
Turbocharger
Refer to Procedure 010-033
ISL8.9 CM2150 SN
4022190
Turbocharger
Refer to Procedure 010-033
ISM11 CM876 SN
4022196
Turbocharger
Refer to Procedure 010-033
ISB6.7 CM2250
4022254
Turbocharger
Refer to Procedure 010-033
ISC8.3 and ISL9 CM2250
4022257
Turbocharger
Refer to Procedure 010-033
ISX15 CM2250
GX CM2250
4022250
Turbocharger
Refer to Procedure 010-033
ISX12/ISX11.9 CM2250
2883445
Turbocharger
Refer to Procedure 010-033
QSL9 CM2250
4022256
Turbocharger
Refer to Procedure 010-033
QSB6.7 CM2250
4022255
Turbocharger
Refer to Procedure 010-033
ISX15 CM2250 SN
4310736
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISF2.8 CM2220 AN
ISF2.8 CM2220 IAN
4022178
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISF2.8 CM2220 F122
5467376
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISF3.8 CM2220 AN
ISF3.8 CM2220 IAN
4021704
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN
4022188
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISL8.9 CM2150 SN
4022190
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISM11 CM876 SN
4022196
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISB6.7 CM2250
4022254
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISC8.3 and ISL9 CM2250
4022257
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISX15 CM2250
GX CM2250
4022250
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISX12/ISX11.9 CM2250
2883445
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
QSL9 CM2250
4022256
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
QSB6.7 CM2250
4022255
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISX15 CM2250 SN
4310736

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3142 or 3143 active?
STEP 2. | Check the air handling system for correct operation. |
 | STEP 2A. Check the charge air cooler, clamps, hoses, and piping. | Air leaks present or clamps loose?
 | STEP 2B. Inspect turbocharger compressor and turbine blades. | Damage found on turbocharger blades?
STEP 3. | Inspect the selective catalytic reduction (SCR) inlet temperature sensor. |
 | STEP 3A. Inspect the SCR inlet temperature sensor. | Damage found on SCR inlet temperature sensor?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree

Go to 2A

Guided Step 2 - Check the air handling system for correct operation.

Guided Step 2A - Check the charge air cooler, clamps, hoses, and piping.

Conditions

  • Turn keyswitch OFF.

Action

Check the charge air cooler, hoses, and piping for leaks.

  • Check the clamps for adequate torque. Refer to Procedure 010-024 in the Associated Procedures Table.

Air leaks present or clamps loose?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn keyswitch OFF.
  • Remove the inlet and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Damage found on turbocharger blades?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the SCR inlet temperature sensor.

Guided Step 3A - Inspect the SCR inlet temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the SCR inlet temperature sensor from the exhaust system.

Action

Inspect the SCR inlet temperature sensor.

  • Inspect the SCR inlet temperature sensor for damage and signs of excessively high temperature.

Damage found on SCR inlet temperature sensor?
YES NO

Replace the SCR inlet temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-May-2017


FAULT CODE 3186 - Tachograph Output Shaft Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3186 active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3186 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

–

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3186 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

NOTE: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3186 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 3242 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 3426, 3429, or 3576 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level ok?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 3426, 3429, or 3576 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including the OEM in-line shutoff valve if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF

Action

Check engine coolant level.

  • Make sure that coolant level is within normal operating levels.

Coolant level ok?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure that the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Refer to the OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2011


FAULT CODE 3326 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2150 B119 ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2150 B120 ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3326 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3326 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for engine control module (ECM) communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for ECM communication.

  • Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connector to all other pins in the OEM connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Feb-2017


FAULT CODE 3328 - Transmission Output Shaft Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3328 active or inactive with more than one count logged in the last 25 engine hours?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3328 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Reference Service Bulletin Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have ben completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3418 - Transmission Output Shaft Speed - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3418 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3418 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the transmission output shaft speed sensor or OEM vehicle electronic control unit. See equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3492 - Real Time Clock - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2150 B119 ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2150 B120 ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Verify fault condition and check engine control module (ECM) calibration. |
 | STEP 2A. Perform the diagnostic and verify the fault condition exists. | Fault Code 3492 active?
 | STEP 2B. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Verify fault condition and check ECM calibration.

Guided Step 2A - Perform the diagnostic and verify the fault condition exists.

Conditions

  • Turn keyswitch OFF.

Action

Perform the following steps in order to allow the diagnostic to run and complete and verify that the fault condition still exists.

  • Leave keyswitch off for at least 1 minute.
  • Turn keyswitch back on for 15 minutes.
  • At the end of 15 minutes, use INSITE™ electronic service tool to read the fault codes.

Fault Code 3492 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jun-2017


FAULT CODE 3525 - Wheel-Based Vehicle Speed - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3525 is active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3525 is active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the wheel-based vehicle speed sensor or OEM vehicle electronic control unit.

See equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3526 - Wheel-Based Vehicle Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3526 active or inactive with more than one count logged in the last 25 engine hours?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration matches the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3526 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3526 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Go to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration matches the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3526 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

See the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3527 - Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3527 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration udate for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3527 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the accelerator pedal or lever idle validation switch or OEM vehicle electronic control unit.

Refer to the equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair Complete

Go to 1A

Last Modified: 09-Dec-2015


FAULT CODE 3532 - Ambient Air Temperature - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3532 active?
STEP 2. | Check the original equiment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3532 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the ambient air temperature sensor or OEM vehicle electronic control unit.

Refer to the OEM service manual.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Jul-2015


FAULT CODE 3539 - Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 EC2CF | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISB6.7 CM2350 B101 | 2883567
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L101 | 4310787
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISX15 CM2350 X101 | 4310641
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2250 | 4022256
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B105 | 4332778
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L102 | 4332796
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L11 | 4367223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B106 | 4367376
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F117 | 4388578
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B122 | 4388767
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F126 | 5411159
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X114B | 5411181
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X116B | 5411186
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | B6.7 CM2350 B121B | 5411223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L116B | 5411330
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L122 | 5411278
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B144 | 5411382
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L119B | 5411267
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISD6.7 CM2880 D101 | 5411372
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F129 | 5411325
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L123B | 5411465
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 EC2CF | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3539 active?
STEP 2. | Check the engine intake throttle actuator position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3539 inactive and Fault Code 3541 active?
 | STEP 2C. Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the engine intake throttle actuator position sensor supply and return circuit at the ECM. | 4.75 VDC to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 3539 inactive and Fault Code 3541 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the engine intake throttle actuator connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 inactive and Fault Code 3541 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness.

  • Measure the voltage between the engine intake throttle actuator position +5 VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

Replace the engine intake throttle actuator. Refer to Procedure 010-140 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the engine intake throttle actuator position sensor supply and return circuit at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply and return circuit at the ECM.

  • Measure the voltage between the engine intake throttle actuator position 5 VDC SUPPLY pin and the engine intake throttle actuator position return at the ECM port.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the ECM engine connector.

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 inactive and Fault Code 3541 active?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 3541 - Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 EC2CF | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISB6.7 CM2350 B101 | 2883567
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L101 | 4310787
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISX15 CM2350 X101 | 4310641
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2250 | 4022256
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L102 | 4332796
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B105 | 4332778
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L111 | 4367223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B106 | 4367376
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F117 | 4388578
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B122 | 4388767
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F126 | 5411159
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X114B | 5411181
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X116B | 5411186
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | B6.7 CM2350 B121B | 5411223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L116B | 5411330
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B144 | 5411382
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L119B | 5411267
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISD6.7 CM2880 D101 | 5411372
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F129 | 5411325
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L123B | 5411465
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L122 | 5411278
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411186
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 EC2CF | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3541 active?
STEP 2. | Check the engine intake throttle actuator position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3539 active and Fault Code 3541 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3541 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins.. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine harness and engine intake throttle actuator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the engine intake throttle actuator position sensor +5 VDC SUPPLY pin and the engine intake throttle actuator position sensor SIGNAL pin at the engine harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 active and Fault Code 3541 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the engine intake throttle actuator position sensor +5 VDC SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake throttle actuator position sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES NO

Replace the engine intake throttle actuator. Refer to Procedure 010-140 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 3539 active and Fault Code 3541 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 3541 active?
YES NO

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the engine intake throttle actuator +5 VDC position SUPPLY pin and the engine intake throttle actuator position RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 3541 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 3542 - Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 EC2CF | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISB6.7 CM2350 B101 | 2883567
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L101 | 4310787
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISX15 CM2350 X101 | 4310641
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2250 | 4022256
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L102 | 4332796
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B105 | 4332778
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L111 | 4367223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B106 | 4367376
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F117 | 4388578
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B122 | 4388767
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F126 | 5411159
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X114B | 5411181
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X116B | 5411186
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | B6.7 CM2350 B121B | 5411223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L116B | 5411330
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L119B | 5411267
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L122 | 5411278
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 EC2CF | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor circuit fault codes. | Fault Code 3539 or 3541 active?
STEP 2. | Check the engine intake throttle actuator position sensor and circuit. |
 | STEP 2A. Inspect the engine intake throttle. | Engine intake throttle blocked or sticking?
 | STEP 2B. Inspect the engine harness and sensor connector pins | Dirty or damaged pins?
 | STEP 2C. Check the circuit response. | Fault Code 3539 active?
 | STEP 2D. Check the circuit response. | Fault Code 3541 active?
 | STEP 2E. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 3539 active?
 | STEP 3C. Check the ECM response. | Fault Code 3541 active?
 | STEP 3D. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor circuit fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 or 3541 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine intake throttle actuator position sensor and circuit.

Guided Step 2A - Inspect the engine intake throttle.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the intake throttle for blockage or obstruction.

Note: It is important to check for a frozen, plugged, or restricted engine intake air throttle in extreme cold ambient temperatures. Ice can form on the engine intake air throttle causing obstuction/sticking and may not be present at the time of troubleshooting.

Engine intake throttle blocked or sticking?
YES NO

A stuck or obstructed engine intake throttle actuator has been detected.

Remove the blockage or obstruction.

Refer to Procedure 010-140 in the Associated Procedures Table.

If icing is suspected, make sure ice is removed. Refer to Cold Weather Operations of Diesel Engines, Bulletin 3379009, to prevent future icing.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine harness and sensor connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 3539 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the engine intake throttle actuator position sensor RETURN pin and the engine intake throttle actuator position sensor SIGNAL pin at the engine intake throttle actuator connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the engine intake throttle actuator position sensor +5 VDC SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for multimeter useage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

A stuck or broken engine intake throttle actuator has been detected.

Replace the engine intake throttle actuator.

Refer to Procedure 010-140 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake throttle actuator position sensor RETURN pin and the engine intake throttle actuator position sensor SIGNAL pin at the ECM engine connector.

  • Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the engine intake throttle actuator position +5 VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for multimeter useage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

An intermittent short or open circuit has been detected in the engine harness.

Repair or replace the engine harness.

019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jan-2017


FAULT CODE 3558 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3558 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3558 inactive and Fault Code 3561 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition. | Fault Code 3558 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3558 inactive and Fault Code 3561 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3558 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 3429, 3571, and 3579 will be active.

Fault Code 3558 inactive and Fault Code 3561 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3558 active?
YES NO

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Turn keyswitch OFF for a minimum of 1 minute.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

NOTE: The key cycle with the controller unplugged (as outlined in the ‘Conditions’ section) must be performed to make sure that the proper fault code is set.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3571, 3576, and 3579 will also be active.

Fault Code 3558 inactive and Fault Code 3561 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3559 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3559 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3559 inactive and Fault Code 3561 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition. | Fault Code 3559 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3559 inactive and Fault Code 3561 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 3429, 3571, and 3579 will be active.

Fault Code 3559 inactive and Fault Code 3561 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3559 active?
YES NO

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3571, 3576, and 3579 will also be active.

Fault Code 3559 inactive and Fault Code 3561 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3561 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3561 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing unit and circuit.. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3561 inactive and Fault Code 3558 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition. | Fault Code 3561 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3561 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin and the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Codes 3429, 3571, and 3579 will be active.

Fault Code 3561 inactive and Fault Code 3558 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3561 active?
YES NO

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedure Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the harness.

Action

Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the harness connector and the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the harness connector and the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature SIGNAL pin at the harness connector and the 86-pin controller connector.

Less than 10 ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Jul-2015


FAULT CODE 3562 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3562 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller and harness. |
 | STEP 2A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF line heater relay. |
 | STEP 3A. Inspect the aftertreatment DEF line heater relay and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the aftertreatment DEF line heater relay circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF controller and harness.

Guided Step 2A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin and all other pins in the aftertreatment DEF controller harness 53-pin connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the RETURN wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF line heater relay.

Guided Step 3A - Inspect the aftertreatment DEF line heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater relay and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the resistance of the aftertreatment DEF line heater relay circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.
  • Connect the aftertreatment DEF line heater relay to the aftertreatment DEF controller harness.

Action

Check the resistance of the aftertreatment DEF line heater relay circuit.

  • Measure the resistance between the aftertreatment DEF line heater relay SUPPLY pin and the aftertreatment DEF line heater relay RETURN pin at the aftertreatment DEF controller harness 53-pin connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A short circuit has been detected in the aftertreatment DEF line heater relay.

Replace the aftertreatment DEF line heater relay. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Feb-2013


FAULT CODE 3563 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted To Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3563 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller and harness. |
 | STEP 2A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF line heater relay. |
 | STEP 3A. Inspect the aftertreatment DEF line heater relay and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3563 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF controller and harness.

Guided Step 2A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin and all other pins in the aftertreatment DEF controller harness 53-pin connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the RETURN wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to the original equipment manufacturer (OEM) service manual.

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF line heater relay.

Guided Step 3A - Inspect the aftertreatment DEF line heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin at the aftertreatment DEF controller harness 53-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the return wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Mar-2013


FAULT CODE 3564 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3564 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater relay. |
 | STEP 2A. Inspect the aftertreatment DEF line heater relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3562 active and Fault Code 3564 inactive?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF line heater relay condition. | Fault Code 3564 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness line heater relay supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF controller harness line heater relay return circuit. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3564 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater relay.

Guided Step 2A - Inspect the aftertreatment DEF line heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater relay and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Perform the following steps to check the circuit response.

  • Place a jumper wire between the aftertreatment DEF line heater relay RETURN pin (pin 85) and the line heater relay SUPPLY pin (pin 86) at the aftertreatment DEF line heater relay harness connector.
  • Turn keyswitch ON.
  • Turn keyswitch OFF and wait 1 minute.
  • Turn the keyswitch ON for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Note: Fault Codes 3258, 3261, and 3425 will be active.

Fault Code 3562 active and Fault Code 3564 inactive?
YES NO

Note: If both fault codes are active then the keyswitch was not cycled twice as necessary.

No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF line heater relay condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF line heater relay to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON for 1 minute.
  • Turn keyswitch OFF and wait 1 minute.
  • Turn keyswitch ON for 1 minute.
  • Turn keyswitch OFF and wait 90 seconds and repeat this process one more time to allow all diagnostic checks to complete.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3564 active?
YES NO

An open circuit has been detected in the aftertreatment DEF line heater relay.

Replace the aftertreatment DEF line heater relay.

Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness line heater relay supply circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater relay SUPPLY pin at the 53 pin controller harness connector and the aftertreatment DEF line heater relay SUPPLY pin (pin 86) at the line heater relay connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater relay supply circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF controller harness line heater relay return circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin at the 53-pin controller harness connector and the aftertreatment DEF line heater relay RETURN pin at the line heater relay connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater relay return circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jan-2014


FAULT CODE 3565 - Aftertreatment DEF Dosing Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3565 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF dosing valve. | Resistance between 11 and 18 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86 pin connector. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3565 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3565 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an internal short or open circuit in the aftertreatment DEF dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.

Action

Inspect the aftertreatment DEF controller harness and 86 pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin at the 86 pin connector and the aftertreatment DEF dosing valve SIGNAL pin in the dosing valve harness connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin at the 86 pin connector and the aftertreatment DEF dosing valve RETURN pin in the dosing valve harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-Pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86-pin connector and engine block ground.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86-pin connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86-pin connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86 pin connector and all other populated pins in the connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86 pin connector and all other populated pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The dosing valve must be commanded on in order for all dosing valve diagnostics to run.

Before checking the fault codes, perform the Aftertreatment DEF Dosing Unit Override Test in INSITE™ electronic service tool.

Refer to Procedure 011-063 in the Associated Procedures Table.

Fault Code 3556 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Do not install the aftertreatment diesel fluid dosing valve into the selective catalytic reduction (SCR) decompostion tube until the repair validation steps have been completed in step 4B and fault code has been cleared.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 26-Aug-2016


FAULT CODE 3566 - Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3566 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF dosing valve. | Resistance between 11 and 18 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86 pin connector. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3566 inactive?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3566 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an internal short or open circuit in the aftertreatment DEF dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pins of the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.

Action

Inspect the aftertreatment DEF controller harness and 86 pin connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.
Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin at the 86 pin connector and the aftertreatment DEF dosing valve SIGNAL pin in the dosing valve harness connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin at the 86 pin connector and the aftertreatment DEF dosing valve RETURN pin in the dosing valve harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3C

Go to 4A

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.
Guided Step 3C - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86 pin connector and engine block ground.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86 pin connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3D

Go to 4A

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.
Guided Step 3D - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86 pin connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86 pin connector and all other populated pins in the connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86 pin connector and all other populated pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The dosing valve must be commanded ON in order for all dosing valve diagnostics to run.

  • Before checking the fault codes, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test in INSITE™ electronic service tool. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3566 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Do not install the aftertreatment diesel fluid dosing valve into the selective catalytic reduction (SCR) decomposition tube until the repair validation steps have been completed in step 4B and fault code has been cleared.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2016


FAULT CODE 3567 - Aftertreatment DEF Dosing Valve - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3567 active?
STEP 2. | Check the aftertreatment DEF dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF dosing valve. | Resistance between 11 and 18 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86-pin connector. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3567 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3567 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an internal short or open circuit in the aftertreatment DEF dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.

Action

Inspect the aftertreatment DEF controller harness and 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin at the 86-pin connector and the aftertreatment DEF dosing valve SIGNAL pin in the dosing valve harness connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin at the 86-pin connector and the aftertreatment DEF dosing valve RETURN pin in the dosing valve harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86-pin connector and engine block ground.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86-pin connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86-pin connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86-pin connector and all other populated pins in the connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86-pin connector and all other populated pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The dosing valve must be commanded on in order for all dosing valve diagnostics to run.

  • Before checking the fault codes, perform the Aftertreatment DEF Dosing Unit Override Test in INSITE™ electronic service tool. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3567 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 04-Apr-2014


FAULT CODE 3568 - Aftertreatment Diesel Exhaust Fluid Dosing Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISX15 CM2250 GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3568 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller software phase. |
 | STEP 2A. Check if an aftertreatment diesel exhaust fluid controller software phase update is available. | If a software phase update for this fault code is available, does the aftertreatment diesel exhaust fluid controller contain that revision or higher?
STEP 3. | Check the diesel exhaust fluid dosing valve circuit. |
 | STEP 3A. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid dosing valve circuit. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment diesel exhaust fluid dosing valve. |
 | STEP 4A. Check the resistance of the aftertreatment diesel exhaust fluid dosing valve. | Resistance between 11 and 18 ohms?
STEP 5. | Check the aftertreatment diesel exhaust fluid dosing unit filter. |
 | STEP 5A. Check the aftertreatment diesel exhaust fluid dosing unit filter. | Aftertreatment diesel exhaust fluid dosing unit filter free from contamination?
STEP 6. | Check the aftertreatment diesel exhaust fluid dosing system operation. |
 | STEP 6A. Check the aftertreatment diesel exhaust fluid dosing system operation. | Dosing valve meets the specifications outlined in Procedure 011-063?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3568 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid controller software phase.

Guided Step 2A - Check if an aftertreatment diesel exhaust fluid controller software phase update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the aftertreatment diesel exhaust fluid controller software phase to the latest revision published on QuickServe™ Online for applicable changes related to this fault code.

  • Refer to Cummins® aftertreatment diesel exhaust fluid controller software phases, Bulletin 4310705.
  • Use INSITE™ electronic service tool to find the present aftertreatment diesel exhaust fluid controller software phase. The aftertreatment diesel exhaust fluid controller software phase is found in the System Dataplate section of Aftertreatment Diesel Exhaust Fluid Controller in Features and Parameters.

If a software phase update for this fault code is available, does the Aftertreatment Diesel Exhaust Fluid Controller contain that revision or higher?

YES NO
No Repair

If necessary, calibrate the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-077 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the diesel exhaust fluid dosing valve circuit.

Guided Step 3A - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid dosing valve circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the 86-pin connector.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment diesel exhaust fluid controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin and the RETURN pin of the aftertreatment diesel exhaust fluid controller harness 86-pin connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the aftertreatment diesel exhaust fluid controller harness.

Refer to the equipment manufacturer service information.

Go to 4A

Go to 7A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid dosing valve.

Guided Step 4A - Check the resistance of the aftertreatment diesel exhaust fluid dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment diesel exhaust fluid controller harness.

Action

Check for an internal short or open circuit in the aftertreatment diesel exhaust fluid dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pins of the aftertreatment diesel exhaust fluid dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment diesel exhaust fluid dosing valve.

Replace the aftretreatment diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table. Do not install the aftertreatment diesel fluid dosing valve into the SCR decompostion tube until the repair validation steps have been completed in Step 7B and fault code has been cleared.

Go to 5A

Go to 7A

Guided Step 5 - Check the aftertreatment diesel exhaust fluid dosing unit filter.

Guided Step 5A - Check the aftertreatment diesel exhaust fluid dosing unit filter.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit filter for contamination.

Use the following procedure to check for contamination. Refer to Procedure 011-060 in the Associated Procedures Table

Aftertreatment diesel exhaust fluid dosing unit filter free from contamination?
YES NO
No Repair

Clean the aftertreatment diesel exhaust fluid system. Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check the aftertreatment diesel exhaust fluid dosing system operation.

Guided Step 6A - Check the aftertreatment diesel exhaust fluid dosing system operation.

Conditions

  • Turn keyswitch OFF.
  • Remove the diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment diesel exhaust fluid dosing valve.

Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specifications outlined in Procedure 011-063?
YES NO
No Repair

A damaged aftertreatment diesel exhaust fluid dosing valve has been detected.

Replace the aftertreatment diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table. Do not install the aftertreatment diesel fluid dosing valve into the SCR decompostion tube until the repair validation steps have been completed in Step 7B and fault code has been cleared

Go to 7A

Go to 7A

Guided Step 7 - Check the ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM.The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3571 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | IGX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | IGX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 3557 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3571 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3572 active and Fault Code 3571 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3571 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the circuit response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 inactive?
YES NO

An inactive or intermittent fault code has been detected. Refer to Procedure 019-362 in Section 19.

No Repair

Go to 1A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment diesel exhaust fluid pressure RETURN pin and the aftertreatment diesel exhaust fluid pressure SIGNAL pin at the diesel exhaust fluid dosing unit connector of the controller harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Note: Fault Codes 3429, 3561, and 3579 will also be active.

Fault Code 3572 active and Fault Code 3571 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment diesel exhaust fluid pressure +5 volt SUPPLY pin to the aftertreatment diesel exhaust fluid pressure RETURN pin at the dosing unit connector of the aftertreatment diesel exhaust fluid controller harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES NO

A damaged aftertreatment diesel exhaust fluid pressure sensor has been detected in the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the diesel exhaust fluid controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment diesel exhaust fluid pressure RETURN pin and the aftertreatment diesel exhaust fluid pressure SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit controller.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Note: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3576, and 3579 may also be active.

Fault Code 3572 active and Fault Code 3571 inactive?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 inactive?
YES NO
No Repair

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from aftertreatment diesel exhaust fluid pressure +5 volt SUPPLY pin to the aftertreatment diesel exhaust fluid pressure RETURN pin at the aftertreatment diesel exhaust fluid controller 86-pin connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Last Modified: 16-Jan-2017


FAULT CODE 3572 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2250 | 4022255

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 3557 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3572 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 3571 active and Fault Code 3572 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3572 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the circuit response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 inactive?
YES NO

An inactive or intermittent fault code has been detected.

Refer to Procedure 019-362 in Section 19.

No Repair

Go to 1A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from aftertreatment diesel exhaust fluid pressure +5 volt SUPPLY pin to the aftertreatment diesel exhaust fluid pressure RETURN pin at the dosing unit connector of the aftertreatment diesel exhaust fluid controller harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 3429, 3561, and 3579 will also be active.

Fault Code 3571 active and Fault Code 3572 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES NO

A damaged aftertreatment diesel exhaust fluid pressure sensor has been detected in the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from aftertreatment diesel exhaust fluid pressure +5 volt SUPPLY pin to the aftertreatment diesel exhaust fluid pressure RETURN pin at the aftertreatment diesel exhaust fluid controller 86-pin connector.

Use the circuit diagram or the wiring diagram for connector pin identification

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Note: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3576, and 3579 will also be active.

Fault Code 3571 active and Fault Code 3572 inactive?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or shorted signal circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3574 - Aftertreatment DEF Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445
Air in the DEF | Refer to Procedure 011-075 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Air in the DEF | Refer to Procedure 011-075 | ISF2.8 CM2220 F122 | 5467376
Air in the DEF | Refer to Procedure 011-075 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Air in the DEF | Refer to Procedure 011-075 | ISB6.7 CM2250 | 4022254
Air in the DEF | Refer to Procedure 011-075 | ISC8.3 and ISL9 CM2250 | 4022257
Air in the DEF | Refer to Procedure 011-075 | ISX15 CM2250 GX CM2250 | 4022250
Air in the DEF | Refer to Procedure 011-075 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3574 active or more than two inactive counts?
 | STEP 1B. Check for low DEF tank level. | DEF tank empty and/or Fault Code 1671, 1673, 3497, or 3498 active?
 | STEP 1C. Check the DEF tank for debris or foreign particles. | Debris or foreign particles found in the DEF tank?
 | STEP 1D. Check for active aftertreatment DEF system fault codes. | Fault Code 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679 active?
 | STEP 1E. Check for active or inactive aftertreatment DEF system fault codes. | Fault Code 1713 active or inactive?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 2B. Check the aftertreatment DEF dosing unit supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 2C. Check for air in the DEF. | Air detected in the DEF?
STEP 3. | Check the aftertreatment DEF tank filter. |
 | STEP 3A. Inspect the DEF tank filter for blockage. | DEF tank filter blocked?
STEP 4. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 4A. Perform the aftertreatment DEF Doser Pump Override Test. | Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
 | STEP 4B. Perform the aftertreatment DEF dosing unit airless flush. | Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1671, 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1671, 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check the DEF tank for debris or foreign particles.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank for debris or foreign particles.

Debris or foreign particles found in the DEF tank?
YES NO

Clean the DEF tank thoroughly and refill with certified diesel exhaust fliud.

 No Repair

Go to 1D

Go to 1D

Guided Step 1D - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active fault codes relating to the aftertreatment DEF dosing unit, return valve, or dosing valve:
  • 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679.

Fault Code 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679 active?
YES NO

Troubleshoot any active fault codes in this list before troubleshooting Fault Code 3574.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for active or inactive Fault Code 1713.

Fault Code 1713 active or inactive?
YES NO

If Fault Code 1713 is active or inactive, go to the troubleshooting tree for Fault Code 1713 and complete step 4B.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF dosing unit fittings and lines.

  • Check the dosing unit supply, outlet, and return connectors and fittings for loose or leaking connections.
  • Disconnect the dosing unit supply, outlet, and return connectors and look for signs of buildup or blockage.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?
YES NO

Repair or replace the leaking DEF line or fitting as necessary. Refer to the OEM service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit supply line from the dosing unit (suction line between the tank and dosing unit).
  • Disconnect the aftertreatment DEF dosing unit supply line from the DEF tank.

Action

Check the DEF dosing unit supply line for blockage.

  • Look at both ends of the line to check for signs of build-up or blockage.
  • Blow compressed shop air through the supply line to establish/confirm free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line using shop air. If necessary, replace the dosing unit supply line.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air detected in the DEF?
YES NO

Check the following components for damage or leaks and repair as necessary:

  • Aftertreatment DEF dosing unit fittings
  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

Replace DEF dosing unit SUPPLY line and RETURN line fittings.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF tank filter.

Guided Step 3A - Inspect the DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the sending unit from the DEF tank.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

Refer to the OEM service manual.

DEF tank filter blocked?
YES NO

Clean or change the DEF tank filter.

Drain, clean, and fill the DEF tank.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check the aftertreatment DEF dosing unit operation.

Guided Step 4A - Perform the Aftertreatment DEF Doser Pump Override Test.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to perform the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Perform the aftertreatment DEF dosing unit airless flush.

Conditions

  • Remove the aftertreatment DEF dosing valve removed.
  • Remove the aftertreatment DEF dosing unit.
  • Connect INSITE™ electronic service tool.

Action

Flush the aftertreatment DEF dosing unit with clean water.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-058 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-May-2017


FAULT CODE 3577 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3577 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid return valve and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid return valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3577 inactive and Fault Code 3579 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid return valve condition. | Fault Code 3577 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3577 inactive and Fault Code 3579 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3577 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid return valve and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid return valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 3429, 3561, and 3571 will be active.

Fault Code 3577 inactive and Fault Code 3579 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid return valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Turn keyswitch OFF for a minimum of 1 minute.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

Note that the key cycle with the dosing unit connected again (as outlined in the ‘Conditions’ section) must be performed to make sure that the proper fault code is set.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3577 active?
YES NO

A damaged aftertreatment diesel exhaust fluid return valve has been detected in the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, and 3576 will also be active.

Fault Code 3577 inactive and Fault Code 3579 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3578 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3578 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid return valve and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid return valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3578 inactive and Fault Code 3579 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid return valve condition. | Fault Code 3578 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3578 inactive and Fault Code 3579 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3578 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid return valve and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid return valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 3429, 3561, and 3571 will be active.

Fault Code 3578 inactive and Fault Code 3579 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid return valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3578 active?
YES NO

A damaged aftertreatment diesel exhaust fluid return valve has been detected in the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, and 3576 will also be active.

Fault Code 3578 inactive and Fault Code 3579 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3579 - Aftertreatment Diesel Exhaust Fluid Return Valve - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
OEM Wiring Harness | Refer to Procedure 019-071 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
OEM Wiring Harness | Refer to Procedure 019-071 | ISF3.8 CM2220 AN | 4021704
OEM Wiring Harness | Refer to Procedure 019-071 | ISB6.7 CM2250 | 4022254
OEM Wiring Harness | Refer to Procedure 019-071 | ISC8.3 and ISL9 CM2250 | 4022257
OEM Wiring Harness | Refer to Procedure 019-071 | ISX15 CM2250 GX CM2250 | 4022250
OEM Wiring Harness | Refer to Procedure 019-071 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3579 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF)return valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF return valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3579 inactive and Fault Code 3577 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF return valve condition. | Fault Code 3579 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF return valve circuit. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3579 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF return valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF return valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.

Action

Inspect the engine harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedured for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF return valve SUPPLY pin and the aftertreatment DEF return valve SIGNAL pin at the aftertreatment DEF dosing unit wiring harness connector.
  • Turn keyswitch OFF for a minimum of 1 minute.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 3429, 3561, and 3571 will be active.

Fault Code 3579 inactive and Fault Code 3577 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF return valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3579 active?
YES NO

A damaged aftertreatment DEF return valve has been detected in the aftertreatment DEF dosing unit.

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Inspect the aftertreatment DEF controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Component Connector and Pin Inspection. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF return valve circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Disconnect the aftertreatment DEF dosing unit from the harness.

Action

Check for an open circuit in the aftertreatment DEF return valve circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin at the dosing unit harness connector and the aftertreatment DEF return valve SUPPLY pin at the 86-pin controller connector.
  • Measure the resistance between the aftertreatment DEF return valve SIGNAL pin at the dosing unit harness connector and the aftertreatment DEF return valve SIGNAL pin at the 86-pin controller connector.

Less than 10 ohms?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness. Refer to the original equipment manufacturer (OEM) service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Mar-2013


FAULT CODE 3596 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 F129 | 5411325
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220 F129 | 5411325
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220 F129 | 5411325
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISB6.7 CM2250 | 4022254
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISC8.3 and ISL9 CM2250 | 4022257
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISX15 CM2250 GX CM2250 | 4022250
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISX12/ISX11.9 CM2250 | 2883554

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3571 and 3572. | Fault Code 3571 or 3572 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid pressure sensor. | Aftertreatment diesel exhaust fluid pressure reading in INSITE™ electronic service tool equal to 0 ± 69 KPa [0 ± 10 psi]?
STEP 3. | Check the aftertreatment diesel exhaust fluid lines and fittings |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 3B. Check the aftertreatment diesel exhaust fluid dosing unit supply line. | Diesel exhaust fluid dosing unit supply line blocked or restricted?
 | STEP 3C. Check the aftertreatment diesel exhaust fluid dosing unit return line. | Diesel exhaust fluid return line blocked or restricted?
 | STEP 3D. Check for air in the diesel exhaust fluid. | Air in the diesel exhaust fluid detected?
 | STEP 3E. Inspect the aftertreatment diesel exhaust fluid dosing unit supply line fitting. | Dosing unit supply line or return line fitting blocked?
 | STEP 3F. Check the aftertreatment diesel exhaust fluid dosing unit lines and fittings. | Is the aftertreatment diesel exhaust fluid dosing unit pump pressure between 850 kPa (123 psi) and 950 kPa (137 psi)?
STEP 4. | Check the aftertreatment diesel exhaust fluid tank filter |
 | STEP 4A. Inspect the diesel exhaust fluid tank filter for blockage. | Diesel exhaust fluid tank filter blocked?
STEP 5. | Check aftertreatment diesel exhaust fluid dosing unit operation |
 | STEP 5A. Check the aftertreatment diesel exhaust fluid dosing unit for proper operation. | Does the aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in Procedure 011-063?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 3571 and 3572.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 or 3572 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid pressure sensor.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve supply line from the aftertreatment diesel exhaust fluid dosing unit.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment diesel exhaust fluid pressure.

Aftertreatment diesel exhaust fluid pressure reading in INSITE™ electronic service tool equal to 0 ± 69 KPa [0 ± 10 psi]?
YES NO
No Repair

A damaged aftertreatment diesel exhaust fluid pressure sensor has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid lines and fittings

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three diesel exhaust fluid lines on the SCR dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing unit and the tank (return line)

Inspect all three diesel exhaust fluid lines and associated fittings/connectors:

  • Check the diesel exhaust fluid tank connections (suction and return lines) for cracks and pitting
  • Check all three dosing unit connections and fittings for loose, leaking, or damaged connections
  • Disconnect the suction line, pressure line, and return line dosing unit connectors and look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which would allow the dosing unit to draw in air with the diesel exhaust fluid.
  • Verify proper sealing at all connection points, including diesel exhaust fluid tank (2 connections), dosing unit (3 connections), and dosing valve (1 connection).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking diesel exhaust fluid line or fitting as necessary.

Refer to the original equipment manufacturer (OEM) service manual.

Repair or replace the aftertreatment diesel exhaust fluid dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the aftertreatment diesel exhaust fluid dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit supply line from the dosing unit (this is the suction line between the dosing unit and the diesel exhaust fluid tank).
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit supply line from the diesel exhaust fluid tank.

Action

Check the diesel exhaust fluid dosing unit supply line for blockage.

  • Visually check both ends of the dosing unit supply line for signs of build-up or blockage.
  • Blow compressed shop air through the dosing unit supply line to ensure free flow.

Diesel exhaust fluid dosing unit supply line blocked or restricted?

YES NO

Try to clean the dosing unit supply line using shop air. If necessary, replace the dosing valve supply line.

Refer to OEM service manual.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check the aftertreatment diesel exhaust fluid dosing unit return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit return line from the dosing unit (return line runs between the tank and dosing unit and returns diesel exhaust fluid to the tank).
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit return line from the diesel exhaust fluid tank.

Action

Check the diesel exhaust fluid return line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

Diesel exhaust fluid return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3D

Guided Step 3D - Check for air in the diesel exhaust fluid.

Conditions

  • Connect the aftertreatment diesel exhaust fluid dosing unit supply and return lines to the diesel exhaust fluid tank.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the diesel exhaust fluid.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the diesel exhaust fluid detected?

YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment diesel exhaust fluid dosing unit fittings.
  • Aftertreatment diesel exhaust fluid dosing unit supply line.
  • Aftertreatment diesel exhaust fluid tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3E

Guided Step 3E - Inspect the aftertreatment diesel exhaust fluid dosing unit supply line fitting.

Conditions

  • Turn keyswitch OFF.
  • Remove the diesel exhaust fluid dosing supply line and return line fittings.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit supply line and return line fittings for blockage.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Dosing unit supply line or return line fitting blocked?

YES NO

Replace the blocked fitting.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3F

Guided Step 3F - Check the aftertreatment diesel exhaust fluid dosing unit lines and fittings.

Conditions

  • Connect all diesel exhaust fluid lines and electrical connectors to the dosing unit and diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Test.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

Monitor the aftertreatment diesel exhaust fluid dosing unit pump pressure.

NOTE: The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Is the aftertreatment diesel exhaust fluid dosing unit pump pressure between 850 kPa (123 psi) and 950 kPa (137 psi)?
YES NO
No Repair

If the DEF dosing unit pump pressure is greater than 950 kPa [137 psi].

  • Check the return line for damage or restrictions and repair as necessary.
  • If there is no damage or restrictions with the return line, replace the return line fitting.
  • Refer to Procedure 011-058 in the Associated Procedures Table.

If the DEF dosing unit pump pressure is less than 850 kPa [123 psi].

  • Check the supply line for damage or leaks and repair as necessary.
  • Check the supply line fittings for damage or leaks and replace as necessary.
  • Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid tank filter

Guided Step 4A - Inspect the diesel exhaust fluid tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the sending unit from the diesel exhaust fluid tank.

Action

Inspect the aftertreatment diesel exhaust fluid tank filter for signs of blockage or buildup.

Refer to the OEM service manual.

Diesel exhaust fluid tank filter blocked?
YES NO

Clean or replace the diesel exhaust fluid tank filter.

Drain, clean, and refill the diesel exhaust fluid tank.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check aftertreatment diesel exhaust fluid dosing unit operation.

Guided Step 5A - Check the aftertreatment diesel exhaust fluid dosing unit for proper operation.

Conditions

  • Connect all diesel exhaust fluid lines and electrical connectors to the dosing unit and the diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Does the aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in Procedure 011-063?

YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid dosing unit filter. (Note that this filter can not be reused and must be replaced upon removal.)

Refer to Procedure 011-060 in the Associated Procedures Table.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test again with the new filter. If the measured volume of diesel exhaust fluid is still not within specifications, replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM Code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 18-May-2017


FAULT CODE 3598 - Aftertreatment Diesel Exhaust Fluid Controller - Received Network Data In Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3598 inactive?
 | STEP 1B. Check for active fault codes. | Any active fault codes other than 3598?
STEP 2. | Check INSITE™ electronic service tool Feature and Parameter settings. |
 | STEP 2A. Check electrical system voltage and diesel exhaust fluid heater configuration settings. | Electrical system voltage and diesel exhaust fluid heater configuration settings are correct?
STEP 3. | Check ECM calibration. |
 | STEP 3A. Calibrate the ECM. | Did Fault Code 3598 become active again?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3598 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Any active fault codes other than 3598?
YES NO

Troubleshoot all other active fault codes before troubleshooting Fault Code 3598.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check INSITE™ electronic service tool Feature and Parameter settings.

Guided Step 2A - Check electrical system voltage and diesel exhaust fluid heater configuration settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check electrical system voltage and diesel exhaust fluid heater configuration settings in INSITE™ electronic service tool.

  • Use the Features and Parameters menu in INSITE™ electronic service tool to make sure the electrical system voltage and diesel exhaust fluid heater configuration settings are correct for the vehicle being serviced.

Electrical system voltage and diesel exhaust fluid heater configuration settings are correct?
YES NO
No Repair

Use INSITE™ electronic service tool to update the Feature and Parameter settings accordingly.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration.

Guided Step 3A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

After calibrating the ECM, operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Use INSITE™ electronic service tool to check the fault codes.

Did Fault Code 3598 become active again?
YES NO

A damaged or malfunctioning aftertreatment diesel exhaust fluid controller has been detected.

Replace the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-057 in the Associated Procedures Table.

Calibration of the ECM has corrected the issue.

Go to 4A

Repair complete

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3616 - Engine VGT Nozzle Position - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 EC2CF | 4310846
Cooling System | Refer to Procedure 008-018 | ISC8.3 sand ISL9 CM 2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2250 | 4022254
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2350 B103 | 4332641
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2250 EC | 2883621
Air Intake Manifold | Refer to Procedure 010-023 | ISC8.3 sand ISL9 CM 2250 | 4022257
Air Intake Manifold | Refer to Procedure 010-023 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Manifold | Refer to Procedure 010-023 | ISX15 CM 2250 GX CM2250 | 4022250
Air Intake Manifold | Refer to Procedure 010-023 | QSX15 CM2250 ECF | 2883557
Air Intake Manifold | Refer to Procedure 010-023 | QSX11.9 CM2250 ECF | 2883561
Air Intake Manifold | Refer to Procedure 010-023 | ISX15 CM2350 X101 | 4310846
Air Intake Manifold | Refer to Procedure 010-023 | PowerGen QSX15 CM2250 ECF | 4310661
Air Intake Manifold | Refer to Procedure 010-023 | PowerGen QSX15 CM2250 | 4310664
Air Intake Manifold | Refer to Procedure 010-023 | ISL9 CM2350 L111 | 4367223
Air Intake Manifold | Refer to Procedure 010-023 | QSB6.7 CM2250 B128 | 4388601
Air Intake Manifold | Refer to Procedure 010-023 | QSL9 CM2250 L115 | 4388626
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2350 B142 | 5411131
Air Intake Manifold | Refer to Procedure 010-023 | QSX15 CM2250 X115 | 4388739
Air Intake Manifold | Refer to Procedure 010-023 | B4.5 CM2350 B129B | 5411247
Air Intake Manifold | Refer to Procedure 010-023 | B6.7 CM2350 B135B | 5411257
Air Intake Manifold | Refer to Procedure 010-023 | B4.5 CM2350 B147B | 5411252
Air Intake Manifold | Refer to Procedure 010-023 | B6.7 CM2350 B148B | 5411262
Air Intake Manifold | Refer to Procedure 010-023 | L9 CM2350 L119B | 5411267
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 EC | 2883621
Turbocharger | Refer to Procedure 010-033 | ISB4.5 CM2350 B104 | 4332641
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM 2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 EC2CF | 4310846
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | ISX15 CM 2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | QSX11.9 CM2250 ECF | 2883561
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 ECF | 2883557
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 | 4310664
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L111 | 4367223
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 B128 | 4388601
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 L115 | 4388626
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B142 | 5411131
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 X115 | 4388739
Turbocharger | Refer to Procedure 010-033 | B4.5 CM2350 B129B | 5411247
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B135B | 5411257
Turbocharger | Refer to Procedure 010-033 | B4.5 CM2350 B147B | 5411252
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B148B | 5411262
Turbocharger | Refer to Procedure 010-033 | L9 CM2350 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 sand ISL9 CM 2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 EC2CF | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM 2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for other active turbocharger fault codes. | Fault Code 2387 active or high inactive counts?
 | STEP 1B. Review claims history for recent turbocharger failures. | Turbocharger replaced in the past three months for the same symptoms?
STEP 2. | Verify the complaint. |
 | STEP 2A. Check the fault code. | Fault Code 3616 active?
 | STEP 2B. Vehicle test drive | Fault Code 2387 active?
 | STEP 2C. Confirm the complaint. | Customer reported a drivability complaint with a cold engine?
 | STEP 2D. Inspect the variable geometry turbocharger actuator. | Use the sector gear travel gauge. Nozzle movement meet the requirements according to Procedure 010-134?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for other active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or high inactive counts?
YES | NO
No Repair | No Repair

Fault Code 2387 troubleshooting symptom tree

Go to 1B

Guided Step 1B - Review claims history for recent turbocharger malfunctions.

Conditions

  • None

Action

Review malfunctions that have occurred over the last six months to see if the engine has been in for the same symptoms.

Has the turbocharger been replaced in the past three months for the same symptoms?
YES NO

Inspect the grid heater for damage or plugging.

If the engine is not equipped with a grid heater, skip to Step 2A.

  • Refer to Procedure 010-023 in the Associated Procedures Table.

Note: If found damaged, replace the grid heater and inspect the air handling system for debris.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Verify the complaint.

Guided Step 2A - Check the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 3616.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3616 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2C

Guided Step 2B - Vehicle test drive.

Conditions

  • Connect all components.
  • Allow the coolant temperature to cool below 74°C [165°F].
  • NOTE: This test can not be performed if the engine does not start. If the engine does not start, verify there are no other faults that can prohibit the engine from starting. Skip this step, and proceed to Step 2D.

Action

Determine whether the fault goes inactive when operated with a coolant temperature above 74°C [165°F].

  • Start the engine and operate under normal driving conditions for at least 15 minutes, or until the coolant temperature is greater than 74°C [165°F].
  • Use INSITE™ electronic service tool to verify the fault code.

Fault Code 2387 active?
YES NO
No Repair

Fault Code 3616 is an informational fault code indicating that the ECM has taken action to resolve a keyswitch ON condition.

Fault Code 2387 troubleshooting symptom tree

Go to 3A

Guided Step 2C - Confirm the complaint

Conditions

  • Turn keyswitch OFF.

Action

Review the customer complaint.

  • Establish whether the customer reported engine warm-up drivability complaints (low power, poor response, or low braking power).

Customer reported a drivability complaint with a cold engine?
YES NO
No Repair

Fault Code 3616 is an informational fault code indicating that the ECM has taken action to resolve a keyswitch ON condition.

Go to 2D

Go to 3A
Go to

Guided Step 2D - Inspect the variable geometry turbocharger actuator

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.

Action

Remove the variable geometry turbocharger actuator from the turbocharger.

  • Use a sector gear travel gauge, Part Number 4919281, to make sure the sector gear moves through its operational range.
  • Refer to Procedure 010-134 in the Associated Procedures Table.

Note: It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Use the sector gear travel gauge. Nozzle movement meet the requirements according to Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

Note: Replace the turbocharger assembly.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect the base engine components for damage. The variable geometry turbocharger actuator will be reused with the new turbocharger. Do not install the actuator on the malfunctioning turbocharger.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 3648 - Aftertreatment Diesel Exhaust Fluid Controller Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 3648 active or more than three inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller mounting location. |
 | STEP 2A. Make sure that the aftertreatment diesel exhaust fluid controller is properly mounted. | Aftertreatment diesel exhaust fluid controller properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment diesel exhaust fluid controller. | Signs of air flow restriction to diesel exhaust fluid controller?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3648 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid controller mounting location.

Guided Step 2A - Make sure that the aftertreatment diesel exhaust fluid controller is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Refer to the OEM service manual to determine the designated mounting location for the aftertreatment diesel exhaust fluid controller, and verify that the controller is mounted at the correct location on the vehicle. Make sure that all fasteners are properly installed and secure.

Aftertreatment diesel exhaust fluid controller properly installed?
YES NO
No Repair

Relocate and/or secure the aftertreatment diesel exhaust controller at the correct mounting location.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment diesel exhaust fluid controller.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Check the aftertreatment diesel exhaust fluid mounting area for air flow obstructions.The diesel exhaust controller is designed to be mounted such that air will flow over it and naturally cool it during operation. Restrictions or blockage of this air flow could cause the controller to overheat.Check for the following:

  • Debris on or around the diesel exhaust fluid controller
  • Aftermarket shields, flaps, or brackets mounted too close to the diesel exhaust fluid controller.

Signs of air flow restriction to diesel exhaust fluid controller?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the diesel exhaust fluid controller. Relocate any aftermarket accessories that might be restricting air flow.

Contact the vehicle OEM for guidance in diesel exhaust fluid controller mounting.

Go to 3A

Repair Complete

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 13-Jan-2012


FAULT CODE 3651 - Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, 1712, 3237, 3239, 3258, 3261, 3422, 3425, 3426, 3429, 3562, 3563, 3564, or 3576 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in the tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level ok?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank temperature sensor. |
 | STEP 3A. Check the aftertreatment diesel exhaust fluid tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infrared thermometer reading?
 | STEP 3B. Check the aftertreatment diesel exhaust fluid tank temperature sensor. | INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature rises more than 5°C or 9°F while heating?
STEP 4. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 4A. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to line or tank heaters.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, 1712, 3237, 3239, 3258, 3261, 3422, 3425, 3426, 3429, 3562, 3563, 3564, or 3576 active?
YES NO

Troubleshoot appropriate active fault codes before troubleshooting Fault Code 3651.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2A - Check the aftertreatment diesel exhaust fluid tank heating system.

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked or restricted coolant lines
  • Loose connections.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in the tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that the coolant level is within normal operating levels.

Coolant level ok?
YES NO
No Repair

Add coolant to the engine as necessary.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Guided Step 3A - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the diesel exhaust fluid in the diesel exhaust fluid tank with an infared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C or 18°F of infrared thermometer reading?
YES NO

No repair.

Replace the diesel exhaust fluid tank temperature sensor.

Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Conditions

NOTE: If the diesel exhaust fluid tank is frozen, it will be necessary to let the tank thaw before performing this step.

  • Thaw the diesel exhaust fluid tank.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and monitorINSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature sensor.

  • Heat the aftertreatment diesel exhaust fluid tank with a heat gun, Part Number 3822860, to raise the temperature of the diesel exhaust fluid.

INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature rises more than 5°C or 9°F while heating?

YES NO

No repair.

Replace the diesel exhaust fluid tank temperature sensor.

Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 4A - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to override the tank heater operation; use the Diesel Exhaust Fluid Doser System Heater Test under the ECM Diagnostic Tests menu.

Make sure that the tank heater control valve is operating correctly, and is not stuck closed or slow to respond. Refer to the OEM service manual for proper diesel exhaust fluid tank heater control valve operation.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO

No repair.

Replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2011


FAULT CODE 3679 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3679 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
 | STEP 2D. Check for active aftertreatment diesel exhaust fluid dosing unit fault codes. | Fault Code 3558, 3559, or 3561 Active?
 | STEP 2E. Check for an active fault code | Fault Code 3679 Active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3679 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the harness.

Action

Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the dosing unit harness connector and the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the dosing unit harness connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SIGNAL/dosing unit temperature pin at the dosing unit harness connector and the aftertreatment diesel exhaust fluid dosing unit SIGNAL/dosing unit temperature pin at the 86-pin controller connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness. Repair or replace the harness. Refer to the OEM service manual.

Go to 3A

Go to 2C

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller and the diesel exhaust fluid dosing unit harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between aftertreatment diesel exhaust fluid dosing unit SIGNAL / dosing unit temperature pin at the aftertreatment diesel exhaust fluid controller harness 86-pin connector and chassis ground.

Refer to the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for active aftertreatment diesel exhaust fluid dosing unit fault codes.

Conditions

  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active aftertreatment diesel exhaust fluid dosing unit fault codes after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3558, 3559, or 3561 active?
YES | NO
No Repair | No Repair

Applicable fault code troubleshooting tree.

Go to 2E

Guided Step 2E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3679 Active?
YES NO

Replace the aftertreatment diesel exhaust fluid dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 09-Mar-2012


FAULT CODE 3681 - Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 SN | 4310736
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B | 5411181
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X116B | 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for the correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor correct for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
 | STEP 2F. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 3C. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3681 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2C - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine configuration.

The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3681 active?
YES NO

Use NOx sensor service tool, Part Number 2892467, to test the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 2F

Go to 4A

Guided Step 2F - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3681 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt system)
  • At least +24 VDC (24 volt system).

Cranking conditions:

  • At least +6.2 VDC (12 volt system)
  • At least +12 VDC (24 volt system).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery (s). See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-May-2017


FAULT CODE 3697 - Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
5467376Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module. | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2350 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Fault Code 3697 active after calibrating the ECM?
 | STEP 2B. Disable and clear the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the engine control module (ECM).

Guided Step 2A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibration. Refer to the calibration revisions listed in the ECM Calibration Revision History to find the latest calibration available for the engine being serviced.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 3697 active after calibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Repair complete.

Last Modified: 22-May-2017


FAULT CODE 3713 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3713 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater relay. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for pin-to-pin short circuit in diesel exhaust fluid line heater relay. | Less than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3713 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater relay.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid line heater relay and connector pins..

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater relay and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for pin-to-pin short circuit in diesel exhaust fluid line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the aftertreatment diesel exhaust fluid controller harness.

Action

Check the resistance of the aftertreatment diesel exhaust fluid line heater relay.

  • Measure the resistance between pin 30 and pin 87 of the aftertreatment diesel exhaust fluid line heater relay.

Use the following precedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO

A pin-to-pin short circuit on the switch side of the aftertreatment diesel exhaust fluid line heater relay has been detected.

Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to the OEM service manual.

A short circuit to battery has been detected in the line heater power supply circuit of the aftertreatment diesel exhaust fluid controller harness

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necesssary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 13-Dec-2011


FAULT CODE 3737 - Engine Starter Mode Overcrank Protection - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3737 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3737 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Use the appropriate troubleshooting symptom tree in the appropriate Service Manual.

  • Refer to Engine Will Not Crank or Cranks Slowly (Electric Starter) troubleshooting symptom tree in Section TS.
  • Refer to the Engine Performance troubleshooting symptom tree in Section TT.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 01-Nov-2016


FAULT CODE 4138 - Security Device - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4138 active?
STEP 2. | Check the anti-theft device for proper configuration. |
 | STEP 2A. Determine if the anti-theft device is configured correctly. | Anti-theft device configured correctly?
STEP 3. | Check the service data link harness. |
 | STEP 3A. Inspect the anti-theft device and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open or short circuit in the J1939 data link harness. | Resistance between 50 and 70 ohms?
STEP 4. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 4A. Check the engine control module (ECM) and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the ECM J1939 data link harness. | Resistance between 50 and 70 ohms?
 | STEP 4C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4138 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the anti-theft device for proper configuration.

Guided Step 2A - Determine if the anti-theft device is configured correctly.

Conditions

  • Turn keyswitch ON.

Action

Check the anti-theft device for the following:

  • Correct power supply and ground connections.
  • Proper connections to the J1939 data link.
  • Correct electronic configuration of the anti-theft device.

Anti-theft device configured correctly?
YES NO
No Repair

Configure the anti-theft device correctly.

Refer to the anti-theft installation instructions provided by the OEM.

Go to 3A

Go to 5A

Guided Step 3 - Check the service data link harness.

Guided Step 3A - Inspect the anti-theft device and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the anti-theft device from the J1939 data link.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the anti-theft device from the J1939 data link.

Action

Check for an open or short circuit:

  • Measure the resistance between the Society of Automotive Engineering (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit:

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit:

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Refer to the No Communication Symptom Tree in the appropriate service manual.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Apr-2014


FAULT CODE 4139 - Security Device - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4139 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for the anti-theft device fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 4139 active?
YES NO

The anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

See equipment manufacturer service information for anti-theft device operation.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Connect all components.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Apr-2014


FAULT CODE 4284 - Desired Engine Fueling State - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for engine control module (ECM) communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
 | STEP 1B. Check for an active fault code. | Fault Code 4284 active?
STEP 2. | Check the engine for proper application. |
 | STEP 2A. Determine vehicle application. | ECM calibration correct for this application?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

The appropriate ECM - No Communication troubleshooting symptom tree in Section TT

Go to 1B

Go to 3A

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4282 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine for proper application.

Guided Step 2A - Determine vehicle application.

Conditions

  • Determine if the ECM has the proper calibration for this application.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Determine if the engine application has Start/Stop functionality and the proper ECM calibration to support it.

–

ECM calibration correct for this application?
YES NO

An original equipment manufacturer (OEM) issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

The engine application is not compatible with the ECM software.

Download the ECM calibration with the correct application. Refer to Procedure 019-032 in Section 19.

Go to 3A

3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jul-2014


FAULT CODE 125 - Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Charge-Air Cooler | Refer to Procedure 010-027 | ISF3.8 CM2220 AN | 4021704
Charge-Air Cooler | Refer to Procedure 010-027 | ISB4.5, ISB6.7 ISD4.5, ISD6.7 CM2150 SN | 4022188
Charge-Air Cooler | Refer to Procedure 010-027 | ISL8.9 CM2150 SN | 4022190
Charge-Air Cooler | Refer to Procedure 010-027 | ISM11 CM876 SN | 4022196
Charge-Air Cooler | Refer to Procedure 010-027 | ISZ13 CM2150 | 4022133
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISF3.8 CM2220 AN | 4021704
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB4.5, ISB6.7 ISD4.5, ISD6.7 CM2150 SN | 4022188
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISL8.9 CM2150 SN | 4022190
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISM11 CM876 SN | 4022196
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISZ13 CM2150 | 4022133
Exhaust Restriction | Refer to Procedure 011-009 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Exhaust Restriction | Refer to Procedure 011-009 | ISF3.8 CM2220 AN | 4021704
Exhaust Restriction | Refer to Procedure 011-009 | ISB4.5, ISB6.7 ISD4.5, ISD6.7 CM2150 SN | 4022188
Exhaust Restriction | Refer to Procedure 011-009 | ISL8.9 CM2150 SN | 4022190
Exhaust Restriction | Refer to Procedure 011-009 | ISM11 CM876 SN | 4022196
Exhaust Restriction | Refer to Procedure 011-009 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 AN | 4021704
Intake Manifold Pressure/Temperture Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7 ISD4.5, ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 SM2150 SN | 4022190
Intake Maifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of Fault Code 122, 123, 221, 222, 295, or 545?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charge-air system?
 | STEP 2B. Check for a restricted charge-air cooler. | Charge-air cooler restriction within specifications?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 127 mm-Hg [5 in-Hg] of mechanical gauge reading?
STEP 4. | Check the turbocharger wastegate. |
 | STEP 4A. Check the wastegate actuator operation. | Turbocharger wastegate operating properly?
STEP 5. | Check exhaust system restriction. |
 | STEP 5A. Check exhaust system restriction. | Exhaust restriction within specifications?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 122, 123, 221, 222, 295, or 545?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate engine.

Action

Check the charge-air cooler and charge air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and the intake manifold.
  • Check the air compressor inlet plumbing connections between the charge-air cooler and air compressor head for leaks.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect the charge-air cooler clamps to make sure they are tight.
  • Inspect the charge-air plumbing for cracks.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the pressure differential across the charge air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler as necessary.

Go to 3A

Go to 6A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm-Hg [5 in-Hg] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the turbocharger wastegate.

Guided Step 4A - Check the turbocharger wastegate operation.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Turbocharger wastegate operating properly?
YES NO
No Repair

Replace the turbocharger wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the exhaust system restriction.

Guided Step 5A - Check the exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check the exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO

Reference the troubleshooting symptom tree, Intake Manifold Pressure (Boost) is Below Normal, in Section TS, in the appropriate service manual.

Continue to investigate the cause of the high exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Aug-2015


FAULT CODE 135sensor - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 | 4310846
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISF2.8 CM2220 | 4310846

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 active?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Use the wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2015


FAULT CODE 135switch - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 | 4310846
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISF2.8 CM2220 | 4310846

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Sensor supply fault codes active?
STEP 2. | Check the oil pressure switch and circuit. |
 | STEP 2A. Inspect the engine harness and oil pressure switch connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for pin-to-pin short. | Greater than 100k ohms?
 | STEP 3D. Check the supply voltage at the oil pressure connector. | 11.75 to 12.25 VDC?
 | STEP 3E. Check the supply voltage at the ECM. | 11.75 to 12.25 VDC?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 2 - Check the oil pressure switch and circuit.

Guided Step 2A - Inspect the oil pressure switch and the oil pressure switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure switch from the engine harness.

Action

Inspect the engine harness and oil pressure switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the oil pressure switch or the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the oil pressure switch.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure switch.

Action

Check for an open circuit.

  • Measure the resistance of the SIGNAL wire from the oil pressure switch connector to the ECM connector.

Less than 10 ohms?
YES NO
No Repair

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.
  • Disconnect the engine harness from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SIGNAL wire of the oil pressure switch connector to all other wires in the engines harness.

Greater then 100k ohms?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check the supply voltage at the oil pressure connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil pressure SIGNAL pin at the switch connector of the engine harness and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

11.75 to 12.25 VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the supply voltage at the ECM.

  • Measure the voltage between the engine oil pressure SIGNAL pin 9 at the engine harness ECM connector port and engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

11.75 to 12.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 135 is inactive.
  • Turn keyswitch to the OFF position.

Fault Code 135 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes. Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2015


FAULT CODE 141sensor - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 | 4310846
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISF2.8 CM2220 | 4310846

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 active?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2015


FAULT CODE 141switch - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 | 4310846
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISF2.8 CM2220 | 4310846

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Sensor supply fault codes active?
STEP 2. | Check the oil pressure switch and circuit. |
 | STEP 2A. Inspect the engine harness and oil pressure switch connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for pin-to-ground short. | Greater than 100k ohms?
 | STEP 3D. Check the supply voltage at the oil pressure connector. | 11.75 to 12.25 VDC?
 | STEP 3E. Check the supply voltage at the ECM. | 11.75 to 12.25 VDC?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 2 - Check the oil pressure switch and circuit.

Guided Step 2A - Inspect the oil pressure switch and the oil pressure switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure switch from the engine harness.

Action

Inspect the engine harness and oil pressure switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the oil pressure switch or the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the oil pressure switch.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure switch.

Action

Check for an open circuit.

  • Measure the resistance of the SIGNAL wire from the oil pressure switch connector to the ECM connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for pin-to-ground short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.
  • Disconnect the engine harness from the ECM.

Action

Check for oil pressure switch SIGNAL to ground short.

  • Measure the resistance of the oil pressure switch to engine block ground.

Greater then 100k ohms?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-ground short circuit has been detected on the oil pressure switch SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check the supply voltage at the oil pressure connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil pressure SIGNAL pin at the switch connector of the engine harness and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

11.75 to 12.25 VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the supply voltage at the ECM.

  • Measure the voltage between the engine oil pressure SIGNAL pin 9 at the engine harness ECM connector port and engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

11.75 to 12.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 141 is inactive.
  • Turn keyswitch to the OFF position.

Fault Code 141 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes. Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2015


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 187 active?
 | STEP 2C. Inspect the intake manifold pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2B - Inspect the camshaft position sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the intake manifold pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 191 - Air Conditioner Clutch Supply Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the air conditioner clutch. |
 | STEP 1A. Inspect and test the air conditioner clutch and air conditioner clutch relay, if equipped. | Air conditioner clutch within specifications?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness, air conditioner clutch relay, and the ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the engine harness and OEM harness connectors. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 191 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the air conditioner clutch.

Guided Step 1A - Check the air conditioner clutch and air conditioner clutch relay, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air conditioner clutch or air conditioner clutch relay.

Action

Check the air conditioner clutch for:

  • Damaged pins
  • Open or short circuits
  • Excessive current draw (power air conditioner clutch directly from battery)
  • Perform this test in accordance with the OEM instructions.

Air conditioner clutch within specifications?
YES NO
No Repair

Repair or replace the air conditioner clutch. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Inspect the engine harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 of the engine harness connector to pin J of the 23-pin OEM harness connector.

Less than 10 ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 21 in the engine harness to engine block ground.

More than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit between pins.

  • Measure the resistance from pin 21 to all other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air conditioner clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Inspect the OEM harness and 23-pin connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or air conditioner clutch relay, whichever has damaged pins.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the air conditioner clutch relay. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air conditioner clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from pin J of the 23-pin connector on the OEM side to the air conditioner clutch solenoid or relay.

Less than 10 ohms?
YES NO
No Repair

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air conditioner clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure resistance from pin J of the 23-pin OEM harness connector to ground.

More than 100k ohms?
YES NO
No Repair

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air conditioner clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit from pin-to-pin in the OEM harness.

  • Measure resistance from pin J of the 23-pin OEM harness connector to all other pins in the 23-pin connector.

More than 100k ohms?
YES NO
No Repair

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 191 is inactive.

Fault Code 191 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Apr-2012


FAULT CODE 195 (2-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISM11 CM876 SN | 4022196
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISZ13 CM2150 | 4022133
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 800k ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant level SIGNAL pin and the engine coolant level RETURN pin at the engine coolant level sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?
YES NO

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the engine coolant level sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Apr-2012


FAULT CODE 195 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISM11 CM876 SN | 4022196
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 1695

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 Iin Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Aug-2015


FAULT CODE 196 (2-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISM11 CM876 SN | 4022196
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISZ13 CM2150 | 4022133
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 is active?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged engine coolant level sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the engine coolant level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Mar-2012


FAULT CODE 196 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISM11 CM876 SN | 4022196
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISZ13 CM2150 | 4022133
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 1696

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for inactive or intermittent fault codes.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Mar-2012


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 in Section 8. | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Cooling System | Refer to Procedure 008-018 in Section 8. | ISL8.9 CM2150 SN | 4022190
Cooling System | Refer to Procedure 008-018 in Section 8. | ISM11 CM876 SN | 4022196
Cooling System | Refer to Procedure 008-018 in Section 8. | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

See the Coolant Loss troubleshooting symptom tree.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likley cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Mar-2012


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 AN | 4021704
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL8.9 CM2150 SN | 4022190
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISM11 CM876 SN | 4022196
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 221 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

See Fault Code 386.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 31-May-2016


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 AN | 4021704
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL8.9 CM2150 SN | 4022190
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISM11 CM876 SN | 4022196
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISZ13 CM2150 | 4022133
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric air pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refet to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric air pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the barometric air pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the barometric air pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric air pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric air pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the barometric air pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check ECM calibration and clear fault codes.. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 2 line.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Apr-2012


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Shutoff Valve | Refer to Procedure 005-043 | ISM CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 254 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for extra wires connected to the fuel shutoff valve. | More than one wire connected to valve?
 | STEP 2C. Check for a pin-to-ground short circuit in the fuel shutoff valve. | Is resistance 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
 | STEP 2D. Check the fuel shutoff valve diagnostic supply voltage and supply line. | Greater than 5.0-VDC?
 | STEP 2E. Check the fuel shutoff valve solenoid resistance. | Is the resistance 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0-VDC?
 | STEP 3C. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for extra wires connected to the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Extra wires connected to the fuel shutoff valve powering devices on the vehicle can cause this fault to be active.

  • Inspect the fuel shutoff valve terminal for more than one wire.

More than one wire connected to valve?
YES NO

Remove extra wires.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for a pin-to-ground short circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance between the fuel shutoff valve terminal stud and engine block ground.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Is the resistance:

  • 1 to 5 ohms for 6-VDC solenoids
  • 6 to 15 ohms for 12-VDC solenoids
  • 24 to 50 ohms for 24-VDC solenoids
  • 42 to 80 ohms for 32-VDC solenoids
  • 46 to 87 ohms for 36-VDC solenoids
  • 92 to 145 ohms for 48-VDC solenoids
  • 315 to 375 ohms for 74-VDC solenoids
  • 645 to 735 ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve.

Refer to Procedure 005-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fuel shutoff valve diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the actuator harness.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve and supply line.

  • Measure the voltage between the fuel shutoff valve SIGNAL wire and engine block ground.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2E

Guided Step 2E - Check the fuel shutoff valve solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff valve solenoid.

Action

Check the fuel shutoff valve solenoid resistance.

  • Measure the resistance from the fuel shutoff valve solenoid to engine block ground.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Is the resistance:

  • 1 to 5 ohms for 6-VDC solenoids
  • 6 to 15 ohms for 12-VDC solenoids
  • 24 to 50 ohms for 24-VDC solenoids
  • 42 to 80 ohms for 32-VDC solenoids
  • 46 to 87 ohms for 36-VDC solenoids
  • 92 to 145 ohms for 48-VDC solenoids
  • 315 to 375 ohms for 74-VDC solenoids
  • 645 to 735 ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve.

Refer to Procedure 005-043 in Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the ECM fuel shutoff valve voltage.

  • Use a multimeter to measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit-to-ground.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin and ground.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Apr-2012


FAULT CODE 255 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Shutoff Valve | Refer to Procedure 005-043 | ISM CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 254 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | More than one wire connected to valve?Is resistance 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
 | STEP 2C. Check the fuel shutoff valve diagnostic supply voltage and supply line. | Greater than 5.0-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0-VDC?
 | STEP 3C. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance between the fuel shutoff valve ring terminal stud and engine block ground.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Is the resistance:

  • 1 to 5 ohms for 6-VDC solenoids
  • 6 to 15 ohms for 12-VDC solenoids
  • 24 to 50 ohms for 24-VDC solenoids
  • 42 to 80 ohms for 32-VDC solenoids
  • 46 to 87 ohms for 36-VDC solenoids
  • 92 to 145 ohms for 48-VDC solenoids
  • 315 to 375 ohms for 74-VDC solenoids
  • 645 to 735 ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve.

Refer to Procedure 005-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2C - Check the fuel shutoff valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the actuator harness.
  • Turn keyswitch ON.

Action

Measure the fuel shutoff valve diagnostic supply voltage.

  • Measure the voltage from the actuator harness fuel shutoff valve SIGNAL ring terminal to engine block ground.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the ECM fuel shutoff valve voltage.

  • Measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for circuit continuity.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness fuel shutoff valve connector and the fuel shutoff valve SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Apr-2012


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 AN | 4021704
Rocker Lever Cover | Refer to Procedure 003-011 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2150 SN | 4022190
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Rocker Lever Cover | Refer to Procedure 003-011 | ISZ13 CM2150 | 4022133
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 AN | 4021704
Injector | Refer to Procedure 006-026 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 SN | 4022190
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISF3.8 CM2220 AN | 4021704
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISL8.9 CM2150 SN | 4022190
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for shorts. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
STEP 3. | Check the injector and injector circuit for an open circuit. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector circuit for an open circuit | Less than 2 ohms?
 | STEP 3B-1. Check the injector solenoid for an open circuit. |
 | STEP 3C. Check the injector solenoid for a short circuit. | Did the fault code follow the injector?
 | STEP 3D. Check for active fault codes. | Fault codes still active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault Codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness for shorts.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to procedure 019-043 in the Associated Procedures Table.

Repair the injector harness, connectors, or pins, if possible. Refer to Procedure in 019-063 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to block ground.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the injector solenoid to block ground.
  • Measure the resistance from the cylinder number 1 RETURN pin at the injector solenoid to block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short to ground has been detected in the injector circuit.

Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 4A

Go to 4A

Guided Step 2C - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover.
  • Disconnect the engine harness from the injectors being tested..

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the cylinder number 1 DRIVER pin and all other pins in the connector.
  • Measure the resistance between the cylinder number 1 RETURN pin and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Note: Repeat for all injectors on the same bank.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the injector and injector circuit for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit..

  • Measure the resistance between the cylinder number 1 DRIVER pin and cylinder number 1 RETURN pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank.
  • Refer to procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Replace the injector.

Refer to procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for active fault codes..

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for a short circuit.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Assoociated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 E and ISF2.8 CM2220 AN | 4022178
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 AN | 4021704
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 SN | 4022190
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E and ISF2.8 CM2220 AN | 4022178
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E and ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISF3.8 CM2220 AN | 4021704
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISL8.9 CM2150 SN | 4022190
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short. | Dirty or damaged pins?
STEP 3. | Check the injector and injector circuit for an open circuit. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuit for an open circuit. | Less than 2 ohms?
 | STEP 3B-1. Check the injector solenoid for an open circuit. |
 | STEP 3C. Check the injector solenoid for a short circuit. | Did the fault code follow the injector?
 | STEP 3D. Check for active fault codes. | Fault Codes still active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault Codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness for shorts.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness, connectors, or pins, if possible. Refer to Procedure in 019-063 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to block ground.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the injector solenoid to block ground.
  • Measure the resistance from the cylinder number 1 RETURN pin at the injector solenoid to block ground.

Refer to the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short to ground has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground. Repair or replace the damaged component.

Replace the injector.

Go to 4A

Go to 4A

Guided Step 2C - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the cylinder number 1 DRIVER pin and all other pins in the connector.
  • Measure the resistance between the cylinder number 1 RETURN pin and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin to pin short circuit. Repair or replace the failed component.

Go to 3A

Go to 4A

Guided Step 3 - Check the injector and injector circuit for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins. Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector circuis foran open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and cylinder number 1 RETURN pin

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit. Repair or replace the damaged component.

Replace the injector.

Go to 4A

Go to 4A

Guided Step 3C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocvker lever cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 AN | 4021704
Rocker Lever Cover | Refer to Procedure 003-011 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2150 SN | 4022190
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Rocker Lever Cover | Refer to Procedure 003-011 | ISZ13 CM2150 | 4022133
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 AN | 4021704
Injector | Refer to Procedure 006-026 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 SN | 4022190
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022190
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISF3.8 CM2220 AN | 4021704
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISL8.9 CM2150 SN | 4022190
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for shorts. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
STEP 3. | Check the injector and injector circuit for an open circuit. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector circuits for an open circuit. | Less than 2 ohms?
 | STEP 3B-1. Check the injector solenoid for an open circuit. |
 | STEP 3C. Check the injector solenoid for a short circuit. | Did the fault code follow the injector?
 | STEP 3D. Check for active fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault Codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness for shorts.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness, connectors, or pins, if possible. Refer to Procedure in 019-063 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to block ground.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the injector solenoid to block ground.
  • Measure the resistance from the cylinder number 1 RETURN pin at the injector solenoid to block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short to ground has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector.

Go to 4A

Go to 4A

Guided Step 2C - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit from pin to pin..

  • Measure the resistance between the cylinder number 1 DRIVER pin and all other pins in the connector.
  • Measure the resistance between the cylinder number 1 RETURN pin and all other pins in the connector.

Refer to the circuit diagram or wiring diagram.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin to pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the injector and injector circuit for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and cylinder number 1 RETURN pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Replace the injector

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 E and ISF2.8 CM2220 AN | 4022178
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 AN | 4021704
Rocker Lever Cover | Refer to Procedure 003-011 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2150 SN | 4022190
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM875 SN | 4022196
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 E and ISF2.8 CM2220 AN | 4022178
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 AN | 4021704
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 E and ISF2.8 CM2220 AN | 4022178
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 AN | 4021704
Injector | Refer to Procedure 006-026 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Injector | Refer to Procedure 006-026 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 SN | 4022190
Injector | Refer to Procedure 006-026 | ISM11 CM875 SN | 4022196
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E and ISF2.8 CM2220 AN | 4022178
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM875 SN | 4022196
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E and ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM875 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISF3.8 CM2220 AN | 4021704
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISL8.9 CM2150 SN | 4022190
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM875 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for shorts. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
STEP 3. | Check the injector and injector circuit for an open circuit. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector circuit for an open short. | Less than 2 ohms?
 | STEP 3B-1. Inspect the injector solenoid for an open circuit. |
 | STEP 3C. Check the injector solenoid for a short circuit. | Did the fault code follow the injector?
 | STEP 3D. Check for active fault codes. | Fault codes still active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault cdes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness for shorts.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins. Repair the damaged harness, connectors, or pins, if possible.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness, connectors, or pins, if possible. Refer to Procedure in 019-063 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to block ground.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the injector solenoid to block ground.
  • Measure the resistance from the cylinder number 1 RETURN pin at the injector solenoid to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short to ground has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 2C - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover.
  • Disconnect the injector harness from the injector being tested.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the cylinder number 1 DRIVER pin and all other pins in the connector.
  • Measure the resistance between the cylinder number 1 RETURN pin and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the injector and injector circuit for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector pass-through connectors corresponding to the cylinders that are on the rear bank.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4

Go to 3B

Guided Step 3B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit

  • Measure the resistance between the cylinder number 1 DRIVER pin and cylinder number 1 RETURN pin

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for active fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4A - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Mar-2017


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 AN | 4021704
Rocker Lever Cover | Refer to Procedure 003-011 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2150 SN | 4022190
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Rocker Lever Cover | Refer to Procedure 003-011 | ISZ13 CM2150 | 4022133
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 AN | 4021704
Injector | Refer to Procedure 006-026 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 SN | 4022190
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISF3.8 CM2220 AN | 4021704
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISL8.9 CM2150 SN | 4022190
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM11 CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for shorts. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damagged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
STEP 3. | Check the injector and injector circuit for an open circuit. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector circuit for an open circuit. | Less than 2 ohms?
 | STEP 3B-1. Check the injector solenoid for an open circuit. |
 | STEP 3C. Check the injector solenoid for a short circuit. | Did the fault code follow the injector
 | STEP 3D. Check for active faut codes. | Fault codes still active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault Codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness for shorts.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the injector harness, connectors, or pins, if possible. Refer to Procedure in 019-063 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short to ground.

  • Measure the resistance from the cylinder number 2 DRIVER pin at the ECM connector of the engine harness to block ground.
  • Measure the resistance from the cylinder number 2 RETURN pin at the ECM connector of the engine harness to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 2 DRIVER pin at the injector solenoid to block ground.
  • Measure the resistance from the cylinder number 2 RETURN pin at the injector solenoid to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the smae bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short to ground has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 2C - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Remove the valve cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the cylinder number 2 DRIVER pin and all other pins in the connector.
  • Measure the resistance between the cylinder number 2 RETURN pin and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Note: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the injector and injector circuit for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and cylinder number 2 RETURN pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Inspect the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the engine harness from the injector solenoid.

Action

Check for a short circuit.

Remove the injector and swap it with an injector in another bank.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Turn the keyswitch ON.

Start and idle the engine.

Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code following the injector?
YES NO

Replace the injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Aug-2012


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 AN | 4021704
Rocker Lever Cover | Refer to Procedure 003-011 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2150 SN | 4022190
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Rocker Lever Cover | Refer to Procedure 003-011 | ISZ13 CM2150 | 4022133
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 AN | 4021704
Injector | Refer to Procedure 006-026 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 SN | 4022190
Injector | Refer to Procedure 006-026 | ISM11 CM876 SN | 4022196
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Internal Actuator Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Internal Actuator Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Internal Actuator Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Internal Actuator Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Internal Actuator Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for shorts. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
STEP 3. | Check the injector and injector circuit for an open circuit. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector circuit for an open circuit. | Less than 2 ohms?
 | STEP 3B-1. Check the injector solenoid for an open circuit. |
 | STEP 3C. Check the injector solenoid for a short circuit. | Did the fault code follow the injector?
 | STEP 3D. Check for active fault code.s | Fault codes still active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault Codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness for shorts.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness, connectors, or pins, if possible. Refer to Procedure 019-063 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 4 DRIVER pin at the ECM connector of the engine harness to block ground.
  • Measure the resistance from the cylinder number 4 RETURN pin at the ECM connector of the engine harness to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 4 DRIVER pin at the injector solenoid to block ground.
  • Measure the resistance from the cylinder number 4 RETURN pin at the injector solenoid to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short to ground has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 2C - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover (if applicable).
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit from pin to pin..

  • Measure the resistance between the cylinder number 4 DRIVER pin and all other pins in the connector.
  • Measure the resistance between the cylinder number 4 RETURN pin and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Repeat for all injectors on the same bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin to pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the injector circuit for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and cylinder number 4 RETURN pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank.
  • Refer to procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Replace the injector.

  • Refer to procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 AN | 4021704
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL8.9 CM2150 SN | 4022190
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISM11 CM876 SN | 4022196
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISZ13 CM2150 | 4022133
EGR Valve | Refer to Procedure 019-022 | ISF2.8 CM2220 E ISF2.8 CM2220 ECF2 | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 AN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Intake Manifold Pressure Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 AN | 4021704
Intake Manifold Pressure Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 AN | 4021704
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 SN | 4022190
Camshaft Position Sensor | Refer to Procedure 019-363 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the fuel rail pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the intake manifold pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2E. Inspect the exhaust gas recirculation (EGR) valve actuator and circuit, if equipped with EGR. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-443 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel rail pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and the fuel rail pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the intake manifold pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake manifold pressure sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 2E - Inspect the EGR valve actuator and circuit connected to the sensor number 1 supply and return, if equipped with EGR.

Conditions

  • Check that the engine is equipped with EGR.
  • Turn keyswitch OFF.
  • Disconnect the EGR valve actuator from the engine harness.

Action

Inspect the engine harness and EGR valve actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR Valve actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR valve.

Refer to Procedure 019-022 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Secdtion 19.

Go to 2A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Replace the ECM. Refer to 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 1 wire.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 426 - J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220, ISF2.8 CM2220 EC, ISF2.8 CM2220 ECF2, ISF2.8 CM2220 AN, ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220, ISF3.8 CM2220 AN, and ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 SN | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - engine control module (ECM) Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Society of Automotive Engineers (SAE) J1939 data link communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | INSITE™ electronic service tool communicates with engine control module (ECM)?
 | STEP 1B. Inspect the ECM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ data link adapter to the ECM SAE J1939 data link connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ (J1939) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

See equipment manufacturer service information for information on troubleshooting the SAE J1939 data link network.

 No Repair

See equipment manufacturer service information.

Go to 1B

Guided Step 1B - Inspect the ECM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness from the ECM connector.

Action

Inspect ECM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

  • Repair or replace the ECM harness connector pins. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the damaged section of the ECM harness. See equipment manufacturer service information.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness from the ECM connector.
  • Connect the ECM bench calibration harness to the ECM connector.
  • Connect the INLINE™ data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Connect to the ECM using ECM bench top calibration harness and ECM bench calibration adapter cable.

INSITE™ electronic service tool communicates with ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates the ECM data link circuit is functioning properly.

See equipment manufacturer service information for information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

See equipment manufacturer service information.

See the ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code..

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 12-Jun-2017


FAULT CODE 435 (Sensor) - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 135 and Fault Code 141 | Fault Code 135 and Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active?
 | STEP 2C. Check the circuit response. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 141 active?
 | STEP 3C. Check the circuit response. | Fault Code 135 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 135 and Fault Code 141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 and Fault Code 141 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 volt SUPPLY pin and the engine oil pressure SIGNAL pin at the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

An in-range failure of the oil pressure sensor has been detected.

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 volt SUPPLY pin and the engine oil pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jun-2012


FAULT CODE 435 (Switch) - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
ECM Calibrtion Code | Refer to Procedure 019-032 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
ECM Calibrtion Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibrtion Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISF3.8 CM2220 AN | 4021704
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 435 active?
STEP 2. | Check the engine oil pressure switch and circuit. |
 | STEP 2A. Inspect the switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the engine oil pressure switch. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 435 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 435 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil pressure switch and circuit.

Guided Step 2A - Inspect the switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Inspect the switch and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the engine oil pressure switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check the resistance of the switch.

  • Measure the resistance between the engine oil pressure SIGNAL pin of the engine oil pressure switch and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine oil pressure switch.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil pressure SIGNAL pin at the switch connector of the engine harness and the engine oil pressure SIGNAL pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance and check for a short circuit between the engine oil pressure SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 435 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Apr-2012


FAULT CODE 436 - Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 AN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 AN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 436 active?
 | STEP 1B. Check for Fault Codes 153 and 154. | Fault Code 153 or 154 active?
STEP 2. | Check the engine intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 153 active?
 | STEP 3C. Check the circuit response. | Fault Code 154 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Intake manifold temperature and ambient air temperature reading within 5.6°C or 10°F of each other?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 436 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 153 and 154.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 or 154 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the original equipment manufacturer (OEM) wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 will also be active when the intake manifold temperature sensor is disconnected.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine intake manifold temperature RETURN pin and the engine intake manifold temperature SIGNAL pin at the engine intake manifold temperature sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

An in-range malfunction of the intake manifold temperature sensor has been detected.

Replace the engine intake manifold temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold temperature RETURN pin and intake manifold temperature SIGNAL pin at the ECM engine connector.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger.

  • Compare INSITE™ electronic service tool reading for intake manifold temperature to ambient air temperature.

Intake manifold temperature and ambient air temperature reading within 5.6°C or 10°F of each other?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Dec-2016


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL8.9 CM2150 SN | 4022190
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISZ13 CM2150 | 4022133
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISL8.9 CM2150 SN | 4022190
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 449 active?
STEP 2. | Check the high-pressure fuel rail drain line restriction. |
 | STEP 2A. Check the drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012 in Section 6?
STEP 3. | Inspect the fuel pressure relief valve. |
 | STEP 3A. Inspect the fuel pressure relief valve for tampering or wrong part number. | Was the correct fuel pressure relief valve part number installed and no tampering found?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault code inactive?
 | STEP 4B. Check the active fault codes. | Fault code active or high inactive counts?
 | STEP 5. Check if an ECM calibration update is available. |
 | STEP 5A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable and clear the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the high-pressure fuel rail drain line restriction.

Guided Step 2A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Inspect the drain line from the high pressure relief valve to the OEM connection point for damage (obstructions, kinks, or crimps).

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012 in Section 6?
YES NO
No Repair

Replace the drain line or repair the source of the high fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the fuel pressure relief valve.

Guided Step 3A - Inspect the fuel pressure relief valve for tampering or wrong part number.

Conditions

  • Engine is not running.

Action

Make sure the correct fuel pressure relief valve part number is installed.

  • Look for tampering of the fuel pressure relief valve.

Was the correct fuel pressure relief valve part number installed and no tampering found?
YES NO

Replace the fuel pump actuator.

Refer to Procedure 019-117 in Section 19.

If replacing the fuel pump actuator doesn't resolve the issue, take the following action:

For ISB, ISF, or ISD engines, replace the fuel pump. Refer to Procedure 005-016 in Section 5.

For ISL engines, replace the fuel pump head. Refer to Procedure 005-227 in Section 5.

Repair the tampering or replace the fuel pressure relief valve.

  • Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault Code 449 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1117, or 2311 active or high inactive counts?
YES NO
No Repair

Appropriate fault code troubleshooting tree.

Go to 5A

Guided Step 5 - Check if an ECM calibration update is available.

Guided Step 5A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 466 - Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Turbocharger Wastegate Controller | Refer to Procedure 010-109 | ISM11 CM876 SN | 4022196
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 466 active?
STEP 2. | Check the engine harness and ECM connector pins. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Resistance greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Resistance greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Resistance less than 10 ohms?
STEP 3. | Check the wastegate actuator number 1. |
 | STEP 3A. Inspect the wastegate actuator number 1 connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Check the actuator post for corrosion. | Corroded or damaged solenoid?
 | STEP 3C. Check the wastegate actuator resistance. | Resistance is 7 to 8 ohms for 12-VDC (28 to 32 ohms for 24-VDC)?
 | STEP 3D. Check for an active fault code. | Fault Code 466 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 466 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness and ECM connector pins.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Inspect the engine harness and ecm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Check for a short circuit from pin-to-pin

  • Measure the resistance from the wastegate acutator number 1 SIGNAL (+) pin of the engine harness connector to all other pins in the connector.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Check for a short circuit to ground.

  • Measure the resistance from the wastegate actuator number 1 SIGNAL (+) pin of the engine harness connector to ground.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Reistance greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Check for an open circuit.

  • Measure the resistance from wastegate acutator number 1 SIGNAL (+) pin at the engine harness connector to the wastegate actuator number 1 SIGNAL (+) pin at the actuator connector.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the wastegate actuator number 1.

Guided Step 3A - Inspect the wastegate actuator number 1 connector for damaged pins.

Conditions

  • Check the wastegate actuator connector for damaged pins.

Action

Inspect the wastegate actuator connector.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the actuator post for corrosion.

Conditions

  • Turn keyswitch OFF

Action

Inspect the solenoid post.

  • Check the solenoid post for corrosion.

Corroded or damaged solenoid?
YES NO

Clean or replace the wastegate actuator.

Refer to Procedure 010-109 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator number 1 to engine block ground.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Resistance is 7 to 8 ohms for 12-VDC (28 to 32 ohms for 24-VDC)?
YES NO
No Repair

Replace the actuator solenoid.

Refer to Procedure 010-109 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 466 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect the INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect the INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Apr-2012


FAULT CODE 491 - Turborcharger 2 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 491 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to the battery. | Less than 1.5-VDC?
 | STEP 2D. Check for an active fault code. | Fault Code 491 active?
STEP 3. | Check the wastegate actuator. |
 | STEP 3A. Inspect the wastegate actuator connector. | Dirty or damaged pins?
 | STEP 3B. Check the actuator solenoid post for corrosion. | Corrosion found on solenoid post?
 | STEP 3C. Check the wastegate actuator resistance. | Resistance from 7 to 8 ohms for (+) 12-VDC solenoids and 28 to 32 ohms for (+) 24-VDC solenoids?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 491 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 2.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the wastegate actuator number 2 SIGNAL (+) pin at the ECM connector to all other pins in the connector.

Reference the appropriate circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to the battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for a short circuit to the battery.

  • Measure the voltage from the wastegate actuator 2 SIGNAL (+) pin at the wastegate actuator connector and engine block ground.
  • Measure the voltage from the wastegate actuator 2 SIGNAL (+) pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Less than 1.5-VDC?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 491 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check the wastegate actuator.

Guided Step 3A - Inspect the wastegate actuator connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the wastegate actuator 2
  • Disconnect the actuator harness connector from the ECM.

Action

Check the wastegate actuator connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the actuator connector.

  • Flush the dirt, debris, or moisture from the connector. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the connector. Refer to Procedure 019-197 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the actuator solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check the actuator solenoid post for corrosion.

–

Corrosion found on solenoid post?
YES NO

Clean the solenoid post.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator number 2 to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance from 7 to 8 ohms for (+) 12-VDC solenoids and 28 to 32 ohms for (+) 24-VDC solenoids?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace the actuator solenoid.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Apr-2012


FAULT CODE 492 - Turbocharger 2 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Turbocharger Wastegate Controller | Refer to Procedure 010-109 | ISM11 CM876 SN | 4022196
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 465 active?
STEP 2. | Check the engine harness and ECM connector pins. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Resistance greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Reistance greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Resistance less than 10 ohms?
STEP 3. | Check the wastegate actuator number 2. |
 | STEP 3A. Inspect the wastegate actuator number 2 connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Check the actuator post for corrosion. | Corroded or damaged solenoid?
 | STEP 3C. Check the wastegate actuator resistance. | Resistance is 7 to 8 ohms for 12-VDC (28 to 32 ohms for 24-VDC)?
 | STEP 3D. Check for an active fault code. | Fault Code 492 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness and ECM connector pins.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Inspect the engine harness and ecm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the wastegate acutator number 2 SIGNAL (+) pin of the engine harness connector to all other pins in the connector.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for a short circuit to ground.

  • Measure the resistance from the wastegate actuator number 2 SIGNAL (+) pin of the engine harness connector to ground.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for an open circuit.

  • Measure the resistance from wastegate acutator number 2 SIGNAL (+) pin at the engine harness connector to the wastegate actuator number 2 SIGNAL (+) pin at the actuator connector.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the wastegate actuator number 2.

Guided Step 3A - Inspect the wastegate actuator number 2 connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Inspect the wastegate actuator connector for damaged pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the actuator post for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the solenoid post.

  • Check the solenoid post for corrosion.

Corroded or damaged solenoid?
YES NO

Clean or replace the wastegate actuator.

Refer to Procedure 010-109 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator Number 2 to engine block ground.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Resistance is 7 to 8 ohms for 12-VDC (28 to 32 ohms for 24-VDC)?
YES NO
No Repair

Replace the actuator solenoid.

Refer to Procedure 010-109 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 492 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

4B

Go to 4B

If necessary, calibrate the ECM.
Refer to Procedure 019-032 in the Associated Procedures Table.

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 527 - Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC ISF2.8 CM2220 ECF2 ISF2.8 CM2220 AN ISF3.8 CM2220 ISF3.8 CM2220 AN | 4022178

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 527 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) output control solenoid and circuit. |
 | STEP 2A. Inspect the OEM output control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM output control solenoid. | Less than 100 ohms?
 | STEP 2C. Check the OEM output control solenoid diagnostic supply voltage, supply line, and return circuit. | Greater the 3.75-VDC?
 | STEP 2D. Check for an open circuit in the OEM output control solenoid circuit. | Less than 10 ohms?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM output control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 527 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 527 is inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM output control solenoid and circuit.

Guided Step 2A - Inspect the OEM output control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Inspect the OEM output control harness and OEM output control solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the OEM output control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check OEM output control solenoid resistance.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

An open circuit in the OEM output control solenoid has been detected.

Replace the OEM output control solenoid.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the OEM output control solenoid diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the OEM output control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector of the OEM harness.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the OEM output control solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM output control harness.

Action

Check the OEM output control solenoid diagnostic supply voltage and return circuit.

  • Measure the resistance between the OEM output control solenoid RETURN pin in the engine harness and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM circuit diagram or wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the faulty connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM output control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM OEM output control solenoid SIGNAL pin and the OEM harness OEM output control solenoid connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open OEM control output solenoid signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the OEM output control solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 527 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Jan-2014


FAULT CODE 545 - Turbocharger 1 Wastegate Control - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISF3.8 CM2220 AN | 4021704
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISL8.9 CM2150 SN | 4022190
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISM11 CM876 SN | 4022196
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 AN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with INSITE™ electronic service tool. | Intake manifold pressure is less than 203.2 mm Hg [8 in Hg]?
 | STEP 1B. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct within 127 mm Hg [5 in Hg]?
 | STEP 1C. Check the system for tampering. | Tampering detected?
 | STEP 1D. Check the turbocharger wastegate operation. | Turbocharger wastegate operating properly?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify sensor accuracy with INSITE™ electronic service tool.

  • Monitor intake manifold pressure with INSITE™ electronic service tool with the keyswitch ON and the engine not running.

Intake manifold pressure is less than 203.2 mm Hg [8 in Hg]?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 1B

Repair Complete.

Guided Step 1B - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical intake manifold pressure gauge to the engine
  • Use INSITE™ electronic service tool to read the fault codes
  • Start the engine and compare the intake manifold pressure reading on the service tool monitor screen to the reading on the mechanical intake manifold pressure gauge.

Note: The engine may need to be loaded before the pressure readings can be compared.

Sensor reading is within 127 mm Hg [5 in Hg]?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 1C

Go to 2A

Guided Step 1C - Check the system for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger and fuel system for the following:

  • Turbocharger wastegate tampering
  • Variable geometry turbocharger tampering
  • Fuel system tampering
  • Fuel system add-on electronic devices.

Tampering detected?
YES NO

Remove the tampering device.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check the turbocharger wastegate operation.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Turbocharger wastegate operating properly?
YES NO
No Repair

Replace the turbocharger wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 559 (ISB, ISD, ISF) - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Pump | Refer to Procedure 005-016 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Pump | Refer to Procedure 005-016 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Air in Fuel | Refer to Procedure 006-003 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Air in Fuel | Refer to Procedure 006-003 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Air in Fuel | Refer to Procedure 006-003 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Injector | Refer to Procedure 006-026 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Rail | Refer to Procedure 006-060 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Rail | Refer to Procedure 006-060 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Rail | Refer to Procedure 006-060 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 281, 449, 1117, 1911, or 2311 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Perform preliminary fuel system checks. |
 | STEP 2A. Check for an adequate fuel supply. | Equipment/vehicle has an adequate fuel supply?
 | STEP 2B. Inspect for external fuel leaks. | Fuel leaks present?
 | STEP 2C. Verify fuel rail pressure sensor accuracy. | Fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Inspect for external fuel leaks. | Fuel leaks present?
 | STEP 3B. Check for air in the fuel. | Air in the fuel?
 | STEP 3C. Check the fuel pressure at the fuel filter outlet. | Fuel filter outlet pressure within the specifications outlined in Procedure 006-015 in Section 6?
 | STEP 3C-1. Check the fuel filter pressure drop. | Fuel pressure drop within the specifications outlined in Procedure 006-015 in Section 6?
 | STEP 3C-2. Check the fuel inlet restriction. | Fuel inlet restriction within the specifications outlined in Procedure 006-020 in Section 6?
STEP 4. | Check the high-pressure fuel system. |
 | STEP 4A. Check the injector return flow. | Injector return flow is within the specifications outlined in Procedure 006-026 in Section 6?
 | STEP 4A-1. Check the high-pressure connector (HPC) torque. |
 | STEP 4A-2. Check for individual leaking injectors. |
 | STEP 4B. Check the high-pressure fuel pump return flow. | Fuel return flow is within the specifications outlined in Procedure 005-016 in Section 5?
 | STEP 4C. Measure the high-pressure fuel rail return flow. | Fuel return flow is within the specifications outlined in Procedure 006-061 in Section 6?
 | STEP 4D. Inspect the fuel pressure relief valve for tampering or an incorrect part number. | Correct fuel pressure relief valve part number installed and no evidence of tampering found?
 | STEP 4E. High-pressure injection pump flow test. | Fuel pump flow meets the specification outlined in Procedure 005-016 in Section 5?
 | STEP 4E-1. Check for drain line restriction. |
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes or high inactive counts.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 281, 449, 1117, 1911, or 2311 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Perform preliminary fuel system checks.

Guided Step 2A - Check for an adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for an adequate fuel supply.

  • Do not rely on the vehicle fuel gauge.
  • Verify there is fuel in the tank.
  • Check the equipment/vehicle fuel gauge.
  • Inspect the fuel tank if there is any doubt about the accuracy of the fuel gauge.

Equipment/vehicle has an adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 5A

Guided Step 2B - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for external fuel leaks.

  • Check for fuel leaking from loose fuel fittings, damaged fuel lines, and/or damaged components.

Fuel leaks present?
YES NO

Repair the fuel leak.

  • Reference the applicable service manual.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Verify fuel rail pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ Monitor.
  • Fuel pressure relieved from the high-pressure fuel rail.
  • Engine not running.

Action

Make sure the correct sensor part number is installed in the high-pressure fuel rail.

  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed OFF, there could be a significant amount of time waiting on the rail to depressurize to zero. It can be necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail by loosening the pump to rail line at the rail.

  • Refer to Procedure 006-060 in the Associated Procedures Table.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch ON.
  • Engine running.

This test can not be performed if the engine will not start. If the engine will not start, proceed to the next step.

Action

Check for external fuel leaks.

  • Start the engine and allow it to idle.
  • Check for fuel leaking from loose fuel fittings, damaged fuel lines, and/or damaged components.

Fuel leaks present?
YES NO

Repair the fuel leak.

  • Reference the applicable engine service manual.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

This test can not be performed if the engine will not start. If the engine will not start, proceed to the next step.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry can be isolated to one of the following locations:

  • Suction fuel lines
  • Original equipment manufacturer (OEM) fuel lines
  • Suction-side fuel filter assemblies
  • Standpipes in the fuel tank(s)

Check the fuel inlet restriction.

Refer to Procedure 006-020 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the fuel pressure at the fuel filter outlet.

Conditions

  • Turn keyswitch ON.
  • Engine running.

This test can be performed if the engine will not start. If the engine will not start, perform the test while cranking the engine.

Action

Check the fuel pressure at the outlet of the fuel filter.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Fuel filter outlet pressure within the specifications outlined in Procedure 006-015 in Section 6?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the fuel filter pressure drop.

Conditions

  • Turn keyswitch ON.
  • Engine running.
  • This test can be performed if the engine will not start. If the engine will not start, perform the test while cranking the engine.

Action

Check the fuel pressure drop across the filter.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Fuel pressure drop within the specifications outlined in Procedure 006-015 in Section 6?
YES NO
No Repair

Make sure the fuel pump pressure into the fuel filter in within specifications.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

If the pump is OK, replace the fuel filter and prime the fuel system.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 3C-2

Go to 5A

Guided Step 3C-2 - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine at idle.

This test can not be performed if the engine will not start. If the engine will not start, replace the fuel pump and proceed to Step 5A.

Action

Check the fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Fuel inlet restriction within the specifications outlined in Procedure 006-020 in Section 6.
YES NO

Replace the fuel pump.

Refer to Procedure 005-016 in the Associated Procedures Table.

If inlet restriction is excessive, look for the root cause.

  • Suction-side filters plugged
  • Fuel heater valves are restricted
  • OEM fuel lines pinched or restricted
  • Fuel tank pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic, paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction-side fuel filter and prime the fuel system.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the high-pressure fuel system.

Guided Step 4A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Operate engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

This test can be performed if the engine will not start.

If the engine will not start, perform this test while cranking the engine.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Injector return flow is within specifications outlined in Procedure 006-026 in Section 6?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A-1

Guided Step 4A-1 - Check the high-pressure connector (HPC) torque, if applicable.

Conditions

  • Turn keyswitch OFF.

If the engine is not equipped with high-pressure connectors, skip to the next step.

Action

Check the injector and HPC torque.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Injectors and HPC torque meets specifications outlined in Procedure 006-052 in Section 6?
YES NO
No Repair

Torque the injector high-pressure connect. Check the injector return flow again.

Go to 4A-2

Go to 4A

Guided Step 4A-2 - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Operate engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

This test can be performed if the engine will not start.

If the engine will not start, perform this test while cranking the engine.

Action

Check for fuel leaks at individual injectors.

Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Fuel injector return flow is within the specifications outlined in Procedure 006-026 in Section 6 with an injector capped off?

YES NO

Replace the injector of the cylinder that is contributing to the high return flow. For ISB CM800, CM850, CM2150, CM2150 SN, CM2250 and QSB CM850 and CM2250 engines inspect the high-pressure connector for damage and only replace the high-pressure connector if necessary.

  • Refer to Procedure 006-026 in the Associated Procedures Table.
  • Refer to Procedure 006-052 in the Associated Procedures Table.

Cap off additional injectors to identify the source of high injector return flow. For the cylinders that are causing the high injector return flow, replace the injectors. For ISB CM800, CM850, CM2150, CM2150 SN, CM2250 and QSB CM850 and CM2250 engines, inspect the high-pressure connector for damage and only replace the high-pressure connector if necessary.

  • Refer to Procedure 006-026 in the Associated Procedures Table.
  • Refer to Procedure 006-052 in the Associated Procedures Table.

Go to 5A

4A

Guided Step 4B - High-pressure fuel pump return flow.

Conditions

  • Turn keyswitch ON.
  • Operate engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test active, if available.

This test can not be performed if the engine will not start.

If the engine will not start, proceed to the next step.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Fuel return flow is within the specifications outlined in Procedure 005-016 in Section 5?
YES NO
No Repair

  • Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.
  • If the fuel pump actuator is replaced, make sure the correct torque sequence is followed. Refer to Procedure 019-117 in the Associated Procedures Table.
  • After replacing the fuel pump actuator, measure the fuel pump drain flow again. If the flow is not within specification, replace the high-pressure fuel pump.
  • Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Operate engine at idle.
  • INSITE™ electronic service tool Fuel System Leakage Test active, if applicable.

This test can not be performed if the engine will not start.

If the engine will not start, proceed to the next step.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Refer to Procedure 005-061 in the Associated Procedures Table.

Fuel return flow is within the specifications outlined in Procedure 005-061 in Section 5?
YES NO
No Repair

  • Replace the rail fuel pressure relief valve.
  • Determine the reason the fuel rail pressure relief valve has been tripping. Failure to do this could result in repeat failures.

Examples:

  • Operation with the electronic fuel control valve unplugged
  • Operation with a plugged fuel filter or excessive inlet restriction.

Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the fuel pressure relief valve for tampering or an incorrect part number.

Conditions

  • Engine not running.

Action

Make sure the correct fuel pressure relief valve part number is installed.

  • Look for tampering of the fuel pressure relief valve.

Correct fuel pressure relief valve part number installed and no evidence of tampering found?
YES NO
No Repair

Repair the tampering or replace the fuel pressure relief valve.

Go to 4E

Go to 5A

Guided Step 4E - Test the high-pressure injection pump flow test.

Conditions

  • Turn keyswitch ON.
  • Engine cranking.

Action

Check the high-pressure injection pump fuel flow.

Disconnect the high-pressure fuel line to the fuel rail from the high-pressure injection pump.

Refer to Procedure 006-071 in the Associated Procedures Table.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Check the high-pressure injection pump fuel flow.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Fuel pump flow meets the specification outlined in Procedure 005-016 in Section 5?
YES NO
No Repair

Check drain line restriction.

Go to 5A

Go to 4E-1

Guided Step 4E-1 - Check for drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

If the engine will not start, crank the engine to perform this test.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within specifications?
YES NO

If these checks are acceptable, replace the fuel pump actuator. Follow the torque sequence. Refer to Procedure 019-117 in the Associated Procedures Table.

After replacing the fuel pump actuator, measure the fuel pump flow again. If the flow is not within specification, replace the high-pressure fuel pump.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

  • Repair the source of the high fuel drain line restriction.
  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2016


FAULT CODE 559 (ISC, ISL, ISX, ISZ) - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISZ13 CM2150 | 4022133
Fuel Lift Pump | Refer to Procedure 005-045 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Head | Refer to Procedure 005-227 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Head | Refer to Procedure 005-227 | ISZ13 CM2150 | 4022133
Fuel System Diagnostics | Refer to Procedure 005-236 | ISZ13 CM2150 | 4022133
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISL8.9 CM2150 SN | 4022190
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISL8.9 CM2150 SN | 4022190
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISZ13 CM2150 | 4022133
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 SN | 4022190
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISL8.9 CM2150 SN | 4022190
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISZ13 CM2150 | 4022133
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISL8.9 CM2150 SN | 4022190
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISZ13 CM2150 | 4022133
Pressure Fuel Filter | Refer to Procedure 006-065 | ISZ13 CM2150 | 4022133
Fuel Filter Suction | Refer to Procedure 006-066 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 281, 322, 323, 324, 325, 331, 332,352, 449, 1117, 1911, or 2311 active or inactive counts?
 | STEP 1B. Check for active Fault Code 559. | Fault Code 559 active or has inactive counts?
 | STEP 1C. Check the rail pressure decay. | Change in fuel rail pressure greater than 100 bar [1450 psi]?
STEP 2. | Check engine operation. |
 | STEP 2A. Check for adequate fuel supply. | The equipment/vehicle has an adequate fuel supply?
 | STEP 2B. Check to see if the engine will start. | Will engine start?
STEP 3. | Check the low-pressure fuel system. |
 | STEP 3A. Check the fuel lift pump flow. | Fuel lift pump flow greater than the specification outlined in Procedure 005-045?
 | STEP 3B. Measure fuel gear pump pressure. | Fuel gear pump pressure greater than the specifications outlined in Procedure 005-025?
STEP 4. | Check the low-pressure fuel system. |
 | STEP 4A. Check the fuel inlet restriction at the OEM connection and gear pump. | Fuel restriction within the specifications?
 | STEP 4B. Measure the gear pump pressure. | Fuel gear pump pressure greater than the specifications outlined in Procedure 005-025?
 | STEP 4B-1. Measure the pressure drop at the pressure side fuel filter. |
 | STEP 4C. Check for air in the fuel. | Air in the fuel?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Check the injector return flow. | Injector return flow within specifications outlined in Procedure 006-026?
 | STEP 5A-1. Check the high-pressure connector (HPC) torque. |
 | STEP 5A-2. Check for individual leaking injectors. |
 | STEP 5B. Check the high-pressure fuel pump return flow. | Fuel return flow within the specification outlined in Procedure 005-227?
 | STEP 5C. Measure the high-pressure fuel rail return flow. | Fuel return flow within specifications outlined in Procedure 006-061?
 | STEP 5D. Perform the high-pressure injection pump flow test. | Fuel pump flow meets the specification outlined in Procedure 005-227?
STEP 6. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 281, 322, 323, 324, 325, 331, 332,352, 449, 1117, 1911, or 2311 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active Fault Code 559.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 559 is active or has inactive counts?
YES | NO
No Repair | No Repair

Go to 1C

Repair complete

Guided Step 1C - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.
  • INSITE™ electronic service tool monitor.

Note: This test can not be performed if the engine will not start. If the engine will not start, go to Step 2A.

Action

Check the rail pressure decay.

  • Stop the engine
  • Wait until engine has stopped
  • Key back ON quickly (do not start engine)
  • Monitor INSITE™ electronic service tool and record fuel rail pressure for 1 minute.

Is the change in fuel rail pressure greater than 100 bar [1450 psi]?
YES NO

Check the high-pressure fuel system.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check engine operation.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle fuel gauge. Verify there is fuel in the tank.
  • Check the equipment/vehicle fuel gauge.
  • Inspect the fuel tank if there is any doubt about the accuracy of the fuel gauge.

The equipment/vehicle has an adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the vehicle tank or fuel gauge.

Go to 2B

Go to 6A

Guided Step 2B - Check to see if the engine will start.

Conditions

  • Turn keyswitch ON.

Action

Check for external fuel leaks.

  • Attempt to start the engine.

Will the engine start?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the low pressure fuel system.

Guided Step 3A - Check the fuel lift pump flow.

Conditions

  • Turn keyswitch ON.
  • Engine OFF.

Action

Measure the fuel lift pump output pressure.

  • Refer to Procedure 005-045 in the Associated Procedures Table.

Is the fuel lift pump flow greater than the specification outlined in Procedure 005-045?
YES NO
No Repair

  • If the lift pump flow is low, make sure the fuel is primed. For example, following fuelfilter replacement, it is necessary to cycle the fuel lift pump three or four times before air is purged. If air does not purge, check for air in the fuel.
  • Verify fuel prime by making sure the original equipment manufacturer (OEM) fuel filter is full of fuel and air is purged.
  • Make sure the ECM cooling plate check valve is not blocked open or sticking.
  • If the ECM cooling plate check valve is not damaged and the system is primed, replace the lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.
  • If the engine is not equipped with a fuel lift pump, skip this step and proceed to 3B.

Go to 3B

Go to 6A

Guided Step 3B - Measure the fuel gear pump pressure.

Conditions

  • Turn keyswitch ON.

Action

Measure fuel gear pump pressure during cranking.

  • Refer to Procedure 005-025 in the Associated Procedures Table.

Is fuel gear pump pressure greater than the specifications outlined in Procedure 005-025?
YES NO
No Repair

Replace the fuel gear pump module.

  • Refer to Procedure 005-025 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 4 - Check the low pressure fuel system.

Guided Step 4A - Check the fuel inlet restriction at the OEM connection and gear pump.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the fuel inlet restriction.

  • ISL8.9 CM2150 SN engine. Refer to Procedure 006-020 in the Associated Procedures Table.
  • ISZ13 CM2150 engine. Refer to Procedure 005-236 in the Associated Procedures Table.

Is the fuel restriction within the specifications?
YES NO
No Repair

If the inlet restriction is excessive, look for the root cause:

  • Suction side fuel filters plugged
  • Fuel heater valves are restricted
  • ECM cooling plate restriction
  • ECM cooling plate check valve plugged/blocked
  • OEM fuel lines pinched or restricted
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic wrapper, paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves

If no issues are found, replace the suction side fuel filter and prime the fuel system.

  • ISL8.9 CM2150 SN engine. Refer to Procedure 006-015 in the Associated Procedures Table.
  • ISZ13 CM2150 engine. Refer to Procedure 006-066 in the Associated Procedures Table.

Go to 4B

Go to 6A

Guided Step 4B - Measure the gear pump pressure.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Measure the fuel gear pump pressure at rated conditions.

  • Refer to Procedure 005-025 in the Associated Procedures Table.

Is the fuel gear pump pressure greater than the specifications outlined in Procedure 005-025?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4B-1

Guided Step 4B-1 - Measure the pressure drop at the pressure side fuel filter.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Measure the pressure drop across the pressure side fuel filter.

  • ISL8.9 CM2150 SN engine. Refer to Procedure 006-015 in the Associated Procedures Table.
  • ISZ13 CM2150 engine. Refer to Procedure 005-236 in the Associated Procedures Table.

Is the fuel pressure drop within the specifications?
YES NO

Replace the fuel gear pump module.

Refer to Procedure 005-025 in the Associated Procedures Table.

Replace the fuel filter and prime the fuel system.

ISL8.9 CM2150 SN engine. Refer to Procedure 006-015 in the Associated Procedures Table.

  • ISZ13 CM2150 engine. Refer to Procedure 006-065 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4C - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Was there air in the fuel?
YES NO

Bubbles are an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

If fuel inlet restriction is not excessive, the source of air entry can be isolated to one of the following locations:

  • Gear pump shaft seal leaks
  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipes in the fuel tank(s).
  • Refer to Procedure 006-020 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the high-pressure fuel system.

Guided Step 5A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test ACTIVE (if available).

NOTE: This test can be performed if the engine will not start. See below.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

If the engine will not start, perform this test while cranking the engine.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Injector return flow is within specifications outlined in Procedure 006-026?
YES | NO
No Repair | No Repair

Go to 5B

Go to 5A-1

Guided Step 5A-1 - Check the high-pressure connector (HPC) torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector (HPC) torque.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Injector pressure connector torque meets specifications outlined in Procedure 006-052?
YES NO
No Repair

Tighten the injector high-pressure connector.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Check the injector return flow again.

Go to 5A-2

If the injector return flow is still high proceed to Step 5A-2

Guided Step 5A-2 - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test ACTIVE (if available).

NOTE: This test can be performed if the engine will not start. See below.

Action

Check for fuel leaks at individual injectors.

  • Cap off each injector one at-a-time with the injector leakage isolation tool. The service tool must be installed with the engine OFF.
  • Refer to Procedure 006-026 in the Associated Procedures Table.

If the engine will not start, perform this test while cranking the engine.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Fuel injector return flow is within specifications outlined in Procedure 006-026 with an injector capped off?
YES NO

Check the injector return flow again.

  • Cap off additional injectors to identify the source of high-injector return flow. Replace the high-pressure connector and injector for the cylinder(s) causing the high-injector return flow. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5B - Check the high-pressure fuel pump return flow.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test ACTIVE (if available).

NOTE: This test can be performed if the engine will not start. See below.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Refer to Procedure 005-227 in the Associated Procedures Table.

If the engine will not start, perform this test while cranking the engine.

  • Refer to Procedure 005-227 in the Associated Procedures Table.

Fuel return flow is within the specifications outlined in Procedure 005-227?
YES NO
No Repair

Replace the high-pressure fuel pump head.

  • Refer to Procedure 005-227 in the Associated Procedures Table.

Go to 5C

Go to 6A

Guided Step 5C - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test ACTIVE (if available).

NOTE: This test can not be performed if the engine will not start; go to Step 5D.

Action

Check for excessive fuel return from the high-pressure fuel rail.

  • Refer to Procedure 006-061 in the Associated Procedures Table.

Fuel return flow is within specifications outlined in Procedure 006-061?
YES NO
No Repair

  • Replace the rail fuel pressure relief valve.
  • Refer to Procedure 006-061 in the Associated Procedures Table.

Determine the reason the fuel rail pressure relief valve has been tripping.

Examples:

  • Operation with the electronic fuel control valve unplugged
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 5D

Go to 6A

Guided Step 5D - Perform the high-pressure injection pump flow test.

Conditions

  • Turn keyswitch ON.
  • Crank the engine.

Action

Disconnect the high-pressure fuel line to the fuel rail from the high-pressure injection pump.

  • Check the high-pressure injection pump fuel flow.
  • Refer to Procedure 005-227 in the Associated Procedures Table.

Fuel pump flow meets the specification outlined in Procedure 005-227?
YES NO
No Repair

Remove the fuel pump head and inspect for damaged or stuck plungers. While the pump head is removed, inspect the cam housing.

If damage is found, replace the fuel pump head.

  • Refer to Procedure 005-227 in the Associated Procedures Table.

If damage is not found, reference the Shop Talk section for exhaust troubleshooting tree repair instructions.

Reference the Shop Talk section

Go to 6A

Guided Step 6A - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | ISF3.8 CM2220 AN | 4021704
Camshaft | Refer to Procedure 001-008 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Camshaft | Refer to Procedure 001-008 | ISL8.9 CM2150 SN | 4022190
Camshaft | Refer to Procedure 001-008 | ISM11 CM876 SN | 4022196
Camshaft | Refer to Procedure 001-008 | ISZ13 CM2150 | 4022133
Crankshaft | Refer to Procedure 001-016 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Crankshaft | Refer to Procedure 001-016 | ISF3.8 CM2220 AN | 4021704
Crankshaft | Refer to Procedure 001-016 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Crankshaft | Refer to Procedure 001-016 | ISL8.9 CM2150 SN | 4022190
Crankshaft | Refer to Procedure 001-016 | ISM11 CM876 SN | 4022196
Crankshaft | Refer to Procedure 001-016 | ISZ13 CM2150 | 4022133
Gear Cover, Front | Refer to Procedure 001-031 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Gear Cover, Front | Refer to Procedure 001-031 | ISF3.8 CM2220 AN | 4021704
Gear Cover, Front | Refer to Procedure 001-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Gear Cover, Front | Refer to Procedure 001-031 | ISL8.9 CM2150 SN | 4022190
Gear Cover, Front | Refer to Procedure 001-031 | ISM11 CM876 SN | 4022196
Gear Cover, Front | Refer to Procedure 001-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 AN | 4021704
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 SN | 4022190
Camshaft Position Sensor | Refer to Procedure 019-363 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN | 4021560
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and speed/position sensors. |
 | STEP 1A. Inspect the engine speed and position sensors for damage. | Any damage?
 | STEP 1B. Inspect the tone wheels for any damage. | Any damage?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Camshaft and crankshaft gears properly installed?
 | STEP 2B. Inspect the gear train. | Any damage?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the tone wheels and speed/position sensors.

Guided Step 1A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine speed and position sensors for damage.

Any damage?
YES NO

Replace the speed or position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for damage.

Any damage?
YES NO

Replace the tone wheel.

Use the following procedure for crankshaft removal and installation. Refer to Procedure 001-016 in the Associated Procedures Table.

Use the following procedure for camshaft removal and installation. Refer to Procedure 001-008 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check for correct engine static timing.

Guided Step 2A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove the gear cover. Refer to Procedure 001-031 in the Associated Procedures Table.
  • Rotate the engine to TDC for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned. Refer to Procedure 001-008 in the Associated Procedures Table.

Action

Inspect the engine static timing.

Camshaft and crankshaft gears properly installed?
YES NO
No Repair

Install the camshaft and crankshaft gear correctly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the gear cover.

Refer to Procedure 001-031 in the Associated Procedures Table.

Inspect the gear train for damage that would lead to slippage.

Any damage?
YES NO

  • Repair the damaged components.
  • Refer to the appropriate service manual for repair procedure.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 1228 - EGR Valve Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 E | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor circuit fault codes. | Fault Codes 352, 386, 2271, or 2272 active?
STEP 2. | Check the EGR valve position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2271 active?
 | STEP 2C. Check the circuit response. | Fault Code 2272 active?
 | STEP 2D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2271 active?
 | STEP 3C. Check the ECM response. | Fault Code 2272 active?
 | STEP 3D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352, 386, 2271, or 2272 active?
YES NO

Troubleshoot active fault codes 352, 386, 2271, and/or 2272 before fault code 1228.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the EGR valve position sensor RETURN pin and the EGR valve position sensor SIGNAL pin at the EGR valve connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the EGR valve position sensor +5-VDC SUPPLY pin and the EGR valve position sensor RETURN pin at the engine harness connector.

Refer to the Circuit Diagram or Wiring Diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

A stuck or broken EGR valve has been detected.

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Note: Multiple unrelated fault codes will become active when the engine harness is unplugged. These faults can be temporarily ignored.

Fault Code 2271 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR valve position sensor RETURN pin and the EGR valve position sensor SIGNAL pin at the ECM engine connector.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read fault codes.

Note: Multiple unrelated fault codes will become active when the engine harness is unplugged. These faults can be temporarily ignored.

Fault Code 2272 active?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor Supply voltage and Return circuit at the ECM.

  • Measure the voltage between the EGR valve position +5-VDC SUPPLY pin and the EGR valve position RETURN pin at the ECM connector.

Refer to the Circuit Diagram or Wiring Diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

An intermittent short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Mar-2012


FAULT CODE 1668 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 2. | Check the diesel exhaust fluid (DEF) tank level sensor and circuit. |
 | STEP 2A. Inspect the DEF tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1668 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

See the appropriate sensor supply fault code.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-361 in Section 19.

Go to 2A

Guided Step 2 - Check the DEF tank level sensor and circuit.

Guided Step 2A - Inspect the DEF tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF tank level sensor from the OEM harness.

Action

Inspect the OEM harness and DEF tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the DEF tank level 5 volt SUPPLY pin to the DEF tank level RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the DEF tank level 5 volt SUPPLY pin to the DEF tank level SIGNAL pin at the catalyst tank level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition

Conditions

  • Turn keyswitch OFF.
  • Connect the DEF tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES NO

A damaged sensor has been detected.

Replace the DEF tank level sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the DEF tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector DEF tank level sensor SIGNAL pin and the OEM harness DER tank level sensor connector SIGNAL pin.

Use wiring diagram and the following procedure for resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the DEF tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector DEF tank level sensor RETURN pin and the OEM harness DEF tank level sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use wiring diagram and the following procedure for resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the DEF tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the DEF tank level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Use wiring diagram and the following procedure for resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the DEF tank level sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the DEF tank level SIGNAL pin in the OEM harness ECM connector and ground.

Use wiring diagram and the following procedure for resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Mar-2015


FAULT CODE 1668 (Airless) - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
ECM Calibration | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1668 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault code inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1668 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Procedure Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19, in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 1 minute.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the fault codes and verify sensor condition

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank level sensor to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 1668 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Aftertreatment Diesel Exhaust Fluid Controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the aftertreatment diesel exhaust fluid controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the diesel exhaust fluid controller harness and or the connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19, in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller connector from the controller.
  • Turn keyswitch ON.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment diesel exhaust fluid level SIGNAL pin at the aftertreatment diesel exhaust fluid controller connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?

YES NO
No Repair

A short circuit between pins has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the aftertreatment diesel exhaust fluid controller harness connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged aftertreatment diesel exhaust fluid controller has been detected.

Replace the aftertreatment diesel exhaust fluid controller.Refer to Procedure 011-057 in Section 11, in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19, in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Mar-2012


FAULT CODE 1669 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 2. | Check the diesel exhaust fluid (DEF) tank level sensor and circuit. |
 | STEP 2A. Inspect the DEF tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1669 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

See the appropriate sensor supply fault code.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the DEF tank level sensor and circuit.

Guided Step 2A - Inspect the DEF tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF tank level sensor from the engine harness.

Action

Inspect the OEM harness and DEF tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF tank level sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF tank level SIGNAL pin and the aftertreatment DEF tank level RETURN pin at the aftertreatment DEF tank level OEM harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES NO
No Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the DEF tank level +5 volt SUPPLY pin to the DEFt tank level RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the DEF tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 1669 active?
YES NO

A damaged sensor has been detected.

Replace the DEF tank level sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the DEF tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector DEF tank level sensor SIGNAL pin and the OEM harness DEF tank level sensor connector SIGNAL pin.

Use wiring diagram and the following procedure for resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the DEF tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector DEF tank level sensor RETURN pin and the OEM harness DEF tank level sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use wiring diagram and the following procedure for resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the DEF tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the DEF tank level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Use wiring diagram and the following procedure for resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Mar-2015


FAULT CODE 1669 (Airless) - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1669 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 1668 active and fault code 1669 inactive?
STEP 3. | Check the aftertreatment DEF |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the aftertreatment DEF harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhuast fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 1 minute.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank level SIGNAL pin and the aftertreatment diesel exhaust fluid tank level RETURN pin at the aftertreatment diesel exhaust fluid tank level OEM harness connector.
  • Use INSITE™ electronic service tool to read the active fault codes.

Fault code 1668 active and fault code 1669 inactive?
YES NO

Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment diesel exhaust fluid controller harness or controller connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor RETURN pin at the controller connector and the aftertreatment diesel exhaust fluid tank level sensor connector RETURN pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the aftertreatment diesel exhaust fluid harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the controller connector and the aftertreatment diesel exhaust fluid tank level sensor connector SIGNAL pin.

Use a the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level SIGNAL pin in the controller connector and all other pins in the controller connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Mar-2012


FAULT CODE 1671 - Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
ECM Calibration | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1671 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1671 active?
YES NO

Low catalyst solution level has been detected.

Add catalyst solution to the catalyst solution tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Dec-2009


FAULT CODE 1673 - Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
ECM Calibration | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1673 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1673 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2015


FAULT CODE 1677 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 2. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1677 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active and Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

Refer to OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 is active and Fault Code 1677 is inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Aug-2015


FAULT CODE 1677 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead AND Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 2. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1677 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1678 active and Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 is active?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 is active and Fault Code 1677 inactive?
YES NO
No Repair

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the aftertreatment DEF controller harness connector and all other pins in the aftertreatment DEF controller harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Disconnect the aftertreatment DEF tank sensor from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF tank sensor SIGNAL pin in the aftertreatment DEF controller harness connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode ought to have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Mar-2012


FAULT CODE 1678 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CMCM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 2. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1678 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1677 active and Fault Code 1678 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code.Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Measure the sensor resistance.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin and aftertreatment DEF tank temperature sensor RETURN pin at the aftertreatment DEF tank temperature sensor.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the aftertreatment DEF tank temperature sensor.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature sensor SIGNAL pin and the aftertreatment DEF tank temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram for pin identification.

Fault Code 1677 active and Fault Code 1678 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment DEF tank temperature sensor RETURN pin and the engine harness aftertreatment DEF tank temperature sensor connector RETURN pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment DEF tank temperature sensor SIGNAL pin and the engine harness aftertreatment DEF tank temperature sensor connector SIGNAL pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 1678 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Aug-2015


FAULT CODE 1678 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 2. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 200k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1678 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1677 active and Fault Code 1678 inactive?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF controller harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the aftertreatment DEF controller harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.

Action

Inspect the engine harness and catalyst sensor temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.

Action

Measure the sensor resistance.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin and aftertreatment DEF tank temperature sensor RETURN pin at the aftertreatment DEF tank temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 200k ohms?
YES NO
No Repair

Replace the aftertreatment DEF tank temperature sensor.

Refer to the OEM service manual.

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller connector.

Action

Inspect the aftertreatment DEF controller harness and controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature sensor SIGNAL pin and the aftertreatment DEF tank temperature sensor RETURN pin at the controller connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1677 active and Fault Code 1678 inactive?
YES NO
No Repair

Replace the aftertreatment DEF controller.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF controller connector RETURN pin and the aftertreatment DEF tank temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF controller connector SIGNAL pin and the aftertreatment DEF tank temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the controller connector and all other pins in the aftertreatment DEF controller connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Mar-2012


FAULT CODE 1679 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid (DEF) Tank Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677 or 1678 active?
STEP 2. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active?
 | STEP 2C. Check the circuit response. | Fault Code 1677 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active?
 | STEP 3C. Check the circuit response. | Fault Code 1677 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1677 or 1678 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1678 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and the aftertreatment DEF tank temperature RETURN pin at the aftertreatment DEF tank temperature connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 is active?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and aftertreatment DEF tank temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Aug-2015


FAULT CODE 1679 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Tank Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677 or 1678 active?
STEP 2. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active?
 | STEP 2C. Check the circuit response. | Fault Code 1677 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active?
 | STEP 3C. Check the circuit response. | Fault Code 1677 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 or 1678 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1678 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and the aftertreatment DEF tank temperature RETURN pin at the aftertreatment DEF tank temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

Refer to OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Inspect the aftertreatment DEF controller harness and controller pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF controller harness connector or controller.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO
No Repair

Replace the aftertreatment DEF controller.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and aftertreatment DEF tank temperature RETURN pin at the controller connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

High resistance or a short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Replace the aftertreatment DEF controller.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Mar-2012


FAULT CODE 1681 - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1681 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1681 active?
YES NO
No Repair

Replace the dosing control unit. Refer to Procedure 019-440 in the Associated Procedure Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Oct-2012


FAULT CODE 1682 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISM11 CM876 SN | 4022196
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codse. | Fault Code 434, 1665, 1666, 1668, 1669, 1671, 1673, 1674, 1675, 1677, 1678, 1697, 1698, or 1711 active?
STEP 2. | Inspect the aftertreatment nozzle. |
 | STEP 2A. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the DEF dosing unit. |
 | STEP 3A. Check the DEF dosing unit during priming. | Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay if applicable)
 | STEP 3B. Check the air solenoid during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)
 | STEP 3C. Confirm the successful priming of the DEF dosing unit | Air flow above 25 liters per minute [6.6 gallons per minute]?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Clear the DEF dosing unit air side circuit. Carry out the flushing procedure. | Flushing procedure successful?
STEP 5. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 5A. Check the DEF dosing unit lines and fittings. | DEF lines and fittings pass inspection?
 | STEP 5B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at screen filter?
 | STEP 5C. Check the DEF dosing unit lines for restrictions or leaks. | Restriction line test completed successfully?
 | STEP 5D. Inspect the DEF tank and the 35 micron tank filter. | DEF tank contaminated or the urea solution less than 32.5%?
STEP 6. | Verify the purging cycle of the DEF dosing unit. |
 | STEP 6A. Monitor the DEF dosing unit purging cycle. | Are the three actions in this step confirmed and zero incomplete purge counts in the ECM Image?
STEP 7. | Perform the DEF Doser Pump Override Test. |
 | STEP 7A. Perform the DEF Doser Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operate correctly during INSITE™ electronic service tool override test? (recommended to carry out the test 3 times.)
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 434, 1665, 1666, 1668, 1669, 1671, 1673, 1674, 1675, 1677, 1678, 1697, 1698, or 1711 active?
YES | NO
No Repair | No Repair

Reference the appropriate Fault Code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Inspect the aftertreatment nozzle.

Guided Step 2A - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Soft crystal and ash-like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Be sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Clean or replace the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the DEF dosing unit.

Guided Step 3A - Check the DEF dosing unit during priming.

Conditions

  • Isolate the vehicle main power for at least 30 seconds prior to carrying out this check.
  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle
  • Connect INSITE™ electronic service tool.

Action

Check the DEF dosing unit during priming.

  • After key ON with the engine operating, listen for the DEF dosing pump to start.
  • Time the pump operation until the pump automatically switches off (The pump is attempting to prime).

NOTE: While the engine is operating it may be difficult to hear the pump. If this is the case, listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

NOTE: Older calibrations did not incorporate the 140 second delay from key ON to initial prime cycle. During the 140 second delay the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization built up on injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Key ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming, this step may be attempted up to 20 times).

4. The DEF injection line will now exhaust air. Priming is now complete.

NOTE: If the pump detects a problem during priming, the priming attempt will be aborted after 3 seconds

Dosing unit only primes for 3 seconds? (Plus the 140 second prime delay if applicable)

YES NO

Complete line restriction testing procedure then re-prime. Refer to Procedure 011-086 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Be sure that the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is has completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment DEF Dosing Unit State to confirm the doser status.

Does the air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)

YES NO
No Repair

NOTE: The DEF dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Secure the DEF dosing line and the attached air flow meter
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 liters per minute [6.6 gallons per minute?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool
  • Start the engine and operate at low idle.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for water or excessive oil from the vehicle's compressed air system.
  • Make sure a clean supply of air, at least 517 kPa [75 psi], pressure is present at the DEF dosing unit.

NOTE: Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Correct the OEM air supply connection or supply. Refer to the OEM service manual.

Go to 4B

Go to 3A

Guided Step 4B - Clear the DEF dosing unit air side circuit. Carry out the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the DEF dosing unit flushing procedure.

  • Refer to procedure 011-082 in the Associated Procedures Table.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Flushing procedure successful?
YES NO
No Repair

A damaged DEF dosing unit has been detected. Replace the DEF dosing unit.

  • Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check the DEF lines and fittings for restriction and contamination.

Guided Step 5A - Check the DEF dosing unit fittings and lines.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit fittings and lines for the following:

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fitting
  • Cracked DEF lines, resulting in leaks or drawing in air
  • Be sure DEF is returning to the tank during the priming cycle.

DEF fittings and lines pass the inspections?
YES NO
No Repair

Repair or replace DEF lines and / or connectors. Refer to the OEM service manual.

5B

Go to 3B

Guided Step 5B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front fact of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the DEF dosing unit supply line.
  • Inspect the inlet screen filter. Refer to Procedure 011-060 in the Associated Procedures Table.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Contamination present at the screen filter?
YES NO

Replace the screen filter.

 No Repair

Go to 5C

Go to 5C

Guided Step 5C - Check the DEF dosing lines for restrictions or leaks.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Complete the line restriction procedure.

Associated Procedures Table.

Check the DEF lines for leaks or restrictions.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

  • Remove and check the supply and return lines.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Restriction line test completed successfully?
YES NO
No Repair

Repair or replace the DEF lines and/or connectors. Refer to OEM Service Manual.

Go to 5D

Go to 3B

Guided Step 5D - Inspect the DEF tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

Refer to the OEM service manual for removal / installation procedures for the DEF tank and DEF tank level sensor assembly.

NOTE: In some cases the DEF tank is bonded to the vehicle chassis leaving no access to DEF tank level sensor assembly. If this is the case then contact the OEM to arrange for the tank to be removed and inspected.

  • Inspect the contents of the tank.
  • Inspect the condition of the tank filter.
  • Check that a 35 micron tank filter is fitted. Refer to Procedure 011-083 in the Associated Procedures Table.
  • Check and record the urea concentration of the DEF using a sample from the tank. Refer to Procedure 018-026 in Section V.

DEF tank contaminated or the urea solution less than 32.5%?

YES NO

Locate/remove source, inform OEM. If required replace components and connectors. Drain / refill the DEF tank. Refer to OEM service manual.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Verify the purging cycle of the aftertreatment dosing unit.

Guided Step 6A - Monitor the aftertreatment dosing unit purging cycle.

Conditions

  • Start engine and operate at low idle.

Action

Verify completion of the aftertreatment dosing unit purge cycle.

  • Turn the keyswitch OFF to shut down the engine.
  • Verify that the aftertreatment dosing unit remains powered for at least 30 seconds after keyswitch OFF to complete the purge cycle.
  • Confirm that air flow is present for 30 seconds after keyswitch OFF.
  • NOTE: The procedure above will flag incomplete purge counts in the ECM, if incorrect. See the Purging section under Shop Talk.

All the actions in this step confirmed and zero incomplete purge counts in the ECM image?
YES NO
No Repair

  • Verify the correct battery power and keyswitch wiring to the aftertreatment dosing unit.
  • Consult the engine and OEM wiring diagrams.
  • Repair any OEM wiring issue and notify the OEM.
  • If the battery isolator switch increases incomplete purge counts, the OEM must be notified. A timer relay must be in the system to allow a 30 second purge.

Go to 7A

Go to 7A

Guided Step 7 - Perform the DEF Doser Pump Override Test.

Guided Step 7A - Perform the DEF Doser Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in the Associated Procedures Table
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

Note: The aftertreatment nozzle must have been warmed in the exhaust before removing. Remove the aftertreatment nozzle and place it in a measuring container of at least 200 ml [6.8 oz] capacity before performing the DEF Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test 3 times)

YES NO
No Repair

A damaged DEF dosing unit has been detected. Replace the DEF dosing unit.

  • Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 1682 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve | Refer to Procedure 011-060 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve | Refer to Procedure 011-060 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair and make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1682 active or more than two inactive counts?
 | STEP 1B. Check for low aftertreatment DEF tank level. | DEF tank empty and/or Fault Code 1671, 1673, 3497, or 3498 active?
 | STEP 1C. Check for related fault codes. | Fault Codes 3574, 3575, 3569, or 3596 active or more than two inactive counts?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 2B. Check the aftertreatment DEF dosing unit supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 2C. Check for air in the DEF. | Air in the DEF detected?
 | STEP 2D. Inspect the aftertreatment DEF dosing unit supply line fitting. | Dosing unit supply line fitting blocked?
STEP 3. | Check the DEF dosing valve circuit. |
 | STEP 3A. Check for a pin-to-pin short circuit in the aftertreatment DEF dosing valve circuit. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment DEF tank filter. |
 | STEP 4A. Inspect the DEF tank filter for blockage. | DEF tank filter blocked?
STEP 5. | Check aftertreatment DEF dosing unit operation. |
 | STEP 5A. Perform aftertreatment DEF Doser Pump Override test. | Measured volume of DEF from Doser Pump Override test within specifications outlined in Procedure 011-058 in the Associated Procedures Table?
 | STEP 5B. Perform aftertreatment DEF dosing unit airless flush. | Aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1682 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty, and the level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes:
  • Fault Code 1671, 1673, 3497, and 3498.

DEF tank empty and/or Fault Codes 1671, 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 5A

Go to 1C

Guided Step 1C - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574, 3575, 3569, or 3596 active or more than two inactive counts?
YES NO

Troubleshoot occurrences of fault codes 3574, 3575,3569, or 3596 before troubleshooting fault code 1682.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the SCR dosing system:

1. Dosing unit supply line between the tank and the dosing unit (suction line).

2. Dosing valve supply line between the dosing unit and the dosing valve (pressure line)

3. Return line between the dosing unit and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check all three dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line, pressure line, and return line dosing unit connectors and look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which would allow the dosing unit to suck in air with the DEF.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (three connections), and dosing valve (one connection).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking DEF line or fitting as necessary.

Refer to the OEM service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit supply line from the dosing unit (this is the suction line between the dosing unit and DEF tank).
  • Disconnect the aftertreatment DEF dosing unit supply line from the DEF tank.

Action

Check the DEF dosing unit supply line for blockage.

  • Check both ends of the dosing unit supply line for signs of buildup or blockage.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line using shop air. If necessary, replace the dosing unit supply line.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-058 in the Associated Procedures Table.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

Air in the DEF detected?
YES NO

Check the following components for damage or leaks and repair as necessary:

  • Aftertreatment DEF dosing unit fittings
  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Inspect the aftertreatment DEF dosing unit supply line fitting.

Conditions

  • Turn keyswitch OFF.
  • Remove the DEF dosing supply line and fitting.

Action

Inspect the aftertreatment DEF dosing unit supply line fitting for blockage.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Dosing unit supply line fitting blocked?
YES NO

Replace the DEF dosing unit supply line fitting.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the DEF dosing valve circuit.

Guided Step 3A - Check for a pin-to-pin short circuit in the aftertreatment DEF dosing valve circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin an dthe RETURN pin of the aftertreatment DEF controller harness 86-Pin connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check the aftertreatment DEF tank filter.

Guided Step 4A - Inspect the DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the tank level and temperature sensor from the DEF tank.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

Refer to the OEM service manual.

DEF tank filter blocked?
YES NO

Clean or replace the DEF tank filter.

Drain, clean, and refill the DEF tank.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check aftertreatment DEF dosing unit operation.

Guided Step 5A - Perform aftertreatment DEF doser pump override test.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the exhaust pipe.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-058 in the Associated Procedures Table.

NOTE: The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Measured volume of DEF from Doser Pump Override Test within specifications outlined in Procedure 011-058 in Section 11?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter. (Note that this filter can not be reused and must be replaced upon removal.)

Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the Aftertreatment DEF Doser Pump Override Test again with the new filter. If the measured volume of DEF is still not within specifications, replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 5B

Guided Step 5B - Perform the aftertreatment DEF dosing unit airless flush.

Conditions

  • Remove the aftertreatment DEF dosing valve.
  • Remove the aftertreatment DEF dosing unit.
  • Connect INSITE™ electronic service tool.

Action

Flush the aftertreatment DEF dosing unit with clean water.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-058 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Oct-2012


FAULT CODE 1683 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1683 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid relay and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment diesel exhaust fluid relay. | Less than 100 ohms?
 | STEP 2C. Check the aftertreatment diesel exhaust fluid diagnostic voltage, supply line and return circuit. | Greater than 6-VDC?
 | STEP 2D. Check for an open circuit in the aftertreatment diesel exhaust fluid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment diesel exhaust fluid relay diagnostic supply voltage. | Greater than 6 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1683 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid relay and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid relays from the engine harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment diesel exhaust fluid relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid relays from the engine harness.

Action

Check aftertreatment diesel exhaust fluid relay resistance.

  • Measure the resistance between the aftertreatment diesel exhaust fluid SIGNAL pin and the aftertreatment diesel exhaust fluid RETURN pin at the aftertreatment diesel exhaust fluid relay.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid relay.

Replace the aftertreatment diesel exhaust fluid relay.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment diesel exhaust fluid diagnostic voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid relay from the engine harness.
  • Turn keyswitch ON.

Action

Check the aftertreatment diesel exhaust fluid supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid relay SIGNAL line and the aftertreatment diesel exhaust fluid relay RETURN line at the aftertreatment diesel exhaust fluid relay connector of the engine harness.

Greater than 6 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the aftertreatment diesel exhaust fluid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid relay from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid relay RETURN pin in the engine harness and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pin to ground circuit on the RETURN line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the OPEN RETURN circuit to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment diesel exhaust fluid relay diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the aftertreatment diesel exhaust fluid relay diagnostic supplly voltage.

  • Measure the voltage between the aftertreatment diesel exhaust fluid relay signal pin and ground at ECM connector

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Greater than 6-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst heater relay from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment diesel exhaust fluid relay SUPPLY pin and the engine harness aftertreatment diesel exhaust fluid relay connector aftertreatment diesel exhaust fluid relay SUPPLY pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open aftertreatment diesel exhaust fluid SUPPLY circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid relay from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid relay SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin to pin short circuit on the aftertreatment diesel exhaust fluid relay SUPPLY line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Mar-2012


FAULT CODE 1683 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Tank Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057. | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057. | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032. | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032. | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1683 inactive?
STEP 2. | Check the aftertreatment DEF tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1683 inactive and Fault Code 3576 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 1683 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1683 inactive and Fault Code 3576 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the aftertreatment DEF controller harness.

Action

Inspect the engine harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1683 inactive and Fault Code 3576 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank heater control valve to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1683 active?
YES NO

A malfunctioning aftertreatment DEF tank heater control valve has been detected.

Replace the aftertreatment DEF tank heater control valve. Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Inspect the aftertreatment DEF controller harness and controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, and 3579 will also be active.

Fault Code 1683 inactive and Fault Code 3576 active?
YES NO

A short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Mar-2012


FAULT CODE 1684 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1684 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heater relay and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 1683 active and fault code 1684 inactive?
 | STEP 2C. Check the fault codes and verify relay condition. | Fault code 1684 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault code 1683 active and fault code 1684 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1684 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. DCheck if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heater relay and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater relays from the engine harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid tank heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid tank heater relays from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1683 active and fault code 1684 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify relay condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment diesel exhaust fluid tank heater relay from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Using INSITE™, read the fault codes

Fault code 1684 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid tank heater relay has been detected.

Replace the aftertreatment diesel exhaust fluid tank heater relay.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1683 active and fault code 1684 inactive?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3E

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst heater relay from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater relay SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater relay from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater relay SUPPLY pin in the engine harness ECM connector and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin to ground short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Aug-2015


FAULT CODE 1684 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Tank Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid (DEF) Controller | Refer to Procedure 011-057. | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid (DEF) Controller | Refer to Procedure 011-057. | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032. | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032. | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1684 inactive?
STEP 2. | Check the aftertreatment DEF tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1684 inactive and Fault Code 3576 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault code 1684 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1684 inactive and Fault Code 3576 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for active or intermittent fault code.Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DEF tank heater control valve from the aftertreatment DEF controller harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • UUse INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 inactive and Fault Code 3576 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment DEF tank heater control valve to the aftertreatment DEF controller harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1684 active?
YES NO

A malfunctioning aftertreatment DEF tank heater control valve has been detected.

Replace the aftertreatment DEF tank heater control valve.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Inspect the aftertreatment DEF controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Using INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, and 3579 will also be active.

Fault Code 1684 inactive and Fault Code 3576 active?
YES NO

A short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to OEM service manual.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Mar-2012


FAULT CODE 1688 - Aftertreatment Diesel Exhaust Filter (DEF) Controller - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1688 active?
STEP 2. | Perform "Reset All Faults" command in INSITE™ electronic service tool. |
 | STEP 2A. Disable the fault code. | Fault Code 1688 come back active?
 | STEP 2B. Perform the leak test. | Fault Code 1688 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1688 active?
YES NO

Replace the aftertreatment DEF controller. Refer to Procedure 011-057 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Perform "Reset All Faults" command in INSITE™ electronic service tool.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Use INSITE™ electronic service tool to clear all fault codes.
  • Turn keyswitch OFF for 90 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1688 come back active?
YES NO

Replace the aftertreatment DEF controller. Refer to Procedure 011-057 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the leak test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Prime the aftertreatment system.

  • Use INSITE™ electronic service tool to initiate the Aftertreatment DEF System Leak Test found under the ECM diagnostics test menu.
  • Turn keyswitch OFF for 90 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1688 active?
YES NO

Replace the aftertreatment DEF controller. Refer to Procedure 011-057 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2012


FAULT CODE 1692 - Aftertreatment Outlet NOx Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1692 inactive?
STEP 2. | Check the aftertreatment outlet NOx sensor circuit. |
 | STEP 2A. Inspect the NOx sensor body and condition of the NOx sensor harness. | External damage to the sensor body, head (component fitted to the exhaust gas recirculation), or harness?
 | STEP 2B. Inspect the NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the voltage to the NOx sensor. | Voltage within the specified range for the vehicle’s electrical system voltage?
 | STEP 2D. Verify that the original equipment manufacturer (OEM) fuse is installed correctly. | Fuse installed correctly, or has it been replaced?
 | STEP 2E. Check the batteries and the power connector. | Connections tight and corrosion free?
 | STEP 2F. Check for an open circuit in the battery power circuit. | At least +22-VDC?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 1692 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1692 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect the NOx sensor body and condition of the NOx sensor harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the NOx sensor body and the NOx sensor harness.

  • Visually inspect the NOx sensor body and NOx sensor harness for cracks or damage

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

External damage to the sensor body, head (component fitted to the exhaust gas recirculation), or harness?
YES NO

Replace the NOx sensor.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor supply circuit and the aftertreatment outlet NOx sensor return circuit at the OEM harness connector.

Vehicle electrical system voltage specified range.

  • For a 24V electrical system the measured voltage should be between +18-VDC and +32-VDC
  • For a 12V electrical system the measured voltage should be between +8-VDC and +16-VDC

Note: Check the voltage at key ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within the specified range for the vehicle’s electrical system voltage?
YES NO

An out-of-range fault has been detected by the aftertreatment exhaust NOx sensor control module.

Replace the aftertreatment exhaust NOx sensor. Refer to Procedure 019-451 in Section 19.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch ON.

Action

Verify the fuse is installed correctly.

Note: The aftertreatment outlet NOx sensor power supply wire contains a 20-ampere fuse. This fuse is located in the OEM harness.

  • Inspect the OEM fuse for correct installation, or for a blown fuse.
  • Inspect the fuse for corrosion or damaged pins.

Fuse installed correctly, or has it been replaced?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion free?
YES NO
No Repair

Clean the terminals and tighten the loose connections. Refer to the OEM service manual.

Go to 2F

Go to 3A

Guided Step 2F - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage from the aftertreatment outlet NOx sensor SUPPLY (+) pin of the OEM harness to engine block ground.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

At least +22-VDC?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

An open circuit in the OEM battery supply circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Start the engine and operate for 1 minute. Diagnostic will perform and fault code will become inactive.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: The inactive fault code can not be cleared from memory with INSITE™ electronic service tool. The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Aug-2015


FAULT CODE 1694 - Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Selective Catalytic Reduction Catalyst | Refer to Procedure 011-036 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Selective Catalytic Reduction Catalyst | Refer to Procedure 011-036 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Selective Catalytic Reduction Catalyst | Refer to Procedure 011-036 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Selective Catalytic Reduction Catalyst | Refer to Procedure 011-036 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Selective Catalytic Reduction Catalyst | Refer to Procedure 011-036 | ISM11 CM876 SN | 4022196
Aftertreatment Selective Catalytic Reduction Catalyst | Refer to Procedure 011-036 | ISZ13 CM2150 | 4022133
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes are present?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor. |
 | STEP 2A. Inspect the NOx sensor body and condition of the NOx sensor harness. | External damage to the sensor body, head (component fitted to the exhaust gas processor), or harness?
 | STEP 2B. Inspect the NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the NOx sensor installation. | NOx sensor installed correctly and the exhaust system free of leaks?
 | STEP 2D. Check pin-to-pin continuity in the original equipment manufacturer (OEM) harness. | Resistances less than 10 ohms?
 | STEP 2E. Check the decomposition tube for crystallization. | Crystallization buildup in the decomposition tube?
 | STEP 2F. Check the diesel exhaust fluid (DEF) dosing pump for correct operation. | DEF dosing pump operates correctly using INSITE™ electronic service tool?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Troubleshoot any other active fault codes first.
  • All other active fault codes must be resolved before following this troubleshooting tree.

Active fault codes are present?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor.

Guided Step 2A - Inspect the NOx sensor body and condition of the NOx sensor harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the NOx sensor body and the NOx sensor harness.

  • Visually inspect the NOx sensor body and NOx sensor harness for cracks or damage.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

External damage to the sensor body, head (component fitted to the exhaust gas processor), or harness?
YES NO

Replace the NOx sensor.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the NOx sensor and connection pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • If broken pins are found within the NOx sensor, replace the NOx sensor.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the NOx sensor installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment NOx sensor installation and check the vehicle exhaust system.

Check for active fault codes.

  • Check that the NOx sensor is securely installed in the correct position with the correct fittings and fasteners.
  • Check the exhaust system for leaks and loose connections

NOx sensor installed correctly and the exhaust system free of leaks?
YES NO
No Repair

Repair the NOx sensor installation and/or exhaust system.

Go to 2D

Go to 3A

Guided Step 2D - Check pin-to-pin continuity in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the NOx sensor.
  • Disconnect the OEM harness ECM connector.

Action

Check the continuity of the NOx sensor circuit in the OEM wiring harness.

  • Check the pin-to-pin resistance of the OEM harness between the ECM connector and the NOx sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistances less than 10 ohms?
YES NO
No Repair

The OEM wiring harness resistance is excessive. Repair or replace the OEM wiring harness.

See equipment manufacturer service information.

Go to 2E

Go to 3A

Guided Step 2E - Check the decomposition tube for crystallization.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table.

Action

For ISF2.8 and ISF3.8 only: Check for DEF crystallization.

  • Inspect the decomposition tube for crystallization. Refer to Procedure 011-062 in the Associated Procedures Table.

Crystallization buildup in the decomposition tube?
YES NO

Remove the crystallization buildup. Refer to Procedure 011-062 in the Associated Procedures Table.

 No Repair

Go to 2F

Go to 2F

Guided Step 2F - Check the DEF dosing pump for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the dosing control unit.

  • For the ISF engines, use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test. Refer to Procedure 011-063 in the Associated Procedures Table.
  • For the ISB, ISD, ISL, ISM, and ISZ engines, use INSITE™ electronic service tool to perform the Aftertreatment DEF Dosing Unit Test. Refer to Procedure 019-440 in the Associated Procedures Table.

Note: The urea injector nozzle must be removed and placed in a measuring container in order to perform this test. Make sure the nozzle is not plugged and urea is flowing from all four holes.

DEF dosing pump operates correctly during INSITE™ electronic service tool override tests?
YES NO
No Repair

Replace the DEF dosing unit. Refer to Procedure 019-036 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Jul-2015


FAULT CODE 1695 - Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN, ISF2.8 CM2220 ECF2 | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harenss connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness (if equipped).
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 5 pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ECM battery (+) in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness (if equipped).
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check for a short circuit to ECM battery (+).

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to the ECM battery (+) pins at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Aug-2012


FAULT CODE 1696 - Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN ISF2.8 CM2220 ECF2 | 4022178
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISM11 CM876 SN | 4022196
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN ISF2.8 CM2220 ECF2 | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN ISF2.8 CM2220 ECF2 | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Check the circuit response. | Fault Code 1696 active?
 | STEP 2B. Check the circuit response. | Fault Code 1696 active?
 | STEP 2C. Check the circuit response. | Fault Code 1696 active?
 | STEP 2D. Check the circuit response. | Fault Code 1696 active?
 | STEP 2E. Check the circuit response. | Fault Code 1696 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the accelerator/lever position sensor. Refer to the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote throttle from the OEM harness (if equipped).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the remote throttle. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan speed sensor from the OEM harness (if equipped). If vehicle does not have a fan speed sensor, skip to the next step.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the fan speed sensor. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness (if equipped). If vehicle does not have a aftertreatment diesel particulate filter differential pressure sensor, skip to the next step.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the remote throttle (if equipped) from the OEM harness.
  • Disconnect the fan speed sensor (if equipped) from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor (if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal 5-VDC SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the remote throttle (if equipped) from the OEM harness.
  • Disconnect the fan speed sensor (if equipped) from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor (if equipped) from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator 5-VDC SUPPLY pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 1697 - Air Supply Actuator - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
ECM Calibration | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1697 inactive?
STEP 2. | Check the air solenoid and circuit. |
 | STEP 2A. Inspect the air solenoid and electrical and connections. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the air solenoid. | Solenoid resistance between 8 and 20 ohms?
 | STEP 2C. Check for a short circuit to ground in the air solenoid. | Greater than 100k ohms?
STEP 3. | Check the dosing control unit and dosing control unit harness. |
 | STEP 3A. Inspect dosing control unit and dosing control unit connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the original equipment manufacturer (OEM) harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool. to read the fault codes.

Fault Code 1697 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the air solenoid and circuit.

Guided Step 2A - Inspect the air solenoid and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Inspect the OEM harness and air solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the air solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Check air solenoid resistance.

  • Measure the resistance between the air solenoid SIGNAL pin and the air solenoid RETURN pin at the air solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Solenoid resistance between 8 and 20 ohms?
YES NO
No Repair

An open or short circuit has been detected in the air solenoid. Replace the dosing control unit. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the air solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Check for an air solenoid short to ground.

  • Measure the resistance between the air solenoid SIGNAL pin and ground at the air solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the dosing control unit. Refer to OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the dosing control unit and dosing control unit harness.

Guided Step 3A - Inspect the dosing control unit and dosing control unit connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing control unit.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the OEM harness from the air solenoid.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the air solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram and a wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the air solenoid signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Aug-2015


FAULT CODE 1698 - Air Supply Actuator - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1698 inactive?
STEP 2. | Check the air solenoid and circuit. |
 | STEP 2A. Inspect the air solenoid and electrical and connections. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the air solenoid. | Solenoid resistance between 8 and 20 ohms?
 | STEP 2C. Check for a short circuit to ground in the air solenoid. | Greater than 100k ohms?
STEP 3. | Check the dosing control unit and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect dosing control unit and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the signal circuit. | Less than 10k ohms?
 | STEP 3E. Check for an open circuit in the return circuit. | Less than 10 ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1698 inactive?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1698 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the air solenoid and circuit.

Guided Step 2A - Inspect the air solenoid and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Inspect the dosing control unit harness and air solenoid connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the air solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Check air solenoid resistance.

  • Measure the resistance between the air solenoid SIGNAL pin and the air solenoid RETURN pin at the air solenoid.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Solenoid resistance between 8 and 20 ohms?
YES NO
No Repair

An open or short circuit has been detected in the air solenoid.

Replace the dosing control unit.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from supply to ground in the air solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Check air solenoid short circuit from supply to ground.

  • Measure the resistance between the air solenoid SIGNAL pin and the air solenoid RETURN pin at the air solenoid.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open or short circuit has been detected in the air solenoid.

Replace the dosing control unit.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the dosing control unit and OEM harness.

Guided Step 3A - Inspect the dosing control unit and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing control unit.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the OEM harness from the air solenoid.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the air solenoid SIGNAL pin in the dosing control unit harness and ground.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the air solenoid signal line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the air solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the air solenoid SIGNAL pin in the OEM harness and all other pins in the OEM harness connector.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the air solenoid signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the air solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the air solenoid SIGNAL pin in the OEM harness at the dosing control unit and the air solenoid SIGNAL pin in the OEM harness at the air solenoid.

Refer to the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the air solenoid signal line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the air solenoid from the dosing control unit harness.

Action

Check for an open circuit.

  • Measure the resistance between the air solenoid RETURN pin in the OEM harness at the dosing control unit and the air solenoid RETURN pin in the OEM harness at the air solenoid.

Refer to the circuit diagram and the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin-to-pin short circuit on the air solenoid return line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1698 inactive?

YES NO

None. The removal and installation of the connector corrected the fault.

Replace the dosing control unit.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Oct-2012


Fault Code 1711 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2220 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2220 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Aftertreatemnt Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatemnt Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2220 SN | 4022190
Aftertreatemnt Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatemnt Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code | Fault Code 1711 active?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the voltage to the aftertreatment diesel exhaust fluid dosing unit. | Voltage is within 1-VDC of battery voltage?
 | STEP 2A-1. Check the battery and the power connector. |
 | STEP 2A-2. Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit voltage supply. |
 | STEP 2B. Check the keyswitch voltage to the aftertreatment diesel exhaust fluid dosing unit. | Voltage is within 1-VDC of battery voltage?
STEP 3. | Check the data link harness. |
 | STEP 3A. Check for an open or short circuit in the J1939 data link harness. | Resistance between 50 and 70 ohms?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the ECM J1939 data link harness. | Resistance between 50 and 70 ohms?
 | STEP 4C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1711 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the voltage to the aftertreatment diesel exhaust fluid dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness from the aftertreatment diesel exhaust fluid dosing unit.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment diesel exhaust fluid dosing unit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid dosing unit OEM battery SUPPLY and the aftertreatment diesel exhaust fluid dosing unit OEM RETURN.

NOTE: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

  • Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 2A-2

Go to 5A

Guided Step 2A-2 - Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the aftertreatment diesel exhaust fluid dosing unit.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment diesel exhaust fluid dosing unit battery voltage SUPPLY pin of the OEM harness dosing unit connector to engine block ground.

NOTE: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the OEM battery voltage RETURN circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the OEM battery voltage SUPPLY circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 2B - Check the keyswitch voltage to the aftertreatment diesel exhaust fluid dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness from the aftertreatment diesel exhaust fluid dosing unit.
  • Turn keyswitch ON.

Action

Check the keyswitch input voltage to the aftertreatment diesel exhaust fluid dosing unit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid dosing unit OEM keyswitch input and ground.

Refer to Procedure 019-359 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES NO
No Repair

An open circuit or low keyswitch voltage input has been detected in the aftertreatment diesel exhaust fluid dosing unit ground circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the data link harness.

Guided Step 3A - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short circuit has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected.

  • Replace the aftertreatment diesel exhaust fluid dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 1712 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level correct?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system.

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including OEM in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that the coolant level is within normal operating levels.

Coolant level correct?
YES NO
No Repair

Add coolant to the engine as necessary.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Refer to OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Dec-2009


FAULT CODE 1713 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active or high inactive counts ?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level correct?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank temperature sensor. |
 | STEP 3A. Check the aftertreatment diesel exhaust fluid tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
STEP 4. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 4A. Verify that the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly. | Diesel exhaust fluid tank heater control valve installed correctly?
 | STEP 4B. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system.

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including OEM in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to OEM service manual.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that coolant level is within normal operating levels.

Coolant level correct?
YES NO
No Repair

Add coolant to engine as necessary.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Guided Step 3A - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the diesel exhaust fluid in the diesel exhaust fluid tank with an infrared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
YES NO
No Repair

Replace the diesel exhaust fluid tank temperature sensor.

  • Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 4A - Verify that the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the installation of the tank heater control valve.

  • Make sure that the tank heater control valve is installed correctly, and not reversed.

Refer to OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve installed correctly?
YES NO
No Repair

Remove the diesel exhaust fluid tank heater control valve, and install it in the correct position. Make sure the valve is not reversed according to the coolant flow direction (where applicable).

Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Make sure the tank heater control valve is installed correctly, and not reversed.

Refer to OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jul-2011


FAULT CODE 1848 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 1848 active?
 | STEP 1B. Check for Fault Codes 153 and 154. | Fault Code 153 or 154 active?
STEP 2. | Check the engine intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 153 active?
 | STEP 3C. Check the circuit response. | Fault Code 154 active?
STEP 4. | Verify the repair. |
 | STEP 4A. Verify the repair. | Intake manifold temperature and aftertreatment SCR intake temperature reading within 6°C [10°F] of each other?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1848 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for fault codes 153 and 154.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 or 154 is active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Connector hsell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins if possible.

  • Flush the dirt, debris, or moisture form the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 123 will also be active when the intake manifold temperature sensor is disconnected.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold temperature SIGNAL pin and the engine intake manifold temperature RETURN pin at the engine intake manifold temperature connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin locations.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

An in-range malfunction of the intake manifold temperature sensor has been detected.

  • Replace the engine intake manifold temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged harness, connectors, or pins if possible.

  • Flush the dirt, debris, or moisture form the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold temperature SIGNAL pin and the engine intake manifold temperature RETURN pin at the engine intake manifold temperature connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin locations.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Verify the repair.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start the INSITE™ electronic service tool Data Monitor/Logger.

Intake Manifold Temperature and Aftertreatment SCR Intake Temperature reading within 6°C [10°F] of each other?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if any ECM calibration updates is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find thepresent ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Mar-2012


FAULT CODE 1887 - Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISM11 CM876 SN | 4022196
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1887 inactive?
 | STEP 1B. Check for inactive fault codes. | Fault Code 1887 inactive?
STEP 2. | Check the aftertreatment outlet NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | For a 12 Volt system, voltage between 11 and 14-VDC or for a 24 Volt system, voltage between 18 and 24-VDC?
 | STEP 2C. Check the batteries and the power connector. | Connections tight and corrosion free?
 | STEP 2D. Verify that the original equipment manufacturer (OEM) fuse is installed correctly. | Fuse installed correctly, or has it been replaced?
 | STEP 2E. Check for an open circuit in the battery power circuit. | For a 12 Volt system, voltage at least 11-VDC or for a 24 Volt system, voltage at least 22-VDC?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it run for at least 2 minutes.

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887 inactive?
YES NO
No Repair

The aftertreatment outlet NOx sensor internal heater has malfunctioned.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor SUPPLY circuit and the aftertreatment outlet NOx sensor RETURN circuit at the OEM harness connector.

Note: Check the voltage at key ON while cranking the engine, and with the engine at idle.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Refer to Procedure 019-359 in Section 19.

For a 12 Volt system, voltage between 11 and 14-VDC or for a 24 Volt system, voltage between 18 and 24-VDC?
YES NO

An out-of-range fault has been detected by the aftertreatment outlet NOx sensor control module.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion free?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Clean the terminals and tighten the loose connections.

Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch ON.

Action

Verify the fuse is installed correctly.

Note: The aftertreatment outlet NOx sensor power supply wire contains a 20-ampere fuse. This fuse is located in the OEM harness.

  • Inspect the OEM fuse for correct installation, or for a blown fuse.
  • Inspect the fuse for corrosion or damaged pins.

Is the fuse installed correctly, or has it been replaced?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage from the aftertreatment outlet NOx sensor SUPPLY (+) pin of the OEM harness to engine block ground.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Refer to Procedure 019-359 in Section 19.

For a 12 Volt system, voltage at least 11-VDC or for a 24 Volt system, voltage at least 22-VDC?
YES NO

An open circuit in the OEM battery return circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

An open circuit in the OEM battery supply circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Aug-2015


FAULT CODE 1896 - EGR Valve Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 | 4022178

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1896 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the exhaust gas recirculation (EGR) valve operation. |
 | STEP 2A. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the EGR valve operation.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Turn the keyswitch OFF for 1 minute and then turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

Clean the EGR valve assembly.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

Turn the keyswitch OFF for 1 minute and then turn the keyswitch ON.

If Fault code 1896 is still active after EGR valve has been cleaned, then a malfunctioning EGR valve has been detected.

  • Replace the EGR valve. Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 19-Jan-2017


FAULT CODE 1898 - VGT Actuator Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 1898 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1938 or 2636 is active?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear is broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Using the sector gear gauge, does the nozzle movement meet the requirements according to Procedure 010-134?
 | STEP 2D. Check the VGT output gear for correct calibration. | Does the VGT actuator gear move when connected to the engine wiring harness?
 | STEP 2D-1. Check the VGT output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 1898. | Fault Code 1898 active?
 | STEP 3B. Disable the fault code. | Fault code inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 1898.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Cycle the keyswitch several times, waiting 30 seconds between each key cycle, to see if Fault Code 1898 becomes active.

Fault Code 1898 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 1898 is active. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 is active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques reference the following procedure. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear is broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

  • Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • VGT actuator removed from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Using the sector gear gauge, does the nozzle movement meet the requirements according to Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

  • Replace the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear should rotate.

Note: The VGT actuator output gear will exhibit one of the following movements depending on the ECM calibration. Make sure to closely observe the VGT actuator gear when the VGT actuator is connected to the engine wiring harness.

  • The actuator output gear could possibly rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the VGT actuator is connected to the engine wiring harness.
  • If the VGT actuator gear does not move, disconnect the VGT actuator from the engine wiring harness for 1 second and then reconnect.
  • Repeat the above procedure 3 times, checking for VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

Does the VGT actuator gear move when connected to the engine wiring harness?
YES NO

Install the VGT actuator back on the turbocharger making sure to perform the VGT actuator install and calibrate procedures. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

Note: Do not use pliers or any other tool to turn the gear. Only rotate the gear by hand.

Can the VGT actuator output gear be rotated by hand?
YES NO

Install the VGT actuator back on the turbocharger making sure to perform the actuator install and calibrate procedures. Refer to Procedure 010-134 in the Associated Procedures Table.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 1898.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 1898.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1898 active?
YES NO

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Mar-2012


FAULT CODE 1911 (ISB, ISD, ISF) - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Pump | Refer to Procedure 005-016 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Pump | Refer to Procedure 005-016 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Air in Fuel | Refer to Procedure 006-003 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Air In Fuel | Refer to Procedure 006-003 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Air In Fuel | Refer to Procedure 006-003 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 559, 1117, or 2311 active or any inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check for air in the fuel. | Air in the fuel?
 | STEP 3B. Check the fuel inlet restriction. | Fuel inlet restriction within the specifications outlined in Procedure 006-020 (Fuel Inlet Restriction)?
 | STEP 3C. Check the fuel filter pressure drop. | Fuel pressure drop within the specifications outlined in Procedure 006-015 (Fuel Filter (Spin-On Type))?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012 (Fuel Drain Line Restriction)?
STEP 5. | Check the fuel pump actuator. |
 | STEP 5A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the fuel pump actuator resistance. | Fuel pump actuator resistance within the specifications outlined in Procedure 019-117 (Fuel Pump Actuator)?
 | STEP 5C. Monitor the fuel rail pressure at idle. | Does Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
 | STEP 5D. Inspect the fuel pump actuator for damage. | Fuel pump actuator damaged?
STEP 6. | Check the engine control module (ECM) to ground strap. |
 | STEP 6A. Inspect the ECM to ground strap. | ECM to ground strap missing or are the connections degraded?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, 559, 1117, or 2311 active or any inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool Monitor.
  • Fuel pressure relieved from the high-pressure fuel rail.
  • Engine not operating.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.
  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero. It may be necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail. Refer to Procedure 006-071 in the Associated Procedures Table.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check for air in the fuel.

Conditions

  • Keyswitch ON.
  • Engine operating.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. Refer to Procedure 006-020 in the Associated Procedures Table if fuel inlet restriction is not excessive.

The source of air entry should be isolated to one for the following:

  • Suction fuel lines
  • Original equipment manufacturer (OEM) fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipe(s) in the fuel tank(s).

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the fuel inlet restriction.

Conditions

  • Keyswitch ON.
  • Engine operating.

Action

Check the fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Fuel inlet restriction within the specifications outlined in Procedure 006-020?
YES NO
No Repair

If inlet restriction is excessive, search for the root cause:

  • Suction side fuel filters plugged
  • Fuel heater valves restricted
  • OEM fuel lines pinched or restricted
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and that the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic, paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers or filters, or any malfunctioning check valves.

If no issues are found, replace the suction side fuel filter and prime the fuel system.

  • Refer to Procedure 006-015 in the Asssociated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check the fuel filter pressure drop.

Conditions

  • Keyswitch ON.
  • Engine operating.

Action

Check the fuel pressure drop across the filter.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Fuel pressure drop within the specifications outlined in Procedure 006-015?
YES NO
No Repair

Make sure the filter pump pressure into the filter is within specification.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

If the pump meets specifications, replace the fuel filter and prime the fuel system.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check drain line restriction.

Conditions

  • Keyswitch ON.
  • Engine operating.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump actuator.

Guided Step 5A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in the Associated Procedures Table.

Fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 5C

Go to 7A

Guided Step 5C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Does Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 5D

Guided Step 5D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in the Associated Procedures Table.

Fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the engine control module (ECM) to ground strap.

Guided Step 6A - Inspect the ECM to ground strap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM to ground strap.

  • Check the ground connections from the cylinder block to battery (-) negative.
  • Check the ground from the ECM to the cylinder block. Refer to Procedure 019-008 in Section 19.

ECM to ground strap missing or are the connections degraded?
YES NO

Repair missing or degraded ground connections. See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Aug-2015


FAULT CODE 1911 (ISC, ISL, ISX, ISZ) - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISZ13 CM2150 | 4022133
Air in Fuel | Refer to Procedure 006-003 | ISL8.9 CM2150 SN | 4022190
Air in Fuel | Refer to Procedure 006-003 | ISZ13 CM2150 | 4022133
Fuel Filter (Spin-on Type) | Refer to Procedure 006-015 | ISL8.9 CM2150 SN | 4022190
Fuel Filter (Spin-on Type) | Refer to Procedure 006-065 | ISZ13 CM2150 | 4022133
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISL8.9 CM2150 SN | 4022190
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISZ13 CM2150 | 4022133
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 SN | 4022190
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Actuator | Refer to Procedure 019-117 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 559, 1117, or 2311 active or any inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check for air in the fuel. | Was there air in the fuel?
 | STEP 3B. Check the fuel inlet restriction at the OEM connection and gear pump. | Is the fuel inlet restriction within the specifications outlined in Procedure 006-020?
 | STEP 3C. Measure the pressure drop at the pressure side fuel filter. | Is the fuel pressure drop within the specifications outlined in Procedure 006-015?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 5. | Check the fuel pump actuator. |
 | STEP 5A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the fuel pump actuator resistance. | Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 5C. Monitor the fuel rail pressure at idle. | Does Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
 | STEP 5D. Inspect the fuel pump actuator for damage. | Is the fuel pump actuator damaged?
STEP 6. | Check the ECM to ground strap. |
 | STEP 6A. Inspect the ECM to ground strap. | Is the ECM to ground strap missing or are the connections degraded?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the fuel pump actuator shorted low or high.

Fault Code 271, 272, 559, 1117, or 2311 active or any inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Run INSITE™ electronic service tool Monitor
  • Fuel pressure relieved from the high-pressure fuel rail
  • Engine not operating.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.
  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed off, there could be a significant amount of time waiting on the rail to depressurize to zero. It is necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check for air in the fuel.

Conditions

  • Turn keyswitch ON
  • Engine operating.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Was there air in the fuel?
YES NO

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

  • If fuel inlet restriction is not excessive, use the following procedure. Refer to Procedure 006-020 in the Associated Procedures Table.

The source of air entry should be isolated to one for the following:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipe(s) in the fuel tank(s).

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the fuel inlet restriction at the OEM connection and gear pump.

Conditions

  • Keyswitch ON
  • Engine operating.

Action

Check the fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Is the fuel inlet restriction within the specifications outlined in Procedure 006-020?
YES NO
No Repair

If inlet restriction is excessive, search for the root cause:

  • Suction side fuel filters plugged
  • Fuel heater valves are restricted
  • OEM fuel lines pinched or restricted
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic , paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction side fuel filter and prime the fuel system.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Measure the pressure drop at the pressure side fuel filter.

Conditions

  • Keyswitch ON
  • Engine operating.

Action

Measure the pressure drop.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Is the fuel pressure drop within the specifications outlined in Procedure 006-015?
YES NO
No Repair

Make sure the filter pump pressure into the filter is within specification.

  • Refer to Procedure 005-025 in the Associated Procedures Table.

If the pressure from the gear pump is within specifications, replace the fuel filter and prime the fuel system.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

If the pressure from the gear pump is not within specifications, replace the gear pump.

  • Refer to Procedure 005-025 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check drain line restriction.

Conditions

  • Keyswitch ON
  • Engine operating.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump actuator.

Guided Step 5A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 5C

Go to 7A

Guided Step 5C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Does Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5D

Guided Step 5D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the ECM to ground strap.

Guided Step 6A - Inspect the ECM to ground strap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM to ground strap.

  • Check the ground connections from the cylinder block to battery (-) negative.
  • Check the ground from the ECM to the cylinder block. Refer to Procedure 019-008 in Section 19.

Is the ECM to ground strap missing or are the connections degraded?
YES NO

Repair missing or degraded ground connections. Refer to the OEM Service manual.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 1981 - Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1981 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
STEP 2. | Inspect the aftertreatment diesel particulate filter (DPF) differential pressure sensor. |
 | STEP 2A. Verify the aftertreatment DPF differential pressure sensor accuracy. | Aftertreatment DPF differential pressure sensor reading 0 ± 3 kPa [0 ± 0.89 in Hg] with keyswitch ON and the engine OFF?
 | STEP 2B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor supply tubes blocked?
STEP 3. | Inspect the aftertreatment diesel particulate filter. |
 | STEP 3A. Inspect the aftertreatment diesel particulate filter. | Tampering or damage to the aftertreatment diesel particulate filter?
STEP 4. | Check for excessive black smoke. |
 | STEP 4A. Inspect the exhaust for excessive black smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1981 active?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment DPF differential pressure sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment DPF differential pressure sensor.

Guided Step 2A - Verify the aftertreatment DPF differential pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Monitor the aftertreatment diesel particulate filter differential pressure sensor reading with INSITE™ electronic service tool.

Is the aftertreatment DPF differential pressure sensor reading 0 ± 3 kPa [0 ± 0.89 in Hg] with keyswitch ON and the engine OFF?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.
  • Disconnect aftertreatment DPF differential pressure sensor supply tubes.

Action

Disconnect the aftertreatment DPF differential pressure sensor supply tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

Are the aftertreatment DPF differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment DPF differential pressure sensor supply tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • If no short circuit is found, replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Inspect the aftertreatment diesel particulate filter.

Guided Step 3A - Inspect the aftertreatment diesel particulate filter.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment diesel particulate filter. Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel particulate filter.

  • Inspect the aftertreatment system to determine if the aftertreatment diesel particulate filter has been tampered with, has been removed from the exhaust system, or has been damaged. Refer to Procedure 011-041 in the Associated Procedures Table.

Tampering or damage to the aftertreatment diesel particulate filter?
YES NO

Remove and inspect the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Clean or replace the aftertreatment DPF as necessary.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for excessive black smoke.

Guided Step 4A - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconnect exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.

NOTE: To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Is there excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

  • Reference the appropriate engine performance troubleshooting tree.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM. Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 2182 - Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2150 SN | 4022190
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Rocker Lever Cover | Refer to Procedure 003-011 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active and/or inactive fault codes. | Fault Code 2182 active or multiple inactive counts?
STEP 2. | Check the engine brake solenoid and circuit. |
 | STEP 2A. Check the engine brake solenoid for an open circuit. | Between 5 and 15 ohms?
 | STEP 2B. Check the diagnostic signal voltage at the engine brake actuator. | Greater than 3.75 VDC?
STEP 3. | Check the ECM and engine harness.. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine brake solenoid number 1 diagnostic supply voltage. | Greater than 3.75 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2182 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | Calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code.. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active and/or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2182 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the engine brake solenoid and circuit.

Guided Step 2A - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the solenoid terminal pin to ground.

Use the following procedure for general inspection techniques.

  • Refer to Procedure 019-361 in Section 19.

Between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Go to 2B

Go to 4A

Guided Step 2B - Check the diagnostic signal voltage at the engine brake actuator.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 1.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 1 diagnostic supply voltage.

  • Measure the voltage between the engine harness engine brake solenoid number 1 SIGNAL pin and ground.

Reference the circuit or wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness..

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques.

  • Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

  • A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 1 diagnostic supply voltage.

  • Measure the voltage between the engine brake solenoid number 1 SIGNAL pin and ground at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL wire at the engine brake solenoid to the engine brake solenoid number 1 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

  • Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 1 SIGNAL circuit has been detected in the engine harness. The open circuit is in one of the following harnesses:

  • The main engine harness between the ECM and the 2-pin connector at the back of the engine
  • The engine brake jumper harness between the engine harness 2-pin connector at the back of the engine and the rocker lever housing.
  • The internal engine brake harness between the rocker lever housing and the engine brake solenoid.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Disconnect the engine brake solenoid number 1 wire from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

  • Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL wire has been detected in the engine.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2182 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 2183 - Engine Brake Actuator Circuit 1 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Engine Control Module | Refer to Procedure 019-031 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISC and ISL CM2150 | 4021569

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2183 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater thank 100k ohms?
STEP 3. | Check the engine brake solenoid. |
 | STEP 3A. Check the engine brake solenoid for a short-to-ground. | 5 ohms or greater?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 1 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 SUPPLY wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SUPPLY wire at the engine brake solenoid and the engine brake solenoid number 1 SIGNAL wire at the ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 1 SIGNAL circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the short-to-ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocket lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine brake number 1 solenoid terminal pin to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance of the engine brake number 1 solenoid SUPPLY terminal pin to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch leve, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Fuel Lift Pump | Refer to Procedure 005-045 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2265 active?
STEP 2. | Check the electric fuel control lift pump. |
 | STEP 2A. Inspect the engine harness and electric fuel control lift pump connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the lift pump. | Less than 10 ohms?
 | STEP 2C. Check the fuel control lift pump diagnostic supply voltage and return circuit. | Voltage is between 2.5 and 4.0-VDC?
 | STEP 2D. Check for an open circuit in the fuel lift pump return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM lift pump diagnostic supply voltage. | Voltage is between 2.5 and 4.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2265 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric fuel control lift pump.

Guided Step 2A - Inspect the engine harness and fuel control lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel control lift pump.

Action

Inspect the engine harness and fuel control lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the lift pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel control lift pump.

Action

Check for an open circuit in the electric fuel control lift pump.

  • Measure the resistance between the electric fuel lift pump relay SUPPLY and the fuel lift pump RETURN pin at the electric fuel supply pump connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the electric fuel lift pump.

Refer to Procedure 005-045 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel control lift pump diagnostic supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel pump.
  • Turn keyswitch ON.
  • Wait a minimum of 2 minutes.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin at the lift pump connector of the engine harness.

Note: The keyswitch must be turned ON for more than 2 minutes before the check can be performed.

Use the circuit diagram or the wiring diagram for connector pin identification.

Voltage is between 2.5 and 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel lift pump return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness lift pump RETURN pin and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM lift pump diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Wait a minimum of 2 minutes.

Action

Check the supply voltage.

  • Measure the voltage between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin at the engine harness ECM connector port.

Note: The keyswitch must be turned ON for more than 2 minutes before the check can be performed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage is between 2.5 and 4.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the lift pump from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel lift pump SUPPLY pin at the fuel lift pump connector and the fuel lift pump SUPPLY pin at the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the lift pump from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2012


FAULT CODE 2266 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Fuel Lift Pump | Refer to Procedure 005-045 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2266 active?
STEP 2. | Check the electric fuel lift pump. |
 | STEP 2A. Inspect the engine harness and electric fuel lift pump connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2265 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2266 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2265 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2266 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric fuel lift pump.

Guided Step 2A - Inspect the engine harness and fuel lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Inspect the engine harness and fuel control lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel lift pump to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES NO

A damaged fuel lift pump has been detected.

Replace the fuel lift pump.

Refer to Procedure 005-045 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Mar-2012


FAULT CODE 2271 - EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 E | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check the fault codes. | Fault Code 2271 active?
STEP 2. | Check the EGR valve position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2272 active and Fault Code 2271 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit.Check the circuit response. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2271 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Troubleshoot Fault Code 386.

 No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the EGR valve position sensor RETURN pin and the EGR valve position sensor SIGNAL pin at the EGR valve connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active and Fault Code 2271 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor Supply voltage and Return circuit at the engine harness.

  • Measure the voltage between the EGR valve position sensor +5-VDC SUPPLY pin and the EGR valve position sensor RETURN pin at the engine harness connector.

Refer to the Circuit Diagram or Wiring Diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES NO

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR valve position sensor RETURN pin and the EGR valve position sensor SIGNAL pin at the ECM engine connector.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 2272 active and Fault Code 2271 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 2271 active?
YES NO

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the EGR valve position +5-VDC SUPPLY pin and the EGR valve position RETURN pin at the ECM connector.

Refer to the Circuit Diagram or Wiring Diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES NO

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Mar-2012


FAULT CODE 2272 - EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 E | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2271 active and Fault Code 2272 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2272 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Troubleshoot Fault Code 352.

 No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active and Fault Code 2272 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the EGR valve position sensor +5-VDC SUPPLY pin and the EGR valve position sensor RETURN pin at the engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 2271 active and Fault Code 2272 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor Supply voltage and Return circuit at the ECM.

  • Measure the voltage between the EGR valve position +5-VDC SUPPLY pin and the EGR valve position RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Mar-2012


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Actuator | Refer to Procedure 019-117 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the fuel pump actuator valve. |
 | STEP 2A. Inspect the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 2C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify the fuel pump actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator.

Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the ECM connector of the engine harness and engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine operating at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel pump actuator.

If a short or open circuit is induced while the engine is operating, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedure Table.

Replace the fuel pump actuator.

Refer to Procedure 019-117 in the Associated Procedure Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Mar-2012


FAULT CODE 2344 - Fuel Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
OEM Wiring Harness | Refer to Procedure 019-071 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2344 active?
STEP 2. | Check the fuel filter differential pressure switch and circuit. |
 | STEP 2A. Inspect the switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the fuel filter differential pressure switch. | Less than 10 ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2344 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2344 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel filter differential pressure switch and circuit.

Guided Step 2A - Inspect the switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fuel filter differential pressure switch.

Action

Inspect the OEM harness and differential pressure switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the fuel filter differential pressure switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fuel filter differential pressure switch.

Action

Check for an open circuit.

  • Measure the resistance between the fuel filter differential pressure switch SIGNAL pin of the fuel filter differential pressure switch and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the fuel filter differential pressure switch.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fuel filter differential pressure switch.

Action

Check for an open circuit.

  • Measure the resistance between the fuel filter differential pressure SIGNAL pin at the switch connector of the OEM harness and the fuel filter differential pressure SIGNAL pin at the ECM connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techneques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the fuel filter differential pressure switch.

Action

Check for a short circuit to ground.

  • Measure the resistance between the fuel filter differential pressure SIGNAL pin in the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techneques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the fuel filter differential pressure switch.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fuel filter differential pressure switch SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techneques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2344 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 03-Feb-2017


FAULT CODE 2347 - Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL8.9 CM2150 SN | 4022190
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISM11 CM876 SN | 4022196
ECM Calibration | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2634, 2449, or 2387 active?
 | STEP 1B. Check for inactive fault codes. | Fault Code 295 or 2973 active?
STEP 2. | Check sensor readings. |
 | STEP 2A. Check ambient air pressure sensor accuracy. | INSITE™ electronic service tool reading within 10 cm Hg [4 inHg] of local barometric pressure?
 | STEP 2B. Check the intake manifold pressure sensor accuracy. | Intake manifold pressure reading less than 10 cm Hg [4 inHg]?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2634, 2449, or 2387 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 295 or 2973 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check sensor readings.

Guided Step 2A - Check the ambient air pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Start INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for Barometric Air Pressure to local barometric pressure. Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading within 10 cm Hg [4 inHg] of local barometric pressure?
YES NO
No Repair

Replace the barometric air pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check the intake manifold pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the value of Intake Manifold Pressure without the engine running.

Intake Manifold Pressure reading less than 10 cm Hg [4 inHg]?
YES NO

Use the following troubleshooting symptom tree for information to continue to troubleshoot for low boost pressure in the appropriate Service Manual. Reference the Intake manifold Pressure (Boost) is Below Normal in Section TS.

Replace the intake manifold pressure sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Mar-2012


FAULT CODE 2351 - EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 E | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for EGR motor circuit fault codes. | Fault Code 2351 active?
STEP 2. | Check the EGR valve and circuit. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the EGR valve motor. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin to pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2351 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve and circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Check for a short circuit to ground in the EGR valve motor.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and engine block ground.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve

Action

Check for a short circuit from pin to pin in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2013


FAULT CODE 2352 - EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 E | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2352 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the EGR valve motor circuit. | Less than 15 ohms?
 | STEP 2B-1. Check for an open circuit in the EGR valve motor. |
 | STEP 2B-2. Check for an open circuit in the engine harness. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to a voltage source. | Less than 1.5-VDC?
 | STEP 3C. Check for a short circuit from pin to pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2352 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2352 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the EGR valve motor circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the EGR valve motor circuit.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B-1

Guided Step 2B-1 - Check for an open circuit in the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Check for an open circuit in the EGR valve motor.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the EGR valve connector.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

An open circuit has been detected in the EGR valve.

Replace the EGR valve assembly.

Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 2B-2

Go to 4A

Guided Step 2B-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EGR valve.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and the EGR valve motor SIGNAL (+) pin at the EGR valve motor connector of the engine harness.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, pins, or ECM.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use the following procedure for multimeter usage information.

Refer to Procedure 019-359 in Section 19.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit to voltage has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve.

Action

Check for a short circuit from pin to pin in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2352 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Mar-2012


FAULT CODE 2357 - EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 E | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2272 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR valve position sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

Troubleshoot fault code 2272 before fault code 2357.

 No Repair

Fault Code 2272 Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the EGR valve circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Keyswitch OFF for 10 seconds.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

Replace the EGR valve assembly. Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the EGR valve operation.

Guided Step 3A - Monitor the EGR valve position.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start and idle the engine for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2357 becomes active after 1 minute?
YES NO

Replace the EGR valve assembly. Refer to Procedure 011-022 in the Associated Procedures Table.

The restriction in the EGR valve has been removed. No repair is necessary.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter.
  • Refer to Procedure 014-013 in the associated procedures section.

Action

Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter.

Progressive damage to the aftertreatment system may have occurred. The aftertreatment system must be inspected for reuse.

  • Refer to Procedure 014-013 in the associated procedures section.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment component. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 2363 (Heavy Duty) - Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Rocker Lever Cover | Refer to Procedure 003-011 | ISZ13 CM2150 | 4022133
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Brake | Refer to Procedure 020-024 | ISM11 CM876 SN | 4022196
Engine Brake | Refer to Procedure 020-024 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake solenoid 2 signal circuit. |
 | STEP 1A. Check the diagnostic voltage at the engine brake pass-through connector. | Greater than 5.0-VDC?
 | STEP 1B. Check the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the diagnostic voltage at the ECM. | Greater than 5.0-VDC?
STEP 2. | Check the engine brake wiring harness and solenoids. |
 | STEP 2A. Check for a short to ground. | Greater than 5 ohms?
 | STEP 2B. Check the engine brake wiring harness for a short to ground. | More than 100k ohms?
 | STEP 2C. Check the brake solenoids for a short to ground. | Greater than 5 ohms?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration udpate is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine brake solenoid 2 signal circuit.

Guided Step 1A - Check the diagnostic voltage at the engine brake pass-through connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage.

  • Use multimeter to measure the voltage from the engine brake solenoid number 2 SIGNAL pin of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage.

  • Use a multimeter to measure the voltage from the engine brake solenoid number 2 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO

Repair or replace the engine harness.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2 - Check the engine brake wiring harness and solenoids.

Guided Step 2A - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 2 SIGNAL pin of the engine brake connector to engine block ground.

Use a wiring diagram for pin identification or the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 5 ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake wiring harness from solenoid number 2.

Action

Check for a pinched or an abraded harness, or areas that may be shorted to ground.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 2 SIGNAL pin of the engine brake connetor to engine block ground.

Use a wiring diagram for pin identification or the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the engine brake wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the brake solenoids for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake wiring harness from solenoid number 2.

Action

Check for resistance of the solenoid.

  • Use a multimeter to measure the resistance from the the solenoid terminal pin to engine block ground.

Use a wiring diagram for pin identification or the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 5 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-024 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibratiion update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2012


FAULT CODE 2363 (Midrange) - Engine Brake Actuator Drive Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 AN | 4022178
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 AN | 4021704
Rocker Lever Cover | Refer to Procedure 003-011 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2363 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid. |
 | STEP 3A. Check the engine brake solenoid for a short to ground. | 5 ohms or greater?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2363 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 SUPPLY wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SUPPLY wire at the engine brake solenoid and the engine brake solenoid number 2 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 signal circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator signal wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 signal wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocket lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine brake number 2 solenoid terminal pin to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance of the engine brake number 2 solenoid SUPPLY terminal pin to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 1.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2367 (Heavy Duty) - Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM11 CM876 SN | 4022196
Rocker Lever Cover | Refer to Procedure 003-011 | ISZ13 CM2150 | 4022133
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Brake | Refer to Procedure 020-024 | ISM11 CM876 SN | 4022196
Engine Brake | Refer to Procedure 020-024 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake harness and solenoids. |
 | STEP 1A. Inspect the connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the engine brake harness and solenoid for an open circuit | Between 5 and 15 ohms?
 | STEP 1C. Check the engine brake harness for an open circuit. | Less than 5 ohms?
 | STEP 1D. Check the engine brake solenoid for an open circuit. | Between 5 and 15 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for an open circuit. | Greater than 5.0-VDC?
 | STEP 2B. Inspect the ECM and engine harness connector pins.. | Dirty or damaged pins
 | STEP 2C. Check the diagnostic voltage at the ECM. | Greater than 5.0-VDC?
 | STEP 2D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit in the engine harness. | More than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault codes. | Fault code inactive?

Guided Step 1 - Check the engine brake harness and solenoids.

Guided Step 1A - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Inspect the engine harness and engine brake connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the engine brake harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid Number 2 SIGNAL pin of the engine brake connector to engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine brake harness for an open circuit.

Conditions

  • Turn keyswitch OFF. Remove the engine rocker lever cover.
  • Disconnect the engine harness from the engine brake connector.
  • Refer to Procedure 003-011 in the Associated Procedure Table.
  • Disconnect the engine brake wiring harness from engine brake solenoid number 2.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance of the engine brake harness from the engine brake solenoid Number 2 SIGNAL pin of the engine brake connector to the solenoid connector pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 1D

Go to 3A

Guided Step 1D - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF. Remove the engine rocker lever cover.
  • Disconnect the engine harness from the engine brake connector.
  • Refer to Procedure 003-011 in the Associated Procedure Table.
  • Disconnect the engine brake wiring harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the engine brake solenoid terminal pin to engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-024 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the engine harness for an open circuit.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin in the internal actuator harness connector of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 2D

Guided Step 2D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance of the engine brake solenoid Number 2 SIGNAL wire between the ECM connector and the engine brake connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the engine harness..

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid Number 2 SIGNAL pin in the ECM connector to all other pins in the connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes relate dto this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revison number is found in the Calibration Information section of System ID and Dataplate in Feature & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2012


FAULT CODE 2367 (Midrange) - Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 AN | 4022178
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 AN | 4021704
Rocker Lever Cover | Refer to Procedure 003-011 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2367 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2367 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the engine brake solenoid to the engine brake solenoid number 2 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 SIGNAL circuit has been detected in the engine harness. The open circuit is in one of the following harnesses:

  • The main engine harness between the ECM and the 2 pin connector at the back of the engine.
  • The engine brake jumper harness between the engine harness 2 pin connector at the back of the engine and the rocker level housing.
  • The internal engine brake harness between the rocker lever housing and the engine brake solenoid.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3B

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL wire has been detected in the engine.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid terminal pin-to-ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 1.
  • Turn keyswitch ON.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Set delay time to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Jan-2016


FAULT CODE 2369 - Engine (Exhaust) Brake Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E/ISF2.8 CM2220 AN | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220/ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E/ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220/ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2369 inactive?
STEP 2. | Check the exhaust brake relay and circuit. |
 | STEP 2A. Inspect the exhaust brake relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2371 active and Fault Code 2369 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2369 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the OEM power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2369 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2369 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust brake relay and circuit.

Guided Step 2A - Inspect the exhaust brake relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake relay from the OEM harness.

Action

Inspect the OEM harness and exhaust brake relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake relay from the engine harness.
  • Turn keyswitch ON.Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2371 active and Fault Code 2369 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust brake relay to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2369 active?
YES NO

A malfunctioning exhaust brake relay has been detected.

Replace the exhaust brake relay.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the exhaust brake relay from the OEM harness.

Action

Check for a pin-to-ground short

  • Measure the resistance between the exhaust brake relay SIGNAL pin in the OEM harness ECM connector and ground.

Note: For 12 volt systems, both leads must be tested.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to- ground short circuit on the exhaust brake relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF. Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the exhaust brake relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust brake relay SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to- ground short circuit on the exhaust brake SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2369 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2012


FAULT CODE 2371 - Engine (Exhaust) Brake Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN ISF3.8 CM2220 | 4021704

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2371 inactive?
STEP 2. | Check the exhaust brake relay and circuit. |
 | STEP 2A. Inspect the exhaust brake relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the exhaust brake relay. | Less than 10 ohms?
 | STEP 2C. Check the exhaust brake diagnostic voltage, supply line, and return circuit. | Greater than 3.75-VDC?
 | STEP 2D. Check for an open circuit in the exhaust brake relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2371 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2371 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the exhaust brake relay and circuit.

Guided Step 2A - Inspect the exhaust brake relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake relay from the OEM harness.

Action

Inspect the OEM harness and exhaust brake relay connections for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the exhaust brake relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake relay from the OEM harness.

Action

Check the exhaust brake relay resistance.

  • Measure the resistance between the exhaust brake SIGNAL pin and the exhaust brake RETURN pin at the exhaust brake relay.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the exhaust brake relay.

Replace the exhaust brake relay.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the exhaust brake diagnostic voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the exhaust brake supply voltage and return circuit.

  • Measure the voltage between the exhaust brake relay SIGNAL line and the exhaust brake relay RETURN line at the exhaust brake relay connector of the OEM harness.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the exhaust brake relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust brake relay RETURN pin at the exhaust brake relay connector to ground.

Use the circuit diagram or the wiring diagram for connector pins identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness, if possible.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the exhaust brake relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector exhaust brake relay SIGNAL pin and the OEM harness exhaust brake relay connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pins identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open exhaust brake relay SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the exhaust brake from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust brake relay SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use the circuit diagram or the wiring diagram for connector pins identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the exhaust brake relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2371 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2012


FAULT CODE 2372 - Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Filter (Cartridge Type) | Refer to Procedure 006-074 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISF2.8 CM2220 ISF2.8 CM2220 AN | 4022178

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2372 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the fuel filter. |
 | STEP 2A. Measure the pressure drop across the fuel filter. | Pressure drop across the fuel filter less than 27.5 kPa [4 psi]??
STEP 3. | Check the fuel inlet restriction. |
 | STEP 3A. Measure the fuel inlet restriction. | Fuel inlet restriction less than the specification?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the fuel filter.

Guided Step 2A - Measure the pressure drop across the fuel filter.

Conditions

  • Turn keyswitch ON.
  • Operate engine at high idle.

Action

Measure the pressure drop across the fuel filter while the engine is operating at high idle.

  • Measure the fuel restriction at the fuel filter inlet. This will be the high-pressure reading.
  • Measure the fuel restriction at the fuel filter outlet. This will be the low-pressure reading.
  • Record the fuel filter outlet restriction value and subtract it from the previously measured fuel filter inlet restriction.
  • Refer to Procedure 006-074 in the Associated Procedures Table.

Pressure drop across the fuel filter less than 27.5 kPa [4 psi]?
YES NO
No Repair

Replace the fuel filter.

  • Refer to Procedure 006-074 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel inlet restriction.

Guided Step 3A - Measure the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Measure the restriction.

  • Measure the fuel inlet restriction.
  • Refer to Procedure 006-020 in the Associated Procedures Table.

Fuel inlet restriction less than the specification?
YES NO
No Repair

Replace or repair the line restriction.

Make certain there are no kinks or bends in the fuel lines and that the fuel lines are not clogged.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 03-Feb-2017


FAULT CODE 2387 - Variable Geometry Turbocharger Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Turbocharger | Refer to Procedure 010-033 | ISL8.9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL8.9 CM2150 SN | 4022190
Exhaust Restriction | Refer to Procedure 011-009 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To prevent damage to the turbocharger actuator, be sure to drain the coolant before removing the actuator.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for previous variable geometry turbocharger actuator removals. | Actuator been removed or replaced?
 | STEP 1C. Check exhaust restriction. | Exhaust restriction greater than 308 mm Hg [12 in Hg]?
STEP 2. | Check the variable geometry turbocharger actuator. |
 | STEP 2A. Inspect the variable geometry turbocharger actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the variable geometry turbocharger actuator. | Gear broken on the variable geometry turbocharger actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Sector gear gauge to determine if nozzle movement meets the requirements according to Procedure 010-134 in Section 10?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2387.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
YES NO
No Repair

No troubleshooting is necessary. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous variable geometry turbocharger actuator removals.

Conditions

Not applicable

Action

Check for previous replacements.

  • Determine if the actuator has been removed or replaced and Fault Code 2387 is active.

Has the actuator been removed or replaced?
YES NO

Remove the actuator and install it in the correct position.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check exhaust restriction.

Conditions

  • Install a pressure gauge into the exhaust system.
  • Turn keyswitch ON.
  • Run engine at rated horsepower and rpm.

Action

Check exhaust restriction by installing a pressure gauge into the exhaust system, just past the turbocharger outlet.

If a port is not found in the exhaust system, remove the aftertreatment selective catalytic reduction intake temperature sensor and install the pressure gauge in the temperature sensor port.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Is exhaust restriction greater than 308 mm Hg [12 in Hg]?
YES NO

Inspect the exhaust piping for damage. Refer to the OEM service information.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the variable geometry turbocharger actuator.

Guided Step 2A - Inspect the variable geometry turbocharger actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.

Action

Inspect the engine harness and variable geometry turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the variable geometry turbocharger actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the variable geometry turbocharger actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the variable geometry turbocharger actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Check for a broken drive gear on the variable geometry turbocharger actuator.

Gear is broken on the variable geometry turbocharger actuator?
YES NO

A damaged gear has been detected on the variable geometry turbocharger actuator.

Replace the variable geometry turbocharger actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger bearing housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Sector gear gauge to determine if nozzle movement meets the requirements according to Procedure 010-134 in Section 10?
YES NO

A damaged VGT actuator has been detected.

Replace the VGTr actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger assembly.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary overview of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete

Escalate or call for assistance.

Last Modified: 29-Jun-2017


FAULT CODE 2398 - Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, AND ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, AND ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2398 active?
 | STEP 1B. Check for Fault Codes 249 and 256. | Fault Code 249 or 256 active?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active?
 | STEP 2C. Check the circuit response. | Fault Code 256 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2398 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 249 and 256.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 or 256 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the ambient air temperature sensor SIGNAL pin and the ambient air temperature sensor RETURN pin at the ambient air temperature sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

An in-range malfunction of the ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Use a wiring diagram for pin identificaton and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 21-Mar-2012


FAULT CODE 2412 - Fan Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2412 inactive?
STEP 2. | Check for a failed fan speed sensor. |
 | STEP 2A. Inspect the original equipment harness (OEM) harness connector to the fan speed sensor. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the fan speed sensor. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the engine control module (ECM) and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check the fault codes. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Fault Code 2412 come active during engine operation?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the repair. | Fault Code 2412 inactive?
 | STEP 5B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2412 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a failed fan speed sensor.

Guided Step 2A - Inspect the OEM harness connector to the fan speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan speed sensor.

Action

Inspect the fan speed sensor connector, the OEM harness connector, and the fan speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the fan speed sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the fan speed sensor from the OEM harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the fan speed SIGNAL (+) pin on the sensor to engine block ground.

Use the wiring diagram for connector pin identification. Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The fan speed sensor is shorted to ground.

Replace the fan speed sensor.

Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the fan speed sensor to the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan speed sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fan speed SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Use the wiring diagram for connector pin identification. Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the fan speed sensor to the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the fan speed SIGNAL (+) pin at the OEM harness ECM connector to engine block ground.

Use the wiring diagram for connector pin identification. Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the fan speed sensor circuit. Inspect the OEM harness for a short to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the fan speed sensor to the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the fan speed SIGNAL (+) pin of the OEM harness ECM connector to all other pins in the connector except the fan speed RETURN (-) pin.

Use the wiring diagram for connector pin identification. Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the fault codes.

Guided Step 4A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch OFF.
  • Connect the fan speed sensor to the OEM harness.
  • Connect the OEM harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle and high idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

NOTE: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Fault Code 2412 come active during engine operation?
YES NO

Replace the fan speed sensor.

Refer to the OEM service manual.

An intermittent fault condition exists.

The problem may exist in the fan speed sensor circuit or it may exist with other vehicle electronic components. The problem may have been corrected when the harness connections were re-engaged.

Be certain the ECM and chassis grounds are in good condition.

Go to 5A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2412 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Sep-2013


FAULT CODE 2634 - Variable Geometry Turbocharger Actuator Controller - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check variable geometry turbocharger actuator installation. |
 | STEP 1A. Check for previous variable geometry turbocharger actuator removals. | VGT actuator recently been removed or replaced?
 | STEP 1B. Check the variable geometry turbocharger actuator. | Variable geometry turbocharger actuator removed from the turbocharger and the keyswitch ON?
 | STEP 1C. Disconnect and connect variable geometry turbocharger actuator connector. | Fault Code 2634 inactive after disconnecting and connecting the variable geometry turbocharger actuator connector?
STEP 2. | Check the variable geometry turbocharger actuator. |
 | STEP 2A. Inspect the variable geometry turbocharger actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check variable geometry turbocharger actuator installation.

Guided Step 1A - Check for previous variable geometry turbocharger actuator removals.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The VGT actuator has recently been removed or replaced and Fault Codes 2634 and 2449 are active.

  • Fault Codes 2449 and 2634 are active.

VGT actuator recently been removed or replaced?
YES NO

Remove the actuator and install it in the correct position. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check variable geometry turbocharger actuator.

Conditions

  • Not Applicable

Action

Check for correct variable geometry turbocharger actuator installation.

VGT actuator removed from the turbocharger and the keyswitch ON?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Disconnect and connect variable geometry turbocharger actuator connector.

Conditions

  • Not Applicable

Action

If the variable geometry turbocharger actuator is removed from the turbocharger and the keyswitch is ON with the wiring harness connected to the variable geometry turbocharger actuator, Fault Code 2634 will be active. Follow the procedures below:

  • Turn keyswitch ON.
  • Disconnect the variable geometry turbocharger actuator from the engine harness and connect.

NOTE: Fault Code 2636 will be active temporarily when the turbocharger actuator is disconnected.

Fault Code 2634 is inactive after disconnecting and connecting the variable geometry turbocharger actuator connector?
YES | NO
No Repair | No Repair

Repair complete

Go to 2A

Guided Step 2 - Check the variable geometry turbocharger actuator.

Guided Step 2A - Inspect the variable geometry turbocharger actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.

Action

Inspect the engine harness and variable geometry turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

A damaged variable geometry turbocharger actuator has been detected.

Replace the variable geometry turbocharger actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2012


FAULT CODE 2636 - VGT Actuator Driver Circuit - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Vaiable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for active fault codes | Fault code 2636 active?
STEP 2. | Check the VGT actuator and circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the VGT actuator. | Voltage is within 1-VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine CPL?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the VGT actuator battery voltage supply. | Voltage is within 1-VDC of battery voltage?
STEP 4. | Check the J1939 data link |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the AJ1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 datalink harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 110 to 130 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2636 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the VGT actuator and circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques reference the Component Connector and Pin Inspection. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the VGT actuator, or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator Battery Voltage SUPPLY circuit and the VGT actuator Battery Voltage RETURN circuit at the VGT actuator wiring harness connector.

Note: Check the voltage at key-ON, while cranking the engine, and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 4A

Go to 5A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the VGT actuator battery voltage supply

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Check for an open circuit

  • Measure the voltage from the VGT actuator battery voltage SUPPLY pin of the engine wiring harness connector to engine block ground.

Note: Check the voltage at key-ON, while cranking the engine and with the engine at idle.

Refer to the wiring diagaram for connector pin identification.

For general inspection techniques reference the Component Connector and Pin Inspection. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the VGT actuator battery voltage RETURN circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the VGT actuator battery voltage RETURN circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in the Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

Measure the resistance between the SAE J1939 data link (+) wire at the VGT actuator wiring harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.

Measure the resistance between the SAE J1939 data link (-) wire at the VGT actuator wiring harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine wiring harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.

Measure the resistance between the SAE J1939 data link (−) wire at the ECM engine harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (−) pins.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the damaged component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine wiring harness
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.

Measure the resistance between the SAE J1939 data link (−) wire at the ECM engine harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the damaged component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the VGT actuator.

  • Measure the resistance between the VGT actuator J1939 data link (+) wire and the VGT actuator J1939 data link (-) wire at the VGT actuator connector.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the engine harness.

Remove the additional terminating resistance or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in VGT actuator.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 21-Mar-2012


FAULT CODE 2719 - Brake Inactivity - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Anti-Lock braking system (ABS) and/or electronic shift control (ESC) warning lamp/s on or vehicle speed fault codes active?
STEP 2. | Interview the customer. |
 | STEP 2A. Interview the customer. | Customer coast to a near stop without using the service brake?
STEP 3. | Check the brake switch and circuit. |
 | STEP 3A. Check the brake switch. | Brake switch status changing correctly?
 | STEP 3B. Inspect the brake switch and connector pins. | Dirty or damaged pins?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

ABS and/or ESC warning lamp/s on or vehicle speed fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Interview the customer.

Guided Step 2A - Interview the customer.

Conditions

  • The diagnostic design is to detect a faulty brake switch.

Action

Diagnostic runs when vehicle speed is above 48 kmh (30 mph) for more than five minutes.

  • Fault code will set when vehicle speed is detected at 3 kmh (2 mph) or less without brake activity.

Customer coast to a near stop without using the service brake?
YES NO

Explain the diagnostic operation to the customer.

 No Repair

Repair Complete

Go to 3A

Guided Step 3 - Check the brake switch and circuit.

Guided Step 3A - Check the brake switch.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the brake switch position while cycling the brake pedal.

  • Use INSITE™ electronic service tool to monitor switch status.

Brake switch status changing correctly?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the brake switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake switch from the equipment manufacturer harness.

Action

Inspect the OEM harness and brake switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

  • Repair or replace the equipment manufacturer harness, or replace the sensor, whichever has the damaged pins. See the equipment manufacturer service information.

A damaged switch has been detected.

Replace the brake switch. See the equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2016


FAULT CODE 2771 - Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISM11 CM876 SN | 4022196
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes | Fault Code 2771 inactive?
STEP 2. | Check the aftertreatment outlet Mono-Nitrogen Oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor body and condition of the aftertreatment outlet NOx sensor harness. | Any external damage to the sensor body, head (component installed on the exhaust gas processor) or harness?
 | STEP 2B. Inspect the aftertreatment outlet NOx sensor and connector pins. | Damaged or dirty pins?
 | STEP 2C. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 - volt of direct current (VDC) of battery voltage?
 | STEP 2D. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2E. Check for correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor the correct sensor for the engine CPL?
STEP 3. | Check the original equipment manufacturer (OEM) harness battery power circuit |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Verify that the OEM fuse in installed correctly. | Is the fuse installed correctly, or has it been replaced?
 | STEP 3C. Check for an open circuit in the battery power circuit. | Voltage is within 1-VDC of battery voltage?
STEP 4. | Check the OEM harness |
 | STEP 4A. Inspect the ECM and OEM harness connector pins. | Damaged or dirty pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Voltage is within 1-VDC of battery voltage?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the fault codes. | Fault Code 2771 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet Mono-Nitrogen Oxides (NOx) sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor body and condition of the aftertreatment outlet NOx sensor harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment outlet NOx sensor body and the aftertreatment outlet NOx sensor harness.

  • Inspect the aftertreatment outlet NOx sensor body and aftertreatment outlet NOx sensor harness for cracks or damage.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any external damage to the sensor body, head (component installed on the exhaust gas processor) or harness?
YES NO

Replace the NOx sensor. Refer to procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor return circuit at the NOx sensor wiring harness connector.

Note: Check the voltage at key-ON, while cranking the engine, and with the engine at idle.

Note: 24-VDC NOx sensors will operate between 14 and 32-VDC. 12-VDC NOx sensors will operate between 6 and 16.5-VDC.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for instructions on how to use a multimeter. Refer to Procedure 019-359 in Section 19.

Voltage within 1 - volt of direct current (VDC) of battery voltage?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2DCheckforcorrrectadjustableparametersettings -

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine control parts list (CPL)?
YES NO
No Repair

To configure the electrical system voltage to match the engine CPL, use INSITE™ electronic service tool.

Go to 2E

Go to 4A

Guided Step 2ECheckforcorrectaftertreatmentoutletNOxsensor. -

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor the correct sensor for the engine CPL.

Note: The aftertreatment outlet NOx sensor is available in 12-VDC or 24-VDC versions.

Aftertreatment outlet NOx sensor the correct sensor for the engine CPL?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor. Refer to procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Tighten the connections.

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Verify that the OEM fuse in installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

The aftertreatment outlet NOx sensor power supply wire contains a 20 amperes fuse. This fuse is located in the OEM harness.

  • Inspect the OEM fuse for correct installation, or for a blown fuse.

Is the fuse installed correctly, or has it been replaced?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the aftertreatment outlet NOx sensor SUPPLY (+) pin of the OEM harness to engine block ground.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Note: 24-VDC NOx sensors will operate between 14 and 32-VDC. 12-VDC NOx sensors will operate between 6 and 16.5-VDC.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit in the OEM battery return circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the battery supply circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (−) wire at the ECM OEM harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM OEM harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (−) pins.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An short circuit has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An short circuit to ground has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the aftertreatment outlet NOx sensor OEM harness connector.

50 to 70 ohms?
YES NO
No Repair

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness. Refer to the OEM service manual.

Go to 4F

Go to 5A

Guided Step 4F - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM connector.
  • Connect the aftertreatment outlet NOx sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Oct-2012


FAULT CODE 2772 (Air-assisted) - Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Exhaust Restriction | Refer to Procedure 011-009 | ISL8.9 CM2150 SN | 4022190
Exhaust Restriction | Refer to Procedure 011-009 | ISM11 CM876 SN | 4022196
Exhaust Restriction | Refer to Procedure 011-009 | ISZ13 CM2150 | 4022133
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISM11 CM876 SN | 4022196
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISZ13 CM2150 | 4022133
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISM11 CM876 SN | 4022196
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISB6.7 CM2150 SQ | 2883504
Aftertreatment Diesel Exhaust Fluid Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the fault codes. |
 | STEP 1A. Check for active counts of Fault Code 1694. | Fault Code 1694 Active?
 | STEP 1B. Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738. | Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?
STEP 2. | Check the aftertreatment catalyst system. |
 | STEP 2A. Inspect the aftertreatment catalyst system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the exhaust back pressure. | Exhaust back pressure exceeds the limits provided in Procedure 011-009?
 | STEP 2C. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the diesel exhaust fluid dosing unit. |
 | STEP 3A. Check the diesel exhaust fluid (DEF) dosing unit during priming. | Dosing unit only prime for 30 seconds? (Plus the 140 second prime delay if applicable)
 | STEP 3B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute [6.6 gal per minute]?
STEP 4. | Check the diesel exhaust fluid dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the diesel exhaust fluid dosing unit. | OEM air supply correctly attached to the diesel exhaust fluid dosing unit and supplying adequate air pressure?
 | STEP 4B. Clear the diesel exhaust fluid dosing unit air side circuit. Carry out the flushing procedure. | Flushing procedure successful?
STEP 5. | Check the diesel exhaust fluid lines and fittings for restriction and contamination. |
 | STEP 5A. Check the diesel exhaust fluid dosing unit fittings and lines. | Diesel exhaust fluid fittings and lines pass the inspections?
 | STEP 5B. Check the diesel exhaust fluid dosing lines for restrictions or leaks. | Restriction line test completed successfully?
 | STEP 5C. Inspect the diesel exhaust fluid tank and the 35 micron tank filter. | DEF tank contaminated or the urea solution less than 32.5%?
STEP 6. | Perform the Diesel Exhaust Fluid Doser Pump Override Test. |
 | STEP 6A. Perform the Diesel Exhaust Fluid Dosing Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test 3 times)
 | STEP 6B. Inspect the diesel exhaust fluid dosing unit inline screen filter connection. | Contamination present at the screen filter?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the fault codes.

Guided Step 1A - Check for active counts of Fault Code 1694.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • Check for active Fault Code 1694.

Fault Code 1694 active?
YES NO

Troubleshoot Fault Code 1694 before returning to this troubleshooting tree.

No Repair

Fault Code 1694 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check for inactive counts of Fault Code 1682, 3548, 3569, 3575 or 3738 in the ECM.

  • Look specifically for one or more inactive counts of Fault Code 1682, 3548, 3569, 3575 or 3738 within 50 engine hours of this fault code being set.

Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?

YES NO

Troubleshooting Fault Code 1682, 3548, 3569, 3575, or 3738 before returning to this fault code troubleshooting tree.

 No Repair

Fault Code 1682, 3548, 3569, 3575 or 3738 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment catalyst system.

Guided Step 2A - Inspect the aftertreatment catalyst system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment catalyst system.

  • Inspect aftertreatment catalyst and all attached exhaust pipework for signs of exhaust gas leakage or damage.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Measure the exhaust back pressure.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust back pressure exceeds the limits provided in Procedure 011-009?
YES NO

Repair source or replace the aftertreatment SCR catalyst.

  • Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 2C

Guided Step 2C - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Refer to Procedure 011-040 in the Associated Procedure Table.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedure Table.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedure Table.
  • Soft crystal and ash-like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Make sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Clean or replace the aftertreatment nozzle.

Refer to Procedure 011-040 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the diesel exhaust fluid dosing unit.

Guided Step 3A - Check the diesel exhaust fluid dosing unit during priming.

Conditions

  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check the diesel exhaust fluid dosing unit during priming

  • After key ON with the engine operating, listen for the diesel exhaust fluid dosing pump to start.
  • Time the pump operation until the pump automatically switches off (The pump is attempting to prime)

Note: While the engine is operating, it may be difficult to hear the pump. If this is the case, listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

Note: Older calibrations did not incorporate the 140 second delay from key ON to initial prime cycle. During the 140 second delay, the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization built up on the injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Key ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming, this step may be attempted up to 20 times).

4. The diesel exhaust fluid injection line will now exhaust air. Priming is now complete.

Does the dosing unit only prime for 30 seconds? (Plus the 140 second prime delay if applicable)

YES NO

Complete the line restriction testing procedure then prime again. Refer to Procedure 011-086 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Make sure that the diesel exhaust fluid dosing unit has successfully primed and entered the dosing state.

  • The diesel exhaust fluid dosing unit enters the dosing state only when a successful prime is completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment DEF Dosing Unit State to confirm the doser status.

Does the air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)

YES NO
No Repair

NOTE: The diesel exhaust fluid dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle.
  • Attach the air flow meter to the diesel exhaust fluid dosing line. Refer to Procedure 011-058 the Associated Procedures Table.
  • Secure the diesel exhaust fluid dosing line and the attached air flow meter.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the diesel exhaust fluid dosing line.

Air flow above 25 liters per minute [6.6 gallons per minute]?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the diesel exhaust fluid dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the diesel exhaust fluid dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Operate the engine at low idle.

Action

Inspect the origninal equipment manufacturer (OEM) air supply line attached to the diesel exhaust fluid dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the diesel exhaust fluid dosing unit air filter for water or excessive oil from the vehicle's compressed air system.
  • Make sure a clean supply of air, at least 517 kPa [75 psi], pressure is present at the diesel exhaust fluid dosing unit.

NOTE: Most vehicles are equipped with an inline air filter in the air line prior to the diesel exhaust fluid dosing unit. A plugged or restricted inline air filter can cause low air pressure to the diesel exhaust fluid dosing unit.

OEM air supply correctly attached to the diesel exhaust fluid dosing unit and supplying adequate air pressure?
YES NO
No Repair

Correct the OEM air supply connection or supply. Refer to the OEM service manual.

Go to 4B

Go to 3A

Guided Step 4B - Clear the diesel exhaust fluid dosing unit air side circuit. Carry out the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the diesel exhaust fluid dosing unit flushing procedure.

  • Refer to Procedure 011-082 in the Associated Procedures Table.
  • Most vehicles are equipped with an inline air filter in the air line prior to the diesel exhaust fluid dosing unit. A plugged or restricted inline air filter can cause low air pressure to the diesel exhaust fluid dosing unit.

Flushing procedure successful?
YES NO
No Repair

Replace the diesel exhaust fluid dosing unit.

Go to 5A

Go to 7A

Guided Step 5 - Check the diesel exhaust fluid lines and fittings for restriction and contamination.

Guided Step 5A - Check the diesel exhaust fluid dosing unit fittings and lines.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the diesel exhaust fluid dosing unit fittings and lines for the following:

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose diesel exhaust fluid inlet connectors or fitting.
  • Cracked diesel exhaust fluid lines, resulting in leaks or drawing in air.
  • Make sure diesel exhaust fluid is returning to the tank during the priming cycle.

Diesel exhaust fluid fittings and lines pass the inspections?
YES NO
No Repair

Repair or replace diesel exhaust fluid lines and/or connectors. Refer to the OEM service manual.

Go to 5B

Go to 3B

Guided Step 5B - Check the diesel exhaust fluid dosing lines for restrictions or leaks.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Complete the line restriction procedure.

  • Refer to Procedure 011-086 in the Associated Procedures Table.
  • Check the diesel exhaust fluid lines for leaks or restrictions.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

  • Remove and check the supply and return lines.

Use the following procedure to identify the different connections on the diesel exhaust fluid dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Restriction line test completed successfully?
YES NO
No Repair

Repair or replace the diesel exhaust fluid lines and/or connectors. Refer to Procedure 011-086 in the Associated Procedures Table.

Go to 5C

Go to 3B

Guided Step 5C - Inspect the diesel exhaust fluid tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the diesel exhaust fluid tank and filters for fuel, oil, coolant, dirt, and debris.

Refer to the OEM service manual for removal / installation procedures for the DEF tank and DEF tank level sensor assembly.

NOTE: In some cases the DEF tank is bonded to the vehicle chassis leaving no access to DEF tank level sensor assembly. If this is the case then contact the OEM to arrange for the tank to be removed and inspected.

  • Inspect the contents of the tank.
  • Inspect the condition of the tank filter.
  • Check that a 35 micron tank filter is fitted. Refer to Procedure 011-083 in the Associated Procedures Table.
  • Check and record the urea concentration of the diesel exhaust fluid using a sample from the tank. Refer to Procedure 018-026 in Section V.

DEF tank contaminated or the urea solution less than 32.5%?

YES NO

Locate/remove source, inform OEM. If required replace components and connectors. Drain/refill the diesel exhaust fluid tank. Refer to the OEM service manual.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 6A - Perform the Diesel Exhaust Fluid Dosing Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in the Associated Procedures Tabl e.
  • Check to make sure that the diesel exhaust fluid is being injected through the aftertreatment nozzle during the dosing state.

NOTE: The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container greater than 200 ml [6.8 oz] capacity to perform the Diesel Exhaust Fluid Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test 3 times)

YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the diesel exhaust fluid dosing unit inline screen filter connection.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the diesel exhaust fluid dosing unit inline screen filter connection.

  • Remove the diesel exhaust fluid dosing unit supply line.
  • Inspect the inlet screen filter. Refer to procedure 011-060 the Associated Procedures Table.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the diesel exhaust fluid dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Contamination present at the screen filter?
YES NO

Replace the screen filter. Refer to procedure 011-060 the Associated Procedures Table.

A damaged diesel exhaust fluid dosing unit has been detected. Replace the diesel exhaust fluid dosing unit.

  • Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 6A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Nov-2013


FAULT CODE 2772 (Airless) - Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Perform basic troubleshooting procedures. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Perform basic troubleshooting checks. | All steps have been verified to be correct?
STEP 2. | Check the aftertreatment system. |
 | STEP 2A. Inspect the DEF system for external leaks. | External leaks detected in the system?
 | STEP 2B. Inspect the DEF lines. | Plugged or restricted DEF lines detected?
 | STEP 2C. Inspect the aftertreatment DEF dosing valve. | Plugged or restricted aftertreatment DEF dosing valve detected?
 | STEP 2D. Check the DEF tank for contamination. | DEF contaminated or diluted?
 | STEP 2E. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates correctly during INSITE™ electronic service tool override tests?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Perform basic troubleshooting steps.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Troubleshoot any other active fault codes first.
  • All other active fault codes must be resolved before following this troubleshooting tree.

Active fault codes present?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Perform basic troubleshooting checks.

Conditions

  • Turn keyswitch OFF.

Action

The following items must be checked or verified before continuing:

  • Verify there have not been any changes to CPL components on the engine.
  • Verify the fuel grade is correct for the application. Refer to Fuels for Cummins® Engines, Bulletin 3379001.
  • Verify that the engine has been operating on Ultra Low Sulfur Diesel (10 ppm for Europe and 50ppm for China)
  • Confirm that the catalyst part number is correct for the CPL.
  • Confirm and verify the DEF quality is correct for the application. Refer to Fleetguard® Selective Catalytic Reduction - DEF Specifications, Bulletin 4021566.
  • Confirm that the correct aftertreatment outlet NOx sensor part number is installed.

All steps have been verified to be correct?
YES NO
No Repair

Correct the damage and verify the complaint is no longer present after the repair.

NOTE: High sulfur diesel fuel can foul the SCR catalyst and increase NOx. Replace the diesel fuel with ULSD fuel and operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure to disable this fault code. If Fault Code 2773 becomes active, replace the aftertreatment SCR catalyst due to damage from the incorrect diesel fuel.

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment system.

Guided Step 2A - Inspect the DEF system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment system.

  • Inspect the DEF lines and DEF tank for external leaks.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the DEF lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the DEF lines.

  • Inspect the DEF lines for kinks, plugging, and/or restrictions.

Plugged or restricted DEF lines detected?
YES NO

Repair or replace the DEF lines.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Action

Inspect the aftertreatment DEF dosing valve for plugging or restrictions.

Refer to Procedure 011-059 in the Associated Procedures Table.

Plugged or restricted aftertreatment DEF dosing valve detected?
YES NO

Clean or replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the DEF tank for contamination.

  • Make sure that the DEF has not been diluted and is at the correct mixture.
  • Confirm and verify the DEF quality is correct for the application. Refer to Fleetguard® Selective Catalytic Reduction - DEF Specifications, Bulletin 4021566.

DEF is contaminated or diluted?
YES NO

Remove and clean the DEF tank.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-058 in the Associated Procedure Table.

NOTE: The DEF dosing valve must be removed and placed in a measuring container in order to run the DEF Doser Pump Override Test. Make sure the DEF dosing unit is not plugged and DEF is flowing from all holes.

The aftertreatment DEF dosing unit operates correctly during INSITE™ electronic service tool override tests?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

The present ECM code and revision number in the ECM can be found using INSITE™ electronic service tool. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2012


Fault Code 2773 (Air-assisted) - Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Exhaust Restriction | Refer to Procedure 011-009 | ISL8.9 CM2150 SN | 4022190
Exhaust Restriction | Refer to Procedure 011-009 | ISM11 CM876 SN | 4022196
Exhaust Restriction | Refer to Procedure 011-009 | ISZ13 CM2150 | 4022133
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISM11 CM876 SN | 4022196
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISZ13 CM2150 | 4022133
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISM11 CM876 SN | 4022196
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISZ13 CM2150 | 4022133
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133
Aftertreatment DEF Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISB6.7 CM2150 SQ | 2883504
Aftertreatment DEF Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit Extended Priming | Refer to Procedure 019-476 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the fault codes. |
 | STEP 1A. Check for active counts of Fault Code 1694. | Fault Code 1694 active?
 | STEP 1B. Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738. | Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?
 | STEP 1C. Check the remaining active/inactive fault codes. | Active fault codes or performance complaints present? (With the exception of Fault Code2772)
STEP 2. | Check the aftertreatment catalyst system. |
 | STEP 2A. Inspect the aftertreatment catalyst system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the exhaust back pressure. | Exhaust back pressure exceeds the limits provided in Procedure 011-009?
 | STEP 2C. Check the aftertreatment selective catalytic reduction (SCR) catalyst. | SCR catalyst present, not damaged, and not found to be broken up?
 | STEP 2D. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 3A. Check the DEF dosing unit during priming. | Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay if applicable)
 | STEP 3B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute [6.6 gal per minute]?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Clear the DEF dosing unit air side circuit. Carry out the flushing procedure. | Flushing procedure successful?
STEP 5. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 5A. Check the DEF dosing unit fittings and lines. | Did the DEF fittings and lines pass the inspections?
 | STEP 5B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at the screen filter?
 | STEP 5C. Inspect the DEF tank and the 35 micron tank filter. | DEF tank contaminated or the urea solution less than 32.5%?
STEP 6. | Perform the DEF Doser Pump Override Test. |
 | STEP 6A. Perform the DEF Dosing Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test 3 times)
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the fault codes.

Guided Step 1A - Check for active counts of Fault Code 1694.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • Check for active counts of Fault Code 1694.

Fault Code 1694 active?
YES NO

Troubleshoot Fault Code 1694 before returning to this troubleshooting tree.

No Repair

Fault Code 1694 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 in the ECM.

  • Look specifically for one or more inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 within 50 engine hours of this fault code being set.

Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?

YES NO

Troubleshoot Fault Code 1682, 3548, 3569, 3575, or 3738 before returning to this fault code troubleshooting tree.

 No Repair

Fault Code 1682, 3548, 3569, 3575, or 3738 troublshooting tree.

Go to 1C

Guided Step 1C - Check the remaining active/inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Troubleshoot any other active fault codes first.
  • All other active fault codes except Fault Code 2772 must be resolved before following this troubleshooting tree.
  • Check for performance complaints
  • Troubleshoot any performance complaints related to smoke or misfire first.

NOTE: Fault Code 2773 is caused by the same symptoms as Fault Code 2772, but at a more severe level. Therefore, if both fault codes are active, Fault Code 2773 should always be addressed first.

Active fault codes or performance complaints present? (With the exception of Fault Code 2772)
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment catalyst system.

Guided Step 2A - Inspect the aftertreatment catalyst system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment catalyst system.

  • Inspect the aftertreatment catalyst and all attached exhaust pipe work for signs of exhaust gas leakage or damage.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Measure the exhaust back pressure.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust back pressure exceeds the limits provided in Procedure 011-009?
YES NO

Repair source or replace the aftertreatment SCR catalyst.

  • Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 2C

Guided Step 2C - Check the aftertreatment SCR catalyst.

Conditions

  • Turn keyswitch OFF.

Action

Make sure that the SCR catalyst is present in the exhaust stream.

Remove the aftertreatment SCR catalyst.

  • Refer to Procedure 011-036 in the Associated Procedures Table.

Inspect the aftertreatment SCR catalyst. If the aftertreatment SCR catalyst has broken up, then a significant mass of broken material will move around inside the assembly when the catalyst is tilted or moved.

SCR catalyst present, not damaged, and not found to be broken up?

YES NO
No Repair

Replace the aftertreatment SCR catalyst.

  • Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 2D

Go to 7A

Guided Step 2D - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Soft crystal and ash-like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Make sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Clean or replace the aftertreatment nozzle.

Refer to Procedure 011-040 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the DEF dosing unit.

Guided Step 3A - Check the diesel exhaust fluid dosing unit during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • After key ON with the engine operating, listen for the DEF dosing pump to start.
  • Time the pump operation until the pump automatically switches off (the pump is attempting to prime).

NOTE: While the engine is operating it may be difficult to hear the pump, if this is the case listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

NOTE: Older calibrations did not incorporate the 140 second delay from key on to initial prime cycle. During the 140 second delay the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization buildup on the injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Key ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming, this step may be attempted up to 20 times).

4. The DEF injection line will now exhaust air. Priming is now complete.

Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay if applicable)

YES NO

Complete line restriction testing procedure then prime again. Refer to Procedure 011-086 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Make sure that the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is has completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment Diesel Exhaust Fluid Dosing Unit State to confirm the doser status.

Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)

YES NO
No Repair

NOTE: The DEF dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Secure the DEF dosing line and the attached air flow meter.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 liters per minute [6.6 gallons per minute]?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Operate the engine at low idle.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for water or excessive oil from the vehicle's compressed air system.
  • Make sure a clean supply of air, at least 517 kPa [75 psi], pressure is present at the DEF dosing unit.

NOTE: Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Correct the OEM air supply connection or supply. Refer to the OEM service manual.

Go to 4B

Go to 3A

Guided Step 4B - Clear the DEF dosing unit air side circuit. Carry out the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the DEF dosing unit flushing procedure.

  • Refer to Procedure 011-082 in the Associated Procedures Table.
  • Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Flushing procedure successful?
YES NO
No Repair

Replace the DEF dosing unit.

Go to 5A

Go to 7A

Guided Step 5 - Check the DEF lines and fittings for restriction and contamination.

Guided Step 5A - Check the DEF dosing unit fittings and lines.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit fittings and lines for the following:

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fittings
  • Cracked DEF lines, resulting in leaks or drawing in air
  • Be sure DEF is returning to the tank during the priming cycle.

DEF fittings and lines pass the inspections?
YES NO
No Repair

Repair or replace DEF lines and/or connectors. Refer to the OEM service manual.

Go to 5B

Go to 3B

Guided Step 5B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the DEF dosing unit supply line.
  • Inspect the inlet screen filter. Refer to Procedure 011-060 in the Associated Procedures Table.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Contamination present at the screen filter?
YES NO

Replace the screen filter.

 No Repair

Go to 5C

Go to 5C

Guided Step 5C - Inspect the DEF tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

  • Inspect the contents of the tank.
  • Inspect the condition of the tank filter. Refer to Procedure 011-083 in the Associated Procedures Table.
  • Check and record the urea concentration of the DEF using a sample from the tank. Refer to Procedure 018-026 in Section V.

DEF tank contaminated or the urea solution less than 32.5%?

YES NO

Locate/remove source, inform OEM. If required, replace components and connectors. Drain/refill the DEF tank. Refer to OEM service manual.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 6A - Perform the Diesel Exhaust Fluid Dosing Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

NOTE: The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container larger than 200 ml [6.8 oz] capacity to perform the Diesel Exhaust Fluid Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test 3 times)

YES NO
No Repair

A damaged diesel exhaust fluid dosing unit has been detected. Replace the diesel exhaust fluid dosing unit.

  • Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 2773 (Airless) - Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Perform basic troubleshooting procedures. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Perform basic troubleshooting checks. | All steps have been verified to be correct?
STEP 2. | Check the aftertreatment system. |
 | STEP 2A. Inspect the DEF system for external leaks. | External leaks detected in the system?
 | STEP 2B. Inspect the DEF lines. | Plugged or restricted DEF lines detected?
 | STEP 2C. Inspect the aftertreatment DEF dosing valve. | Plugged or restricted aftertreatment DEF dosing valve detected?
 | STEP 2D. Check the DEF tank for contamination. | DEF is contaminated or diluted?
 | STEP 2E. Check the aftertreatment DEF dosing unit for proper operation. | DEF dosing unit operates correctly during INSITE™ electronic service tool override tests?
 | STEP 2F. Check the aftertreatment SCR catalyst. | SCR catalyst present, not damaged, and does not rattle when tilted or moved?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Perform basic troubleshooting steps.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • All other active fault codes must be resolved before following this troubleshooting tree.
  • All other active fault codes except Fault Code 2772 must be resolved before following this troubleshooting tree.

Active fault codes present?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Perform basic troubleshooting checks.

Conditions

  • Turn keyswitch OFF.

Action

The following items must be checked or verified before continuing:

  • Verify there have not been any changes to CPL components on the engine.
  • Verify the fuel grade is correct for the application. Use Fuels for Cummins® Engines Service Bulletin. Refer to Bulletin Number 3379001.
  • Verify that the engine has been operating on Ultra Low Sulfur Diesel (10 ppm for Europe and 50 ppm for China)
  • Confirm that the catalyst part number is correct for the CPL.
  • Confirm and verify the DEF solution quality is correct for the application. Use Fleetguard® Selective Catalytic Reduction - DEF Specifications. Refer to Bulletin Number 4021566.
  • Confirm that the correct aftertreatment outlet NOx sensor part number is installed.

All steps have been verified to be correct?
YES NO
No Repair

Correct the damage and verify the complaint is no longer present after the repair.

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment system.

Guided Step 2A - Inspect the DEF system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment system.

  • Inspect the DEF lines and DEF tank for external leaks.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the DEF lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the DEF lines.

  • Inspect the DEF lines for kinks, plugging, or other restrictions.

Plugged or restricted DEF lines detected?
YES NO

Repair or replace the DEF lines.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Action

Inspect the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Plugged or restricted aftertreatment DEF dosing valve detected?
YES NO

Clean or replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedure Table.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Make sure that the DEF has not been diluted and is at the correct mixture.

Confirm and verify the DEF quality is correct for the application. Use Fleetguard® Selective Catalytic Reduction - DEF Specifications. Reference Bulletin Number 4021566.

DEF is contaminated or diluted?
YES NO

Remove and clean the DEF tank.

No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Refer to Procedure 011-058 in the Associated Procedures Table.

Note: The DEF dosing valve must be removed and placed in a measuring container in order to run the DEF Doser Pump Override Test. Make sure that the DEF dosing valve is not plugged and DEF is flowing from all holes.

The DEF dosing unit operates correctly during INSITE™ electronic service tool override tests?
YES NO
No Repair

Replace the DEF dosing unit.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check the aftertreatment SCR catalyst.

Conditions

  • Turn keyswitch OFF.

Action

Make sure that SCR catalyst is present in the exhaust stream.

Remove the aftertreatment SCR catalyst.

  • Refer to Procedure 011-036 in the Associated Procedures Table.

Inspect the aftertreatment SCR catalyst. If the aftertreatment SCR catalyst has broken up, then a significant mass of broken material will move around inside the assembly when the catalyst is tilted or moved.

SCR catalyst present, not damaged, and does not rattle when tilted or moved?

YES NO
No Repair

Replace the aftertreatment SCR catalyst.

Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2012


FAULT CODE 2973 - Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISF2.8 CM2220 AN | 4022178
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISL8.9 CM2150 SN | 4022190
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISM11 CM876 SN | 4022196
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISZ13 CM2150 | 4022133
Charge-Air Cooler | Refer to Procedure 010-027 | ISF2.8 CM2220 AN | 4022178
Charge-Air Cooler | Refer to Procedure 010-027 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Charge-Air Cooler | Refer to Procedure 010-027 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Charge-Air Cooler | Refer to Procedure 010-027 | ISL8.9 CM2150 SN | 4022190
Charge-Air Cooler | Refer to Procedure 010-027 | ISM11 CM876 SN | 4022196
Charge-Air Cooler | Refer to Procedure 010-027 | ISZ13 CM2150 | 4022133
Exhaust Restriction | Refer to Procedure 011-009 | ISF2.8 CM2220 AN | 4022178
Exhaust Restriction | Refer to Procedure 011-009 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Exhaust Restriction | Refer to Procedure 011-009 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Exhaust Restriction | Refer to Procedure 011-009 | ISL8.9 CM2150 SN | 4022190
Exhaust Restriction | Refer to Procedure 011-009 | ISM11 CM876 SN | 4022196
Exhaust Restriction | Refer to Procedure 011-009 | ISZ13 CM2150 | 4022133
Barometric Pressure at Altitude | Refer to Procedure 018-028 | ISF2.8 CM2220 AN | 4022178
Barometric Pressure at Altitude | Refer to Procedure 018-028 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Barometric Pressure at Altitude | Refer to Procedure 018-028 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Barometric Pressure at Altitude | Refer to Procedure 018-028 | ISL8.9 CM2150 SN | 4022190
Barometric Pressure at Altitude | Refer to Procedure 018-028 | ISM11 CM876 SN | 4022196
Barometric Pressure at Altitude | Refer to Procedure 018-028 | ISZ13 CM2150 | 4022133
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 AN | 4022178
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL8.9 CM2150 SN | 4022190
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISM11 CM876 SN | 4022196
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISZ13 CM2150 | 4022133
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 AN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISF2.8 CM2220 AN | 4022178
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL8.9 CM2150 SN | 4022190
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2250 | 4022178
Turbocharger | Refer to Procedure 010-033 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Turbocharger | Refer to Procedure 010-033 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Turbocharger | Refer to Procedure 010-033 | ISL8.9 CM2150 SN | 4022190
Turbocharger | Refer to Procedure 010-033 | ISM11 CM876 SN | 4022196
Turbocharger | Refer to Procedure 010-033 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or high inactive counts of Fault Codes 122, 123, 221, 222, 295, 687, or 2345?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 51 mm Hg [2 in Hg] of local barometric pressure?
STEP 3. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 3A. Inspect the engine intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify the sensor accuracy. | INSITE™ electronic service tool reading for intake manifold pressure within 77 mm-Hg [3 in-Hg] of local barometric pressure?
 | STEP 3C. Check the circuit response. | Fault Code 123 active?
 | STEP 3D. Check the circuit response. | Fault Code 122 active?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 123 active?
 | STEP 4C. Check the circuit response. | Fault Code 122 active?
STEP 5. | Check the air intake system for leaks. |
 | STEP 5A. Check the charge-air cooler for leaks. | Air leak present?
 | STEP 5B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 5C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 5D. Check for a restricted charge-air cooler. | Differential pressure across the charge-air cooler within specifications?
STEP 6. | Check the turbocharger speed sensor. |
 | STEP 6A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 6B. Measure the turbocharger speed sensor resistance, if applicable. | Between 600 and 1600 ohms?
STEP 7. | Check exhaust restriction. |
 | STEP 7A. Check the exhaust system for restriction. | Exhaust restriction within specifications?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code and malfunction indicator lamp (MIL). | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Codes 122, 123, 221, 222, 295, 687, or 2345?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and compare to the Data Monitor/Logger.

  • Compare the barometric pressure with the intake manifold pressure at key ON.

Refer to Procedure 019-004 in the Associated Procedures Table for specifications.

INSITE™ electronic service tool reading within 51 mm Hg [2 in Hg] of local barometric pressure and intake manifold pressure?
YES NO
No Repair

Check the wiring harness for resistance.

  • Repair or replace if needed. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the barometric pressure sensor if the wiring harness is not damaged. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 8A

Guided Step 3 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 3A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor connector and the engine harness connector for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the intake manifold pressure/temperature sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold pressure/temperature sensor. Refer to the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-159 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 3B

Guided Step 3B - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Turn engine OFF.

Action

With keyswitch ON/ and engine OFF, the intake manifold pressure and barometric pressure readings must agree.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the reading for barometric pressure.
  • Use the Barometric Pressure at Altitude table, if needed. Refer to Procedure 018-028 in the Associated Procedures Table.

INSITE™ electronic service tool reading for intake manifold pressure within 77 mm-Hg [3 in-Hg] of local barometric pressure?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 3D

Go to 4A

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and the engine intake manifold pressure SIGNAL pin at the engine intake manifold pressure/temperature connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

An in-range malfunction of the intake manifold pressure/temperature sensor has been detected.

Replace the engine intake manifold pressure/temperature sensor.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 8A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and engine intake manifold pressure SIGNAL pin at the engine control module engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 5 - Check the air intake system for leaks.

Guided Step 5A - Check the charge-air cooler for leaks.

Conditions

  • Engine running.

Action

Check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component. Refer to Procedure 010-027 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 5B

Guided Step 5B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Operate engine.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 8A

Go to 5C

Guided Step 5C - Inspect turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

No Repair

Go to 8A

Go to 5D

Guided Step 5D - Check for a restricted charge-air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Differential pressure across the charge-air cooler within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler if necessary.

Go to 6A

Go to 8A

Guided Step 6 - Check the turbocharger speed sensor.

Guided Step 6A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Only perform this step if the engine is equipped with a turbocharger speed sensor. Inspect the turbocharger or refer to the engine wiring diagram to determine if the engine has a turbocharger speed sensor. If no sensor is present, skip to Step 7.

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6B

Guided Step 6B - Measure the turbocharger speed sensor resistance, if applicable.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedurer for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 7A

Go to 8A

Guided Step 7 - Check the exhaust system for restriction.

Guided Step 7A - Check exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check exhaust restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code and MIL.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 2976 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2976 inactive?
STEP 2. | Check the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Inspect the dosing unit body and condition of the harness. | Damaged dosing unit or harness?
 | STEP 2B. Inspect the DEF dosing unit connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2D. Read the fault codes. | Fault Code 2976 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2976 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in section 19.

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) dosing unit.

Guided Step 2A - Inspect the dosing unit body and condition of the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the DEF dosing unit.

Action

Inspect the OEM harness and DEF dosing unit body/casing for the following:

  • Cracked or damaged DEF dosing unit casing
  • Melting or heat damage to the DEF
  • Dosing unit melted wiring harness or connectors
  • Loose or damaged wires in the OEM wiring harness
  • Damaged fasteners or wiring harness connectors.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged dosing unit or harness?
YES NO

A damaged OEM wiring harness or DEF dosing unit has been detected.

  • Repair the damaged harness, connector, or pins if possible.
  • Replace the DEF dosing unit if damage is detected. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the DEF dosing unit connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the DEF dosing unit.

Action

Inspect the OEM harness and DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the DEF dosing unit or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Conduct a pin-to-pin continuity check in the OEM harness.

  • Measure the resistance from each pin at the DEF dosing unit connector to the corresponding pin on the ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2976 inactive?
YES NO

No Repair. Removal and Installation of the connectors has corrected the fault.

Replace the aftertreatment DEF dosing unit.

  • Use the following procedure for air-assisted selective catalytic reduction (SCR) dosing systems. Refer to Procedure 019-440 in the Associated Procedure Table.

Use the following procedure for airless SCR dosing systems. Refer to Procedure 011-058 in the Associated Procedure Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Oct-2012


FAULT CODE 3139 - Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3139 active?
STEP 2. | Check the engine air shutoff solenoid and circuit. |
 | STEP 2A. Inspect the engine air shutoff solenoid and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine air shutoff solenoid for an open circuit. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3139 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3139 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine air shutoff solenoid and circuit.

Guided Step 2A - Inspect the engine air shutoff solenoid and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Inspect the OEM harness and solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine air shutoff solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid OEM harness connector.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine air shutoff solenoid SIGNAL pin to the engine air shutoff solenoid RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

An open circuit has been detected in the engine air shutoff solenoid.

Replace the engine air shutoff solenoid.

  • Refer to OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin in the engine harness ECM connector and the engine air shutoff solenoid SIGNAL pin at the engine air shutoff solenoid OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine air shutoff solenoid signal circuit.

Troubleshoot the OEM harness, engine harness, and all interconnects for the open circuit.

Repair or replace the damaged component.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff solenoid RETURN pin in the engine harness ECM connector and the engine air shutoff solenoid RETURN pin at the engine air shutoff solenoid OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine air shutoff solenoid return circuit.

Troubleshoot the OEM harness, engine harness, and all interconnects for the open circuit.

Repair or replace the damaged component.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine air shutoff solenoid SIGNAL wire has been detected.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component(s).

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3139 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2013


FAULT CODE 3141 - Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 3141 active?
STEP 2. | Check the engine air shutoff solenoid and circuit. |
 | STEP 2A. Inspect the engine air shutoff solenoid and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine air shutoff solenoid for a short to ground. | Greater than 100k ohms?
 | STEP 2C. Check the engine air shutoff solenoid for an internal short. | Less than 5 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3141 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3141 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine air shutoff solenoid and circuit

Guided Step 2A - Inspect the engine air shutoff solenoid and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Inspect the OEM harness and solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine air shutoff solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid OEM harness connector.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine air shutoff solenoid SIGNAL pin to ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine air shutoff solenoid.

  • Refer to OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the engine air shutoff solenoid for an internal short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid OEM harness connector.

Action

Check the resistance of the solenoid.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin and the engine air shutoff solenoid RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO

An internally shorted engine air shutoff solenoid has been detected.

Replace the engine air shutoff solenoid.

  • Refer to OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine air shutoff solenoid SIGNAL wire has been detected.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component(s).

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine air shutoff solenoid SIGNAL wire has been detected in the OEM harness.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component(s).

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Nov-2013


FAULT CODE 3142 - Aftertreatment SCR Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISM11 CM876 SN | 4022196
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3142 inactive?
STEP 2. | Check the SCR inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3143 active and Fault Code 3142 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3142 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3142 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the SCR inlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and SCR inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR inlet temperature sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the SCR inlet temperature SIGNAL pin and the SCR inlet temperature RETURN pin at the sensor connector of the OEM harness.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 3143 active and Fault Code 3142 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the SCR inlet temperature sensor to the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO

A damaged SCR inlet temperature sensor has been detected.

Replace the SCR inlet temperature sensor.

Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector SCR inlet temperature sensor RETURN pin and the OEM harness SCR inlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector SCR inlet temperature sensor SIGNAL pin and the OEM harness SCR inlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-360 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SCR inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response. This could take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-May-2012


FAULT CODE 3143 - Aftertreatment SCR Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
OEM Wiring Harness | Refer to Procedure 019-071 | ISF2.8 CM2220 AN | 4022178
OEM Wiring Harness | Refer to Procedure 019-071 | ISF3.8 CM2220 AN | 4021704
OEM Wiring Harness | Refer to Procedure 019-071 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
OEM Wiring Harness | Refer to Procedure 019-071 | ISL8.9 CM2150 SN | 4022190
OEM Wiring Harness | Refer to Procedure 019-071 | ISM11 CM876 SN | 4022196
OEM Wiring Harness | Refer to Procedure 019-071 | ISZ13 CM2150 | 4022133
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISM11 CM876 SN | 4022196
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3143 inactive?
STEP 2. | Check the SCR inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active and Fault Code 3143 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3143 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3143 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the SCR inlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and SCR catalyst inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active and Fault Code 3143 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the SCR inlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

Replace the SCR inlet temperature sensor.

Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SCR inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the SCR inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 for Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Mar-2012


FAULT CODE 3144 - Aftertreatment SCR Inlet Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISM11 CM876 SN | 4022196
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3142 or 3143. | Fault Code 3142 or 3143 active?
STEP 2. | Check the selective catalytic reduction (SCR) inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active?
 | STEP 2C. Check the circuit response. | Fault Code 3143 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Verify the repair. |
 | STEP 4A. Verify the repair | SCR inlet temperature and SCR outlet temperature reading within 14°C or 25°F of each other?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 3142 or 3143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the SCR inlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the engine harness.

Action

Inspect the engine harness and SCR inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure engine coolant temperature is above 60°C [140°F].

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR inlet gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the SCR catalyst inlet temperature SIGNAL pin and the SCR catalyst inlet temperature RETURN pin at the SCR catalyst inlet temperature connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

Replace the SCR inlet temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Disconnect the aftertreatment SCR inlet gas temperature sensor from the OEM harness.

Action

  • Measure the resistance between the SCR catalyst inlet temperature SIGNAL pin at the SCR catalyst inlet temperature sensor connector and SCR catalyst inlet temperature SIGNAL pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance or a short circuit has been detected in the OEM harness.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment SCR inlet gas temperature sensor from the OEM harness

Action

  • Measure the resistance between the SCR catalyst inlet temperature RETURN pin at the SCR catalyst inlet temperature sensor connector and SCR catalyst inlet temperature RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance or a short circuit has been detected in the engine harness.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment SCR inlet gas temperature sensor from the OEM harness

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the SCR catalyst inlet temperature SIGNAL pin at the ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

High resistance or a short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment SCR inlet gas temperature sensor from the OEM harness

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the SCR catalyst inlet temperature SIGNAL pin at the ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for catalyst inlet temperature and catalyst outlet temperature.

SCR inlet temperature and SCR outlet temperature reading within 14°C or 25°F of each other?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Oct-2016


FAULT CODE 3145 - Aftertreatment SCR Intake Gas Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISM11 CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3142 or 3143. | Fault Code 3142 or 3143 active?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) intake gas temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR intake gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active?
 | STEP 2C. Check the circuit response. | Fault Code 3143 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3142 active?
 | STEP 3C. Check the circuit response. | Fault Code 3143 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 3142 or 3143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment selective catalytic reduction (SCR) intake gas temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment SCR intake gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake gas temperature sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment SCR intake gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the aftertreatment SCR intake gas temperature SIGNAL pin and the SCR catalyst inlet temperature RETURN pin at the aftertreatment SCR intake gas temperature connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

Replace the aftertreatment SCR inlet gas temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the SCR catalyst inlet temperature SIGNAL pin and SCR catalyst inlet temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Feb-2014


FAULT CODE 3146 - Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
OEM Wiring Harness | Refer to Procedure 019-071 | ISF2.8 CM2220 AN | 4022178
OEM Wiring Harness | Refer to Procedure 019-071 | ISF3.8 CM2220 AN | 4021704
OEM Wiring Harness | Refer to Procedure 019-071 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
OEM Wiring Harness | Refer to Procedure 019-071 | ISL8.9 CM2150 SN | 4022190
OEM Wiring Harness | Refer to Procedure 019-071 | ISM11 CM876 SN | 4022196
OEM Wiring Harness | Refer to Procedure 019-071 | ISZ13 CM2150 | 4022133
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISM11 CM876 SN | 4022196
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3146 inactive?
STEP 2. | Check the SCR outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3147 active and Fault Code 3146 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3146 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3146 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the SCR outlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and SCR outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the SCR outlet temperature SIGNAL pin and the SCR outlet temperature RETURN pin at the sensor connector of the OEM harness.

  • Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 3147 active and Fault Code 3146 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the SCR outlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM or circuit response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES NO

A damaged SCR outlet temperature sensor has been detected.

Replace the SCR outlet temperature sensor.

Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector SCR outlet temperature sensor RETURN pin and the OEM harness SCR outlet temperature sensor connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector SCR outlet temperature sensor SIGNAL pin and the OEM harness SCR outlet temperature sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SCR outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM or circuit response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Mar-2012


FAULT CODE 3147 - Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
OEM Wiring Harness | Refer to Procedure 019-071 | ISF2.8 CM2220 AN | 4022178
OEM Wiring Harness | Refer to Procedure 019-071 | ISF3.8 CM2220 AN | 4021704
OEM Wiring Harness | Refer to Procedure 019-071 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
OEM Wiring Harness | Refer to Procedure 019-071 | ISL8.9 CM2150 SN | 4022190
OEM Wiring Harness | Refer to Procedure 019-071 | ISM11 CM876 SN | 4022196
OEM Wiring Harness | Refer to Procedure 019-071 | ISZ13 CM2150 | 4022133
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISM11 CM876 SN | 4022196
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3147 inactive?
STEP 2. | Check the SCR outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3146 active and Fault Code 3147 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3147 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3147 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the SCR outlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and SCR outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM or circuit response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active and Fault Code 3147 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the SCR outlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 is active?
YES NO

Replace the SCR outlet temperature sensor.

Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SCR outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the SCR outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM or circuit response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Mar-2012


FAULT CODE 3149 - Aftertreatment SCR Outlet Gas Temperature Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISM11 CM876 SN | 4022196
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 3146 or 3147 active?
STEP 2. | Check the aftertreatment SCR outlet gas temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3146 active?
 | STEP 2C. Check the circuit response. | Fault Code 3147 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3146 active?
 | STEP 3C. Check the circuit response. | Fault Code 3147 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 or 3147 active?
YES | NO
No Repair | No Repair

Fault Code 3146 or 3147 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment SCR outlet gas temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment SCR outlet gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR outlet gas temperature sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment SCR outlet gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR outlet gas temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR outlet gas temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the SCR catalyst outlet temperature SIGNAL pin and the SCR catalyst outlet temperature RETURN pin at the SCR catalyst outlet temperature connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 active?
YES NO

Replace the aftertreatment SCR outlet gas temperature sensor.

Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the SCR catalyst outlet temperature SIGNAL pin and SCR catalyst outlet temperature RETURN pin at the ECM connector.

Fault Code 3147 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 3151 - Aftertreatment SCR Catalyst System Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISM11 CM876 SN | 4022196
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, 3149, or 3163 active?
 | STEP 1B. Check for the presence of an SCR catalyst. | Is the SCR catalyst present in the aftertreatment system.
 | STEP 1C. Inspect the aftertreatment system. | Damage or tampering found in the SCR catalyst system?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3142, 3143, 3144, 3145, 3146, 3147, 3148, 3149, or 3163 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for the presence of an SCR catalyst.

Conditions

  • Turn keyswitch OFF.

Action

Check for the presence of the SCR catalyst.

  • Inspect for the presence of the SCR catalyst in the exhaust system.

Is the SCR catalyst present in the aftertreatment system?
YES NO
No Repair

Install the proper SCR catalyst for the application.

Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 1C

Go to 2A

Guided Step 1C - Inspect the aftertreatment system.

Conditions

  • Turn keyswitch OFF.
  • Remove the SCR catalyst from the exhaust system.

Action

Inspect the SCR catalyst.

  • Inspect the SCR catalyst for cracks or contamination.

Damage or tampering found in the SCR catalyst system?
YES NO

Install the proper SCR catalyst for the application. Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Mar-2017


FAULT CODE 3236 - Aftertreatment SCR Outlet Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 | 4022178
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 | 4021704
Injector | Refer to Procedure 006-026 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 | 4022188
Injector | Refer to Procedure 006-026 | ISL8.9 CM2150 | 4022190
Injector | Refer to Procedure 006-026 | ISM11 CM876 | 4022196
Injector | Refer to Procedure 006-026 | ISZ13 CM2150 | 4022133
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISF2.8 CM2220 | 4022178
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISF3.8 CM2220 | 4021704
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 | 4022188
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL8.9 CM2150 | 4022190
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISM11 CM876 | 4022196
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF2.8 CM2220 | 4022178
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF2.8 CM2220 | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 | 4022178
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2220 | 4021704
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 | 4022188
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL8.9 CM2150 | 4022190
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISM11 CM876 | 4022196
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the diesel exhaust fluid (DEF) for contamination. | Diesel exhaust fluid (DEF) contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check the aftertreatment fuel injector. |
 | STEP 5A. Check the operation of the aftertreatment fuel injector (if equipped). | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 6. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 6A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 6B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.
  • Idle engine for greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the signal pin of the temperature sensor in question to all other pins in the harness.

Check for a short circuit in the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

If no short is found replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the diesel exhaust fluid (DEF) for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the diesel exhaust fluid (DEF) for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel exhaust fluid (DEF) contaminated?
YES NO

Drain the diesel exhaust fluid (DEF) tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the aftertreatment fuel injector.

Guided Step 5A - Check the operation of the aftertreatment fuel injector (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • If the engine does not have an aftertreatment fuel injector, skip to step 6A.

Action

Check for fuel leaking from the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a snap acceleration test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

  • If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 6A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6B

Go to 6B

Guided Step 6B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Aftertreatment diesel oxidation catalyst removed.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell wall.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3237 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3237 inactive?
STEP 2. | Check the ECM and OEM harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 3238 active and Fault Code 3237 inactive?
 | STEP 2D. Check the fault codes and verify the aftertreatment diesel exhaust fluid line 1 heater relay condition. | Fault Code 3237 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid line 1 heater relay. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid line 1 heater relay and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness line 1 heater relay supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness line 1 heater relay return circuit. | Less than 10 ohms?
 | STEP 3D. Check resistance of the aftertreatment diesel exhaust fluid line 1 heater relay circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3237 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the aftertreatment diesel exhaust fluid line 1 heater relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line 1 heater relay RETURN pin and all other pins in the OEM harness.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line 1 heater relay SUPPLY pin and all other pins in the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line 1 heater relay from the OEM harness.

Action

Perform the following steps to check the circuit response.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid line 1 heater relay RETURN pin (pin 85) and the line 1 heater relay SUPPLY pin (pin 86) at the aftertreatment diesel exhaust fluid line 1 heater relay harness connector.
  • Turn keyswitch ON, start engine, and allow engine to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 3238 active and Fault Code 3237 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the aftertreatment diesel exhaust fluid line 1 heater relay condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment diesel exhaust fluid line 1 heater relay to the aftertreatment diesel exhaust fluid controller harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON, start engine, and allow engine to idle for 1 minute.

Use INSITE™ electronic service tool to read the fault codes.

Shut down engine and repeat this process again to allow all diagnostic checks to complete.

Fault Code 3237 active?
YES NO

An open circuit has been detected in the aftertreatment diesel exhaust fluid line 1 heater relay.

  • Replace the aftertreatment diesel exhaust fluid line 1 heater relay. Refer to OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid line 1 heater relay.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid line 1 heater relay and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line 1 heater relay from the OEM harness.

Action

Inspect the aftertreatment diesel exhaust fluid line 1 heater relay and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins if possible.Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness line 1 heater relay supply circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line 1 heater relay from the OEM harness
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line 1 heater relay SUPPLY pin at the OEM harness ECM connector and the aftertreatment diesel exhaust fluid line 1 heater relay SUPPLY pin (pin 86) at the line 1 heater relay connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness line 1 heater relay supply circuit.

  • Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness line 1 heater relay return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line 1 heater relay from the OEM harness
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line 1 heater relay RETURN pin at the OEM harness ECM connector and the aftertreatment diesel exhaust fluid line 1 heater relay RETURN pin (pin 85) at the line 1 heater relay connector.

Use the circuit diagram or wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness line 1 heater relay return circuit.

  • Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check resistance of the aftertreatment diesel exhaust fluid line 1 heater relay circuit..

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Connect the aftertreatment diesel exhaust fluid line 1 heater relay to the OEM harness.

Action

Check resistance of the aftertreatment diesel exhaust fluid line1 heater relay circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line 1 heater relay SUPPLY pin and the aftertreatment diesel exhaust fluid line 1 heater relay RETURN pin at the OEM harness ECM connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid line 1 heater relay.

  • Replace the aftertreatment diesel exhaust fluid line 1 heater relay. Refer to OEM service manual.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


Fault Code 3237 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
OEM Wiring Harness | Refer to Procedure 019-071 | ISF2.8 CM2220 AN | 4022178
OEM Wiring Harness | Refer to Procedure 019-071 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3237 inactive?
STEP 2. | Check the aftertreatment DEF line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF line heater 1. | Greater than 2 ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3237 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the aftertreatment DEF controller harness.

Action

Inspect the engine harness and SCR catalyst reagent line in heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 1 or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF line heater 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the aftertreatment DEF controller harness.

Action

Check the resistance of the aftertreatment DEF line heater 1.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin and the aftertreatment DEF line heater 1 SUPPLY pin at the aftertreatment DEF line heater 1 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 2 ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DEF line heater 1, or the line heater 1 resistance is too low.

Replace the aftertreatment DEF line heater 1.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin and all other pins in the aftertreatment DEF controller harness 86-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF controller.

  • Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 3238 - Aftertreatment Diesel Exhaust Fluid (DEF) Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3238 inactive?
STEP 2. | Check the ECM and OEM harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF line 1 heater relay. |
 | STEP 3A. Inspect the aftertreatment DEF line 1 heater relay and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3238 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF line 1 heater relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line 1 heater relay RETURN pin and all other pins in the OEM harness.
  • Measure the resistance between the aftertreatment DEF line 1 heater relay SUPPLY pin and all other pins in the OEM harness

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF line 1 heater relay.

Guided Step 3A - Inspect the aftertreatment DEF line 1 heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line 1 heater relay from the OEM harness.

Action

Inspect the aftertreatment DEF line 1 heater relay and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF line 1 heater relay from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF line 1 heater relay RETURN pin at the OEM harness and ground.
  • Measure the resistance between the aftertreatment DEF line 1 heater relay SUPPLY pin at the OEM harness and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-ground short circuit has been detected in the OEM harness.

  • Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3239 - Aftertreatment Diesel Exhaust Fluid (DEF) Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3239 inactive?
STEP 2. | Check the aftertreatment DEF line heater 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check resistance of the aftertreatment DEF line heater 2. | Greater than 2 ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3239 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 2 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater 2 and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the line heater 2 or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check resistance of the aftertreatment DEF line heater 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the aftertreatment DEF controller harness.

Action

Check the resistance of the aftertreatment DEF line heater 2.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin and the aftertreatment DEF line heater 2 SUPPLY pin at the aftertreatment DEF line heater 2 connector.

Refer to the circuit diagram and a wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 2 ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DEF line heater 2, or the line heater 2 resistance is too low.

Replace the aftertreatment DEF line heater 2.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin and all other pins in the aftertreatment DEF controller harness 86-pin connector.

Refer to the circuit diagram and a wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the aftertreatment DEF controller harness

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3258 - Aftertreatment Diesel Exhaust Fluid (DEF) Line Heater 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3258 inactive?
 | STEP 1B. Check for active DEF line heater relay fault codes. | Fault Codes 3562, 3563, or 3564 active?
 | STEP 1C. Check for multiple active DEF line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment DEF line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3237 active and Fault Code 3258 inactive?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF dosing unit condition. | Fault Code 3258 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness line heater supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF controller harness line heater signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3258 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Procedure 019-362

Go to 1B

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3562, 3563, or 3564 active?
YES NO

Refer to appropriate fault code troubleshooting tree.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple active DEF line heater fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment DEF controller harness line heater power supply circuit.

This could be caused by:

  • Switch side of line heater relay stuck open
  • Burned out in-line fuse on the line heater power supply circuit (if equipped)
  • Open circuit or short to ground in the aftertreatment DEF controller harness line heater power supply circuit.

Repair or replace the damaged component.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater 1 and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the aftertreatment DEF controller harness.

Action

Perform the following steps to check the circuit response.

  • Place a jumper wire between the aftertreatment DEF line heater 1 SIGNAL pin and the aftertreatment DEF line heater 1 SUPPLY pin at the aftertreatment DEF line heater 1 harness connector.
  • Use INSITE™ electronic service tool to perform the DEF Doser System Heater Test to manually command line heater 1 to ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 3237 active and Fault Code 3258 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF line heater 1 to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON, start engine, and allow the engine to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Shut down engine and repeat this process one more time to allow all diagnostic checks to complete.

Fault Code 3258 active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment DEF line heater 1.

Replace the aftertreatment DEF line heater 1.

Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness line heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF line heater relay.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment DEF controller harness between the aftertreatment DEF line heater 1 SUPPLY pin and pin 87 of the aftertreatment DEF line heater relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater power supply circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF controller harness line heater signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin at the 86 pin controller harness connector and the aftertreatment DEF line heater 1 SIGNAL pin at the line heater 1 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater signal circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin at the aftertreatment DEF controller harness 86-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin to ground short circuit on the SIGNAL wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3261 - Aftertreatment Diesel Exhaust Fluid (DEF) Line Heater 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3261 inactive?
 | STEP 1B. Check for active DEF line heater relay fault codes. | Fault Codes 3562, 3563, or 3564 active?
 | STEP 1C. Check for multiple active DEF line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment DEF line heater 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3237 active and Fault Code 3261 inactive?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF dosing unit condition. | Fault Code 3261 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness line heater supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF controller harness line heater supply circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3261 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Procedure 019-362

Go to 1B

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3562, 3563, or 3564 active?
YES NO

Refer to appropriate fault code troubleshooting tree.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple active DEF line heater fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment DEF controller harness line heater power supply circuit.

This could be caused by:

  • Switch side of line heater relay stuck open
  • Burned out in-line fuse on the line heater power supply circuit (if equipped)
  • Open circuit or short to ground in the aftertreatment DEF controller harness line heater power supply circuit.

Repair or replace the malfunctioning component.

Refer to OEM service manual.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 2 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater 2 and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the aftertreatment DEF controller harness.

Action

Perform the following steps to check the circuit response.

  • Place a jumper wire between the aftertreatment DEF line heater 2 SIGNAL pin and the aftertreatment DEF line heater 2 SUPPLY pin at the aftertreatment DEF line heater 2 harness connector.
  • Use INSITE™ electronic service tool to perform the DEF Doser System Heater Test to manually command line heater 2 to ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 3237 active and Fault Code 3261 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF line heater 2 to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON, start engine, and allow the engine to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Shut down the engine and repeat this process one more time to allow all diagnostic checks to complete.

Fault Code 3261 active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment DEF line heater 2.

Replace the aftertreatment DEF line heater 2.

Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness line heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF line heater relay.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment DEF controller harness between the aftertreatment DEF line heater 2 SUPPLY pin and pin 87 of the aftertreatment DEF line heater relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater power supply circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF controller harness line heater signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin at the 86 pin controller harness connector and the aftertreatment DEF line heater 2 SIGNAL pin at the line heater 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater signal circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin at the aftertreatment DEF controller harness 86-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin to ground short circuit on the SIGNAL wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3382 - Engine Exhaust Gas Recirculation System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Cooler | Refer to Procedure 011-019 | ISF2.8 CM2220 E | 4022178
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 E | 4022178
EGR Connection Tubes | Refer to Procedure 011-025 | ISF2.8 CM2220 E | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E | 4022178
Mass Air Flow Sensor | Refer to Procedure 019-460 | ISF2.8 CM2220 E | 4022178

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active EGR valve fault codes. | Fault Code 1228, 2271, 2272, 2351, 2352, or 2357 active?
 | STEP 1B. Check for active engine intake throttle actuator fault codes. | Fault Code 175, 176, 177, 3539, 3541, or 3542 active?
 | STEP 1C. Check for active mass air flow sensor fault codes. | Fault Code 356, 357, or 358 active?
STEP 2. | Check the exhaust gas recirculation (EGR) system for leaks or restrictions. |
 | STEP 2A. Check the EGR system for leaks. | Leaks detected?
 | STEP 2B. Check the EGR crossover tube for restriction. | Restriction or damage to the EGR crossover tube?
 | STEP 2C. Check the EGR valve for restriction. | Restriction or damage to the EGR valve?
 | STEP 2D. Check the EGR cooler for restriction. | Restriction or damage to the EGR cooler?
STEP 3. | Check the mass air flow sensor. |
 | STEP 3A. Verify mass air flow sensor reading. | Mass air flow sensor reading between -.91 and .91 kg/min [-2 and 2 lb/min]?
 | STEP 3B. Inspect the mass air flow sensor and connector pins. | Dirty or damaged sensor and/or connector pins?
STEP 4. | Inspect the air intake system. |
 | STEP 4A. Check for air intake system leaks. | Leaks found in the air intake system?
 | STEP 4B. Check air filter condition. | Was the air filter damaged, restricted, or installed incorrectly?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1228, 2271, 2272, 2351, 2352, or 2357 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active engine intake throttle actuator fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active engine intake throttle actuator fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 175, 176, 177, 3539, 3541, or 3542 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active mass air flow sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active mass air flow sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 356, 357, or 358 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR system for leaks or restrictions.

Guided Step 2A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR system for leaks.

  • Leaks should be easily noted by traces of soot.

Leaks detected?
YES NO

Repair or replace the leaky component.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the EGR crossover tube for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR crossover tube for restrictions, kinks, or damage.

  • Refer to Procedure 011-025 in the Associated Procedures Table.

Restriction or damage to the EGR crossover tube?
YES NO

Clear the restriction or replace the EGR crossover tube.

  • Refer to Procedure 011-025 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the EGR valve for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR valve for restrictions.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

Restriction or damage to the EGR valve?
YES NO

Clear the restriction or replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check the EGR cooler for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR cooler for restrictions.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

Restriction or damage to the EGR cooler?
YES NO

Clear the restriction or replace the EGR cooler.

Refer to Procedure 011-019 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the mass air flow sensor

Guided Step 3A - Verify mass air flow sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine not running.

Action

Using the electronic service tool, monitor the mass air flow sensor reading.

  • Use the “Data Monitor/Logger” function in INSITE™ electronic service tool to monitor the value of “Mass Air Flow” with the engine not running.

Mass Air Flow sensor reading between -.91 and .91 kg/min [-2 and 2 lb/min]?
YES NO
No Repair

Replace the Mass Air Flow sensor.

Refer to Procedure 019-460 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Inspect the mass air flow sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.
  • Disconnect mass air flow sensor from engine harness connector.

Action

Remove the mass air flow sensor from its mounting location.

  • Refer to Procedure 019-460 in the Associated Procedures Table.

Inspect the mass air flow sensor body and heated wire measuring components for the following:

  • Dirt or debris
  • Physical damage
  • Moisture or oil contamination.

Note: The mass air flow sensor can not be cleaned and must be replaced if found to be contaminated.

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor and/or connector pins?
YES NO

Replace the dirty or damaged mass air flow sensor.

Repair or replace the damaged engine harness connector.

Refer to Procedure 019-460 in the Associated Procedures Table.

Install the mass air flow sensor.

Refer to Procedure 019-460 in the Associated Procedures Table.

Go to 5A

Go to 4A

Guided Step 4 - Inspect the air intake system.

Guided Step 4A - Check for air intake system leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for an air intake leak between the air box and the intake manifold.

  • Check all clamps and connectors for tightness.
  • Check for disconnected or damaged air pipes.
  • Perform a pressurized leak test of the system, if possible.

Leaks found in the air intake system?
YES NO

Repair or replace leaking component(s).

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check air filter condition

Conditions

  • Turn keyswitch OFF.

Action

Check the intake air filter for excessive build-up and restriction.

  • Check the filter restriction monitor gauge, if equipped.
  • Remove filter, if necessary, and inspect for excessive debris build-up or filter media damage.
  • Make sure the filter was installed properly.

Was the air filter damaged, restricted, or installed incorrectly?
YES NO

Replace air filter.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3383 - Engine Exhaust Gas Recirculation System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISF2.8 CM2220 E | 4022178
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 E | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 E | 4022178
Mass Air Flow Sensor | Refer to Procedure 019-460 | ISF2.8 CM2220 E | 4022178

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active EGR valve fault codes. | Fault Code 1895, 1896, 2357, or 2774 active?
 | STEP 1B. Check for active engine intake throttle actuator fault codes. | Fault Code 175, 176, 177, 3539, 3541, or 3542 active?
 | STEP 1C. Check for active mass air flow sensor fault codes. | Fault Code 356, 357, or 358 active?
STEP 2. | Check the exhaust gas recirculation (EGR) and exhaust system. |
 | STEP 2A. Check the EGR system for leaks. | Leaks detected?
 | STEP 2B. Check exhaust restriction. | Does the exhaust restriction exceed the specifications in Procedure 011-009?
STEP 3. | Check the mass air flow sensor. |
 | STEP 3A. Verify mass air flow sensor reading. | Mass air flow sensor reading between -.91 kg/min and .91 kg/min [-2 lb/min and 2 lb/min]?
 | STEP 3B. Inspect the mass air flow sensor and connector pins. | Dirty or damaged sensor and/or connector pins?
STEP 4. | Inspect the air intake system. |
 | STEP 4A. Leaks found in the air intake system? |
 | STEP 4B. Check air filter condition. | Was the air filter damaged, restricted, or installed incorrectly?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1228, 2271, 2272, 2351, 2352, or 2357 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active engine intake throttle actuator fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active engine intake throttle actuator fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 175, 176, 177, 3539, 3541, or 3542 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active mass air flow sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active mass air flow sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 356, 357, or 358 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR and exhaust system.

Guided Step 2A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR system for leaks.

  • Leaks should be easily noted by traces of soot.

Leaks detected?
YES NO

Repair or replace the leaky component.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check exhaust restriction.

Conditions

  • Install a pressure gauge into the exhaust system.
  • Turn keyswitch ON.
  • Run engine at rated horsepower and rpm.

Action

Check exhaust restriction by installing a pressure gauge into the exhaust system, just past the turbocharger outlet.

If a port is not found in the exhaust system, remove the SCR intake temperature sensor and install the pressure gauge in the temperature sensor port.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Does the exhaust restriction exceed the specifications in Procedure 011-009?
YES NO

If exhaust pressure exceeds the specification, inspect the exhaust piping for damage or other sources of restriction. Refer to the equipment manufacturer's repair instructions.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the mass air flow sensor.

Guided Step 3A - Verify mass air flow sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine not running.

Action

Use the INSITE™ electronic service tool to monitor the mass air flow sensor reading.

  • Use the “Data Monitor/Logger” function in INSITE™ electronic service tool to monitor the value of “Mass Air Flow” with the engine not running.

Mass air flow sensor reading between -.91 kg/min and .91 kg/min [-2 lb/min and 2 lb/min]?
YES | NO
No Repair | No Repair

Go to 3B

Go to 5A

Guided Step 3B - Inspect the mass air flow sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.
  • Disconnect mass air flow sensor from engine harness connector.

Action

Remove the mass air flow sensor from its mounting location. (Mass Air Flow Sensor) in Section 19.

  • Refer to Procedure 019-460 in the Associated Procedures Table.

Inspect the mass air flow sensor body and heated wire measuring components for the following:

  • Dirt or debris
  • Physical damage
  • Moisture or oil contamination.

NOTE: The mass air flow sensor can not be cleaned and must be replaced, if found to be contaminated.

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor and/or connector pins?
YES NO

Replace the dirty or damaged mass air flow sensor

Repair or replace the damaged engine harness connector.

Refer to Procedure 019-460 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the air intake system

Guided Step 4A - Check for air intake system leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for an air intake leak between the air box and the intake manifold.

  • Check all clamps and connectors for tightness
  • Check for disconnected or damaged air pipes
  • Perform a pressurized leak test of the system if possible.

Leaks found in the air intake system?
YES NO

Repair or replace leaking component(s).

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check air filter condition

Conditions

  • Turn keyswitch OFF.

Action

Check the intake air filter for excessive build-up and restriction.

  • Check the filter restriction monitor gauge if equipped.
  • Remove filter if necessary and inspect for excessive debris build-up or filter media damage.
  • Make sure the filter was installed properly.

Was the air filter damaged, restricted, or installed incorrectly?
YES NO

Replace air filter.

Refer to OEM service manual.

Replace the EGR valve.

Refer to procedure 011-022 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3422 - Aftertreatment Diesel Exhaust Fluid (DEF) Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3422 inactive?
STEP 2. | Check the aftertreatment DEF line heater 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check resistance of the aftertreatment DEF line heater 3. | Greater than 2 ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3422 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 3 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater 3 and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 3 or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check resistance of the aftertreatment DEF line heater 3.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the aftertreatment DEF controller harness.

Action

Check the resistance of the aftertreatment DEF line heater 3.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin and the aftertreatment DEF line heater 3 SUPPLY pin at the aftertreatment DEF line heater 3 connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 2 ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DEF line heater 3, or the line heater 3 resistance is too low.

Replace the aftertreatment DEF line heater 3.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin and all other pins in the aftertreatment DEF controller harness 86-pin connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3425 - Aftertreatment Diesel Exhaust Fluid (DEF) Line Heater 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3425 inactive?
 | STEP 1B. Check for active DEF line heater relay fault codes. | Fault Codes 3562, 3563, or 3564 active?
 | STEP 1C. Check for multiple active DEF line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment DEF line heater 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3237 active and Fault Code 3425 inactive?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF dosing unit condition. | Fault Code 3425 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness line heater supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF controller harness line heater signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3425 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Procedure 019-362

Go to 1B

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3562, 3563, or 3564 active?
YES NO

Refer to appropriate fault code troubleshooting tree.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple active DEF line heater fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment DEF controller harness line heater power supply circuit.

This could be caused by:

  • Switch side of line heater relay stuck open
  • Burned out in-line fuse on the line heater power supply circuit (if equipped)
  • Open circuit or short to ground in the aftertreatment DEF controller harness line heater power supply circuit.

Repair or replace the malfunctioning component.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 3 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater 3 and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the aftertreatment DEF controller harness.

Action

Perform the following steps to check the circuit response.

  • Place a jumper wire between the aftertreatment DEF line heater 3 SIGNAL pin and the aftertreatment DEF line heater 3 SUPPLY pin at the aftertreatment DEF line heater 3 harness connector.
  • Use INSITE™ electronic service tool to perform the DEF Doser System Heater Test to manually command line heater 3 to ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 3237 active and Fault Code 3425 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF line heater 3 to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON, start engine, and allow the engine to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Shut down the engine and repeat this process one more time to allow all diagnostic checks to complete.

Fault Code 3425 active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment DEF line heater 3.

Replace the aftertreatment DEF line heater 3.

Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness line heater supply circuit. .

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF line heater relay.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment DEF controller harness between the aftertreatment DEF line heater 3 SUPPLY pin and pin 87 of the aftertreatment DEF line heater relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater power SUPPLY circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF controller harness line heater SIGNAL circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin at the 86 pin controller harness connector and the aftertreatment DEF line heater 3 SIGNAL pin at the line heater 3 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater signal circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 86-pin connector from the controller.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin at the aftertreatment DEF controller harness 86-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin to ground short circuit on the SIGNAL wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3426 - Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3426 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 4 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check resistance of the aftertreatment diesel exhaust fluid line heater 4. | Greater than 2 ohms?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3426 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 4 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check resistance of the aftertreatment diesel exhaust fluid line heater 4.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Check resistance of the aftertreatment diesel exhaust fluid line heater 4.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 4 SUPPLY pin at the aftertreatment diesel exhaust fluid dosing unit connector.

Greater than 2 ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment diesel exhaust fluid line heater 4, or the line heater 4 resistance is too low.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin and all other pins in the aftertreatment diesel exhaust fluid controller harness 86-pin connector.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - A Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - A Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Oct-2009


FAULT CODE 3429 - Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3429 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 4 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3426 active and Fault Code 3429 inactive?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness connector pins. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3429 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Procedure 019-362.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 4 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Perform the following steps to check the circuit response.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 4 SUPPLY pin at the aftertreatment diesel exhaust fluid dosing unit harness connector.
  • Turn keyswitch ON, start engine, and allow the engine to idle for 1 minute.
  • Use INSITE™ to read the fault codes.

NOTE: Fault codes 3561, 3579, and 3571 will also be active.

Fault code 3426 active and Fault Code 3429 inactive?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid line heater 4, which is internal to the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit and aftertreatment diesel exhaust fluid controller harness connections for the following: Check the intake manifold pressure sensor.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment diesel exhaust fluid controller harness between the aftertreatment diesel exhaust fluid line heater 4 SUPPLY pin at the dosing unit connector and the aftertreatment diesel exhaust fluid line heater 4 SUPPLY pin at the 86-pin controller harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater 4 supply circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment diesel exhaust fluid controller harness between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin at the dosing unit connector and the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin at the 86-pin controller harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin at the aftertreatment diesel exhaust fluid controller harness 86-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin to ground short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Jan-2010


FAULT CODE 3548 - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit Loss of Prime - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISM11 CM876 SN | 4022196
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISZ13 CM2150 | 4022133
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1671, 1673, 1712, 3242 or 3738 active?
STEP 2. | Inspect the aftertreatment nozzle. |
 | STEP 2A. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the DEF dosing unit. |
 | STEP 3A. Check the DEF dosing unit during priming. | Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay if applicable)
 | STEP 3B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute [6.6 gallons per minute]?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Clear the DEF dosing unit air side circuit. Carry out the flushing procedure. | Flushing procedure successful?
STEP 5. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 5A. Check the DEF dosing unit fittings and lines. | DEF fittings and lines pass the inspections?
 | STEP 5B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at the screen filter?
 | STEP 5C. Check the DEF dosing lines for restrictions or leaks | Restriction line test completed successfully?
 | STEP 5D. Inspect the DEF tank and the 35 micron tank filter. | DEF tank contaminated or the urea solution less than 32.5%?
STEP 6. | Verify the purging cycle of the aftertreatment dosing unit. |
 | STEP 6A. Monitor the aftertreatment dosing unit purging cycle. | All the actions in this step confirmed and zero incomplete purge counts in the ECM image?
STEP 7. | Perform the Diesel Exhaust Fluid Doser Pump Override Test. |
 | STEP 7A. Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test 3 times)
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1671, 1673, 1712, 3242, or 3738 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment nozzle.

Guided Step 2A - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Soft crystal and ash-like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Make sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Clean or replace the aftertreatment nozzel. Refer to Procedure 011-040 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the diesel exhaust fluid dosing unit.

Guided Step 3A - Check the diesel exhaust fluid dosing unit during priming.

Conditions

  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check the diesel exhaust fluid dosing unit during priming.

  • After key ON with the engine operating, listen for the diesel exhaust fluid dosing pump to start
  • Time the pump operation until the pump automatically switches off (The pump is attempting to prime)

Note: While the engine is operating it may be difficult to hear the pump, if this is the case listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

Note: Older calibrations did not incorporate the 140 second delay from key on to initial prime cycle. During the 140 second delay the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization buildup on the injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Key ON

2. 140 second pump start delay

3. Pump starts and runs for 30 seconds. (The system is now priming, this step may be attempted up to 20 times).

4. The diesel exhaust fluid injection line will now exhaust air. Priming is now complete.

Does the dosing unit only prime for 3 seconds? (Plus the 140 second prime delay if applicable)
YES NO

Complete line restriction testing procedure then re-prime. Refer to Procedure 011-086 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Be sure that the diesel exhaust fluid dosing unit has successfully primed and entered the dosing state.

  • The diesel exhaust fluid dosing unit enters the dosing state only when a successful prime is has completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment DEF Dosing Unit State to confirm the doser status.

Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)

YES NO
No Repair

NOTE: The diesel exhaust fluid dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle.
  • Attach the air flow meter to the diesel exhaust fluid dosing line. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Secure the diesel exhaust fluid dosing line and the attached air flow meter
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the diesel exhaust fluid dosing line.

Air flow above 25 liter per minute [6.6 gallons per minute]?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Make sure the vehicle air tanks are full.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for contamination from water or excessive oil from the vehicle compressed air system.
  • Make sure a clean air supply of at least 517 kPa [75 psi] of pressure is present at the DEF dosing unit, downstream of the air filter.

NOTE: Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Correct the OEM air supply connection or supply.

Refer to the OEM service manual.

Go to 4B

Go to 3A

Guided Step 4B - Clear the diesel exhaust fluid dosing unit air side circuit. Carry out the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the diesel exhaust fluid dosing unit flushing procedure.

  • Refer to Procedure 011-082 in the Associated Procedures Table.

Most vehicles are equipped with an inline air filter in the air line prior to the diesel exhaust fluid dosing unit. A plugged or restricted inline air filter can cause low air pressure to the diesel exhaust fluid dosing unit.

Flushing procedure successful?
YES NO
No Repair

A damaged diesel exhaust fluid dosing unit has been detected. Replace the diesel exhaust fluid dosing unit.

  • Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check the diesel exhaust fluid lines and fittings for restriction and contamination.

Guided Step 5A - Check the diesel exhaust fluid dosing unit fittings and lines.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the diesel exhaust fluid dosing unit fittings and lines for the following:

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose diesel exhaust fluid inlet connectors or fitting
  • Cracked diesel exhaust fluid lines, resulting in leaks or drawing in air
  • Make sure diesel exhaust fluid is returning to the tank during the priming cycle.

Diesel exhaust fluid fittings and lines pass the inspections?
YES NO
No Repair

Repair or replace diesel exhaust fluid lines and / or connectors. Refer to the OEM service manual.

Go to 5B

Go to 3B

Guided Step 5B - Inspect the diesel exhaust fluid dosing unit inline screen filter connection.

Conditions

  • Clean the front fact of the doser before removing any lines.
  • Disconnect the diesel exhaust fluid line from the aftertreatment nozzle and secure appropriately.

Action

Inspect the diesel exhaust fluid dosing unit inline screen filter connection.

  • Remove the diesel exhaust fluid dosing unit supply line
  • Inspect the inlet screen filter. Refer to Procedure 011-060 in the Associated Procedures Table.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the diesel exhaust fluid dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Is contamination present at the screen filter?
YES NO

Replace the screen filter.

 No Repair

Go to 5C

Go to 5C

Guided Step 5C - Check the diesel exhaust fluid dosing lines for restrictions or leaks.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Complete the line restriction procedure.

Refer to Procedure 011-086 in the Associated Procedures Table.

Check the diesel exhaust fluid lines for leaks or restrictions.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

  • Remove and check the supply and return lines.

Use the following procedure to identify the different connections on the diesel exhaust fluid dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Restriction line test completed successfully?
YES NO
No Repair

Repair or replace the diesel exhaust fluid lines and/or connectors. Refer to OEM Service Manual.

Go to 5D

Go to 3B

Guided Step 5D - Inspect the DEF tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

  • Inspect the contents of the tank.
  • Inspect the condition of the tank filter.

Refer to the OEM service manual for removal / installation procedures for the DEF tank and DEF tank level sensor assembly.

NOTE: In some cases the DEF tank is bonded to the vehicle chassis, leaving no access to the DEF tank level sensor assembly. If this is the case, contact the OEM to arrange for the tank to be removed and inspected.

  • Inspect the contents of the tank.
  • Inspect the condition of the tank filter.
  • Check that a 35 micron tank filter is fitted. Refer to Procedure 011-083 in the Associated Procedures Table.
  • Check and record the urea concentration of the DEF using a sample from the tank. Refer to Procedure 018-026 in Section V.

DEF tank contaminated or the urea solution less than 32.5%?

YES NO

Locate/remove source, inform OEM. If required replace components and connectors. Drain/refill the DEF tank. Refer to OEM service manual.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Verify the purging cycle of the aftertreatment dosing unit.

Guided Step 6A - Monitor the aftertreatment dosing unit purging cycle.

Conditions

  • Start the engine and operate at low idle.

Action

Verify completion of the aftertreatment dosing unit purge cycle.

  • Turn the keyswitch OFF to shut down the engine.
  • Verify that the aftertreatment dosing unit remains powered for at least 30 seconds after keyswitch OFF to complete the purge cycle.
  • Confirm that air flow is present for 30 seconds after keyswitch OFF.
  • Confirm the battery isolation switch allows the purge to continue for a full 30 seconds.

NOTE: The procedure above will flag incomplete purge counts in the ECM, if incorrect. See the Purging section under Shop Talk.

All the actions in this step confirmed and zero incomplete purge counts in the ECM image?
YES NO
No Repair

  • Verify the correct battery power and keyswitch wiring to the aftertreatment dosing unit.
  • Consult the engine and OEM wiring diagrams.
  • Repair any OEM wiring issue and notify the OEM.
  • If the battery isolator switch increases incomplete purge counts, the OEM must be notified. A timer relay must be in the system to allow a 30 second purge.

Go to 7A

Go to 7A

Guided Step 7 - Perform the DEF Doser Pump Override Test.

Guided Step 7A - Perform the DEF Doser Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

NOTE: The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container larger than 200 ml [6.8 oz] capacity to perform the DEF Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test 3 times)

YES NO
No Repair

A damaged DEF dosing unit has been detected. Replace the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 3555 - Engine Wait to Start Lamp - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with the INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3555 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3555 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3555 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Multiplexing Troubleshooting, Bulletin 4021378.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.
  • Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3555 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Appropriate ECM No Communication troubleshooting symptom tree in Section TT

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Sep-2013


FAULT CODE 3557 - Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3557 active?
STEP 2. | Check the aftertreatment DEF pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3557 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatement DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3557 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3557 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and aftertreatment DEF pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 3429, 3561, 3571, and 3577 will be active.

Fault Code 3557 active?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatement DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the aftertreatment DEF controller.

Action

Inspect the aftertreatment DEF controller harness and 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the contoller or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 86-pin connector from the aftertreatment DEF controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, 3576, and 3579 will be active.

Fault Code 3557 active?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 86-pin connector from the aftertreatment DEF controller.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller.

Action

Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

  • Measure the resistance from the aftertreatment DEF pressure 5 volt SUPPLY pin at the 86-pin connector and all other pins in the 86-pin connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Sectio 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF pressure sensor 5 volt SUPPLY line.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Assoicated Procedures Table.

The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 3569 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISM11 CM876 SN | 4022196
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1117, 1711, 1668, 1669, 1671, 1673, 1674, 1675, 1677, 1678, 1697, 1698, 3142, 3143, 3146 or 3147 active?
STEP 2. | Inspect the aftertreatment nozzle. |
 | STEP 2A. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 3A. Check the DEF dosing unit during priming. | Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay, if applicable)?
 | STEP 3B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)?
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute [6.6 gallons per minute]?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Clear the DEF dosing unit air side circuit. Carry out the flushing procedure. | Flushing procedure successful?
STEP 5. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 5A. Check the DEF dosing unit fittings and lines. | DEF fittings and lines pass the inspection?
 | STEP 5B. Inspect the DEF dosing unit inline screen connection. | Contamination present at the screen filter?
 | STEP 5C. Check the DEF dosing lines for restrictions or leaks. | Restriction line test completed successfully?
 | STEP 5D. Inspect the DEF tank and the 35 micron tank filter. | DEF tank contaminated or the urea solution less than 32.5%?
STEP 6. | Verify the purging cycle of the aftertreatment dosing unit. |
 | STEP 6A. Monitor the aftertreatment dosing unit purging cycle. | Actions in this step confirmed and the aftertreatment dosing unit purging cycle verified?
STEP 7. | Perform DEF Doser Pump Override Test. |
 | STEP 7A. Perform DEF Doser Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool Override Test? (It is recommended to complete this test 3 times)
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1117, 1711, 1668, 1669, 1671, 1673, 1674, 1675, 1677, 1678, 1697, 1698, 3142, 3143, 3146 or 3147 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting fault code tree.

Go to 2A

Guided Step 2 - Inspect the aftertreatment nozzle.

Guided Step 2A - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Soft crystal and ash-like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Make sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Clean or replace the aftertreatment nozzel. Refer to Procedure 011-040 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the DEF dosing unit.

Guided Step 3A - Check the DEF dosing unit during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check the DEF dosing unit during priming.

  • After key ON with the engine operating, listen for the DEF dosing pump to start
  • Time the pump operation until the pump automatically switches off (The pump is attempting to prime)

While the engine is operating it may be difficult to hear the pump, if this is the case listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

Older calibrations did not incorporate the 140 second delay from key on to initial prime cycle. During the 140 second delay the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization buildup on the injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Turn keyswitch ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming, this step may be attempted up to 20 times).

4. The DEF injection line will now exhaust air. Priming is now complete.

Does the dosing unit only prime for 3 seconds? (Plus the 140 second prime delay, if applicable)
YES NO

Complete line restriction testing procedure then re-prime. Refer to Procedure 011-086 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON .
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Make sure the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is has completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment DEF Dosing Unit State to confirm the doser status.

Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)

YES NO
No Repair

The DEF dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Secure the DEF dosing line and the attached air flow meter.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 liter per minute [6.6 gallons per minute]?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Make sure the vehicle air tanks are full.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for contamination from water or excessive oil from the vehicle compressed air system.
  • Make sure a clean air supply of at least 517 kPa [75 psi] of pressure is present at the DEF dosing unit, downstream of the air filter.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Correct the OEM air supply connection or supply.

See equipment manufacturer service information.

Go to 4B

Go to 3A

Guided Step 4B - Clear the DEF dosing unit air side circuit. Carry out the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the DEF dosing unit flushing procedure.

  • Refer to Procedure 011-082 in the Associated Procedures Table.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Note: Make sure the customer is performing the Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing according to the published maintenance schedule.

Flushing procedure successful?
YES NO
No Repair

Replace the DEF dosing unit.

Go to 5A

Go to 7A

Guided Step 5 - Check the DEF lines and fittings for restriction and contamination.

Guided Step 5A - Check the DEF dosing unit fittings and lines.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit fittings and lines for the following:

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fitting
  • Cracked DEF lines, resulting in leaks or drawing in air
  • Be sure DEF is returning to the tank during the priming cycle.

Diesel exhaust fluid fittings and lines pass the inspections?
YES NO
No Repair

Repair or replace DEF lines and / or connectors. See equipment manufacturer service information.

Go to 5B

Go to 3B

Guided Step 5B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front fact of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the DEF dosing unit supply line.
  • Inspect the inlet screen filter. Refer to Procedure 011-060 in the Associated Procedures Table.

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Contamination present at the screen filter?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5C

Guided Step 5C - Check the DEF dosing lines for restrictions or leaks.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Complete the line restriction procedure.

Check the DEF lines for leaks or restrictions.

Refer to Procedure 011-086 in the Associated Procedures Table.

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

  • Remove and check the supply and return lines.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Restriction line test completed successfully?
YES | NO
No Repair | No Repair

Go to 5D

Go to 3B

Guided Step 5D - Inspect the DEF tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

Refer to the OEM service manual for removal / installation procedures for the DEF tank and DEF tank level sensor assembly.

In some cases the DEF tank is bonded to the vehicle chassis leaving no access to DEF tank level sensor assembly. If this is the case, contact the OEM to arrange for the tank to be removed and inspected.

  • Inspect the contents of the tank.
  • Inspect the condition of the tank filter.
  • Check that a 35 micron tank filter is fitted. Refer to Procedure 011-083 in the Associated Procedures Table.
  • Check and record the urea concentration of the DEF using a sample from the tank. Refer to Procedure 018-026 in Section V.

DEF tank contaminated or the urea solution less than 32.5%?

YES NO

Locate/remove source, inform OEM. If required replace components and connectors. Drain / refill the DEF tank.

See equipment manufacturer service information.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Verify the purging cycle of the aftertreatment dosing unit.

Guided Step 6A - Monitor the aftertreatment dosing unit purging cycle.

Conditions

  • Start the engine and operate at low idle.

Action

Verify completion of the aftertreatment dosing unit purge cycle.

  • Turn the keyswitch OFF to shut down the engine.
  • Verify that the aftertreatment dosing unit remains powered for at least 30 seconds after keyswitch OFF to complete the purge cycle.
  • Confirm that air flow is present for 30 seconds after keyswitch OFF.
  • Confirm the battery isolation switch allows the purge to continue for a full 30 seconds.

The procedure above will flag incomplete purge counts in the ECM, if incorrect. See the Purging section under Shop Talk.

Note: Incomplete purge counts are not necessarily detrimental to operation, but can be used as an indicator to assist in troubleshooting purge effectiveness.

Actions in this step confirmed and the aftertreatment dosing unit purging cycle verified?
YES NO
No Repair

  • Verify the correct battery power and keyswitch wiring to the aftertreatment dosing unit.
  • Consult the engine and OEM wiring diagrams.
  • Repair any OEM wiring issue and notify the OEM.
  • If the battery isolator switch increases incomplete purge counts, the OEM must be notified. A timer relay must be in the system to allow a 30 second purge.

Go to 7A

Go to 7A

Guided Step 7 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 7A - Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container greater than 200 ml [6.8 oz] capacity to peform the Diesel Exhaust Fluid Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool Override Test? (It is recommended to complete this test 3 times)

YES NO
No Repair

A damaged DEF dosing unit has been detected. Replace the DEF dosing unit.

Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Feb-2016


FAULT CODE 3569 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3569 active or more than two inactive counts?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 2B. Check the aftertreatment DEF dosing valve supply line. | DEF dosing valve supply line blocked or restricted?
STEP 3. | Check the aftertreatment DEF dosing valve. |
 | STEP 3A. Inspect the DEF dosing valve for blockage. | Does the DEF dosing valve show signs of blockage or restrictions?
 | STEP 3B. Perform the aftertreatment DEF doser pump override test. | Measured volume of DEF from doser pump override test within specifications outlined in Procedure 011-058 and DEF dosing valve providing uniform spray pattern?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes..

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3569 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

An inactive or intermittent fault codes has been detected. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF lines and fittings

Guided Step 2A - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all three aftertreatment DEF dosing unit fittings and lines.

  • Check the dosing unit supply, dosing valve supply, and return connectors and fittings for loose or leaking connections.
  • Disconnect the dosing unit supply, dosing valve supply, and return connectors. Look for signs of build-up or blockage.
  • Check the dosing unit supply line for signs of leakage or openings which would allow the dosing unit to suck in air with the DEF.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking DEF line or fitting as necessary.

Refer to the OEM service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing valve supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve supply line from the dosing unit (this is the pressure line between the dosing unit and the dosing valve)
  • Disconnect the aftertreatment DEF dosing valve supply line from the dosing valve.

Action

Check the DEF dosing unit supply line for blockage.

  • Visually check both ends of the line for signs of build-up or blockage.
  • Blow compressed shop air through the supply line to make sure of free flow.

DEF dosing valve supply line blocked or restricted?
YES NO

Try to clean the dosing valve supply line with shop air. If necessary, replace the dosing valve supply line.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 3A

Guided Step - 3 Check the aftertreatment DEF dosing valve.

Guided Step 3AInspecttheDEFdosingvalveforblockage. -

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Action

Inspect the aftertreatment DEF dosing valve for signs of build-up, blockage, or restrictions.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Does the DEF dosing valve show signs of blockage or restrictions?
YES NO

Clean or replace the DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3B

Guided Step - 3B Perform the aftertreatment DEF doser pump override test.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the exhaust pipe.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

Refer to Procedure 011-058 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Make sure the DEF dosing valve is providing a uniform spray pattern while dosing.

Measured volume of DEF from doser pump override test within specifications outlined in Procedure 011-058 and DEF dosing valve providing uniform spray pattern?

YES NO
No Repair

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step - 4A Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step - 4B Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Mar-2012


FAULT CODE 3575 (Air-assisted) - Aftertreatment Diesel Exhaust Fluid (DEF) Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Fluid Dosing Unit Tank Filter | Refer to Procedure 011-083 | ISZ13 CM2150 | 4022133
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment Diesel Exhaust Line Restriction Test | Refer to Procedure 011-086 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3575 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3569 active?
STEP 2. | Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Check the DEF dosing unit during priming. | Dosing unit attempts to prime for only 3 seconds? (Plus the 140 second prime delay if applicable)
 | STEP 2B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)
 | STEP 2C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute [6 gallons per minute]?
STEP 3. | Check the DEF dosing unit air supply system. |
 | STEP 3A. Inspect the air supply lines to the DEF dosing unit. | Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 3B. Clear the DEF dosing unit air side circuit. Perform the flushing procedure. | Flushing procedure successful?
STEP 4. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 4A. Check the DEF dosing unit lines and fittings. | DEF lines and fittings pass the inspections?
 | STEP 4B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at the screen filter?
 | STEP 4C. Check the DEF dosing unit lines for restrictions or leaks. | Restriction line test completed successfully?
 | STEP 4D. Inspect the DEF tank and the 35 micron tank filter. | DEF tank contaminated or the urea solution less than 32.5%?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3575 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3569 active?
YES NO

Troubleshoot Fault Code 3569.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Verify the priming cycle of the DEF dosing unit.

Guided Step 2A - Check the DEF dosing unit during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check the DEF dosing unit during priming.

  • After key ON with the engine operating, listen for the DEF dosing pump to start
  • Time the pump operation until the pump automatically switches off (The pump is attempting to prime)

Note: While the engine is operating it may be difficult to hear the pump. If this is the case, listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

NOTE: Older calibrations did not incorporate the 140 second delay from key ON to initial prime cycle. During the 140 second delay the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization built up on injection tip prior to the priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Key ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming, this step may be attempted up to 20 times).

4. The DEF injection line will now exhaust air. Priming is now complete.

Note: If the pump detects a problem during priming, the priming attempt will be aborted after 3 seconds.

Dosing unit attempts to prime for only 3 seconds? (Plus the 140 second prime delay if applicable)

YES NO

Complete line restriction testing procedure then prime again. Refer to Procedure 011-086 in the Associated Procedures Table.

Note: : If system fails to prime on the second attempt, then a malfunctioning DEF dosing unit has been detected. Replace the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Be sure the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is has completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment DEF Dosing Unit State to confirm the doser status.

Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Note: will attempt to prime up to 20 times)

YES NO
No Repair

NOTE: The DEF dosing unit has not primed.

Go to 2C

Go to 4A

Guided Step 2C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Secure the DEF dosing line and the attached air flow meter.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 liters per minute [6.6 gallons per minute]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check DEF dosing unit air supply system.

Guided Step 3A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Make sure the vehicle air tanks are full.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for contamination from water or excessive oil from the vehicle compressed air system.
  • Make sure a clean air supply of at least 517 kPa [75 psi] of pressure is present at the DEF dosing unit, downstream of the air filter.

NOTE: Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Correct the OEM air supply connection or supply.

Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Clear the DEF dosing unit air side circuit. Perform the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Perform the DEF dosing unit flushing procedure.

  • Refer to Procedure 011-082 in the Associated Procedures Table.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Flushing procedure successful?
YES NO
No Repair

A damaged DEF dosing unit has been detected. Replace the DEF dosing unit.

Go to 4A

Go to 5A

Guided Step 4 - Check the DEF lines and fittings for restriction and contamination.

Guided Step 4A - Check the DEF dosing unit lines and fittings.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit lines and fittings for the following:

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fitting.
  • Cracked DEF lines, resulting in leaks or drawing in air.
  • Be sure DEF is returning to the tank during the priming cycle.

DEF unit lines and fittings pass the inspections?
YES NO
No Repair

Repair or replace DEF lines and/or connectors. Refer to the OEM service manual.

Go to 4B

Go to 2B

Guided Step 4B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the DEF dosing unit supply line
  • Inspect the inlet screen filter. Refer to Procedure 011-060 in the Associated Procedures Table.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Contamination present at the screen filter?
YES NO

Replace the screen filter.

 No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the DEF dosing lines for restrictions or leaks.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Complete the line restriction procedure.

  • Refer to Procedure 011-086 in the Associated Procedures Table.
  • Check the DEF lines for leaks or restrictions.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

  • Remove and check the supply and return lines.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Restriction line test completed successfully?
YES NO
No Repair

Repair or replace the DEF lines and/or connectors.

Refer to OEM Service Manual.

Go to 4D

Go to 2B

Guided Step 4D - Inspect the DEF tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

Refer to the OEM service manual for removal/installation procedures for the DEF tank and DEF tank level sensor assembly.

NOTE: In some cases the DEF tank is bonded to the vehicle chassis leaving no access to DEF tank level sensor assembly. If this is the case, contact the OEM to arrange for the tank to be removed and inspected.

  • Inspect the contents of the tank.
  • Inspect the condition of the tank filter.
  • Check that a 35 micron tank filter is fitted. Refer to Procedure 011-083 in the Associated Procedures Table.
  • Check and record the urea concentration of the DEF using a sample from the tank. Refer to Procedure 018-026 in Section V.

DEF tank contaminated or the urea solution less than 32.5%?

YES NO

Locate/remove source, inform OEM. If required, replace components and connectors. Drain/refill the DEF tank. Refer to OEM service manual.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 3575 (Airless) - Aftertreatment Diesel Exhaust Fluid (DEF) Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3575 active or more than 2 inactive counts?
 | STEP 1B. Check for active aftertreatment DEF system fault codes. | Fault Code 1681, 3565, 3566, 3567, 3568, 3577, 3578, 3579, 3612, or 3679 active?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 2B. Check the aftertreatment DEF dosing unit return line. | DEF return line blocked or restricted?
 | STEP 2C. Inspect the aftertreatment DEF dosing unit return line fitting. | Dosing unit return line fitting blocked?
STEP 3. | Check aftertreatment DEF dosing unit operation. |
 | STEP 3A. Perform aftertreatment DEF doser pump override test. | Measured volume of DEF from doser pump override test within specifications outlined in Procedure 011-058?
 | STEP 3B. Perform aftertreatment DEF doser pump override test with new filter. | Measured volume of DEF from doser pump override test within specifications outlined in Procedure 011-058?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3575 active or more than 2 inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active fault codes relating to the aftertreatment DEF dosing unit, return valve, or dosing valve. Fault Codes 1681, 3565, 3566, 3567, 3568, 3577, 3578, 3579, 3612, or 3679.

Fault Code 1681, 3565, 3566, 3567, 3568, 3577, 3578, 3579, 3612, or 3679 active?
YES NO

Troubleshoot any active faults in this list before troubleshooting fault code 3575.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all three aftertreatment DEF dosing unit fittings and lines.

  • Check the dosing unit supply, dosing valve supply, and return connectors and fittings for loose or leaking connections
  • Disconnect the dosing unit supply, dosing valve supply, and return connectors on the dosing unit and look for signs of build-up or blockage.
  • Check the dosing unit supply line for signs of leakage or openings which would allow the dosing unit to suck in air with the DEF.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking DEF line or fitting as necessary.

Refer to the original equipment manufacturer (OEM) service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit return line from the dosing unit (return line runs between the tank and dosing unit and returns DEF to the tank).
  • Disconnect the aftertreatment DEF dosing unit return line from the DEF tank.

Action

Check the DEF return line for blockage.

  • Check both ends of the line for signs of build-up or blockage.
  • Blow compressed shop air through the return line to ensure free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

Refer to the OEM service manual.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the aftertreatment DEF dosing unit return line fitting.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit return line from the dosing unit (return line runs between the tank and dosing unit and returns DEF to the tank).
  • Remove the DEF dosing unit return line fitting.

Action

Inspect the aftertreatment DEF dosing unit return line fitting for blockage or restrictions.

  • If necessary, blow compressed shop air through the return line fitting.
  • Note: The return line fitting is equipped with an internal check valve that only allows flow in one direction.
  • Refer to Procedure 011-058 in the Associated Procedures Table.

Dosing unit return line fitting blocked?

YES NO

Replace the DEF dosing unit return line fitting.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment DEF dosing unit operation.

Guided Step 3A - Perform aftertreatment DEF doser pump override test.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from exhaust pipe.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Measured volume of DEF from doser pump override test within specifications outlined in Procedure 011-058?

YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter. (Note: This filter can not be reused and must be replaced upon removal.)

Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Perform aftertreatment DEF doser pump override test with a new filter.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from exhaust pipe.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Measured volume of DEF from doser pump override test within specifications outlined in Procedure 011-058?

YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Nov-2012


FAULT CODE 3576 - Aftertreatment Diesel Exhaust Fluid (DEF) Tank Heater - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3576 inactive?
STEP 2. | Check the aftertreatment DEF tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3576 inactive and Fault Code 1683 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 3576 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 1A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF tank heater control valve circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the aftertreatment DEF controller harness.

Action

Inspect the engine harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Component Connector and Pin Inspection. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF tank heater control valve SIGNAL pin and the aftertreatment DEF tank heater control valve RETURN pin at the aftertreatment DEF tank heater control valve wiring harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 inactive and Fault Code 1683 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank heater control valve to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 active?
YES NO

A damaged aftertreatment DEF tank heater control valve has been detected.

  • Replace the aftertreatment DEF tank heater control valve. Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Inspect the aftertreatment DEF controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Component Connector and Pin Inspection. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Disconnect the aftertreatment DEF tank heater control valve from the harness.

Action

Check for an open circuit in the aftertreatment DEF tank heater control valve circuit.

  • Measure the resistance between the aftertreatment DEF control valve SIGNAL pin at the harness connector and the 86-pin controller connector.
  • Measure the resistance between the aftertreatment DEF control valve RETURN pin at the harness connector and the 86-pin controller connector.

Greater than 100k ohms?
YES NO

An open circuit has been detected in the aftertreatment DEF controller harness.

  • Repair or replace the harness. Refer to the OEM service manual.

Replace the aftertreatment DEF controller. Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Apr-2012


FAULT CODE 3597 - Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3597 inactive?
 | STEP 1B. Check for active fault codes. | Fault codes 3597 and 2771 both active?
 | STEP 1C. Check active aftertreatment DEF controller voltage supply fault codes. |
STEP 2. | Check the aftertreatment DEF controller circuit. |
 | STEP 2A. Inspect aftertreatment DEF controller and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF controller. | Voltage is within 1-VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. |
 | STEP 3. Check the OEM harness. |
 | STEP 3A. Check the battery and the power connector. |
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller battery voltage supply |
 | STEP 4. Check the J1939 data link. |
 | STEP 4A. Inspect ECM and engine harness connector pins. |
 | STEP 4B. Check for an open circuit in the J1939 data link harness. |
 | STEP 4C. Check for a short circuit in the J1939 data link harness. |
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. |
 | STEP 4E. Check the J1939 terminating resistance. |
 | STEP 4F. Check the fault codes. |
 | STEP 5. Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. |
 | STEP 5B. Disable the fault code. |

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3597 and 2771 both active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check for active aftertreatment DEF controller voltage supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 477 or 478 active?
YES NO

Troubleshoot active Fault Codes 477 or 478 before troubleshooting Fault Code 3597.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF controller circuit.

Guided Step 2A - Inspect aftertreatment DEF controller and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller from the OEM harness.

Action

Inspect the harness and aftertreatment DEF controller 53-pin connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the controller or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DEF controller.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller 53-pin connector.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF controller.

  • Measure the voltage between the aftertreatment DEF controller battery voltage SUPPLY circuit and the aftertreatment DEF controller battery voltage RETURN circuit at the 53-pin OEM wiring harness connector.

NOTE: Check the voltage at key-on, while cranking the engine, and with the engine at idle.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 4A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO

Tighten the connections.

Tighten the loose connections, and clean the terminals.

Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller battery voltage supply.

Conditions

  • .Turn keyswitch OFF
  • Disconnect the aftertreatment DEF controller 53-pin connector.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment DEF controller battery voltage SUPPLY pin of the 53-pin OEM harness connector to engine block ground.

NOTE: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment DEF controller battery voltage RETURN circuit.

Repair or replace the OEM harness.

Refer to the OEM service manual.

An open circuit has been detected in the aftertreatment DEF controller battery voltage SUPPLY circuit.

Repair or replace the OEM harness.

Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DEF controller 53-pin connector.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the aftertreatment DEF controller 53-pin wiring harness connector and the SAE J1939 datalink (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 datalink (-) wire at the aftertreatment DEF controller 53-pin wiring harness connector and the SAE J1939 data link (-) wire at the ECM OEM harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link.

Troubleshoot the OEM wiring harness, and all interconnects for an open circuit.

Repair or replace the malfunctioning component.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller 53-pin connector.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit in the J1939 datalink harness.

  • Measure the resistance between the SAE J1939 datalink (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 datalink (−) wire at the ECM OEM harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 datalink (+) and the SAE J1939 datalink (-) pins.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step - 4D Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DEF controller 53-pin connector
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DEF controller 53-pin connector.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 datalink (-) wire at the aftertreatment DEF controller 53-pin OEM harness connector.

50 to 70 ohms?
YES NO
No Repair

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness.

Refer to the OEM service manual.

Go to 4F

Go to 5A

Guided Step 4F - Check the fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness to the ECM
  • Connect the aftertreatment DEF controller 53-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 is active?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step - 5 Check ECM calibration and clear fault codes.

Guided Step - 5A Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 03-Apr-2012


FAULT CODE 3612 - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1117, 3577, 3578, or 3579 active?
STEP 2. | Check main battery disconnect switch operation. |
 | STEP 2A. Check main battery disconnect switch, if equipped. | Battery disconnect switch and shutdown sequence ok?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid return valve fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117, 3577, 3578, or 3579 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check main battery disconnect switch operation.

Guided Step 2A - Check main battery disconnect switch, if equipped.

Conditions

  • Turn keyswitch OFF.

Action

Check the main battery disconnect switch for the following:

  • If the vehicle is equipped with an automatic main battery disconnect switch, make sure it has a built-in delay device to prevent power-down of the dosing unit until the purge sequence is complete.
  • Make sure that the operator is shutting down the engine using the keyswitch and not the main battery disconnect.
  • Make sure the dosing unit remains powered for at least 60 seconds after key OFF.

Battery disconnect switch and shutdown sequence ok?
YES NO
No Repair

Repair the wiring so the diesel exhaust fluid dosing unit remains powered for at least 60 seconds after key OFF. Consult with the OEM if necessary.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Apr-2012


FAULT CODE 3726 - Aftertreatment Intake NOx - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM875 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM875 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3726 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3726 active?
YES NO

Replace the aftertreatment DEF dosing unit.

  • Use the following procedure for air-assisted SCR dosing systems. Refer to 019-440 in the Associated Procedures Table.
  • Use the following procedure for airless SCR dosing systems. Refer to 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jun-2012


FAULT CODE 3731 - Instrument Cluster Control Module - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3731 active?
STEP 3. | Check the OEM vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for engine control module (ECM) communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate ECM No Communication troubleshooting tree

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3731 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Use the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 3735 - Engine Auxiliary Governor Switch - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with the ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM. Use a data link adapter (J1939) ECM connector.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM service manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Connect the ECM bench calibration harness to the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM.Use a data link adapter (J1939) ECM connector.

INSITE™ electronic service tool communicates with the ECM?
YES NO

NSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM service manual.

Refer to the Communication Error - Electronic Service Tool or Control Device Symptom troubleshooting tree.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Nov-2009


FAULT CODE 3736 - Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM220 AN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
ECM Calibration Code | Refer to Procedure 019-032 | ISF2.8 CM2220 AN | 4022178
ECM Calibration Code | Refer to Procedure 019-032 | ISF3.8 CM2220 AN | 4021704

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3558 inactive?
STEP 2. | Check the aftertreatment DEF dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3558 inactive and Fault Code 3561 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF dosing unit condition. | Fault Code 3558 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3558 inactive and Fault Code 3561 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3558 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 3429, 3571, and 3579 will be active.

Fault Code 3558 inactive and Fault Code 3561 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3558 active?
YES NO

A damaged aftertreatment DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Inspect the aftertreatment DEF controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Turn keyswitch ON.
  • Turn keyswitch OFF for a minimum of 1 minute.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

NOTE: The key cycle with the controller unplugged (as outlined in the ‘Conditions’ section) must be performed to make sure that the proper fault code is set.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3571, 3576, and 3579 will also be active.

Fault Code 3558 inactive and Fault Code 3561 active?
YES NO

A short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Apr-2012


FAULT CODE 3738 - Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3738 inactive?
 | STEP 1B. Check for air supply actuator fault codes. | Fault Code 1697 or 1698 active?
STEP 2. | Check DEF dosing unit air supply system. |
 | STEP 2A. Check the DEF dosing unit air solenoid. | Is the air solenoid clicking, and allowing air to flow from the DEF line?
 | STEP 2B. Inspect the air supply lines to the DEF dosing unit. | Is the OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
STEP 3. | Perform the DEF doser pump override test. |
 | STEP 3A. Perform the DEF doser pump override test with INSITE™ electronic service tool. | Does the DEF dosing unit operate correctly during INSITE™ electronic service tool override test?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3738 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for air supply actuator fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1697 or 1698 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Appropriate Fault Code Troubleshooting Tree

Guided Step 2A - Check the DEF dosing unit air solenoid.

Conditions

  • Disconnect DEF line from the aftertreatment nozzle and secure appropriately
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Make sure the vehicle air tanks are full.

Action

Check the solenoid.

  • Use INSITE™ electronic service tool to perform the “DEF Doser Pump Air Solenoid Click Test” under the ECM Diagnostic Tests menu.
  • Check for correct solenoid operation.
  • While the test is running, the solenoid should click, and air flow must be felt at the outlet of the aftertreatment nozzle line.

Is the air solenoid clicking, and allowing air to flow from the DEF line?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON
  • Make sure the vehicle air tanks are full.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for contamination from water or excessive oil from the vehicle compressed air system.
  • Make sure a clean air supply of at least 517 kPa [75 psi] of pressure is present at the DEF dosing unit, downstream of the air filter.

Is the OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO

A malfunctioning DEF dosing unit has been detected. Replace the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Correct the OEM air supply connection or supply. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Perform the DEF doser pump override test.

Guided Step 3A - Perform the DEF doser pump override test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Start and idle engine.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

Does the DEF dosing unit operate correctly during INSITE™ electronic service tool override test?
YES NO
No Repair

Replace the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 3749 - Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2150 SN | 4022190
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISZ13 CM2150 | 4022133

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3749 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 1887 or 2771 active?
STEP 2. | Check the aftertreatment outlet NOx sensor. |
 | STEP 2A. Check the aftertreatment outlet NOx sensor. | Is the aftertreatment outlet NOx sensor installed correctly with no signs of tampering detected?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3749 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1887 or 2771 active?
YES | NO
No Repair | No Repair

Go to Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor.

Guided Step 2A - Check the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.

Action

The aftertreatment outlet NOx sensor should be securely installed in the vehicle exhaust tailpipe at the outlet of the SCR aftertreatment system.

Inspect the outlet NOx sensor for the following:

  • Correct NOx sensor part number
  • NOx sensor removal or relocation
  • Indications of NOx sensor tampering.

Is the aftertreatment outlet NOx sensor installed correctly with no signs of tampering detected?
YES NO

A malfunctioning aftertreatment outlet NOx sensor has been detected. Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

Correctly install the NOx sensor and repair the tampering if possible.

Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibraton Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 3866 - Aftertreatment Diesel Exhaust Fluid (DEF) Quality - Data Valid but Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2150 SQ | 2883504
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISB6.7 CM2150 SQ | 2883504

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3866. | Fault Code 3866 active?
STEP 2. | Check the diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF tank for contamination. | Diesel fuel detected in the DEF tank?
 | STEP 2B. Check the aftertreatment DEF concentration. | DEF concentration within 32.5 ± 1.25 percent?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3866.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3866 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for diesel fuel.

Diesel fuel detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF Refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. Refer to Procedure 019-475 in the Associated Procedures Table.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Apr-2012


FAULT CODE 3867 - Aftertreatment Diesel Exhaust (DEF) Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2150 SQ | 2883504
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISB6.7 CM2150 SQ | 2883504

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for for Fault Code 3867. | Fault Code 3867 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF concentration. | DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3867.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3867 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF Refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. Refer to Procedure 019-475 in the Associated Procedures Table.

Drain the DEF fluid tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Apr-2012


FAULT CODE 3868 - Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the battery. To reduce the possibility of arching, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3868 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) quality sensor and circuit. |
 | STEP 2A. Inspect the DEF quality sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the DEF quality sensor. | Voltage within 1-VDC of battery voltage?
STEP 3. | Check the OEM wiring harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the DEF quality sensor battery voltage supply. | Voltage within 1-VDC of battery voltage?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | Resistance between 50 and 70 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) quality sensor and circuit.

Guided Step 2A - Inspect the DEF quality sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF quality sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the DEF quality sensor

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF quality sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the DEF quality sensor.

  • Measure the voltage between the DEF quality sensor battery voltage SUPPLY circuit and the DEF quality sensor battery voltage return circuit at the sensor wiring harness connector.

Note: Check the voltage at key ON, while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM wiring harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the DEF quality sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF quality sensor from the OEM wiring harness.

Action

Check for an open circuit.

  • Measure the voltage from the DEF quality sensor battery voltage SUPPLY pin of the OEM wiring harness connector to engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the DEF quality sensor battery voltage return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the DEF quality sensor battery voltage.

Troubleshoot the OEM harness, any fuses, and/or relays in the supply circuit.

Repair or replace the necessary components.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link harness.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisutre in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the DEF quality sensor from the OEM harness
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the DEF quality sensor wiring harness connector and the SAE J1939 (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the DEF quality sensor wiring harness connector and the SAE J1939 (-) wire at the ECM OEM harness connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DEF quality sensor from the OEM wiring harness
  • Disconnect the DEF dosing unit from the OEM wiring harness
  • Disconnect the OEM wiring harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and all other pins in the connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DEF quality sensor from the OEM wiring harness
  • Disconnect the DEF dosing unit from the OEM harnesses
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the DEF quality sensor from the OEM harness.

Action

Check the terminating resistance of the J1939 data link.

  • Measure the resistance between the J1939 data link (+) wire and the J1939 data link (-) wire at the DEF quality sensor wiring harness connector.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An incorrect terminating resistance has been detected in the OEM harness.

Repair the OEM J1939 data link. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Apr-2012


FAULT CODE 3876 - Aftertreatment Diesel Exhaust Fluid (DEF) Quality - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2150 SQ | 2883504
Aftertreatment DEF Quality Sensor | Refer to Procedure 019-475 | ISB6.7 CM2150 SQ | 2883504

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3876 active?
 | STEP 1B. Check for active fault codes. | Fault codes for DEF level active?
STEP 2. | Check the aftertreatment DEF quality sensor. |
 | STEP 2A. Inspect the aftertreatment DEF quality sensor. | Aftertreatment DEF quailty sensor properly installed?
 | STEP 2B. Inspect the aftertreatment DEF quality sensor. | Aftertreatment DEF quality sensor meets the inspection criteria?
 | STEP 2C. Check the aftertreatment DEF quality sensor. | Fault Code 3876 active?
 | STEP 2D. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3876 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes for DEF level active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF quality sensor.

Guided Step 2A - Inspect the aftertreatment DEF quality sensor.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF quality sensor.

  • Check to make sure the aftertreatment DEF quality sensor is properly installed.
  • Refer to the OEM service manual.

Aftertreatment DEF quality sensor properly installed?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Inspect the aftertreatment DEF quality sensor.

Conditions

  • Turn keyswitch OFF
  • Remove the aftertreatment DEF quality sensor.

Action

Inspect the aftertreatment DEF quality sensor.

  • Inspect the aftertreatment DEF quality sensor for crystallization or debris. Refer to Procedure 019-475 in the Associated Procedures Table.

Aftertreatment DEF quality sensor meets the inspection criteria?
YES NO
No Repair

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the aftertreatment DEF quality sensor.

Conditions

  • Place the aftertreatment DEF quality sensor in a beaker of new DEF. Refer to Procedure 019-475 in the Associated Procedures Table.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3876 active?
YES NO

A malfunctioning aftertreatment DEF sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the DEF for contamination.

Conditions

  • Check the DEF for contamination.

Action

Check the DEF in the tank for contamination, water, or incorrect fluid.

  • Use the DEF refractometer, Part Number 4919318, to check the DEF concentration.
  • Inspect the DEF for contamination.

DEF contaminated?
YES NO

Empty and clean the DEF tank.

Refill the tank with new DEF.

Continue to investigate the cause of contamination.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Apr-2012


FAULT CODE 3877 - Aftertreatment Diesel Exhaust Fluid Quality Sensor - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2150 SQ | 2883504
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISB6.7 CM2150 SQ | 2883504

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3877 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) quality sensor. |
 | STEP 2A. Inspect the aftertreatment DEF quality sensor. | Aftertreatment DEF quality sensor meets inspection criteria?
 | STEP 2B. Check for active fault codes. | Fault Code 3877 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3877 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) quality sensor.

Guided Step 2A - Inspect the aftertreatment DEF quality sensor.

Conditions

  • Turn keyswitch OFF
  • Remove the aftertreatment DEF quality sensor.

Action

Inspect the aftertreatment DEF quality sensor.

  • Inspect the aftertreatment DEF quality sensor for damage or debris. Refer to Procedure 019-475 in the Associated Procedures Table.

Aftertreatment DEF quality sensor meets inspection criteria?
YES NO

Clean the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for active fault codes.

Conditions

  • Install aftertreatment DEF quality sensor
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3877 active?
YES NO

An internal error has been detected in the aftertreatment DEF quality sensor.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Apr-2012


FAULT CODE 3878 - Aftertreatment Diesel Exhaust Fluid Quality Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2150 SQ | 2883504
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISB6.7 CM2150 SQ | 2883504

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 3878 active or more than three inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) quality sensor mounting location. |
 | STEP 2A. Make sure the aftertreatment DEF quality sensor is properly mounted. | Aftertreatment DEF quality sensor properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment DEF quality sensor. | Signs of air flow restriction or debris on the aftertreatment DEF quality sensor?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3878 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) quality sensor mounting location.

Guided Step 2A - Make sure the aftertreatment DEF quality sensor is properly mounted.

Conditions

  • Turn keyswitch OFF
  • Engine not running.

Action

Determine the designated mounting location for the aftertreatment DEF quality sensor, and verify the sensor is mounted at the correct location on the vehicle. Refer to the OEM service manual.

  • Make sure all fasteners are properly installed and secure.

Aftertreatment DEF quality sensor properly installed?
YES NO
No Repair

Relocate and/or secure the aftertreatment DEF quality sensor at the correct mounting location. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment DEF quality sensor.

Conditions

  • Turn keyswitch OFF
  • Engine not running.

Action

Check the aftertreatment diesel exhaust fluid quality sensor mounting area for air flow obstructions. The diesel exhaust fluid quality sensor is designed to be mounted such that air will flow over it and naturally cool during operation. Restrictions or blockage of this air flow could cause the sensor to overheat.

Check the sensor for the following:

  • Debris in or around the aftertreatment DEF quality sensor
  • Aftermarket shields, flaps, or brackets mounted too close to the aftertreatment DEF quality sensor.

Signs of air flow restriction or debris on the aftertreatment DEF quality sensor?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the aftertreatment DEF quality sensor.

Relocate any aftermarket accessories that might be restricting air flow.

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Oct-2010


FAULT CODE 3879 - Aftertreatment Diesel Exhaust Fluid (DEF) Quality - Data Valid but Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2150 SQ | 2883504
Aftertreatment DEF Quality Sensor | Refer to Procedure 019-475 | ISB6.7 CM2150 SQ | 2883504

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3879. | Fault Code 3879 active?
STEP 2. | Check the aftertreatment DEF concentration. |
 | STEP 2A. Check the aftertreatment DEF concentration. | Aftertreatment DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3879.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3879 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the DEF concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use a DEF refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in Section 19.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Apr-2012


FAULT CODE 4484 - Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3139 or 3141 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4484 active?
 | STEP 1C. Verify the fault code. | Fault Code 4484 active?
STEP 2. | Check the engine air shutoff position switch and circuit. |
 | STEP 2A. Inspect the engine air shutoff position switch and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine air shutoff position switch signal and return circuits. | Greater than 5-VDC?
 | STEP 2C. Check the engine air shutoff position switch return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3139 or 3141 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4484 active?
YES | NO
No Repair | No Repair

Go to 1C

Go to 1C

Guided Step 1C - Verify the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Use INSITE™ electronic service tool to calibrate the ECM.

NOTE: The engine must be calibrated again to clear the fault code.

Verify the complaint.

  • Perform the Air Shutoff Valve Test.

Fault Code 4484 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine air shutoff position switch and circuit.

Guided Step 2A - Inspect the engine air shutoff position switch and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM harness.

Action

Inspect the OEM harness and engine air shutoff position switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine air shutoff position switch signal and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check the engine air shutoff position switch signal and return circuits.

  • Measure the voltage between the engine air shutoff position switch SIGNAL pin and the engine air shutoff position switch RETURN pin at the engine air shutoff position switch connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5-VDC?
YES NO

An open circuit has been detected in the engine air shutoff solenoid.

  • Refer to OEM service manual.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an engine air shutoff position switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff position switch RETURN pin in the OEM harness and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine air shutoff position switch return circuit.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component(s).

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff position switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff position switch SIGNAL pin in the engine harness ECM connector and the engine air shutoff position switch SIGNAL pin at the engine air shutoff position switch OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine air shutoff position switch signal circuit.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component(s).

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff position switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff position switch RETURN pin in the engine harness ECM connector and the engine air shutoff position switch RETURN pin at the engine air shutoff position switch OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine air shutoff solenoid return circuit.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff position switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine air shutoff position switch SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine air shutoff position switch SIGNAL wire has been detected.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component(s).

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff position switch from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine air shutoff position switch SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the OEM air shutoff solenoid. Refer to the OEM service manual.

A pin-to-pin short circuit on the engine air shutoff position switch SIGNAL wire has been detected.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component(s).

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Use INSITE™ electronic service tool to calibrate the ECM.

NOTE: The engine must be calibrated again to clear the fault code.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2013


FAULT CODE 4572 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 4572 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3326 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for ECM communication.

  • Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4572 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Note: Refer to the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 Section 19.

50 to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connector to all other pins in the OEM connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Feb-2015


FAULT CODE 4642 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 4642?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4642.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 4642?
YES NO

Drain water from the fuel filter.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 4731 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4731 active?
YES NO

A malfunctioning deisel exhaust fluid (DEF) tank temperature sensor has been detected.

Replace the DEF tank temperature sensor. Refer to the original equipment manufacturer (OEM) service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Oct-2013


FAULT CODE 4732 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4732 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4732 active?
YES NO

A malfunctioning diesel exhaust fluid(DEF) tank level sensor has been detected.

Replace the DEF tank level sensor. Refer to the original equipment manufacturer (OEM) service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Oct-2013


FAULT CODE 4737 - Aftertreatment Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 or 4572 active?
STEP 2. | Check engine control moduoe (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 4572 active?
YES NO
No Repair

An internal malfunction has been detected in the diesel exhaust fluid (DEF) tank temperature sensor.

Replace the DEF tank temperature sensor.

Refer to the original equipment manufacturer (OEM) service manual.

NOTE: The DEF tank temperature sensor may be a combination type sensor that measures tank level, temperature, and quality. Refer to the OEM service manual.

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Oct-2013


FAULT CODE 4739 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 or 4739 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 4739 active?
YES NO
No Repair

An internal failure has been detected in the diesel exhaust fluid (DEF) tank level sensor.

Replace the DEF tank level sensor.

Refer to the original equipment manufacturer (OEM) service manual.

Note: The DEF tank temperature sensor may be a combination type sensor that measures tank level, temperature, and quality. Refer to the OEM service manual.

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Nov-2013


FAULT CODE 4769 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1668, 1669, 4679, 4732, 4738, or 4739 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4769 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668, 1669, 4679, 4732, 4738, or 4739 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4769 active?
YES NO

An internal error has been detected in the aftertreatment diesel exhaust fluid (DEF) tank level sensor.

Replace the aftertreatment DEF tank level sensor.

Refer to the equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Dec-2014


FAULT CODE 4948 - Performance Bias Selection Switch - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 4948 inactive?
STEP 2. | Check the performance bias selection switch and connector pins. |
 | STEP 2A. Inspect the performance bias selection switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4949 active and Fault Code 4948 inactive?
 | STEP 2C. Check the fault codes and verify the switch condition. | Fault Code 4948 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 4948 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4948 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the performance bias selection switch and circuit.

Guided Step 2A - Inspect the performance bias selection switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the performance bias selection switch from the OEM harness.

Action

Inspect the OEM harness and the performance bias selection switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the performance bias selection switch from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the performance bias selection SIGNAL pin and the performance bias selection RETURN pin at the switch connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4949 active and Fault Code 4948 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the switch condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the performance bias selection switch to the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4948 active?
YES NO

A damaged performance bias selection switch has been detected.

Replace the performance bias selection switch. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the performance bias selection switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector performance bias selection switch RETURN pin and the OEM harness performance bias selection switch connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the performance bias selection switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector performance bias selection switch SIGNAL pin and the OEM harness performance bias selection switch connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the performance bias selection switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the performance bias selection switch SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4948 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jun-2016


FAULT CODE 4949 - Performance Bias Selection Switch - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 4949 inactive?
STEP 2. | Check the performance bias selection switch and circuit. |
 | STEP 2A. Inspect the performance bias selection switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4948 active and Fault Code 4949 inactive?
 | STEP 2C. Check the fault codes and verify the switch condition. | Fault Code 4949 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 4949 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4949 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the performance bias selection switch and circuit.

Guided Step 2A - Inspect the performance bias selection switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the performance bias selection switch from the OEM harness.

Action

Inspect the OEM harness and the performance bias selection switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the performance bias selection switch from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4949 inactive and Fault Code 4948 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the switch condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the performance bias selection switch to the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4949 active?
YES NO

Replace the performance bias selection switch. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the performance bias selection switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the performance bias selection switch SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the performance bias selection switch from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the performance bias selection switch SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4949 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jun-2016


FAULT CODE 5221 - Engine Air Shutoff Status - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3139 or Fault Code 3141 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4484 active?
 | STEP 1C. Check for active fault codes. | Fault Code 5221 active?
STEP 2. | Check the engine air shutoff position switch and circuit. |
 | STEP 2A. Inspect the engine air shutoff position switch and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibraation is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3139 or 3141 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4484 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5221 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the engine air shutoff position switch and circuit.

Guided Step 2A - Inspect the engine air shutoff position switch and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM harness.

Action

Inspect the OEM harness and engine air shutoff position switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the OEM service manual.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff position switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff position switch SIGNAL pin in the engine harness ECM connector and the engine air shutoff position switch SIGNAL pin at the engine air shutoff position switch OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine air shutoff position switch signal circuit.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged OEM air shutoff solenoid.

  • Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff position switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff position switch RETURN pin in the engine harness ECM connector and the engine air shutoff position switch RETURN pin at the engine air shutoff position switch OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Replace the OEM air shutoff solenoid.

  • Refer to the OEM service manual.

An open circuit has been detected in the engine air shutoff solenoid RETURN circuit.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component.

  • Refer to Procedure 010-143 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


INDEX
120-fc111.htm

00-t05-111.htm

120-fc115.htm

00-t05-115.htm

120-fc122.htm

00-t05-122.htm

120-fc123.htm

00-t05-123.htm

120-fc125.htm

120-t05-125.htm

120-fc131.htm

00-t05-131.htm

120-fc132.htm

00-t05-132.htm

120-fc133.htm

00-t05-133.htm

120-fc134.htm

00-t05-134.htm

120-fc135.htm

120-fc135sensor.htm

120-t05-135sensor.htm

120-fc135switch.htm

120-t05-135switch.htm

120-fc141.htm

120-fc141sensor.htm

120-t05-141sensor.htm

120-fc141switch.htm

120-t05-141switch.htm

120-fc143.htm

00-t05-143.htm

120-fc144.htm

00-t05-144.htm

120-fc145.htm

00-t05-145.htm

120-fc146.htm

00-t05-146.htm

120-fc151.htm

00-t05-151.htm

120-fc153.htm

00-t05-153.htm

120-fc154.htm

00-t05-154.htm

120-fc155.htm

00-t05-155.htm

120-fc175.htm

00-t05-175.htm

120-fc176.htm

00-t05-176.htm

120-fc177.htm

00-t05-177.htm

120-fc187.htm

120-t05-187.htm

120-fc191.htm

120-t05-191.htm

120-fc195.htm

120-fc195-2wire.htm

120-t05-195-2wire.htm

120-fc195-3wire.htm

120-t05-195-3wire.htm

120-fc196.htm

120-fc196-2wire.htm

120-t05-196-2wire.htm

120-fc196-3wire.htm

120-t05-196-3wire.htm

120-fc197.htm

120-t05-197.htm

120-fc212.htm

00-t05-212.htm

120-fc213.htm

00-t05-213.htm

120-fc214.htm

00-t05-214.htm

120-fc221.htm

120-t05-221.htm

120-fc222.htm

120-t05-222.htm

120-fc227.htm

120-t05-227.htm

120-fc234.htm

00-t05-234.htm

120-fc238.htm

00-t05-238.htm

120-fc239.htm

00-t05-239.htm

120-fc241.htm

00-t05-241.htm

120-fc242.htm

00-t05-242.htm

120-fc245.htm

00-t05-245.htm

120-fc249.htm

00-t05-249.htm

120-fc252.htm

00-t05-252.htm

120-fc253.htm

00-t05-253.htm

120-fc254.htm

120-t05-254.htm

120-fc255.htm

120-t05-255.htm

120-fc256.htm

00-t05-256.htm

120-fc257.htm

00-t05-257.htm

120-fc269.htm

00-t05-269.htm

120-fc271.htm

00-t05-271.htm

120-fc272.htm

00-t05-272.htm

120-fc281.htm

00-t05-281.htm

120-fc285.htm

00-t05-285.htm

120-fc286.htm

00-t05-286.htm

120-fc287.htm

00-t05-287.htm

120-fc288.htm

00-t05-288.htm

120-fc291.htm

00-t05-291.htm

120-fc295.htm

00-t05-295.htm

120-fc311.htm

00-t05-311.htm

120-fc312.htm

00-t05-312.htm

120-fc313.htm

00-t05-313.htm

120-fc314.htm

00-t05-314.htm

120-fc315.htm

00-t05-315.htm

120-fc319.htm

00-t05-319.htm

120-fc321.htm

00-t05-321.htm

120-fc322.htm

120-t05-322.htm

120-fc323.htm

120-t05-323.htm

120-fc324.htm

120-t05-324.htm

120-fc325.htm

120-t05-325.htm

120-fc331.htm

120-t05-331.htm

120-fc332.htm

120-t05-332.htm

120-fc334.htm

00-t05-334.htm

120-fc338.htm

00-t05-338.htm

120-fc339.htm

00-t05-339.htm

120-fc343.htm

00-t05-343.htm

120-fc346.htm

00-t05-346.htm

120-fc351.htm

00-t05-351.htm

120-fc352.htm

120-t05-352.htm

120-fc356.htm

00-t05-356.htm

120-fc357.htm

00-t05-357.htm

120-fc358.htm

00-t05-358.htm

120-fc386.htm

120-t05-386.htm

120-fc415.htm

00-t05-415.htm

120-fc418.htm

00-t05-418.htm

120-fc425.htm

00-t05-425.htm

120-fc426.htm

120-t05-426.htm

120-fc427.htm

00-t05-427.htm

120-fc428.htm

00-t05-428.htm

120-fc429.htm

00-t05-429.htm

120-fc435.htm

120-fc435sensor.htm

120-t05-435sensor.htm

120-fc435switch.htm

120-t05-435switch.htm

120-fc436.htm

120-t05-436.htm

120-fc441.htm

00-t05-441.htm

120-fc442.htm

00-t05-442.htm

120-fc449.htm

120-t05-449.htm

120-fc451.htm

00-t05-451.htm

120-fc452.htm

00-t05-452.htm

120-fc465.htm

00-t05-465.htm

120-fc466.htm

120-t05-466.htm

120-fc471.htm

00-t05-471.htm

120-fc477.htm

00-t05-477.htm

120-fc478.htm

00-t05-478.htm

120-fc491.htm

120-t05-491.htm

120-fc492.htm

120-t05-492.htm

120-fc498.htm

00-t05-498.htm

120-fc499.htm

00-t05-499.htm

120-fc527.htm

120-t05-527.htm

120-fc545.htm

120-t05-545.htm

120-fc553.htm

00-t05-553.htm

120-fc554.htm

00-t05-554.htm

120-fc555.htm

00-t05-555.htm

120-fc556.htm

00-t05-556.htm

120-fc559.htm

120-fc559bdf.htm

120-t05-559bdf.htm

120-fc559clxz.htm

120-t05-559clxz.htm

120-fc584.htm

00-t05-584.htm

120-fc585.htm

00-t05-585.htm

120-fc596.htm

00-t05-596.htm

120-fc597.htm

00-t05-597.htm

120-fc598.htm

00-t05-598.htm

120-fc649.htm

00-t05-649.htm

120-fc686.htm

00-t05-686.htm

120-fc687.htm

00-t05-687.htm

120-fc688.htm

00-t05-688.htm

120-fc689.htm

00-t05-689.htm

120-fc691.htm

00-t05-691.htm

120-fc692.htm

00-t05-692.htm

120-fc693.htm

00-t05-693.htm

120-fc697.htm

00-t05-697.htm

120-fc698.htm

00-t05-698.htm

120-fc699.htm

00-t05-699.htm

120-fc731.htm

120-t05-731.htm

120-fc778.htm

00-t05-778.htm

120-fc784.htm

00-t05-784.htm

120-fc1117.htm

00-t05-1117.htm

120-fc1228.htm

120-t05-1228.htm

120-fc1239.htm

00-t05-1239.htm

120-fc1241.htm

00-t05-1241.htm

120-fc1242.htm

00-t05-1242.htm

120-fc1668.htm

120-fc1668air.htm

120-t05-1668air.htm

120-fc1668airless.htm

120-t05-1668airless.htm

120-fc1669.htm

120-fc1669air.htm

120-t05-1669air.htm

120-fc1669airless.htm

120-t05-1669airless.htm

120-fc1671.htm

120-t05-1671.htm

120-fc1673.htm

120-t05-1673.htm

120-fc1677.htm

120-fc1677air.htm

120-t05-1677air.htm

120-fc1677airless.htm

120-t05-1677airless.htm

120-fc1678.htm

120-fc1678air.htm

120-t05-1678air.htm

120-fc1678airless.htm

120-t05-1678airless.htm

120-fc1679.htm

120-fc1679air.htm

120-t05-1679air.htm

120-fc1679airless.htm

120-t05-1679airless.htm

120-fc1681.htm

120-t05-1681.htm

120-fc1682.htm

120-fc1682air.htm

120-t05-1682air.htm

120-fc1682airless.htm

120-t05-1682airless.htm

120-fc1683.htm

120-fc1683air.htm

120-t05-1683air.htm

120-fc1683airless.htm

120-t05-1683airless.htm

120-fc1684.htm

120-fc1684air.htm

120-t05-1684air.htm

120-fc1684airless.htm

120-t05-1684airless.htm

120-fc1688.htm

120-t05-1688.htm

120-fc1689.htm

00-t05-1689.htm

120-fc1692.htm

120-t05-1692.htm

120-fc1694.htm

120-t05-1694.htm

120-fc1695.htm

120-t05-1695.htm

120-fc1696.htm

120-t05-1696.htm

120-fc1697.htm

120-t05-1697.htm

120-fc1698.htm

120-t05-1698.htm

120-fc1711.htm

120-t05-1711.htm

120-fc1712.htm

120-t05-1712.htm

120-fc1713.htm

120-t05-1713.htm

120-fc1843.htm

00-t05-1843.htm

120-fc1844.htm

00-t05-1844.htm

120-fc1848.htm

120-t05-1848.htm

120-fc1852.htm

00-t05-1852.htm

120-fc1879.htm

00-t05-1879.htm

120-fc1881.htm

00-t05-1881.htm

120-fc1883.htm

00-t05-1883.htm

120-fc1887.htm

120-t05-1887.htm

120-fc1896.htm

120-t05-1896.htm

120-fc1898.htm

120-t05-1898.htm

120-fc1911.htm

120-fc1911bdf.htm

120-t05-1911bdf.htm

120-fc1911clxz.htm

120-t05-1911clxz.htm

120-fc1938.htm

00-t05-1938.htm

120-fc1942.htm

00-t05-1942.htm

120-fc1943.htm

00-t05-1943.htm

120-fc1962.htm

00-t05-1962.htm

120-fc1981.htm

120-t05-1981.htm

120-fc1993.htm

00-t05-1993.htm

120-fc2182.htm

120-fc2182ism.htm

120-t05-2182.htm

120-fc2182mr.htm

120-t05-2182.htm

120-fc2183.htm

120-fc2183ism.htm

120-t05-2183.htm

120-fc2183ism.htm

120-t05-2183.htm

120-fc2185.htm

00-t05-2185.htm

120-fc2186.htm

00-t05-2186.htm

120-fc2198.htm

00-t05-2198.htm

120-fc2265.htm

120-t05-2265.htm

120-fc2266.htm

120-t05-2266.htm

120-fc2271.htm

120-t05-2271.htm

120-fc2272.htm

120-t05-2272.htm

120-fc2288.htm

00-t05-2288.htm

120-fc2311.htm

120-t05-2311.htm

120-fc2321.htm

00-t05-2321.htm

120-fc2322.htm

00-t05-2322.htm

120-fc2344.htm

120-t05-2344.htm

120-fc2345.htm

00-t05-2345.htm

120-fc2346.htm

00-t05-2346.htm

120-fc2347.htm

120-t05-2347.htm

120-fc2351.htm

120-t05-2351.htm

120-fc2352.htm

120-t05-2352.htm

120-fc2357.htm

120-t05-2357.htm

120-fc2363.htm

120-fc2363hd.htm

120-t05-2363hd.htm

120-fc2363mr.htm

120-t05-2363mr.htm

120-fc2367.htm

120-fc2367hd.htm

120-t05-2367hd.htm

120-fc2367mr.htm

120-t05-2367mr.htm

120-fc2369.htm

120-t05-2369.htm

120-fc2371.htm

120-t05-2371.htm

120-fc2372.htm

120-t05-2372.htm

120-fc2373.htm

00-t05-2373.htm

120-fc2374.htm

00-t05-2374.htm

120-fc2377.htm

00-t05-2377.htm

120-fc2387.htm

120-t05-2387.htm

120-fc2398.htm

120-t05-2398.htm

120-fc2412.htm

120-t05-2412.htm

120-fc2442.htm

00-t05-2442.htm

120-fc2443.htm

00-t05-2443.htm

120-fc2444.htm

00-t05-2444.htm

120-fc2445.htm

00-t05-2445.htm

120-fc2448.htm

00-t05-2448.htm

120-fc2449.htm

00-t05-2449.htm

120-fc2451.htm

00-t05-2451.htm

120-fc2555.htm

00-t05-2555.htm

120-fc2556.htm

00-t05-2556.htm

120-fc2634.htm

120-t05-2634.htm

120-fc2635.htm

00-t05-2635.htm

120-fc2636.htm

120-t05-2636.htm

120-fc2719.htm

120-t05-2719.htm

120-fc2771.htm

120-t05-2771.htm

120-fc2772.htm

120-fc2772air.htm

120-t05-2772air.htm

120-fc2772airless.htm

120-t05-2772airless.htm

120-fc2773.htm

120-fc2773air.htm

120-t05-2773air.htm

120-fc2773airless.htm

120-t05-2773airless.htm

120-fc2963.htm

00-t05-2963.htm

120-fc2964.htm

00-t05-2964.htm

120-fc2973.htm

120-t05-2973.htm

120-fc2976.htm

120-t05-2976.htm

120-fc3139.htm

120-t05-3139.htm

120-fc3141.htm

120-t05-3141.htm

120-fc3142.htm

120-t05-3142.htm

120-fc3143.htm

120-t05-3143.htm

120-fc3144.htm

120-t05-3144.htm

120-fc3145.htm

120-t05-3145.htm

120-fc3146.htm

120-t05-3146.htm

120-fc3147.htm

120-t05-3147.htm

120-fc3149.htm

120-t05-3149.htm

120-fc3151.htm

120-t05-3151.htm

120-fc3163.htm

00-t05-3163.htm

120-fc3164.htm

00-t05-3164.htm

120-fc3186.htm

00-t05-3186.htm

120-fc3236.htm

120-t05-3236.htm

120-fc3237.htm

120-fc3237air.htm

120-t05-3237air.htm

120-fc3237airless.htm

120-t05-3237airless.htm

120-fc3238.htm

120-t05-3238.htm

120-fc3239.htm

120-t05-3239.htm

120-fc3242.htm

00-t05-3242.htm

120-fc3258.htm

120-t05-3258.htm

120-fc3261.htm

120-t05-3261.htm

120-fc3326.htm

00-t05-3326.htm

120-fc3328.htm

00-t05-3328.htm

120-fc3382.htm

120-t05-3382.htm

120-fc3383.htm

120-t05-3383.htm

120-fc3418.htm

00-t05-3418.htm

120-fc3422.htm

120-t05-3422.htm

120-fc3425.htm

120-t05-3425.htm

120-fc3426.htm

120-t05-3426.htm

120-fc3429.htm

120-t05-3429.htm

120-fc3492.htm

00-t05-3492.htm

120-fc3525.htm

00-t05-3525.htm

120-fc3526.htm

00-t05-3526.htm

120-fc3527.htm

00-t05-3527.htm

120-fc3532.htm

00-t05-3532.htm

120-fc3539.htm

00-t05-3539.htm

120-fc3541.htm

00-t05-3541.htm

120-fc3542.htm

00-t05-3542.htm

120-fc3548.htm

120-t05-3548.htm

120-fc3555.htm

120-t05-3555.htm

120-fc3557.htm

120-t05-3557.htm

120-fc3558.htm

00-t05-3558.htm

120-fc3559.htm

00-t05-3559.htm

120-fc3561.htm

00-t05-3561.htm

120-fc3562.htm

00-t05-3562.htm

120-fc3563.htm

00-t05-3563.htm

120-fc3564.htm

00-t05-3564.htm

120-fc3565.htm

00-t05-3565.htm

120-fc3566.htm

00-t05-3566.htm

120-fc3567.htm

00-t05-3567.htm

120-fc3568.htm

00-t05-3568.htm

120-fc3569.htm

120-fc3569air.htm

120-t05-3569air.htm

120-fc3569airless.htm

120-t05-3569airless.htm

120-fc3571.htm

00-t05-3571.htm

120-fc3572.htm

00-t05-3572.htm

120-fc3574.htm

00-t05-3574.htm

120-fc3575.htm

120-fc3575air.htm

120-t05-3575air.htm

120-fc3575airless.htm

120-t05-3575airless.htm

120-fc3576.htm

120-t05-3576.htm

120-fc3577.htm

00-t05-3577.htm

120-fc3578.htm

00-t05-3578.htm

120-fc3579.htm

00-t05-3579.htm

120-fc3596.htm

00-t05-3596.htm

120-fc3597.htm

120-t05-3597.htm

120-fc3598.htm

00-t05-3598.htm

120-fc3612.htm

120-t05-3612.htm

120-fc3616.htm

00-t05-3616.htm

120-fc3648.htm

00-t05-3648.htm

120-fc3651.htm

00-t05-3651.htm

120-fc3679.htm

00-t05-3679.htm

120-fc3681.htm

00-t05-3681.htm

120-fc3697.htm

00-t05-3697.htm

120-fc3713.htm

00-t05-3713.htm

120-fc3726.htm

120-t05-3726.htm

120-fc3731.htm

120-t05-3731.htm

120-fc3735.htm

120-t05-3735.htm

120-fc3736.htm

120-t05-3736.htm

120-fc3737.htm

00-t05-3737.htm

120-fc3738.htm

120-t05-3738.htm

120-fc3749.htm

120-t05-3749.htm

120-fc3866.htm

120-t05-3866.htm

120-fc3867.htm

120-t05-3867.htm

120-fc3868.htm

120-t05-3868.htm

120-fc3876.htm

120-t05-3876.htm

120-fc3877.htm

120-t05-3877.htm

120-fc3878.htm

120-t05-3878.htm

120-fc3879.htm

120-t05-3879.htm

120-fc4138.htm

00-t05-4138.htm

120-fc4139.htm

00-t05-4139.htm

120-fc4284.htm

00-t05-4284.htm

120-fc4484.htm

120-t05-4484.htm

120-fc4572.htm

120-t05-4572.htm

120-fc4642.htm

120-t05-4642.htm

120-fc4731.htm

120-t05-4731.htm

120-fc4732.htm

120-t05-4732.htm

120-fc4737.htm

120-t05-4737.htm

120-fc4739.htm

120-t05-4739.htm

120-fc4769.htm

120-t05-4769.htm

120-fc4948.htm

120-t05-4948.htm

120-fc4949.htm

120-t05-4949.htm

120-fc5221.htm

120-t05-5221.htm