QST30 - CM850 - Power Generation, QST30 - Power Gen

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Fuel Rack Actuator Position 2 Circuit - Data Incorrect (Right Bank)

FAULT CODE 174

Fuel Rack Actuator Position 2 Circuit - Data Incorrect (Right Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 174 PID: FMI: LAMP: Warning SRT: | Fuel Rack Actuator Position 2 Circuit - data incorrect (right bank). | Performance can be sluggish or slow to respond.
Fuel Rack Actuator Position 2 Circuit

Circuit Description

The fuel rack position sensor circuit's measured, reference and common signals are used by the ECM to verify that the rack has been properly positioned by the rack actuator. This fault code indicates that either the rack is mechanically stuck, or the rack position sensor data is incorrect. This is accomplished as follows:

The ECM sends out a fixed frequency and voltage signal on the reference signal line to the fuel pump. The ECM also sends out a fixed frequency but variable voltage signal that is 180 degrees out of phase from the reference signal from the measured signal line to the fuel pump. The amplitude of the measured signal voltage is measured in the ECM and represents the rack position of the fuel pump.

Circuitry inside the fuel pump compares the difference in voltage between the reference signal input and the measured signal input to the pump and sends a signal back to the ECM that is the difference of these two signals. The difference voltage signal is output on the common signal line back to the ECM. The amplitude of the common signal is dependent on the position of the rack inside the fuel pump. Circuitry inside the ECM determines if the common signal is below a certain threshold. If it is, this means that the rack position of the fuel pump is at the commanded position. The voltage value of the measured signal line is then measured by the ECM and represents the rack position.

Component Location

The fuel pump rack, rack actuator, and rack position sensor are all located within the fuel pump.

Shop Talk

The possible failure modes are rack mechanically stuck, rack position sensor stuck in range, rack position sensor out of calibration, or bad fuel pump.

This fault code requires engine speed greater than zero before the fault will go active.

Fault Code 174 will go active after Fault Code 183 is corrected. If this is the case, key off and Fault Code 174 will go inactive and can be cleared.

Refer to Troubleshooting Fault Code t05-174

Last Modified: 29-Jul-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is a 10-ampere fuse in the battery 1 voltage wires to protect the OEM wiring harness from overheating. The ECM receives power supply through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery 1 voltage return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery through a 4-pin connector on the engine wiring harness inside the generator set panel. The extension harness also has a 4-pin connector that provides battery power to both ECMs and the generator set control panel. The location of the battery will vary with the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low battery voltage.
  • Battery disconnect switch turned off before ECM is powered down.
Refer to Troubleshooting Fault Code 1117 .

Last Modified: 28-Sep-2020


Engine Timing Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 113

Engine Timing Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 113 PID: S20 SPN: 635 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the timing actuator driver circuit. | Possible reduced engine performance.
Engine Timing Actuator Driver Circuit

Circuit Description

The timing actuator circuit supplies current to the timing actuator. The ECM commands a varying amount of current to the timing actuator to control the amount of timing pressure to the injectors.

Component Location

The timing actuator is located on the electronic control valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the timing actuator circuit voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged or malfunctioning timing actuator.
  • Damaged or loose connections.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 113 .

Last Modified: 28-Sep-2020


Engine Timing Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 114

Engine Timing Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 114 PID: S20 SPN: 635 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the timing actuator driver circuit. | Possible reduced engine performance.
Engine Timing Actuator Driver Circuit

Circuit Description

The timing actuator circuit supplies current to the timing actuator. The ECM commands a varying amount of current to the timing actuator to control the amount of timing pressure to the injectors.

Component Location

The timing actuator is located on the electronic control valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the timing rail actuator is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the timing actuator circuit voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connections.
Refer to Troubleshooting Fault Code 114 .

Last Modified: 28-Sep-2020


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Both signals failed to be detected at the engine position sensor circuit. | The engine will shut down or will not start.
Engine Crankshaft Speed Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The engine speed sensor and the engine position sensor are located in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position and camshaft position signal inputs to the ECM are missing or reversed.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed.
  • Damaged or loose connectors.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 115 .

Last Modified: 28-Sep-2020


Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10/10 LAMP: Amber SRT: | No engine speed signal detected from either the main or backup speed sensors. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor Circuit.

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The engine speed sensor and the engine position sensor are located in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a signal failure with engine crankshaft speed sensor or engine position sensor.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • Engine will run on backup speed signal provided by engine position sensor.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or malfunctioning engine speed sensor
  • Damaged or malfunctioning engine position sensor.
  • Damaged tone wheel
Refer to Troubleshooting Fault Code 121 .

Last Modified: 28-Sep-2020


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine oil rifle pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil rifle pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the oil pressure in the oil rifle.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged engine oil rifle pressure sensor.
Refer to Troubleshooting Fault Code 135 .

Last Modified: 28-Sep-2020


Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1357

Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1357 PID: P17 SPN: 1380 FMI: 1/18 LAMP: Amber SRT: | The remote engine oil reservoir is below the normal operating level. | Possible damage to engine if left unresolved.
Engine Oil Remote Reservoir Level Sensor Circuit

Circuit Description

The engine oil remote reservoir level sensor is used to monitor the oil level inside the remote reservior.

Component Location

The engine oil remote reservoir level sensor is located in the engine oil remote reservoir and the location is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote reservoir engine oil level was low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low engine oil level in the remote reservior
  • Malfunctioning engine oil remote reservior level sensor.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 1357 .

Last Modified: 28-Sep-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1383

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1383 PID: P102 SPN: 102 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the intake manifold 1 pressure sensor circuit. | Possible reduced engine performance.
Intake Manifold 1 Pressure Sensor Circuit.

Circuit Description

The intake manifold pressure sensor is a variable resistance sensor used by the ECM to monitor the intake manifold pressure. The intake manifold pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the charged air pressure in the intake manifold.

Component Location

The intake manifold 1 pressure sensor is located in the right bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 1 pressure sensor signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • Intake manifold 2 pressure sensor is used for intake manifold pressure reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning intake manifold 1 pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 1383 .

Last Modified: 28-Sep-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1384

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1384 PID: P102 SPN: 102 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the intake manifold 1 pressure sensor circuit. | Possible reduced engine performance.
Intake Manifold 1 Pressure Sensor Circuit.

Circuit Description

The intake manifold pressure sensor is a variable resistance sensor used by the ECM to monitor the intake manifold pressure. The intake manifold pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the charged air pressure in the intake manifold.

Component Location

The intake manifold 1 pressure sensor is located in the right bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 1 pressure sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • Intake manifold 2 pressure sensor is used for intake manifold pressure reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning intake manifold 1 pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 1384 .

Last Modified: 28-Sep-2020


Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1385

Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1385 PID: SPN: 1128 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the intake manifold 2 pressure sensor circuit. | Possible reduced engine performance.
Intake Manifold 2 Pressure Sensor Circuit.

Circuit Description

The intake manifold pressure sensor is a variable resistance sensor used by the ECM to monitor the intake manifold pressure. The intake manifold pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the charged air pressure in the intake manifold.

Component Location

The intake manifold 2 pressure sensor is located in the left bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 2 temperature sensor signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • Intake manifold 1 pressure sensor is used for intake manifold pressure reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning intake manifold 2 pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 1385 .

Last Modified: 28-Sep-2020


Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1386

Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1386 PID: SPN: 1128 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the intake manifold 2 pressure sensor circuit. | Possible reduced engine performance.
Intake Manifold 2 Pressure Sensor Circuit.

Circuit Description

The intake manifold pressure sensor is a variable resistance sensor used by the ECM to monitor the intake manifold pressure. The intake manifold pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the charged air pressure in the intake manifold.

Component Location

The intake manifold 2 pressure sensor is located in the left bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 2 pressure sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • Intake manifold 1 pressure sensor is used for intake manifold pressure reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning intake manifold 2 pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 1386 .

Last Modified: 28-Sep-2020


SAE J1939 Engine Commanded Shutdown - Condition Exists

FAULT CODE 1387

SAE J1939 Engine Commanded Shutdown - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1387 PID: S117 SPN: 1384 FMI: 11/31 LAMP: None SRT: | The generator set controller detected a shutdown from the Engine Control Module on the J1939 network. | None on performance.
J1939 Data Link Circuit

Circuit Description

This fault code will be logged if the engine is shutdown by anything other then the engine keyswitch.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a shutdown message from the J1939 datalink network.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code is information ONLY. Troubleshoot other fault codes that are presently active in the ECM.

Refer to Troubleshooting Fault Code 1387 .

Last Modified: 28-Sep-2020


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine oil rifle pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil rifle pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the oil pressure in the oil rifle.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged engine oil rifle pressure sensor.
Refer to Troubleshooting Fault Code 141 .

Last Modified: 28-Sep-2020


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1411

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1411 PID: S151 SPN: 4182 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the generator output frequency adjust potentiometer circuit. | None.
Generator Output Frequency Adjust Potentiometer Circuit.

Circuit Description

The generator output frequency adjust potentiometer is a potentiometer used by the ECM to regulate the generator frequency. This is the frequency at which the generator set output voltage starts to drop. The potentiometer has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the generator output frequency adjust potentiometer input to the ECM.

Component Location

The generator output frequency adjust potentiometer is located on the generator control panel.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the generator output frequency adjust potentiometer signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A dirty generator frequency adjust potentiometer.
  • Malfunctioning generator frequency adjust potentiometer.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 1411 .

Last Modified: 28-Sep-2020


Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1412

Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1412 PID: S151 SPN: 4183 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the droop adjust potentiometer circuit. | None.
Droop Adjust Potentiometer Circuit

Circuit Description

The droop adjust potentiometer is a potentiometer used by the ECM to regulate the engine droop. The potentiometer has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the droop adjust potentiometer input to the ECM.

Component Location

The droop adjust potentiometer is located on the generator control panel.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the droop adjust potentiometer signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The droop adjust potentiometer will go to the default value.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A dirty droop adjust potentiometer.
  • Malfunctioning droop adjust potentiometer.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 1412 .

Last Modified: 28-Sep-2020


Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1418

Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1418 PID: S151 SPN: 4184 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the gain adjust potentiometer circuit. | None.
Gain Adjust Potentiometer Circuit

Circuit Description

The gain adjust potentiometer is a potentiometer used by the ECM to regulate the governor gains. The potentiometer has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the gain adjust potentiometer input to the ECM.

Component Location

The gain adjust potentiometer is located on the generator set control panel.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the gain adjust potentiometer signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The engine control module (ECM) gain adjust potentiometer will go to the default value.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A dirty gain adjust potentiometer.
  • Malfunctioning gain adjust potentiometer.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 1418 .

Last Modified: 28-Sep-2020


Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

FAULT CODE 1427

Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1427 PID: SPN: 4185 FMI: 11/31 LAMP: Amber SRT: | Error detected in the overspeed lamp driver circuit. | The overspeed shutdown lamp will not turn on.
Overspeed shutdown lamp Circuit

Circuit Description

The overspeed shutdown lamp will indicate when the engine has reached overspeed.

Component Location

The overspeed shutdown lamp is located on the generator set control panel.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an error in the engine overspeed lamp circuit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged or malfunctioning overspeed shutdown lamp
  • Low voltage to the overspeed shutdown lamp
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 1427 .

Last Modified: 28-Sep-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine oil rifle pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil rifle pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the oil pressure in the oil rifle.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil rifle pressure is below the engine protection limits.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Lubricating oil level is above or below specification.
  • Lubrication oil pressure sensor is malfunctioning.
Refer to Troubleshooting Fault Code 143 .

Last Modified: 28-Sep-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is a variable resistor sensor used by the ECM to monitor the engine coolant temperature. The engine coolant temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine coolant temperature sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning engine coolant temperature sensor
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 144 .

Last Modified: 28-Sep-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is a variable resistor sensor used by the ECM to monitor the engine coolant temperature. The engine coolant temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine coolant temperature sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning engine coolant temperature sensor
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 145 .

Last Modified: 28-Sep-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine coolant temperature is above the engine protection warning limit. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is a variable resistor sensor used by the ECM to monitor the engine coolant temperature. The engine coolant temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Obstructed airflow through the radiator.
  • Engine coolant level low
  • Collapsed or restricted cooling system hoses.
  • Malfunctioning engine coolant thermostat.
  • A malfunctioning water pump.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 146 .

Last Modified: 28-Sep-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Engine will shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is a variable resistor sensor used by the ECM to monitor the engine coolant temperature. The engine coolant temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Obstructed airflow through the radiator.
  • Engine coolant level low
  • Collapsed or restricted cooling system hoses.
  • Malfunctioning engine coolant thermostat.
  • A malfunctioning water pump.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 151 .

Last Modified: 28-Sep-2020


At Least One Module Has A Most Severe Fault - Condition Exists

FAULT CODE 1517

At Least One Module Has A Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1517 PID: S254 SPN: 1484 FMI: 11/31 LAMP: Red SRT: | A most severe fault code has been detected by at least one module | Possible engine shutdown. Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features. A most severe fault code has been detected from an ECM on the J1939 datalink network.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected one or more most severe faults.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all amber lamp fault codes in secondary ECMs are inactive.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each ECM has an individual source address that displays when the recommended Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in the recommended Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • A most severe fault code detected on another ECM
Refer to Troubleshooting Fault Code 1517 .

Last Modified: 28-Sep-2020


At Least One Module Has A Moderately Severe Fault - Condition Exists

FAULT CODE 1518

At Least One Module Has A Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1518 PID: S254 SPN: 1484 FMI: 11/31 LAMP: Amber SRT: | A moderately severe fault code has been detected by at least one module | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features. A moderately severe fault code has been detected from a ECM on the J1939 datalink network.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected one or more moderately severe faults.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all amber lamp fault codes in secondary ECMs are inactive.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each ECM has an individual source address that displays when the recommended Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in the recommended Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • A moderately severe fault code detected on another ECM
Refer to Troubleshooting Fault Code 1518 .

Last Modified: 28-Sep-2020


At Least One Module Has A Least Severe Fault - Condition Exists

FAULT CODE 1519

At Least One Module Has A Least Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1519 PID: S254 SPN: 1484 FMI: 11/31 LAMP: Maintenance SRT: | A least severe fault code has been detected by at least one module | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features. A least severe fault code has been detected from a ECM on the J1939 datalink network.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected one or more least severe faults.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all amber lamp fault codes in secondary ECMs are inactive.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each ECM has an individual source address that displays when the recommended Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in the recommended Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • A least severe fault code detected on another ECM.
Refer to Troubleshooting Fault Code 1519 .

Last Modified: 28-Sep-2020


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold 1 temperature sensor circuit. | None on performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor used by the ECM to monitor the intake manifold temperature. The intake manifold temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the intake manifold temperature.

Component Location

The intake manifold 1 temperature sensor is located in the left bank rear air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 1 temperature sensor signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning Intake Manifold Temperature Sensor
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 153 .

Last Modified: 28-Sep-2020


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold 1 temperature sensor circuit. | None on performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor used by the ECM to monitor the intake manifold temperature. The intake manifold temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the intake manifold temperature.

Component Location

The intake manifold 1 temperature sensor is located in the left bank rear air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 1 temperature sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning intake manifold 1 temperature sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 154 .

Last Modified: 28-Sep-2020


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake manifold 1 temperature above engine protection critical limit. | Engine will shut down.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor used by the ECM to monitor the intake manifold temperature. The intake manifold temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the intake manifold temperature.

Component Location

The intake manifold 1 temperature sensor is located in the left bank rear air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 1 temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155 .

Last Modified: 28-Sep-2020


Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 156

Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 156 PID: SPN: 1131 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold 2 temperature sensor circuit. | None on performance.
Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor used by the ECM to monitor the intake manifold temperature. The intake manifold temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the intake manifold temperature.

Component Location

The intake manifold 2 temperature sensor is located in the right bank rear air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 2 temperature sensor signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • No engine protection for intake manifold air temperature.
  • A default value is used for the intake manifold temperature reading.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning intake manifold 2 temperature sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 156 .

Last Modified: 28-Sep-2020


Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 157

Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 157 PID: SPN: 1131 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold 2 temperature sensor circuit. | None on performance.
Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor used by the ECM to monitor the intake manifold temperature. The intake manifold temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the intake manifold temperature.

Component Location

The intake manifold 2 temperature sensor is located in the right bank rear air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 2 temperature sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning intake manifold 2 temperature sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 157 .

Last Modified: 28-Sep-2020


Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 158

Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 158 PID: SPN: 1131 FMI: 0/0 LAMP: Red SRT: | Intake manifold 2 temperature above engine protection critical limit. | Engine will shut down.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor used by the ECM to monitor the intake manifold temperature. The intake manifold temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the intake manifold temperature.

Component Location

The intake manifold 2 temperature sensor is located in the right bank rear air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 2 temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down.
  • A default value is used for the intake manifold temperature reading.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Low coolant level
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 158 .

Last Modified: 28-Sep-2020


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 1597

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1597 PID: S254 SPN: 629 FMI: 12/12 LAMP: Maintenance SRT: | Internal ECM failure has been detected. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each ECM has an individual source address that displays when the recommended Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in the recommended Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Internal ECM failure.
Refer to Troubleshooting Fault Code 1597 .

Last Modified: 28-Sep-2020


Fuel Rack Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 166

Fuel Rack Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 166 PID: S24 SPN: 1210 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected on the fuel rack position sensor signal circuit. | Possible reduced engine performance.
Fuel Rack Position Sensor Circuit

Circuit Description

The fuel rack position sensor circuit is supplied with a varying current source from the ECM. The fuel rack position uses this current to change the position of the control rack, which regulates the amount of fuel delivered from the fuel pump. The fuel rack position feedback sensor circuit relays the fuel rack position back to the ECM.

Component Location

The fuel rack position sensor is internal to the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rack position sensor circuit voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or malfunctioning fuel rack position sensor
  • Damaged or loose connections.
Refer to Troubleshooting Fault Code 166 .

Last Modified: 28-Sep-2020


Fuel Rack Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 167

Fuel Rack Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 167 PID: S24 SPN: 1210 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected on the fuel rack position sensor signal circuit. | Possible reduced engine performance.
Fuel Rack Position Sensor Circuit

Circuit Description

The fuel rack position sensor circuit is supplied with a varying current source from the ECM. The fuel rack position uses this current to change the position of the control rack, which regulates the amount of fuel delivered from the fuel pump. The fuel rack position feedback sensor circuit relays the fuel rack position back to the ECM.

Component Location

The fuel rack position sensor is internal to the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rack position sensor circuit voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or malfunctioning fuel rack position sensor
  • Damaged or loose connections.
Refer to Troubleshooting Fault Code 167 .

Last Modified: 28-Sep-2020


Fuel Rack Actuator Driver - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 172

Fuel Rack Actuator Driver - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 172 PID: S23 SPN: 638 FMI: 7/7 LAMP: Red SRT: | Fuel control rack is in a stuck position. | Engine will shut down.
Fuel Rack Actuator Driver Circuit

Circuit Description

The fuel control rack and solenoid determine the quantity of fuel metered to the engine.

Component Location

The fuel control rack and solenoid are internal parts of the fuel injection pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rack is stuck or not responding to fueling commands.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Loose or damaged actuator connector.
  • Malfunctioning fuel pump.
Refer to Troubleshooting Fault Code 172 .

Last Modified: 28-Sep-2020


Fuel Rack Actuator Driver Mechanically Stuck Closed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 173

Fuel Rack Actuator Driver Mechanically Stuck Closed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 173 PID: S23 SPN: 638 FMI: 1/18 LAMP: Amber SRT: | Fuel control rack is in a stuck position. | Possible reduced engine performance.
Fuel Rack Actuator Driver Circuit

Circuit Description

The fuel control rack and solenoid determine the quantity of fuel metered to the engine.

Component Location

The fuel control rack and solenoid are internal parts of the fuel injection pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rack is stuck or not responding to fueling commands.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Loose or damaged actuator connector.
  • Malfunctioning fuel pump.
Refer to Troubleshooting Fault Code 173 .

Last Modified: 28-Sep-2020


Engine Control Module Identification Input State Error - Data erratic, intermittent or incorrect

FAULT CODE 184

Engine Control Module Identification Input State Error - Data erratic, intermittent or incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 184 PID: S233 SPN: 609 FMI: 2/2 LAMP: Amber SRT: | The control module identification input state is incorrect. | Engine will shut down. Engine may not start.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
  • Incorrect parameter settings.
  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code 184 .

Last Modified: 28-Sep-2020


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: P110 SPN: 110 FMI: 14/14 LAMP: Red SRT: | Engine coolant temperature is above the engine protection warning limit. | Engine will shut down. Generator set will disconnect from the grid.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is a variable resistor sensor used by the ECM to monitor the engine coolant temperature. The engine coolant temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Obstructed airflow through the radiator.
  • Engine coolant level low
  • Collapsed or restricted cooling system hoses.
  • Malfunctioning engine coolant thermostat.
  • A malfunctioning water pump.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 1847 .

Last Modified: 28-Sep-2020


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 185

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 185 PID: S231 SPN: 639 FMI: 2/2 LAMP: Amber SRT: | Communication between the engine control module (ECM) and another device on the J1939 datalink has been lost. | Possible reduced engine performance.
J1939 Datalink Circuit

Circuit Description

The ECM identified another device on the J1939 datalink network has stopped communicating on the network. The devices on the J1939 datalink network include: ECMs’, and the Generator Interface Module. The harness for the J1939 datalink network has a shielded twisted pair of wires that connect each of the network devices and termination resistor.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 datalink wiring harness.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each smart device on the J1939 datalink network need power and ground to turn on, after the smart device turns on, it can then communicate on the J1939 datalink network.

Possible causes of this fault code include:

  • Malfunctioning or damaged J1939 datalink wiring harness.
Refer to Troubleshooting Fault Code 185 .

Last Modified: 28-Sep-2020


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply 2 circuit. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 2 Circuit.

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine wiring harness.

Component Location

The sensor supply 2 circuit is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connections.
  • Malfunctioning sensor
Refer to Troubleshooting Fault Code 187 .

Last Modified: 28-Sep-2020


Engine Oil Change Interval - Condition Exists

FAULT CODE 1891

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1891 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Amber SRT: | Engine conditions are preventing engine oil burn valve operation. | Engine oil burn valve solenoid unable to inject oil.
Engine Oil Burn Valve Solenoid Driver Circuit.

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve solenoid is located in the top of the engine oil burn valve. The location of the burn valve is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil burn valve system has been unable to operate for an extended period of time due to engine conditions.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a keycycle, start the engine and perform the Centinel™ Operational Test using the recommended Cummins® electronic service tool or equivalent.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

When the engine oil burn valve solenoid tries to inject oil and can not, it generates a miss count. When these counts reach a predefined level, the fault code becomes active. If an oil make up tank is not used, it is recommended to change the engine oil at the next maintenance interval.

Possible causes of this fault code include:

  • Incorrect engine oil pressure
  • Incorrect engine coolant temperature
  • low lubrication oil level
  • A faulty engine oil burn valve
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 1891 .

Last Modified: 28-Sep-2020


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine coolant level sensor circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a variable resistance sensor used by the ECM to monitor the coolant level. The coolant level sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the level of the coolant in the radiator top tank or surge tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged coolant level sensor.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 195 .

Last Modified: 28-Sep-2020


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine coolant level sensor circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a variable resistance sensor used by the ECM to monitor the coolant level. The coolant level sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the level of the coolant in the radiator top tank or surge tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
  • Malfunctioning or damaged coolant level sensor.
Refer to Troubleshooting Fault Code 196 .

Last Modified: 28-Sep-2020


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Low engine coolant level detected. | Possible reduced engine performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a variable resistance sensor used by the ECM to monitor the coolant level. The coolant level sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the level of the coolant in the radiator top tank or surge tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • Malfunctioning or damaged coolant level sensor.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 197 .

Last Modified: 28-Sep-2020


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 3938 FMI: 3/3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit has detected voltage above normal or shorted to high source. | Engine will not synchronize with the grid, if connected.
Generator Speed/Load Governing Bias Circuit.

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected generator speed/load governing bias signal is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 1978 .

Last Modified: 28-Sep-2020


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 3938 FMI: 4/4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit has detected voltage below normal or shorted to low source. | Engine will not synchronize with the grid, if connected.
Generator Speed/Load Governing Bias Circuit.

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected generator speed/load governing bias signal is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 1979 .

Last Modified: 28-Sep-2020


Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1984

Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1984 PID: SPN: 1131 FMI: 0/16 LAMP: Amber SRT: | Intake manifold 2 temperature above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor used by the ECM to monitor the intake manifold temperature. The intake manifold temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the intake manifold temperature.

Component Location

The intake manifold 2 temperature sensor is located in the right bank rear air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 2 temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Low coolant level
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 1984 .

Last Modified: 28-Sep-2020


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: P190 SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine crankshaft speed signal indicates engine speed above engine protection limit. | Engine will shut down.
Engine Crankshaft Speed Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The engine crankshaft speed/position sensor is located on the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine crankshaft speed sensor is higher than the engine protection limits.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.
Refer to Troubleshooting Fault Code 1992 .

Last Modified: 28-Sep-2020


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor used by the ECM to monitor the engine oil temperature. The engine oil temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the engine oil temperature.

Component Location

The engine oil temperature sensor is located in the oil pan adapter on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • No engine protection for engine oil temperature.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning or damaged engine oil temperature sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 212 .

Last Modified: 28-Sep-2020


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at engine oil temperature sensor circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor used by the ECM to monitor the engine oil temperature. The engine oil temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the engine oil temperature.

Component Location

The engine oil temperature sensor is located in the oil pan adapter on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • A malfunctioning or damaged engine oil temperature sensor.
Refer to Troubleshooting Fault Code 213 .

Last Modified: 28-Sep-2020


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine oil temperature is above the engine protection limit. | Engine will shut down.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor used by the ECM to monitor the engine oil temperature. The engine oil temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the engine oil temperature.

Component Location

The engine oil temperature sensor is located in the oil pan adapter on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning lubricating oil cooler.
  • A malfunctioning or damaged engine oil temperature sensor.
Refer to Troubleshooting Fault Code 214 .

Last Modified: 28-Sep-2020


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply 4 circuit. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 4 Circuit

Circuit Description

The sensor supply circuits of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine wiring harness.

Component Location

The sensor supply 4 circuit is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for Sensor Supply 4 voltage is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 2185 .

Last Modified: 28-Sep-2020


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply 4 circuit. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 4 Circuit

Circuit Description

The sensor supply circuits of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine wiring harness.

Component Location

The sensor supply 4 circuit is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for Sensor Supply 4 voltage is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connections.
  • Malfunctioning sensor
Refer to Troubleshooting Fault Code 2186 .

Last Modified: 28-Sep-2020


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the barometric pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged barometric pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 221 .

Last Modified: 28-Sep-2020


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the barometric pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged barometric pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 222 .

Last Modified: 28-Sep-2020


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 223

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S85 SPN: 1265 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine oil burn valve solenoid driver circuit. | Engine control module (ECM) turns off the engine oil burn valve solenoid driver supply voltage and the system is disabled.
Engine Oil Burn Valve Solenoid Driver Circuit.

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve solenoid is located in the top of the engine oil burn valve. The location of the burn valve is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil burn valve solenoid driver circuit was not at system voltage when the driver was turned on.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a keycycle, start the engine and perform the Centinel™ Operational Test using the recommended Cummins® electronic service tool or equivalent.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A damaged or malfunctioning engine oil burn valve solenoid
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 223 .

Last Modified: 28-Sep-2020


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 224

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 224 PID: S85 SPN: 1265 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine oil burn valve solenoid driver circuit | Engine control module (ECM) turns off the engine oil burn valve solenoid driver supply voltage and the system is disabled.
Engine Oil Burn Valve Solenoid Driver Circuit.

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve solenoid is located in the top of the engine oil burn valve. The location of the burn valve is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil burn valve solenoid driver circuit was at system voltage when the driver was off.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a keycycle, start the engine and perform the Centinel™ Operational Test using the recommended Cummins® electronic service tool or equivalent.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A damaged or malfunctioning engine oil burn valve solenoid
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 224 .

Last Modified: 28-Sep-2020


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at the fuel lift pump relay signal circuit. | Engine may not start or may be difficult to start.
Electronic Control Module (ECM)

Circuit Description

The fuel pump relay is controlled by the engine control module (ECM), and provides power to the lift pump 1 and lift pump 2. The fuel pump relay has 4 circuits: battery 1 voltage supply, lift pump 1 supply, lift pump relay signal, and battery 1 voltage return. The ECM monitors the lift pump relay signal circuit.

Component Location

The electric lift pump is located on the right bank rear high position or on the left bank front high position.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the lift pump relay signal circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.

Shop Talk

Possible causes of this fault code include:

A malfunctioning fuel lift pump relay.

  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 2265 .

Last Modified: 28-Sep-2020


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel lift pump relay circuit. | Engine may not start or may be difficult to start.
Electronic Control Module (ECM)

Circuit Description

The fuel pump relay is controlled by the engine control module (ECM), and provides power to the lift pump 1 and lift pump 2. The fuel pump relay has 4 circuits: battery 1 voltage supply, lift pump 1 supply, lift pump relay signal, and battery 1 voltage return. The ECM monitors the lift pump relay signal circuit.

Component Location

The electric lift pump is located on the right bank rear high position or on the left bank front high position.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the lift pump relay signal circuit is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning fuel lift pump relay.

  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 2266 .

Last Modified: 28-Sep-2020


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply 2 circuit. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine wiring harness.

Component Location

The sensor supply 2 circuit is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connections.
Refer to Troubleshooting Fault Code 227 .

Last Modified: 28-Sep-2020


Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 228

Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 228 PID: P109 SPN: 109 FMI: 1/1 LAMP: Red SRT: | Coolant pressure signal indicates coolant pressure is below the engine protection critical limit. | Engine may shutdown.
Coolant Pressure Sensor Circuit

Circuit Description

The engine coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The engine coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The coolant pressure sensor is located on the water pump connection to the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant pressure was less than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • A malfunctioning radiator cap.
  • A malfunctioning coolant pressure sensor.
  • A malfunctioning water pump.
Refer to Troubleshooting Fault Code 228 .

Last Modified: 28-Sep-2020


Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 231

Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: P109 SPN: 109 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the coolant pressure sensor circuit. | None on performance.
Coolant Pressure Sensor Circuit

Circuit Description

The engine coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The engine coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The coolant pressure sensor is located on the water pump connection to the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning coolant pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 231 .

Last Modified: 28-Sep-2020


Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 232

Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: P109 SPN: 109 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the coolant pressure sensor circuit. | None on performance.
Coolant Pressure Sensor Circuit

Circuit Description

The engine coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The engine coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The coolant pressure sensor is located on the water pump connection to the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning coolant pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 232 .

Last Modified: 28-Sep-2020


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 234-ECM1

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: SPN: 190 FMI: 0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
Crankshaft Speed/Position Circuit - QST30 Power Generation Interface Engine

Circuit Description

The engine crankshaft speed sensor and engine camshaft speed sensor provide engine speed and position information to the ECM through the engine harness.

Component Location

The engine crankshaft speed sensor is located in the flywheel housing. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine crankshaft speed sensor and the engine camshaft speed sensor.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed sensor and the engine camshaft speed sensor for damage or tampering.

Refer to Troubleshooting Fault Code t05-234

Last Modified: 19-Jun-2018


Engine Speed High - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 234-ECM2

Engine Speed High - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: SPN: 190 FMI: 0 LAMP: Red SRT: | Engine Speed High - Data Valid but Above Normal Operational Range - Most Severe Level | The fuel shutoff valve is de-energized (closed). The fuel shutoff valve is re-engergized (opened) when engine speed falls below the calibrated value (2130 rpm).
Engine Speed High Circuit - QST30 Power Generation Interface Engine

Circuit Description

The engine speed sensor monitors the engine position and the engine speed and passes this information to the electronic control module (ECM) through the engine harness.

Component Location

The engine speed sensor and the engine position sensor are located in the flywheel housing.

Shop Talk

  • Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks.
  • Inspect the engine speed sensor for signs of damage or tampering.
Refer to Troubleshooting Fault Code t05-234

Last Modified: 19-Jun-2018


Fault Code Path Selection

FAULT CODE 234
Fault Code Path Selection

Are you connected to CM850 service port (source address (00))? | Go to 60-fc234-ecm2
Are you connected to CM552 service port (source address (00))? | Go to 60-fc234-ecm1

Last Modified: 20-Dec-2012


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Low engine coolant level detected. | Engine will shut down.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a variable resistance sensor used by the ECM to monitor the coolant level. The coolant level sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the level of the coolant in the radiator top tank or surge tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 5 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • Malfunctioning or damaged coolant level sensor.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 235 .

Last Modified: 28-Sep-2020


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply 3 circuit. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply circuits of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine wiring harness.

Component Location

The sensor supply 3 circuit is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connections.
  • Malfunctioning sensor
Refer to Troubleshooting Fault Code 238 .

Last Modified: 28-Sep-2020


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Low voltage detected on the fuel shutoff control circuit. | Engine will shut down.
Fuel Shutoff Valve

Circuit Description

The fuel shutoff valve is a device used by the ECM to control the fuel supply into the injection pump.

Component Location

The fuel shutoff valves are located on the oil pan rail near the middle of the block on both banks.

Conditions for Running the Diagnostics

This diagnostic runs when the fuel shutoff valve is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected the fuel shutoff control is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each ECM has an individual source address that displays when the recommended Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in the recommended Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • A malfunctioning fuel shutoff valve.
  • Damaged or loose connections.
Refer to Troubleshooting Fault Code 254 .

Last Modified: 28-Sep-2020


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 11/31 LAMP: Red SRT: | One or more unacknowledged most severe fault codes has been detected. | Engine will shut down.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a most severe fault.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all amber lamp fault codes in secondary ECMs are inactive.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information-only fault code that will only become active if other critical engine protection fault codes are active.Fault code will remain active until reset by the operator. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

Refer to Troubleshooting Fault Code 2661 .

Last Modified: 28-Sep-2020


At Least One Unacknowledged Moderately Severe Fault - Condition Exists

FAULT CODE 2662

At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2662 PID: SPN: 629 FMI: 11/31 LAMP: Amber SRT: | One or more unacknowledged moderately severe fault codes has been detected. | None on performance.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a moderately severe fault.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information-only fault code that will only become active if other critical engine protection fault codes are active.Fault code will remain active until reset by the operator. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

Refer to Troubleshooting Fault Code 2662 .

Last Modified: 28-Sep-2020


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 2727

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2727 PID: S206 SPN: 1231 FMI: 9/9 LAMP: Maintenance SRT: | Communication between the engine control module (ECM) and another device on the J1939 datalink has been lost. | Possible reduced engine performance.
J1939 Data Link 2 Engine Network Circuit

Circuit Description

The ECM identified another device on the J1939 datalink network has stopped communicating on the network. The devices on the J1939 datalink network include: ECMs’, and the Generator Interface Module. The harness for the J1939 datalink network has a shielded twisted pair of wires that connect each of the network devices and termination resistor.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Each smart device on the J1939 datalink network need power and ground to turn on, after the smart device turns on, it can then communicate on the J1939 datalink network.

Possible causes of this fault code include:

  • Malfunctioning or damaged J1939 datalink wiring harness.
Refer to Troubleshooting Fault Code 2727 .

Last Modified: 28-Sep-2020


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | Communication between the engine control module (ECM) and another device on the J1939 datalink has been lost. | Possible reduced engine performance.
J1939 Datalink Circuit

Circuit Description

The ECM identified another device on the J1939 datalink network has stopped communicating on the network. The devices on the J1939 datalink network include: ECMs’, and the Generator Interface Module. The harness for the J1939 datalink network has a shielded twisted pair of wires that connect each of the network devices and termination resistor.

Component Location

The J1939 datalink wiring and the J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each smart device on the J1939 datalink network need power and ground to turn on, after the smart device turns on, it can then communicate on the J1939 datalink network.

Possible causes of this fault code include:

  • Malfunctioning or damaged J1939 datalink wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 285 .

Last Modified: 28-Sep-2020


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
J1939 Datalink Circuit

Circuit Description

The ECM identified another device on the J1939 datalink network has stopped communicating on the network. The devices on the J1939 datalink network include: ECMs’, and the Generator Interface Module. The harness for the J1939 datalink network has a shielded twisted pair of wires that connect each of the network devices and termination resistor.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each smart device on the J1939 datalink network need power and ground to turn on, after the smart device turns on, it can then communicate on the J1939 datalink network.

Possible causes of this fault code include:

  • Malfunctioning or damaged J1939 datalink wiring harness.
  • Communication failure between J1939 devices
Refer to Troubleshooting Fault Code 286 .

Last Modified: 28-Sep-2020


Electronic Calibration Code Incompatibility - Out of Calibration

FAULT CODE 342-ECM1

Electronic Calibration Code Incompatibility - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: 630 FMI: 13 LAMP: Red SRT: | Electronic Calibration Code Incompatibility - Out of Calibration. | Hard to start or no start.
Electronic Control Module (ECM) - QST30 Power Generation Interface Engine

Circuit Description

The ECMs communicate via the wiring harness.

Component Location

ECM1, ECM2, and ECM3 are mounted above the flywheel housing on the rear of the engine. ECM1 is located (from left to right) on the left bank, followed by ECM2 in the middle, and ECM3 on the right bank. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs on this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected to the corresponding service port. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool along with which service port (CM850 or CM552) you are connected to in order to determine which ECM and circuit is affected.

ECM2 (CM850) contains status information about ECM1 (CM552) and ECM3 (CM552). At key on, if the data link in interrupted between ECM2 and ECM1 and/or ECM3, the communication will not update until the data link is established. If there is a communication or performance calibration incompatibility between ECM1, ECM2, or ECM3, a fault occurs that requires a recalibration of the modules identified with the fault and source address. This is for incompatibilities in calibrations between ECM1 and ECM2 or ECM3, and not related to accessibility. ECM1, ECM2, and ECM3 can communicate, but something in ECM1 or ECM3 calibration does not match with ECM2.

Possible causes:

  • Wrong or corrupt calibration
  • Wrong or damaged ECM
  • Private terminating resistor damaged or disconnected.
Refer to Troubleshooting Fault Code t05-342


Engine Control Module - Out of Calibration

FAULT CODE 342-ECM2

Engine Control Module - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: None FMI: 13 LAMP: Red SRT: | Engine Control Module - Out of Calibration. ECM calibrations do not match. | Engine will not start.
Electronic Control Module (ECM2)

Circuit Description

Fault Code 342 indicates the calibrations in the ECMs are not the same.

Component Location

ECM1, ECM2, and ECM3 are mounted above the flywheel housing on the rear of the engine. ECM1 is located (from left to right) on the left bank, followed by ECM2 in the middle, and ECM3 on the right bank. Refer to Procedure 100-002 in Section F.

Shop Talk

This problem can occur by changing a single ECM.

Refer to Troubleshooting Fault Code t05-342


Fault Code Path Selection

FAULT CODE 60-342
Fault Code Path Selection

Are you connected to CM850 service port (source address (00))? | Go to 60-fc342-ecm2
Are you connected to CM552 service port (source address (01))? | Go to 60-fc342-ecm1


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | An internal ECM communication failure has been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Internal ECM failure.
Refer to Troubleshooting Fault Code 343 .

Last Modified: 28-Sep-2020


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12/12 LAMP: Amber SRT: | Bad intelligent device or component has been detected. | Data stored during power down is lost.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a power interruption to the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If a battery disconnect switch is turned OFF after the keyswitch is turned OFF, but before the ECM completely powers down (up to 30 seconds), this fault can register.

Possible causes of this fault code include:

  • Loss of voltage to the ECM
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
  • Internal ECM failure.
Refer to Troubleshooting Fault Code 346 .

Last Modified: 28-Sep-2020


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply 1 circuit. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 1 Circuit.

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volts supply to various sensors on the engine wiring harness.

Component Location

The sensor supply 1 circuit is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connections.
  • Malfunctioning sensor
Refer to Troubleshooting Fault Code 352 .

Last Modified: 28-Sep-2020


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at the sensor supply 1 circuit. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 1 Circuit.

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volts supply to various sensors on the engine wiring harness.

Component Location

The sensor supply 1 circuit is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 386 .

Last Modified: 28-Sep-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Oil pressure is below the engine protection critical limit. | Engine will shut down.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine oil rifle pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil rifle pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the oil pressure in the oil rifle.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil rifle pressure is below the engine protection limits.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Lubricating oil level is above or below specification.
  • Plugged or restricted lubricating oil filter.
  • Lubrication oil pressure sensor is malfunctioning.
  • Main oil pressure regulator is malfunctioning
  • Lubricating oil suction or transfer tube is malfunctioning.
  • Internal engine damage.
Refer to Troubleshooting Fault Code 415 .

Last Modified: 28-Sep-2020


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine oil temperature is above the engine protection limit. | Possible reduced engine performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor used by the ECM to monitor the engine oil temperature. The engine oil temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the engine oil temperature.

Component Location

The engine oil temperature sensor is located in the oil pan adapter on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning lubricating oil cooler.
  • A malfunctioning or damaged engine oil temperature sensor.
Refer to Troubleshooting Fault Code 421 .

Last Modified: 28-Sep-2020


Injector Timing Rail 1 Fuel Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 423

Injector Timing Rail 1 Fuel Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 423 PID: P156 SPN: 156 FMI: 2/2 LAMP: Amber SRT: | Signal voltage indicates that the timing pressure sensor signal is irrational. | Possible reduced engine performance.
Engine Fuel Timing Actuator Circuit

Circuit Description

The engine fuel timing actuator circuit is used to control the start of injection. The engine control module (ECM) monitors the current on the timing actuator pulse width modulated supply circuit.

Component Location

The engine timing pressure actuator is internal to the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs when the timing rail actuator is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for all injectors.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged or malfunctioning engine fuel timing actuator
  • Damaged or loose connectors.
  • Malfunctioning or damaged engine wiring harness.
  • Drainline restriction
Refer to Troubleshooting Fault Code 423 .

Last Modified: 28-Sep-2020


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | Communication between the engine control module (ECM) and another device on the J1939 datalink has been lost. | None on performance.
J1939 Datalink Circuit

Circuit Description

The ECM identified another device on the J1939 datalink network has stopped communicating on the network. The devices on the J1939 datalink network include: ECMs’, and the Generator Interface Module. The harness for the J1939 datalink network has a shielded twisted pair of wires that connect each of the network devices and termination resistor.

Component Location

The location of the J1939 datalink wiring may vary depending on OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 datalink wiring harness.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged J1939 datalink wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
  • Communication failure between J1939 devices
Refer to Troubleshooting Fault Code 426 .

Last Modified: 28-Sep-2020


Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441-ECM1

Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine can stop running or be difficult to start.
Unswitched Battery Supply - QST30 Power Generation Interface Engine

Circuit Description

The ECM receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the battery 1 voltage wires to protect the harness and ECM. The ECM receives switched battery input through the ignition wire when the ignition is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECMs are located on a support bracket above the flywheel housing at the rear of the engine. ECM1 is the front most left mounted ECM. ECM2 is in the middle and ECM3 is the right most mounted ECM. The ECMs are connected to the battery by the OEM harness and engine harness. This direct link provides a constant power supply for the ECMs. The location of the battery will vary with the OEM. Reference the OEM troubleshooting and repair manual for battery location.

Shop Talk

There are multiple ECMs. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM battery supply voltage drops below the minimum system voltage level.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441


Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441-ECM2

Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage Low - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine can stop running or be difficult to start.
Unswitched Battery Supply - QST30 Power Generation Interface Engine

Circuit Description

The ECM receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the battery 1 voltage wires to protect the harness and ECM. The ECM receives switched battery input through the ignition wire when the ignition is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECMs are located on a support bracket above the flywheel housing at the rear of the engine. ECM-1 is the front most left mounted ECM. ECM-2 is in the middle and ECM-3 is the right most mounted ECM. The ECMs are connected to the battery by the OEM harness and engine harness. This direct link provides a constant power supply for the ECMs. The location of the battery will vary with the OEM. Reference the OEM troubleshooting and repair manual for battery location.

Shop Talk

There are multiple ECMs, each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM battery supply voltage drops below the minimum system voltage level.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM battery 1 voltage supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441


Fault Code Path Selection

FAULT CODE 441
Fault Code Path Selection

Are you connected to CM850 service port (source address (00))? | Go to 60-fc441-ecm2
Are you connected to CM552 service port (source address (01))? | Go to 60-fc441-ecm1


Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 442-ECM1

Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
Battery 1 Voltage Circuit - QST30 Power Generation Interface Engine

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the unswitched battery wire to protect the OEM harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery 1 RETURN wires are connected directly to the negative (-) battery post.

Component Location

The engine has 3 ECMs. ECMs are located on a support bracket above the flywheel housing at the rear of the engine. ECM1 is the left most mounted ECM. ECM2 is in the middle and ECM3 is the right most mounted ECM. The ECMs are connected to the battery by the engine and OEM harnesses. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Reference the OEM troubleshooting and repair manual for battery location.

Shop Talk

There are multiple ECMs. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM battery 1 voltage exceeds +36-VDC. Causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code t05-442


Battery 1 Voltage High - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 442-ECM2

Battery 1 Voltage High - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage High - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the minimum system voltage level. | Engine can stop running or be difficult to start.
Unswitched Battery Supply - QST30 Power Generation Interface Engine

Circuit Description

The ECM receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the battery 1 voltage wires to protect the harness and ECM. The ECM receives switched battery input through the ignition wire when the ignition is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECMs are located on a support bracket above the flywheel housing at the rear of the engine. ECM1 is the left most mounted ECM. ECM2 is in the middle and ECM3 is the right most mounted ECM. The ECMs are connected to the battery by the OEM harness and engine harness. This direct link provides a constant power supply for the ECMs. The location of the battery will vary with the OEM. Reference the OEM troubleshooting and repair manual for battery location.

Shop Talk

There are multiple ECMs. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM battery supply voltage drops below the minimum system voltage level.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM battery 1 voltage supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-442


Fault Code Path Selection

FAULT CODE 442
Fault Code Path Selection

Are you connected to CM850 service port (source address (00))? | Go to 60-fc442-ecm2
Are you connected to CM552 service port (source address (01))? | Go to 60-fc442-ecm1


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake manifold 1 temperature above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor used by the ECM to monitor the intake manifold temperature. The intake manifold temperature sensor has two circuits: signal, and return circuits. The signal voltage indicates the intake manifold temperature.

Component Location

The intake manifold 1 temperature sensor is located in the left bank rear air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold 1 air temperature sensor was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Low coolant level
  • High coolant temperature
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 488 .

Last Modified: 28-Sep-2020


Engine Shut Down Hot - Condition Exists

FAULT CODE 611

Engine Shut Down Hot - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 611 PID: S116 SPN: 1383 FMI: 11/31 LAMP: None SRT: | Engine shut down hot without a proper cool down run period. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) uses inputs from the engine coolant temp sensor, engine speed sensor, keyswitch, and calculated engine torque for this diagnostic.

Component Location

The emergency stop switch is located on the generator set control panel.

The Engine Control Modules (ECM) are located on a plate that is above the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected engine speed is 0 within 15 seconds of the engine operating under a load.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information only fault code that will only become active if the engine was shut down before proper engine cooldown.

Refer to Troubleshooting Fault Code 611 .

Last Modified: 28-Sep-2020


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Possible reduced performance or shutdown.
Engine Crankshaft Speed Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The engine speed sensor and the engine position sensor are located in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or malfunctioning engine speed sensor
  • Damaged tone wheel
Refer to Troubleshooting Fault Code 689 .

Last Modified: 28-Sep-2020


Rack Position

FAULT CODE 171

Rack Position

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 171 PID: FMI: LAMP: SRT: | Fuel pump rack position fault. One or both of the left bank or right bank fuel pump racks is not at the commanded position. | Performance could be sluggish or slow to respond. Common Warning output is energized.

Fuel Pump and Rack Circuit

Circuit Description

The rack position sensor circuit's measured, reference and common signals are used by the electronic control module (ECM) to verify that the rack has been properly positioned by the rack actuator. The actuator power supply and PWM return circuits are used by the ECM to drive the actuator to the desired position.

Component Location

The rack position sensor is located in the governor housing of the fuel pump. The QST30 G-Drive engine has one on each engine bank.

Shop Talk

  • Fault Code 171 will be recorded if the measured rack position for either bank is not at commanded rack position. First determine which bank is causing the error, then determine what part of that circuit is at fault.
  • Fault Code 171 may be recorded if the fuel pump rack is sticking at one particular point within its travel path. You may need to load the engine to make the fault go active.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine which bank is at fault. |
 | STEP 1A. Perform fuel pump rack test. | The measured voltage matches the service tool voltage reading (±0.2 VDC)
 | STEP 1A-1. Monitor the rack position voltages while the engine is in operation. |
STEP 2. | Check engine harness. |
 | STEP 2A. Inspect engine harness adaptor cable and ECM connector pins. | No damaged pins
 | STEP 2A-1. Inspect engine harness and fuel pump connector pins. |
 | STEP 2A-2. Inspect engine harness connector and any engine harness extension cable used. |
 | STEP 2B. Check rack position sensor and rack actuator circuits for short circuit from pin to pin. | More than 100k ohms
 | STEP 2B-1. Check for a short circuit from pin to pin in the engine harness adaptor cable and any engine harness extension cable used. |
 | STEP 2C. Check rack position sensor and rack actuator circuits for an open circuit. | Less than 10 ohms
 | STEP 2C-1. Check for an open circuit in the engine harness adaptor cable and any engine harness extension cable used. |
 | STEP 2D. Check rack position sensor and rack actuator circuits for short circuit to ground. | More than 100k ohms
 | STEP 2D-1. Check for short circuit to ground in the engine harness. |
STEP 3. | Check rack actuator. |
 | STEP 3A. Check the resistance of rack actuator coil. | 0.55 to 0.90 ohms
 | STEP 3B. Verify rack movement. | Full range of rack movement
STEP 4. | Check rack position sensor. |
 | STEP 4A. Check resistance of rack position sensor coil. | 17 to 23 ohms
 | STEP 4B. Check resistance of rack position sensor reference coil. | 17 to 23 ohms
STEP 5. | Check ECM. |
 | STEP 5A. Check rack position sensor signal pins for proper voltage levels. | 2.4 to 2.6 VDC
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 171 inactive
 | STEP 6B. Clear inactive fault codes. | All faults cleared

Guided Step 1 - Determine which bank is at fault.

Guided Step 1A - Perform fuel pump rack test.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller in the diagnostic mode.

Action

Using INSITE™, Part No. 3825145, perform fuel pump rack test.

  • Gradually ramp the fuel pump rack from it's lower limit of travel (0 mm) to it's maximum limit of travel (20 mm) while reading the voltage from pin B to pin A at the diagnostic connector for the left bank fuel pump.
  • Gradually ramp the fuel pump rack from it's lower limit of travel (0 mm) to it's maximum limit of travel (20 mm) while reading the voltage from pin C to pin A at the diagnostic connector for the right bank fuel pump.
OK NOT OK

The measured voltage matches the rack position voltages as indicated by the service tool (±0.2 VDC)

Proceed with the following steps (Step 2A) for the engine bank in error.

Go to 1A-1

Go to 2A

Guided Step 1A-1 - Monitor the rack position voltages while the engine is in operation.

Conditions

  • Stop/Run switch in the "RUN" position.

Action

Read the voltages at the diagnostic connector pins B (left bank fuel pump) to pin A (ground) and pin C (right bank fuel pump) to pin A (ground) at various levels of engine load.

OK NOT OK

Voltage readings between pins A and B are identical (±0.2 VDC) at a given load condition and both voltage reading fluctuate with varying load (fueling) conditions.

Go to 6A

Go to 2A

Guided Step 2 - Check engine harness.

Guided Step 2A - Inspect engine harness adaptor cable and ECM connector pins.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness adaptor cable from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins
Repair or replace the engine harness adaptor cable or the ECM, whichever has the damaged pins.

  • Repair the engine harness adaptor cable. Refer to Procedure 019-240 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the engine harness adaptor cable. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the ECM. Refer to OEM procedures.
  • Dry the connector by using electrical contact cleaner, Part No. 3824510.

Go to 2A-1

Go to 6A

Guided Step 2A-1 - Inspect engine harness and fuel pump connector pins.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness connector from the fuel pump.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins
Repair or replace the engine harness or the fuel pump whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-209 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the fuel pump. Refer to Base Engine Troubleshooting and Repair Manual.
  • Dry the connector by using electrical contact cleaner, Part No. 3824510.

Go to 2A-2

Go to 6A

Guided Step 2A-2 - Inspect engine harness connector and any engine harness extension cable used.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness connector from the engine harness extension cable(s).

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins
Repair or replace the engine harness or the engine harness extension cable(s), whichever has the damaged pins.

  • Repair the engine harness or the engine harness extension cable(s). Refer to Procedure 019-209 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the engine harness or the engine harness extension cable(s). Refer to Procedure 019-043 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Dry the connector by using electrical contact cleaner, Part No. 3824510.

Go to 2B

Go to 6A

Guided Step 2B - Check rack position sensor and rack actuator circuits for short circuit from pin to pin.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness adaptor cable from the ECM.
  • Disconnect the engine harness connector from the fuel pump.

Action

  • Measure the resistance from pin 5 (pin 10 for the right fuel pump) of the engine harness adaptor cable connector to all other pins in the connector.
  • Measure the resistance from pin 3 (pin 4 for the right fuel pump) of the engine harness adaptor cable connector to all other pins in the connector.
  • Measure the resistance from pin 6 (pin 9 for the right fuel pump) of the engine harness adaptor cable connector to all other pins in the connector.
  • Measure the resistance from pin 7 (pin 8 for the right fuel pump) of the engine harness adaptor cable connector to all other pins in the connector.
  • Measure the resistance from pin 1 (pin 2 for the right fuel pump) of the engine harness adaptor cable connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check for a short circuit from pin to pin in the engine harness adaptor cable and any engine harness extension cable used.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness from the engine harness extension cable(s).
  • Disconnect the engine harness adaptor cable from the ECM.

Action

  • Measure the resistance from pin 5 (pin 10 for the right fuel pump) of the engine harness adaptor cable connector and any engine harness extension cable connector to all other pins in the connector.
  • Measure the resistance from pin 3 (pin 4 for the right fuel pump) of the engine harness adaptor cable connector and any engine harness extension cable connector to all other pins in the connector.
  • Measure the resistance from pin 6 (pin 9 for the right fuel pump) of the engine harness adaptor cable connector and any engine harness extension cable connector to all other pins in the connector.
  • Measure the resistance from pin 7 (pin 8 for the right fuel pump) of the engine harness adaptor cable connector and any engine harness extension cable connector to all other pins in the connector.
  • Measure the resistance from pin 1 (pin 2 for the right fuel pump) of the engine harness adaptor cable connector and any engine harness extension cable connector to all other pins in the connector.
OK NOT OK

More than 100k ohms
Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-209 or 019-240 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.

Repair or replace the engine harness adaptor cable or engine harness extension cable(s), whichever is found faulty

  • Repair the engine harness adaptor cable or engine harness extension cable(s). Refer to Procedure 019-209 or 019-240 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the engine harness adaptor cable or engine harness extension cable(s). Refer to Procedure 019-043 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.

Go to 6A

Go to 6A

Guided Step 2C - Check rack position sensor and rack actuator circuits for an open circuit.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness connector from the fuel pump.
  • Disconnect the engine harness adaptor cable from the ECM.

Action

  • Measure the resistance from pin 5 (pin 10 for the right bank fuel pump) on the engine harness adaptor cable connector to pin E on the harness side of the fuel pump connector.
  • Measure the resistance from pin 3 (pin 4 for the right bank fuel pump) on the engine harness adaptor cable connector to pin G on the harness side of the fuel pump connector.
  • Measure the resistance from pin 6 (pin 9 for the right bank fuel pump) on the engine harness adaptor cable connector to pin F on the harness side of the fuel pump connector.
  • Measure the resistance from pin 7 (pin 8 for the right bank fuel pump) on the engine harness adaptor cable connector to pin A on the harness side of the fuel pump connector.
  • Measure the resistance from pin 1 (pin 2 for the right bank fuel pump) on the engine harness adaptor cable connector to pin B on the harness side of the fuel pump connector.
OK NOT OK

Less than 10 ohms

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for an open circuit in the engine harness adaptor cable and any engine harness extension cable used.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness connector from the engine harness extension cable(s).
  • Disconnect the engine harness adaptor cable from the ECM.

Action

  • Measure the continuity for pin 5 (pin 10 for the right bank fuel pump) on the engine harness adaptor cable and any engine harness extension cables used.
  • Measure the continuity for pin 3 (pin 4 for the right bank fuel pump) on the engine harness adaptor cable and any engine harness extension cables used.
  • Measure the continuity for pin 6 (pin 9 for the right bank fuel pump) on the engine harness adaptor cable and any engine harness extension cables used.
  • Measure the continuity for pin 7 (pin 8 for the right bank fuel pump) on the engine harness adaptor cable and any engine harness extension cables used.
  • Measure the continuity for pin 1 (pin 2 for the right bank fuel pump) on the engine harness adaptor cable and any engine harness extension cables used.
OK NOT OK

Less than 10 ohms
Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-209 or 019-240 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.

Repair or replace the engine harness adaptor cable or engine harness extension cable(s), whichever is found faulty

  • Repair the engine harness adaptor cable or engine harness extension cable(s). Refer to Procedure 019-209 or 019-240 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the engine harness adaptor cable or engine harness extension cable(s). Refer to Procedure 019-043 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.

Go to 6A

Go to 6A

Guided Step 2D - Check rack position sensor and rack actuator circuits for short circuit to ground.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness adaptor cable from the ECM.
  • Disconnect the engine harness connector from the fuel pump.

Action

  • Measure the resistance from pin 5 (pin 10 for the right bank fuel pump) on the engine harness adaptor cable to engine block ground.
  • Measure the resistance from pin 3 (pin 4 for the right bank fuel pump) on the engine harness adaptor cable to engine block ground.
  • Measure the resistance from pin 6 (pin 9 for the right bank fuel pump) on the engine harness adaptor cable to engine block ground.
  • Measure the resistance from pin 7 (pin 8 for the right bank fuel pump) on the engine harness adaptor cable to engine block ground.
  • Measure the resistance from pin 1 (pin 2 for the right bank fuel pump) on the engine harness adaptor cable to engine block ground.
OK NOT OK

Greater than 100k ohms

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for short circuit to ground in the engine harness.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness connector from the engine harness extension cable(s).
  • Disconnect the engine harness connector from the fuel pump.

Action

  • Measure the resistance from pin 5 (pin 10 for the right bank fuel pump) on the engine harness connector to engine block ground.
  • Measure the resistance from pin 3 (pin 4 for the right bank fuel pump) on the engine harness connector to engine block ground.
  • Measure the resistance from pin 6 (pin 9 for the right bank fuel pump) on the engine harness connector to engine block ground.
  • Measure the resistance from pin 7 (pin 8 for the right bank fuel pump) on the engine harness connector to engine block ground.
  • Measure the resistance from pin 1 (pin 2 for the right bank fuel pump) on the engine harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-209 or 019-240 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual QST Fuel System QST30 G-Drive Engine Series, Bulletin No. 3666184.

Go to 3A

Go to 6A

Guided Step 3 - Check rack actuator.

Guided Step 3A - Check the resistance of the rack actuator coil.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness connector from the fuel pump.

Action

  • Measure the resistance from pin B to pin G of the fuel pump connector.
OK NOT OK

Less than 10 ohms

Replace the fuel pump
Refer to Base Engine Troubleshooting and Repair Manual.

Go to 3B

Go to 6A

Guided Step 3B - Verify rack movement

Conditions

  • Stop/Run switch in the "STOP” position.
  • Controller in the diagnostic mode.

Action

Using INSITE™, Part No. 3825145, perform a rack movement test. Insert upper and lower limits of fuel pump rack positions. Remove the cap on the front of the fuel pump and verify rack movement.

Note: If the cap on the fuel pump is not accessible for visual verification of rack movement, proceed with steps 4 and 5 prior to removing the fuel pump.

OK NOT OK

Full range of rack movement

Replace the fuel pump
Refer to Base Engine Troubleshooting and Repair Manual.

Go to 4A

Go to 6A

Guided Step 4 - Check rack position sensor.

Guided Step 4A - Check resistance of rack position sensor coil.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness connector from the fuel pump.

Action

  • Measure the resistance from pin E to pin F of the fuel pump connector.
OK NOT OK

17 to 23 ohms

Replace the fuel pump
Refer to Base Engine Troubleshooting and Repair Manual.

Go to 4B

Go to 6A

Guided Step 4B - Check resistance of rack position sensor reference coil.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller not in the diagnostic mode.
  • Disconnect the engine harness connector from the fuel pump.

Action

  • Measure the resistance from pin A to pin F of the fuel pump connector.
OK NOT OK

17 to 23 ohms

Replace the fuel pump
Refer to Base Engine Troubleshooting and Repair Manual.

Go to 5A

Go to 6A

Guided Step 5 - Check ECM

Guided Step 5A - Check rack position sensor signal pins for proper voltage.

Conditions

  • Stop/Run switch in the "STOP" position.
  • Controller in the diagnostic mode.
  • Disconnect engine harness from fuel pump.

Action

  • Measure the signal voltage from pin A on the harness side of the fuel pump connector to ground.
  • Measure the signal voltage from pin E on the harness side of the fuel pump connector to ground.
  • Measure the signal voltage from pin F on the harness side of the fuel pump connector to ground.
OK NOT OK

2.4 to 2.6 VDC

Replace the ECM
Refer to OEM procedures.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • connect all components
  • start the engine and let it idle for one minute
  • verify Fault Code 171 is inactive.
OK NOT OK

Fault Code 171 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™, Part No. 3825145.

NOTE: The datalink connector is located on the right bank of the flywheel housing.

OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Mar-2003


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 174 - Fuel Rack Actuator Position 2 Circuit - Data Incorrect (Right Bank)

Printable Version Printable Version

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify rack position movement. |
 | STEP 1A. Verify rack position at zero position. | Rack position is between 0-3mm
 | STEP 1B. Verify that the rack position changes. | Rack position changes at each step
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 174 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify rack position movement.

Guided Step 1A - Verify rack position at zero position.

Conditions

  • Operation mode switch in Manual position.
  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™electronic service tool.

Action

Verify that the rack position is zero.

  • Use INSITE™ electronic service tool to monitor the right rack position and verify that it is zero when right rack DC is set to zero.
OK NOT OK

Rack position is between 0-3mm

Replace the fuel pump. Reference the following procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1B

Go to 2A

Guided Step 1B - Verify that the rack position changes.

Conditions

  • Place operation mode switch in the manual position.
  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fuel rack position changes.

  • Perform the fuel rack position test for the right bank using the electronic service tool. Input a rack position of 15, 10, 5, 0 mm and monitor right rack position.

Note: The fuel rack position 2 override command is located under the Test/Fuel System Test menu in the electronic service tool.

OK NOT OK

Rack position changes within + or − 3 mm of the commanded position at each step

Replace the fuel pump. Reference the following procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 174 is inactive.
OK NOT OK

Fault Code 174 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Apr-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 113 active
 | STEP 1C. Check for a short circuit between the supply and return wires. | More than 100k ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D-1. Check for a short circuit to ground. |
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 113 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 113 active?
YES NO
No Repair

Repair

Repair complete.

Go to 1C

Go to 2B

Guided Step 1C - Check for a short circuit between the supply and return wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit between the supply and return wires.

  • Measure the resistance between the timing actuator power supply pin and the timing actuator return pin in the ECM 1 connector.

More than 100k ohms
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from timing actuator pulse width modulation supply pin of the engine harness connector to engine block ground.
  • Measure the resistance from timing actuator return pin of the engine harness connector to engine block ground.

More than 100k ohms
YES | NO
No Repair | No Repair

Go to 1E

Go to 1D-1

Guided Step 1D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from timing actuator pulse width modulation supply pin of the engine harness connector to engine block ground.
  • Measure the resistance from timing actuator return pin of the engine harness connector to engine block ground.

More than 100k ohms
YES NO

Repair

More than 100k ohms

Replace the fuel pump(s). Refer to Procedure 005-012 (Fuel Injection Pumps, Inline) in Section 5 in the QST30 Service Manual, Bulletin 4021539.

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from timing actuator pulse width modulation supply pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from timing actuator return pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.

More than 100k ohms
YES NO

Repair

Replace the ECM call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 113 is inactive.

Fault Code 113 inactive
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™electronic service tool to erase the inactive fault codes.

All fault codes cleared
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 114 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1C-1. Check for an open circuit. |
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 114 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 114 is inactive.

Fault Code 114 active
YES NO
No Repair

Repair

Repair complete.

Go to 1C

Go to 2B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from timing actuator pulse width modulator supply pin to the timing actuator return pin of the engine harness connector.

Less than 10 ohms
YES NO

Repair

Replace the ECM and call for pre-authorization. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 1C-1

Guided Step 1C-1 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from the timing actuator pulse width modulator supply pin of the engine harness connector to timing actuator pulse width modulator supply pin of the engine harness fuel pump connector.
  • Measure the resistance from timing actuator return pin of the engine harness connector to timing actuator return pin of the engine harness fuel pump connector.

Less than 10 ohms
YES NO

Repair

Replace the fuel pump(s). Refer to Procedure 005-012 (Fuel Injection Pump, Inline) in Section 5 in the QST30 Service Manual, Bulletin 4021539.

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 114 inactive
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test leadPart Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 115 active?
 | STEP 1C. Check for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the engine speed sensor and engine harness connectors. | No damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 115 active?
 | STEP 2C. Check the engine speed sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2D. Check for a signal from the engine speed sensor. | Signal present?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043.
  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 active?
YES | NO
No Repair | No Repair

Go to 1C

Repair complete.

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1, ECM2, and ECM3 connectors.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit in the 5-VDC supply wire, signal wire, and return wire.

  • Measure the resistance from engine crankshaft speed 5 volt supply pin of the engine harness connector to engine crankshaft speed 5 volt supply pin on the harness side of the engine speed sensor connector.
  • Measure the resistance from engine crankshaft speed return pin of the engine harness connector to engine crankshaft speed return pinon the harness side of the engine speed sensor connector.
  • Measure the resistance from engine crankshaft speed signal pin of the engine harness connector to engine crankshaft speed signal pin on the harness side of the engine speed sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19.Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1, ECM2, and ECM3 connectors.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from engine crankshaft speed 5 volt supply pin of the engine harness connector to engine block ground.
  • Measure the resistance from engine crankshaft speed signal pin of the engine harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1, ECM2, and ECM3 connectors.
  • Disconnect the OEM harness from the ECM1, ECM2, and ECM3 connectors.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from engine crankshaft speed 5 volt supply pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from engine crankshaft speed signal pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from engine crankshaft speed return pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the engine speed sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Connect the engine harness to the ECM.

Action

Inspect the engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor.Refer to Procedure 019-042 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the engine speed sensor supply voltage.

Conditions

  • Disconnect the engine harness from the engine speed sensor.
  • Turn keyswitch ON.

Action

Check the engine speed sensor supply voltage.

  • Measure the voltage from the engine crankshaft speed 5 volt SUPPLY pin to the crankshaft speed RETURN pin on the harness side of the engine speed sensor connector.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a signal from the engine speed sensor.

Conditions

  • Install breakout cable, Part Number 3824775, between the engine speed sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for a signal from the engine speed sensor.

  • Measure the voltage from pin C to pin B on the breakout cable while barring the engine over.

Signal present?
YES NO

Repair

Signal should change from 4 to 5-VDC to 0.5 to 2.3-VDC and back every 2.5 degrees of crankshaft rotation.

  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test leadPart Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 121 active?
 | STEP 1C. Check for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the engine speed sensor and engine harness connectors. | No damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 121 active?
 | STEP 2C. Check the engine speed sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2D. Check for a signal from the engine speed sensor. | Signal present. Signal should change from 4 to 5-VDC to 0.5 to 2.3-VDC and back every 2.5 degrees of crankshaft rotation?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1 and ECM3 connectors.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 1C

Repair complete.

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1 and ECM3 connectors.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit in the 5VDC supply wire, signal wire, and return wire.

  • Measure the resistance from engine crankshaft speed 5 volt supply pin of the engine harness connector to engine crankshaft speed 5 volt supply pin on the harness side of the engine speed sensor connector.
  • Measure the resistance from engine crankshaft speed return pin of the engine harness connector to engine crankshaft speed return pin on the harness side of the engine speed sensor connector.
  • Measure the resistance from engine crankshaft speed signal pin of the engine harness connector to engine crankshaft speed signal pin on the harness side of the engine speed sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM1 and ECM3 connectors.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from engine crankshaft speed 5 volt supply pin of the engine harness connector to engine block ground.
  • Measure the resistance from engine crankshaft speed signal pin of the engine harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1 and ECM3 connectors.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from engine crankshaft speed 5 volt supply pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from engine crankshaft speed signal pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from engine crankshaft speed return pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the engine speed sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Connect the engine harness to the ECM.

Action

Inspect the engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the engine speed sensor supply voltage.

Conditions

  • Disconnect the engine harness from the engine speed sensor.
  • Turn keyswitch ON.

Action

Check the engine speed sensor supply voltage.

  • Measure the voltage from engine crankshaft speed 5 volt supply pin to engine crankshaft speed return pin on the harness side of the engine speed sensor connector.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM.
  • Call for pre-autorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a signal from the engine speed sensor.

Conditions

  • Install breakout cable, Part Number 3824775, between the engine speed sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for a signal from the engine speed sensor.

  • Measure the voltage from engine crankshaft speed signal pin to engine crankshaft speed return pin on the breakout cable while barring the engine over.

Signal present
YES NO

Repair

Signal should change from 4 to 5 VDC to 0.5 to 2.3-VDC and back every 2.5 degrees of crankshaft rotation.

  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome™ test leadPart Number 3822917 - female Deutsch™ /Amp™ /Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the engine oil rifle pressure 1 sensor and circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure 1 sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault code 135 inactive?
 | STEP 2C. Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit. | 4.75 to 5.25-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

See Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 135 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil rifle pressure 1 sensor and circuit.

Guided Step 2A - Inspect the engine oil rifle pressure 1 sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and sensor connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness or damaged sensor.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-066 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the engine oil rifle pressure 1 - 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1 - 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 3B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Repair

A pin to pin short circuit has been detected on the signal wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged section of harness.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1 - 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the ECM engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of engine harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement.Part Number 3164596 - male Framatome™ test leadPart Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the engine oil rifle pressure 1 sensor and circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine oil rifle pressure 1 - 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine oil rifle pressure 1 - 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

See Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Inactive or intermittent fault code, 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil rifle pressure 1 sensor and circuit.

Guided Step 2A - Inspect the engine oil rifle pressure 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and engine oil rifle pressure 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damged connection has been detected in the sensor harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the damaged section of harness or damaged sensor.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
  • Replace the sensor.Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from engine oil rifle pressure 1 - 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the engine oil rifle pressure 1 - 5 volt SUPPLY (sensor supply 1) pin and the engine oil rifle pressure 1 SIGNAL pin at the engine oil rifle pressure 1 sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil rifle pressure 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the engine oil rifle pressure 1 sensor.
  • Refer to Procedure 019-066 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the 60-pin ECM connector.

Action

Inspect the engine harness connector and 60-pin ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the damaged section of harness.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine oil rifle pressure 1 - 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1 - 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the ECM engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM and call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted SUPPLY circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the damaged section of harness.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the damaged section of harness.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the engine oil rifle pressure 1 - 5 volt SUPPLY (sensor supply 1) pin and the engine oil rifle pressure 1 SIGNAL pin at the ECM engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Repair

Replace the ECM and call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the damaged section of harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Repair

See the Lubricating Oil Pressure - Low troubleshooting tree.

 No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AM™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature 1 sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature 1 sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin and engine coolant temperature 1 RETURN (sensor return 1) pin at the engine coolant temperature 1 sensor.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature 1 sensor.

  • Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for pre-authorization.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine coolant temperature 1 SIGNAL pin and engine coolant temperature 1 RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Repair

  • Call for pre-authorization.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector, the engine coolant temperature 1 RETURN (sensor return 1) pin, and the engine harness engine coolant temperature 1 RETURN (sensor return 1) connector pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature 1 SIGNAL pin and the engine harness engine coolant temperature 1 SIGNAL connector pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the malfunction.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature 1 sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step a - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to a

Guided Step 2 - Check the engine coolant temperature 1 sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant temperature 1 sensor.

  • Refer to Procedure 019-019 in Section 19.

Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for pre-authorization.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Repair

  • Call for pre-authorization.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the malfunction.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 146. | Active or inactive counts of Fault Code 146?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 146.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 146.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 146?
YES NO

Repair

Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in the Service Manual, QST30, Bulletin 4021539.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 151. | Active or inactive counts of Fault Code 151?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 151.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 151?
YES NO

Repair

Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in the Service Manual, QST30, Bulletin 4021539.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Code)

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 (Intake Manifold Pressure/Temperature Sensor) in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold 1 temperature SIGNAL pin and intake manifold 1 temperature RETURN (sensor return 1) pin at the intake manifold 1 temperature sensor.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 (Intake Manifold Pressure/Temperature Sensor) in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for pre-authorization.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 1 temperature SIGNAL pin and the intake manifold 1 temperature RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Repair

  • Call for pre-authorization.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 1 temperature (sensor return 1) RETURN pin and the engine harness intake manifold 1 temperature (sensor return 1) RETURN connector pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 1 temperature SIGNAL pin and the engine harness intake manifold 1 temperature SIGNAL connector pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be completed again from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or the damaged sensor.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 (Intake Manifold Pressure/Temperature Sensor) in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 (Intake Manifold Pressure/Temperature Sensor) in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for pre-authorization.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Repair

  • Call for pre-authorization.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector and pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector and pin location.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the malfunction.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 155 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Connect INSITE™ electronic service tool.
  • Compare the intake manifold 1 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe. NOTE: If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

A fault intake manifold 1 temperature sensor has been detected.

  • Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 (Intake Manifold Pressure/Temperature Sensor) in Section 19..

Intake Manifold Air Temperature Above Specification symptom tree in the Service Manual, QST30, Bulletin 4021539.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 155 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 156 inactive?
STEP 2. | Check the intake manifold 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 156 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 157 active and Fault Code 156 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 156 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 156 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 2 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 2 temperature sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner Part Number 3824510.
  • Install the apropriate connector seal if it is damaged or missing.
  • Check all harnesses connected in series.
  • Replace the damaged section of harness or damaged intake manifold 2 temperature sensor.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the sensor.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold 2 temperature SIGNAL pin and intake manifold 2 temperature RETURN (sensor return 1) pin at the intake manifold 2 temperature sensor.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold 2 temperature sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the ECM connector or the engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Check all harnesses connected in series.
  • Replace the damaged section of harness.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 2 temperature SIGNAL pin and the intake manifold 2 temperature RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or wiring diagram for connector pin identification.

Fault Code 157 active and Fault Code 156 inactive?
YES NO
No Repair

Repair

  • Replace the ECM.
  • Call for pre-authorization. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 2 temperature RETURN (sensor return 1) pin and the engine harness connector intake manifold 2 temperature RETURN (sensor return 1) pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open intake manifold 2 temperature RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 2 temperature SIGNAL pin and the engine harness connector intake manifold 2 temperature SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open in the intake manifold 2 temperature SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin to pin short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be completed again from the beginning. A failure mode ought to have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 156 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 157 inactive?
STEP 2. | Check the intake manifold 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 157 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 157 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 157 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 2 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner Part Number 3824510.
  • Install the apropriate connector seal if it is damaged or missing.
  • Check all harnesses connected in series.
  • Replace the damaged section of harness or damaged intake manifold 2 temperature sensor.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the sensor.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold 2 temperature sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 is active?
YES NO

Repair

A damaged intake manifold 2 temperature sensor has been detected.

  • Replace the intake manifold 2 temperature sensor.
  • Refer to Procedure Procedure 019-059 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Check all harnesses connected in series.
  • Replace the damaged section of harness.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES NO
No Repair

Repair

  • Replace the ECM.
  • Call for pre-authorization. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector and pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin to pin short.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner Part Number 3824510.
  • Install the apropriate connector seal if it is damaged or missing.
  • Check all harnesses connected in series.
  • Replace the damaged section of harness or damaged intake manifold 2 temperature sensor.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector and pin location.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner Part Number 3824510.
  • Install the apropriate connector seal if it is damaged or missing.
  • Check all harnesses connected in series.
  • Replace the damaged section of harness or damaged intake manifold 2 temperature sensor.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be completed again from the beginning. A failure mode ought to have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 157 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 2 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 158 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 2 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 2 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold, except at the probe threads.
  • Compare the intake manifold 2 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe. NOTE: If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

A faulty intake manifold 2 temperature sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner Part Number 3824510.
  • Install the apropriate connector seal if it is damaged or missing.
  • Replace the intake manifold 2 temperature sensor.
  • Refer to Procedure 019-059 in Section 19.

Intake Manifold Air Temperature Above Specification troubleshooting symptom tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 158 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.Part Number 3823254 - male 3-way Metri-Pack™ connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rack actuator. |
 | STEP 1A. Inspect the fuel pump and engine harness connectors. | No damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 166 active?
 | STEP 1C. Check the rack actuator coil resistance. | More than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin in the fuel pump harness. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 166 active?
 | STEP 2C. Check for an open circuit. | Less than 20 ohms?
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2F. Check for a short circuit from the return wire to the power supply. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 166 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel pump.

Guided Step 1A - Inspect the fuel pump and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Inspect the fuel pump and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the fuel pump, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the fuel pump connector. Refer to Procedure 019-207 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 166 active?
YES NO
No Repair

Repair

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check the rack actuator coil resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check the fuel rack position 1 coil resistance.

  • Measure the resistance from rack actuator power supply pin to rack actuator return pin of the fuel pump connector.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the fuel pump. Refer to Procedure 005-012 (Fuel Injection Pumps, In-Line) in Section 5, in the QST30 Service Manual, Bulletin 4021539.

Go to 2A

Go to 3A

Guided Step 1D - Check for a short circuit from pin-to-pin in the fuel pump harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to pin in the fuel fuel rack positon coil.

  • Measure the resistance from the rack actuator power supply pin of the fuel pump connector to all other pins of the connector, except rack actuator return pin.
  • Measure the resistance from the rack actuator return pin of the fuel pump connector to all other pins of the connector, except rack actuator power supply pin.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the fuel pump. Refer to Procedure 005-012 (Fuel Injection Pumps, In-Line) in Section 5, in the QST30 Service Manual, Bulletin 4021539.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19
  • Replace the ECM
  • Call for pre-authorization
  • Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 166 active?
YES NO
No Repair

Repair

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from rack actuator return pin to rack actuator power supply pin of the engine harness connector.

Less than 20 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from rack actuator power supply pin of the engine harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM1.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from rack actuator return pin of the engine harness connector to all other pins in the connector, except rack actuator return pin, and to all pins in the OEM harness connector.
  • Measure the resistance from rack actuator power supply pin of the engine harness connector to all other pins in the connector, except rack actuator power supply pin, and to all pins in the OEM harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit from the return wire to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from the return wire to the power supply.

  • Measure the resistance from rack actuator return pin to rack actuator power supply pin of the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 166 is inactive.

Fault Code 166 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823254 - male 3-way Metri-Pack™ connector test leadPart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rack actuator. |
 | STEP 1A. Inspect the fuel pump and engine harness connectors. | No damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 166 active?
 | STEP 1C. Check the rack actuator coil resistance. | 0.7 to 0.9 ohms?
 | STEP 1D. Check for a short circuit from pin to pin in the fuel pump harness. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 166 active?
 | STEP 2C. Check for an open circuit. | Less than 20 ohms?
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2F. Check for a short circuit from the return wire to the power supply. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 166 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel pump.

Guided Step 1A - Inspect the fuel pump and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Inspect the fuel pump and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the fuel pump, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the fuel pump connector. Refer to Procedure 005-012 (Fuel Injection Pumps, In-Line) in Section 5, in the QST30 Service Manual, Bulletin 4021539.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 167 active?
YES NO
No Repair

Repair

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check the rack actuator coil resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check the rack actuator coil resistance.

  • Measure the resistance from pin G to pin B of the fuel pump connector.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the fuel pump. Refer to Procedure 005-012 (Fuel Injection Pumps, In-Line) in Section 5, in the QST30 Service Manual, Bulletin 4021539.

Go to 2A

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin in the fuel pump harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to- in in the fuel pump rack actuator coil.

  • Measure the resistance from rack actuator power supply pin of the fuel pump connector to all other pins of the connector, except rack actuator return pin.
  • Measure the resistance from rack actuator return pin of the fuel pump connector to all other pins of the connector, except rack actuator power supply pin.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the fuel pump. Refer to Procedure 005-012 (Fuel Injection Pumps, In-Line) in Section 5, in the QST30 Service Manual, Bulletin 4021539.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19
  • Replace the ECM
  • Call for pre-authorization
  • Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 167 active?
YES NO
No Repair

Repair

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1 connector.
  • Connect the engine harness to the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from rack actuator return pin to rack actuator power supply pin of the engine harness connector.
  • Measure the resistance from rack actuator return pin to rack actuator power supply pin of the engine harness connector.
  • Measure the resistance from rack actuator return pin to rack actuator return pin of the engine harness connector.
  • Measure the resistance from rack actuator return pin to rack actuator power supply pin of the engine harness connector.

Less than 20 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from rack actuator power supply pin of the engine harness connector to engine block ground.
  • Measure the resistance from rack actuator power supply pin of the engine harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from rack actuator return pin of the engine harness connector to all other pins in the connector, except rack actuator return pin, and to all pins in the OEM harness connector.
  • Measure the resistance from rack actuator return pin of the engine harness connector to all other pins in the connector, except rack actuator return pin, and to all pins in the OEM harness connector.
  • Measure the resistance from rack actuator power supply pin of the engine harness connector to all other pins in the connector, except rack actuator return pin, and to all pins in the OEM harness connector.
  • Measure the resistance from rack actuator return pin of the engine harness connector to all other pins in the connector, except rack actuator power supply pin, and to all pins in the OEM harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit from the return wire to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1 connector.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from the return wire to the power supply.

  • Measure the resistance from rack actuator return pin to rack actuator power supply pin of the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 167 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 172 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 172 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 172 active
YES NO
No Repair

Repair

Replace the fuel pump. Refer to Procedure 005-012 (Fuel Injection Pumps, In-Line) in the Troubleshooting and Repair Manual, QST30 Series Engine, Bulletin 3666217.

Fault Code 172

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 172 is inactive.

Fault Code 172 inactive
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Fuel Rack Actuator Driver Mechanically Stuck Closed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 173 active
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 173 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 173 active?
YES NO
No Repair

Repair

Replace the fuel pump. Refer to Procedure 005-012 in Section 5 (Fuel Injection Pumps, In-Line) in the QST30 Service Manual, Bulletin 4021539.

Go to Fault Code 173.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 173 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 2B

Escalate or call for assistance.

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 14-Aug-2018


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness at each bank. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 184 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 184 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness at each bank.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins
YES NO
No Repair

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for pre-authorization
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 184 active
YES | NO
No Repair | No Repair

Go to 1C

Go to 2B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM3.

Action

Check for an open circuit.

  • Measure the resistance from the secondary ID bit pin to the secondary ID bit pin of the engine harness connector.

Less than 10 ohms
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the secondary ID bit pin of the engine harness connector to the engine block ground.

More than 100k ohms
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM3.
  • Disconnect the OEM harness from the ECM3.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the secondary ID bit pin of the engine harness connector to all other pins in the connector, to all other pins in the connector OEM harness connector.

Note: These pin callouts are for the left-bank harness only.

More than 100k ohms
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 184 is inactive.

Fault Code 184 inactive
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test leadPart Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the connectors on ECM1, ECM2, and ECM3 engine harnesses. |
 | STEP 1A. Inspect the primary ECM connectors. | No damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 185 active?
STEP 2. | Inspect the 15-ampere fuses. |
 | STEP 2A. Inspect the 15-ampere fuse. | Less than 10 ohms?
STEP 3. | Inspect the SAE J1939 Circuit. |
 | STEP 3A. Check for an open circuit in the data link wire. | Less than 10 ohms?
 | STEP 3B. Check for an open circuit in the data link wire. | Less than 10 ohms?
 | STEP 3C. Check for proper termination of the harness. | 55 to 65 ohms?
 | STEP 3C-1. Check the individual termination connectors. |
 | STEP 3D. Check for an open circuit in the shield wire. | Less than 10 ohms?
 | STEP 3E. Check for a short circuit in the data link wire. | Less than 8.0-VDC?
 | STEP 3F. Check for a short circuit in the data link wire. | Less than 8.0-VDC
 | STEP 3G. Check for a short circuit to ground in the data link wire. | More than 100k ohms?
 | STEP 3H. Check for a short circuit to ground in the data link wire. | More than 100k ohms?
 | STEP 3I. Check for a short circuit from pin to pin in the data link wire. | More than 100k ohms?
STEP 4. | Check the ECM. |
 | STEP 4A. Check communication with the ECM. | Communication established?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 185 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Inspect the connectors on ECM1, ECM2, and ECM3 engine harnesses.

Guided Step 1A - Inspect the primary ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM connectors.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Repair

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or the J1939 backbone harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for pre-authorization and replace the ECM.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 185 active?
YES NO
No Repair

Repair

Repair complete.

Go to 2A

Go to 5B

Guided Step 2 - Inspect the 15-ampere fuses.

Guided Step 2A - Inspect the 15-ampere fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the 15-ampere fuse.

  • Measure the fuse resistance.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the SAE J1939 Circuit.

Guided Step 3A - Check for an open circuit in the data link wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

Check the data link wire resistance.

  • Measure the resistance from SAE J1939 data link supply of the primary ECM interface connector to SAE J1939 data link supply of the secondary ECM interface connector.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the data link wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the data link wire resistance.

  • Measure the resistance from SAE J1939 data link RETURN pin of the primary ECM interface connector to SAE J1939 data link RETURN pin of the secondary ECM interface connector.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for proper termination of the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the primary ECM.

Action

Check for proper termination of the harness.

  • Check the resistance across SAE J1939 data link SUPPLY pin and the SAE J1939 data link RETURN pin.

55 to 65 ohms?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C-1

Guided Step 3C-1 - Check the individual termination connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the ECM connector.

Action

Check the individual termination connectors.

  • Measure the resistance across SAE J1939 data link SUPPLY pin and the SAE J1939 data link RETURN pin.

110 to 130 ohms?
YES NO

Repair

  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Repair

Replace the end cap, Part Number 3163051

Go to 5A

Go to 5A

Guided Step 3D - Check for an open circuit in the shield wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all modules from the J1939.

Action

Check for an open circuit in the shield wire.

  • Measure the resistance from SAE J1939 data link shield pin of the J1939 to ground.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit in the data link wire.

Conditions

  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.

Action

Check for a short circuit in the data link wire.

  • Measure the voltage between SAE J1939 data link SUPPLY pin and SAE J1939 data link shield pin of the J1939 service tool interface.

Less than 8-VDC?
YES NO
No Repair

Repair

  • Replace the ground on the harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check for a short circuit in the data link wire.

Conditions

  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.

Action

Check for a short circuit in the data link wire.

  • Measure the voltage between SAE J1939 data link RETURN pin and SAE J1939 data link shield pin of the J1939 harness.

Less than 8-VDC?
YES NO
No Repair

Repair

  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3G

Go to 5A

Guided Step 3G - Check for a short circuit to ground in the data link wire.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.

Action

Check for a short circuit to ground in the data link wire.

  • Measure the resistance from SAE J1939 data link SUPPLY pin to SAE J1939 data link RETURN pin of the J1939 harness.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3H

Go to 5A

Guided Step 3H - Check for a short circuit to ground in the data link wire.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harnesses to the ECM connector.

Action

Check for a short circuit to ground in the data link wire.

  • Measure the resistance from SAE J1939 data link RETURN pin to SAE J1939 data link shield pin of the J1939 harness.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3I

Go to 5A

Guided Step 3I - Check for a short circuit from pin to pin in the data link wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnesses from the ECM connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from SAE J1939 data link 2 engine network SUPPLY pin to all other pins of the engine harness connector.
  • Measure the resistance from SAE J1939 data link 2 engine network RETURN pin to all other pins of the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check communication with the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check communication with the primary ECM.

  • Start the engine and let it idle for 1 minute.
  • Monitor ECM Time, use INSITE™ electronic service tool.

Communication established?
YES NO
No Repair

Repair

  • Call for pre-authorization and replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 185 is inactive.

Fault Code 185 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3164596 - male Framatome™ test leadPart Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2 and return. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold 2 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2 and return.

Guided Step 2A - Inspect the engine camshaft speed/position sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness or damaged sensor.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE ™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the engine camshaft speed/position sensor.

  • Refer to Procedure 019-363 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness or damaged sensor.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the intake manifold 1 pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness or damaged sensor.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2E

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness.
  • Reference the circuit art or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Repair

  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Repair

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/Amp®/Metri-Pack™ test leadPart Number 3824811 - female Deutsch™/Amp®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the coolant level sensor 1 and circuit. |
 | STEP 2A. Inspect the coolant level sensor 1 and connector and pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 800k ohms?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the coolant level sensor 1 and OEM harness connector.

Guided Step 2A - Inspect the coolant level sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the coolant level sensor 1 connector.

Action

Inspect the OEM harness connector and coolant level sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, pins, or replace the coolant level sensor 1.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-017 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the coolant level SIGNAL pin and the coolant level RETURN pin at the coolant level sensor 1 connector.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?
YES NO

Repair

Replace the coolant level sensor 1.

  • Refer to Procedure 019-017 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness and OEM harness.

Guided Step 3A - Inspect the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness connector and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or OEM harness connector or ECM connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness, the OEM harness or the ECM.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM and call for pre-aurthorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the coolant level sensor 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector coolant level sensor 1 RETURN pin and the OEM harness coolant level sensor 1 connector RETURN pin.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the OEM harness or engine harness.

Troubleshoot each section of the engine and OEM harnesses to determine which contains the open circuit.

  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or OEM harness.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant level SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or OEM harness.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM 50-pin connector.
  • Disconnect the engine coolant level sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM 50-pin connector and all other pins in the OEM harness ECM 50-pin connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Troubleshoot each section of the OEM harness to determine which contains the pin-to-pin short.

  • Check all harnesses connected in the series.
  • Replace the damaged section of the engine harness or OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the coolant level sensor 1 and OEM connector. |
 | STEP 2A. Inspect the coolant level sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 is active?
STEP 3. | Check the OEM harness, engine harness, and ECM. |
 | STEP 3A. Inspect the ECM, OEM harness and engine harness connector pins and engine harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the coolant level sensor 1 and OEM connector.

Guided Step 2A - Inspect the coolant level sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, or replace the coolant level sensor 1.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-017 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the coolant level sensor 1 connector to the OEM harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 is active?
YES NO

Repair

A damaged coolant level sensor 1 has been detected.

  • Replace the coolant level sensor 1.
  • Refer to Procedure 019-017 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness, engine harness, and ECM.

Guided Step 3A - Inspect the ECM, OEM harness and engine harness connector pins and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the OEM harness connector from the sensor connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the OEM harness, the engine harness, or the ECM.

  • Clean the connector and pins.
  • Replace the damaged section of the OEM harness, the engine harness, or the ECM.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.
  • Replace the ECM and call for pre—authorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM 50-pin connector.
  • Disconnect the engine coolant level sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the coolant level 1 5-volt (sensor supply 1) SUPPLY pin in the OEM harness ECM 50-pin connector and the coolant level 1 5-volt supply (sensor supply 1) SUPPLY pin in the OEM harness engine coolant level sensor 1 connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY wire has been detected in the OEM harness.

Troubleshoot each section of the OEM harness to determine which contains the pin-to-pin short.

  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or OEM harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM 50-pin connector
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-362 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit between pins has been detected in the OEM harness or engine harness.

Troubleshoot each of the harness sections to determine which contains the pin-to-pin short.

  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or OEM harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM 50-pin connector
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the coolant level sensor 1 SIGNAL pin at the engine harness ECM connector and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the OEM harness or engine harness.

Troubleshoot each of the harness sections to determine which contains the open circuit.

  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or OEM harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
 | STEP 1B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 1C. Check for a pin-to-pin circuit in the OEM harness. | Greater than 100k ohms?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 197 inactive?
 | STEP 2B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

Guided Step 1B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM 50-pin connector.
  • Disconnect the engine coolant level sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the coolant level 1 5-volt (sensor supply 1) SUPPLY pin in the OEM harness ECM 50-pin connector and the coolant level 1 5-volt supply (sensor supply 1) SUPPLY pin in the OEM harness engine coolant level sensor 1 connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY wire has been detected in the OEM harness.

  • Troubleshoot each section of the OEM harness to determine which contains the pin-to-pin short.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a pin-to-pin circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM 50-pin connector.
  • Disconnect the engine coolant level sensor 1 from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine coolant level 1 SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

See the Coolant Loss troubleshooting symptom troubleshooting tree in the QST30 CM552 Service Manual, Bulletin 4021674.

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

  • Troubleshoot each section of the OEM harness to determine which contains the pin-to-pin short circuit.
  • Replace the damaged section of the engine harness or OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Appropriate troubleshooting steps

Repair complete

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 197 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor 1 and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Inspect the engine harness and engine oil temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins.
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector or shell broken
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil temperature sensor 1 or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness or the damaged engine oil temperature sensor 1.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-067 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin and engine oil temperature 1 RETURN (sensor return 1) pin at the engine oil temperature sensor 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor 1.

  • Refer to Procedure 019-067 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the oil temperature sensor 1 connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins.
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector or shell broken
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil temperature 1 SIGNAL pin and engine oil temperature 1 RETURN (sensor return 1) pin at the ECM 60-pin engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Repair

  • Replace the ECM call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil temperature 1 RETURN (sensor return 1) pin of the engine harness connector and the oil temperature 1 RETURN (sensor return 1) pin of the engine harness ECM 60-pin connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine oil temperature RETURN (sensor return 1) circuit has been detected in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open circuit.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine oil temperature 1 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin of the engine harness ECM 60-pin connector and the engine oil temperature 1 SIGNAL pin of the engine harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine oil temperature 1 SIGNAL circuit has been detected in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open circuit.
  • Replace the damaged section of engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the engine harness ECM 60-pin connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine oil temperature 1 SIGNAL wire has been detected in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.
  • Replace the damaged section of engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 212 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor 1 and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Inspect the engine harness and engine oil temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil temperature 1 sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness or damaged engine oil temperature 1 sensor.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-067 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine oil temperature sensor 1 connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 is active?
YES NO

Repair

A damaged engine oil temperature sensor 1 has been detected.

  • Replace the engine oil temperature sensor 1.
  • Refer to Procedure 019-067 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Repair

  • Replace the ECM and call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine oil temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the engine oil temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 213 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 214 active?
STEP 2. | Clear the Fault Codes. |
 | STEP 2A. Disable the fault code. | Fault Code 214 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES NO

Repair

Reference the Engine Oil Temperature Above Normal troubleshooting symptom tree in the QST30 CM552 Service Manual, Bulletin 4021674.

No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 214 is inactive.

Fault Code 214 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome™ test leadPart Number 3822917 - female Deutsch™ /AMP™ /Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227, on the same source address as Fault Code 221, active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor supply 2). | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227, on same source address as Fault Code 221, active?
YES | NO
No Repair | No Repair

Reference Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-004 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.
  • Repair pins or replace the connector. Refer to Procedure 019-218 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the barometric air pressure sensor. Refer to Procedure 019-004 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Check each section of harness to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor return 2).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the ECM engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine harness.

Check each section of harness to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome™ test leadPart Number 3822917 - female Deutsch™ /AMP™ /Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187, on same source address as Fault Code 222, active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor return 2) circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor return 2) circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187, on same source address as Fault Code 222, active?
YES | NO
No Repair | No Repair

Reference Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-004 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.
  • Repair pins or replace the connector. Refer to Procedure 019-218 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the barometric pressure 5 volt SUPPLY (sensor supply 2) pin and the barometric pressure RETURN (sensor return 2) pin at the barometric pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the barometric air pressure sensor. Refer to Procedure 019-004 in Section 19.

Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor return 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the ECM engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted SUPPLY circuit has been detected in the engine harness.

Check each section of engine harness to determine which contains the open or short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the barometric pressure 5 volt SUPPLY (sensor supply 2) pin and the barometric pressure SIGNAL pin at the ECM engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
  • Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Check each section of the engine harness to determine which contains the open or pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the engine harness.Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test leadPart Number 3823994 - female Deutsch™ test lead Part Number 3823995 - male Weather-Pack™ test lead Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil burn valve solenoid driver. |
 | STEP 1A. Verify the engine oil burn valve solenoid driver is connected to the engine harness. | Solenoid is connected?
 | STEP 1B. Inspect the engine oil burn valve solenoid driver and harness connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the engine oil burn valve solenoid driver for a short circuit to engine block ground. | Between 18 to 22 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 223 inactive?
 | STEP 3BA. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the engine oil burn valve solenoid driver.

Guided Step 1A - Verify the engine oil burn valve solenoid driver is connected to the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the engine oil burn valve solenoid driver is connected to the engine harness.

Solenoid is connected?
YES NO
No Repair

Repair

Connect the solenoid to the engine harness.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine oil burn valve solenoid driver and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Inspect the engine oil burn valve solenoid driver and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the engine oil burn valve solenoid driver connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of the harness or damaged driver sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Inspect and test the solenoid driver. Refer to Procedure 019-173 in Section 19.

Go to 3A

Go to 1C

Guided Step 1C - Check the engine oil burn valve solenoid driver for a short circuit to engine block ground.

Conditions

  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Check for a short circuit to ground in the engine oil burn valve solenoid driver.

  • Measure the resistance from the engine oil burn valve SIGNAL pin of the engine oil burn valve solenoid driver to engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19..

Between 18 to 22 ohms?
YES NO
No Repair

Repair

Replace the engine oil burn valve solenoid driver.

Refer to Procedure 019-173 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine oil burn valve SIGNAL pin of the engine harness 50-pin connector to engine block ground.
  • Measure the resistance from the engine oil burn valve RETURN pin of the engine harness 50-pin connector to engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the pins or the connector. Refer to Procedure 019-202 in Section 19.
  • Replace pins or connector. Refer to Procedure 019-204 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine oil burn valve SIGNAL pin of the engine harness 50-pin connector to all other pins in the connector, excluding the following pins: the engine oil burn valve RETURN pin, the accelerator or lever position RETURN (sensor return 4), the OEM temperature return pin, the idle validation switch RETURN pin, and the external speed command input RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace pins or connector. Refer to Procedure 019-204 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 30 seconds.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify that Fault Code 223 is inactive.

Fault Code 223 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked agaain.

Repair complete

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test leadPart Number 3823994 - female Deutsch™ test lead Part Number 3823995 - male Weather-Pack™ test lead Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 224 is active?
STEP 2. | Check the engine oil burn valve solenoid driver. |
 | STEP 2A. Inspect the engine harness and engine oil burn valve solenoid driver. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine oil burn valve solenoid driver. | Between 18 to 22 ohms?
 | STEP 2C. Check for engine oil burn valve solenoid driver supply voltage and return circuit. | Greater than 6.0-VDC?
 | STEP 2D. Check for an open circuit in the engine oil burn valve solenoid driver return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM engine oil burn valve solenoid driver diagnostic supply voltage. | Greater than 6.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 224 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 224 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 is active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Code ) in Section 19

Guided Step 2 - Check the engine oil burn valve solenoid driver.

Guided Step 2A - Inspect the engine harness and engine oil burn valve solenoid driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Inspect the engine harness connector and solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or solenoid.

Clean the connector and pins.

Replace the damaged section of the harness or damaged solenoid.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Inspect and test the solenoid driver. Refer to Procedure 019-173 in Section 19.
  • Replace the pins or the connector. Refer to Procedure 019-202 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine oil burn valve solenoid driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Check for an open circuit in the engine oil burn valve solenoid driver.

  • Measure the resistance from the engine oil burn valve SIGNAL pin to the engine oil burn valve RETURN pin at the engine oil burn valve solenoid driver.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 18 to 22 ohms?
YES NO
No Repair

Repair

Replace the engine oil burn valve solenoid driver.

  • Inspect and test the solenoid driver. Refer to Procedure 019-173 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for engine oil burn valve solenoid driver supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure between the engine oil burn valve SIGNAL pin and the engine oil burn valve RETURN pin at the engine oil burn valve solenoid driver connector of the engine harness.

Greater than 6.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the engine oil burn valve solenoid driver return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Check for an open circuit.

  • Measure the resistance from the engine oil burn valve solenoid driver engine harness connector RETURN pin to engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM engine oil burn valve solenoid driver diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil burn valve SIGNAL pin and the engine oil burn valve RETURN pin at the ECM 50-pin connector port.

Reference the circuit diagram or wiring diagram for connector pin identification.

Greater than 6.0-VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil burn valve solenoid driver harness connector SUPPLY pin and the engine oil burn valve solenoid driver 50-pin engine harness connector SUPPLY pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine oil burn valve solenoid driver from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil burn valve SIGNAL pin in the engine harness 50-pin connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the supply wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 30 seconds.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 224 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM 60-pin connector.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Repair

  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace the damaged section of the engine harness.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 228. | Active or inactive counts of Fault Code 228?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for fault code 228. | Active or inactive counts of Fault Code 228?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 228.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 228?
YES NO

Repair

Reference the Low Coolant Pressure troubleshooting tree in the Service Manual, QST30, Bulletin 4021539.

 No Repair

Appropriate troubleshooting symptom tree

Go to 1B

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 228 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome™ test leadP art Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 231 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 232 active and Fault code 231 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 231 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 231 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 231 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Sectio 19

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness 60-pin connector.

Action

Check for an inactive fault code

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the coolant pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged coolant pressure sensor.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 ( Coolant Pressure Sensor) in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the coolant pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active?
YES NO

Repair

A damaged coolant pressure sensor has been detected.

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 ( Coolant Pressure Sensor) in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the coolant pressure SIGNAL line of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the ECM engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open coolant pressure RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 231 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement.Part Number 3164596 - male Framatome™ test leadPart Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for inactive fault code. | Fault Code 232 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 231 active and Fault Code 232 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 232 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 232 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and coolant pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the coolant pressure sensor harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged coolant pressure sensor.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 ( Coolant Pressure Sensor) in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the coolant pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the coolant pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the coolant pressure sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

Repair

A damaged coolant pressure sensor has been detected.

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 ( Coolant Pressure Sensor) in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the ECM 60-pin engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace teh ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted coolant pressure SUPPLY (sensor supply 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

Replace the damaged section of engine harness.Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-199 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the ECM 60-pin engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the coolant pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin to pin short.

Replace the damaged section of the engine harness.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 232 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 2450 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine crankshaft speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1F. Test the genset application. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring at overspeedwhen the fault was logged.

Engine motoring at overspeed?
YES NO
No Repair

Repair

Check for engine damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the operator reported a fuel-controlled event where the engine rapidly accelerated to or past 2150 rpm, followed by moderate deceleration to 2150 rpm.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.
  • Engine is running

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine crankshaft speed sensor reading on INSITE™ electronic service tool to a mechanical tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine crankshaft speed sensor and the engine camshaft speed sensor as outlined in Fault Code 689.

Go to 1D

Fault Code 689

Guided Step 1D - Inspect the engine harness and engine crankshaft speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine crankshaft speed sensor connector.

Action

Inspect the engine harness and engine crankshaft speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine crankshaft speed sensor or harness connector.

Clean the connector and pins.

Repair the damaged section of the harness or damaged engine crankshaft speed sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for active Fault Code 234 when the engine is not running above 1800 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Test the equipment.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Test the equipment to determine if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2650 rpm, the engine must be shut off immediately. The engine will be damaged.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source present?
 | STEP 1C. Check the engine rpm with the monitor mode. | Correct rpm reading?
 | STEP 1D. Check for an active fault code at low engine rpm. | Active Fault Code 234 below 2650 rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO
No Repair

Repair

Check the engine for damage.

  • Check for damaged electronics.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check with the operator to see if he reported a fuel-controlled event where the engine rapidly accelerated to or past 2650 rpm, followed by moderate deceleration to 2130 rpm.

Alternate fuel source present?
YES NO

Repair

Locate the alternate fuel source.

  • Locate and remove any alternate fuel sources, such as operating the engine near flammable vapors, damaged turbocharger seals, etc.
No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with the monitor mode.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with the monitor mode.

  • Use INSITE™ electronic service tool to monitor engine rpm.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine speed sensor.

  • Check the engine speed sensor as outlined in Fault Codes 115 and 121.

Go to 1D

Fault Codes 115 and 121

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1D - Check for an active fault code at low engine rpm.

Conditions

  • Turn keyswitch OFF.

Action

Check for an active fault code at low engine rpm.

  • Check for an active Fault Code 234 when the engine is not running above 2650 rpm.

Active Fault Code 234 below 2650 rpm?
YES NO

Repair

  • Call for pre-authorization.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 2A

Go to 1E

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle.

  • Check if the overspeed condition is still present.

Fault code 234 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Repair

Reference the Coolant Loss troubleshooting symptom tree in the Service Manual QST30 CM552, Bulletin 4021539.

 No Repair

Appropriate troubleshooting steps

Repair complete

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3164596 - male Framatome™ test leadPart Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 3 and return. |
 | STEP 2A. Inspect the engine crankshaft speed sensor and circuit connected to the sensor supply 3 and return | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 238 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 3 and return.

Guided Step 2A - Inspect the engine crankshaft speed sensor and circuit connected to the sensor supply 3 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged sensor.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section od the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged connector. Refer to Procedure 019-218 in Section 19.
No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE ™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Repair

Replace the engine crankshaft speed sensor.

  • Refer to Procedure 019-042 (Engine Crankshaft Speed Sensor) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Repair

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot each section of the harnesses connected in series to determine which contains the short circuit to ground or pin-to-pin short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3163531 - fuel shutoff valve breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff valve. |
 | STEP 1A. Check for extra wires splice into the fuel shutoff valve. | No extra wires
 | STEP 1B. Inspect the engine harness and fuel shutoff valve connectors. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault code 254 active
 | STEP 1D. Check the fuel shutoff valve supply voltage. | More than 16.5-VDC
 | STEP 1E. Check the fuel shutoff valve supply voltage. | More than 16.5-VDC
 | STEP 1E-1. Check for an open circuit. |
 | STEP 1E-2. Check for a short circuit to ground. |
 | STEP 1E-3. Check for a short circuit from pin to pin. |
 | STEP 1F. Check the fuel shutoff valve resistance. | 38.5 to 43.5 ohms for 24-VDC solenoids.
STEP 2. | Check the ECM |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault code 254 active
 | STEP 2C. Check the supply voltage to the ECM. | More than 17-VDC
 | STEP 2C-1. Check the in-line fuse. |
 | STEP 2C-2. Check for an open circuit. |
 | STEP 2C-3. Check for a short circuit to ground. |
 | STEP 2C-4. Check for a short circuit from pin to pin. |
 | STEP 2D. Check the keyswitch voltage at the ECM. | More that 17-VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code 254 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel shutoff valve.

Guided Step 1A - Check for extra wires spliced into the fuel shutoff valve circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires spliced to the fuel shutoff valve circuit.

Are extra wires spliced into the fuel shutoff valve circuit?
YES NO

Repair

Remove any extra wires from the fuel shutoff valve circuit.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Inspect the engine harness and fuel shutoff valve connectors.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Inspect the engine harness and fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or fuel shutoff valve connector.

  • Clean the connector and pins.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 (Fuel Shutoff Valve) in Section 19.
No Repair

Go to 3A

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Is fault code 254 active?
YES | NO
No Repair | No Repair

Go to 1D

Go to 3B

Guided Step 1D - Check the fuel shutoff valve supply voltage.

Conditions

  • Disconnect the engine harness from the fuel shutoff valve.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve supply voltage.

  • Install breakout cable, Part Number 3163531, between the fuel shutoff valve and the engine harness.
  • Measure the voltage from the red test lead of the breakout cable to the black test lead.

More than 16.5-VDC?
YES | NO
No Repair | No Repair

Go to 1F

Go to 1E

Guided Step 1E - Check the fuel shutoff valve supply voltage.

Conditions

  • Disconnect the engine harness from the fuel shutoff valve.
  • Disconnect the breakout cable, Part Number 3163531, from the fuel shutoff valve and the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve supply voltage.

  • Measure the voltage from the supply pin of the engine harness fuel shutoff valve connector to engine block ground.

More than 16.5-VDC?
YES NO

Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 (Fuel Shutoff Valve) in Section 19.

No Repair

Go to 3A

Go to 1E-1

Guided Step 1E-1 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve supply pin of the engine harness fuel shutoff valve connector to the fuel shutoff valve return pin of the engine harness connector.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair of replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E-2

Go to 3A

Guided Step 1E-2 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit to ground.

  • Measure the resistance from the fuel shutoff valve supply pin to engine block ground.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E-3

Go to 3A

Guided Step 1E-3 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve supply pin of the engine harness connector to all other pins in the connector, and to all other pins in the OEM connector.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 1F - Check the fuel shutoff valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check the fuel shutoff valve resistance.

  • Measure the resistance from the fuel shutoff valve supply pin to the fuel shutoff valve return pin on the sensor side of the connector.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

38.5 to 43.5 ohms for 24-VDC solenoids?
YES NO
No Repair

Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 (Fuel Shutoff Valve) in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or replace the ECM.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the supply voltage to the ECM.

Conditions

  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff valve.
  • Turn keyswitch ON.

Action

Check the supply voltage to the ECM.

  • Measure the voltage from battery 1 voltage supply of the engine harness connector ECM port to engine block ground.

More than 17-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the in-line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the in-line fuse from the engine harness.

Action

Check the in-line fuse.

  • Measure the resistance across the fuse.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C-2

Go to 3A

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 16-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from battery 1 voltage supply pin of the engine harness connector to unswitched battery voltage supply (ECM1) of the 16-pin OEM harness connector.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-3

Go to 3A

Guided Step 2C-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 16-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the battery 1 voltage supply pin of the engine harness to engine block ground.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-4

Go to 3A

Guided Step 2C-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 16-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the battery 1 voltage supply pin of the engine harness connector to all other pins in the connector.
  • Measure the resistance from the battery 1 voltage supply pin of the engine harness connector to all other pins in the OEM harness connector.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

Correct the OEM power supply.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 2D - Check the keyswitch voltage at the ECM.

Conditions

  • Disconnect the engine harness at the ECM.
  • Disconnect the engine harness from the fuel shutoff valve.
  • Turn keyswitch ON.

Action

Check the keyswitch voltage at the ECM.

  • Measure the voltage from the keyswitch input pin of the engine harness connector to engine block ground.

More than 17-VDC?
YES NO

Repair

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Check the OEM keyswitch circuit. Reference the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify fault code 254 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 is active?
STEP 3. | Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the SAE J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM SAE J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM SAE J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 is active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service SAE J1939 data link harness.

Guided Step 4A - Inspect the service SAE J1939 data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link adapter from the 9-pin service data link connector.

Action

Inspect the service SAE J1939 data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service SAE J1939 data link cable.

  • Clean the connector and pins.
  • Repair or replace the damaged section of the harness.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-205 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter connector from the 9-pin service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the service data link connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service data link connector or harness connection to the SAE J1939 data link.

  • Troubleshoot harnesses connected in series to determine which contains the open or short circuit.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-205 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the SAE J1939 data link connector or harness.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of harness. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-204 in Section 19.
No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the appropriate Cummins® ECM connection to the SAE J1939 data link harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or short circuit.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the Cummins® ECM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link SUPPLY and the SAE J1939 data link RETURN pins.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged section of the harness. Refer to Procedure 019-199 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check for appropriate circuit response.

Fault Code 285 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the SAE J1939 data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Reference the ECM No Communication (tt-ECM) symptom tree

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 286 is active?
STEP 3. | Check the OEM electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the SAE J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM SAE J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM SAE J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 286 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 6B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 is active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM electronic control unit multiplexing configuration component enables and OEM electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM electronic control unit multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service SAE J1939 data link harness.

Guided Step 4A - Inspect the service SAE J1939 data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link connector adapter from the 9-pin service data link connector.

Action

Inspect the service SAE 1939 datalink connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service SAE J1939 data link cable or connector.

  • Clean the connector and pins.
  • Repair or replace the damaged section of the service SAE J1939 data link harness.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-026 (data link Circuit, Public) in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-205 (Deutsch&trade; DT Connector Series).
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link connector adapter from the 9-pin service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the service data link connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service SAE J1939 data link connector or harness connection to the SAE J1939 data link.

  • Troubleshoot all harness connected in series to determine which contains the open or short circuit.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-026 (data link Circuit, Public) in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-205 (Deutsch&trade; DT Connector Series).

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the SAE J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair or replace the damaged section of the harness.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-026 (data link Circuit, Public) in Section 19.
  • Refer to Procedure 019-204 in Section 19.
No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the appropriate Cummins ECM engine connection to the SAE J1939 data link harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open or short circuit.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-026 (data link Circuit, Public) in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the data link connector adapter from the 9-pin service data link connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the Cummins ECM connection to all other pins in the connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link SUPPLY and the SAE J1939 data link RETURN pins.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-026 (data link Circuit, Public) in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Reference the appropriate ECM No Communication (tt-ECM) symptom tree

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 286 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM and engine harness. |
 | STEP 1A. Inspect all ECM and engine harness connector pins. | Dirty or damaged pins?
STEP 2. | Inspect terminating resistor and circuit. |
 | STEP 2A. Inspect the terminating resistor. | 120 ohms?
 | STEP 2B. Inspect data link circuit | 60 ohms?
STEP 3. | Calibrate the ECMs. |
 | STEP 3A. Calibrate ECMs. | ECMs accepted calibration?
 | STEP 3B. ROM boot ECMs. | ROM boot procedure successful?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 342 inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM and engine harness.

Guided Step 1A - Inspect all ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all of the engine harness connectors from the ECM connectors.

Action

Inspect the engine harness and all ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in an ECM engine connector or engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness.
  • Reference the circuit diagram or wiring diagram for connector identification.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2A

Go to 2A

Guided Step 2 - Inspect the terminating resistor and circuit.

Guided Step 2A - Inspect the terminating resistor.

Conditions

  • Disconnect terminating resistors.

Action

Measure the resistance across SAE J1939 data link SUPPLY pin and SAE J1939 data link RETURN pin on both terminating resistors.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

120 ohms?
YES NO
No Repair

Repair

Replace the terminating resistor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the data link circuit.

Conditions

  • Disconnect all of the engine harness ECM 60-pin connectors
  • Connect terminating resistor.

Action

Measure the resistance across SAE J1939 data link RETURN pin and SAE J1939 data link SUPPLY pin on the 60-pin connectors for all ECMs.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

60 ohms?
YES NO
No Repair

Repair

A damaged connection has been detected in an ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness.
  • Reference the circuit diagram or wiring diagram for connector pin identification.
  • Check all harnesses connected in series.
  • Refer to Procedure 019-043 in Section 19.
  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Calibrate the ECMs

Guided Step 3A - Calibrate the ECM.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECMs.

  • Refer to Procedure For calibration procedures, 019-032 (ECM Calibration Code) in Section 19 and INSITE&trade; electronic service tool user manual.

ECMs accepted calibration?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - ROM boot the ECMs.

Conditions

  • Turn keyswitch OFF.

Action

ROM boot the ECMs.

  • Refer to Procedure 019-427 (ECM ROM Boot) in Section 19.

ROM boot procedure successful?
YES NO
No Repair

Repair

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 342 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 2B

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to 2B

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Recalibrate the primary and secondary ECMs. |
 | STEP 1A. Recalibrate the primary and secondary ECMs. | ECMs recalibrated?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Multiple fault codes inactive?
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Recalibrate the primary and secondary ECMs.

Guided Step 1A - Recalibrate the ECMs.

Conditions

  • Turn keyswitch ON

Action

Calibrate the ECMs.

  • Refer to Procedure For calibration procedures, 019-032 (ECM Calibration Code) in Section 19 and INSITE&trade; electronic service tool user manual.

ECMs recalibrated?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON, but do not start the engine.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 342 is inactive.

Multiple fault codes inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault code 343 active?
 | STEP 1B. Disconnect power to the ECM. | Fault code 343 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

Action

Check for active fault code 343.

  • Turn keyswitch OFF and wait at least 5 seconds.
  • Turn keyswitch ON.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to check for active fault code 343.

Fault Code 343 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Disconnect the power to the ECM.

Conditions

Action

Disconnect power to the ECM.

  • Turn keyswitch OFF.
  • Disconnect INSITE™ electronic service tool from the data link.
  • Disconnect the power to the ECM at the battery.
  • Wait 1 minute.
  • Connect the power to the ECM at the battery.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to the data link.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to check for inactive Fault Code 343.

Fault code 343 active?
YES NO

Repair

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that fault code 343 is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test leadPart Number 3823994 - female Deutsch™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connection?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC?
STEP 2. | Check the OEM interface harness. (The following steps have been constructed for generic troubleshooting of the OEM circuit. Reference the OEM manual for more details.) |
 | STEP 2A. Inspect the OEM interface harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 346 active?
 | STEP 2C. Check unswitched battery voltage. | 17 to 35-VDC?
 | STEP 2D. Check unswitched battery voltage (key-off). | 17 to 35-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness ground connection. | Damaged connection?
 | STEP 3B. Inspect the engine harness and ECM connectors. | Damaged connectors?
 | STEP 3C. Read the fault codes. | Fault code 346 active?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3F. Check for an open circuit. | Fault Code 346 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 346 active?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?
STEP 5. | Download the calibration. |
 | STEP 5A. Download the calibration. | Calibration download successful?
 | STEP 5B. Cycle the keyswitch three times. | Fault code 346 active?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

  • Repair or replace the battery connections. Reference the OEM service manual.
 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.

17.3 to 34.7-VDC?
YES NO
No Repair

Repair

Reference the Battery Low symptom tree in the Service Manual, QST30 Series Engines, Bulletin 4021539.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM interface harness. (The following steps have been constructed for generic troubleshooting of the OEM circuit. Reference the OEM manual for more details.)

Guided Step 2A - Inspect the OEM harness and ECM connectors.

Conditions

  • Turn keyswitch OFF
  • Disconnect OEM harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check unswitched battery voltage.

Conditions

  • Disconnect the OEM harness from the OEM interface harness at the 16-pin connector.
  • Disable the master disconnect switch.
  • Turn keyswitch ON.

Action

Check unswitched battery voltage.

  • Measure the voltage from unswitched battery voltage supply (ECM1) of the 16-pin OEM harness connector, OEM side, to engine block ground.

17 to 35-VDC?
YES NO
No Repair

Repair

Check the OEM fuses.

Repair or replace the OEM harness or OEM interface harness.

  • Repair the harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check unswitched battery voltage (key-off).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 16-pin connector.
  • Disable the master disconnect switch.

Action

Check unswitched battery voltage (key-off).

  • Measure the voltage from unswitched battery voltage supply (ECM1) of the 16-pin OEM harness connector, OEM side, to engine block ground.

17 to 35-VDC?
YES NO
No Repair

Repair

Correct the unswitched battery supply.

  • Check the keyswitch wiring. Reference the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness ground connection.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine block at the ground connection.

Action

Check the engine harness ground connection for the following:

  • Loose connections
  • Broken connections
  • Corroded connections
  • Excessive paint, oil, or dirt.

Damaged connection?
YES NO

Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-197 (Ring Terminal) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors.

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE electronic service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 16-pin connector.
  • Disconnect the OEM interface harness from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Measure the resistance from battery 1 voltage supply pin of the engine harness connector to the battery 1 voltage supply pin of the 16-pin OEM harness connector, OEM interface harness side.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM interface harness from the battery.

Action

Check for an short circuit from pin to pin in the unswitched battery supply.

  • Measure the resistance from battery 1 voltage return pin of the engine harness connector to all other pins in the connector.
  • Measure the resistance from battery 1 voltage return pin of the engine harness connector to all pins in the 50-pin OEM harness connector.
  • Measure the resistance from battery 1 voltage supply pin of the engine harness connector to all other pins in the connector.
  • Measure the resistance from battery 1 voltage supply pin of the engine harness connector to all pins in the 50-pin OEM harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness or engine harness.

  • Repair the OEM harness or engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness or engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the block grond circuit.

  • Measure the resistance from battery 1 voltage return pin of the engine harness connector to the engine block ground connection on the engine harness.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-197 (Ring Terminal) in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Cycle the keyswitch three times.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: Wait 30 seconds after each key-off to let the ECMs complete their power-down cycle.

Fault Code 346 inactive?
YES NO
No Repair

Repair

Recalibrate the ECMs. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Guided Step 5 - Download the calibration

Guided Step 5A - Download the calibration.

Conditions

  • Connect all components.

Action

Download the calibration.

Calibration download successful?
YES NO
No Repair

Repair

Check communication connections and retry the download.

Repair complete

Go to 5B

Guided Step 5B - Cycle the keyswitch three times.

Conditions

  • Connect all components.

Action

Cycle the keyswitch three times.

NOTE: Wait 30 seconds after each key-off to let the ECMs complete their power-down cycle.

Fault Code 346 inactive?
YES NO
No Repair

Repair

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair complete

Repair complete

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test leadPart Number 3823994 - female Deutsch™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault code 352 active?
STEP 2. | Check the sensors and circuits connected to sensor 1 supply and return. |
 | STEP 2A. Inspect the engine oil rifle pressure 1 sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the coolant level 1 sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the remote accelerator pedal or lever position sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
 | STEP 3C. Inspect the vehicle for optional OEM devices. | OEM devices installed?
 | STEP 3D. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the OEM and engine harness for short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check the OEM and engine harness for short circuit pin to pin. | Greater than 100k ohms?
 | STEP 3G. Check for a short circuit in the OEM harness ECM battery negative (-) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 1 and return.

Guided Step 2A - Inspect the engine oil rifle pressure 1 sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the sensor. Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine oil rifle pressure 1 sensor.

  • Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the coolant level 1 sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level 1 sensor connector from the OEM harness connector.
  • Disconnect the engine harness from the 50-pin OEM connector.

Action

Inspect the OEM, engine harness, and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Reference the OEM troubleshooting and repair manual for sensor repair instructions.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level 1 sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the OEM coolant level 1 sensor. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the coolant pressure sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor connector from the engine harness connector.
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the OEM, engine harness, and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Reference the OEM troubleshooting and repair manual for sensor repair instructions.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the sensor. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

There is a short circuit in the engine harness pulling the sensor supply voltage down.

  • Troubleshoot each section of harness to determine which contains the short circuit.
  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Replace the damaged section of the engine harness.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM and engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor. Reference the OEM troubleshooting and repair manual.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the OEM harness or engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 50-pin connector.
  • Disconnect the coolant level 1 sensor connector from the OEM harness connector.

Action

Check the harnesses connected in series for a short to ground.

  • Measure the resistance between the OEM 5-VDC SUPPLY pin at the OEM 50-pin harness connector and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short to ground in the OEM harness or engine harness.

  • Troubleshoot the harness connected in series to determine which contains the short circuit.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Repair or replace the damaged section of harness or damaged sensor.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the OEM harness and engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 50-pin connector.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness ECM 50-pin connector.
  • Disconnect the coolant pressure sensor connector from the engine harness ECM 50-pin connector.

Action

Check the harnesses connected in series for a pin-to-pin short circuit.

  • Measure the resistance between the OEM 5-VDC SUPPLY pin at the OEM 50-pin harness connector to all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot the harnesses connected in series to determine which contains the pin-to-pin short.

  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Repair or replace the damaged section of harness.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit in the OEM harness ECM battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine harness battery supply ECM 4-pin power connector.
  • Disconnect the coolant level 1 sensor connector from the OEM harness connector.

Action

Check for a short circuit

  • Measure the resistance between the OEM 5-VDC SUPPLY pin at the engine harness ECM connector and the ECM battery negative (-) pins in the ECM power connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot the harnesses connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that fault code is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test leadPart Number 3823994 - female Deutsch™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check the OEM 5-VDC supply. |
 | STEP 3A. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the OEM harness or engine harness for a short circuit pin to pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the OEM harness ECM battery positive (+) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply 1.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM connector and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-204 Deutsch&trade; DRC Connector Series) in Section 19.
  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO
No Repair

Repair

There is a short in the engine harness causing the sensor 5-VDC supply wire to have to high a voltage.

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit.
  • Reference the circuit diagram or wiring diagram for all interconnections.
  • Replace the damaged section of the wiring harness.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM 5-VDC supply.

Guided Step 3A - Inspect all OEM, ECM, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM, ECM, and engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged connector. Reference the OEM troubleshooting and repair manual.

  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the OEM harness or engine harness for a short circuit pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine oil rifle pressure 1 sensor from the engine harness ECM 50-pin connector.
  • Disconnect the coolant pressure sensor from the engine harness ECM 50-pin connector.

Action

Check the OEM or engine harness for a short circuit from pin-to-pin.

  • Measure the resistance between the OEM 5-VDC SUPPLY pin at the engine harness ECM 50-pin connector to all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Replace the damaged section of harness.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the OEM harness ECM battery positive (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine harness battery supply ECM 4-pin power connector.
  • Disconnect the generator speed/load governor bias connector from the OEM harness connector.
  • Disconnect the OEM pressure sensor connector from the OEM harness connector.

Action

Check for a short circuit to ECM battery positive (+) in the OEM harness or engine harness.

  • Measure the resistance between the OEM 5-VDC SUPPLY pin at the engine harness ECM connector to the ECM battery positive (+) pins at the ECM 4-pin power connector on the engine harness battery supply.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Replace the damaged section of harness.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 415. | Active or inactive counts of Fault Code 415?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 415.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Repair

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in the QST30 Series Engines, Service Manual, Bulletin 4021539.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 421.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES NO

Repair

Reference the Engine Oil Temperature Above Normal troubleshooting symptom tree in the Service Manual, QST30 Series Engines, Bulletin 4021539.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 20-Dec-2012


FC423 - Injector Timing Rail 1 Fuel Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 113 and 114 active?
STEP 2. | Measure fuel inlet restriction. |
 | STEP 2A. Measure restriction. | Fuel restriction within specification?
STEP 3. | Check for a mechanical failure of the pump. |
 | STEP 3A. Check the sleeve current. | Sleeve current changing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 423 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 113 and 114 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Measure fuel inlet restriction.

Guided Step 2A - Measure restriction.

Conditions

  • Turn keyswitch ON.
  • Start the engine and let it idle.

Action

Measure the fuel inlet restriction.

  • Refer to Procedure 006-020 (Fuel Inlet Restriction) in Section 6 of the Service Manual, QST30 Series Engines, Bulletin 4021539.

Fuel inlet restriction within specification?
YES NO
No Repair

Repair

Refer to Procedure 006-020 (Fuel Inlet Restriction) in Section 6 of the Service Manual, QST30 Series Engines, Bulletin 4021539.

Go to 3A

Appropriate troubleshooting tree

Guided Step 3 - Check for mechanical failure of the pump.

Guided Step 3A - Check the sleeve current.

Conditions

  • Turn keyswitch ON.
  • Start the engine and let it idle.
  • Connect INSITE™ electronic service tool.

Action

Check the sleeve current.

  • Use INSITE™ electronic service tool to monitor the sleeve current while varying the engine rpm.

Sleeve current changing?
YES NO

Repair

Repair or replace the fuel pump.

  • Refer to Procedure 005-016 (Fuel Pump) in Section 5 of the Service Manual, QST30 Series Engines, Bulletin 4021539.

Repair

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 423 is inactive.

Fault Code 423 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Dec-2016


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement:Part Number 3163151 - ECM Bench Top Calibration Harness Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SAE J1939 data link communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does the INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection. Use INSITE™ electronic service tool to communicate with the ECM.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

Repair

The ECM SAE J1939 data link circuit is functioning properly.

  • Reference the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 data link network.
 No Repair

Reference the OEM troubleshooting and repair manual for information on troubleshooting and vehicle SAE J1939 data link network

Go to 1B

Guided Step 1B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 50-pin connector.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Replace the damaged section of the engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the harness. Refer to Procedure 019-199 (Connection, Butt Splice) in Section 19. Refer to Procedure 019-204 (Deutsch&trade; DRC connectors..

Reference the circuit diagram or wiring diagram for all interconnections.

  • Call for pre-authorization.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect the INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

Repair

The INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

  • Reference the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 data link network.
 No Repair

Reference the OEM troubleshooting and repair manual

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Verify that Fault Code 426 is inactive.

Fault Code 426 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the 4-pin power connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Reference the OEM troubleshooting and repair manual.

Refer to Procedure 013-009 (Battery Cables and Connections) in Section 13 in the Service Manual, QST30, Bulletin 4021539.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least 24-VDC (+24-VDC systems).

Normal conditions:

  • At least 12-VDC (+12-VDC systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 10-ampere fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly.

Refer to Procedure 019-198 (Fuse, In-Line Harness) in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Repair

Replace the fuse.

Refer to Procedure 019-198 (Fuse, In-Line Harness) in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal connector to all ECM battery 1 voltage (ECM 3) SUPPLY (+) pins, one at a time, in the 4-pin power ECM connector.
  • Measure the resistance from the negative (-) battery terminal connector to all ECM battery 1 voltage (ECM 3) RETURN pins, one at a time, in the 4-pin power ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the open circuit.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery 1 voltage (ECM 3) pin in the power harness ECM connector to the ECM battery 1 voltage (ECM 3) RETURN pins.

Reference the circuit diagram or wiring diagram for connector identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery 1 voltage (ECM 3) SUPPLY pin in the 4-pin power harness ECM connector to engine block ground.

Reference the circuit diagram or wiring diagram for connector identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to- pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the battery.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ECM battery 1 voltage (ECM 3) SUPPLY (+) pins in the 4-pin power harness ECM connector to all pins in the 50-pin harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short circuit.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Reference the OEM troubleshooting and repair manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the 4-pin power connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Reference the OEM troubleshooting and repair manual.

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Refer to Procedure 013-009 (Battery Cables and Connections) in Section 13 in the Service Manual, QST30, Bulletin 4021539.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +24-VDC (24-VDC systems).

Cranking conditions:

  • At least +12-VDC (24-VDC systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Refer to Procedure 013-009 (Battery Cables and Connections) in Section 13 in the Service Manual, QST30, Bulletin 4021539.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 10-ampere fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly.

Refer to Procedure 019-198 (Fuse, In-Line Harness) in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Repair

Replace the fuse.

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.Refer to Procedure 019-220 (Augat Connector Series) in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness.Refer to Procedure 019-208 (Duetsch&trade; HDP20 and HD30 Connector Series) in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal connector to all ECM battery 1 voltage (ECM2) SUPPLY (+) pins, one at a time, in the 4-pin power ECM connector.
  • Measure the resistance from the negative (-) battery terminal connector to all ECM battery 1 voltage (ECM2) RETURN pins, one at a time, in the 4-pin power ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery 1 voltage (ECM2) pin in the power harness ECM connector to the ECM battery 1 voltage (ECM2) RETURN pins.

Reference the circuit diagram or wiring diagram for connector identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery 1 voltage (ECM2) SUPPLY pin in the 4-pin power harness ECM connector to engine block ground.

Reference the circuit diagram or wiring diagram for connector identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ECM battery 1 voltage (ECM2) SUPPLY (+) pins in the 4-pin power harness ECM connector to all pins in the 50-pin harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the defective section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Reference the OEM troubleshooting and repair manual.

Refer to Procedure 013-009 (Battery Cables and Connections) in Section 13 in the Service Manual, QST30 CM552, Bulletin 4021539.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 inactive
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than +32-VDC for +24-VDC system
 | STEP 2B. Check the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 442 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect all aftermarket devices connectors from the battery 1 voltage circuit connectors
  • Disconnect the 4-pin ECM power harness connector from the ECM connector.

Action

Check the battery voltage.

  • Measure the battery 1 voltage from one of the ECM battery 1 voltage pins in the 4-pin power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery 1 voltage pin in the 4-pin power harness ECM connector.

Less than +32-VDC for +24-VDC system?
YES NO
No Repair

Repair

Install the battery system correctly. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

NOTE: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Reference the OEM troubleshooting and repair manual.

Refer to Procedure 013-001 (Alternator) in Section 13 in the Service Manual, QST30 CM552, Bulletin 4021539.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 442 is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the 4-pin power connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Reference the OEM troubleshooting and repair manual.

Refer to Procedure 013-009 (Battery Cables and Connections) in Section 13 in the Service Manual, QST30 CM552, Bulletin 4021539.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +24-VDC (24-VDC systems).

Cranking conditions:

  • At least +12-VDC (24-VDC systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Refer to Procedure 013-009 (Battery Cables and Connections) in Section 13 in the Service Manual, QST30 CM552, Bulletin 4021539.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 10-ampere fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Repair

Replace the fuse.

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 (Augat Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal connector to all ECM battery 1 voltage (ECM2) SUPPLY (+) pins, one at a time, in the 4-pin power ECM connector.
  • Measure the resistance from the negative (-) battery terminal connector to all ECM battery 1 voltage (ECM2) RETURN pins, one at a time, in the 4-pin power ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery 1 voltage (ECM2) pin in the power harness ECM connector to the ECM battery 1 voltage (ECM2) RETURN pins.

Reference the circuit diagram or wiring diagram for connector identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery 1 voltage (ECM2) SUPPLY pin in the 4-pin power harness ECM connector to engine block ground.

Reference the circuit diagram or wiring diagram for connector identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the battery.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ECM battery 1 voltage (ECM2) SUPPLY (+) pins in the 4-pin power harness ECM connector to all pins in the 50-pin harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the defective section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Reference the OEM troubleshooting and repair manual.

Refer to Procedure 013-009 (Battery Cables and Connections) in Section 13 in the Service Manual, QST30 CM552, Bulletin 4021539.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 488 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Keyswitch in the ON position
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor.

Note: The probe must extend into the air flow and must not touch the intake manifold, except at the probe threads.

  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the intake manifold 1 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

A faulty intake manifold 1 temperature sensor has been detected.

Replace the intake manifold 1 temperature sensor.

Refer to Procedure 019-059 in Section 19.

Follow the Intake Manifold Air Temperature Above Specifications in the Service Manual, QST30 CM552, Bulletin4021539.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 488 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | No action required. |
 | STEP 1A. No action required. | Was the engine shut down before proper cool down?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 611 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - No action required.

Guided Step 1A - No action required.

Conditions

None

Action

Engine Hot Shutdown - Condition Exists.

The engine was shut down with the keyswitch before proper engine cool down, resulting in a load factor above the maximum shutdown threshold.

Was the engine shut down before proper cool down?
YES | NO
No Repair | No Repair

Go to None

Go to None

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 611 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3164596 - male Framatome™ test leadPart Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for engine crankshaft speed sensor supply fault codes. | Fault Code 238 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine crankshaft speed sensor and circuit. |
 | STEP 2A. Inspect the engine crankshaft speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine crankshaft speed sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Engine crankshaft speed sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the engine crankshaft speed sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate engine crankshaft speed sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor engine crankshaft speed sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for engine crankshaft speed sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Fault Code 238

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • While engine idles, monitor the fault code status.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 689 active?

YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19

Guided Step 2 - Check the engine crankshaft speed sensor and circuit.

Guided Step 2A - Inspect the engine crankshaft speed sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine crankshaft speed sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine crankshaft speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or the damaged sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-042 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine crankshaft speed sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine crankshaft speed sensor connector from the engine harness connector
  • Turn keyswitch ON.

Action

Measure the voltage at the sensor connector.

  • Measure the voltage between the engine crankshaft speed 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed RETURN (sensor return 3) pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine crankshaft speed sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed sensor state.

Engine crankshaft speed sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine crankshaft speed sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine crankshaft speed 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed SIGNAL pin at the sensor connector of the engine harness.
  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed sensor state.

Reference the circuit diagram or wiring diagram for connector pin identification.

Engine crankshaft speed sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the engine crankshaft speed sensor.

Conditions

  • Turn keyswitch OFF
  • Remove the engine crankshaft speed sensor from the engine. Refer to Procedure 019-042 in section 19.

Action

Inspect the engine crankshaft speed/position sensor for the following:

  • Damaged sensor tip
  • Physical signs of the engine crankshaft speed sensor touching the speed teeth.

Damaged sensor tip?
YES NO

Repair

Replace the engine crankshaft speed sensor.

Refer to Procedure 019-042 in section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Remove the engine crankshaft speed sensor from the engine. Refer to Procedure 019-042 in section 19.
  • Make sure the engine crankshaft speed sensor is connected to the harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response.

  • Use the ratchet drive side of the socket tool that was used to remove the sensor from the engine. Place it flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.
  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed sensor state.

Engine crankshaft speed sensor state transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Repair

  • Replace the engine crankshaft speed sensor. Refer to Procedure 019-042 in section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate engine crankshaft speed sensor air gap.

Conditions

  • Turn keyswitch ON
  • Install the engine crankshaft speed sensor to the engine. Refer to Procedure 019-042 in Section 19.
  • Connect INSITE™ electronic service tool
  • Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary.

Action

Monitor the engine crankshaft speed sensor state of the engine crankshaft speed sensor for the following:

  • Change of state from high to low or low to high, or the state shows triggered.

Engine crankshaft speed sensor transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Repair

Inspect the flywheel for teeth damage.

Refer to Procedure 016-005 (Flywheel) in Section 16 in the Service ManuaL, QST30, Bulletin 4021539, for inspection of the flywheel.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed sensor state.

Monitor engine crankshaft speed sensor state equals low?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine crankshaft speed 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed sensor SIGNAL pin at the ECM port.

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed sensor state.

Reference the circuit diagram or wiring diagram for connector pin identification.

Monitor engine crankshaft speed sensor state equals high?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Measure the voltage between the engine crankshaft speed 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed RETURN (sensor return 3) pin at the ECM engine harness port.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Repair

  • Call for pre-authorization.
  • Replace the ECM.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gasses. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - female Deutsch™AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 1C. Check the resistance of the OEM power harness and engine harness. | Less than 10 ohms?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness and engine harness. |
 | STEP 3A. Inspect the ECM 4-pin power connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuits. | 10.0 to 15.0-VDC?
 | STEP 3C. Check battery 1 voltage supply for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check battery 1 voltage return for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check battery 1 voltage supply for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or accessory wiring at the positive (+) battery terminal. | Damaged wires?
 | STEP 3G. Check the power supply to ECM wire. | Power supply wire uninterrupted?
 | STEP 3H. Check the power supply circuit. | Less than 5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1117 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the connections.

Tighten the loose connections, and clean the terminals. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Normal conditions:

  • At least +24 VDC (24-VDC systems).

During Cranking:

  • At least +12 VDC (24-VDC systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance of the OEM power harness and engine harness.

Conditions

  • Turn keyswitch off
  • Disconnect the ECM 4-pin power connector
  • Disconnect the positive terminal from the battery.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery 1 voltage SUPPLY pin and the positive (+) battery connector.
  • Measure the resistance between the ECM battery 1 voltage RETURN pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch off.

Action

Verify that the fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for blown fuse.

Conditions

  • Turn keyswitch off.

Action

Check for blown fuse.

  • Inspect the 10-ampere fuse to see if it has blown.

Fuse blown?
YES NO

Repair

Replace the fuse.

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the ECM 4-pin power connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery 1 voltage SUPPLY pin in the ECM 4-pin power connector to engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

10.0 to 15.0-VDC?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check battery supply for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM 4-pin power connector from the ECM
  • Disconnect the battery leads.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from a battery 1 voltage SUPPLY pin in the ECM 4-pin power connector to all other pins in the connector, except the other battery 1 voltage SUPPLY pins.
  • Measure the resistance from a battery 1 voltage RETURN pin in the ECM 4-pin power connector to all other pins in the connector, except the other battery 1 voltage RETURN pins.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check battery 1 voltage return for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM 4-pin power connector from the ECM
  • Disconnect the battery leads.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ECM battery 1 voltage RETURN pin in the ECM 4-pin power connector to all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check battery 1 voltage supply for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM 4-pin power connector from the ECM
  • Disconnect the battery leads.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ECM battery 1 voltage SUPPLY pin in the ECM 4-pin power connector to all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) battery terminal.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) battery terminal.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Reference the OEM troubleshooting and repair manual.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check the power supply to ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the power supply to ECM wire.

Inspect the power supply wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is no solenoids or relays.

Power supply wire uninterrupted?
YES NO
No Repair

Repair

Correct the wiring so the wire is uninterrupted.

Go to 4A

Go to 3H

Guided Step 3H - Check the power supply circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the power supply circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to power supply SIGNAL pin of the 50-pin engine harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the harness. Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1117 is inactive.

Fault Code 1117 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check all fault codes. |
 | STEP 1A. Check for fault code 1357. | Active or inactive counts of Fault Code 1357?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1357 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check all the fault codes.

Guided Step 1A - Check for fault code 1357.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1357?
YES NO

Repair

Fill remote engine oil reservoir to appropriate level.

 No Repair

Appropriate troubleshooting symptom tree

Repair Complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1357 is inactive.

Fault Code 1357 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Appropriate troubleshooting steps

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1383 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1384 active and Fault Code 1383 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1383 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1383 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged intake manifold 1 pressure sensor.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold 1 pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active and Fault Code 1383 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the intake manifold 1 pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring harness for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold 1 pressure sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1383 active?
YES NO

Repair

A damaged intake manifold pressure 1 sensor has been detected.

  • Replace the intake manifold 1 pressure sensor. Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active and Fault Code 1383 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the intake manifold 1 pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM.
  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open intake manifold 1 pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring harness for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1383 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1384 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1383 active and Fault Code 1384 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness control pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1384 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 pressure sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold 1 pressure sensor. Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-061 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the intake manifold 1 pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 1 pressure SIGNAL pin at the intake manifold 1 pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active and Fault Code 1384 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active?
YES NO

Repair

A damaged intake manifold 1 pressure sensor has been detected.

  • Replace the intake manifold 1 pressure sensor.
  • Refer to Procedure 019-061 in Section 19..

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A open or shorted intake manifold 1 pressure SUPPLY (sensor supply 2) circuit has been detected in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open or short.
  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness. Reference the circuit diagram or wiring diagram for all interconnections.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 1 pressure SIGNAL pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • Check the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active and Fault Code 1384 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the intake manifold 1 pressure SIGNAL wire of the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short. Reference the circuit diagram or wiring harness for all engine harness interconnections.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1384 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1385 inactive?
STEP 2. | Check the intake manifold 2 pressure sensor and circuit |
 | STEP 2A. Inspect the intake manifold 2 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1386 active and Fault Code 1385 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault code 1385 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply and voltage return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1385 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 2 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 2 pressure sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold 2 pressure sensor. Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-061 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1386 active and Fault Code 1385 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 2 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring harness for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active?
YES NO

Repair

A damaged intake manifold 2 pressure sensor has been detected.

  • Replace the intake manifold 2 pressure sensor.
  • Refer to Procedure 019-061 in Section 19..

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active and Fault Code 1385 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the intake manifold 2 pressure SIGNAL wire of the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open or short.
  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness. Reference the circuit diagram or wiring diagram for all interconnections.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 2 pressure RETURN (sensor return 2) pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open intake manifold 2 pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short. Reference the circuit diagram or wiring harness for all engine harness interconnections.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1385 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1386 inactive?
STEP 2. | Check the intake manifold 2 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1385 active and Fault Code 1386 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1386 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness control pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1386 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 2 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 2 pressure sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold 2 pressure sensor. Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-061 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 2 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 2 pressure SIGNAL pin at the intake manifold 2 pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active and Fault Code 1386 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active?
YES NO

Repair

A damaged intake manifold 2 pressure sensor has been detected.

  • Replace the intake manifold 2 pressure sensor.
  • Refer to Procedure 019-061 in Section 19..

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 2 pressure RETURN (sensor return 2) pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A open SUPPLY circuit has been detected in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open or short.
  • Reference the circuit diagram or wiring diagram for all engine harness interconnections.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness. Reference the circuit diagram or wiring diagram for all interconnections.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 2 pressure SIGNAL pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • Check the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active and Fault Code 1386 inactive?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the fault codes.

Fault Code 1386 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the intake manifold 2 pressure SIGNAL wire of the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short. Reference the circuit diagram or wiring harness for all engine harness interconnections.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1386 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Disable and clear the fault codes. |
 | STEP 1A. Disable and clear the fault codes. | All fault codes cleared?

Guided Step 1 - Disable and clear the fault codes.

Guided Step 1A - Disable and clear the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

All fault codes cleared?
YES | NO
No Repair | No Repair

No repair

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test leadPart Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator output frequency adjust potentiometer. |
 | STEP 1A. Inspect the generator output frequency adjust potentiometer assembly for damage to pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 5k ohms?
 | STEP 1C. Check the resistance range of the generator output frequency adjust potentiometer. | Resistance varies?
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1411 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the generator output frequency adjust potentiometer.

Guided Step 1A - Inspect the generator output frequency adjust potentiometer assembly for damage to pins.

Conditions

  • Run/Stop switch in the Stop position.

Action

Inspect the generator output frequency adjust potentiometer assembly for damage to pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the generator output frequency adjust potentiometer. Reference the OEM troubleshooting and repair manual.
  • Repair the generator interface harness. Refer to Procedure s 019-213 in Section 19. Refer to Procedure Also, 019-199 in Section 19.
No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Run/stop switch in the stop position.
  • Disconnect the generator output frequency adjust potentiometer connector from the harness connector.

Action

Check the generator output frequency adjust potentiometer resistance.

  • Measure the resistance between the generator output frequency adjust potentiometer pins using a multimeter.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5k ohms?
YES NO
No Repair

Repair

Replace the generator output frequency adjust potentiometer. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the resistance range of the generator output frequency adjust potentiometer.

Conditions

  • Run/Stop switch in the STOP position.
  • Disconnect the generator output frequency adjust potentiometer connector from the harness connector.
  • Adjust the generator output frequency adjust potentiometer throughout its entire range.

Action

Check the resistance range of the generator output frequency adjust potentiometer.

  • Measure the resistance between the generator output frequency adjust potentiometer pins using a multimeter.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance varies?
YES NO
No Repair

Repair

Replace the generator output frequency adjust potentiometer. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 2 - Check the generator interface harness.

Guided Step 2A - Inspect the generator interface harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the STOP position.
  • Disconnect the generator interface harness from the ECM.

Action

Inspect the generator interface harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19. Refer to Procedure Also, 019-199 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Run/Stop switch in the STOP position.
  • Disconnect the generator interface harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19. Refer to Procedure Also, 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Run/Stop switch in the STOP position.
  • Disconnect the generator interface harness from the ECM.
  • Disconnect the bulb from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

Repair the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19. Refer to Procedure Also, 019-199 in Section 19.

Repair

A pin-to-pin short circuit on the optional gain adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

  • Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes

  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Code 1411 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test leadPart Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1412 inactive?
STEP 2. | Check the engine harness and OEM harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 1412 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM 50-pin and 60-pin connectors.
  • Disconnect the OEM harness connectors from the engine harness connectors.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or OEM harness connector or ECM connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness or the ECM.
  • Check all harnesses connected in series. Refer to Procedure 019-043 in Section 19. Refer to Procedure Also, 019-199 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine harness connector from the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open optional gain adjust potentiometer RETURN (sensor return 4) circuit has been detected in the engine harness.

  • Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin and 60-pin connector.
  • Disconnect the engine harness connector from the 31-pin connector.

Action

Check for pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the optional gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A malfunction in the generator drive harness or Potentiometer has occurred.

  • Reference the OEM troubleshooting and repair manual for repair instructions.

Repair

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

  • Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1412 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test leadPart Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1418 inactive?
STEP 2. | Check the engine harness and OEM harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 1418 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or ECM connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness, the OEM harness or the ECM.
  • Check all harnesses connected in series. Refer to Procedure 019-043 in Section 19. Refer to Procedure Also, 019-199 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 50-pin connector.
  • Disconnect the engine harness from the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open optional gain adjust potentiometer RETURN (sensor return 4) circuit has been detected in the engine harness.

  • Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-199 (Connector, Butt Splice).

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 50-pin connector.
  • Disconnect the engine harness from the 31-pin connector.

Action

Check for pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A malfunction in the generator drive harness or potentiometer has occurred.

  • Reference the OEM Troubleshooting and Repair Manual for repair instructions.

Repair

A pin-to-pin short circuit on the gain adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

  • Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1418 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1427 inactive?
STEP 2. | Check the engine harness and OEM harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1427 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1427 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or ECM connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness, the OEM harness or the ECM.
  • Check all harnesses connected in series. Refer to Procedure 019-043 in Section 19. Refer to Procedure Also, 019-199 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector overspeed shutdown SIGNAL pin and the OEM harness connector overspeed shutdown SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open overspeed shutdown SIGNAL circuit has been detected in the engine harness.

  • Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-199 (Connector, Butt Splice).

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the overspeed shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

No repair

Repair

A pin-to-pin short circuit on the overspeed shutdown SIGNAL wire has been detected in the engine harness.

  • Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin to short ground

  • Measure the resistance and check for a short circuit between the overspeed shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A malfunction in the generator drive harness or lamp has occurred.

  • Reference the OEM troubleshooting and repair manual.

Repair

A short circuit to ground has been detected in the engine harness.

  • Troubleshoot each of the harness sections to determine which contains the short circuit to ground.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure Also, 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1427 inactive?
YES NO

Repair

No repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for fault codes. |
 | STEP 1A. Check the ECM for fault codes. | Fault Code 1517 and other fault codes are active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1517 is inactive?
 | STEP 2B. Clear the fault code. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes.

Guided Step 1A - Check the ECM for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1517 and other fault codes are active?
YES NO

Repair

Appropriate troubleshooting steps

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1517 is inactive?
YES NO

Repair

No repair.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for fault codes. |
 | STEP 1A. Check the ECM for fault codes. | Fault Code 1518 and other fault codes are active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1518 is inactive?
 | STEP 2B. Clear the fault code. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes.

Guided Step 1A - Check the ECM for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1518 and other fault codes are active?
YES NO

Repair

Appropriate troubleshooting steps

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1518 is inactive?
YES NO

Repair

No repair.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for fault codes. |
 | STEP 1A. Check ECM for fault codes. | Fault Code 1519 and other fault codes are active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1519 is inactive?
 | STEP 2B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes.

Guided Step 1A - Check ECM for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1519 and other fault codes are active?
YES NO

Repair

Appropriate troubleshooting steps

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1519 is inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if alls steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 1597 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 1597. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1597 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1597 active?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 1597.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 1597

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 1597.

Are there less than three counts?
YES NO
No Repair

Repair

  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 2B

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1597 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1847. | Active or inactive counts of Fault Code 1847?
 | STEP 1. 1B | Fault Code 1847 inactive?
 | STEP 1B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1847.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1847.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1847?
YES NO

Repair

  • Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Service Manual, QST30 CM552, Bulletin 4021539.
No Repair

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 1B - Disable the fault code

Conditions

  • Connect the components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1847 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® authorized repair location if all steps have beeb completed and checked again.

Go to 1C

Go to 1A

Guided Step 1C - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

  • Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1891. | Fault Code 1891 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1891 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1891.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1891.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1891 active?
YES NO

Repair

Troubleshoot any additional fault codes. If necessary, change the engine lubricating oil and filter.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to reset the Centinel™ Missed Pulse Counts monitor.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1891 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot ant remaining active fault codes.

Repair complete.

Reference the appropriate troubleshooting steps.


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor Supply Fault Code 2185 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 1979 active and Fault Code 1978 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1978 is active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1978 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 2185 active?
YES | NO
No Repair | No Repair

Reference Fault Code 2185.

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch ON
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damage connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active and Fault Code 1978 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 4) pin and the generator speed/load governing bias RETURN (sensor return 4) pin at the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness connector to the OEM 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 is active?
YES NO

Repair

A malfunction on the generator set has been detected.

Reference the OEM troubleshooting and repair manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin and 60-pin connectors
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damage connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector, OEM harness, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 (Engine Wiring Harness in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias RETURN (sensor return 4) pin and the OEM harness connector generator speed/load governing bias RETURN (sensor return 4) pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open generator speed/load governing bias RETURN (sensor return 1) circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 (Engine Wiring Harness in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted supply circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 (Engine Wiring Harness in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair Complete.

Appropriate troubleshooting steps.


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code Sensor Supply Fault Code 2186 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1978 active and Fault Code 1979 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1979 is active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1979 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1979 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code Sensor Supply Fault Code 2186 active?
YES | NO
No Repair | No Repair

Fault Code 2186

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 4) pin and the generator speed/load governing bias RETURN (sensor return 4) pin at the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 4) pin and the generator speed/load governing bias SIGNAL pin at the OEM 31-pin connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active and Fault Code 1979 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness connector to the OEM 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 is active?
YES NO

Repair

A malfunction on generator set side has been detected.

Reference the OEM troubleshooting and repair manual for the correct procedure.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector and 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias SIGNAL pin and the OEM 31-pin connector generator speed/load governing bias SIGNAL pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open generator speed/load governing bias SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin to ground short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 2 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1984 inactive?
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 2 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 2 temperature sensor.

Note: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 datalink.
  • Compare the intake manifold 2 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Repair

Follow the Intake Manifold Air Temperature Above Specifications symptom tree in Service Manual, QST30, Bulletin 4021539.

Repair

A damaged intake manifold 2 temperature sensor has been detected.

Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-059 (Intake Manifold Air Intake Temperature Sensor) in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1984 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 15 percent of rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine crankshaft speed sensor reading with INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine crankshaft speed sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine crankshaft speed sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine crankshaft speed sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed sensor.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure s 019-042 in Section 19.
  • Refer to Procedure s 019-043 in Section 19.
  • Refer to Procedure s 019-199 in Section 19.
  • Refer to Procedure s 019-218 (Framatom&trade; Connector Series) in Section 19.
No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active fault at low engine rpm.

  • Check for active Fault Code 1992 when the engine is not running above 15 percent rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine to check if the overspeed condition is still present.

  • Test the engine to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1992 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164133 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM, OEM harness, and engine harness. |
 | STEP 2A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit in the unswitched battery supply power harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19

Guided Step 2 - Check the ECM, OEM harness, and engine harness.

Guided Step 2A - Inspect the ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the OEM harness 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the unswitched battery supply power harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the OEM harness 31-pin connector
  • Disconnect the engine power harness connector from the ECM connector.

Action

Check for a short circuit to battery.

  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the engine harness ECM connector and the ECM battery SUPPLY (+) pin or the power harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Repair

A short circuit to the battery has been detected in the OEM harness or engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3164596 - male Framatome™ test leadPart Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 4 and return. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply 4 and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 2186 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2186 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 4 and return.

Guided Step 2A - Inspect the gain adjust potentiometer and droop adjust potentiometer circuit connected to the sensor supply 4 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the harness connectors and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-085 Accelerator Pedal or Lever Position Sensor) in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2186 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Replace the damaged section of harness.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the OEM harness 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the engine harness ECM connector and all other pins in the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the OEM harness 31-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the engine harness ECM connector and the gain adjust potentiometer RETURN (sensor supply 4).

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Repair

A short circuit has been detected in the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire.

Troubleshoot harnesses connected in series to determine which contains the short circuit to ground.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harnesses.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2186 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electric lift pump for engine fuel supply relay. |
 | STEP 1A. Inspect the engine harness connector and fuel control electric lift pump for engine fuel supply relay pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit in the electric lift pump for engine fuel supply relay. | Less than 20 ohms?
 | STEP 1C. Check the electric lift pump for engine fuel supply diagnostic supply voltage and return circuit. | Voltage greater than 18.0-VDC?
 | STEP 1D. Check for an open circuit in the electric lift pump for engine fuel supply return circuit. | Less than 10 ohms?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for an active fault code. | Fault Code 2265 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2265 inactive?
 | STEP 3B. Clear the inactive fault codes. | Fault codes cleared?

Guided Step 1 - Check the electric lift pump for engine fuel supply relay.

Guided Step 1A - Inspect the engine harness connector and fuel control electric lift pump for engine fuel supply relay pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the electric lift pump relay.

Action

Inspect the relay and relay connector pins on the engine harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector pins.

Replace the damaged section of the harness or replace the relay.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit in the electric lift pump for engine fuel supply relay.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the relay.

Action

Check for an open circuit in the relay.

  • Measure the resistance between the relay SIGNAL pin and the relay RETURN pin at the relay.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 20 ohms?
YES NO

Repair

Replace the relay.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the electric lift pump for engine fuel supply diagnostic supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the relay
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine harness connector SUPPLY pin and the engine harness connector RETURN pin at the relay connector of the engine harness.

Voltage greater than 18.0-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 1D

Guided Step 1D - Check for an open circuit in the electric lift pump for engine fuel supply return circuit.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the relay connector from the engine harness connector.

Action

Measure the resistance between the relay RETURN pin and ground.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

Troubleshoot harnesses connected in series to determine which contains the open short.

Reference the circuit diagram or wiring diagram for all harness interconnections and pin identification.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the right bank ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of the harness.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the right bank ECM 50-pin connector
  • Disconnect the lift pump relay from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the SIGNAL pin at the engine harness lift pump relay connector and the fuel lift pump SIGNAL pin at the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contains the open circuit.

Reference the wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the right bank ECM 50-pin connector
  • Disconnect the electric lift pump for engine fuel supply from the relay.

Action

Check for a pin to pin short circuit.

  • Measure the resistance between the lift pump SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short.

Reference the circuit art or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Call for authorization to replace the ECM.

  • Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2265 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electric lift pump for engine fuel supply relay. |
 | STEP 1A. Inspect the engine harness and electric lift pump for engine fuel supply relay pins. | Dirty or damaged pins?
 | STEP 1B. Check the nominal resistance in the electric lift pump for engine fuel supply relay. | Greater than 1k ohms or less than 50 ohms?
 | STEP 1C. Check the fault codes and verify electric lift pump for engine fuel supply condition. | Fault code 2266 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a pin short to ground. | Greater than 100k ohms?
 | STEP 2D. Check for an inactive fault code. | Fault Code 2266 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2266 inactive?
 | STEP 3B. Clear the inactive fault codes. | Fault codes cleared?

Guided Step 1 - Check the electric lift pump for engine fuel supply relay.

Guided Step 1A - Inspect the engine harness and electric lift pump for engine fuel supply relay pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the electric lift pump relay.

Action

Inspect the relay and relay connector pins on the engine harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector pins.

Replace the damaged section of the harness or replace the relay.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the nominal resistance in the electric lift pump for engine fuel supply relay.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electric lift pump for engine fuel supply relay from the engine harness connector.

Action

Check the resistance between the two pins of the relay.

  • Measure the resistance between the two pins of the relay.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 1k ohms or less than 50 ohms?
YES NO

Repair

Replace the relay.

 No Repair

Go to 1C

Go to 3A

Guided Step 1C - Check the fault codes and verify electric lift pump for engine fuel supply condition.

Conditions

  • Turn keyswitch OFF
  • Connect the electric lift pump relay to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2266 inactive?
YES NO

Repair

Removal and installation of the connector corrected the fault.

Repair

  • A damaged electric lift pump for engine fuel supply has been detected.

Replace the electric lift pump relay.

Refer to Procedure 005-045 (Fuel Lift Pump) in Section 5 of the Service Manual QST30, Bulletin 4021539.

Go to 3A

Go to 3A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the right bank ECM 50-pin engine connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of the harness.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the right bank ECM 50-pin engine connector
  • Disconnect the electric lift pump for engine fuel supply from the relay.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the lift pump SIGNAL pin in the engine harness ECM connector and all other pins in the harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short circuit.

  • Reference the wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the right bank ECM 50-pin engine connector
  • Disconnect the electric lift pump for engine fuel supply from the relay.

Action

Check for a pin to ground short.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SUPPLY wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-ground short.

  • Reference the wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2266 inactive?
YES NO

Repair

The removal and installation of the connector corrected the fault.

Repair

Return the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been checked and checked a second time.

Go to 3A

Go to 1A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault code 2266 inactive?
YES NO

Repair

The removal and installation of the connector corrected the fault.

Repair

Return the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been checked and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Clear the fault code. |
 | STEP 1A. Disable the fault code. | Fault Code 2661 inactive?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Clear the fault code.

Guided Step 1A - Disable the fault code.

Conditions

  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2661 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1A

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Clear the fault code. |
 | STEP 1A. Disable the fault code. | Fault Code 2662 inactive?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Clear the fault code.

Guided Step 1A - Disable the fault code.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2662 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1A

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2727 inactive?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect all engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the SAE J1939 data link 2 engine network resistance in the engine harness. | Between 55 and 65 ohms?
 | STEP 2C. Check the SAE J1939 data link 2 engine network terminator resistor. | Between 115 and 125 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2727 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2727 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 60-pin connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the ECM.

  • Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the SAE J1939 data link 2 engine network resistance in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 engine network SUPPLY pin and the SAE J1939 data link 2 engine network RETURN pin in the ECM engine harness connector.
  • Reference the circuit diagram or wiring diagram for connector pin for identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 55 and 65 ohms?
YES NO

Repair

The SAE J1939 data link 2 engine network resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed on the ECMs.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the SAE J1939 data link 2 engine network terminator resistor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the SAE J1939 data link 2 engine network terminator resistor from the engine harness.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 engine network SUPPLY pin and the SAE J1939 data link 2 engine network RETURN pin in the ECM engine harness connector.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistence measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 115 and 125 ohms?
YES NO

Repair

A damaged SAE J1939 data link 2 engine network terminator resistor had been detected.

Replace the SAE J1939 data link 2 engine network terminator resistor.

Contact a Cummins® Authorized Repair Location for SAE1939 data link 2 engine terminator resistor replacement.

Repair

An open or short engine SAE J1939 data link 2 circuit or a damaged internal terminator resistor has been detected in the harnesses connected in series.

  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2727 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Dec-2012


INDEX
60-fc113.htm

60-t05-113.htm

60-fc114.htm

60-t05-114.htm

60-fc115.htm

60-t05-115.htm

60-fc121.htm

60-t05-121.htm

60-fc135.htm

60-t05-135.htm

60-fc141.htm

60-t05-141.htm

60-fc143.htm

60-t05-143.htm

60-fc144.htm

60-t05-144.htm

60-fc145.htm

60-t05-145.htm

60-fc146.htm

60-t05-146.htm

60-fc151.htm

60-t05-151.htm

60-fc153.htm

60-t05-153.htm

60-fc154.htm

60-t05-154.htm

60-fc155.htm

60-t05-155.htm

60-fc156.htm

60-t05-156.htm

60-fc157.htm

60-t05-157.htm

60-fc158.htm

60-t05-158.htm

60-fc166.htm

60-t05-166.htm

60-fc167.htm

60-t05-167.htm

94-fc171.htm

60-fc172.htm

60-t05-172.htm

60-fc173.htm

60-t05-173.htm

01-fc174.htm

01-t05-174.htm

60-fc184.htm

60-t05-184.htm

60-fc185.htm

60-t05-185.htm

60-fc187.htm

60-t05-187.htm

60-fc195.htm

60-t05-195.htm

60-fc196.htm

60-t05-196.htm

60-fc197.htm

60-t05-197.htm

60-fc212.htm

60-t05-212.htm

60-fc213.htm

60-t05-213.htm

60-fc214.htm

60-t05-214.htm

60-fc221.htm

60-t05-221.htm

60-fc222.htm

60-t05-222.htm

60-fc223.htm

60-t05-223.htm

60-fc224.htm

60-t05-224.htm

60-fc227.htm

60-t05-227.htm

60-fc228.htm

60-t05-228.htm

60-fc231.htm

60-t05-231.htm

60-fc232.htm

60-t05-232.htm

60-fc234.htm

60-fc234-ecm1.htm

60-t05-234-ecm1.htm

60-fc234-ecm2.htm

60-t05-234-ecm2.htm

60-fc235.htm

60-t05-235.htm

60-fc238.htm

60-t05-238.htm

60-fc254.htm

60-t05-254.htm

60-fc285.htm

60-t05-285.htm

60-fc286.htm

60-t05-286.htm

60-fc342.htm

60-fc342-ecm1.htm

60-t05-342-ecm1.htm

60-fc342-ecm2.htm

60-t05-342-ecm2.htm

60-fc343.htm

60-t05-343.htm

60-fc346.htm

60-t05-346.htm

60-fc352.htm

60-t05-352.htm

60-fc386.htm

60-t05-386.htm

60-fc415.htm

60-t05-415.htm

60-fc421.htm

60-t05-421.htm

60-fc423.htm

60-t05-423.htm

60-fc426.htm

60-t05-426.htm

60-fc441.htm

60-fc441-ecm1.htm

60-t05-441-ecm1.htm

60-fc441-ecm2.htm

60-t05-441-ecm2.htm

60-fc442.htm

60-fc442-ecm1.htm

60-t05-442-ecm1.htm

60-fc442-ecm2.htm

60-t05-442-ecm2.htm

60-fc488.htm

60-t05-488.htm

60-fc611.htm

60-t05-611.htm

60-fc689.htm

60-t05-689.htm

60-fc1117.htm

60-t05-1117.htm

60-fc1357.htm

60-t05-1357.htm

60-fc1383.htm

60-t05-1383.htm

60-fc1384.htm

60-t05-1384.htm

60-fc1385.htm

60-t05-1385.htm

60-fc1386.htm

60-t05-1386.htm

60-fc1387.htm

60-t05-1387.htm

60-fc1411.htm

60-t05-1411.htm

60-fc1412.htm

60-t05-1412.htm

60-fc1418.htm

60-t05-1418.htm

60-fc1427.htm

60-t05-1427.htm

60-fc1517.htm

60-t05-1517.htm

60-fc1518.htm

60-t05-1518.htm

60-fc1519.htm

60-t05-1519.htm

60-fc1597.htm

60-t05-1597.htm

60-fc1847.htm

60-t05-1847.htm

60-fc1891.htm

60-t05-1891.htm

60-fc1978.htm

60-t05-1978.htm

60-fc1979.htm

60-t05-1979.htm

60-fc1984.htm

60-t05-1984.htm

60-fc1992.htm

60-t05-1992.htm

60-fc2185.htm

60-t05-2185.htm

60-fc2186.htm

60-t05-2186.htm

60-fc2265.htm

60-t05-2265.htm

60-fc2266.htm

60-t05-2266.htm

60-fc2661.htm

60-t05-2661.htm

60-fc2662.htm

60-t05-2662.htm

60-fc2727.htm

60-t05-2727.htm