KTA38GC CM558

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Speed Sensor (Flywheel) Circuit

FAULT CODE 121

Engine Speed Sensor (Flywheel) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Yellow SRT: | Invalid engine speed signal detected on the engine speed sensor signal pins at the ECM connector. | Engine can die. Engine will not start.
Engine Speed Sensor (Flywheel) Circuit

Circuit Description

The engine speed sensor monitors the engine position and speed, then passes this information to the ECM through the engine harness.

Component Location

The engine speed sensor is located on the flywheel housing on the left side of the engine.

Shop Talk

The engine speed sensor is a magnetic sensor and senses the raised material on the back of the camshaft gear to determine engine position and speed.

Refer to Troubleshooting Fault Code t05-121

Last Modified: 19-Dec-2012
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No engine protection for intake manifold 1 air temperature.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for intake manifold 1 air temperature.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154


Intake Manifold 1 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Engine is shutdown.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the Intake Manifold 1 Pressure/Temperature Sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code t05-155


Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 156

Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 156 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold air temperature sensor pin at the ECM. | No engine protection for intake manifold 2 temperature.
Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left rear intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-156


Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 157

Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 157 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source | No engine protection for intake manifold 2 temperature.
Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left rear intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-157


Intake Manifold 2 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 158

Intake Manifold 2 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 158 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 2 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Engine is shutdown.
Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left rear intake manifold housing (combination sensor with absolute pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code t05-158


Intake Manifold 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 159

Intake Manifold 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 159 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold air temperature sensor pin at the ECM. | No engine protection for intake manifold 3 temperature.
Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the right front intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-159


Intake Manifold 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 161

Intake Manifold 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 161 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for intake manifold 3 temperature.
Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the right front intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-161


Intake Manifold 3 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 162

Intake Manifold 3 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 162 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 3 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Engine is shutdown.
Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The ECM uses the Intake Manifold Pressure/Temperature Sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the right front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code t05-162


Intake Manifold 4 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 163

Intake Manifold 4 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 163 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 4 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold air temperature sensor pin at the ECM. | No engine protection for intake manifold 4 temperature.
Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the right rear intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-163


Intake Manifold 4 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 164

Intake Manifold 4 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 164 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 4 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for intake manifold 4 temperature.
Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the right rear intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | ETemperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-164.

Last Modified: 30-Sep-2013


Intake Manifold 4 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 165

Intake Manifold 4 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 165 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 4 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Engine is shutdown.
Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the right rear intake manifold housing (combination sensor with absolute pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | ETemperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code t05-165.

Last Modified: 30-Sep-2013


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 3510 FMI: 4 LAMP: Yellow SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 3 and intake manifold 4 temperature sensors and any optional OEM sensors.

Component Location

The sensor supply voltage 2 circuit is contained in the wiring harness.

Shop Talk

The voltage supply on the KTA38 GC engine is broken up into 1 and 2.

Refer to Troubleshooting Fault Code t05-187.

Last Modified: 30-Sep-2013


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: 232 SPN: 3510 FMI: 3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on sensor supply number 2 circuit. | Possible reduced engine performance, shutdown, or loss of engine protection.
Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 3 and intake manifold 4 temperature sensors and any optional OEM sensors.

Component Location

The sensor supply voltage 2 circuit is contained in the wiring harness.

Shop Talk

The voltage supply on the KTA38 GC engine is broken up into 1 and 2.

Refer to Troubleshooting Fault Code t05-227.

Last Modified: 30-Sep-2013


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Engine is shutdown.
Crankshaft Speed Sensors Circuit

Circuit Description

The crankshaft (primary) engine speed sensor provides engine speed information to the engine control module (ECM) through the engine harness.

Component Location

The crankshaft speed sensor is located on the flywheel housing on the left side of the engine under the filter bracket.

Shop Talk

Possible causes of this fault code include:

  • Engine governor damage
  • Tampering of the speed sensors

Make sure the correct operation conditions are followed when operating the engine as described in the operation and maintenance manual. To check for valid overspeed, check the fault code snapshot information for the speed reached. This fault will activate at 1980 rpm.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 30-Sep-2013


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on sensor supply voltage 12-VDC (3). | None on engine performance.
Sensor Supply 3 Circuit

Circuit Description

This voltage supply is not being used; however, it is still being monitored by the electronic control module (ECM).

Component Location

There are no wires or components attached to sensor supply 3.

Shop Talk

This is a +14 volt supply that is monitored by the ECM. This fault commonly means there is a voltage supply issue or an internal power issue with the ECM.

Refer to Troubleshooting Fault Code t05-238


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on sensor supply voltage 12-VDC (3). | None on engine performance.
Sensor Supply 3 Circuit

Circuit Description

This voltage supply is not being used; however, it is still being monitored by the electronic control module (ECM).

Component Location

There are no wires or components attached to sensor supply 3.

Shop Talk

This is a +14 volt supply that is monitored by the ECM. This fault commonly means there is a voltage supply issue or an internal power issue with the ECM.

Refer to Troubleshooting Fault Code t05-239


Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 244

Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 244 PID: S238 SPN: 623 FMI: 4 LAMP: Amber SRT: 00-313 | Voltage Below Normal or Shorted to Low Source - Short to ground detected on diagnostic lamp pin 31 of the ECM connector. | Red lamp will light without fault code (always lit).
Red Stop Lamp Circuit

Circuit Description

The Electronic Control Module (ECM) uses the diagnostic lamp to flash out active fault codes.

Component Location

The diagnostic lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel.

Shop Talk

Proper diagnostic lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-244


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4 LAMP: Red SRT: | Voltage Below Normal or Shorted to Low Source - Low voltage detected at the signal RETURN pin of the fuel control valve. | Engine is shut down and engine will not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection.

The fuel shutoff valve is often connected as part of the OEM wiring. Make sure to check the terminal connections at the valve.

Refer to Troubleshooting Fault Code t05-254


Electronic Fuel Injection Control Valve - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 277

Electronic Fuel Injection Control Valve - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: SPN: 633 FMI: 7 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment | Possible reduced engine performance or shutdown.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing in the rear of the engine, just after the secondary fuel pressure regulator. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Electronic fuel control valve high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve with low internal resistance
  • Electronic fuel control valve or engine harness that has shorted to ground
  • The electronic control valve being physically stuck or unable to move freely.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty.

Refer to Troubleshooting Fault Code t05-277


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: 254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. | No effect on engine performance.
ECM

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-343


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: 253 SPN: 630 FMI: 12 LAMP: Yellow SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. | No effect on engine performance.
ECM Power-down Error

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can be caused by an internal ECM problem. This can also be caused if battery power is disconnected before power-down sequence is completed. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-346


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: 232 SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance.
Sensor Supply Voltage 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor.

Component Location

The sensor supply voltage 5 Volt (1) circuit is contained in the wiring harness.

Shop Talk

The voltage supply for the KTA38GC engine is broken up into 1, 2, and 3.

Refer to Troubleshooting Fault Code t05-352


Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 354

Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: P106 SPN: 3563 FMI: 3 LAMP: Amber SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the sensor signal pin at the ECM. | Possible reduced engine performance or shutdown, no engine protection for intake manifold pressure 1.
Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The ECM uses the intake manifold 1 pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the KTA38 GC engines are absolute sensors.

Refer to Troubleshooting Fault Code t05-354


Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 355

Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: 3563 FMI: 4 LAMP: Amber SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage (short to ground) detected on the sensor signal pin at the ECM. | Possible reduced engine performance or shutdown, no engine protection for intake manifold pressure 1.
Intake Manifold Pressure Sensor 1 Circuit

Circuit Description

The ECM uses the intake manifold 1 pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the KTA38 GC engines are absolute sensors.

Refer to Troubleshooting Fault Code t05-355


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on sensor supply number 1 circuit. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 1

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor.

Component Location

The sensor supply voltage 5 Volt (1) circuit is contained in the engine wiring harness.

Shop Talk

The voltage supply for the KTA38 GC engines is broken up into 1, 2, and 3.

Refer to Troubleshooting Fault Code t05-386


SAE J1939 Datalink - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

SAE J1939 Datalink - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Datalink - Data Erratic, Intermittent, or Incorrect | No effect on engine performance, electronic service tool or other datalink devices can not communicate with the ECM.
SAE J1939 Datalink Circuit

Circuit Description

The SAE J1939 datalink is a public datalink that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for component location or the wiring diagram for the datalink location.

Shop Talk

The SAE J1939 datalink is a network datalink on which each ECM is attached via a network stub connection. Be sure that the electronic service tool is set up for J1939 communications (if applicable) when using this datalink.

Refer to Troubleshooting Fault Code t05-426


Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | ECM voltage supply approaching a level at which unpredictable operation will occur. Engine will possibly be hard to start.
Battery 1 Voltage Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in a service panel which is located in the middle of the left bank wiring harness. The service panel in normally not field accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Refer to Troubleshooting Fault Code t05-441


Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | ECM damage will occur. Possible damage to all other electronic components.
Battery 1 Voltage Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in a service panel which is located in the middle of the left bank wiring harness. The service panel in normally not field accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Refer to Troubleshooting Fault Code t05-442


Battery 2 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P168 SPN: 444 FMI: 18 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine is shutdown.
Unswitched Battery Supply Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in a service panel which is located in the middle of the left bank wiring harness. The service panel in normally not field accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Refer to Troubleshooting Fault Code t05-477


Battery 2 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P168 SPN: 444 FMI: 16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | ECM damage will occur.
Unswitched Battery Supply Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in a service panel which is located in the middle of the left bank wiring harness. The service panel in normally not field accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Refer to Troubleshooting Fault Code t05-478


Intake Manifold 1 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 16 LAMP: None SRT: | Intake Manifold 1 Temperature Sensor Circuit - Data Valid but Above Normal Operational Range - Moderately Severe Level. High intake manifold temperature warning. | Possible reduced engine performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold 1 pressure/temperature sensor input to determine the temperature of the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the intake manifold housing (combination sensor with absolute pressure) on the left front side of the engine.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-488


Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 512

Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the ECM. | No effect on engine performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The governor is a self-controlling system that receives no input from the ECM. Throttle position is transmitted from the governor to the ECM in order for it to be displayed on the Electronic Engine Display.

Component Location

The throttle actuator is located on the top front of the engine after the turbochargers and before the charge air aftercoolers.

Shop Talk

The fault will light if the throttle actuator shorts to a high source on the throttle position signal circuits. The governor fault lamp (if installed) can be lit as well.

Refer to Troubleshooting Fault Code t05-512


Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 513

Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 SPN: 51 FMI: 4 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the ECM. | No effect on engine performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The governor is a self-controlling system that receives no input from the ECM. Throttle position is transmitted from the governor to the ECM in order for it to be displayed on the Electronic Engine Display.

Component Location

The throttle actuator is located on the top front of the engine after the turbochargers and before the charge air aftercoolers.

Shop Talk

The fault will light if the throttle actuator shorts to a low source on the throttle position signal circuits. The governor fault lamp (if installed) can be lit as well.

Refer to Troubleshooting Fault Code t05-513


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/ Position Sensor

Circuit Description

The ECM provides a 5-VDC supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor while the engine is running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code:

  • Open or short circuit of the +5-VDC SUPPLY, SIGNAL, or RETURN wire in the engine harness
  • Damaged or malfunctioning engine speed sensor.
Refer to Troubleshooting Fault Code 689.

Last Modified: 03-Sep-2014


ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Warning SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source | No effect on engine performance.
CM558

Circuit Description

The CM558 contains an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-697


Heated Oxygen Sensor - Data Erratic,F Intermittent, or Incorrect

FAULT CODE 752

Heated Oxygen Sensor - Data Erratic,F Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 752 PID: S065 SPN: 724 FMI: 2 LAMP: Amber SRT: | Heated Oxygen Sensor - Data Erratic, Intermittent, or Incorrect. The sensed air fuel ratio does not match the desired air fuel ratio. | Possible reduced engine performance. (lean burn applications only)
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

This fault is not typically caused by a failed heated oxygen sensor, but is a result of the engine running very lean or very rich. To determine if the engine is rich or lean, monitor the heated oxygen sensor compensation with INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-752


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: SPN: 105 FMI: 10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change | Engine is shutdown.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the left bank front air intake manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This feature provides protection for the engine when a rapid increase in intake manifold temperature occurs. Intake manifold temperature rapid rise monitors the change in the intake manifold 1 temperature sensor over a period of time and then logs a fault and requests a derate or shut down due to excessive temperature change.

Possible causes of this fault include:

  • Restricted air flow through the charge air cooler
  • LTA cooling circuit temperature too high
  • Damaged valves
  • An intake manifold overpressure event
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-783


Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1776

Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1776 PID: SPN: 2634 FMI: 3 LAMP: Amber SRT: | Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Short to ground detected on power relay driver circuit pin 36 of the ECM connector B. | Engine will possibly not start or be hard to start.
Power Relay Driver Circuit

Circuit Description

The ECM uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit.

Component Location

The power relay driver circuit is located in the engine harness.

Shop Talk

The power relay driver circuit can be used by the OEM control panel, so issues within the panel can activate this fault code.

Refer to Troubleshooting Fault Code t05-1776


Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1858

Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1858 PID: SPN: 3217 FMI: 3 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal, or Shorted to High Source. | Possible reduced engine performance. (Stoichiometric applications only)
Aftertreatment Inlet Oxygen Concentration Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment inlet oxygen concentration sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The aftertreatment inlet oxygen concentration sensor is used to correct the fuel composition that is used by the engine. The aftertreatment inlet oxygen concentration sensor only affects the closed-loop operation of the engine.

This aftertreatment inlet oxygen concentration sensor is used on the stoichiometric engines only. It is a switching sensor designed to keep the engine at a nominal value, switching above or below the value, depending on if the engine is running richer or leaner than needed. Thus, millivolt readings from this aftertreatment inlet oxygen concentration sensor will constantly alternate between a high and low value.

Refer to Troubleshooting Fault Code t05-1858


Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1859

Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1859 PID: SPN: 3217 FMI: 4 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance. (Stoichiometric applications only)
Aftertreatment Inlet Oxygen Concentration Sensor Circuit

Circuit Description

The ECM uses this aftertreatment inlet oxygen concentration sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment inlet oxygen concentration sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The aftertreatment inlet oxygen concentration sensor is used to correct the fuel composition that is used by the engine. The aftertreatment inlet oxygen concentration sensor only affects the closed-loop operation of the engine.

This aftertreatment inlet oxygen concentration sensor is used on the stoichiometric engines only. It is a switching sensor designed to keep the engine at a nominal value, switching above or below the value, depending on if the engine is running richer or leaner than needed. Thus, millivolt readings from this aftertreatment inlet oxygen concentration sensor will constantly alternate between a high and low value.

Refer to Troubleshooting Fault Code t05-1859


Aftertreatment Inlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1861

Aftertreatment Inlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1861 PID: S065 SPN: 3217 FMI: 2 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect. The sensed air fuel ratio does not match the desired air fuel ratio. | Possible reduced engine performance. (Stoichiometric engines only)
Aftertreatment Inlet Oxygen Concentration Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The aftertreatment inlet oxygen concentration sensor is located in the exhaust plumbing , after the catalyst.

Shop Talk

This fault is not typically caused by a failed oxygen sensor, but is a result of the engine running very lean or very rich. To determine if the engine is rich or lean, monitor the oxygen sensor compensation in INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-1861


Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1862

Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1862 PID: SPN: 3227 FMI: 3 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal, or Shorted to High Source. | Possible reduced engine performance. (Stoichiometric applications only)
Aftertreatment Outlet Oxygen Concentration Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment outlet oxygen concentration sensor is located in the exhaust plumbing, after the catalyst.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed-loop operation of the engine.

This sensor is used on the stoichiometric engines only and is a customer option. It is used to read the oxygen content of the exhaust, after it has gone through the catalyst, to confirm that the stoichiometric engine settings are correct for creating the proper catalyst reaction. Unlike the aftertreatment outlet oxygen concentration switching sensor that is before the catalyst in the exhaust collector, this sensor in a linear sensor that gives a constant millivolt reading.

Refer to Troubleshooting Fault Code t05-1862


Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1863

Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1863 PID: SPN: 3227 FMI: 4 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance. (Stoichiometric applications only)
Aftertreatment Outlet Oxygen Concentration Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment outlet oxygen concentration sensor is located in the exhaust plumbing, after the catalyst.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed-loop operation of the engine.

This sensor is used on the stoichiometric engines only and is a customer option. It is used to read the oxygen content of the exhaust, after it has gone through the catalyst, to confirm that the stoichiometric engine settings are correct for creating the proper catalyst reaction. Unlike the aftertreatment outlet oxygen concentration switching sensor that is before the catalyst in the exhaust collector, this sensor in a linear sensor that gives a constant millivolt reading.

Refer to Troubleshooting Fault Code t05-1863


Aftertreatment Outlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1864

Aftertreatment Outlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1864 PID: S065 SPN: 3227 FMI: 2 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect. The sensed air fuel ratio does not match the desired air fuel ratio. | Possible reduced engine performance. (Stoichiometric engines only)
Aftertreatment Inlet Oxygen Concentration Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The aftertreatment inlet oxygen concentration sensor is located in the exhaust plumbing, after the catalyst.

Shop Talk

This sensor is a customer option.

This fault is not typically caused by a failed oxygen sensor, but is a result of the engine running very lean or very rich. To determine if the engine is rich or lean, monitor the oxygen sensor compensation in INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-1864


Intake Manifold 2 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1984

Intake Manifold 2 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1984 PID: SPN: 1131 FMI: 16 LAMP: Amber SRT: | Intake Manifold 2 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. Intake manifold 2 temperature above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold 2 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 2 temperature sensor is located in the front right air intake manifold.

Shop Talk

The intake manifold 2 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature
  • An intake manifold overpressure event.
Refer to Troubleshooting Fault Code t05-1984


Intake Manifold 3 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1985

Intake Manifold 3 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1985 PID: SPN: 1132 FMI: 16 LAMP: Amber SRT: | Intake Manifold 3 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. Intake manifold 3 temperature above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The intake manifold 3 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 3 temperature sensor is located in the front right air intake manifold.

Shop Talk

The intake manifold 3 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature
  • An intake manifold overpressure event.
Refer to Troubleshooting Fault Code t05-1985


Intake Manifold 4 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1986

Intake Manifold 4 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1986 PID: SPN: 1133 FMI: 16 LAMP: Amber SRT: | Intake Manifold 4 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. Intake manifold 4 temperature above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The intake manifold 4 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 4 temperature sensor is located in the front right air intake manifold.

Shop Talk

The intake manifold 4 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature
  • An intake manifold overpressure event.
Refer to Troubleshooting Fault Code t05-1986


Intake Manifold 2 Temperature - Abnormal Rate of Change

FAULT CODE 2157

Intake Manifold 2 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2157 PID: SPN: 1131 FMI: 10 LAMP: Red SRT: | Intake Manifold 2 Temperature - Abnormal Rate of Change | Engine is shutdown.
Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold 2 temperature sensor monitors intake manifold air temperature and passes information to the ECMs through the engine harness.

Component Location

The intake manifold 2 temperature sensor is located in the right-bank front air intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section i for a detailed component location view.

Shop Talk

The intake manifold 2 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

This feature provides protection for the valves and turbocharger when a rapid increase in intake manifold temperature occurs. Intake manifold 2 temperature sensor rapid rise monitors rapid rise in and change in intake manifold 2 temperature over a period of time and then logs a fault and requests a derate or shutdown because of excessive temperature change.

Possible causes of this fault include:

  • Restricted air flow through the air intake circuit
  • LTA cooling circuit temperature too high
  • Damaged valves
  • Intake manifold overpressure event
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2157


Intake Manifold 3 Temperature - Abnormal Rate of Change

FAULT CODE 2158

Intake Manifold 3 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2158 PID: SPN: 1132 FMI: 10 LAMP: Red SRT: | Intake Manifold 3 Temperature - Abnormal Rate of Change. | Engine is shutdown.
Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The intake manifold 3 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 3 temperature sensor is located in the front right air intake manifold.

Shop Talk

The intake manifold 3 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature
  • An intake manifold overpressure event.
Refer to Troubleshooting Fault Code t05-2158


Intake Manifold 4 Temperature - Abnormal Rate of Change

FAULT CODE 2159

Intake Manifold 4 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2159 PID: SPN: 1133 FMI: 10 LAMP: Red SRT: | Intake Manifold 4 Temperature - Abnormal Rate of Change. | Engine is shutdown.
Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The intake manifold 4 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 4 temperature sensor is located in the front right air intake manifold.

Shop Talk

The intake manifold 4 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature
  • An intake manifold overpressure event.
Refer to Troubleshooting Fault Code t05-2159


Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2188

Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2188 PID: SPN: 724 FMI: 3 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source. Open circuit detected on the heater return pin at the ECM or no heater supply voltage. | Possible reduced engine performance. (lean burn applications only)
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code t05-2188


Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2192

Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2192 PID: SPN: 724 FMI: 4 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Heater voltage to heated oxygen sensor low. | Possible reduced engine performance. (lean burn applications only)
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

Refer to Troubleshooting Fault Code t05-2192


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: SPN: 630 FMI: 31 LAMP: Amber SRT: | Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists. Internal ECM error. | Possible engine shutdown, loss of performance or engine will possibly not start.
ECM

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-2217


Heated Oxygen Sensor Circuit - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2219

Heated Oxygen Sensor Circuit - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2219 PID: S65 SPN: 724 FMI: 16 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Data Valid but Above Normal Operational Range - Moderately Severe Level. The measured air-to-fuel ratio is greater than the desired calculated air-to-fuel ratio. | Possible reduced engine performance (lean burn applications only).
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

The ECM will read an in-range high fault if the engine is running lean or the heated oxygen sensor or heated oxygen sensor circuit has failed. An exhaust leak can cause this fault by not providing enough back pressure to the heated oxygen sensor. Also, If there are any intake leaks after the throttle actuator the engine can also run lean due to low fuel pressure problems, which can cause this fault to activate. If this troubleshooting tree does not fix the problem, the ECM can be the fault.

Refer to Troubleshooting Fault Code t05-2219


Heated Oxygen Sensor Circuit - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 2221

Heated Oxygen Sensor Circuit - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2221 PID: S65 SPN: 724 FMI: 18 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Data Valid but Below Normal Operational Range - Moderately Severe Level. The measured air-to-fuel ratio is lower than the desired calculated air-to-fuel ratio. | Possible reduced engine performance (lean burn applications only).
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

The ECM will read an in-range low fault if the engine is running rich or the heated oxygen sensor or heated oxygen sensor circuit has failed. Excessive exhaust back pressure can cause this fault by creating a lower partial pressure of oxygen to form at the heated oxygen sensor. If the fuel control valve is stuck open the engine will not burn all the gas that is ingested causing it to run rich. If the heated oxygen sensor heater supply has shorted to ground or has a open circuit, then the sensor will read a lower than normal exhaust oxygen value. Also, if there is an ignition misfire, the unburned fuel will cause the sensor to read a lower than normal exhaust oxygen value.

Refer to Troubleshooting Fault Code t05-2221


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: SPN: 633 FMI: 31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit | Possible reduced engine performance.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Electronic fuel control valve high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve with low internal resistance
  • Electronic fuel control valve or engine harness that has shorted to ground.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty.

  • Ignition System Faults? Yes: See the KTA38GC Electronics Master Repair Manual bulletin 4021665, for instructions on how to troubleshoot the ignition system. Yes: Go to 6A No: Go to 2B
Refer to Troubleshooting Fault Code t05-2311


Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2315

Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2315 PID: SPN: 623 FMI: 3 LAMP: Amber SRT: | Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source. | Red lamp will not illuminate.
Red Stop Lamp Driver Circuit

Circuit Description

The ECM uses the diagnostic lamp to flash out active fault codes.

Component Location

The diagnostic lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel.

Shop Talk

Proper diagnostic lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-2315


Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2316

Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2316 PID: SPN: 624 FMI: 3 LAMP: Amber SRT: | Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source. Short to ground detected on diagnostic lamp pin 31 of the ECM connector. | No effect on performance. Amber lamp will not illuminate.
Amber Warning Lamp Driver Circuit

Circuit Description

The ECM uses the amber warning lamp to inform the operator about active faults on the engine.

Component Location

The lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel.

Shop Talk

Proper lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-2316


Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2317

Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2317 PID: SPN: 624 FMI: 4 LAMP: Amber SRT: | Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source. Short to ground detected on diagnostic lamp pin 31 of the ECM connector. | No effect on performance. Amber lamp will be illuminated constantly.
Amber Warning Lamp Driver Circuit

Circuit Description

The ECM uses the amber warning lamp to inform the operator about active faults on the engine.

Component Location

The lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel.

Shop Talk

Proper lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-2317


ECM Internal Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2544

ECM Internal Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2544 PID: SPN: 1136 FMI: 0 LAMP: SRT: | ECM Internal Temperature - Data Valid but Above Normal Operational Range - Most Severe Level | Engine is shutdown.
Electronic Control Module (ECM)

Circuit Description

The CM558 contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-2544


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | Engine possibly will not start.
Unacknowledged Fault

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location depends on the OEM. Reference the OEM troubleshooting and repair manual for component location.

Shop Talk

This fault code occurs as a result of other fault codes becoming active or inactive. Fault Code 2661 will remain active until reset by the operator. Fault Code 2661 is designed to latch onto other fault codes that have become active or have gone inactive. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

This fault code is generated by red/shutdown lamp faults. Other fault codes need to be corrected before acknowledging this fault code, otherwise this fault code will become active again after a calibrated period of time, if other fault codes are still active.

Refer to Troubleshooting Fault Code t05-2661


Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2797

Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2797 PID: SPN: 520353 FMI: 3 LAMP: Amber SRT: | Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the aftertreatment carburetor inlet gas pressure sensor circuit. | Possible reduced engine performance.
Carburetor Inlet Gas Differential Pressure Sensor

Circuit Description

The ECM provides a 5 volt supply to the carburetor inlet gas differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The carburetor inlet gas differential pressure sensor provides a signal to the ECM on the carburetor inlet gas differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure between the fuel pressure and the inlet air pressure entering the carburetors.

Component Location

The carburetor inlet gas differential pressure sensor is located between the two carburetors on the rear of the engine.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2797


Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2798

Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2798 PID: SPN: 520353 FMI: 4 LAMP: Amber SRT: | Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment carburetor inlet gas pressure sensor circuit. | Possible reduced engine performance.
Carburetor Inlet Gas Differential Pressure Sensor

Circuit Description

The ECM provides a 5 volt supply to the carburetor inlet gas differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The carburetor inlet gas differential pressure sensor provides a signal to the ECM on the carburetor inlet gas differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure between the fuel pressure and the inlet air pressure entering the carburetors.

Component Location

The carburetor inlet gas differential pressure sensor is located between the two carburetors on the rear of the engine.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2798


Engine Fuel Shutoff Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2864

Engine Fuel Shutoff Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2864 PID: SPN: 632 FMI: 3 LAMP: Red SRT: | Engine Fuel Shutoff Valve Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the signal return pin of the fuel control valve. | Loss of engine protection.
Engine Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 100-002 ( Engine Diagrams) in Section E for the component location.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supply and one ground connection.

The fuel shutoff valve is often connected as part of the OEM wiring. Be sure to check terminal connections at the valve.

Refer to Troubleshooting Fault Code t05-2864


Power Relay Driver Diagnostic has detected an error - Condition Exists

FAULT CODE 2865

Power Relay Driver Diagnostic has detected an error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2865 PID: 2634 FMI: 31 LAMP: Amber SRT: | Power Relay Driver Diagnostic has detected an error - Condition Exists | Possible reduced engine performance, engine will possibly not start or be hard to start.
Power Relay Driver Circuit

Circuit Description

The Electronic Control Module (ECM) uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit.

Component Location

The power relay driver circuit is located in the engine harness.

Shop Talk

The power relay driver circuit can be used by the OEM control panel, and issues within the panel can activate this fault code.

Refer to Troubleshooting Fault Code t05-2865


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2866

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2866 PID: SPN: 1422 FMI: 31 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No effect on engine performance.
Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

The electronic fuel control valve communicates its position by varying a resistance internal to the actuator. This resistance is sent to the ECM, which uses the resistance to calculate the valve position as a percentage between 0 and 100.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The electronic fuel control valve is not repairable. So if the valve is determined to be failed after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Refer to Troubleshooting Fault Code t05-2866


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2867

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2867 PID: SPN: 1422 FMI: 4 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No effect on engine performance.
Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

The electronic fuel control valve communicates its position by varying a resistance internal to the actuator. This resistance is sent to the ECM, which uses the resistance to calculate the valve position as a percentage between 0 and 100.

Component Location

The electronic fuel control valve is located with fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The electronic fuel control valve is not repairable. If the valve is determined to be failed after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Refer to Troubleshooting Fault Code t05-2867


Intake Manifold 1 Pressure - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2995

Intake Manifold 1 Pressure - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2995 PID: SPN: 3563 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Pressure - Data Valid but Above Normal Operational Range - Most Severe Level. Intake manifold air pressure signal indicates intake manifold pressure above engine protection critical limit. | Engine is shutdown.
Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature and pressure of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

This fault can be activated by the following issues:

  • Sensor failures
  • Wiring harness failed high
  • Intake manifold overpressure event
  • Malfunction in the control system.
Refer to Troubleshooting Fault Code t05-2995


Intake Manifold 1 Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2996

Intake Manifold 1 Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2996 PID: SPN: 3563 FMI: 16 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. Intake manifold air pressure signal indicates intake manifold pressure above engine protection normal limit. | Possible reduced engine performance.
Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The ECM uses the Intake Manifold Pressure/Temperature Sensor input to determine the temperature and pressure of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

This fault can be activated by the following issues:

  • Sensor failures
  • Wiring harness failed high
  • Malfunction in the control system.
Refer to Troubleshooting Fault Code t05-2996


Heated Oxygen Sensor Circuit - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 2997

Heated Oxygen Sensor Circuit - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2997 PID: SPN: 724 FMI: 1 LAMP: Red SRT: | Heated Oxygen Sensor Circuit - Data Valid but Below Normal Operational Range - Most Severe Level. The measured air-to-fuel ratio is lower than the desired calculated air-to-fuel ratio. | Engine is shut down (lean burn applications only).
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

The ECM will read an out of range low fault if the engine is running rich or the heated oxygen sensor or heated oxygen sensor circuit has failed. This fault can cause engine damage, so the engine will shut down immediately if this fault activates in order to protect the engine. If the fuel control valve is stuck open the engine will not burn all the gas that is ingested causing it to run rich. If the heated oxygen sensor heater supply has shorted to ground or has a open circuit, then the sensor will read a lower than normal exhaust oxygen value.

Also, if there is an ignition misfire, the unburned fuel will cause the sensor to read a lower than normal exhaust oxygen value.

Refer to Troubleshooting Fault Code t05-2997


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 121 active?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the engine harness and engine speed sensor connector pins. | Damaged or dirty pins?
 | STEP 2B. Inspect the sensor for damage. | Damage found?
 | STEP 2C. Read the fault codes. | Fault Code 121 active?
 | STEP 2D. Check the resistance of the sensor. | 1000 to 2000 ohms?
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 3B. Read the fault codes. | Fault Code 121 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine harness and engine position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine position sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damage found?
YES NO

Replace the sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4B

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine speed sensor positive pin to the engine speed sensor negative pin in the engine speed sensor connector.
  • Measure the resistance from the engine speed sensor backup positive pin to the engine speed sensor backup negative pin in the engine speed sensor connector.

1000 to 2000 ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-038 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor
  • Make sure the sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine speed sensor positive pin in the engine speed sensor connector, sensor side, to engine block ground.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine speed sensor connector, sensor side, to engine block ground.

More than 100k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-038 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness sensor connector to the engine speed sensor positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness sensor connector to the engine speed sensor backup positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor negative pin in the engine harness sensor connector to the engine speed sensor negative pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor backup negative pin in the engine harness sensor connector to the engine speed sensor backup negative pin in the engine harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch off
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector to the engine block ground.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector to the engine block ground.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch off
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector 1 to all the pins in engine harness connector 2.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector 1 to all the pins in engine harness connector 2.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | 175 ohms to 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold 1 temperature sensor.

Action

Inspect the engine harness and intake manifold 1 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the intake manifold 1 temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

175 ohms to 274 ohms?
YES NO

Go to the table in Shop Talk for specifications.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Call for pre-authorization. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the temperature RETURN pin and the ECM connector 1 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold 1 temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 active?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the intake manifold air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in engine harness ECM connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 155 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the Intake Manifold 1 Pressure/Temperature Sensor. |
 | STEP 3A. Inspect the Intake Manifold 1 Pressure/Temperature Sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 155 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 155 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°]F?
YES NO

Replace the intake manifold intake pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Intake Manifold 1 Pressure/Temperature Sensor.

Guided Step 3A - Inspect the Intake Manifold 1 Pressure/Temperature Sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Intake Manifold Pressure/Temperature Sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual KTA38 GC CM855, Bulletin 4021642.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 155 is inactive.

Fault Code 155 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 156 inactive?
STEP 2. | Check the intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | 175 ohms to 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 156 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 156 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the intake manifold temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

175 ohms to 274 ohms?
YES NO

Go to the table in Shop Talk for specifications.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the temperature RETURN pin and the ECM connector 1 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 156 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 157 active?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 157 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 157 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 157 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the intake manifold air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in engine harness ECM connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 158 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the Intake Manifold Pressure/Temperature Sensor. |
 | STEP 3A. Inspect the Intake Manifold Pressure/Temperature Sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 158 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 158 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the intake manifold intake pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Intake Manifold Pressure/Temperature Sensor.

Guided Step 3A - Inspect the Intake Manifold Pressure/Temperature Sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Intake Manifold Pressure/Temperature Sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual KTA38 GC CM855, Bulletin 4021642.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 158 is inactive.

Fault Code 158 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 159 inactive?
STEP 2. | Check the intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | 175 ohms to 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 159 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 159 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 159 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the intake manifold temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

175 ohms to 274 ohms?
YES NO

Go to the table in Shop Talk for specifications.

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the temperature RETURN pin and the ECM connector 1 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 159 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 159 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 161 active?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 159 active and Fault Code 161 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 161 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 161 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 161 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 161 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the intake manifold air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 159 active and Fault Code 161 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 161 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in engine harness ECM connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 161 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 161 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 162 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the Intake Manifold Pressure/Temperature Sensor. |
 | STEP 3A. Inspect the Intake Manifold Pressure/Temperature Sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 162 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 162 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 162 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading from INSITE™ electronic service tool to the reading from the probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the Intake Manifold Intake Pressure/Temperature Sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Intake Manifold Pressure/Temperature Sensor.

Guided Step 3A - Inspect the Intake Manifold Pressure/Temperature Sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Intake Manifold Pressure/Temperature Sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 162 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual KTA38 GC CM855, Bulletin 4021642.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 162 is inactive.

Fault Code 162 active?
YES NO

Troubleshooting procedures need to be completed again from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 163 inactive?
STEP 2. | Check the intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | 175 ohms to 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 163 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 163 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 163 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the intake manifold temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

175 ohms to 274 ohms?
YES NO

Go to the table in Shop Talk for specifications.

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the temperature RETURN pin and the ECM connector 1 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 163 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 163 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts


FAULT CODE 164 - Intake Manifold 4 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 164 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 163 active and Fault Code 164 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 164 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 164 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 164 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 164 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the intake manifold air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 163 active and Fault Code 164 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 164 is active?
YES NO

A damaged sensor has been detected.

  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the intake manifold air temperature sensor connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in engine harness ECM connector 1 to ground.

Refer to the circuit diagram or wiring diagram for connector and pin location.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 164 is inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 164 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Oct-2013


FAULT CODE 165 - Intake Manifold 4 Temperature Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 165 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 165 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 165 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 165 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy.

  • Compare the intake manifold temperature sensor reading from INSITE™ electronic service tool to the reading from the probe.

Note: If no temperature measuring device is available, answer NO to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the intake manifold intake pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold intake pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold intake pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 165 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom tree in Section TS in the KTA38GC CM855 Service Manual, Bulletin 4021642.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 165 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Oct-2013


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the intake manifold 3 temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold 4 temperature and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the intake manifold 3 temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Inspect the intake manifold 3 temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A defective sensor has been detected.

Replace the intake manifold 3 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold 4 temperature and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor from the OEM harness.

Action

Inspect the intake manifold 4 temperature sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the intake manifold 4 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harnes connector 1 and connector 2 from the ECM.

Action

Inspect the ECM engine wiring harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the remote accelerator pedal position sensor, mixer inlet pressure sensor, coolant level sensor and coolant pressure/temperature sensor from the engine harness.
  • Make sure all components connected to sensor supply number 2 are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 2 circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the remote accelerator pedal position sensor, mixer inlet pressure sensor, coolant level sensor and coolant pressure/temperature sensor from the engine harness.
  • Make sure all components connected to sensor supply number 2 are disconnected.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply number 2 circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Oct-2013


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the intake manifold 3 temperature and intake manifold 4 temperature sensors from the engine harness.
  • Disconnect all components connected to sensor supply number 2.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 2 circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES NO
No Repair

  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 01-Oct-2013


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2000 rpm, the engine must be shut off immediately or engine damage will occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for governor fault codes. | Did a governor malfunction cause this issue?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an inactive fault code at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed

Guided Step 1A - Check for governor fault codes.

Conditions

  • Turn keyswitch OFF

Action

Check for governor fault codes.

  • Reference the KTA38 GC CM558 Master Repair Manual, Bulletin 4021654, for information on how to check for governor faults.

Did a governor malfunction cause this issue?
YES NO

Reference the KTA38 GC CM558 Master Repair Manual, Bulletin 4021654, for information.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Engine is running
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with INSITE™ electronic service tool.

  • Compare the engine speed reading from INSITE™ electronic service tool to a mechanical tachometer or the panel tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor as outlined in Fault Code 121.

Go to 1C

Troubleshoot Fault Code 121.

Guided Step 1C - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensors.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Ben or broken pins
  • Pushed back or expanded pins
  • Moisture in or on connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged connector pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code at low engine rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Test the engine.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 2B

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 01-Oct-2013


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit. |
 | STEP 2C. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins with electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Make sure all components connected to sensor supply 3 circuit are disconnected.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY number 3 pin in the engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 3 pin in the engine harness ECM connector 1 to all other pins in the engine connector 2.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 3 circuit wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins with electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Make sure all components connected to sensor supply 3 circuit are disconnected.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the sensor SUPPLY voltage number 3 pin in the engine harness ECM connector 1 ground.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply 3 circuit wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins with electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins with electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Make sure all components connected to sensor supply 3 circuit are disconnected.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY number 3 pin in the engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 3 pin in the engine harness ECM connector 1 to all other pins in the engine connector 2.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 3 circuit wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins with electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:Part No. 3822917 - female AMP™/Cannon™ test leadPart No. 3823994 - female Deutsch™ test leadTo reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 244 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniquesRefer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair the OEM harness connector.

Refer to Procedure 019-043 in Section 19.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the 21 pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 19 on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check the OEM control panel and relays.

  • Reference the KTA38GC CM558 Panel System, Master Repair Manual, Bulletin 4021656.

More than 100k ohms?
YES NO
No Repair

  • Reference the KTA38GC CM558 Panel System, Master Repair Manual, Bulletin 4021656.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 3 in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 3 in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let it idle for 1 minute.

Fault Code 244 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the valve supply voltage. | +24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 254 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 254 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE® electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

NOTE: Make sure the engine is not performing a purge cycle when making this measurement.

+24-VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the engine harness connector to the fuel shutoff valve SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness connector to the fuel shutoff valve SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or the engine wiring diagram for the appropriate circuit.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the engine harness connector from the Fuel Shutoff Valve
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine. Reference the circuit diagram or the engine wiring diagram for the appropriate circuit.
  • Use INSITE® electronic service tool to verify the fault codes.

NOTE: Fault Code 255 will become active.

Fault Code 254 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE® electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE® electronic service tool to verify that Fault Code 254 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE® electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE® electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 277 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
 | STEP 2D. Check the butterfly valve. | Debris found or valve difficult to move?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 277 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 277 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 277 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Refer to Procedure 019-049 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-049 in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-049 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the butterfly valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the butterfly valve.

Remove the electronic fuel control valve assembly from the engine fuel supply. Refer to Procedure 019-049 in Section 19.

Inspect the butterfly valve and housing for the following:

  • Debris
  • Mineral buildup
  • Difficult movement of the butterfly valve.

Debris found or valve difficult to move?
YES NO

Remove the blockage and clean the electronic fuel control valve, if possible. If the electronic fuel control valve is damaged or irreparable, replace the entire fuel control valve assembly.Refer to Procedure 019-049 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Reference the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Reference the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Codes 277 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Reference the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve.

Refer to Procedure 019-049 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 277 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check ECM for a short circuit to ground. | More than 100k ohms?
 | STEP 1D. Calibrate the ECM. | ECM calibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to check for fault codes.
  • Recycle the power to the ECM using the keyswitch.

Fault Code 343 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

Go to 1C

Go to 2A

Guided Step 1C - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

ECM calibrated successfully?
YES NO
No Repair

Active fault codes present.

Replace the ECM.

Call for pre-authorization. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 343 is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 346 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check the ECM ground. | More than 100k ohms?
 | STEP 1D. Recalibrate the ECM. | Fault Code 346 active after recalibration?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 346 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Check the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2B

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM
  • Check the OEM connector as a possible source of an intermittent power supply
  • Make certain the power supply to the ECM is constant and not intermittent.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

Go to 1C

Go to 2A

Guided Step 1C - Check the ECM ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Fault Code 346 active after calibration?
YES NO

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 352 inactive?
STEP 2. | Check the sensor and sensor supply circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure/temperature sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure/temperature sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

Go to 2B

Go to 4B

Guided Step 2B - Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pressure/temperature sensor from the engine harness.

Action

Inspect the carburetor inlet gas differential pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the carburetor inlet gas differential pressure sensor. Refer to Procedure 019-457 in Section 19.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM
  • Disconnect the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin to pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 to all pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor supply number 1 pin in the engine harness ECM connector 1 and ground.

More than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the apprporiate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 355 active and Fault Code 354 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 354 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 354 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active and Fault Code 354 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES NO

A damaged sensor has been detected

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the intake manifold pressure sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness to all other pins in the engine connector 1.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness connector 1 to all pins in engine harness ECM connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure sensor 5 Volt SUPPLY pin in engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the intake manifold pressure 5 Volt SUPPLY pin in engine harness connector 1 and all pins in engine harness ECM connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin to pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 354 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 2. | Check the intake manifold pressure 1 sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 354 active and Fault Code 355 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 355 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 355 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold pressure 1 sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure 1 sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake pressure SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 354 active and Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES NO

A damaged sensor has been detected

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins.

Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the intake manifold pressure sensor connector SUPPLY pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin and the intake manifold pressure sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in the connector 1.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector 1 and all pins in connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector 1 and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin to pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Refer to Procedure 019-165 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between +11.5-VDC and +15.0-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Damaged fuse?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between +11.5-VDC and +15.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between +11.5-VDC and +15.0-VDC?
YES NO
No Repair

A damaged battery has been detected.

Replace the defective battery or batteries. Reference the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM and engine harness connectors for the following:

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656, for details on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness service panel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses in the engine harness service panel.

  • Open the service panel by loosening the screw clamps.
  • Inspect the circuit board and locate the glass fuses.
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector 1 unswitched battery SUPPLY pins and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage between +11.5-VDC and +15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4E

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector 1 and the 47 pin OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin to pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Damaged fuse?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between +11.5-VDC and +15.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM and engine harness connectors for the following:

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656, for details on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness service panel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses in the engine harness service panel.

  • Open the service panel by loosening the screw clamps.
  • Inspect the circuit board and locate the glass fuses.
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector 1 unswitched battery SUPPLY pins and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage between +11.5-VDC and +15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4E

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector 1 and the 47 pin OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin to pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 477 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between +11.5-VDC and +15.0-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Damaged fuse?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between +11.5-VDC and +15.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 477 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 477 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between +11.5-VDC and +15.0-VDC?
YES NO
No Repair

A damaged battery has been detected.

Replace the defective battery or batteries. Reference the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM and engine harness connectors for the following:

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656, for details on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness service panel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses in the engine harness service panel.

  • Open the service panel by loosening the screw clamps.
  • Inspect the circuit board and locate the glass fuses.
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector 1 unswitched battery SUPPLY pins and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage between +11.5-VDC and +15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4E

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector 1 and the 47 pin OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin to pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 477 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 478 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Damaged fuse?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between +11.5-VDC and +15.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 478 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 478 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM and engine harness connectors for the following:

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656, for details on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness service panel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses in the engine harness service panel.

  • Open the service panel by loosening the screw clamps.
  • Inspect the circuit board and locate the glass fuses.
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector 1 unswitched battery SUPPLY pins and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage between +11.5-VDC and +15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4E

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector 1 and the 47 pin OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin to pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 478 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 488 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Temperature within 3°C [5°F]?
STEP 3. | Check the intake manifold 1 pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 488 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 488 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading from INSITE™ electronic service tool to the reading from the probe.

Note: If no temperature measuring device is available, answer Yes to this step.

Temperature within 3°C [5°F]?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-099 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the intake manifold 1 pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual KTA38 GC CM855, Bulletin 4021642.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 488 is inactive.

Fault Code 488 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Check for governor faults. | Active governor faults?
 | STEP 2B. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 512 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO

Refer to Procedure 019-362 in Section 19

No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Check for governor faults.

Conditions

  • Keep keyswitch ON.

Action

Check for governor faults.

  • Check if the governor fault light is on. If this light is not installed on the OEM control panel, it can also be found in the Service Access Panel on the left bank wiring harness. Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656, for further details.

Governor fault?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator. Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness.

Repair the damaged pins. Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ICM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Use to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 512 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Check for governor faults. | Active governor faults?
 | STEP 2B. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 513 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO

Refer to Procedure 019-362 in Section 19

No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Check for governor faults.

Conditions

  • Keep keyswitch ON.

Action

Check for governor faults.

  • Check if the governor fault light is on. If this light is not installed on the OEM control panel, it can also be found in the Service Access Panel on the left bank wiring harness. Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656, for further details.

Governor fault?
YES NO

Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator. Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness.

Repair the damaged pins. Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ICM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Use to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 513 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 453, 454, 455, 511, and/or 751 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 752 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 2B. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 3. | Check Base engine components. |
 | STEP 3A. Check for an exhaust leak. | Any exhaust leaks?
 | STEP 3B. Check for an intake restriction. | Is intake restriction below 381 mm H2O [15 in H2O]?
STEP 4. | Check the engine harness and heated oxygen sensor. |
 | STEP 4A. Check the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
 | STEP 4C. Check the heated oxygen sensor heater supply voltage. | Voltage greater than +12-VDC?
 | STEP 4C-1. Check for an open circuit in the engine harness. |
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4G. Verify oxygen sensor operation. | Did the sensor pass the test?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 752 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 453, 454, 455, 511, and/or 751 active?
YES NO

Troubleshoot any remaining fault codes before proceeding.

 No Repair

Fault Codes 453, 454, 455, 511, or 751 first.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the Fuel System.

Guided Step 2A - Verify secondary fuel pressure.

Conditions

  • Connect all components
  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet.
  • Operate the engine at idle with no load.
  • Fuel pressure must be between 127 to 152 mm H2O [5 to 6 in H2O].

Is pressure correct for the engine family?
YES NO
No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT in the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656, for details on how to perform this procedure.

Go to 2B

Go to 5A

Guided Step 2B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve position feedback and commanded position while keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check base engine components.

Guided Step 3A - Check an exhaust leak.

Conditions

  • Turn keyswitch OFF.

Action

Check for an exhaust leak between the exhaust manifold and the heated oxygen sensor.

  • Check all gaskets
  • Check all castings
  • Check all pipe plugs.

Any exhaust leaks?
YES NO

An exhaust leak has been detected.

Repair or replace any exhaust component. Reference the Service Manual KTA38 GC CM855, Bulletin 4021642.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for intake restriction.

Conditions

Turn keyswitch OFF.

Action

Check for intake system restrictions.

  • Measure the intake system restriction with a vacuum/pressure gauge.

Is intake restriction below 381 mm H2O [15 in H2O]?

YES NO

Replace the air filters. Reference the Service Manual KTA38 GC CM855, Bulletin 4021642.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the engine harness and heated oxygen sensor.

Guided Step 4A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness connector 2 and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check heated oxygen sensor resistance.

  • Measure the resistance between the heated oxygen sensor heater SUPPLY pin and the heated oxygen sensor heater RETURN pin at the heated oxygen sensor connector.
  • Make sure to check the resistance at room temperature (23°C [73°F] ± 3°C [5°F]).

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than +12-VDC?
YES | NO
No Repair | No Repair

Go to 4D

Go to 4C-1

Guided Step 4C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 heated oxygen heater RETURN pin and the engine harness heated oxygen sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line in the OEM harness.

Check for an open circuit in the OEM switched battery supply to the heated oxygen sensor supply.

Repair the damaged pins. Replace the engine harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the 10 Ampere heater supply fuse. Refer to Procedure 019-198 in Section 19.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and the engine harness heated oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and the engine harness heated oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor reference RETURN pin and the engine harness heated oxygen sensor connector reference RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current signal or reference return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 2 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and the engine block ground.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and the engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the heated oxygen sensor test using the INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to activate the heated oxygen sensor test. Follow the directions given by INSITE™ electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.
  • Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 752 is inactive.

Fault Code 752 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 783 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 1 temperature sensor reading on the INSITE™ service tool monitor screen to the reading from the temperature probe. NOTE: If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

A fault intake manifold 1 temperature sensor has been detected.

Replace the intake manifold 1 temperature sensor.

Refer to Procedure 019-059 in Section 19.

Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 783 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:Part Number 3822917 - female AMP/Cannon test leadPart Number 3823994 - female Deutsch test leadTo reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | No damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | No damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1776 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Repair the damaged pins

Repair or replace the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin L on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Reference the manufacturer's instructions.
  • Replace the OEM harness. Reference the manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relays.

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656.

Any issues?
YES NO

  • Reference the Master Repair Manual KTA38 GC CM558 Panel System, Bulletin 4021656, for information on how to resolve the issue.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 3 in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 3 in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 1776 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the aftertreatment inlet oxygen concentration sensor until it has cooled. The aftertreatment inlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the aftertreatment inlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 1858 active?
STEP 2. | Check the aftertreatment inlet oxygen concentration sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1858 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1858 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the aftertreatment inlet oxygen concentration sensor.

Guided Step 2A - Inspect the engine harness and aftertreatment inlet oxygen concentration sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Measure the aftertreatment inlet oxygen concentration sensor supply voltage.

  • Measure the aftertreatment inlet oxygen concentration sensor SUPPLY voltage from the engine harness connector to chassis ground.

Note: See Shop Talk.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the aftertreatment inlet oxygen concentration sensor SUPPLY line. Check the OEM voltage SUPPLY and aftertreatment inlet oxygen concentration sensor fuse. Repair or replace the heated oxygen heater line.

Reference the OEM troubleshooting and repair manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment inlet oxygen concentration sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment inlet oxygen concentration sensor heater negative pin on the aftertreatment inlet oxygen concentration sensor engine harness connector to the aftertreatment inlet oxygen concentration sensor heater negative pin on the ECM connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the aftertreatment inlet oxygen concentration sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the oxygen heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1858 is inactive.

Fault Code 1858 inactive?
YES NO
No Repair

Troubleshooting procedures need to be checked again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the aftertreatment inlet oxygen concentration sensor until it has cooled. The aftertreatment inlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the aftertreatment inlet oxygen concentration sensor connector. The aftertreatment inlet oxygen concentration sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 1859 active?
STEP 2. | Check the aftertreatment inlet oxygen concentration sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1859 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1859 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1859 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the aftertreatment inlet oxygen concentration sensor.

Guided Step 2A - Inspect the engine harness and aftertreatment inlet oxygen concentration sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment inlet oxygen concentration sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Measure the aftertreatment inlet oxygen concentration sensor supply voltage.

  • Measure the aftertreatment inlet oxygen concentration sensor supply voltage.
  • Measure the aftertreatment inlet oxygen concentration sensor SUPPLY voltage from the engine harness connector to chassis ground.

Note: See Shop Talk.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the aftertreatment inlet oxygen concentration sensor SUPPLY line. Check the OEM voltage SUPPLY and aftertreatment inlet oxygen concentration sensor fuse. Repair or replace the aftertreatment inlet oxygen concentration sensor line.

Reference the OEM troubleshooting and repair manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment inlet oxygen concentration sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1859 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment inlet oxygen concentration sensor negative pin on the aftertreatment inlet oxygen concentration sensor engine harness connector to the aftertreatment inlet oxygen concentration sensor heater negative pin on the ECM connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the aftertreatment inlet oxygen concentration sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the oxygen heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1859 is inactive.

Fault Code 1859 inactive?
YES NO
No Repair

Troubleshooting procedures need to be checked again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the oxygen sensor until it has cooled. The oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1861 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 2B. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 3. | Check Base engine components. |
 | STEP 3A. Check for an exhaust leak. | Any exhaust leaks?
 | STEP 3B. Check for an intake restriction. | Is intake restriction 381 mm H2O [15 in H2O] or greater?
STEP 4. | Check the engine harness and oxygen sensor. |
 | STEP 4A. Check the engine harness and oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
 | STEP 4C. Check the oxygen sensor supply voltage. | Voltage greater than 12-VDC?
 | STEP 4C-1. Check for an open circuit in the engine harness. |
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4G. Verify oxygen sensor operation. | Did the sensor pass the test?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1861 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1861 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the Fuel System.

Guided Step 2A - Verify secondary fuel pressure.

Conditions

  • Connect all components
  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet.
  • Operate the engine at idle with no load.
  • Fuel pressure must be between 127 to 152.4 mm H2O [5 to 6 in H2O].

Is pressure correct for the engine family?
YES NO
No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT.

Go to 2B

Go to 5A

Guided Step 2B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck open fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve position feedback and commanded position while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check base engine components.

Guided Step 3A - Check an exhaust leak.

Conditions

  • Turn keyswitch OFF.

Action

Check for an exhaust leak between the exhaust manifold and the oxygen sensor.

  • Check all gaskets
  • Check all castings
  • Check all pipe plugs.

Any exhaust leaks?
YES NO

An exhaust leak has been detected.

Repair or replace any exhaust component. Refer to Procedure 011-007 in Section 11.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for intake system restriction.

Conditions

Turn keyswitch OFF.

Action

Check for intake system restriction.

  • Measure the intake system restriction with a vacuum pressure gauge.

Is intake restriction 381 mm H2O [15 in H2O] or greater?

YES NO

Replace the air filters. Refer to Procedure 010-014 in Section 10.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the engine harness and oxygen sensor.

Guided Step 4A - Inspect the engine harness and oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the oxygen sensor from the engine harness.

Action

Inspect the engine harness connector 2 and oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the oxygen sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oxygen sensor from the engine harness.

Action

Check oxygen sensor resistance.

  • Measure the resistance between the oxygen sensor heater SUPPLY pin and the oxygen sensor heater RETURN pin at the oxygen sensor connector.
  • Make sure to check the resistance at room temperature (23°C [73°F] ± 3°C [5°F] degrees).

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the oxygen sensor supply voltage.

Conditions

  • Turn keyswitch ON
  • Disconnect the oxygen sensor from the engine harness.

Action

Check the voltage at the oxygen sensor connector at the engine harness.

  • Measure the voltage between the oxygen heater SUPPLY pin and the oxygen heater RETURN pin at the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES | NO
No Repair | No Repair

Go to 4D

Go to 4C-1

Guided Step 4C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 oxygen heater RETURN pin and the engine harness oxygen sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Check for a blown, corroded, or wet fuse in the oxygen heater supply line in the OEM harness.

Check for an open circuit in the OEM switched battery supply to the oxygen sensor supply.

Repair the damaged pins. Repair or replace the engine harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor adjustment current pin and the engine harness oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor SIGNAL pin and the engine harness oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor reference RETURN pin and the engine harness oxygen sensor connector reference RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current signal or reference return circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 2 from the ECM
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor adjustment current pin and the engine block ground.
  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor SIGNAL pin and the engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.
  • Measure the resistance between the oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the oxygen sensor test using the INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to activate the heated oxygen sensor test. Follow the directions given by INSITE™ electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1861 is inactive.

Fault Code 1861 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 1862 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the heated oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1862 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1862 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1862 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oxygen sensor from the engine harness.

Action

Inspect the engine harness and oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the oxygen sensor from the engine harness.

Action

Measure the oxygen sensor heater supply voltage.

  • Measure the heated oxygen sensor heater SUPPLY voltage from the engine harness connector to chassis ground.

Note: See Shop Talk.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the oxygen sensor SUPPLY line. Check the OEM voltage SUPPLY and oxygen sensor fuse. Repair or replace the oxygen heater line.

Reference the OEM troubleshooting and repair manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the oxygen sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oxygen sensor from the engine harness.

Action

Check the oxygen sensor heater.

  • Measure the resistance between the oxygen sensor heater positive and the oxygen sensor heater negative at the heated oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the oxygen sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1862 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oxygen sensor heater negative pin on the oxygen sensor engine harness connector to the oxygen sensor heater negative pin on the ECM connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the heated oxygen heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1862 is inactive.

Fault Code 1862 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed and checked again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 1863 active?
STEP 2. | Check the oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1863 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1863 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1863 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the oxygen sensor.

Guided Step 2A - Inspect the engine harness and oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oxygen sensor from the engine harness.

Action

Inspect the engine harness and oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the oxygen sensor from the engine harness.

Action

Measure the oxygen sensor heater supply voltage.

  • Measure the oxygen sensor heater SUPPLY voltage from the engine harness connector to chassis ground.

Note: See Shop Talk.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the oxygen sensor SUPPLY line. Check the OEM voltage SUPPLY and oxygen sensor fuse. Repair or replace the oxygen heater line.

Reference the OEM troubleshooting and repair manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the oxygen sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oxygen sensor from the engine harness.

Action

Check the oxygen sensor heater.

  • Measure the resistance between the oxygen sensor heater positive and the heated oxygen sensor heater negative at the heated oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the oxygen sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1863 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oxygen sensor heater negative pin on the oxygen sensor engine harness connector to the oxygen sensor heater negative pin on the ECM connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the oxygen sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the oxygen heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1863 is inactive.

Fault Code 1863 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1864 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 2B. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 3. | Check Base engine components. |
 | STEP 3A. Check for an exhaust leak. | Any exhaust leaks?
 | STEP 3B. Check for an intake restriction. | Is intake restriction 381 mm H2O [15 in H2O] or greater?
STEP 4. | Check the engine harness and heated oxygen sensor. |
 | STEP 4A. Check the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
 | STEP 4C. Check the heated oxygen sensor heater supply voltage. | Voltage greater than 12-VDC?
 | STEP 4C-1. Check for an open circuit in the engine harness. |
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4G. Verify oxygen sensor operation. | Did the sensor pass the test?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1864 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1864 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the Fuel System.

Guided Step 2A - Verify secondary fuel pressure.

Conditions

  • Connect all components
  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet.
  • Operate the engine at idle with no load.
  • Fuel pressure must be between 127 to 152.4 mm H2O [5 to 6 in H2O].

Is pressure correct for the engine family?
YES NO
No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT.

Go to 2B

Go to 5A

Guided Step 2B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck open fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve position feedback and commanded position while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check base engine components.

Guided Step 3A - Check an exhaust leak.

Conditions

  • Turn keyswitch OFF.

Action

Check for an exhaust leak between the exhaust manifold and the heated oxygen sensor.

  • Check all gaskets
  • Check all castings
  • Check all pipe plugs.

Any exhaust leaks?
YES NO

An exhaust leak has been detected.

Repair or replace any exhaust component. Refer to Procedure 011-007 in Section 11.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for intake system restriction.

Conditions

Turn keyswitch OFF.

Action

Check for intake system restriction.

  • Measure the intake system restriction with a vacuum pressure gauge.

Is intake restriction 381 mm H2O [15 in H2O] or greater?

YES NO

Replace the air filters. Refer to Procedure 010-014 in Section 10.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the engine harness and oxygen sensor.

Guided Step 4A - Inspect the engine harness and oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the oxygen sensor from the engine harness.

Action

Inspect the engine harness connector 2 and oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the oxygen sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oxygen sensor from the engine harness.

Action

Check oxygen sensor resistance.

  • Measure the resistance between the oxygen sensor heater SUPPLY pin and the oxygen sensor heater RETURN pin at the oxygen sensor connector.
  • Make sure to check the resistance at room temperature (23°C [73°F] ±3°C [± 5°F] degrees).

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Disconnect the oxygen sensor from the engine harness.

Action

Check the voltage at the oxygen sensor connector at the engine harness.

  • Measure the voltage between the oxygen heater SUPPLY pin and the oxygen heater RETURN pin at the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES | NO
No Repair | No Repair

Go to 4D

Go to 4C-1

Guided Step 4C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 oxygen heater RETURN pin and the engine harness oxygen sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Check for a blown, corroded or wet fuse in the oxygen heater supply line in the OEM harness.

Check for an open circuit in the OEM switched battery supply to the oxygen sensor supply.

Repair the damaged pins. Repair or replace the engine harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor adjustment current pin and the engine harness oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor SIGNAL pin and the engine harness oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor reference RETURN pin and the engine harness heated oxygen sensor connector reference RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current signal or reference return circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 2 from the ECM
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor adjustment current pin and the engine block ground.
  • Measure the resistance between the engine harness ECM connector 2 oxygen sensor SIGNAL pin and the engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.
  • Measure the resistance between the oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the oxygen sensor test using the INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to activate the heated oxygen sensor test. Follow the directions given by INSITE™ electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-458 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1864 is inactive.

Fault Code 1864 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 2 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1984 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 2 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 2 temperature sensor.

Note: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 datalink.
  • Compare the intake manifold 2 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Follow the Intake Manifold Air Temperature Above Specifications symptom tree in Service Manual, KTA38GC CM558, Bulletin 4021642.

A damaged intake manifold 2 temperature sensor has been detected.

Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1984 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 3 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 3 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1985 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 3 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 3 temperature sensor.

Note: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 datalink.
  • Compare the intake manifold 3 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 3 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Follow the Intake Manifold Air Temperature Above Specifications symptom tree in Service Manual, KTA38GC CM558, Bulletin 4021642.

A damaged intake manifold 3 temperature sensor has been detected.

Replace the intake manifold 3 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1985 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 4 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 4 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1986 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 4 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy.

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 4 temperature sensor.

Note: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 datalink.
  • Compare the intake manifold 4 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 4 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Follow the Intake Manifold Air Temperature Above Specifications symptom tree in Service Manual, KTA38GC CM558, Bulletin 4021642.

A damaged intake manifold 4 temperature sensor has been detected.

Replace the intake manifold 4 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1986 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 2 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2157 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 2 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy.

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 2 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 2 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

A damaged intake manifold 2 temperature sensor has been detected.

Replace the intake manifold 2 temperature sensor.

Refer to Procedure 019-059 in Section 19.

Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2157 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 3 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 3 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2158 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 3 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 3 temperature sensor accuracy.

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 3 temperature sensor.

Note: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 datalink.
  • Compare the intake manifold 3 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 3 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Follow the Intake Manifold Air Temperature Above Specifications symptom tree in Service Manual, KTA38GC CM558, Bulletin 4021642.

A damaged intake manifold 3 temperature sensor has been detected.

Replace the intake manifold 3 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2158 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 4 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 4 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2159 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 4 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 4 temperature sensor accuracy.

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 4 temperature sensor.

Note: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 datalink.
  • Compare the intake manifold 4 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 4 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Follow the Intake Manifold Air Temperature Above Specifications symptom tree in Service Manual, KTA38GC CM558, Bulletin 4021642.

A damaged intake manifold 4 temperature sensor has been detected.

Replace the intake manifold 4 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2159 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 2188 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the heated oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2188 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2188 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2188 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the heated oxygen sensor heater SUPPLY voltage from the engine harness connector to chassis ground.

Note: See Shop Talk.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the heated oxygen sensor SUPPLY line. Check the OEM voltage SUPPLY and heated oxygen sensor fuse. Repair or replace the heated oxygen heater line.

Reference the OEM troubleshooting and repair manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the heated oxygen sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the heated oxygen sensor heater positive and the heated oxygen sensor heater negative at the heated oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the heated oxygen sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2188 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the heated oxygen sensor heater negative pin on the heated oxygen sensor engine harness connector to the heated oxygen sensor heater negative pin on the ECM connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the heated oxygen heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2188 is inactive.

Fault Code 2188 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed and checked again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2192 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 2192 active?
 | STEP 2C. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage to the engine harness. | 11-VDC to 14-VDC?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2192 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2192 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2192 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor form the engine harness
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check heated oxygen sensor resistance.

  • Measure the resistance between the heated oxygen sensor heater SUPPLY pin and the heated oxygen sensor heater RETURN pin at the heated oxygen sensor connector.
  • Make sure to check the resistance at room temperature 23°C [73°F] ±3°C [± 5] degrees.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM
  • Disconnect the engine harness from the OEM harness at the 47 pin OEM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage to the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM harness at the 47 pin OEM connector
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the SUPPLY voltage to the heated oxygen heater SUPPLY pin in the 47 pin connector, OEM side.

11-VDC to 14-VDC?
YES NO
No Repair

  • Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Note: Make sure that the 10 Ampere fuse is not blown in the OEM harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM
  • Disconnect the engine harness from the heated oxygen sensor
  • Disconnect the engine harness from the OEM harness at the 47 pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance from the heated oxygen heater SUPPLY pin at the 47 pin OEM connector of the engine harness to the heated oxygen heater SUPPLY pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference SIGNAL pin in the engine harness ECM connector to the heated oxygen reference SIGNAL pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference RETURN pin in the engine harness ECM connector to the heated oxygen reference RETURN pin in the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM
  • Disconnect the 47 pin OEM connector from the engine harness
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the heated oxygen heater SUPPLY pin in the engine harness sensor connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the 47 pin connector from the OEM harness
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor SUPPLY pin at the 47 pin OEM connector of the engine harness and all other pins in the 47 pin connector.
  • Measure the resistance between the heated oxygen sensor SUPPLY pin at the 47 pin OEM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the heated oxygen sensor supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness.Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2192 is inactive.

Fault Code 2192 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed and checked again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 2217 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check ECM for a short circuit to ground. | More than 100k ohms?
 | STEP 1D. Recalibrate the ECM. | ECM recalibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2217 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Recycle the power to the ECM, use the keyswitch.

Fault Code 2217 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656.

Go to 1C

Go to 2A

Guided Step 1C - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Recalibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Recalibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

ECM recalibrated successfully?
YES NO
No Repair

Active fault codes present.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 2217 is inactive.

Fault Code 2217 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 752 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 2. | Check the engine harness and heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 3. | Check the fuel pressure. |
 | STEP 3A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 3B. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 4. | Check the intake and exhaust system |
 | STEP 4A. Check the intake and exhaust system for air leaks. | Air leaks?
 | STEP 4B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2219 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 active?
YES | NO
No Repair | No Repair

Fault Code 752

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine harness and heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness connector 2 and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, engine harness, or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and the engine harness heated oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and the engine harness heated oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor RETURN pin and the engine harness heated oxygen sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current, SIGNAL or RETURN circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 3A

Guided Step 3 - Check the fuel pressure.

Guided Step 3A - Verify secondary fuel pressure.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet
  • Operate the engine at idle with no load
  • Fuel pressure must be between [101.60 to 152.40 mm H 2O] 4 to 6 in H2O.

Is pressure correct for the engine family?
YES NO
No Repair

For more troubleshooting details on low fuel pressure issues, go to Fault Code 2119.

Go to 4A

Go to 5A

Guided Step 3B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck open fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel control valve position feedback and commanded position while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO
No Repair

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 4A

Go to 5A

Guided Step 4 - Check for intake and exhaust systems.

Guided Step 4A - Check the intake and exhaust system for air leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the intake and exhaust system for air leaks.

Refer to Procedure 010-024 (Air Leaks, Air Intake and Exhaust Systems) in the Service Manual KTA38 CM558, Bulletin 4021642.

Air Leaks?
YES NO

Refer to Procedure Follow the troubleshooting steps in Procedure 010-024 (Air Leaks, Air Intake and Exhaust Systems) in the Service Manual KTA38 CM558, Bulletin 4021642.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Use INSITE™ electronic service tool to reset.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2219 inactive?
YES NO
No Repair

Troubleshooting.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 752 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 2. | Check the ignition system. |
 | STEP 2A. Check for ignition system faults. | Ignition system faults?
 | STEP 2B. Check for ignition system misfire. | Ignition system misfire?
STEP 3. | Check the engine harness and heated oxygen sensor. |
 | STEP 3A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the heated oxygen sensor heater supply voltage. | Voltage Greater than 12-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 4. | Check the fuel control valve. |
 | STEP 4A. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 5. | Check the exhaust system |
 | STEP 5A. Check for high exhaust back pressure. | Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2219 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 active?
YES | NO
No Repair | No Repair

Fault Code 752

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ignition system.

Guided Step 2A - Check for ignition system faults.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch on.

Action

Check for ignition system faults.

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656, for instructions on how to check for ignition system faults.

Ignition system faults?
YES NO

Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656, for instructions on how to check for ignition system faults.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for ignition system misfire.

Conditions

  • Turn keyswitch on.

Action

Check for ignition system misfire.

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to check for ignition system misfire.

Ignition system misfire?
YES NO

Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to check for ignition system misfire.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the engine harness and heated oxygen sensor.

Guided Step 3A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and engine block ground.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 and the circuit diagram or wiring diagram.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 6A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 and the circuit diagram or wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES NO
No Repair

An open circuit or short to ground has been detected on the heated oxygen sensor supply line in the engine harness. An open circuit in the heated oxygen sensor return line can also be a possible cause of this fault.

Check for a blown, corroded, or wet fuse in the heated oxygen heater supply line.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 4A

Guided Step 4 - Check the fuel control valve.

Guided Step 4A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck open fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve commanded position and position feedback while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the exhaust systems.

Guided Step 5A - Check for high exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for higher than specified exhaust back pressure.

  • Check the exhaust back pressure by installing a pressure gauge into the exhaust system just past the turbocharger outlet.

Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
YES NO
No Repair

011-009 (Exhaust Restriction) in the Service Manual KTA38 CM558, Bulletin 4021642.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2219 inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the connector and pins.

Replace the damaged section of the harness or damaged electronic fuel control valve.

Reference the wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19. or Refer to Procedure 019-117 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the fuel pump pressurizing assembly 1 RETURN pin at the electronic fuel control valve connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-117 in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-117 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

Call for pre-authorizaton.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Reference the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Reference the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Codes 2311 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Reference the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve. Refer to Procedure 019-117 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:Part Number 3822917 - female AMP/Cannon test leadPart Number 3823994 - female Deutsch test leadTo reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2315 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Repair or replace the OEM harness connector pins.

  • Repair the OEM harness. Reference the manufacturer's instructions.
  • Replace the OEM harness. Reference the manufacturer's instructions.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 19 on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Reference the manufacturer's instructions.
  • Replace the OEM harness. Reference the manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Key switch in the OFF position.

Action

Check the OEM control panel and relays.

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656.

Any issues?
YES | NO
No Repair | No Repair

Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to resolve the issues.
Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 3 in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 3 in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 2315 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:Part Number 3822917 - female AMP/Cannon test leadPart Number 3823994 - female Deutsch test leadTo reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2316 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Repair the damaged pins

Repair the OEM harness connector.

  • Repair the 47 pin Deutsch connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 8 on the OEM connector to the engine block ground
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Reference the manufacturer's instructions.
  • Replace the OEM harness. Reference the manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Key switch in the OFF position.

Action

Check the OEM control panel and relays.

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656.

Any issues?
YES | NO
No Repair | No Repair

Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to resolve the issues.
Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 3 in the ECM connector to all of the other pins in the connector
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 3 in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 2316 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:Part Number 3822917 - female AMP/Cannon test leadPart Number 3823994 - female Deutsch test leadTo reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the Part No. 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2317 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Repair the OEM harness connector.

  • Repair the 47 pin Deutsch connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 8 on the OEM connector to the engine block ground
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Reference the manufacturer's instructions.
  • Replace the OEM harness. Reference the manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Key switch in the OFF position.

Action

Check the OEM control panel and relays.

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656.

Any issues?
YES | NO
No Repair | No Repair

Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to resolve the issues.
Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Refer to Procedure 019-204 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19

Replace the ECM.

Call for pre-authorization.

  • Replace the ECM.Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

CAUTION

To reduce the possibility of pin and harness damage use the Part No. 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 3 in the ECM connector to all of the other pins in the connector
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 3 in the ECM connector to the engine block ground
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 2317 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2544 active?
YES NO

Allow the ECM to cool and then restart the engine. If the fault reoccurs, contact a Cummins® Authorized Service Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2661 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2661 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location if the fault code will not reset.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2797 inactive?
STEP 2. | Check the carburetor inlet gas differential pressure sensor and circuit. |
 | STEP 2A. Inspect the carburetor inlet gas differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2798 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2797 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2797 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2797 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the carburetor inlet gas differential pressure sensor and circuit.

Guided Step 2A - Inspect the carburetor inlet gas differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and carburetor inlet gas differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the carburetor inlet gas differential pressure sensor SUPPLY pin and the carburetor inlet gas differential pressure sensor RETURN pin at the carburetor inlet gas differential pressure sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the carburetor inlet gas differential pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 active?
YES NO

A damaged sensor has been detected.

Replace the carburetor inlet gas differential pressure sensor.

Refer to Procedure 019-457 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector carburetor inlet gas differential pressure sensor RETURN pin and the OEM harness carburetor inlet gas differential pressure sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be completed again from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2797 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2798 inactive?
STEP 2. | Check the carburetor inlet gas differential pressure sensor and circuit. |
 | STEP 2A. Inspect the carburetor inlet gas differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2797 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2798 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2798 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2798 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the carburetor inlet gas differential pressure sensor and circuit.

Guided Step 2A - Inspect the carburetor inlet gas differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and carburetor inlet gas differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the carburetor inlet gas differential pressure sensor SUPPLY pin and the carburetor inlet gas differential pressure sensor RETURN pin at the carburetor inlet gas differential pressure sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the carburetor inlet gas differential pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 active?
YES NO

A damaged sensor has been detected.

Replace the carburetor inlet gas differential pressure sensor.

Refer to Procedure 019-457 in Section 19.

None. The removal an installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector carburetor inlet gas differential pressure sensor RETURN pin and the OEM harness carburetor inlet gas differential pressure sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be completed again from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2798 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the valve supply voltage. | +24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2864 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2864 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

NOTE:Be sure that the engine is not performing a purge cycle when making this measurement.

+24-VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness.

Reference the circuit diagram or wiring diagram for component identification.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the engine harness connector from the Fuel Shutoff Valve
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine.
  • Reference the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2864 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2864 is inactive.

Fault Code 2864 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:Part Number 3822917 - female AMP/Cannon test leadPart Number 3823994 - female Deutsch test leadTo reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use Part Number 3823994 - female Deutsch test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for a short circuit to ground. | More power relay driver diagnostics has detected an error - Condition Exists
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2865 Inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • bent or broken pins
  • pushed back or expanded pin
  • corroded pins
  • moisture in or on connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Repair the 47 pin Deutsch connector. Refer to Procedure 019-207 in Section 19..

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use Part Number 3823994 - female Deutsch test lead when taking a measurement.
Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • measure the resistance from pin 22 on the OEM connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Repair the OEM harness. Reference the manufacturer's instructions.
  • Replace the OEM harness. Reference the manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relays.

Action

Check the OEM control panel and relays.

  • measure the resistance from pin 22 on the OEM connector to the engine block ground.
OK NOT OK

go to 2A

  • See the KTA38GC Electronics Master Repair Manual, Bulletin 4021665.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043 in Section 19..
  • Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • measure the resistance from pin 3 in the ECM connector to all of the other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203 in Section 19..
  • Replace the harness. Refer to Procedure 019-043 in Section 19..

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • measure the resistance from pin 3 in the ECM connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203 in Section 19..
  • Replace the harness. Refer to Procedure 019-043 in Section 19..

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.
OK NOT OK

Fault Code 2865 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2866 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 2866 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2866 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2866 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the connector and pins.

Replace the damaged section of the harness or damaged electronic fuel control valve.

Reference the wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 .

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 .

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

Call for pre-authorizaton.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 .

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Reference the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Reference the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2866 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Reference the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2866 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2866 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 2866 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2866 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2866 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Reference the circuit diagram or wiring diagram for all engine harness interconnections.

Call for pre-authorizaton.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 .

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Reference the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Reference the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2866 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Reference the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2866 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2995 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2995 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2995 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2995 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.
  • Start the INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the Intake Manifold Pressure Sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2995 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual KTA38GC CM558, Bulletin 4021642.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2995 is inactive.

Fault Code 2995 active?
YES NO

Troubleshooting procedures need to be completed again from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2996 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the Intake Manifold Pressure/Temperature Sensor. |
 | STEP 3A. Inspect the Intake Manifold Pressure/Temperature Sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2996 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2996 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2996 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.
  • Start INSITE™ Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the Intake Manifold Pressure Sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Intake Manifold Pressure/Temperature Sensor.

Guided Step 3A - Inspect the Intake Manifold Pressure/Temperature Sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Intake Manifold Pressure/Temperature Sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2996 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual KTA38 CM558 Bulletin 4021642.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2996 is inactive.

Fault Code 2996 active?
YES NO

Troubleshooting procedures need to be completed again from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 752 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2997 inactive?
STEP 2. | Check the ignition system |
 | STEP 2A. Check the ignition system for faults. | Ignition system faults?
 | STEP 2B. Check for ignition system misfires. | Ignition system misfire?
STEP 3. | Check the engine harness and heated oxygen sensor. |
 | STEP 3A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the heated oxygen sensor heater supply voltage. | Voltage Greater than 12-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2997 inactive?
STEP 4. | Check the fuel control valve. |
 | STEP 4A. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 5. | Check the exhaust system |
 | STEP 5A. Check for high exhaust back pressure. | Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2997 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 active?
YES | NO
No Repair | No Repair

Fault Code 752

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2997 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ignition system.

Guided Step 2A - Check for ignition system faults.

Conditions

  • Turn keyswitch on.

Action

Check for ignition system faults.

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to check for ignition system faults.

Ignition system faults?
YES NO

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to check for ignition system faults.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for ignition system misfire.

Conditions

  • Turn keyswitch on.

Action

Check for ignition system misfire.

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to check for ignition system spark voltage counts (CAVGs).

Ignition system misfire?
YES NO

  • Reference the Master Repair Manual KTA38GC CM558 Panel System, Bulletin 4021656 for instructions on how to check for ignition system misfire.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the engine harness and heated oxygen sensor.

Guided Step 3A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and engine block ground.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES NO
No Repair

An open circuit or shorted to ground has been detected on the heated oxygen sensor supply line in the engine harness. An open circuit in the heated oxygen sensor return line can also be a possible fail mode.

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2997 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 4A

Guided Step 4 - Check the fuel control valve.

Guided Step 4A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck open fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve commanded position and position feedback while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the exhaust systems.

Guided Step 5A - Check for high exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for higher than specified exhaust back pressure.

  • Check the exhaust back pressure by installing a pressure gauge into the exhaust system just past the turbocharger outlet.
  • Refer to Procedure 011-009 (Exhaust Restriction) in the Service Manual KTA38 CM558, Bulletin 4021642.

Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
YES NO
No Repair

Refer to Procedure 011-009 (Exhaust Restriction) in the Service Manual KTA38 CM558, Bulletin 4021642.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2997 inactive?
YES NO
No Repair

Troubleshooting procedures need to be checked again from the beginning.

Go to 6B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


INDEX
51-fc121.htm

51-t05-121.htm

51-fc153.htm

51-t05-153.htm

51-fc154.htm

51-t05-154.htm

51-fc155.htm

51-t05-155.htm

51-fc156.htm

51-t05-156.htm

51-fc157.htm

51-t05-157.htm

51-fc158.htm

51-t05-158.htm

51-fc159.htm

51-t05-159.htm

51-fc161.htm

51-t05-161.htm

51-fc162.htm

51-t05-162.htm

51-fc163.htm

51-t05-163.htm

51-fc164.htm

51-t05-164.htm

51-fc165.htm

51-t05-165.htm

51-fc187.htm

51-t05-187.htm

51-fc227.htm

51-t05-227.htm

51-fc234.htm

51-t05-234.htm

51-fc238.htm

51-t05-238.htm

51-fc239.htm

51-t05-239.htm

51-fc244.htm

51-t05-244.htm

51-fc254.htm

51-t05-254.htm

51-fc277.htm

51-t05-277.htm

51-fc343.htm

51-t05-343.htm

51-fc346.htm

51-t05-346.htm

51-fc352.htm

51-t05-352.htm

51-fc354.htm

51-t05-354.htm

51-fc355.htm

51-t05-355.htm

51-fc386.htm

51-t05-386.htm

51-fc426.htm

51-t05-426.htm

51-fc441.htm

51-t05-441.htm

51-fc442.htm

51-t05-442.htm

51-fc477.htm

51-t05-477.htm

51-fc478.htm

51-t05-478.htm

51-fc488.htm

51-t05-488.htm

51-fc512.htm

51-t05-512.htm

51-fc513.htm

51-fc689.htm

00-t05-689.htm

51-t05-513.htm

51-fc697.htm

51-t05-697.htm

51-fc752.htm

51-t05-752.htm

51-fc783.htm

51-t05-783.htm

51-fc1776.htm

51-t05-1776.htm

51-fc1858.htm

51-t05-1858.htm

51-fc1859.htm

51-t05-1859.htm

51-fc1861.htm

51-t05-1861.htm

51-fc1862.htm

51-t05-1862.htm

51-fc1863.htm

51-t05-1863.htm

51-fc1864.htm

51-t05-1864.htm

51-fc1984.htm

51-t05-1984.htm

51-fc1985.htm

51-t05-1985.htm

51-fc1986.htm

51-t05-1986.htm

51-fc2157.htm

51-t05-2157.htm

51-fc2158.htm

51-t05-2158.htm

51-fc2159.htm

51-t05-2159.htm

51-fc2188.htm

51-t05-2188.htm

51-fc2192.htm

51-t05-2192.htm

51-fc2217.htm

51-t05-2217.htm

51-fc2219.htm

51-t05-2219.htm

51-fc2221.htm

51-t05-2221.htm

51-fc2311.htm

51-t05-2311.htm

51-fc2315.htm

51-t05-2315.htm

51-fc2316.htm

51-t05-2316.htm

51-fc2317.htm

51-t05-2317.htm

51-fc2544.htm

51-t05-2544.htm

51-fc2661.htm

51-t05-2661.htm

51-fc2797.htm

51-t05-2797.htm

51-fc2798.htm

51-t05-2798.htm

51-fc2864.htm

51-t05-2864.htm

51-fc2865.htm

51-t05-2865.htm

51-fc2866.htm

51-t05-2866.htm

51-fc2867.htm

51-t05-2867.htm

51-fc2995.htm

51-t05-2995.htm

51-fc2996.htm

51-t05-2996.htm

51-fc2997.htm

51-t05-2997.htm