GTA8.3 CM558

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Magnetic Crankshaft Speed/Position lost one or two signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position lost one or two signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Yellow SRT: | Engine Magnetic Crankshaft Speed/Position lost one or two signals - Abnormal Rate of Change. Invalid engine speed signal detected on the engine speed sensor signal pins at the ECM connector. | Engine is shutdown and will not start.

Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor monitors the engine speed, then passes this information to the ECM through the engine harness.

Component Location

The engine speed sensor is located on the flywheel housing on the left side of the engine.

Shop Talk

The engine speed sensor is a magnetic sensor and senses the ring gear teeth on the flywheel to determine engine speed.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3823995 - male Weather-Pack™ test lead
Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 121 active?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the engine harness and engine speed sensor connector pins. | Damaged or dirty pins?
 | STEP 2B. Inspect the sensor for damage. | Damage found?
 | STEP 2C. Read the fault codes. | Fault Code 121 active?
 | STEP 2D. Check the resistance of the sensor. | 1000 to 2000 ohms?
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 3B. Read the fault codes. | Fault Code 121 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 (Weatherpack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 (Engine Speed Sensor (ESS)) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damage found?
YES NO

Replace the engine speed sensor. Refer to Procedure 019-042 (Engine Speed Sensor (ESS)) in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4B

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine speed sensor positive pin to the engine speed sensor negative pin in the engine speed sensor connector.
  • Measure the resistance from the engine speed sensor backup positive pin to the engine speed sensor backup negative pin in the engine speed sensor connector.

1000 to 2000 ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 (Engine Speed Sensor (ESS)) in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor
  • Make sure the sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine speed sensor positive pin in the engine speed sensor connector, sensor side, to engine block ground.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine speed sensor connector, sensor side, to engine block ground.

More than 100k ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 (Engine Speed Sensor (ESS)) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect engine harness connector A from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness sensor connector to the engine speed sensor positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness sensor connector to the engine speed sensor backup positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor negative pin in the engine harness sensor connector to the engine speed sensor negative pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor backup negative pin in the engine harness sensor connector to the engine speed sensor backup negative pin in the engine harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 (Weatherpack Connector Series) in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch off
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect the engine harness connector A from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector to the engine block ground.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Install the appropriate connector seal if it is damaged or missing. Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch off
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector A to all other pins in the connector.
  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector A to all the pins in engine harness connector B.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector A to all other pins in the connector.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector A to all the pins in engine harness connector B.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Install the appropriate connector seal if it is damaged or missing. Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Oil Rifle Pressure 1 Sensor Circuit - Shorted High

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the engine oil pressure sensor pin at the ECM. | No engine protection for engine oil rifle pressure 1.

Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil pressure sensor is located on the left side of the block, below the ignition control module.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault goes inactive.
  • Engines operating in altitudes above 5000 feet with auxiliary lubricating oil filtering devices can experience low lubricating oil pressure faults at idle conditions.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3823996 - female Weather-Pack™ test lead
Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for 386 fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for 386 fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the oil pressure RETURN pin on the engine oil pressure sensor connector of the engine harness.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector A RETURN pin and the engine oil pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness and all other pins in the engine connector A.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure 5 Volt SUPPLY pin in engine harness connector A and all other pins in the ECM connector A.
  • Measure the resistance between the oil pressure 5 Volt SUPPLY pin in engine harness connector A and all other pins in the ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the engine oil pressure sensor pin at the ECM. | No engine protection for engine oil rifle pressure 1.

Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The lubricating oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil pressure sensor is located on the left side of the block, below the ignition control module.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault goes inactive.
  • Engines operating in altitudes above 5000 feet with auxiliary lubricating oil filtering devices can experience low lubricating oil pressure faults at idle conditions.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3823996 - female Weather-Pack™ test lead
Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 (Engine Oil Rifle Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the oil pressure RETURN pin on the engine oil pressure sensor connector of the engine harness.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil pressure SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine oil pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A SUPPLY pin and the engine harness engine oil pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A SIGNAL pin and the engine harness engine oil pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector A and all other pins in connector A.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector A and all other pins in connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Oil Rifle Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 142

Engine Oil Rifle Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 142 PID: P100 SPN: 100 FMI: 16 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure above the engine protection warning limit. | Possible reduced engine performance.

Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left side of the block, below the ignition control module.

Shop Talk

Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault goes inactive.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1. Read the fault codes. | Fault Code 142 active?
STEP 2. | Check the oil pressure sensor accuracy. |
 | STEP 2A. Check the sensor accuracy. | Sensor reading is correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 142 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 142 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the oil pressure sensor accuracy.

Guided Step 2A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine
  • Connect INSITE™ electronic service tool to the vehicle datalink.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.

Note: If necessary, increase the engine rpm to make it easier to see differences in the readings.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 142 is inactive.

Note: If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 142 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If the fault code remains active, refer to the Lubricating Oil Temperature Above Specifications troubleshooting symptom chart in Section TS of the GTA8.3GC CM558 Service Manual, Bulletin 4021641.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Sep-2007


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure below the engine protection warning limit. | Possible reduced engine performance.

Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left side of the block, below the ignition control module.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading is correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch on
  • Connect a mechanical oil pressure gauge
  • Connect INSITE™ electronic service tool
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Refer to Procedure 007-052 (Lubricating Oil Pressure Sensor, OEM) in Section 7 in the GTA8.3 CM558 Service Manual, Bulletin 4021641.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 143 is inactive.

Note: If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 143 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If fault code remains active, go to the Low Oil Pressure symptom tree in Section TS.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 14-Sep-2007


Engine Coolant Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. | No engine protection for coolant temperature 1.

Engine Coolant Temperature Sensor 1 Circuit

Circuit Description

The ECM uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault code can log in extremely cold weather.

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 144 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 175 ohms to 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the coolant temperature sensor and circuit.

Guided Step 2A - Inspect the coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the coolant temperature sensor connector.

175 ohms to 274k ohms?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature RETURN pin and the ECM connector A RETURN pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin and the ECM connector A SIGNAL pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness to all other pins in the engine ECM connector A.
  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness and all pins in engine ECM connector B.

Refer to circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short circuit on the SIGNAL pin has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive faults.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Coolant Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for engine coolant temperature 1.

Engine Coolant Temperature Sensor 1 Circuit

Circuit Description

The ECM uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine coolant temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine coolant temperature sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the coolant temperature sensor. Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector A and all other pins in the engine connector A.
  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. High coolant temperature warning. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The ECM uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-146

Last Modified: 24-Sep-2013


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. High coolant temperature critical. | Engine is shutdown.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The ECM uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

The engine protection shutdown for the coolant temperature is a customer feature and will only be enabled at the customer's request. This sensor will deactivate the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-151

Last Modified: 24-Sep-2013


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold air temperature sensor pin at the ECM. | Possible reduced engine performance.

Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe must compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | 175 ohms to 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold 1 temperature sensor.

Action

Inspect the engine harness and intake manifold 1 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 (Intake Manifold Air Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the intake manifold 1 temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

175 ohms to 274 ohms?
YES NO

Go to the table in Shop Talk for specifications.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 (Intake Manifold Air Temperature Sensor) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the temperature RETURN pin and the ECM connector A RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold 1 temperature sensor SIGNAL pin and the ECM connector A SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector A.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance.

Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe must compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 active?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 (Intake Manifold Air Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 (Intake Manifold Air Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector A and all other pins in the engine connector A.
  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and the Wiring Diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in engine harness ECM connector A to ground.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Engine is shutdown.

Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 155 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the Intake Manifold Pressure/Temperature Sensor. |
 | STEP 3A. Inspect the Intake Manifold Pressure/Temperature Sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 155 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 155 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the Intake Manifold Air Temperature Sensor. Refer to Procedure 019-059 (Intake Manifold Air Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Intake Manifold Pressure/Temperature Sensor.

Guided Step 3A - Inspect the Intake Manifold Pressure/Temperature Sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Intake Manifold Pressure/Temperature Sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 (Deutsch DT Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the Intake Manifold Air Temperature Sensor. Refer to Procedure 019-059 (Intake Manifold Air Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES NO

Refer to the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual GTA8.3 CM558, Bulletin 4021641.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 155 is inactive.

Fault Code 155 active?
YES NO

Troubleshooting procedures need to be completed again from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 3510 FMI: 4 LAMP: Yellow SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance, shutdown or loss of engine protection.

Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for the exhaust gas stack temperature sensor and the air intake humidity/temperature sensor.

Component Location

The sensor supply 2 circuit is contained in the wiring harness.

Shop Talk

The voltage supply on the GTA8.3 engine is broken up into Sensor Supply 1, and Sensor Supply 2.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Codes 187 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the exhaust gas stack temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response |
 | STEP 2B. Inspect the air intake humidity/temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3B-1. Check for a pin short to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Dirty or damaged pins?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the exhaust gas stack temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Inspect the exhaust gas stack temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell damaged
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the exhaust gas stack temperature sensor. Contact a Cummins® Authorized Repair Facility to replace this sensor.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas stack temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

Contact a Cummins® Authorized Repair Facility to replace this sensor.

Go to 2C

Go to 4A

Guided Step 2B - Inspect the air intake humidity/temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor from the OEM harness.

Action

Inspect the air intake humidity/temperature sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell damaged
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the air intake humidity/temperature sensor. Contact a Cummins® Authorized Repair Facility to replace this sensor.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the air intake humidity/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged air intake humidity/temperature sensor has been detected.

Replace the sensor. Contact a Cummins® Authorized Repair Facility to replace this sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell damaged
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector B from the ECM
  • Disconnect the exhaust gas stack temperature sensor and the air intake humidity/temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the sensor SUPPLY 2 pin in the engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY 2 pin in the engine harness ECM connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor SUPPLY 2 has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector B from the ECM
  • Disconnect the exhaust gas stack temperature sensor and the air intake humidity/temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the sensor SUPPLY 2 pin in the engine harness ECM connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor SUPPLY 2 has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 187 inactive.

Fault Code 187 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Sensor Supply 2 - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: 232 SPN: 3510 FMI: 3 LAMP: Amber SRT: | Sensor Supply 2 - Voltage Above Normal or Shorted to High Source. High voltage detected on sensor supply number 2 circuit. | Possible reduced engine performance, shutdown, or loss of engine protection.

Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for the exhaust gas stack temperature sensor and the air intake humidity/temperature sensor.

Component Location

The sensor supply voltage 5 Volt circuit is contained in the wiring harness.

Shop Talk

The voltage supply on the GTA8.3 engine voltage supplies is broken up into Sensor Supply 1, and Sensor Supply 2.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 227 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch ON
  • Disconnect the engine harness connector A and connector B from the ECM.
  • Disconnect the exhaust gas stack temperature sensor from the engine harness.
  • Disconnect the air intake humidity/temperature sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 2.

Action

Check for a pin to pin short.

  • Measure the resistance between the sensor SUPPLY 2 pin in the engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY 2 pin in the engine harness ECM connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor SUPPLY 2 pin has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive?

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Engine is shutdown.

Crankshaft Speed Sensors Circuit

Circuit Description

The crankshaft (primary) engine speed sensor provides engine speed information to the ECM through the engine harness.

Component Location

The crankshaft speed sensor is located on the flywheel housing on the left side of the engine, under the filter bracket.

Shop Talk

Possible causes of this fault code include:

  • Engine governor damage
  • Tampering of the speed sensors

Make sure the correct operation conditions are followed when operating the engine as described in the operation and maintenance manual. To check for valid overspeed, check the fault code snapshot information for the speed reached. This fault will activate at 1980 rpm.

Cautions and Warnings

CAUTION

If the engine speed stays above 2000 rpm, the engine must be shut off immediately or engine damage will occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a
measurement:
Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for governor faults. | Did a governor malfunction cause this issue?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an inactive fault code at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed

Guided Step 1A - Check for governor faults.

Conditions

  • Turn keyswitch OFF

Action

Check for governor faults.

  • Refer to the GTA8.3 Master Repair Manual, Bulletin 4021654, for information on how to complete this.

Did a governor malfunction cause this issue?
YES NO

Refer to the GTA8.3 Master Repair Manual Bulletin 4021654, for information.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Engine is running
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with INSITE™ electronic service tool.

  • Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the panel tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor as outlined in Fault Code 121.

Go to 1C

Fault Code 121

Guided Step 1C - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensors.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Ben or broken pins
  • Pushed back or expanded pins
  • Moisture in or on connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged connector pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 (Engine Speed Sensor) in Section 19.

No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code at low engine rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Test the engine.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 2B

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Exhaust Gas Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 246

Exhaust Gas Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 246 PID: SPN: 173 FMI: 3 LAMP: Amber SRT: | Exhaust Gas Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor pin at the ECM. | No engine protection for exhaust gas temperature 1.

Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The ECM uses the exhaust gas temperature 1 sensor for engine protection purposes.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold, below the turbocharger.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault code can log in extremely cold weather.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 246 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 175 ohms to 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 246 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 246 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 246 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 (Exhaust Gas Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the exhaust gas temperature sensor connector.

175 ohms to 274k ohms?
YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 (Exhaust Gas Temperature Sensor) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature RETURN pin and the ECM connector A RETURN pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin and the ECM connector A SIGNAL pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the exhaust gas temperature SIGNAL pin in engine harness to all other pins in the engine ECM connector A.
  • Measure the resistance between the exhaust gas temperature SIGNAL pin in engine harness and all pins in engine ECM connector B.

Refer to circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short circuit on the SIGNAL pin has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 246 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 246 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Exhaust Gas Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 247

Exhaust Gas Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 247 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Exhaust Gas Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source | No engine protection for exhaust gas temperature 1.

Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The ECM uses the exhaust gas temperature 1 sensor for engine protection purposes.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold, below the turbocharger.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 247 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 246 active and Fault Code 247 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 247 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 247 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 247 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 247 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor.

Guided Step 2A - Inspect the exhaust gas temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 (Exhaust Gas Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 246 active and Fault Code 247 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the exhaust gas temperature sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 247 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 (Exhaust Gas Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the exhaust gas temperature SIGNAL pin in the engine harness ECM connector A and all other pins in the engine connector A.
  • Measure the resistance between the exhaust gas temperature SIGNAL pin in the engine harness ECM connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the exhaust gas temperature SIGNAL pin in the engine harness ECM connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 247 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 247 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Exhaust Gas Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 248

Exhaust Gas Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 248 PID: P110 SPN: 110 FMI: 16 LAMP: Amber SRT: | Exhaust Gas Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level | Possible reduce engine performance.

Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The ECM uses the exhaust gas temperature 1 sensor for engine protection purposes.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold, below the turbocharger.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 248 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the Exhaust Gas Temperature Sensor. |
 | STEP 3A. Inspect the exhaust gas temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 248 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 248 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 248 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine
  • Connect INSITE™ electronic service tool to the vehicle data link
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the exhaust gas temperature reading in INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 (Exhaust Gas Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the exhaust gas temperature sensor.

Guided Step 3A - Inspect the exhaust gas temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the exhaust gas temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 (Exhaust Gas Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 248 active?
YES NO

Refer to the Exhaust Gas Temperature Above Normal troubleshooting symptom chart in Section TS of the GTA8.3 CM558 Service Manual, Bulletin 4021641.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 248 is inactive.

Fault Code 248 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4 LAMP: Shutdown SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the signal return pin of the fuel control valve. | Engine is shutdown or engine will not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558. The module outputs operate relays that power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection.

The Fuel Shutoff Valve is often connected as part of the OEM wiring. Be sure to check terminal connections at the valve.

Refer to Troubleshooting Fault Code t05-254

Last Modified: 06-Jul-2017


Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 277

Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: SPN: 633 FMI: 7 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment | Possible reduced engine performance or shutdown.

Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing in the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Electronic fuel control valve high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve with low internal resistance
  • Electronic fuel control valve or engine harness that has shorted to ground
  • The electronic control valve being physically stuck or unable to move freely.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 277 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
 | STEP 2D. Check the butterfly valve. | Debris found or valve difficult to move?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 277 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 277 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 277 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the fuel control valve. Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the butterfly valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the butterfly valve.

Remove the electronic fuel control valve assembly from the engine fuel supply. Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Inspect the butterfly valve and housing for the following:

  • Debris
  • Mineral buildup
  • Difficult movement of the butterfly valve.

Debris found or valve difficult to move?
YES NO

Remove the blockage and clean the electronic fuel control valve, if possible. If the electronic fuel control valve is damaged or irreparable, replace the entire fuel control valve assembly. Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Codes 277 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 277 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Sep-2007


Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: 254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. | No effect on engine performance.

ECM

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check ECM for a short circuit to ground. | More than 100k ohms?
 | STEP 1D. Recalibrate the ECM. | ECM recalibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Recycle the power to the ECM using the keyswitch.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

Go to 1C

Go to 2A

Guided Step 1C - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Recalibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Recalibrate the ECM.

  • Refer to Procedure 019-032 (ECM Calibration Code) in Section 19.

ECM recalibrated successfully?
YES NO
No Repair

Active fault codes present.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 343 is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Sep-2007


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: 253 SPN: 630 FMI: 12 LAMP: Yellow SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. | No effect on engine performance.

ECM Power-down Error

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can be caused by an internal ECM problem. This can also be caused if battery power is disconnected before power-down sequence is completed. Repairs to the ECM are not possible.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 346 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check the ECM ground. | More than 100k ohms?
 | STEP 1D. Recalibrate the ECM. | Fault Code 346 active after recalibration?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 346 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2B

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM
  • Check the OEM connector as a possible source of an intermittent power supply
  • Make certain the power supply to the ECM is constant and not intermittent.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

Go to 1C

Go to 2A

Guided Step 1C - Check the ECM ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Recalibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Recalibrate the ECM.

  • Refer to Procedure 019-032 (ECM Calibration Code) in Section 19.

Fault Code 346 active after recalibration?
YES NO

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Sep-2007


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: 232 SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine performance, shutdown or lose of engine protection.

Sensor Supply 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor.

Component Location

The sensor supply voltage 5 Volt (1) circuit is contained in the wiring harness.

Shop Talk

The voltage supply for the GTA8.3 engines is broken up into Sensor Supply 1 and Sensor Supply 2.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 352 inactive?
STEP 2. | Check the sensor and sensor supply circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure/temperature sensor and connector pins connected to sensor supply 1. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure/temperature sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-099 (Intake Manifold Absolute Pressure and Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-099 (Intake Manifold Absolute Pressure and Temperature Sensor) in Section 19.

Go to 2B

Go to 4B

Guided Step 2B - Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pressure/temperature sensor from the engine harness.

Action

Inspect the carburetor inlet gas differential pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-099 (Intake Manifold Absolute Pressure and Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-099 (Intake Manifold Absolute Pressure and Temperature Sensor) in Section 19.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM
  • Disconnect the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin to pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A to all other pins in the engine connector A.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A to all pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and the Wiring Diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor supply number 1 pin in the engine harness ECM connector A and ground.

More than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Codes 352 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Sep-2007


Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 354

Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: P106 SPN: 3563 FMI: 3 LAMP: Amber SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the sensor signal pin at the ECM. | Possible reduced performance or shutdown, no engine protection for intake manifold pressure 1.

Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The ECM uses the intake manifold 1 pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the GTA8.3 engine are absolute sensors.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 355 active and Fault Code 354 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 354 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 354 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general techniques refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, replace the sensor or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 (Intake Manifold Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 355 active and Fault Code 354 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES NO

A damaged sensor has been detected

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 (Intake Manifold Pressure Sensor) in Section 19.

No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general techniques refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the intake manifold pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness to all other pins in the engine connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness connector A to all pins in engine harness ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure sensor 5 Volt SUPPLY pin in engine harness connector A and all other pins in the ECM connector A.
  • Measure the resistance between the intake manifold pressure 5 Volt SUPPLY pin in engine harness connector A and all pins in engine harness ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin to pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 354 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Sep-2007


Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 355

Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: 3563 FMI: 4 LAMP: Amber SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage (short to ground) detected on the sensor signal pin at the ECM. | Possible reduced performance or shutdown, no engine protection for intake manifold pressure 1.

Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The ECM uses the intake manifold 1 pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the GTA8.3 engine are absolute sensors.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead
Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 354 active and Fault Code 355 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 355 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 355 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold pressure 1 sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure 1 sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure 1 sensor connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general techniques refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, replace the sensor or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 (Intake Manifold Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure 1 sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure 1 sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake pressure SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 354 active and Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold pressure 1 sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES NO

A damaged sensor has been detected

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 (Intake Manifold Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general techniques refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins.

Repair or replace the harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A SUPPLY pin and the intake manifold pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A SIGNAL pin and the intake manifold pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and all other pins in the connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and all pins in connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to procedure 019-031 (Electronic Control Module) in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced engine performance, shutdown or loss of engine protection.

Sensor Supply 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor.

Component Location

The sensor supply voltage 5 volt (1) circuit is contained in the wiring harness.

Shop Talk

The voltage supply for the GTA8.3 engine is broken up into Sensor Supply 1, and Sensor Supply 2, and is shown as such on the wiring diagram.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM.
  • Disconnect intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin to pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A and all other pins in the engine connector A.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: SPN: 100 FMI: 1 LAMP: Red SRT: | Oil Pressure Low - Data Valid but below normal operational range - most severe level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine is shut down.

Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left side of the engine block, below the ignition control module.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading is correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute. Add atmospheric pressure to the gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if the electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch on
  • Connect a mechanical oil pressure gauge
  • Connect INSITE™ electronic service tool
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Refer to Procedure 007-052 in the Service Manual GTA8.3 CM558, Bulletin 4021641.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 415 is inactive.

Note: If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 415 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If fault code remains active, go to the Low Oil Pressure symptom tree in Section TS.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 14-Sep-2007


SAE J1939 Datalink - Data Erratic, Intermittent, or Incorrect.

FAULT CODE 426

SAE J1939 Datalink - Data Erratic, Intermittent, or Incorrect.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Datalink - Data Erratic, Intermittent, or Incorrect. | No effect on engine performance, electronic service tool or other datalink devices can not communicate with the ECM.

SAE J1939 Datalink Circuit

Circuit Description

The SAE J1939 datalink is a public datalink that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for component location or the wiring diagram for the datalink location.

Shop Talk

The SAE J1939 datalink is a network datalink on which each ECM is attached via a network stub connection. Be sure that the electronic service tool is set up for J1939 communications (if applicable) when using this datalink.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Refer to Procedure 019-165 (Datalink Circuit, SAE J1939) in Section 19 for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Sep-2007


Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | ECM voltage supply approaching a level at which unpredictable operation will occur. Engine will possibly be hard to start.

Battery Supply 1 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in a service panel which is located in the middle of the wiring harness. The service panel is normally not field accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch™ test lead
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5 VDC and 15.0 VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5 VDC and 15.0 VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between 11.5 VDC and 15.0 VDC?
YES NO
No Repair

A malfunctioning battery has been detected.

Replace the malfunctioning battery or batteries. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM harness and connector pins.

  • Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654 for information on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness panel.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the engine harness panel.

  • Open the service panel by loosening the screw clamps
  • Inspect the circuit board and locate the glass fuses
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has been located. Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector A unswitched battery SUPPLY pins and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 VDC and 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector A and the 47 pin OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin to pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level.

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | ECM damage will occur. Possible electrical damage to all other electronic components.

Battery Supply 1 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in a service panel which is located in the middle of the wiring harness. The service panel is normally not field accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch™ test lead
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5 VDC and 15.0 VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM harness and connector pins.

  • Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654 for information on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness panel.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the engine harness panel.

  • Open the service panel by loosening the screw clamps
  • Inspect the circuit board and locate the glass fuses
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has bee located. Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector A unswitched battery SUPPLY pins and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 VDC and 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector A and the 47 pin OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin to pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Battery 2 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P168 SPN: 444 FMI: 18 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine is shutdown.

Battery Supply 2 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in a service panel which is located in the middle of the wiring harness. The service panel is normally not field accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch™ test lead
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 477 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5 VDC and 15.0 VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5 VDC and 15.0 VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 477 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 477 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between 11.5 VDC and 15.0 VDC?
YES NO
No Repair

A malfunctioning battery has been detected.

Replace the malfunctioning battery or batteries. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM harness and connector pins.

  • Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654 for information on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness panel.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the engine harness panel.

  • Open the service panel by loosening the screw clamps
  • Inspect the circuit board and locate the glass fuses
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has bee located. Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector A unswitched battery SUPPLY pins and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 VDC and 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector A and the 47 pin OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin to pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 477 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Battery 2 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level.

FAULT CODE 478

Battery 2 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P168 SPN: 444 FMI: 16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | ECM damage will occur.

Battery Supply 2 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in a service panel which is located in the middle of the wiring harness. The service panel is normally not field accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch™ test lead
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 478 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5 VDC and 15.0 VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 478 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 478 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654, for details on how to perform this procedure.

Relay installed?
YES NO

Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM harness and connector pins.

  • Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654, for information on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness panel.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the engine harness panel.

  • Open the service panel by loosening the screw clamps
  • Inspect the circuit board and locate the glass fuses
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has bee located. Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector A unswitched battery SUPPLY pins and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 VDC and 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector A and the 47 pin OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin to pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 inactive?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 478 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 16 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Possible reduced engine performance.

Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold 1 pressure/temperature sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the intake manifold housing (combination sensor with absolute pressure) on the left front side of the engine.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 488 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Temperature within 3°C [5°F]?
STEP 3. | Check the Intake Manifold 1 Pressure/Temperature Sensor. |
 | STEP 3A. Inspect the Intake Manifold 1 Pressure/Temperature Sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 488 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 488 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading from INSITE™ electronic service tool to the reading from the probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Temperature within 3°C [5°F]?
YES NO

Replace the Intake Manifold 1 Intake Pressure/Temperature Sensor. Refer to Procedure 019-099 (Intake Manifold Absolute Pressure/Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Intake Manifold 1 Pressure/Temperature Sensor.

Guided Step 3A - Inspect the Intake Manifold 1 Pressure/Temperature Sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Intake Manifold 1 Pressure/Temperature Sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 (Deutsch DT Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 (Intake Manifold Air Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES NO

Refer to the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual GTA8.3 CM558, Bulletin 4021641.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 488 is inactive.

Fault Code 488 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Warning SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. The internal signal for the ECM temperature is reading abnormally high voltage. | No effect on engine performance.

CM558

Circuit Description

The CM558 contains an internal air temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM Internal Air Temperature Sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Sep-2007


ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Warning SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The internal signal for the ECM temperature is reading abnormally low voltage. | No effect on engine performance.
CM558/CM2358

Circuit Description

The CM558/CM2358 contains an internal air temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM Internal Air Temperature Sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-698

Last Modified: 24-Sep-2013


Heated Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 752

Heated Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 752 PID: S065 SPN: 724 FMI: 2 LAMP: Amber SRT: | Heated Oxygen Sensor - Data Erratic, Intermittent, or Incorrect. The sensed air fuel ratio does not match the desired air fuel ratio. | Possible reduced engine performance.

Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, which is then used to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

This fault is not typically caused by a failed heated oxygen sensor, but is a result of the engine running very lean or very rich. To determine if the engine is running rich or lean, monitor the heated oxygen sensor compensation in INSITE™ electronic service tool.

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 453, 454, 455, 511, and/or 751 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 752 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 2B. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 3. | Check base engine components. |
 | STEP 3A. Check for an exhaust leak. | Any exhaust leaks?
 | STEP 3B. Check for an intake restriction. | Is intake restriction less than 15 in H 2O?
STEP 4. | Check the engine harness and heated oxygen sensor. |
 | STEP 4A. Check the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
 | STEP 4C. Check the heated oxygen sensor heater supply voltage. | Voltage greater than 12 VDC?
 | STEP 4C-1. Check for an open circuit in the engine harness. |
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4G. Verify oxygen sensor operation. | Did the sensor pass the test?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 752 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 453, 454, 455, 511, and/or 751 active?
YES NO

Troubleshoot any remaining fault codes before proceeding.

 No Repair

Fault Codes 453, 454, 455, 511, or 751 first.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the Fuel System.

Guided Step 2A - Verify secondary fuel pressure.

Conditions

  • Connect all components
  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet
  • Operate the engine at idle with no load
  • Fuel pressure must be between 5 to 6 inches H 2O.

Is pressure correct for the engine family?
YES NO
No Repair

Refer to the Engine Performance Troubleshooting Tree in Section TT.

Go to 2B

Go to 5A

Guided Step 2B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve position feedback and command position while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 (Fuel Control Valve) in Section 19..

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check base engine components.

Guided Step 3A - Check an exhaust leak.

Conditions

  • Turn keyswitch OFF.

Action

Check for an exhaust leak between the exhaust manifold and the heated oxygen sensor.

  • Check all gaskets
  • Check all castings
  • Check all pipe plugs.

Any exhaust leaks?
YES NO

An exhaust leak has been detected.

Repair or replace any exhaust component. Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for intake system restriction.

Conditions

Turn keyswitch OFF.

Action

Check for intake restriction.

  • Measure the intake system restriction with a vacuum/pressure gauge.

Is intake restriction less than 15 in H 2O?

YES NO

Replace the air cleaner element. Refer to Procedure 010-013 (Air Cleaner Assembly (Engine-Mounted) in Section 10 in the Service Manual GTA8.3GC CM558, Bulletin 4021641.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the engine harness and heated oxygen sensor.

Guided Step 4A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness connector B and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Components Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check heated oxygen sensor resistance.

  • Measure the resistance between the heated oxygen sensor heater SUPPLY pin and the heated oxygen sensor heater RETURN pin at the heated oxygen sensor connector.
  • Make sure to check the resistance at room temperature (23°C [73°F] ± 5 degrees).

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to and Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

  • Replace the heated oxygen sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12 VDC?
YES | NO
No Repair | No Repair

Go to 4D

Go to 4C-1

Guided Step 4C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A heated oxygen heater RETURN pin and the engine harness heated oxygen sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to and Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line in the OEM harness.

Check for an open circuit in the OEM switched battery supply to the heated oxygen sensor supply.

Repair the damaged pins. Replace the engine harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 (OEM Wiring Harness) in Section 19.
  • Repair or replace the 10 Ampere heater supply fuse. Refer to 019-198 (Fuse, Harness In-Line) in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4E

Go to 5A

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor adjustment current pin and the engine harness heated oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor SIGNAL pin and the engine harness heated oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor reference RETURN pin and the engine harness heated oxygen sensor connector reference RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current signal or reference return circuit has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor adjustment current pin and the engine block ground.
  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector B and all other pins in the engine harness connector B.
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector B and all other pins in the engine harness connector A.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness connector B.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to and Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the heated oxygen sensor test using the INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to activate the heated oxygen sensor test. Follow the directions given by INSITE™ electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

  • Replace the heated oxygen sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 752 is inactive.

Fault Code 752 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: SPN: 105 FMI: 10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change | Engine is shutdown.

Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the left bank front air intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

This feature provides protection for the engine when a rapid increase in intake manifold temperature occurs. Intake manifold temperature rapid rise monitors the change in the intake manifold 1 temperature sensor over a period of time and then logs a fault and requests a derate or shut down due to excessive temperature change.

Possible causes of this fault include:

  • Restricted air flow through the charge air cooler
  • LTA cooling circuit temperature too high
  • Damaged valves
  • An air intake manifold overpressure event
  • High turbocharger compressor outlet temperature.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 783 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 1 temperature sensor reading on the INSITE™ service tool monitor screen to the reading from the temperature probe. NOTE: If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

A damaged intake manifold 1 temperature sensor has been detected.

Replace the intake manifold 1 temperature sensor.

Refer to Procedure 019-059 (Intake Manifold Air Temperature Sensor) in Section 19.

Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 783 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Sep-2007


Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1776

Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1776 PID: SPN: 2634 FMI: 3 LAMP: Amber SRT: | Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Short to ground detected on power relay driver command of the ECM connector B. | Engine will possibly not start or will possibly be hard to start.
Power Relay Driver Circuit

Circuit Description

The ECM uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit.

Component Location

The power relay driver circuit is located in the engine harness.

Shop Talk

The power relay driver circuit can be used by the OEM control panel, so issues with the panel can activate this fault code.

Refer to Troubleshooting Fault Code t05-1776

Last Modified: 24-Sep-2013


Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1777

Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1777 PID: SPN: 2634 FMI: 4 LAMP: Amber SRT: | Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Short to ground detected on power relay driver circuit pin 36 of the ECM connector B. | Engine is shutdown.
Power Relay Driver Circuit

Circuit Description

The ECM uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit.

Component Location

The power relay driver circuit is located in the engine harness.

Shop Talk

The power relay driver circuit can be used by the OEM control panel, so issues with the panel can activate this fault code.

Refer to Troubleshooting Fault Code t05-1777

Last Modified: 24-Sep-2013


Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2188

Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2188 PID: S151 SPN: 724 FMI: 3 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source. Open circuit detected on the heater return pin at the ECM or no heater supply voltage. | Possible reduced engine performance.

Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, which is then used to adjust fueling when operating in closed loop.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed-loop operation of the engine.

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 2188 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the heated oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2188 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2188 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2188 active?
YES | NO
No Repair | No Repair

Go to 2A

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 (Amp Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the heated oxygen sensor heater SUPPLY voltage from the engine harness connector to chassis ground.

Note: See Shop Talk.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the heated oxygen sensor SUPPLY line. Check the OEM voltage SUPPLY and heated oxygen sensor fuse. Repair or replace the heated oxygen heater line.

Refer to the OEM troubleshooting and repair manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the heated oxygen sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the heated oxygen sensor heater positive and the heated oxygen sensor heater negative at the heated oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the heated oxygen sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2188 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 (Deutsch HDP20 and HDP30 Connector Series) in Section 19.
  • Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the heated oxygen sensor heater negative pin on the heated oxygen sensor engine harness connector to the heated oxygen sensor heater negative pin on the ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the heated oxygen heater negative pin in engine harness connector A to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2188 is inactive.

Fault Code 2188 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Nov-2007


Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2192

Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2192 PID: S151 SPN: 724 FMI: 4 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Heater voltage to heated oxygen sensor low. | Possible reduced engine performance.

Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, which is then used to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2192 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 2192 active?
 | STEP 2C. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage to engine harness. | 11 to 14-VDC?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2192 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2192 active?
YES | NO
No Repair | No Repair

Go to 2A

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Components Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-203 (Amp Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2192 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor form the engine harness
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Check heated oxygen sensor resistance.

  • Measure the resistance between the heated oxygen sensor heater SUPPLY pin and the heated oxygen sensor heater RETURN pin at the heated oxygen sensor connector.
  • Make sure to check the resistance at room temperature 23°C [73°F] ± 5 degrees.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM
  • Disconnect the engine harness from the OEM harness at the 47 pin OEM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Components Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 (Deutsch HDP20 and HDP30 Connector Series) in Section 19.
  • Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage to engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM harness at the 47 pin OEM connector
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the SUPPLY voltage to the heated oxygen heater SUPPLY pin in the 47 pin connector, OEM side.

11 to 14-VDC?
YES NO
No Repair

  • Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Note: Make sure that the 10 Ampere fuse is not blown in the OEM harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM
  • Disconnect the engine harness from the heated oxygen sensor
  • Disconnect the engine harness from the OEM harness at the 47 pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance from the heated oxygen heater SUPPLY pin at the 47 pin OEM connector of the engine harness to the heated oxygen heater SUPPLY pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference SIGNAL pin in the engine harness ECM connector to the heated oxygen reference SIGNAL pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference RETURN pin in the engine harness ECM connector to the heated oxygen reference RETURN pin in the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 (Amp Connector Series) in Section 19.
  • Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM
  • Disconnect the 47 pin OEM connector from the engine harness
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the heated oxygen heater SUPPLY pin in the engine harness sensor connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 (Amp Connector Series) in Section 19.
  • Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the 47 pin connector from the OEM harness
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor SUPPLY pin at the 47 pin OEM connector of the engine harness and all other pins in the 47 pin connector.
  • Measure the resistance between the heated oxygen sensor SUPPLY pin at the 47 pin OEM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the heated oxygen sensor supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2192 is inactive.

Fault Code 2192 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: SPN: 630 FMI: 31 LAMP: Amber SRT: | Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists. Internal ECM error. | Possible engine shutdown, loss of performance or engine will possibly not start.

ECM

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 2217 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check ECM for a short circuit to ground. | More than 100k ohms?
 | STEP 1D. Recalibrate the ECM. | ECM recalibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2217 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Recycle the power to the ECM using the keyswitch.
  • Use INSITE™ electronic service tool to check for fault codes.

Fault Code 2217 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

Go to 1C

Go to 2A

Guided Step 1C - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Recalibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Recalibrate the ECM.

  • Refer to Procedure 019-032 (ECM Calibration Code) in Section 19.

ECM recalibrated successfully?
YES NO
No Repair

Active fault codes present.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 2217 is inactive.

Fault Code 2217 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Sep-2007


Heated Oxygen Sensor - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2219

Heated Oxygen Sensor - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2219 PID: S65 SPN: 724 FMI: 16 LAMP: Amber SRT: | Heated Oxygen Sensor - Data Valid but Above Normal Operational Range - Moderately Severe Level. The measured air-to-fuel ratio is greater than the desired calculated air-to-fuel ratio. | Possible reduced engine performance.

Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, which is then used to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

The ECM will read an in-range high fault if the engine is running lean or the heated oxygen sensor or heated oxygen sensor circuit has failed. An exhaust leak can cause this fault by not providing enough back pressure to the heated oxygen sensor. Also, If there are any intake leaks after the throttle actuator, the engine can also run lean due to low fuel pressure problems which can cause this fault to activate. If this troubleshooting tree does not fix the problem, the ECM can be the fault.

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 752 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 2. | Check the engine harness and heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 3. | Check the fuel pressure. |
 | STEP 3A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 3B. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 4. | Check the intake and exhaust system |
 | STEP 4A. Check the intake and exhaust system for air leaks. | Air leaks?
 | STEP 4B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2219 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 active?
YES | NO
No Repair | No Repair

Fault Code 752

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the engine harness and heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness connector B and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor adjustment current pin and the engine harness heated oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor SIGNAL pin and the engine harness heated oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor RETURN pin and the engine harness heated oxygen sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current, SIGNAL or RETURN circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector B and all other pins in the ECM connector B
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector B and all other pins in the ECM connector A
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the ECM connector B.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 3A

Guided Step 3 - Check the fuel pressure.

Guided Step 3A - Verify secondary fuel pressure.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet.
  • Operate the engine at idle with no load.
  • Fuel pressure must be between 5 to 6 in H 2O.

Is pressure correct for the engine family?
YES NO
No Repair

For more troubleshooting details on low fuel pressure issues, go to Fault Code 2119.

Go to 4A

Go to 5A

Guided Step 3B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel control valve position feedback and commanded position while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO
No Repair

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 4A

Go to 5A

Guided Step 4 - Check for intake and exhaust systems.

Guided Step 4A - Check the intake and exhaust system for air leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the intake and exhaust system for air leaks.

Refer to Procedure 010-024 (Air Leaks, Air Intake and Exhaust Systems) in Section 10 in the Service Manual GTA8.3 CM558, Bulletin 4021641.

Air Leaks?
YES NO

Follow the troubleshooting steps in Procedure 010-024 (Air Leaks, Air Intake and Exhaust Systems) in Section 10 in the Service Manual GTA8.3 CM558, Bulletin 4021641.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Heated Oxygen Sensor - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 2221

Heated Oxygen Sensor - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2221 PID: S65 SPN: 724 FMI: 18 LAMP: Amber SRT: | Heated Oxygen Sensor - Data Valid but Below Normal Operational Range - Moderately Severe Level. The measured air-to-fuel ratio is lower than the desired calculated air-to-fuel ratio. | Possible reduced engine performance.

Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, which is then used to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

The ECM will read an in-range low fault if the engine is running rich or the heated oxygen sensor or heated oxygen sensor circuit has failed. Excessive exhaust back pressure can cause this fault by creating a lower partial pressure of oxygen to form at the heated oxygen sensor. If the fuel control valve is stuck open the engine will not burn all the gas that is ingested, causing it to run rich. If the heated oxygen sensor heater supply has shorted to ground or has a open circuit, then the sensor will read a lower than normal exhaust oxygen value. Also, if there is an ignition misfire, the unburned fuel will cause the sensor to read a lower than normal exhaust oxygen value.

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 752 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 2. | Check the ignition system. |
 | STEP 2A. Check for ignition system faults. | Ignition system faults?
STEP 3. | Check the engine harness and heated oxygen sensor. |
 | STEP 3A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the heated oxygen sensor heater supply voltage. | Voltage Greater than 12-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 4. | Check the fuel control valve . |
 | STEP 4A. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 5. | Check the exhaust system |
 | STEP 5A. Check for high exhaust back pressure. | Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2219 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 active?
YES | NO
No Repair | No Repair

Fault Code 752

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the ignition system.

Guided Step 2A - Check for ignition system faults.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch on.

Action

Check for ignition system faults.

  • Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654 for instructions on how to check for ignition system faults.

Ignition system faults?
YES NO

Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654, for instructions on how to troubleshoot the ignition system.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for ignition system misfire.

Conditions

  • Turn keyswitch on.

Action

Check for ignition system misfire.

  • Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654 for instructions on how to check for ignition system spark voltage counts (CAVGs).

Ignition system misfire?
YES NO

Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654, for instructions on how to troubleshoot the ignition system.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the engine harness and heated oxygen sensor.

Guided Step 3A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor adjustment current pin and engine block ground.
  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 6A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector B and all other pins in the ECM connector B
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector B and all other pins in the ECM connector A
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the ECM connector B.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES NO
No Repair

An open circuit or shorted to ground has been detected on the heated oxygen sensor supply line in the engine harness. An open circuit in the heated oxygen sensor return line can also be a possible fail mode.

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 4A

Guided Step 4 - Check the fuel control valve.

Guided Step 4A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve commanded position and position feedback while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the exhaust systems.

Guided Step 5A - Check for high exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for higher than specified exhaust back pressure.

  • Check the exhaust back pressure by installing a pressure gauge into the exhaust system just past the turbocharger outlet.

Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
YES NO
No Repair

Refer to the Service Manual GTA8.3 CM558, Bulletin 4021641.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: SPN: 633 FMI: 31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. | Possible reduced engine performance.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing in the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Electronic fuel control valve high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve with low internal resistance
  • Electronic fuel control valve or engine harness that has shorted to ground.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty.

Ignition system faults?

  • Yes: Reference the Master Repair Manual GTA8.3 CM558/CM2358 Panel System, Bulletin 4021654 for instructions on how to troubleshoot the ignition system. Go to Step 6A.
  • No: Go to Step 2B.
Refer to Troubleshooting Fault Code t05-2311

Last Modified: 24-Sep-2013


ECM Internal Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2544

ECM Internal Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2544 PID: SPN: 1136 FMI: 0 LAMP: SRT: | ECM Internal Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. The ECM internal temperature has exceeded the high shutdown threshold. | Engine is shutdown.
Electronic Control Module (ECM)

Circuit Description

The CM558/CM2358 contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-2544

Last Modified: 24-Sep-2013


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | Engine will possibly not start.

Unacknowledged Fault

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location depends on the OEM. Refer to the OEM troubleshooting and repair manual for component location.

Shop Talk

This fault code occurs as a result of other fault codes becoming active or inactive. Fault Code 2661 will remain active until reset by the operator. Fault Code 2661 is designed to latch onto other fault codes that have become active or have gone inactive. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

This fault code is generated by red/shutdown lamp faults. Other fault codes need to be corrected before acknowledging this fault code, otherwise this fault code will become active again after a calibrated period of time, if other fault codes are still active.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2661 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2661 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location if the fault code will not reset.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Sep-2007


Exhaust Gas Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2737

Exhaust Gas Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2737 PID: SPN: 173 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature - Data Valid but Above Normal Operational Range - Most Severe Level | Engine is shutdown.

Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The ECM uses the exhaust gas temperature 1 sensor for engine protection purposes.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold, below the turbocharger.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2737 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the exhaust gas temperature sensor. |
 | STEP 3A. Inspect the exhaust gas temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2737 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2737 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2737 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the exhaust gas temperature reading on the INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 (Exhaust Gas Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the exhaust gas temperature sensor.

Guided Step 3A - Inspect the exhaust gas temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the exhaust gas temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 (Exhaust Gas Temperature Sensor) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2737 active?
YES NO

Refer to the Exhaust Gas Temperature Above Normal troubleshooting symptom chart in Section TS of the GTA8.3 CM558 Service Manual, Bulletin 4021641.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 2737 is inactive.

Fault Code 2737 active?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: 110 SPN: 110 FMI: 18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Moderately Severe Level. Engine coolant temperature is below normal operating temperature limits. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is below a calibration limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when the coolant temperature is detected to be within the normal operating temperature limits.

Shop Talk

If this fault indicates that coolant temperature is below a calibration limit set in the ECM. Reference the Engine Coolant Temperature Below Normal troubleshooting symptom tree in the GTA8.3 CM558/CM2358 Service Manual, Bulletin 4021641.

Refer to Troubleshooting Fault Code t05-2789

Last Modified: 24-Sep-2013


Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 2793

Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2793 PID: 110 SPN: 110 FMI: 18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Most Severe Level. Engine coolant temperature is below normal operating temperature limits. | Engine is shutdown.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is below a calibration limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when the coolant temperature is detected to be within the normal operating temperature limits.

Shop Talk

If this fault indicates that coolant temperature is below the minimum limit set in the ECM. Reference the Engine Coolant Temperature Below Normal troubleshooting symptom tree in the GTA8.3 CM558/CM2358 Service Manual, Bulletin 4021641.

Refer to Troubleshooting Fault Code t05-2793

Last Modified: 11-Jun-2014


Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2864

Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2864 PID: SPN: 632 FMI: 3 LAMP: Red SRT: | Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the signal return pin of the fuel control valve. | Loss of engine protection.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558/CM2358. The module outputs operate relays that power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24 VDC supplies and one ground connection.

The Fuel Shutoff Valve is often connected as part of the OEM wiring. Be sure to check terminal connections at the valve.

Refer to Troubleshooting Fault Code t05-2864

Last Modified: 06-Jun-2014


Power Relay Driver Diagnostics has Detected an Error - Condition Exists

FAULT CODE 2865

Power Relay Driver Diagnostics has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2865 PID: SPN: 2634 FMI: 31 LAMP: Amber SRT: | Power Relay Driver Diagnostics has Detected an Error - Condition Exists. | Possible reduced engine performance, engine possibly to hard to start or will not start.

Power Relay Driver Circuit

Circuit Description

The ECM uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit.

Component Location

The power relay power circuit is located in the engine harness.

Shop Talk

The power relay power circuit can be used by the OEM control panel, so issues within the panel can activate this fault code.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female AMP®/Cannon® test lead
Part Number 3823994 - female Deutsch™ test lead
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any Issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2865 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-207 (Deutsch HD10 Connector Series) in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from power relay driver command pin on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO

  • Repair the OEM harness. Refer to manufacturer's instructions.
  • Replace the OEM harness. Refer to manufacturer's instructions.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the OEM panel and relays.

Conditions

  • Key switch in the OFF position.

Action

Check the OEM control panel and relays.

  • Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

Any issues?
YES NO

  • Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654, for instruction on how to resolve the issue.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

No damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Disconnect the harness connector B from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from power relay driver command pin in the ECM connector B to all of the other pins in the connector B.

More than 100k ohms?
YES NO

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 (Amp Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Disconnect the harness connector B from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from power relay driver command pin in the ECM connector B to the engine block ground.

More than 100k ohms?
YES NO

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 (Amp Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components
  • Start the engine and let idle for 1 minute.

Fault Code 2865 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO

Troubleshoot any remaining active fault codes.

Troubleshoot any remaining active fault codes.

Appropriate troubleshooting chart

Repair complete

Last Modified: 05-Nov-2007


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2866

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2866 PID: SPN: 1422 FMI: 3 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No effect on engine performance.

Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

The electronic fuel control valve communicates its position by varying a resistance internal to the actuator. This resistance is sent to the ECM, which uses the resistance to calculate the valve position as a percentage between o and 100.

Component Location

The electronic fuel control valve is located fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The electronic fuel control valve is not repairable, so if the valve is determined to be failed after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2866 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 2866 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2866 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2866 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2866 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2866 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Nov-2007


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2867

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2867 PID: SPN: 1422 FMI: 4 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No effect on engine performance.

Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

The electronic fuel control valve communicates its position by varying a resistance internal to the actuator. This resistance is sent to the ECM, which uses the resistance to calculate the valve position as a percentage between 0 and 100.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The electronic fuel control valve is not repairable, so if the valve is determined to be failed after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2867 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 2867 becomes active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2867 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2867 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the ECM.

Call for pre-authorization.

  • Refer to Procedure 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2867 becomes active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Replace the electronic fuel control valve.

Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2867 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Nov-2007


Intake Manifold Pressure 1 Sensor - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2995

Intake Manifold Pressure 1 Sensor - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2995 PID: SPN: 3563 FMI: 0 LAMP: Red SRT: | Intake Manifold Pressure 1 Sensor - Data Valid but Above Normal Operational Range - Most Severe Level. Intake manifold air pressure signal indicates intake manifold pressure above engine protection critical limit. | Engine is shutdown.
Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature and pressure of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

This fault can be activated by the following issues:

  • Sensor failures
  • Wiring harness failed high
  • Intake manifold overpressure event
  • Failure in the control system.
Refer to Troubleshooting Fault Code t05-2995

Last Modified: 24-Sep-2013


Intake Manifold Pressure 1 - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2996

Intake Manifold Pressure 1 - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2996 PID: SPN: 3563 FMI: 16 LAMP: Amber SRT: | Intake Manifold Pressure 1 - Data Valid but Above Normal Operational Range - Moderately Severe Level. Intake manifold air pressure signal indicates intake manifold pressure above engine protection normal limit. | Possible reduced engine performance.

Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature and pressure of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

This fault can be activated by the following issues:

  • Sensor failures
  • Wiring harness failed high
  • Failure in the control system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2996 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
STEP 3. | Check the Intake Manifold Pressure/Temperature Sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2996 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2996 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2996 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.
  • Start the INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
YES NO

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 (Intake Manifold Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 (Deutsch DT Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the sensor. Refer to Procedure 019-061 (Intake Manifold Pressure Sensor) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2996 active?
YES NO

Refer to the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS in the Service Manual GTA8.3 CM558, Bulletin 4021641.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2996 is inactive.

Fault Code 2996 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


Heated Oxygen Sensor - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 2997

Heated Oxygen Sensor - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2997 PID: SPN: 724 FMI: 1 LAMP: Red SRT: | Heated Oxygen Sensor - Data Valid but Below Normal Operational Range - Most Severe Level. The measured air-to-fuel ratio is lower than the desired calculated air-to-fuel ratio. | Engine is shutdown.

Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, which is then used to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

The ECM will read an out of range low fault if the engine is running rich or the heated oxygen sensor or heated oxygen sensor circuit has failed. This fault can cause engine damage, so the engine will shutdown immediately if this fault activates, in order to protect the engine. If the fuel control valve is stuck open the engine will not burn all the gas that is ingested, causing it to run rich. If the heated oxygen sensor heater supply has shorted to ground or has a open circuit, the sensor will read a lower than normal exhaust oxygen value.

Also, if there is an ignition misfire, the unburned fuel will cause the sensor to read a lower than normal exhaust oxygen value.

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 752 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2997 inactive?
STEP 2. | Check the ignition system |
 | STEP 2A. Check the ignition system for faults. | Ignition system faults?
 | STEP 2B. Check for ignition system misfires. | Ignition system misfire?
STEP 3. | Check the engine harness and heated oxygen sensor. |
 | STEP 3A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the heated oxygen sensor heater supply voltage. | Voltage Greater than 12 VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2997 inactive?
STEP 4. | Check the fuel control valve. |
 | STEP 4A. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 5. | Check the exhaust system |
 | STEP 5A. Check for high exhaust back pressure. | Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2997 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 active?
YES | NO
No Repair | No Repair

Fault Code 752

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2997 inactive?
YES | NO
No Repair | No Repair

Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Go to 2A

Guided Step 2 - Check the ignition system.

Guided Step 2A - Check for ignition system faults.

Conditions

  • Turn keyswitch on.

Action

Check for ignition system faults.

  • Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654.

Ignition system faults?
YES NO

  • Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654, for instruction on how to troubleshoot the ignition system.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for ignition system misfire.

Conditions

  • Turn keyswitch on.

Action

Check for ignition system misfire.

  • Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654, for instruction on how to check for ignition system spark voltage counts (CAVGs).

Ignition system misfire?
YES NO

  • Refer to the Master Repair Manual GTA8.3GC CM558 Panel System, Bulletin 4021654, for instruction on how to troubleshoot the ignition system.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the engine harness and heated oxygen sensor.

Guided Step 3A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques, refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 (Heated Oxygen Sensor) in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor adjustment current pin and engine block ground.
  • Measure the resistance between the engine harness ECM connector B heated oxygen sensor SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector B and all other pins in the ECM connector B
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector B and all other pins in the ECM connector A
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the ECM connector B.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and a Wiring Diagram) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12 VDC?
YES NO
No Repair

An open circuit or shorted to ground has been detected on the heated oxygen sensor supply line in the engine harness. An open circuit in the heated oxygen sensor return line can also be a possible fail mode.

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2997 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 4A

Guided Step 4 - Check the fuel control valve.

Guided Step 4A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve commanded position and position feedback while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 (Fuel Control Valve) in Section 19.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the exhaust systems.

Guided Step 5A - Check for high exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for higher than specified exhaust back pressure.

  • Check the exhaust back pressure by installing a pressure gauge into the exhaust system just past the turbocharger outlet.
  • Refer to Procedure 011-009 (Exhaust Restriction) in the Service Manual GTA8.3 CM558, Bulletin 4021641.

Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
YES NO
No Repair

Follow the troubleshooting steps in Procedure 011-009 (Exhaust Restriction) in the Service Manual GTA8.3 CM558, Bulletin 4021641.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2997 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Nov-2007


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


INDEX
29-fc121.htm

29-fc135.htm

29-fc141.htm

29-fc142.htm

29-fc143.htm

29-fc144.htm

29-fc145.htm

29-fc146.htm

29-fc151.htm

29-fc153.htm

29-fc154.htm

29-fc155.htm

29-fc187.htm

29-fc227.htm

29-fc234.htm

29-fc246.htm

29-fc247.htm

29-fc248.htm

29-fc254.htm

29-fc277.htm

29-fc343.htm

29-fc346.htm

29-fc352.htm

29-fc354.htm

29-fc355.htm

29-fc386.htm

29-fc415.htm

29-fc426.htm

29-fc441.htm

29-fc442.htm

29-fc477.htm

29-fc478.htm

29-fc488.htm

29-fc697.htm

29-fc698.htm

29-fc752.htm

29-fc783.htm

29-fc1776.htm

29-fc1777.htm

29-fc2188.htm

29-fc2192.htm

29-fc2217.htm

29-fc2219.htm

29-fc2221.htm

29-fc2311.htm

29-fc2544.htm

29-fc2661.htm

29-fc2737.htm

29-fc2789.htm

29-fc2793.htm

29-fc2864.htm

29-fc2865.htm

29-fc2866.htm

29-fc2867.htm

29-fc2995.htm

29-fc2996.htm

29-fc2997.htm