KTA19, G855 CM558 G Drive, KTA19GC CM558,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Magnetic Crankshaft Speed/Position Sensor Lost One Of Two Signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position Sensor Lost One Of Two Signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Amber SRT: | Engine Magnetic Crankshaft Speed/Position Sensor Lost One Of Two Signals - Abnormal Rate of Change. Invalid engine speed signal detected on the engine position sensor SIGNAL pins at the ECM connector. | Possible reduced engine performance, shutdown, or loss of engine protection.
Engine Speed Sensor Circuit

Circuit Description

The engine magnetic crankshaft speed/position sensor (ESS) monitors the engine speed, then passes this information to the ECM through the engine harness.

Component Location

The ESS is located on the flywheel housing on the left side of the engine.

Shop Talk

The ESS is a magnetic sensor and senses the ring gear teeth on the flywheel to determine engine speed.

Refer to Troubleshooting Fault Code t05-121.

Last Modified: 21-Dec-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Amber SRT: | Engine Oil Rifle Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the engine oil pressure sensor pin at the ECM. | No engine protection for engine oil rifle pressure 1.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the block, below the ignition control module.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault goes inactive.
  • Engines operating in altitudes above 5000 feet with auxiliary lubricating oil filtering devices can experience low lubricating oil pressure faults at idle conditions.
Refer to Troubleshooting Fault Code t05-135.

Last Modified: 08-Dec-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the engine oil pressure sensor pin at the ECM. | No engine protection for engine oil rifle pressure 1.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The lubricating oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the block, below the ignition control module.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault goes inactive.
  • Engines operating in altitudes above 5000 feet with auxiliary lubricating oil filtering devices can experience low lubricating oil pressure faults at idle conditions.
Refer to Troubleshooting Fault Code t05-141.

Last Modified: 08-Dec-2010


Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 142

Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 142 PID: P100 SPN: 100 FMI: 16 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Pressure is above the engine protection limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the block, below the ignition control module.

Shop Talk

Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault goes inactive.

Refer to Troubleshooting Fault Code t05-142.

Last Modified: 04-Jan-2011


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the block, below the ignition control module.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low a speed, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.
Refer to Troubleshooting Fault Code t05-143.

Last Modified: 31-Dec-2010


Engine Coolant Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine coolant temperature sensor pin at the ECM. | Possible reduced engine performance. No engine protection for coolant temperature 1.
Engine Coolant Temperature Sensor 1 Circuit

Circuit Description

The ECM uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault code can log in extremely cold weather.
Refer to Troubleshooting Fault Code t05-144.

Last Modified: 04-Jan-2011


Engine Coolant Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine performance. No engine protection for coolant temperature 1.
Engine Coolant Temperature Sensor 1 Circuit

Circuit Description

The ECM uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145.

Last Modified: 04-Jan-2011


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High coolant temperature warning. | Possible reduced engine performance.
Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The ECM uses the coolant temperature 1 sensor for engine protection purposes.

Component Location

The coolant temperature 1 sensor is located on the right side of the block, in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-146.

Last Modified: 04-Jan-2011


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. High coolant temperature critical. | Engine is shutdown.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The ECM uses the coolant temperature 1 sensor for engine protection purposes.

Component Location

The coolant temperature 1 sensor is located on the right side of the block, in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

The engine protection shutdown for the coolant temperature is a customer feature and will only be enabled at the customer's request. This sensor will deactivate the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-151.

Last Modified: 04-Jan-2011


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold air temperature sensor pin at the ECM. | Possible reduced engine performance. No engine protection for intake manifold temperature 1.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 04-Jan-2011


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Intake Manifold Temperature Sensor Circuit - Shorted Low. | Possible reduced engine performance. No engine protection for intake manifold temperature 1.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 04-Jan-2011


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates left front intake manifold temperature above engine protection critical limit. | Engine is shutdown.
Intake Manifold 1 Temperature Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will only be enabled at the customer's request.

Refer to Troubleshooting Fault Code t05-155.

Last Modified: 04-Jan-2011


Electronic Throttle Control Actuator - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 PID: None SPN: 3464 FMI: 7 LAMP: Red SRT: None | Electronic Throttle Control Actuator - Mechanical System Not Responding Properly or Out of Adjustment. | Engine is shut down.
Electronic Throttle Control Actuator Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electronic throttle control actuator. The electronic throttle control actuator is grounded in the ECM. The ECM varies the current to this valve to provide the correct air/fuel mixture flow to the engine based on engine operating conditions. The electronic throttle control actuator is a normally closed valve.

Component Location

The electronic throttle control actuator is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E.

Shop Talk

NOTE: The voltage is checked within 90 seconds after turning the keyswitch ON. The battery conservation relay is commanded OFF after 90 seconds if the engine is not operating.

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Electronic throttle control actuator high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connector or pins
  • Electronic throttle control actuator with low internal resistance
  • Electronic throttle control actuator or engine harness that has shorted to ground
  • The control valve being physically stuck or unable to move freely
  • Low power supply to actuator driver.

If an intermittent electrical circuit problem of the electronic throttle control actuator circuit exists, it is possible for the fault code to become active, and then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty.

Refer to Troubleshooting Fault Code t05-177.

Last Modified: 03-Oct-2014


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 3510 FMI: 4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for the engine oil rifle pressure sensor.

Component Location

The sensor supply 2 circuit is contained in the wiring harness.

Shop Talk

The voltage supply on the KTA19GC CM558/CM2358 engine is broken up into sensor supply 1 and sensor supply 2.

Refer to Troubleshooting Fault Code t05-187.

Last Modified: 24-Sep-2013


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: 232 SPN: 3510 FMI: 3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on sensor supply number 2 circuit. | Possible reduced engine performance, shutdown, or loss of engine protection.
Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 3 and intake manifold 4 temperature sensors and any optional OEM sensors.

Component Location

The sensor supply voltage 5 volt (2) circuit is contained in the wiring harness.

Shop Talk

The voltage supply on the KTA19GC engine voltage supplies are broken up into supply 1 and supply 2.

Refer to Troubleshooting Fault Code t05-227.

Last Modified: 04-Jan-2011


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit, | Engine is shut down.
Engine Magnetic Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine magnetic crankshaft speed/position sensor (ESS) provides engine speed information to the ECM through the engine harness.

Component Location

The ESS is located on the flywheel housing on the left side of the engine under the air filter bracket.

Shop Talk

Possible causes of this fault code include:

  • Overspeed
  • Engine governor malfunction
  • Tampering of the speed sensor
  • ESS malfunction.

Make sure the correct operation conditions are followed when operating the engine as described in the operation and maintenance manual. To check for valid overspeed, check the fault code snapshot information for the speed reached. This fault will activate at 1980 rpm.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 04-Jan-2011


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: SPN: 232 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on sensor supply voltage +5-VDC (3). | Possible reduced performance.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

Sensor supply voltage 3 circuit consists of a +14 volt supply.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The sensor supply 3 pins are not populated in the present wiring harness. If this fault occurs, the cause is most likely dirty/damaged pins in the ECM connector.

When testing the resistance of the wires, make sure the ECM and OEM connectors are disconnected.

The sensor supply 3 fault code indicates an internal issue with the ECM or wiring harness.

Refer to Troubleshooting Fault Code t05-238.

Last Modified: 03-Oct-2014


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: FMI: 3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 3 circuit. | Possible reduced performance.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

Sensor supply voltage 3 circuit consists of a +14 volt supply.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The sensor supply 3 pins are not populated in the present wiring harness. If this fault occurs, the cause is most likely dirty/damaged pins in the ECM connector.

When testing the resistance of the wires, make sure the ECM and OEM connectors are disconnected.

Sensor supply 3 fault code indicates an internal issue with the ECM or wiring harness.

Refer to Troubleshooting Fault Code t05-239.

Last Modified: 03-Oct-2014


Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 244

Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 244 PID: S238 SPN: 623 FMI: 4 LAMP: Amber SRT: 00-313 | Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source. Short to ground detected on diagnostic lamp pin-31 of the engine interface connector A. | Red lamp will not light and ability lost to send shut down request to customer.
Red Stop Lamp Circuit

Circuit Description

The ECM uses the red STOP lamp driver to send a shut down signal and/or the customer's red lamp. The ECM also uses the diagnostic lamp (red & WARNING) to flash out active fault codes.

Component Location

The diagnostic lamp is an OEM component that is located on the OEM control panel.

Shop Talk

The ECM energizes a relay to send a shut down signal and/or light the customer's red lamp. The red lamp STOP relay also provides a signal and return to the fuel shutoff (FSO), and also a signal for the customer shut down status.

Refer to Troubleshooting Fault Code t05-244.

Last Modified: 04-Jan-2011


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the signal RETURN pin of the fuel control valve. | Engine is shutdown and engine will not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the electronic control module (ECM). The ECM outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two + 24-VDC supplies, and one ground connection.

The fuel shutoff valve is often connected as part of the OEM wiring. Make sure to check terminal connections at the valve.

Refer to Troubleshooting Fault Code t05-254.

Last Modified: 04-Jan-2011


Electronic Fuel Injection Valve - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 277

Electronic Fuel Injection Valve - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: SPN: 633 FMI: 7 LAMP: Amber SRT: | Electronic Fuel Injection Valve - Mechanical System Not Responding Properly or Out of Adjustment. | Possible reduced engine performance or shutdown.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the engine electronic fuel valve. The engine electronic fuel valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The engine electronic fuel valve is a normally open valve.

Component Location

The engine electronic fuel valve is located in the fuel supply plumbing on the front right side of the engine, after the secondary fuel pressure regulator. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components.

Possible causes of this fault code include:

  • Engine electronic fuel valve 1 high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Engine electronic fuel valve 1 low internal resistance
  • Engine electronic fuel valve 1 or engine harness shorted to ground
  • Engine electronic fuel valve 1 physically stuck or unable to move freely.

If an intermittent electrical circuit problem of the engine electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioned.

Refer to Troubleshooting Fault Code t05-277.

Last Modified: 04-Jan-2011


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: 254 SPN: 629 FMI: 12 LAMP: Amber SRT: | Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. Internal ECM error. | No effect on engine performance.
Electronic Control Module

Circuit Description

The electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the left side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-343.

Last Modified: 04-Jan-2011


Engine Control Module Calibration Memory Software - Bad Intelliget Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelliget Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: 253 SPN: 630 FMI: 12 LAMP: Amber SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. ECM software error. | No effect on engine performance.
Electronic Control Module

Circuit Description

The electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the left side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can be caused by an internal ECM problem. This can also be caused if battery power is disconnected before the power-down sequence is completed. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-346.

Last Modified: 04-Jan-2011


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: 232 SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine performance, shutdown, or loss of engine protection.
Sensor Supply 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor.

Component Location

The sensor supply voltage 5 volt (1) circuit is contained in the wiring harness.

Shop Talk

The sensor voltage supplies for the KTA19GC engines are broken up into 1 and 2.

Not all applications are supplied with a Cummins® customer interface box (CIB). For applications that have an OEM supplied CIB, refer to the OEM service manual.

Refer to Troubleshooting Fault Code t05-352.

Last Modified: 04-Jan-2011


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 354

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: P106 SPN: 3563 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the sensor SIGNAL pin at the ECM. | Possible reduced performance or shutdown.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine.

Shop Talk

The intake manifold pressure/temperature sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the KTA19GC engines are absolute sensors.

Refer to Troubleshooting Fault Code t05-354.

Last Modified: 04-Jan-2011


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 355

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: 3563 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage (short-to-ground) detected on the sensor SIGNAL pin at the ECM. | Possible reduced performance or shutdown, no engine protection for intake manifold 1 pressure.
Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the KTA19GC engines are absolute sensors.

Refer to Troubleshooting Fault Code t05-355.

Last Modified: 04-Jan-2011


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on sensor supply 1 circuit. | Possible reduced performance, shutdown, or loss of engine protection.
Sensor Supply 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor.

Component Location

The sensor supply circuit 1 is contained in the engine wiring harness.

Shop Talk

The voltage supplies for the KTA19GC engines are broken up into 1 and 2, and are shown as such on the wiring diagram. Not all applications are supplied with a Cummins® customer interface box (CIB). For applications that have an OEM supplied CIB, refer to the OEM service manual.

Refer to Troubleshooting Fault Code t05-386.

Last Modified: 27-Jan-2011


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: SPN: 100 FMI: 1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Engine oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine is shut down.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value. The engine oil rifle pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the engine block, below the ignition control module.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low a speed, the oil pressure can drop below the engine protection limits.

Possible causes of this fault code include:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be replaced.
Refer to Troubleshooting Fault Code t05-415.

Last Modified: 04-Jan-2011


SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Erratic, intermittent, or incorrect data detected on the SAE J1939 data link. | No effect on engine performance, electronic service tool or other data link device can not communicate with the ECM.
SAE J1939 Data Link Circuit

Circuit Description

The SAE J1939 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The SAE J1939 data link is a network data link to which each ECM is attached via a network stub connection. Make sure that the electronic service tool is set up for J1939 communications (if applicable) when using this data link.

Refer to Troubleshooting Fault Code t05-426.

Last Modified: 20-Jan-2011


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | ECM voltage supply approaching a level at which unpredictable operation will occur. Engine will possibly be hard to start.
Battery Supply 1 Circuit

Circuit Description

There are three battery inputs into the customer interface box (CIB) that are unswitched battery supply to the ECM, battery conservation relay, and the ignition control module (ICM).

Component Location

The battery voltage circuit is located in the wiring harness. The fuses are located in the CIB.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through the fuses, and in some cases, relays in the CIB.

Refer to Troubleshooting Fault Code t05-441.

Last Modified: 10-Jan-2011


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level.

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | ECM damage will occur, possible electrical damage to all other electronic components.
Battery Supply 1 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located from the battery, through the customer interface box (CIB), wire harness, and to the ECM. The fuses are located in a CIB.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays in the CIB before reaching the engine.

Refer to Troubleshooting Fault Code t05-442

Last Modified: 10-Jan-2011


Battery 2 Voltage Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P168 SPN: 444 FMI: 18 LAMP: Amber SRT: | Battery 2 Voltage Low - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine is shutdown.
Battery Supply Circuit

Circuit Description

There are three battery inputs into the customer interface box (CIB) that are unswitched battery supply to the electronic control module (ECM).

Component Location

The battery voltage circuit is located from the battery through the CIB, wire harness, and to the ignition module and ECM. The fuses are located in a CIB. The service panel is normally not accessible.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays and fuses in the CIB.

Refer to Troubleshooting Fault Code t05-477.

Last Modified: 10-Jan-2011


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P168 SPN: 444 FMI: 16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | ECM damage will occur.
Battery Supply Circuit

Circuit Description

There are three battery inputs into the customer interface box (CIB) that are unswitched battery supply to the electronic control module (ECM).

Component Location

The battery voltage circuit is located from the battery, through the CIB, wire harness, and to the ECM. The fuses are located in the CIB.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays and fuses in the CIB.

Refer to Troubleshooting Fault Code t05-478.

Last Modified: 10-Jan-2011


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High intake manifold temperature warning. | Possible reduced engine performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature of the intake manifold.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with absolute pressure), on the left front side of the engine.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-488.

Last Modified: 10-Jan-2011


Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 512

Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No effect on engine performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the throttle actuator, which is both an input and output device.

Component Location

The throttle actuator is located on the top front of the engine after the turbochargers, before the charged air aftercoolers.

Shop Talk

The fault code will light if the throttle actuator shorts to a high source on either the positive (+) throttle command or throttle position signal circuits. The governor fault lamp (if installed) could be lit as well.

Refer to Troubleshooting Fault Code t05-512.

Last Modified: 10-Jan-2011


Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 513

Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 SPN: 51 FMI: 4 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No effect on engine performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the throttle actuator, which is both an input and output device.

Component Location

The throttle actuator is located on the top front of the engine after the turbochargers and before the charge-air aftercoolers.

Shop Talk

The fault will light if the throttle actuator shorts to a low source on either the battery 1 voltage circuit or throttle position signal circuits. The governor fault lamp (if installed) could be illuminated as well.

Refer to Troubleshooting Fault Code t05-513.

Last Modified: 31-Dec-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor

Circuit Description

The ECM provides a 5-VDC supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor while the engine is running.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code:

  • Open or short circuit of the +5-VDC SUPPLY, SIGNAL, or RETURN wire in the engine harness
  • Damaged or malfunctioning engine speed sensor.
Refer to Troubleshooting Fault Code 689.

Last Modified: 03-Sep-2014


ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. The internal signal for the ECM temperature is reading abnormally high voltage. | No effect on engine performance.
ECM (CM558/CM2358) Internal Temperature Sensor Circuit

Circuit Description

The CM558/CM2358 contains an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-697

Last Modified: 24-Sep-2013


ECM Internal Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source.

FAULT CODE 698

ECM Internal Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Amber SRT: | ECM Internal Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The internal signal for the ECM temperature is reading abnormally low voltage. | No effect on engine performance.
ECM (CM558/CM2358) Internal Air Temperature Sensor Circuit

Circuit Description

The ECM (CM558/CM2358) contains an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-698

Last Modified: 24-Sep-2013


Heated Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 752

Heated Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 752 PID: S065 SPN: 724 FMI: 2 LAMP: Amber SRT: | Heated Oxygen Sensor Error. The sensed air fuel ratio does not match the desired air fuel ratio. | Possible reduced performance.
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, which is then used to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

This fault is not typically caused by a failed heated oxygen sensor, but is a result of the engine running very lean or very rich. To determine if the engine is running rich or lean, monitor the heated oxygen sensor compensation in INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-752

Last Modified: 30-Nov-2010


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: SPN: 105 FMI: 10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change | Engine is shut down.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the intake manifold housing (combination sensor with absolute pressure) on the left front side of the engine.

Shop Talk

This feature provides protection for the engine when a rapid increase in intake manifold temperature occurs. Intake manifold temperature rapid rise monitors the change in the intake manifold 1 temperature sensor over a period of time and then logs a fault and requests a derate or shut down due to excessive temperature change.

Possible causes of this fault include:

  • Restricted air flow through the charge-air cooler
  • LTA cooling circuit temperature too high
  • Damaged valves
  • An air intake manifold overpressure event
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-783

Last Modified: 31-Dec-2010


Engine Throttle Control Actuator - Condition Exists

FAULT CODE 1739

Engine Throttle Control Actuator - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1739 PID: SPN: 3464 FMI: 31 LAMP: Amber SRT: | Engine Throttle Control Actuator - Condition Exists. Problem detected in the engine throttle actuator or the circuitry connected to it. | Possible reduced engine performance, engine shut down, or engine will possibly not start.
Engine Throttle Control Actuator Circuit

Circuit Description

The circuit covered in this procedure sends power and command signals to the engine throttle control actuator, and also receives a return back from it.

Component Location

The engine throttle control actuator is located on the top of the engine between the turbocharger crossover connection and the aftercooler housing. The circuitry is located in the engine harness.

Shop Talk

This fault code commonly occurs in parallel with other faults regarding the engine throttle control actuator. If this troubleshooting does not resolve the fault code, the cause can be related to another engine system.

Refer to Troubleshooting Fault Code t05-1739

Last Modified: 19-Dec-2010


Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1776

Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1776 PID: SPN: 2634 FMI: 3 LAMP: Amber SRT: | Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Short to ground detected on power relay driver circuit pin 36 of the ECM connector B. | Engine will possibly not start or will possibly be hard to start.
Power Relay Driver Circuit

Circuit Description

The ECM uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit and the Woodward ProAct™ II governor driver.

Component Location

The power relay driver circuit is located in the engine harness and the customer interface box.

Shop Talk

The power relay driver circuit can be used by the customer interface box (C.I.B.), so issues with the C.I.B. can activate this fault code.

Refer to Troubleshooting Fault Code t05-1776

Last Modified: 21-Dec-2010


Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1777

Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1777 PID: SPN: 2634 FMI: 4 LAMP: Amber SRT: | Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Short to ground detected on power relay driver circuit pin 36 of the ECM connector B. | Engine is shut down.
Power Relay Driver Circuit

Circuit Description

The ECM uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit and the Woodward ProAct™ II governor driver.

Component Location

The power relay driver circuit is located in the engine harness and customer interface box (CIB).

Shop Talk

The power relay driver circuit can be used by the CIB, so issues with the CIB can activate this fault code.

Refer to Troubleshooting Fault Code t05-1777

Last Modified: 04-Jan-2011


Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

FAULT CODE 1791

Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1791 PID: SPN: 1204 FMI: 31 LAMP: Red SRT: | The engine was unable to meet the required speed or load demand. | Engine is shut down.
Electrical Load

Circuit Description

N/A

Component Location

N/A

Shop Talk

This fault code will commonly occur in parallel with other faults. If this troubleshooting does not resolve the fault, the cause could be related to another engine system. A misfire in the ignition system is a common cause for this fault, as the unburned fuel will enter the exhaust and cause the exhaust oxygen sensor to sense a rich mixture and command the air/fuel to lean out, which will then result in a loss of power and cause the engine to shut down. Other common causes for this fault are: improper air-fuel mixture, intake restriction, malfunctioning throttle, fuel control valve, or turbocharger. Another cause may be that the engine is loaded beyond its published limit.

Refer to Troubleshooting Fault Code t05-1791.

Last Modified: 04-Jan-2011


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 3938 FMI: 3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source. Above normal voltage detected in the generator speed/load governing bias circuit. | Possible reduced engine performance.
Generator Speed/Load Governing Bias Circuit

Circuit Description

The ECM uses the signal from this circuit to determine the commanded engine speed, and equates this to a throttle position, which it commands to the throttle.

Component Location

N/A

Shop Talk

This is a 0 to 5 volt engine speed signal circuit that is controlled by a customer-supplied voltage governing device, such as a speed potentiometer, or a digital controller (PLC). This 0 to 5 volt signal is then sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue you will need to check the ECM, engine wiring, customer interface box wiring, OEM wiring, and the customer supplied voltage governing device.

For applications that have OEM supplied customer interface box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Refer to Troubleshooting Fault Code t05-1978.

Last Modified: 06-Jan-2011


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 3938 FMI: 4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. Below normal voltage detected in the generator speed/load governing bias circuit. | Possible reduced engine performance.
Generator Speed/Load Governing Bias Circuit

Circuit Description

The ECM uses the signal from this circuit to determine the commanded engine speed, and equates this to a throttle position, which it commands to the throttle.

Component Location

N/A

Shop Talk

This is a 0 to 5 volt engine speed signal circuit that is controlled by a customer-supplied voltage governing device, such as a speed potentiometer, or a digital controller (PLC). This 0 to 5 volt signal is then sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue you will need to check the ECM, engine wiring, customer interface box wiring, OEM wiring, and the customer supplied voltage governing device.

Refer to Troubleshooting Fault Code t05-1979

Last Modified: 04-Jan-2011


Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2188

Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2188 PID: S151 SPN: 724 FMI: 3 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source. Open circuit detected on the heater return pin at the ECM or no heater supply voltage. | Possible reduced engine performance.
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the oxygen concentration of the exhaust gas, which is then used to adjust fueling when operating in closed loop.

The exhaust gas oxygen sensor power up relay (CR3) sends 13.8 Volts to the oxygen sensor after the approximately 45 seconds of run time. The ECM starts using the feedback from the oxygen sensor after 90 seconds of run time. The oxygen sensor is not powered when the engine is not running. The ECM only uses the oxygen sensor input during closed loop (automatic mode) operation.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

This tree assumes FC 2188 is active during engine operation. Use the following procedure if there are high inactive counts. Refer to Procedure 019-362 in Section 19. Other possible causes of this fault code are an engine misfire or knock causing a lean run condition. These conditions should be troubleshot using symptom based troubleshooting trees prior to using this tree.

Refer to Troubleshooting Fault Code t05-2188.

Last Modified: 04-Jan-2011


Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2192

Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2192 PID: S151 SPN: 724 FMI: 4 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Heater voltage to heated oxygen sensor low. | Possible reduced engine performance.
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the oxygen concentration of the exhaust gas, which is then used to adjust fueling.

The exhaust gas oxygen sensor power-up relay (CR3) sends 13.8 volts to the oxygen sensor after approximately 45 seconds of run time. The ECM starts using the feedback from the oxygen sensor after 90 seconds of run time. The oxygen sensor is not powered when the engine is not operating. The ECM only uses the oxygen sensor input during closed loop (automatic mode) operation.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

This tree assumes FC 2192 is active during engine operation. Use the following procedure if there are high inactive counts. Refer to Procedure 019-362 in Section 19. Other possible causes of this fault code are an engine misfire or knock causing a rich run condition. Use symptom based troubleshooting trees to troubleshoot these conditions prior to using this tree.

Refer to Troubleshooting Fault Code t05-2192

Last Modified: 04-Jan-2011


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: SPN: 630 FMI: 31 LAMP: Amber SRT: | Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists. Internal ECM error. | Possible engine shutdown, loss of performance, or engine will possibly not start.
ECM

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-2217

Last Modified: 04-Jan-2011


Heated Oxygen Sensor - Data Valid But Above Normal Operating Range Range - Moderately Severe Level

FAULT CODE 2219

Heated Oxygen Sensor - Data Valid But Above Normal Operating Range Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2219 PID: S65 SPN: 724 FMI: 16 LAMP: Amber SRT: | Heated Oxygen Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level. The measured air-to-fuel ratio is greater than the desired calculated air-to-fuel ratio. | Possible reduced engine performance.
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the oxygen concentration of the exhaust gas, which is then used to adjust fueling.

The exhaust gas oxygen sensor power up relay (CR3) sends 13.8 volts to the oxygen sensor after approximately 45 seconds of run time. The ECM starts using the feedback from the oxygen sensor after 90 seconds of run time. The oxygen sensor is not powered when the engine is not operating. The ECM only uses the oxygen sensor input during closed loop (automatic mode) operation.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the percent of oxygen present in the exhaust gas.

The ECM will read an in-range high fault if the engine is operating lean or the heated oxygen sensor has failed. An exhaust leak can cause this fault by not providing enough back pressure to the heated oxygen sensor. Also, if there are any intake leaks after the throttle actuator, the engine can also run lean due to low fuel pressure problems which can cause this fault code to activate. Other possible causes of this fault code are an engine misfire or knock causing a lean or fuel rich on oxygen run condition. Troubleshoot these conditions using symptom based troubleshooting trees prior to using this tree. If this troubleshooting tree does not fix the problem, the ECM can be the fault.

Refer to Troubleshooting Fault Code t05-2219

Last Modified: 04-Jan-2011


Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2221

Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2221 PID: S65 SPN: 724 FMI: 18 LAMP: Amber SRT: | Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level. The measured air-to-fuel ratio is lower than the desired calculated air-to-fuel ratio. | Possible reduced engine performance.
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the oxygen concetration of the exhaust gas, which is then used to adjust fueling.

The Exhaust Gas Oxygen Sensor Power-Up Relay (CR3) sends 13.8 volts to the oxygen sensor after approximately 45 seconds of operating time. The ECM starts using the feedback from the oxygen sensor after 90 seconds of operating time. The oxygen sensor is not powered when the engine is not operating. The ECM only uses the oxygen sensor input during closed loop (automatic mode) operation.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the percent of oxygen present in the exhaust gas.

The ECM will read an in-range low fault if the engine is running rich or if the heated oxygen sensor or heated oxygen sensor circuit has failed. Excessive exhaust back pressure can cause this fault by creating a lower partial pressure of oxygen to form at the heated oxygen sensor. If the fuel control valve is stuck open, the engine will not burn all the gas that is ingested, causing it to run rich. If the heated oxygen sensor heater supply has shorted to ground or has an open circuit, then the sensor will read a lower than normal exhaust oxygen value.

Other possible causes of this fault code are an engine misfire or knock causing a rich-on-fuel, lean-on-oxygen, run condition. Troubleshoot these conditions using symptom based troubleshooting trees prior to using this tree. This fault code can log when the engine is not operating in automatic mode.

Refer to Troubleshooting Fault Code t05-2221

Last Modified: 06-Jan-2011


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: SPN: 633 FMI: 31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. | Possible reduced engine performance.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded through the customer interface box (CIB). The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing in the rear right of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can become active for any of the following reasons:

  • Electronic fuel control valve high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve with low internal resistance
  • Electronic fuel control valve or engine harness that has shorted to ground, shorted to battery, or open circuit.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active, then inactive, during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty.

ignition system faults?

  • Yes: Reference the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655 for instructions on how to troubleshoot the ignition system. Go to Step 6A.
  • No: Go to Step 2B.
Refer to Troubleshooting Fault Code t05-2311

Last Modified: 24-Sep-2013


Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2315

Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2315 PID: SPN: 623 FMI: 3 LAMP: Amber SRT: | Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source. | Red lamp will not illuminate.
Red Stop Lamp Driver Circuit

Circuit Description

The ECM uses the red stop lamp driver to send a shutdown signal and/or light the customer's red lamp.

The ECM also uses the diagnostic lamp to flash out active fault codes.

Component Location

The diagnostic lamp is an OEM component that is located on the OEM control panel.

Shop Talk

The ECM energizes a relay to send a shutdown signal and/or light the customer's red lamp.

Refer to Troubleshooting Fault Code t05-2315

Last Modified: 06-Jan-2011


Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2316

Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2316 PID: SPN: 624 FMI: 3 LAMP: Amber SRT: | Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on amber warning lamp driver wire of the ECM connector. | Amber lamp will not illuminate.
ECM Diagnostic Lamp Circuit

Circuit Description

The ECM uses the amber warning lamp to inform the operator about active fault codes on the engine.

Component Location

The lamp is an OEM component that is located on the OEM control panel.

Shop Talk

Proper lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-2316

Last Modified: 06-Jan-2011


Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2317

Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2317 PID: SPN: 624 FMI: 4 LAMP: Amber SRT: | Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source. High voltage detected on amber warning lamp driver wire of the ECM connector. | Amber lamp will be illuminated constantly.
ECM Diagnostic Lamp Circuit

Circuit Description

The ECM uses the amber warning lamp to inform the operator about active faults on the engine.

Component Location

The lamp is an OEM component that is located on the OEM control panel.

Shop Talk

Proper lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-2317.

Last Modified: 17-Jan-2011


External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

FAULT CODE 2455

External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2455 PID: SPN: 3938 FMI: 5 LAMP: Amber SRT: | External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit. Below normal current detected in the external generator speed or frequency bias circuit. | Possible reduced engine performance.
External Governor Speed or Frequency Bias Signal Circuit

Circuit Description

The ECM uses the signal from this circuit to determine the external commanded engine speed.

Component Location

N/A

Shop Talk

This is a 4-20 milliampere engine speed signal circuit that is controlled by a customer supplied voltage governing device, such as a digital controller (PLC). This 4-20 mA signal is then sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue, it is necessary to check the ECM, engine wiring, customer interface box wiring, OEM wiring, and the customer supplied voltage governing device.

Refer to Troubleshooting Fault Code t05-2455.

Last Modified: 04-Jan-2011


External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

FAULT CODE 2456

External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 244 PID: SPN: 3938 FMI: 6 LAMP: Amber SRT: 00-313 | Above normal current detected in the External Governor Speed or Frequency Bias Circuit. | Possible reduced engine performance.
ECM Diagnostic Lamp Circuit

Circuit Description

The ECM uses the signal from this circuit to determine the external commanded engine speed.

Component Location

The diagnostic lamp is an OEM component that is located on the vehicle dashboard.

Shop Talk

This is a 4-20 milliamp engine speed signal circuit that is controlled by a customer- supplied voltage governing device, such as a digital controller (PLC). This 4-20 mA signal is then sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue, check the ECM, the engine wiring, the Customer Interface Box (CIB) wiring, the OEM wiring, and the customer-supplied voltage governing device.

For applications that have OEM supplied CIB, refer to the OEM service manual for troubleshooting steps related to the CIB.

Refer to Troubleshooting Fault Code t05-2456.

Last Modified: 31-Dec-2010


ECM Internal Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2544

ECM Internal Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2544 PID: SPN: 1136 FMI: 0 LAMP: Red SRT: | ECM Internal Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM internal temperature has exceeded the high shutdown threshold. | Engine is shutdown.
Electronic Control Module (ECM)

Circuit Description

The CM558 ECMs contain an internal temperature sensor. The circuit is entirely internal to the electronic control module (ECM).

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-2544.

Last Modified: 13-Jan-2011


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | Engine will possibly not start.
Unacknowledged Fault

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location is located in the Customer Interface Box (CIB).

Shop Talk

This fault code occurs as a result of other fault codes becoming active or inactive. Fault Code 2661 will remain active until reset by the operator. Fault Code 2661 is designed to latch onto other fault codes that have become active or have gone inactive. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

This fault code is generated by red/shutdown lamp faults. Other fault codes need to be corrected before acknowledging this fault code, otherwise this fault code will become active again after a calibrated period of time, if other fault codes are still active.

Refer to Troubleshooting Fault Code t05-2661.

Last Modified: 04-Jan-2011


Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: 110 SPN: 110 FMI: 18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine coolant temperature is below normal operating temperature limits. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is below a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when the coolant temperature is detected to be within the normal operating temperature limits.

Shop Talk

This fault indicates that coolant temperature is below a calibratible limit set in the ECM. Reference the Engine Coolant Temperature Below Normal troubleshooting symptom tree in the KTA19 G CM558 Service Manual, Bulletin 4021653.

Refer to Troubleshooting Fault Code t05-2789.

Last Modified: 04-Jan-2011


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2793

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2793 PID: 110 SPN: 110 FMI: 1 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. Engine coolant temperature is below normal operating temperature limits. | Engine is shutdown.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is below a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when the coolant temperature is detected to be within the normal operating temperature limits.

Shop Talk

This fault indicates that coolant temperature is below the minimum limit set in the ECM. Reference the Engine Coolant Temperature Below Normal troubleshooting symptom tree in the KTA19GC3 CM558/CM2358 Service Manual, Bulletin 4021653.

Refer to Troubleshooting Fault Code t05-2793

Last Modified: 24-Sep-2013


Ignition Module Shutdown Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2794

Ignition Module Shutdown Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2794 PID: SPN: 520352 FMI: 3 LAMP: Amber SRT: | Ignition Module Shutdown Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source. Above normal voltage detected in the ignition module shutdown relay driver control circuit. | No effect on engine performance.
Ignition Module Shutdown Relay Driver Control Circuit

Circuit Description

The ECM uses the signal from this circuit as a reset signal, similar to a keyswitch on a vehicle.

Component Location

N/A

Shop Talk

This circuit acts as a keyswitch-style reset for the ECM. In the case of a critical shutdown, the ECM prevents the engine from being restarted until it has been reset. The circuit allows the user to reset the ECM without powering down the entire unit. Part of this circuit resides in the Customer Interface Box (CIB).

For applications that have OEM supplied CIB, refer to the OEM service manual for troubleshooting steps related to the CIB.

Refer to Troubleshooting Fault Code t05-2794.

Last Modified: 18-Jan-2011


Ignition Module Shutdown Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2795

Ignition Module Shutdown Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2795 PID: SPN: 520352 FMI: 4 LAMP: Amber SRT: | Ignition Module Shutdown Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source. Below normal voltage detected in the ignition module shutdown relay driver control circuit. | Engine will shutdown and engine will not start.
ECM Diagnostic Lamp Circuit

Circuit Description

The ECM uses the signal from this circuit as a reset signal, similar to a keyswitch on a vehicle.

Component Location

N/A

Shop Talk

This circuit acts as a keyswitch-style reset for the ECM. In the case of a critical shutdown, the ECM prevents the engine from being restarted until it has been reset. The circuit allows the user to reset the ECM without powering down the entire unit. Part of this circuit resides in the Customer Interface Box (CIB).

For applications that have OEM supplied CIB, refer to the OEM service manual for troubleshooting steps related to the CIB.

Refer to Troubleshooting Fault Code t05-2795.

Last Modified: 18-Jan-2011


Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2797

Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2797 PID: S324 SPN: 520353 FMI: 3 LAMP: Amber SRT: | Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the carburetor inlet gas differential pressure sensor circuit. | Possible reduced engine performance.
Carburetor Inlet Gas Differential Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the carburetor inlet gas differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The carburetor inlet gas differential pressure sensor provides a signal to the ECM on the carburetor inlet gas differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure between the fuel pressure and the inlet air pressure entering the carburetor.

Component Location

The carburetor inlet gas differential pressure sensor is located below the carburetor, at the rear of the engine.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2797

Last Modified: 04-Jan-2011


Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2798

Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2798 PID: S324 SPN: 520353 FMI: 4 LAMP: Amber SRT: | Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the carburetor inlet gas differential pressure sensor circuit. | Possible reduced engine performance.
Carburetor Inlet Gas Differential Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the carburetor inlet gas differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The carburetor inlet gas differential pressure sensor provides a signal to the ECM on the carburetor inlet gas differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure between the fuel pressure and the inlet air pressure entering the carburetor.

Component Location

The carburetor inlet gas differential pressure sensor is located below the carburetor, at the rear of the engine.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2798

Last Modified: 04-Jan-2011


Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2864

Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2864 PID: SPN: 632 FMI: 3 LAMP: Red SRT: | Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the signal return pin of the fuel control valve. | Engine is shut down and engine will not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558/CM2358. The module outputs operate relays that power the respective solenoids in the fuel shutoff valve.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection.

The fuel shutoff valve is often connected as part of the OEM wiring. Be sure to check terminal connections at the valve.

Refer to Troubleshooting Fault Code t05-2864

Last Modified: 24-Sep-2013


Power Relay Driver Diagnostics Has Detected an Error - Condition Exists

FAULT CODE 2865

Power Relay Driver Diagnostics Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2865 PID: SPN: 2634 FMI: 31 LAMP: Amber SRT: | Power Relay Driver Diagnostics Has Detected an Error - Condition Exists. | Engine possibly hard to start, no start, or possible engine shutdown.
Power Relay Driver Circuit

Circuit Description

The power relay driver command controls the battery conservation feature.

Component Location

The power relay driver command circuit is located in the engine harness.

Shop Talk

The power relay driver command circuit can be used by the OEM control panel, so issues within the panel can activate this fault code. Ground connections must be checked.

Refer to Troubleshooting Fault Code t05-2865

Last Modified: 13-Jan-2011


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2866

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2866 PID: SPN: 1442 FMI: 3 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No effect on engine performance.
Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

The electronic fuel control valve communicates its position by varying a resistance internal to the actuator. This resistance is sent to the ECM, which uses the resistance to calculate the valve position as a percentage between 0 and 100.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The electronic fuel control valve is not repairable, so if the valve is determined to be malfunctioning after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Refer to Troubleshooting Fault Code t05-2866

Last Modified: 13-Jan-2011


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2867

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2867 PID: SPN: 1442 FMI: 4 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No effect on engine performance.
Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

The electronic fuel control valve communicates its position by varying a resistance internal to the actuator. This resistance is sent to the ECM, which uses the resistance to calculate the valve position as a percentage between 0 and 100.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The electronic fuel control valve is not repairable, so if the valve is determined to be malfunctioning after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Refer to Troubleshooting Fault Code t05-2867

Last Modified: 06-Jan-2011


Intake Manifold Pressure 1 Sensor - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2995

Intake Manifold Pressure 1 Sensor - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2995 PID: SPN: 3563 FMI: 0 LAMP: Red SRT: | Intake Manifold Pressure 1 Sensor - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air pressure signal indicates intake manifold pressure above engine protection critical limit. | Engine is shutdown.
Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature and pressure of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

This fault can be activated by the following issues:

  • Sensor malfunction
  • Wiring harness malfunction high
  • Intake manifold overpressure event
  • Malfunction in the control system.
Refer to Troubleshooting Fault Code t05-2995

Last Modified: 04-Jan-2011


Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2996

Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2996 PID: SPN: 3563 FMI: 16 LAMP: Amber SRT: | Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold air pressure signal indicates intake manifold pressure above engine protection normal limit. | Possible reduced engine performance.
Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature and pressure of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure).

Shop Talk

This fault can be activated by the following issues:

  • Sensor malfunction
  • Wiring harness malfunction high
  • Malfunction in the control system.
Refer to Troubleshooting Fault Code t05-2996

Last Modified: 04-Jan-2011


Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2997

Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2997 PID: SPN: 724 FMI: 1 LAMP: Red SRT: | Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Most Severe Level. The measured air-to-fuel ratio is lower than the desired calculated air-to-fuel ratio. | Engine is shutdown.
Heated Oxygen Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the oxygen concentration of the exhaust gas, which is then used to adjust fueling.

The exhaust gas oxygen sensor power up relay (CR3) sends 13.8 volts to the oxygen sensor after approximately 45 seconds of run time. The ECM starts using the feedback from the oxygen sensor after 90 seconds of run time. The oxygen sensor is not powered when the engine is not running. The ECM only uses the oxygen sensor input during closed loop (automatic mode) operation.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas.

The ECM will read an out-of-range low fault if the engine is running rich or the heated oxygen sensor or heated oxygen sensor circuit has malfunctioned. This fault can cause engine damage, so the engine will shutdown immediately if this fault activates, in order to protect the engine. If the fuel control valve is stuck open the engine will not burn all the gas that is ingested, causing it to run rich. If the heated oxygen sensor heater supply has shorted to ground or has an open circuit, the sensor will read a lower than normal exhaust oxygen value.

Other possible causes of this fault code are an engine misfire or knock causing a rich run condition. These conditions should be troubleshot using symptom based troubleshooting trees prior to using this tree. This fault code can log when engine is not running in automatic mode.

Refer to Troubleshooting Fault Code t05-2997

Last Modified: 04-Jan-2011


ECU Type - Condition Exists

FAULT CODE 4686

ECU Type - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4686 PID: SPN: 2904 FMI: 31 LAMP: Amber SRT: | Connector Cap Not Present- Condition Exists - Warning. The 60-pin connector plug is not installed or is not making connection. | Amber lamp will be illuminated constantly.
Engine Interface Connector C

Circuit Description

The electronic control module (ECM) sends a signal through the jumper wires contained within the 60 pin connector plug to ensure the appropriate hardware has been installed into the ECM connector.

Component Location

The connector cap is located in the one 60-pin connector port (C) of the ECM.

Shop Talk

If the 60-pin plug is not installed into port C of the ECM, a warning fault will become active. If the 60-pin plug is not installed in connector C of the ECM, install the plug and power cycle the ECM. If the fault code is still active, follow the troubleshooting tree.

Refer to Troubleshooting Fault Code t05-4686

Last Modified: 16-Dec-2013


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 121 - Engine Magnetic Crankshaft Speed/Position Sensor Lost One Of Two Signals - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 121 active?
STEP 2. | Check the ESS. |
 | STEP 2A. Inspect the engine harness and ESS connector pins. | Damaged or dirty pins?
 | STEP 2B. Inspect the sensor for damage. | Damage found?
 | STEP 2C. Read the fault codes. | Fault Code 121 active?
 | STEP 2D. Check the resistance of the sensor. | 1000 to 2000 ohms?
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 3B. Read the fault codes. | Fault Code 121 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the ESS.

Guided Step 2A - Inspect the engine harness and ESS connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ESS.

Action

Inspect the engine harness and ESS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ESS.

Action

Inspect the ESS for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damage found?
YES NO

  • Replace the sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4B

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ESS.

Action

Check the resistance of the sensor.

  • Measure the resistance from the ESS primary SIGNAL pin to the ESS primary RETURN pin in the engine position sensor connector.
  • Measure the resistance from the ESS secondary SIGNAL pin to the ESS secondary RETURN pin in the ESS connector.

1000 to 2000 ohms?
YES NO
No Repair

  • Replace the sensor. Refer to Procedure 019-042 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ESS.
  • Make sure the sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ESS primary SIGNAL pin in the ESS connector, sensor side, to engine block ground.
  • Measure the resistance from the ESS secondary SIGNAL pin in the ESS connector, sensor side, to engine block ground.

More than 100k ohms?
YES NO
No Repair

  • Replace the sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A mating face from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ESS.
  • Disconnect engine interface connector A mating face from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the ESS primary SIGNAL pin in the engine harness sensor connector to the ESS primary SIGNAL pin in the engine harness ECM connector A.
  • Measure the resistance from the ESS secondary SIGNAL pin in the engine harness sensor connector to the ESS secondary SIGANL pin in the engine harness ECM connector.
  • Measure the resistance from the ESS primary RETURN pin in the engine harness sensor connector to the ESS primary RETURN pin in the engine harness ECM connector.
  • Measure the resistance from the ESS secondary RETURN pin in the engine harness sensor connector to the ESS secondary RETURN pin in the engine harness ECM connector A.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ESS.
  • Disconnect the engine interface connector A from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance from the ESS primary SIGNAL pin in the engine harness ECM connector A to the engine block ground.
  • Measure the resistance from the ESS secondary SIGNAL pin in the engine harness ECM connector A to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ESS.
  • Disconnect the engine interface connector A and connector B from the ECM.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the ESS primary SIGNAL pin in the engine harness ECM connector A to all other pins in the connector.
  • Measure the resistance from the ESS primary SIGNAL pin in the engine harness ECM connector A to all the pins in engine harness connector B.
  • Measure the resistance from the ESS secondary SIGNAL pin in the engine harness ECM connector A to all other pins in the connector.
  • Measure the resistance from the ESS secondary SIGNAL pin in the engine harness ECM connector A to all the pins in engine harness connector B.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Jul-2012


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for 386 fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for 386 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the oil pressure RETURN pin on the engine oil pressure sensor connector of the engine harness.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector B from the ECM.

Action

Inspect the interface connector B and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or engine interface connector B.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine interface connector B.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine interface connector B sensor RETURN 2 pin and the engine oil rifle pressure 1 RETURN (sensor RETURN 2) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine inface connectors from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil rifle pressure 1 SIGNAL pin in engine harness and all other pins in the engine interface connector B.
  • Measure the resistance between the oil rifle pressure 1 SIGNAL pin in engine interface connector B and all other pins in the engine interface connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connectors from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil rifle pressure 5 Volt SUPPLY pin in engine interface connector B and all other pins in the engine interface connector B.
  • Measure the resistance between the oil rifle pressure 5 Volt SUPPLY pin in engine interface connector B and all other pins in the engine interface connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Oct-2014


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the engine oil pressure 1 sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine oil pressure 1 sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor from the engine harness.

Action

Inspect the engine harness and oil rifle pressure 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the oil rifle pressure 1-5 Volt SUPPLY pin and the oil rifle pressure 1 RETURN pin on the engine oil rifle pressure sensor connector of the engine harness.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil rifle pressure5 volt SUPPLY pin and the oil rifle pressure SIGNAL pin at the oil rifle pressure SIGNAL pin at the oil rifle pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil rifle pressure 1 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil rifle pressure sensor. Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector B from the ECM.

Action

Inspect the engine harness and engine interface connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine interface connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from the ECM.
  • Disconnect the engine oil rifle pressure 1 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine interface connector B engine oil rifle pressure 1-5volt SUPPLY pin and the engine harness engine oil rifle pressure 1 sensor connector 5 volt SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from the ECM.
  • Disconnect the engine oil rifle pressure 1 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine interface connector B engine oil rifle pressure 1 SIGNAL pin and the engine harness engine oil rifle pressure 1 sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector B from the ECM.
  • Disconnect the engine oil rifle pressure 1 sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the engine oil rifle pressure 1 SIGNAL pin in engine interface connector B and all other pins in engine interface connector B.
  • Measure the resistance between the oil rifle pressure 1 SIGNAL pin in engine interface connector B and all other pins in engine interface connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector B from the ECM.
  • Disconnect the engine oil rifle pressure 1 sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine oil rifle pressure 1 sensor SIGNAL pin in engine interface connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 142 - Engine Oil Rifle Pressure - Data Valid But Above Normal Operatiing Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1. Read the fault codes. | Fault Code 142 active?
STEP 2. | Check the engine oil rifle pressure 1 sensor accuracy. |
 | STEP 2A. Check the sensor accuracy. | Sensor reading is correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 142 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 142 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the engine oil rifle pressure 1 sensor accuracy.

Guided Step 2A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.

Note: If necessary, increase the engine rpm to make it easier to see differences in the readings.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if the electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 142 is inactive.

Note: If the fault was at a particular speed, operate the engine at that speed to verify the problem is corrected.

Fault Code 142 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If the fault code remains active, reference the Lubricating Oil Temperature Above Specifications troubleshooting symptom chart in Section TS of the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jun-2014


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil rifle pressure 1 sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading is correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil rifle pressure 1 sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute. Add atmospheric pressure to gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-066 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical oil pressure gauge.
  • Connect INSITE™ electronic service tool.
  • Operate engine at idle speed.

Action

Check the engine oil pressure.

  • Use the following procedure for lubricating oil pressure information in the in the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653. Refer to Procedure 007-028 in Section 7.

Oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 143 is inactive.

Note: If the fault was at a particular speed, operate the engine at that speed to verify the problem is corrected.

Fault Code 143 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If fault code remains active, reference the Low Oil Pressure symptom tree in Section TS.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 03-Oct-2014


FAULT CODE 144 - Engine Coolant Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 144 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 175 ohms to 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the coolant temperature sensor and circuit.

Guided Step 2A - Inspect the coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature 1 sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the coolant temperature 1 sensor connector.

175 ohms to 274k ohms?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine interface connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature 1 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature 1 RETURN pin and the engine interface connector B sensor RETURN 2 pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature 1 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature 1 sensor SIGNAL pin and the engine interface connector B SIGNAL pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature 1 sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant temperature 1 SIGNAL pin in engine harness to all other pins in the engine interface connector A.
  • Measure the resistance between the coolant temperature 1 SIGNAL pin in engine harness and all pins in engine interface connector B.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL pin has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Refer to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive faults.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 145 - Engine Coolant Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A and engine interface connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A and engine interface connector B from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine interface connector B and all other pins in the engine interface connector A.
  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine interface connector B and all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector B from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine interface connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 146 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Temperature differs more than 3°C or [5°F]?
STEP 3. | Check the coolant temperature 1 sensor. |
 | STEP 3A. Inspect the coolant temperature 1 sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 146 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 146 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine
  • Connect INSITE™ electronic service tool to the vehicle data link
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Temperature differs more than 3°C or [5°F]?
YES NO

Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature 1 sensor.

Guided Step 3A - Inspect the coolant temperature 1 sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the coolant temperature 1 sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it operate for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom chart in Section TS of the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 146 is inactive.

Fault Code 146 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Loocation if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 11-Jun-2014


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 151 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Temperature differs more than 3°C or [5°F]?
STEP 3. | Check the coolant temperature 1 sensor. |
 | STEP 3A. Inspect the coolant temperature 1 sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 151 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Temperature differs more than 3°C or [5°F]?
YES NO

Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature 1 sensor.

Guided Step 3A - Inspect the coolant temperature 1 sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature 1 sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it operate for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom chart in Section TS of the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 151 is inactive.

Fault Code 151 active?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 03-Oct-2014


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | 175 ohms to 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and intake manifold pressure/tetmperature sensor RETURN 1 pin at the intake manifold temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

175 ohms to 274 ohms?
YES NO

Go to the table in Shop Talk for specifications.

Replace the intake manifold temperature sensor. Refer to Procedure 019-099 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure/temperature RETURN (sensor RETURN 1) pin and the engine interface connector A sensor RETURN 1 pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold temperature SIGNAL pin and the engine interface connector A intake manifold temperature SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine interface connector A and all other pins in the engine interface connector A.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine interface connector A and all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 active?
STEP 2. | Check the intake manifold pressure/temperature. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A and connector B from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure/temperature SIGNAL pin in the engine interface connector A and all other pins in the engine interface connector A.
  • Measure the resistance between the intake manifold pressure/temperature SIGNAL pin in the engine interface connector A and all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness with the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold pressure/temperature SIGNAL pin in engine harness interface connector A to ground.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness with the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO
No Repair

  • eplace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 155 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Does the temperature differ more than 3°C or [5°F]?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 155 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 155 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

Note: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C or [5°F]?
YES NO

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-099 Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS (Troubleshooting Symptoms) in Service Manual, KTA19GC CM558/CM2358, Bulletin 4021653.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 155 is inactive.

Fault Code 155 active?
YES NO

Troubleshooting procedures need to be checked again from the beginning.

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jun-2014


FAULT CODE 177 - Electronic Throttle Control Actuator - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 177 active or high inactive counts?
STEP 2. | Check the electronic throttle control actuator. |
 | STEP 2A. Inspect the electronic throttle control actuator and harness. | Dirty or damaged pins?
 | STEP 2B. Check the electronic throttle control actuator resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic throttle control actuator for a short to ground. | Greater than 100k ohms?
 | STEP 2D. Check the butterfly valve. | Debris found or valve difficult to move?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and Engine Control Module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 177 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 177 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic throttle control actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 177 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic throttle control actuator.

Guided Step 2A - Inspect the electronic throttle control actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic throttle control actuator connector from the engine harness connector.

Action

Inspect the electronic throttle control connector, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the connector and pins.

Replace the damaged section of the harness or damaged electronic throttle control actuator.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic throttle control actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic throttle control actuator connector from the engine harness connector.

Action

Check the electronic throttle control actuator resistance.

  • Measure the resistance between the electronic throttle control actuator SIGNAL pin and the electronic throttle control actuator RETURN pin at the electronic throttle control actuator connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic throttle control actuator.

Reference the following procedure in the Master Repair Manual, KTA19GC CM558/CM2358 Panel System, Bulletin 4021655. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic throttle control actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic throttle control actuator connector from the engine harness connector.

Action

Check the electronic throttle control actuator resistance.

  • Measure the resistance between the electronic throttle control actuator SIGNAL pin and engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic throttle control actuator.

Reference the following procedure in the Master Repair Manual, KTA19GC CM558/CM2358 Panel System, Bulletin 4021655. Refer to Procedure 006-049 in Section 6.

Go to 2D

Go to 4A

Guided Step 2D - Check the butterfly valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the engine harness connector.

Action

Remove the electronic fuel control valve assembly from the engine fuel supply.

Reference the following procedure in the Master Repair Manual, KTA19GC CM558/CM2358 Panel System, Bulletin 4021655. Refer to Procedure 006-049 in Section 6.

Inspect the butterfly valve and housing for the following:

  • debris
  • mineral buildup
  • difficult movement of the butterfly valve.

Debris found or valve difficult to move?
YES NO

Remove the blockage and clean the valve, if possible.

If the valve is damaged beyond repair, replace the entire electronic fuel control valve assembly.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine interface connector B.

Clean the connector pins.

Replace the damaged section of harness.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the electronic throttle control actuator connector to the engine harness connector.
  • Disconnect the engine interface connector B from the ECM 50-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic throttle control actuator SIGNAL pin and the electronic throttle control actuator RETURN pin at the engine interface connector B of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic throttle control actuator connector from the engine harness connector.
  • Disconnect the engine interface connector B from the ECM 50-pin connector.

Action

Check the engine harness and electronic throttle control actuator resistance.

  • Measure the resistance between the electronic throttle control actuator SIGNAL pin at the engine interface connector B of the engine harness and engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the engine interface connector B and working to the electronic throttle control actuator.

Fault Code 177 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the electronic throttle control actuator.

Reference the following procedure in the Master Repair Manual, KTA19GC CM558/CM2358 Panel System, Bulletin 4021655. Refer to Procedure 006-049 in Section 6.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 177 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Jun-2014


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM and engine interface connector B harness. |
 | STEP 3A. Inspect the ECM and engine interface connector B pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3B-1. Check for a pin short to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the engine oil rifle sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil rifle pressure sensor from the engine harness.

Action

Inspect the engine oil rifle sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell damaged
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • A damaged sensor has been detected. Replace the engine oil rifle pressure sensor.
  • Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

  • A damaged sensor has been detected. Replace the engine oil rifle pressure sensor.
  • Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine interface connector B harness.

Guided Step 3A - Inspect the ECM and engine interface connector B pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A and connector B.

Action

Inspect the engine interface connector A and connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell damaged
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from the ECM.
  • Disconnect the remote accelerator pedal position sensor, mixer inlet pressure sensor, coolant level sensor and coolant pressure/temperature sensor from the engine harness.
  • Make sure all components connected to sensor supply number 2 are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine interface connector B and all other pins in the engine interface connector B.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine interface connector B and all other pins in the engine interface connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply line number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from the ECM.
  • Disconnect the remote accelerator pedal position sensor, mixer inlet pressure sensor, coolant level sensor and coolant pressure/temperature sensor from the engine harness.
  • Make sure all components connected to sensor supply number 2 are disconnected.

Action

Check for a pin to ground short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine interface connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor supply line number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES NO
No Repair

Replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 187 is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A and connector B from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine interface connector A and B from the ECM.
  • Disconnect the intake manifold 3 and intake manifold 4 temperature sensors from the engine harness.
  • Disconnect all components connected to sensor supply number 2.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine interface connector B and all other pins in the engine interface connector B.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine interface connector B and all other pins in the engine interface connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY number 2 wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 227 is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2000 rpm, the engine must be shut off immediately or engine damage will occur.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1B. Inspect the engine harness and engine sensor connector pins. | Dirty or damaged pins?
 | STEP 1C. Check for an active fault code at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1D. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with INSITE™ electronic service tool.

  • Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the panel tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor as outlined in Fault Code 121.

Go to 1B

Fault Code 121

Guided Step 1B - Inspect the engine harness and ESS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged connector pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code at low engine rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low rpm?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Test the engine.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test the engine.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Troubleshooting procedures need to be checked again from the beginning.

Go to 2B

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 234 is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit. |
 | STEP 2C. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Make sure all components connected to sensor supply 3 circuit are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 3 pin in engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY 3 pin in engine harness ECM connector B and all other pins in the engine connector A.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector B from the ECM
  • Make sure all components connected to sensor supply 3 circuit are disconnected.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY voltage 3 pin in the engine harness ECM connector B and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply 3 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Jul-2012


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.
  • Make sure all components connected to sensor supply 3 circuit are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 3 pin in engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY 3 pin in engine harness ECM connector B and all other pins in the engine connector A.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Jul-2012


FAULT CODE 244 - Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the customer interface box (CIB). |
 | STEP 2A. Check the CIB. | Voltage between 18 and 32-VDC?
 | STEP 2B. Check the CIB. | Voltage between 18 and 32-VDC?
 | STEP 2C. Check the CIB. | Greater than 100k ohms?
 | STEP 2D. Check the relay coil. | Resistance between 420 and 520 ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 244 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM connector A and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from CIB C4.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from the red STOP lamp DRIVER pin in the ECM connector A to all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from CIB C4.
  • Disconnect the engine harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the red STOP lamp DRIVER pin in the ECM connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the customer interface box (CIB).

Guided Step 2A - Check the CIB.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the CIB C4 connector
  • Turn battery supply ON
  • Disconnect the CR5 relay.

Action

Check the CIB voltage.

  • Measure the voltage from pin-10 at CR5 relay base to ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 18 and 32-VDC?
YES NO
No Repair

Check and repair the battery supply circuit.

Go to 2B

Go to 3A

Guided Step 2B - Check the CIB.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the CIB C4 connector
  • Turn battery supply ON
  • Remove the CR5 relay.

Action

Check the CIB voltage.

  • Measure the voltage from pin-2 at CR5 relay base to ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 18 and 32-VDC?
YES NO

Replace the diode.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the CIB.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the CIB C4 connector
  • Disconnect the CR5 relay.

Action

Check for a pin-to-pin short circuit as follows:

  • Measure the resistance from the red STOP lamp DRIVER pin in the 35-pin connector (C4) to all other pins in the 35-pin connector (C4).

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair the damaged wire, connection, or component.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the relay coil.

Conditions

  • Disconnect the relay from the CIB
  • Make sure the temperature is between 18°C [65°F] and 29°C [85°F].

Action

Check the resistance of the relay coil.

Measure the resistance across the coil on the relay.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 420 and 520 ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Relay damage is found. Replace relay.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let it idle for 1 minute.

Fault Code 244 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 20-Jul-2012


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage BelowNormal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Check the fuel shutoff valve supply voltage. | Voltage greater than 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 254 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 254 inactive?
 | STEP 5B. Clear the inactive fault codes. | Fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Check the valve supply voltage.

Conditions

  • Turn keyswitch ON
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

Make sure the engine is not performing a purge cycle when making this measurement.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 24-VDC?
YES NO
No Repair

Check the battery connections and fuses in the harness. Refer to the appropriate circuit or wiring diagram for connector pin identification.

Go to 3A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector A
  • Disconnect the engine harness from the 35-pin connector (C4).

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector A
  • Disconnect the engine harness from the 35-pin connector (C4).

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the fuel shutoff valve DRIVER RETURN pin on the engine interface connector A to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve DRIVER SUPPLY pin on the engine interface connector A to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate circuit and wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from ECM connector A
  • Disconnect the engine harness from the 35-pin connector (C4).

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the engine interface connector A to the fuel shutoff valve driver SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness connector to the fuel shutoff valve SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or the engine wiring diagram for the appropriate circuit.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Turn keyswitch ON
  • Disconnect the engine harness connector from the fuel shutoff valve

Action

Check for the appropriate CM558 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 255 will become active.

Fault Code 254 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 254 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 20-Jul-2012


FAULT CODE 277 - Electronic Fuel Injector Control Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 277 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
 | STEP 2D. Check the butterfly valve. | Debris found or valve difficult to move?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and Engine Control Module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 277 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 277 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify engine electronic fuel valve 1 is connected to engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 277 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the engine electronic fuel valve 1.

Guided Step 2A - Inspect the engine electronic fuel valve 1 and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Inspect the engine electronic fuel valve 1, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine electronic fuel valve 1 resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Check the electronic fuel valve 1 resistance.

  • Measure the resistance between the engine electronic fuel valve 1 position SIGNAL pin and the engine electronic fuel valve 1 RETURN pin at the electronic fuel valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the engine electronic fuel valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Check the engine electronic fuel valve 1 resistance.

  • Measure the resistance between the engine electronic fuel control valve 1 SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the butterfly valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Check the butterfly valve.

Remove the fuel control valve. Refer to Procedure 019-102 in Section 19.

Inspect the butterfly valve and housing for the following:

  • Debris
  • Mineral buildup.
  • Difficult movement of the butterfly valve.

Debris found or valve difficult to move?
YES NO

Remove the blockage and clean the electronic fuel control valve, if possible. If the electronic fuel control valve is damaged or irreparable, replace the entire fuel control valve assembly. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the engine electronic fuel valve 1 connector to the engine harness connector
  • Disconnect the engine interface connector B from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance between the engine electronic fuel valve 1 SIGNAL pin and the engine electronic fuel valve 1 RETURN pin at the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector
  • Disconnect the engine interface connector B from the ECM.

Action

Check the engine harness and electronic fuel control valve 1 resistance.

  • Measure the resistance between the electronic fuel control valve1 SIGNAL pin at the engine interface connector B and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 277 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 277 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 20-Jul-2012


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check ECM for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Calibrate the ECM. | ECM calibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the electronic control module (ECM).

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Recycle the power to the ECM using the keyswitch.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 35-pin connector (C4). Reference the KTA19GC CM558/CM2358 Panel Master Repair Manual, Bulletin 4021655.

Go to 1C

Go to 2A

Guided Step 1C - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connectors A and B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from the engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from the battery (-) post to all pins in the ECM connector ports.

Greater than 100k ohms?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

ECM calibrated successfully?
YES NO
No Repair

Active fault codes are still present.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 343 is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 346 - Engine Control Module (ECM) Calibration Memory Software - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 346 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check the ECM ground. | Greater than 100k ohms?
 | STEP 1D. Calibrate the ECM. | Fault Code 346 active after calibration?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 346 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2B

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM
  • Check the OEM connector as a possible source of an intermittent power supply
  • Make sure the power supply to the ECM is constant and not intermittent.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 35-pin OEM connector. Refer to the KTA19GC CM558/CM2358, Panel Master Repair Manual, Bulletin 4021655.

Go to 1C

Go to 2A

Guided Step 1C - Check the ECM ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector A and connector B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the engine interface connector ports.
  • Measure the resistance from battery (-) post to all pins in the engine interface connector ports.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Fault Code 346 active after calibration?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and connector pins connected to sensor supply 1. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply 1. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 4. | Check the 35-pin extension harness. |
 | STEP 4A. Inspect the 35-pin extension harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 5. | Check the customer interface box (CIB). |
 | STEP 5A. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Codes 352 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and connector pins connected to sensor supply 1.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

Go to 2B

Go to 6B

Guided Step 2B - Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply 1.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply 1 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harnesswith the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the carburetor inlet gas differential pressure sensor. Refer to Procedure 019-457 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector A and B from the ECM
  • Disconnect the 35-pin extension harness connector from the CIB.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector A and B from the ECM
  • Disconnect the intake manifold pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness.
  • Disconnect all components connected to sensor supply 1
  • Disconnect the 35-pin extension harness connector from the CIB.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A to all other pins in the engine interface connector A.
  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A to all other pins in the engine interface connector B.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 1 line has been detected in the engine harness.

Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 6A

Guided Step 3B-1 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness.
  • Disconnect all components connected to sensor supply 1
  • Disconnect the 35-pin extension harness connector from the CIB.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the sensor supply 1 pin in the engine interface connector A and ground.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply 1 line has been detected in the engine harness.

Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6B

Go to 6A

Guided Step 4 - Check the 35-pin extension harness.

Guided Step 4A - Inspect the 35-pin extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin extension harness from the engine harness and CIB.

Action

Inspect the extension harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the 35-pin harness or connectors.

Repair or replace the wire or connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin extension harness from the engine harness and the CIB.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the speed adjustment 5 volt SUPPLY (sensor supply 1) pin in the 35-pin connect and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

  • Repair or replace the 35-pin extension harness.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 5A

Go to 6A

Guided Step 5 - Check the customer interface box (CIB).

Guided Step 5A - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin extension harness from the engine harness and the CIB
  • Disconnect the speed adjustment 5 volt supply (sensor supply 1) wire from the customer terminal strip.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the speed adjustment 5 volt SUPPLY (sensor supply 1) pin in the 35-pin connector of the CIB and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Repair or replace the CIB.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the CIB. Use the following procedure in the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655. Refer to Procedure 015-023 in Section 15.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Codes 352 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 354 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 355 active and Fault Code 354 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage between 4.5 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 354 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 354 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 386.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 355 active and Fault Code 354 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor voltage and circuit.

  • Measure the voltage between the intake manifold pressure/temperature 5 volt SUPPLY (sensor supply 1) pin and the intake manifold pressure/temperature RETURN (sensor return 1) at the intake manifold pressure temperature sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold pressure/temperature sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES NO

A damaged sensor has been detected

Replace the intake manifold pressure sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, as necessary.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine interface connector A sensor RETURN 1 pin and the intake manifold pressure/temperature RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in engine harness.

Repair or replace the harness, as necessary.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine interface connector A to all other pins in the engine interface connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine interface connector A to all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness, as necessary.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 1 pin in engine interface connector A and all other pins in the engine interface connector A.
  • Measure the resistance between the sensor SUPPLY 1 pin in engine interface connector A and all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness, as necessary.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 354 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Jul-2012


FAULT CODE 355 - Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Voltage between 4.5 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 354 active and Fault Code 355 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 355 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 355 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor voltage and circuit.

  • Measure the voltage between the intake manifold pressure/temperature 5 volt SUPPLY pin (sensor supply 1) and the intake manifold pressure/temperature RETURN pin (sensor supply 1) at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure/temperature 5 volt SUPPLY pin (sensor supply 1) and the intake manifold pressure SIGNAL pin at the intake manifold sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 354 active and Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold pressure/temperature sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES NO

A damaged sensor has been detected.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins.

Repair or replace the harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine interface connector A sensor SUPPLY 1 pin and the intake manifold pressure/temperature sensor connector sensor SUPPLY 1 pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in engine harness.

Repair or replace the harness, as necessary.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine interface connector A intake manifold pressure SIGNAL pin and the intake manifold pressure/temperature sensor connector intake manifold pressure SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in engine harness.

Repair or replace the harness, as necessary.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine interface connector A and all other pins in the engine interface connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine interface connector A and all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness, as necessary.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine interface connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 and the Wiring Diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness, as necessary.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 355 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Jul-2012


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 3. | Check the 35-pin extension harness. |
 | STEP 3A. Inspect the 35-pin extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the 35-pin extension harness. | Greater than 100k ohms?
STEP 4. | Check the customer interface box (CIB). |
 | STEP 4A. Check for a pin-to-pin short circuit in the CIB. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Codes 386 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine engine interface connectors A and B from the ECM
  • Disconnect the 35-pin extension harness connector from the customer interface box (CIB).

Action

Inspect the engine harness and ECM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, as necessary.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connectors A and B from the ECM
  • Disconnect the intake manifold pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness
  • Disconnect all components connected to sensor supply 1
  • Disconnect the 35-pin extension harness connector from the CIB.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A and all other pins in the engine interface connector A.
  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A and all other pins in the engine interface connector B.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, as necessary.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3 - Check the 35-pin extension harness.

Guided Step 3A - Inspect the 35-pin extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin extension harness from the engine harness and CIB.

Action

Inspect the 35-pin extension harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected int he 35-pin extension harness or connectors.

  • Repair the damaged pins. Repair or replace the wire or connector, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the 35-pin extension harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin extension harness from the engine harness and CIB.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the speed adjustment 5 volt SUPPLY (sensor supply 1) pin in the 35-pin connector and all other pins in the connector.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

  • Repair the damaged pins. Repair or replace the 35 pin extension harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 4A

Go to 5A

Guided Step 4 - Check the customer interface box (CIB).

Guided Step 4A - Check for a pin-to-pin short circuit in the CIB.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin extension harness from the engine harness and CIB.
  • Disconnect the speed adjustment 5 volt SUPPLY (sensor supply 1) wire from the customer terminal strip.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the speed adjustment 5 volt SUPPLY (sensor supply 1) pin in the 35-pin connector of the CIB and all other pins in the connector.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Repair the damaged pins. Repair or replace the CIB.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the CIB. Use the following procedure from the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655. Refer to Procedure 015-023 in section 15.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil rifle pressure 1 sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil rifle pressure 1 sensor accuracy.

Guided Step 1A - Check the engine oil rifle pressure 1 sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute. Add atmospheric pressure to the gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if the electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-066 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil rifle pressure.

Guided Step 2A - Check the engine oil rifle pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON
  • Connect a mechanical oil pressure gauge
  • Connect INSITE™ electronic service tool
  • Operate engine at idle speed.

Action

Check the engine oil rifle pressure.

  • Use the following procedure in the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653. Refer to Procedure 007-029 in Section 7.

Oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 415 is inactive.

If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 415 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If the fault code remains active, go to the Low Oil Pressure symptom tree in Section TS.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 426 - SAE J1939 Data Link — Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Action

Check the electronic control module (ECM).

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Refer to Procedure 019-165 in Section 19.

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 20-Jul-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if the customer interface box (CIB) has a malfunctioning relay. | Relay malfunctioning?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5-VDC and 15.0-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pins. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the CIB. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5 VDC and 15.0 VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin to pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a damaged voltage source.

Guided Step 2A - Determine if the customer interface box (CIB) has a malfunctioning relay.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery conservation relay.

  • Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655 for details on how to perform this procedure.

Relay malfunctioning?
YES NO

Replace the relay. Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Battery voltage between 11.5 and 15.0-VDC?
YES NO
No Repair

A malfunctioning battery has been detected.

Replace the malfunctioning battery or batteries. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 35-pin OEM harness connector.

Action

Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

  • Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655 for information on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the OEM troubleshooting and repair manual.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the CIB.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the CIB.

  • Open the service panel by loosening the screw clamps
  • Inspect the circuit board and locate the glass fuses
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Defective fuse?
YES NO

A damaged or blown fuse has been located. Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the ECM and engine interface connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the battery 1 and battery 2 voltage SUPPLY pins on the engine interface connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the all battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and the battery voltage 1 and battery voltage 2 SUPPLY pin on the 35-pin connector (C4).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connectors A and B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure all battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and all other pins in the engine interface connector A..
  • Measure all battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 2. | Check for a malfunctioned voltage source. |
 | STEP 2A. Check the relays in the customer interface box (CIB). | Relay installed?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 23.5 and 27.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Check the relays in the customer interface box (CIB).

Conditions

  • Turn keyswitch OFF.

Action

Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

  • Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 35-pin OEM harness connector and from the 35-pin connector (C4) at the CIB.

Action

Inspect the ECM and OEM harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the OEM harness. Refer to the OEM service manual

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the CIB.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the CIB.

  • Open the CIB
  • Inspect the CIB fuses
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has been located. Replace the fuse. For information on the repair procedure, refer to the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the battery voltage 1 and battery voltage 2 pins on the engine interface connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general mutlimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 23.5 and 27.0-VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector A
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and the 35-pin (C4) connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connectors A and B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and all other pins in the engine interface connector A.
  • Measure the resistance between the battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 13-Jun-2014


FAULT CODE 477 - Battery 2 Voltage Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check for a damaged voltage source. |
 | STEP 2A. Determine battery voltage. | Battery voltage between +11.5-VDC and +15.0-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pins. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 23.0 and 27.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for a damaged voltage source.

Guided Step 2A - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of each battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between +11.5-VDC and +15.0-VDC?
YES NO
No Repair

A damaged battery has been detected.

Replace the damaged battery or batteries. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Disconnect the batteries
  • Turn keyswitch OFF
  • Disconnect the engine harness from the 35-pin OEM harness connector from the customer interface box (CIB) and (C4) connector.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connectors. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness service panel.

Conditions

  • Turn keyswitch OFF
  • Disconnect the batteries.

Action

Open the CIB.

  • Inspect the fuses for a black discoloration in the glass. This signifies that the fuse is not good.

Damaged fuse?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 23.0 and 27.0-VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and 35-pin connector (C4).
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A and B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the battery voltage 1 and battery voltage 2 SUPPLY pins in the engine interface connector A and all other pins in the engine interface connector A.
  • Measure the resistance between the battery voltage 1 and battery voltage 2 SUPPLY pins in the engine interface connector A and all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Jul-2012


FAULT CODE 478 - Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the fuses in the customer interface box (CIB). | Blown fuses?
 | STEP 3B. Inspect the ECM and CIB connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage at the ECM. | Voltage between 23.5 and 27.0-VDC?
 | STEP 3D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 3E. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 35-pin OEM harness connector.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector harness. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the fuses in the CIB.

Conditions

  • Turn keyswitch OFF.

Action

Open the CIB.

  • Inspect the fuses for a black discoloration in the glass. This signifies that the fuse is not good.
  • Reference the KTA19GC Panel Master Repair Manual, Bulletin 4021655.

Damaged fuse?
YES NO

Reference the KTA19GC Panel Master Repair Manual, Bulletin 4021655.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the battery voltage 1 and battery voltage 2 SUPPLY pins in the engine interface connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 23.5 and 27.0-VDC?
YES | NO
No Repair | No Repair

Go to 3F

Go to 3D

Guided Step 3D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the battery voltage 1 and battery voltage 2 SUPPLY pins on the engine interface connector A and at the OEM connector (C4).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A and B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the battery voltage and battery voltage 2 SUPPLY pins on the engine interface connector A and all other pins on the engine interface connector A.
  • Measure the resistance between the battery voltage and battery voltage 2 SUPPLY pins on the engine interface connector A and all other pins on the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Jul-2012


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 488 active?
STEP 2. | Check the intake manifold 1 pressure/temperature sensor accuracy. |
 | STEP 2A. Verify the intake manifold 1 pressure/temperature sensor accuracy with a thermocouple or similar probe. | Temperature within 3°C or 5°F?
STEP 3. | Check the intake manifold 1 pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 488 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 488 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold 1 pressure/temperature sensor accuracy.

Guided Step 2A - Verify the intake manifold 1 pressure/temperature sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the intake manifold 1 pressure/temperature sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

If no temperature measuring device is available, answer Yes to this step.

Temperature within 3°C [5°F]?
YES NO
No Repair

Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the intake manifold 1 pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector B from the ECM.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold 1 pressure temperature sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES NO

Reference the Intake Manifold Temperature Above Normal troubleshooting symptom tree in Section TS of the KTA19GC Service Manual, Bulletin 4021653.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 488 is inactive.

Fault Code 488 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 22-Nov-2011


FAULT CODE 512 - Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 512 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO

Refer to Procedure 019-362 in Secion 19.

No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator. Use the following procedure in the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector B from the ECM.

Action

Inspect the engine interface connector B and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness.

Repair or replace the harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19..

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector B from the ECM.
  • Disconnect the 16-pin connector (C13) from the customer interface box (CIB).

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle position 1 SIGNAL pin in the engine interface connector A to all other pins in the engine interface connector A and B.

Use to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 512 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Oct-2014


Fault Code 513 - Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a newengine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 513 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO

Refer to Procedure 019-362 in Section 19.

No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure in the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653. Replace the throttle actuator. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector B from the ECM.

Action

Inspect the engine interface connector B and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connectors A and B from the ECM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator feedback (+) SIGNAL pin in the engine interface connector B to all other pins in the engine interface connectors A and B.
  • Measure the resistance between the throttle actuator feedback (0) SIGNAL pin in the engine interface connector B to all other pins in the engine interface connectors A and B.
  • Measure the resistance between the throttle actuator feedback (-) SIGNAL pin in the engine interface connector B to all other pins in the engine interface connectors A and B.

Use to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO
No Repair

  • Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 513 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jun-2014


FAULT CODE 697 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in RUN mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2012


FAULT CODE 698 - ECM Internal Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source.

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in RUN mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 698 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2012


FAULT CODE 752 - Heated Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 453, 454, 455, 511, and/or 751 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 752 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 2B. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 3. | Check Base engine components. |
 | STEP 3A. Check for an exhaust leak. | Any exhaust leaks?
 | STEP 3B. Check for an intake restriction. | Is intake restriction more than 15 in H2O?
STEP 4. | Check the engine harness and heated oxygen sensor. |
 | STEP 4A. Check the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
 | STEP 4C. Check the heated oxygen sensor heater supply voltage. | Voltage greater than 12-VDC?
 | STEP 4C-1. Check for an open circuit in the engine harness. |
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4G. Verify oxygen sensor operation. | Did the sensor pass the test?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 752 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 453, 454, 455, 511, and/or 751 active?
YES NO

Troubleshoot any remaining fault codes before proceeding.

 No Repair

Fault Codes 453, 454, 455, 511, or 751 first.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Fuel System.

Guided Step 2A - Verify secondary fuel pressure.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet
  • Operate the engine at idle with no load
  • Fuel pressure must be between 5 to 6 inches H2O.

Is pressure correct for the engine family?
YES NO
No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT.

Go to 2B

Go to 5A

Guided Step 2B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve position feedback and command position while the keyswitch is on.

Note: If the fuel control valve is stuck open, excessive amounts of fuel will be allowed into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check base engine components.

Guided Step 3A - Check an exhaust leak.

Conditions

  • Turn keyswitch ON
  • Start engine.

Action

Check for an exhaust leak between the exhaust manifold and the heated oxygen sensor.

  • Check all gaskets
  • Check all castings
  • Check all pipe plugs.

Any exhaust leaks?
YES NO

An exhaust leak has been detected.

Repair or replace any exhaust component. Reference Section 11 of the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for intake system restriction.

Conditions

  • Turn keyswitch ON
  • Start engine.

Action

Check for intake system restriction.

  • Measure the intake system restriction with a vacuum/pressure gauge.

Is intake restriction more than 15 in H2O?

YES NO
No Repair

Replace the air cleaner element. Use the following procedure in the Service Manual KTA19GC CM558/CM2358 System, Bulletin 4021653. Refer to Procedure 010-013 in Section 10.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness and heated oxygen sensor.

Guided Step 4A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness connector A and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques, Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check heated oxygen sensor resistance.

  • Measure the resistance between the heated oxygen sensor heater SUPPLY pin and the heated oxygen sensor heater RETURN pin at the heated oxygen sensor connector.
  • Make sure to check the resistance at room temperature (23°C [73°F] ± 5 degrees).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques, Refer to Procedure 019-361 in Section 19.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES | NO
No Repair | No Repair

Go to 4D

Go to 4C-1

Guided Step 4C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A heated oxygen heater RETURN pin and the engine harness heated oxygen sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques, Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line in the OEM harness.

Check for an open circuit in the OEM switched battery supply to the heated oxygen sensor supply.

Repair the damaged pins. Replace the engine harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the 10 Ampere heater supply fuse. Refer to Procedure 019-198 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A heated oxygen sensor compensating resistor signal and the engine harness heated oxygen sensor connector compensating resistor signal pin.
  • Measure the resistance between the engine harness ECM connector A heated oxygen sensor SIGNAL pin and the engine harness heated oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector A heated oxygen sensor reference RETURN pin and the engine harness heated oxygen sensor connector reference RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurment techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current signal or reference return circuit has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A heated oxygen sensor compensating resistor signal and the engine block ground.
  • Measure the resistance between the engine harness ECM connector A heated oxygen sensor SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurment techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector A and all other pins in the engine harness connector A.
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector A and all other pins in the engine harness connector B.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness connector A.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurment techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the heated oxygen sensor test using the INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to activate the heated oxygen sensor test. Follow the directions given by INSITE™ electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 752 is inactive.

Fault Code 752 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2014


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure/temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold pressure/temperature sensor accuracy with a thermocouple or similar temperature probe. | Thermocouple reading agrees with the intake manifold pressure/temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 783 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold pressure/temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold pressure/temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold pressure/temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold pressure/temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold pressure/temperature sensor reading on the INSITE™ service tool monitor screen to the reading from the temperature probe. NOTE: If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold pressure/temperature sensor reading in INSITE™ electronic service tool?

YES NO
No Repair

A damaged intake manifold pressure/temperature sensor has been detected.

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-099 in Section 19.

Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree

2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 783 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Dec-2010


FAULT CODE 1739 - Engine Throttle Control Actuator - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other issues |
 | STEP 1A. Check for active or inactive fault codes. | No active or inactive fault codes?
STEP 2. | Check for actuator issues. |
 | STEP 2A. Inspect the 16-pin connector pins. | Dirty or damaged pins?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1739 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for other issues.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive Fault Codes 177, 234, 441, 442, 512, 513, 1791, 1978, 1979, 2455, or 2456.

No active or inactive fault codes?
YES NO

One or more active fault codes.

Troubleshoot the active fault code identified.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for actuator issues.

Guided Step 2A - Inspect the 16-pin connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 16-pin connector.

Action

Inspect the 16-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

Reference the KTA19GC CM558 Electronic Master Repair Manual, Bulletin 4021655, for further troubleshooting.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1739 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jun-2014


FAULT CODE 1776 - Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822917 - female AMP™/Cannon™ test lead, Part No. 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Check the customer interface box (CIB) and relay. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1776 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Check the Customer Interface Box (CIB) and relay.

Conditions

  • Turn keyswitc OFF.

Action

Check the CIB and relay.

  • Use the Master Repair Manual, KTA19GC CM558/CM2358 Panel System, Bulletin 4021655.

Any issues?
YES NO

Use the Master Repair Manual, KTA19GC CM558/CM2358 Panel System, Bulletin 4021655 for instructions on how to resolve the issue.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitc OFF.
  • Disconnect the harness from the ECM and 35-pin (C4) connector.

Action

Inspect the 35-pin (C4) connector ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the 35-pin (C4) connector, ECM engine connector, or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitc OFF.
  • Disconnect the 35-pin (C4) connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from the power relay drive command pin in the engine interface connector B to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitc OFF.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the power relay driver command pin in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 1776 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Troubleshoot any remaining active fault codes.

Last Modified: 13-Jun-2014


FAULT CODE 1777 - Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Check the customer interface box (CIB) and relay. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1777 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Check the customer interface box (CIB) and relay.

Conditions

  • Turn the keyswitch OFF.

Action

Check the CIB and relay.

  • Referrence the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655.

Any issues?
YES NO

Reference the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655, for instructions on how to resolve the issue.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the harness from the ECM and the 35-pin (C4) connector.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general inspection techniques use the following procedure. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector and the 35-pin (C4) connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the 35-pin (C4) connector

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from power relay driver command pin in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from power relay driver command pin in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 1777 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate Troubleshooting chart

Last Modified: 13-Jun-2014


FAULT CODE 1791 - Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1791 inactive?
 | STEP 2B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes.

Active or inactive fault codes?
YES NO

Refer to appropriate troubleshooting tree.

Inspect the ignition system and check for fault flashouts on the Ignition Control Module. Reference the No Spark or Cylinder Misfire (Flashout 1, 2, or 3 When Engine Stopped) Troubleshooting Tree in Section TS of the KTA19 GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

If the ignition system is working properly, reference to the Engine Starts But Will Not Keep Running and Engine Will Not Reach Rated Speed Troubleshooting Trees in Section TS of the KTA19 GC CM558/CM2358 Service Manual, Bulletin 4021653.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let it idle for 1 minute.

Fault Code 1791 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault Codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 13-Jun-2014


FAULT CODE 1978 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead, Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the customer interface box (CIB). |
 | STEP 1A. Check the 35-pin connector pins. | No damaged pins?
 | STEP 1B. Check for a short circuit in the wiring. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM, the engine interface connector pins, and the 35-pin connector (C4). | No damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1978 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the customer interface box (CIB).

Guided Step 1A - Inspect the 35-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 35-pin connector.

Action

Inspect the 35-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For applications that have an OEM supplied customer interface box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Reference the KTA19GC CM558 Panel System Master Repair Manual, Bulletin 4021655.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to the customer interface box (CIB).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 35-pin (C4) connector.

Action

Check for a short circuit to the wiring harness as follows:

  • Measure the resistance from the generator speed/load governing bias SIGNAL pin to all other pins on the 35-pin (C4) connector on the CIB. Reference the KTA19GC CM558 Panel System Master Repair Manual, Bulletin 4021655, for further troubleshooting.

Greater than 100k ohms?
YES NO
No Repair

For applications that have OEM supplied customer interface box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM, and the engine interface connector pins and the 35-pin connector (C4).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connectors A and B from the ECM and the 35-pin connector (C4).

Action

Inspect the engine interface connectors A and B and the engine harness at the 35-pin connector (C4) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A and B from the ECM.

Action

Check for a short circuit from pin to pin as follows:

Measure the resistance from the generator speed/load governor bias SIGNAL pin in engine interface connector B to all other pins in engine interface connector B.

  • Measure the resistance from the generator speed/load governor bias SIGNAL pin in engine interface connector B to all other pins in engine interface connector A.
  • Measure the resistance from the generator speed/load governor bias RETURN pin in engine interface connector B to all other pins in engine interface connector B.
  • Measure the resistance from the generator speed/load governor bias RETURN pin in engine interface connector B to all other pins in engine interface connector A.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1978 is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


Fault Code 1979 - Generator Speed/Load Governing Bias Circuit - Voltage Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead, Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the customer interface box (CIB). |
 | STEP 1A. Check the 35-pin (C4) connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1979 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the customer interface box (CIB).

Guided Step 1A - Inspect the 35-pin connector pins.

Conditions

  • Disconnect the 35-pin connector.

Action

Inspect the 35-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 35-pin (C4) connector.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the generator speed/load governing bias SIGNAL pincat the 35-pin (C4) connector on the CIB to all other pins on the 35-pin (C4) connector on the CIB. Measure the resistance from the generator speed/load governing bias RETURN pin at the 35-pin (C4) connector on the CIB to all other pins on the 35-pin (C4) connector on the CIB. Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655, for further troubleshooting.

More than 100k ohms?
YES NO
No Repair

  • Repair the CIB. Reference the KTA19GC CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655, for further troubleshooting.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 35-pin connector (C4) and the engine interface Connector B.

Action

Inspect the 35-pin connector (C4), the engine interface connector B, and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins.

Repair or replace the engtine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connectors A and B from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from generator speed/load governing bias SIGNAL pin on the engine interface connector B to all other pins on the engine interface connector B.
  • Measure the resistance from generator speed/load governing bias SIGNAL pin on the engine interface connector B to all other pins on the engine interface connector A.
  • Measure the resistance from generator speed/load governing bias RETURN pin on the engine interface connector B to all other pins on the engine interface connector B.
  • Measure the resistance from generator speed/load governing bias RETURN pin on the engine interface connector B to all other pins on the engine interface connector A.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the interface B connector from the ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the generator speed/load governor bias SIGNAL pin at the engine interface connector B.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1979 is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2014


FAULT CODE 2188 - Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 2188 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the heated oxygen sensor. | Greater than 100k ohms?
 | STEP 2C. Check the heated oxygen sensor heater. | Resistance is between 2.9 ohms and 3.7 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. |
STEP 3. | Check the INLINE™ module. |
 | STEP 3A. Inspect the INLINE™ module connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short in the INLINE™ module. | Greater than 100k ohms?
STEP 4. | Check the ECM and the engine harness. |
 | STEP 4A. Inspect the engine harness interface connector A and 2-pin connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 4C. Check the ECM response. | Fault Code 2192 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2188 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2188 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.

Action

Inspect the and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector.

Replace the heated oxygen sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.

Action

Check for a pin-to-pin short in the heated oxygen sensor.

Measure the resistance between the compensating resistor SIGNAL pin in the heated oxygen sensor and all other pins in the heated oxygen sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the heated oxygen sensor.

Replace the heated oxygen sensor. Refer to Procedure 019-100.

Go to 2C

Go to 5A

Guided Step 2C - Check the heated oxygen sensor heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the heater SUPPLY pin and the heater RETURN pin at the heated oxygen sensor connector.

Resistance is between 2.9 ohms and 3.7 ohms?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the heated oxygen sensor to the INLINE™ module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2188 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 5A

Guided Step 3 - Check the INLINE™ module.

Guided Step 3A - Inspect the INLINE™ module connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect INLINE™ module from the heated oxygen sensor and the engine harness.

Action

Inspect the INLINE™ module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the INLINE™ module connector.

Repair the damaged pins. Repair or replace the damaged INLINE™ module connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the 8-pin AMP™ connector. Refer to Procedure 019-203 in section 19.
  • Replace the 2-pin Bosch™ connector. Refer to Procedure 019-214 in section 19.
  • Replace the 2-pin Packard™ connector. Refer to Procedure 019-211 in section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the INLINE™ module

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ module from the heated oxygen sensor.
  • Disconnect the INLINE™ module from the engine harness.

Action

Check for a pin-to-pin short circuit.

Measure the resistance between the compensating resistor SIGNAL pin in the INLINE™ module 8-pin connector and all other pins in the INLINE™ module 8-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the INLINE™ module.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the INLINE™ module. Refer to Procedure 019-353 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and the engine harness.

Guided Step 4A - Inspect the engine harness interface connector A and 2-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the INLINE™ module.
  • Disconnect engine interface connector A.

Action

Inspect the engine harness 2-pin connector and engine interface connector A for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Damage has been found in the engine interface A connector or 2-pin connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate conecter seal if it is damaged or missing.
  • Repair or replace the engine interface connector A. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short cicuit

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the INLINE™ module.
  • Disconnect engine interface connector A.

Action

Check for a pin-to-pin short circuit.

Measure the resistance between the engine heated oxygen (0 to 5 volt) SIGNAL pin in the engine interface connector A and all other pins in the engine interface connector A.

Measure the resistance between the engine heated oxygen (0 to 5 volt) RETURN pin in the engine interface connector A and all other pins in the engine interface connector A.

Greater than 100k ohms?

YES NO
No Repair

A pin-to-pin short circuit has be detected in the engine harness.

Repair or replace the harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connecter seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 2-pin connector at the INLINE™ module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2192 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2188 is inactive.

Fault Code 2188 inactive?
YES NO
No Repair

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Oct-2014


FAULT CODE 2192 - Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2192 active?
STEP 2. | Check the heated oxygen sensor and INLINE™ module. |
 | STEP 2A. Inspect the INLINE™ module and heated oxygen sensor. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage 13.6 to 14.0-VDC?
 | STEP 2C. Check the heated oxygen sensor heater. | Resistance between 2.9 to 3.7 ohms?
 | STEP 2D. Check for an open circuit in the INLINE™ module. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit to ground in the INLINE™ module. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the INLINE™ module. | Greater than 100k ohms?
STEP 3. | Check the heater supply/return circuit in the INLINE™ module. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short cicuit. | Greater than 100k ohms?
STEP 4. | Check the 2-pin to 35-pin engine harness. |
 | STEP 4A. Inspect the 2-pin to 35-pin connectors pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the 2-pin to 35-pin engine harness. | Less than 10k ohms?
 | STEP 4C. Check for a short circuit to ground in the 2-pin to 35-pin engine harness. | Greater than 100K ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the 2-pin to 35-pin engine harness. | Greater than 100K ohms?
STEP 5. | Check the customer interface box (CIB) circuit. |
 | STEP 5A. Check the OEM terminal strip supply voltage. | Supply voltage 13.6 to 14.0-VDC?
 | STEP 5B. Inspect the relay. | Resistance between 420 and 520 ohms?
 | STEP 5C. Check the switched mode 24 to 13.8-VDC converter. | Supply voltage 24-VDC?
 | STEP 5D. Check the OEM supply voltage circuit. | Issues or damage found?
STEP 6. | Check the ECM and the engine harness. |
 | STEP 6A. Inspect the engine harness interface connector A and 2-pin connector pins. | Dirty or damaged pins?
 | STEP 6B. Check for an open circuit. | Less than 10 ohms?
 | STEP 6C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 6D. Check for a pin-to-pin short cicuit. | Greater than 100k ohms?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 2192 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2192 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the heated oxygen sensor and INLINE™ module.

Guided Step 2A - Inspect the INLINE™ module and heated oxygen sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.
  • Disconnect the INLINE™ module from the engine harness.

Action

Inspect the INLINE™ module and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or in the INLINE™ module connector.

Repair the damaged pins. Repair or replace the INLINE™ module, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the 8-pin AMP™ connector. Refer to Procedure 019-203 in Section 19.
  • Replace the 2-pin Bosch™ connector. Refer to Procedure 019-214 in Section 19.
  • Replace the 2-pin Packard™ connector. Refer to Procedure 019-211 in Section 19.
  • Replace the INLINE™ module. Refer to Procedure 019-353 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Operate engine for more than 45 second.
  • Disconnect the heated oxygen sensor from the INLINE™ module .

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the voltage between the heater SUPPLY pin and the heater RETURN pin in the INLINE™ module connector.

Supply voltage 13.6 to 14.0-VDC?
YES NO
No Repair

There is an issue in the sensor supply voltage circuit. The sensor is not getting enoughvoltage to function properly.

NOTE: Make sure the 3 ampere fuse is not blown in the INLINE™ module. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the heated oxygen sensor heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.

Action

Check the heated oxygen sensor heater.

Measure the resistance between the heater SUPPLY pin and the heater RETURN pin at the heated oxygen sensor connector.

Resistance is between 2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Go to 2D

Go to 7A

Guided Step 2D - Check for an open circuit in the INLINE™ module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.
  • Disconnect the INLINE™ module from the 2-pin to 35-pin engine harness.

Action

Check for an open circuit.

Measure the resistance between the the compensating resistor SIGNAL pin on the INLINE™ module heated oxygen sensor connector and the compensating resistor SIGNAL pin on the INLINE™ module engine harness 2-pin connector.

Measure the resistance between the the compensating resistor SIGNAL pin on the INLINE™ module heated oxygen sensor connector and the compensating resistor SIGNAL pin on the INLINE™ module engine harness 2-pin connector.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the INLINE™ module.

Replace the INLINE™ module.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the INLINE™ module. Refer to Procedure 019-353 in section 19.

Go to 2E

Go to 7A

Guided Step 2E - Check for a short circuit to ground in the INLINE™ module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.
  • Disconnect the INLINE™ module from the engine harness.

Action

Check for a short circuit to ground.

Measure the resistance between the compensating resistor SIGNAL pin on the oxygen sensor connector and ground.

Measure the resistance between the compensating resistor RETURN pin on the oxygen sensor connector and ground.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the INLINE™ module.

Replace the INLINE™ module.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the INLINE™ module. Refer to Procedure 019-353 in section 19.

Go to 2F

Go to 7A

Guided Step 2F - Check for a pin-to-pin short circuit in the INLINE™ module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.
  • Disconnect the INLINE™ module from the engine harness.

Action

Check for a pin-to-pin short.

Measure the resistance between the compensating resistor SIGNAL pin on the oxygen sensor connector and and all other pins in the INLINE™ module .

Measure the resistance between the compensating resistor RETURN pin on the oxygen sensor connector and all other pins in the INLINE™ module.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the INLINE™ module.

Replace the INLINE™ module.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the INLINE™ module. Refer to Procedure 019-353 in section 19.

Go to 6A

Go to 7A

Guided Step 3 - Check the heater supply/return circuit in the INLINE™ module.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the INLINE™ module.
  • Disconnect the INLINE™ module from the 2-pin to 35-pin engine harness.

Action

Check for an open circuit.

Measure the resistance between the the heater SUPPLY pin on the INLINE™ module heated oxygen sensor connector and the heater SUPPLY pin on the INLINE™ module engine harness 2-pin connector.

Measure the resistance between the heater RETURN pin on the INLINE™ module heated oxygen sensor connector and the heater RETURN pin on the INLINE™ module engine harness 2-pin connector.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?

YES NO
No Repair

An open circuit has been detected in the INLINE™ module.

Replace the INLINE™ module.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connecter seal if it damaged or missing.

Replace the INLINE™ module. Refer to Procedure 019-353 in section 19.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconect the INLINE™ module from the heated oxygen sensor.
  • Disconnect the INLINE™ module from the 2-pin to 35-pin engine harness.

Action

Check for a short circuit to ground.

Measure the resistance between the heater SUPPLY pin in the INLINE™ module heated oxygen sensor connector and ground.

Measure the resistance between the heater RETURN pin in the INLINE™ module heated oxygen sensor connector and ground.

Refer to circuit diagram or wiring diagram for connector pin identificatio

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in section 19.

Greater than 100k ohms?

YES NO
No Repair

A short circuit has been detected in the INLINE™ module.

Replace the INLINE™ module.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connecter seal if it is damaged or missing.

Replace the INLINE™ module. Refer to Procedure 019-353 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a pin-to-pin short cicuit

Conditions

  • Turn keyswitch OFF.
  • Disconect the INLINE™ module from the heated oxygen sensor.
  • Disconnect the INLINE™ module from the 2-pin to 35-pin engine harness.

Action

Check for a pin-to-pin short circuit.

Measure the resistance between the heater SUPPLY pin in the INLINE™ module heated oxygen sensor connector and all other pins in the INLINE™ module heated oxygen sensor connector.

Measure the resistance between the heater RETURN pin in the INLINE™ module heated oxygen sensor connector and all other pins in the INLINE™ module heated oxygen sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has be detected in the INLINE™ module.

Replace the INLINE™ module.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Replace the INLINE™ module. Refer to Procedure 019-353 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the 2-pin to 35-pin engine harness.

Guided Step 4A - Inspect the 2-pin to 35-pin engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 2-pin to 35-pin engine harness from the INLINE™ module.
  • Disconnect the 35-pin connector at the customer interface box (CIB).

Action

Inspect the engine harness 35-pin and 2-pin connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Damage has been found in the engine interface A connector or 2-pin connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the 2-pin Bosch™ connector. Refer to Procedure 019-214 in Section 19.
  • Replace the 35-pin ITT Cannon™ connector. Refer to Procedure 019-219 in Section 19.
  • Repair the 2-pin to 35-pin engine harness. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check for an open circuit in the 2-pin to 35-pin engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 2-pin to 35-pin engine harness from the INLINE™ module.
  • Disconnect the 35-pin connector at the CIB

Action

Check for an open circuit.

Measure the resistance between the engine heated oxygen 13 volt SUPPLY pin in the 35-pin connector and the engine heated oxygen 13 volt SUPPLY pin in the 2-pin connector.

Measure the resistance between the engine heated oxygen RETURN pin in the 35-pin connector and the engine hated RETURN pin in the 2-pin connector.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in section 19.

Less than 10 ohms?

YES NO
No Repair

An open circuit has been detected in the 2-pin to 35-pin engine harness.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connecter seal if it is damaged or missing.

Repair the 2-pin to 35-pin engine harness. Refer to Procedure 019-204 in Section 19.

Replace the 2-pin to 35-pin engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit to ground n the 2-pin to 35-pin engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 2-pin to 35-pin engine harness from the INLINE™ module.
  • Disconnect the 35-pin connector at the customer interface box (CIB).

Action

Check for a short circuit to ground.

Measure the resistance between the engine heated oxygen 13 volt SUPPLY pin in the 35-pin connector and ground.

Measure the resistance between the engine heated oxygen RETURN pin in the 35-pin connector and ground.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the 2-pin to 35-pin engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the 2-pin to 35-pin engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the 2-pin to 35-pin engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a pin-to-pin short circuit in the 2-pin to 35-pin engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 2-pin to 35-pin engine harness from the INLINE™ module.
  • Disconnect the 35-pin connector at the CIB.

Action

Check for a pin-to-pin short circuit.

Measure the resistance between the engine heated oxygen 13 volt SUPPLY pin in the engine harness 35-pin connector and all other pins in the CIB 35-pin connector.

Measure the resistance between the engine heated oxygen RETURN pin in the engine harness 35-pin connector and all other pins in the CIB 35-pin connector.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the 35-pin engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the 2-pin to 35-pin engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the 2-pin to 35-pin engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the Customer Interface Box (CIB) .

Guided Step 5A - Check the CIB Supply Voltage.

Conditions

  • Operate engine for more than 45 seconds.
  • Disconnect the sensor harness from the OEM CIB 35-pin connector from the engine harness 35-pin connector.

Action

Measure the voltage between the engine heated oxygen 13 volt SUPPLY pin and the engine heated oxygen RETURN pin in the CIB 35-pin connector.

Supply voltage 13.6 to 14.0-VDC?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the CIB 35-pin connector from the engine harness 35-pin connector.
  • Remove the oxygen sensor relay (CR1).
  • Make sure the ambient air temperature is between 65-85°F.

Action

Check the Oxygen Sensor relay resistance across the coil.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 420 and 520 ohms?
YES NO
No Repair

Replace the relay. Refer to the OEM service manual for replacement instructions.

Go to 5C

Go to 7A

Guided Step 5C - Check the switched mode 24 to 13.8-VDC converter.

Conditions

  • Turn keyswitch ON.
  • Operate engine for more than 45 seconds.

Action

Measure the supply voltage to the switched mode 24 to 13.8-VDC converter.

Measure the voltage from the battery +24-VDC wire to the battery negative wire going into the switched mode 24 to 13.8-VDC converter.

Measure the voltage from the switched battery +24-VDC wire to the battery negative wire going into the switched mode 24 to 13.8-VDC converter.

Refer to circuit diagram or wiring diagram and the OEM service manual for wire names and detailed component location.

Supply voltage 24-VDC?
YES NO
No Repair

If there is 24-VDC going to the switched mode 24 to 13.8-VDC converter and not 13.8-VDC out, a damaged converter has been detected.

  • Replace the switched mode 24 to 13.8-VDC converter. Refer to the OEM service manual.

Go to 5D

Go to 7A

Guided Step 5D - Check the OEM supply voltage circuit.

Conditions

  • Operate engine for more than 45 seconds.

Action

Check the OEM control panel for damaged wires, shorts, or open circuits.

Possible causes:

  • Blown fuse
  • Malfunctioning 24 to 13.8-VDC converter
  • Low battery voltage.

Refer to OEM wiring diagram for wire names and component location.

Issues or damage found?
YES NO

  • Repair or replace the damaged components or wires. Refer to the OEM service manual.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the ECM and the engine harness.

Guided Step 6A - Inspect the engine harness interface connector A and 2-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the INLINE™ module.
  • Disconnect engine interface connector A.

Action

Inspect the engine harness 2-pin connector and engine interface connector A for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Damage has been found in the engine interface A connector or 2-pin connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510
  • Install the appropriate conecter seal if it damaged or missing.
  • Repair or replace the engine interface connector A. Refer to Procedure 019-204 in section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in section 19.
  • Replace the engine harness. Refer to Procedure 019-043 insection 19.

No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the INLINE™ module
  • Disconnect engine interface connector A.

Action

Check for an open circuit.

Measure the resistance between the engine heated oxygen (0 to 5 volt) SIGNAL pin in the engine interface connector A and the engine heated oxygen (0 to 5 volt) SIGNAL pin in the 2-pin connector.

Measure the resistance between the engine heated oxygen (0 to 5 volt) RETURN pin in the engine interface connector A and the engine heated oxygen (0 to 5 volt) RETURN pin in the 2-pin connector.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?

YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate conecter seal if it damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in section 19.

Go to 6C

Go to 7A

Guided Step 6C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the INLINE module.
  • Disconnect engine interface connector A.

Action

Check for a short circuit to ground.

Measure the resistance between the engine heated oxygen (0 to 5 volt) SIGNAL pin in the engine interface connector A and ground.

Measure the resistance between the engine heated oxygen (0 to 5 volt) RETURN pin in the engine interface connector A and ground.

Greater than 100k ohms?

YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harneess.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Install the appropriate conecter seal if it damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in section 19.
  • Replace the engine harness. Refer to Procedure 019-043 insection 19.

Go to 6D

Go to 7A

Guided Step 6D - Check for a pin-to-pin short cicuit

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the INLINE™ module.
  • Disconnect engine interface connector A.

Action

Check for a pin-to-pin short circuit.

Measure the resistance between the engine heated oxygen (0 to 5 volt) SIGNAL pin in the engine interface connector A and all other pins in the engine interface connector A.

Measure the resistance between the engine heated oxygen (0 to 5 volt) RETURN pin in the engine interface connector A and all other pins in the engine interface connector A.

Greater than 100k ohms?

YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electarical contact cleaner, Part Number 3824510.
  • Install the appropriate conecter seal if it damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in section 19.
  • Replace the engine harness. Refer to Procedure 019-043 insection 19.

Go to 6E

Go to 7A

Guided Step 6E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 2-pin connector at the INLINE™ module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2192 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in section 19.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2192 is inactive.

Fault Code 2192 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Oct-2014


FAULT CODE 2217 - Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 2217 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check the ECM for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Calibrate the ECM. | ECM calibrated?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2217 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Recycle the power to the ECM using the keyswitch.
  • Use INSITE™ electronic service tool to check for fault codes.

Fault Code 2217 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the 35-pin (C4) connector as a possible source of an intermittent power supply.

Constant +24-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 35-pin (C4) OEM connector. Refer to the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655.

Go to 1C

Go to 2A

Guided Step 1C - Check the ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connectors A and B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

Greater than 100k ohms?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

ECM calibrated?
YES NO
No Repair

Active fault codes present.

Replace the ECM.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 2217 is inactive.

Fault Code 2217 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2014


FAULT CODE 2219 - Heated Oxygen Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM)all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 2. | Check the engine harness and engine heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and engine heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 3. | Check the fuel pressure. |
 | STEP 3A. Verify secondary fuel pressure. | Pressure correct for the engine family?
 | STEP 3B. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
STEP 4. | Check the intake and exhaust system. |
 | STEP 4A. Check the intake and exhaust system for air leaks. | Air leaks?
STEP 5. | Verify emissions. |
 | STEP 5A. Measure oxygen concentration. | In range?
 | STEP 5B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2219 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and engine heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and engine heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine interface connector A from the ECM.
  • Disconnect the engine heated oxygen sensor from the engine harness.

Action

Inspect the engine interface connector A and engine heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or engine heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A from the ECM.
  • Disconnect the engine heated oxygen sensor from the engine harness.
  • Disconnect inline module from the engine harness.

Action

Check for an open circuit.

  • Measure resistance from the engine heated oxygen SIGNAL (0 to 5 volt) pin in the engine interface connector A of the harness to the engine heated oxygen SIGNAL(0 to 5 volt) pin at the INLINE™ module connector.
  • Measure resistance from the engine heated oxygen RETURN (0 to 5 volt) pin in the engine interface connector A of the harness to the engine heated oxygen RETURN (0 to 5 volt) pin at the INLINE™ module connector.
  • Measure resistance from the engine heated oxygen SIGNAL (0 to 65 mV) pin in the engine interface connector A of the harness to the engine heated oxygen SIGNAL (0 to 65 volt) pin at the INLINE™ module connector.
  • Measure resistance from the engine heated oxygen RETURN (0 to 65 mV) pin in the engine interface connector A of the harness to the engine heated oxygen RETURN (0 to 65 volt) pin at the INLINE™ module connector.
  • Measure the resistance between the heater RETURN pin in the INLINE™ module connector and the heater RETURN pin in the engine heated oxygen sensor connector.
  • Measure the resistance between the heater SUPPPLY pin in the INLINE™ module connector and the heater SUPPPLY pin in the engine heated oxygen sensor connector.
  • Measure the resistance between the compensating resistor SIGNAL pin in the INLINE™ module connector and the compensating resistor SIGNAL pin in the engine heated oxygen sensor connector.
  • Measure the resistance between the compensating resistor RETURN pin in the INLINE™ module connector and the compensating resistor RETURN pin in the engine heated oxygen sensor connector.
  • Measure the resistance between the reference voltage pin in the INLINE™ module connector and the reference voltage pin in the engine heated oxygen sensor connector.
  • Measure the resistance between the ground pin in the INLINE™ module connector and the ground pin in the engine heated oxygen sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Check the connection at the 2-pin connector in the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A and connector B from the ECM.
  • Disconnect the engine heated oxygen sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine heated oxygen SIGNAL (0 to 5 volt) pin in the engine interface connector A at the engine harness and all other pins in the engine interface connector A and B at the engine harness.
  • Measure the resistance between the engine heated oxygen RETURN (0 to 5 volt) pin in the engine interface connector A at the engine harness and all other pins in the engine interface connector A and B at the engine harness.
  • Measure the resistance between the engine heated oxygen SIGNAL (0 to 65 mVolt) pin in the engine interface connector A at the engine harness and all other pins in the engine interface connector A and B at the engine harness.
  • Measure the resistance between the engine heated oxygen RETURN (0 to 65 mVolt) pin in the engine interface connector A at the engine harness and all other pins in the engine interface connector A and B at the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 6A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 3A

Guided Step 3 - Check the fuel pressure.

Guided Step 3A - Verify secondary fuel pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet.
  • Operate the engine at idle with no load.
  • Fuel pressure must be between 5 to 6 in H2O.

Pressure correct for the engine family?
YES NO
No Repair

For more troubleshooting details on low fuel pressure issues, go to Fault Code 2119.

Go to 4A

Go to 6A

Guided Step 3B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel control valve position feedback and commanded position while the keyswitch is on.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO
No Repair

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 4A

Go to 6A

Guided Step 4 - Check for intake and exhaust systems.

Guided Step 4A - Check the intake and exhaust system for air leaks.

Conditions

  • Turn keyswitch ON.
  • Start engine.

Action

Check the intake and exhaust system for air leaks.

Use the following procedure in the Service Manual KTA19GC CM558, Bulletin 4021653. Refer to Procedure 010-024 in Section 10.

Air leaks?
YES NO

Use the following procedure in the Service Manual KTA19GC CM558, Bulletin 4021653. Refer to Procedure 010-024 in Section 10.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Verify emmissions.

Guided Step 5A - Measure the oxygen concentration.

Conditions

  • Operate engine at the highest load possible based on applicable derates.
  • Connect oxygen meter.

Action

Measure the oxygen concentration.

Use an oxygen meter to measure the oxygen concentration and compare to the value in the KTA19GC CM558 Operation and Maintenance Manual, Bulletin 4021652. Refer to Procedure 018-016 in Section V.

In range?
YES NO

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Check engine setup. Use the following procedure in the O&M manual, Bulletin 4021652. Refer to Procedure 307-001 in Section H.

Go to 6A

Go to 6A

Guided Step 5B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 6B

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2219 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Oct-2014


FAULT CODE 2221 - Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 2. | Check the ignition system. |
 | STEP 2A. Check for ignition system faults. | Ignition system faults?
 | STEP 2B. Check for ignition system misfire. | Ignition system misfire?
STEP 3. | Inspect the engine harness and heated oxygen sensor. |
 | STEP 3A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the heated oxygen sensor heater supply voltage. | Voltage greater than 12-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 4. | Check the fuel control valve. |
 | STEP 4A. Check the fuel pressure. | Fuel pressure correct for the engine family?
 | STEP 4B. Check for a stuck open fuel control valve. |
STEP 5. | Check the exhaust systems. |
 | STEP 5A. Check for high exhaust back pressure. | Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
STEP 6. | Verify emissions. |
 | STEP 6A. Measure the oxygen concentration. | In range?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 2219 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ignition system.

Guided Step 2A - Check for ignition system faults.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for ignition system faults.

  • Use the following procedure in the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655, for instructions on how to check for ignition system faults. Refer to Procedure 101-013 in Section 1.

Ignition system faults?
YES NO

Use the following procedure in the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655, for instructions on how to check for ignition system faults. Refer to Procedure 101-013 in Section 1.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check for ignition system misfire.

Conditions

  • Turn keyswitch ON.

Action

Check for an ignition system misfire.

  • Reference the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655.

Ignition system misfire?
YES NO

Reference the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655 for instructions on how to troubleshoot the ignition system.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the engine harness and heated oxygen sensor.

Guided Step 3A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A from the ECM.
  • Disconnect the engine heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and engine heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or engine heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the Heated Oxygen Sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check for pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A from the ECM.
  • Disconnect the engine heated oxygen sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure resistance from the engine heated oxygen SIGNAL (0 to 5 volt) pin in the engine interface connector A of the harness to the engine block ground.
  • Measure resistance from the engine heated oxygen RETURN (0 to 5 volt) pin in the engine interface connector A of the harness to the engine block ground.
  • Measure resistance from the engine heated oxygen SIGNAL (0 to 65 mV) pin in the engine interface connector A of the harness to the engine block ground.
  • Measure resistance from the engine heated oxygen RETURN (0 to 65 mV) pin in the engine interface connector A of the harness to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 ) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 7A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A and connector B from the ECM.
  • Disconnect the engine heated oxygen sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine heated oxygen SIGNAL (0 to 5 volt) pin in the engine interface connector A at the engine harness and all other pins in the engine interface connector A and B at the engine harness.
  • Measure the resistance between the engine heated oxygen RETURN (0 to 5 volt) pin in the engine interface connector A at the engine harness and all other pins in the engine interface connector A and B at the engine harness.
  • Measure the resistance between the engine heated oxygen SIGNAL (0 to 65 mV) pin in the engine interface connector A at the engine harness and all other pins in the engine interface connector A and B at the engine harness.
  • Measure the resistance between the engine heated oxygen RETURN (0 to 65 mV) pin in the engine interface connector A at the engine harness and all other pins in the engine interface connector A and B at the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the folowing procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 ) in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Disconnect the heated oxygen sensor from the engine harness. The engine must be operating in open loop (automatic) to perform this check. Once the engine is started, the checks will have to be made within 90 seconds, before the engine shuts down.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES NO
No Repair

An open circuit or shorted to ground has been detected on the heated oxygen sensor supply line in the engine harness. An open circuit in the heated oxygen sensor return line can also be a possible fail mode.

Check for a blown, corroded, or wet fuse in the heated oxygen heater supply line.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 7A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 7B

Go to 4A

Guided Step 4 - Check the fuel pressure.

Guided Step 4A - Verify secondary fuel pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet.
  • Operate the engine at idle with no load.
  • Fuel pressure must be between 5 to 6 in H2O.

Fuel pressure correct for the engine family?
YES NO
No Repair

Troubleshoot the fuel pressure issues. Use the following procedure in the KTA19GC CM558/CM2358 Operation and Maintenance Manual, Bulletin 4021652. Refer to Procedure 307-001 in Section H.

Go to 4B

Go to 5A

Guided Step 4B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve commanded position and position feedback while the keyswitch is ON.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO
No Repair

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the exhaust systems.

Guided Step 5A - Check for high exhaust back pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the exhaust system for higher than specified exhaust back pressure.

  • Check the exhaust back pressure by installing a pressure gauge into the exhaust system just past the turbocharger outlet.

Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
YES NO
No Repair

Use the following procedure in Service Manual KTA19 CM558, Bulletin 4021653. Refer to Procedure 011-009 in Section 11.

Go to 7A

Go to 7A

Guided Step 6 - Verify emmissions.

Guided Step 6A - Measure the oxygen concentration

Conditions

  • Operate engine at the highest load possible, based on applicable derates.
  • Connect oxygen meter.

Action

Measure oxygen concentration.

  • Use an oxygen meter to measure the oxygen concentration and compare to value in the KTA19GC CM558/CM2358 Operation and Maintenance Manual, Bulletin 4021652. Refer to Procedure 018-016 in Section V.

In range?
YES NO

Replace the oxygen sensor. Refer to Procedure 019-100 in Section 19.

Use the following procedure in the Operation and Maintenance Manual KTA19GC CM558/CM2358, Bulletin 4021652. Check engine setup. Refer to Procedure 307-001 in Section H.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2219 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Oct-2014


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve for a short. | Greaer than 40 to 120K ohms??
 | STEP 2C. Check the electronic fuel control valve for a short to battery. | Voltage below 1 volt?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for short pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check for an intermittent engine harness problem. | Fault Code 2311 intermittent?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve for a short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel injector control valve command and the electronic fuel injection control valve command return.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 and the Wiring Diagram.

Greater than 40 to 120k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve voltage.

  • Measure the voltage between the electronic fuel injector control valve command and the electronic fuel injection control valve command return at the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is voltage below 1 volt?
YES NO
No Repair

Find the source of the voltage and repair.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.
  • Disconnect the engine interface connector B from the ECM.
  • Disconnect the battery.

Action

Check the engine harness continuity.

  • Measure the resistance between the electronic fuel injector control valve command pin on ECM interface connector B and at the engine electronic fuel valve 1 interface connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Sectio 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.
  • Disconnect the engine interface connector B from the ECM.

Action

Check the engine harness for a short to ground.

  • Measure the resistance between the electronic fuel injector control valve command pin on ECM interface connector B to the battery return post.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A and B.

Action

Check the engine harness for a pin to pin short.

  • Measure the resistance between the electronic fuel injector control valve command pin on ECM interface connector B and all other pins on the ECM connector B and A interface.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine interface connector B and working to the electronic fuel cotrol valve.

Fault Codes 2311 intermittent?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged component. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2012


FAULT CODE 2315 - Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for any other active fault codes. | Fault Codes active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | No damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2315 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for any other active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for any other active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes active?
YES NO

Troubleshoot any remaining fault codes before proceeding.

 No Repair

Go to 2A

Go to 1B

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Trun keyswitch OFF.
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Replace the engine harness or ECM, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A and B from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from red lamp stop driver pin in the engine interface connector A to all of the other pins in engine interface connectors A and B.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 2315 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2012


FAULT CODE 2316 - Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2316 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connectors A and B from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pin
  • Moisture in or on connector.
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine interface connectors or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connectors A and B from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from the amber warning lamp driver pin in the engine interface connector to all of the other pins in the engine interface connectors A and B.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 2316 inactive?
YES NO

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO

Troubleshoot any remaining active fault codes.

Troubleshoot any remaining active fault codes.

Appropriate troubleshooting chart

Repair complete

Last Modified: 21-Jul-2012


FAULT CODE 2317 - Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead, Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2317 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connectors A and B from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pin
  • Moisture in or on connector.
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine interface connectors or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connectors A and B from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from the amber warning lamp driver pin in the engine interface connector A to all of the other pins in the engine interface connectors A and B.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connectors A and B from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the amber warning light driver pin in the engine interface connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.

Fault Code 2317 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Appropriate troubleshooting chart

Repair complete

Last Modified: 21-Jul-2012


FAULT CODE 2455 - External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead, Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit in the wiring. | Greater than 100k ohms?
STEP 2. | Check the customer interface box. |
 | STEP 2A. Check the 35-pin connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the customer interface box. | Less than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the resistance in external governor speed or frequency bias SIGNAL (4-20mA) wire. | Less than 10 ohms?
 | STEP 3B. Check the resistance in external governor speed or frequency bias RETURN (4-20mA) wire. | Less than 10 ohms?
 | STEP 3C. Check the resistance in external governor speed or frequency bias SIGNAL (4-20mA) wire. | Less than 10 ohms?
 | STEP 3D. Check the resistance in external governor speed or frequency bias RETURN wire. | Less than 10 ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2455 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the 35 pin connector (C4)
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Go to the KTA19 G CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the engine harness connector.

Repair or replace the engine harness.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for a short circuit to the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the 35 pin connector (C4).

Action

Check for a short circuit to the wiring harness as follows:

  • Measure the resistance from the external governor speed or frequency bias signal (4-20mA) pin in the 35 pin connector (C4) on the engine harness side to all other pins in the 35 pin connector (C4).

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 2 - Check the customer interface box.

Guided Step 2A - Inspect the 35-pin connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4).

Action

Inspect the 35-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

For applications that have OEM supplied Customer Interface Box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Dirty or damaged pins?

YES NO

Repair the damaged pins or connector.

  • Repair the harness. Refer to Procedure 019-209 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the customer interface box.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4) from customer interface box.

Action

Check for a short circuit in the wiring harness as follows:

  • Measure the resistance from the external governor speed or frequency bias signal (4-20mA) pin in the 35 pin (C4) connector on the customer interface box side to the other pins in the 35-pin connector.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • For applications that have OEM supplied Customer Interface Box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Less than 100k ohms?
YES NO
No Repair

  • Repair the customer interface box. For applications that have OEM supplied Customer Interface Box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Go to 3C

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the resistance in external governor speed or frequency bias SIGNAL (4-20mA) wire.

Conditions

  • Disconnect engine interface connector A from ECM
  • Disconnect 35 pin connector (C4) from the customer interface box.

Action

Check the resistance in external governor speed or frequency bias SIGNAL (4-20mA) wire.

  • Measure the resistance from the external governor speed or frequency bias SIGNAL (4-20mA) wire in the engine interface connector A to the external governor speed or frequency bias SIGNAL (4-20mA) wire in the 35 pin connector (C4) on the engine harness.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance in external governor speed or frequency bias RETURN (4-20mA) wire.

Conditions

  • Disconnect engine interface connector A from ECM
  • Disconnect 35 pin connector (C4) from the customer interface box.

Action

Check the resistance in the external governor speed or frequency bias RETURN (4-20mA) wire.

  • Measure resistance from external governor speed or frequency bias RETURN (4-20mA) wire in the engine interface connector A to the external governor speed or frequency bias return (4-20mA) wire in the 35 pin connector (C4) on the engine harness.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 3C - Check the resistance in the external governor speed or frequency bias SIGNAL (4-20mA) wire.

Conditions

  • Disconnect 35 pin connector (C4) from the customer interface box
  • Disconnect the external governor speed or frequency bias SIGNAL (4-20mA) wire from customer terminal strip.

Action

Check the resistance in the external governor speed or frequency bias SIGNAL (4-20mA) wire.

  • Measure resistance from external governor speed or frequency bias SIGNAL (4-20mA) wire at the 35 pin connector (C4) at the customer interface box to the external governor speed or frequency bias SIGNAL (4-20mA) wire at the customer terminal strip.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the wire or connector.

  • Repair the harness. Refer to Procedure 019-209 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check resistance in external governor speed or frequency bias RETURN wire.

Conditions

  • Disconnect 35 pin connector (C4) from the customer interface box
  • Disconnect external governor speed or frequency bias return wire from customer terminal strip.

Action

Check resistance in external governor speed or frequency bias RETURN wire.

  • Measure resistance from external governor speed or frequency bias RETURN wire at the 35 pin connector (C4) at the customer interface box to the external governor speed or frequency bias SIGNAL (4-20mA) wire at the customer terminal strip.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the wire or connector.

  • Repair the harness. Refer to Procedure 019-209 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2455 is inactive.

Fault Code 2455 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2014


Fault Code 2456 - External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead, and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the customer interface box. |
 | STEP 1A. Inspect the 35-pin connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit in the wiring harness. | Greater than a 100k ohms?
 | STEP 1B-1. Check resistance in external governor speed or frequency bias SIGNAL (4-20mA) wire. |
 | STEP 1B-2. Check resistance in external governor speed or frequency bias RETURN wire. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2456 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the customer interface box.

Guided Step 1A - Inspect the 35-pin connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35 pin connector (C4).

Action

Inspect the 35 pin connector (C4) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 (in Section 19.

For applications that have OEM supplied customer interface box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Dirty or damaged pins?
YES NO

Repair the damaged pins or connector. Refer to Procedure 019-209 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4).

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from block ground to all other pins in the 35-pin connector at the CIB.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • For applications that have OEM supplied customer interface box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Greater than 100k ohms?
YES NO
No Repair

Repair the customer interface box wiring.

  • Use the following for troubleshooting steps related to the CIB on applications that have an OEM supplied CIB. Refer to the OEM service manual.

Go to 1B-1

Go to 3A

Guided Step 1B-1 - Check resistance in external governor speed or frequency bias SIGNAL (4-20mA) wire.

Conditions

  • Disconnect 35 pin connector (C4) from the customer interface box
  • Disconnect external governor speed or frequency bias SIGNAL (4-20mA) wire from customer terminal strip.

Action

Check resistance in external governor speed or frequency bias SIGNAL (4-20mA) wire.

  • Measure resistance from external governor speed or frequency bias SIGNAL (4-20mA) wire at the 35 pin connector (C4) at the customer interface box to the external governor speed or frequency bias SIGNAL (4-20mA) wire at the customer terminal strip.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the wire or connector. Refer to Procedure 019-209 in Section 19.

Go to 1B-1

Go to 3A

Guided Step 1B-2 - Check resistance in external governor speed or frequency bias RETURN wire.

Conditions

  • Disconnect 35 pin connector (C4) from the customer interface box
  • Disconnect external governor speed or frequency bias RETURN wire from customer terminal strip.

Action

Check resistance in external governor speed or frequency bias RETURN wire.

  • Measure resistance from external governor speed or frequency bias RETURN wire at the 35 pin connector (C4) at the customer interface box to the external governor speed or frequency bias SIGNAL (4-20mA) wire at the customer terminal strip.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the wire or connector. Refer to Procedure 019-209 in Section 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference to KTA19 G Panel Master Repair Manual, Bulletin 4021655.

Dirty or damaged pins?
YES NO

  • Repair the damaged pins.
  • Replace the harness or ECM, whichever has the damaged pins.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35 pin connector (C4)
  • Disconnect the engine interface connector A from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from the external governor speed or frequency bias SIGNAL (4-20 mA) pin in the engine interface connector A to all of the other pins in the connector.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let it idle for 1 minute.

Fault Code 2456 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All inactive fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2012


FAULT CODE 2544 - ECM Internal Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2544 active?
YES NO

Allow the ECM to cool and then restart the engine. If the fault reoccurs, contact a Cummins® Authorized Service Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2012


FAULT CODE 2661 - At Least One Unacknowledged Most Severe Fault - ConditionExists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2661 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the engine control module (ECM) reset button or switch inside the customer interface box.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2661 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2012


FAULT CODE 2789 - Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2789 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the coolant temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Below Normal troubleshooting symptom tree in the KTA19GC CM558 Service Manual, Bulletin 4021653.

Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2789 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jan-2011


FAULT CODE 2793 - Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2793 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the coolant temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Below Normal troubleshooting symptom tree in the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653.

Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2793 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jun-2014


Fault Code 2794 - Ignition Module Shutdown Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead, and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the customer interface box. |
 | STEP 1A. Check the 35-pin connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit in the wiring. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2794 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the customer interface box.

Guided Step 1A - Inspect the 35-pin connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4).

Action

Inspect the 35-pin connector (C4) pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For applications that have OEM supplied customer interface box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Reference the KTA19 G CM558 Panel System Master Repair Manual, Bulletin 4021655.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4).

Action

Check for a short circuit in the wiring harness as follows:

  • Measure the resistance from ignition module shutdown relay driver control (keyswitch) pin in the 35-pin connector (C4) at the CIB to the other pins on the 35-pin connector (C4) at the CIB. Reference the KTA19 G CM558/CM2358 Electronic Master Repair Manual, Bulletin 4021655, for further troubleshooting.
  • For applications that have OEM supplied customer interface box (CIB), refer to the OEM service manual for troubleshooting steps related to the CIB.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the customer interface box. Reference the KTA19 G CM558/CM2358 Electronic Master Repair Manual, Bulletin 4021655, for further troubleshooting.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the ECM and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4)
  • Disconnect the engine interface connector A from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from ignition module shutdown relay driver control (keyswitch) pin in the engine interface connector A to all of the other pins in the connector.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2794 is inactive.

Fault Code 2794 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2014


FAULT CODE 2795 - Ignition Module Shutdown Relay Driver Control Circuit - Voltage Below Normal or Shorted to LowSource

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead, and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the customer interface box. |
 | STEP 1A. Check the 35-pin connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit in the wiring. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2795 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the customer interface box.

Guided Step 1A - Inspect the 35-pin connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4).

Action

Inspect the 35-pin connector (C4) pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For applications that have OEM supplied customer interface box (CIB), reference the OEM service manual for troubleshooting steps related to the CIB.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Reference the KTA19 G CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4).

Action

Check for a short circuit in the wiring harness as follows:

  • Measure the resistance from ignition module shutdown relay driver control (keyswitch) pin in the 35-pin connector at the CIB to the other pins on the 35-pin connector in the CIB. Reference the KTA19 G CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655, for further troubleshooting.

For applications that have a OEM supplied Customer Interface Box (CIB), reference the OEM service manual for troubleshooting steps related to the CIB.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the customer interface box. Reference the KTA19 G CM558/CM2358 Panel System Master Repair Manual, Bulletin 4021655, for further troubleshooting. For applications that have a OEM supplied customer interface box (CIB), reference the OEM service manual for troubleshooting steps related to the CIB.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the ECM and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4)
  • Disconnect the engine interface connector A from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from ignition module shutdown relay driver control (keyswitch) pin in the engine interface connector A to all of the other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 35-pin connector (C4)
  • Disconnect the engine interface connector A from the ECM.

Action

Check for a short circuit ito ground as follows:

  • Measure the resistance from ignition module shutdown relay driver control (keyswitch) pin in the engine interface connector A to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2795 is inactive.

Fault Code 2795 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2014


FAULT CODE 2797 - Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2797 inactive?
STEP 2. | Check the carburetor inlet gas differential pressure sensor and circuit. |
 | STEP 2A. Inspect the carburetor inlet gas differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2798 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2797 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2797 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2797 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the carburetor inlet gas differential pressure sensor and circuit.

Guided Step 2A - Inspect the carburetor inlet gas differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.

Action

Inspect the engine harness and carburetor inlet gas differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

Replace the sensor. Refer to Procedure 019-457 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the carburetor inlet gas differential pressure sensor SUPPLY pin (sensor supply 1) and the carburetor inlet gas differential pressure sensor RETURN pin (sensor return 1) at the carburetor inlet gas differential pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the carburetor inlet gas differential pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 active?
YES NO

A damaged sensor has been detected.

Replace the carburetor inlet gas differential pressure sensor.

Refer to Procedure 019-457 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine interface connector A sensor RETURN 1 pin and the carburetor inlet gas differential pressure sensor RETURN (sensor return 1) pin the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A and B from the ECM.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SIGNAL pin in the engine interface connector A and all other pins in the engine interface connector A and B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A and B from the ECM.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A and all the other pins in the engine interface connector A and B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be completed again from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2797 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2014


Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2798 inactive?
STEP 2. | Check the carburetor inlet gas differential pressure sensor and circuit. |
 | STEP 2A. Inspect the carburetor inlet gas differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2798 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2798 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2798 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the carburetor inlet gas differential pressure sensor and circuit.

Guided Step 2A - Inspect the carburetor inlet gas differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.

Action

Inspect the engine harness and carburetor inlet gas differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the carburetor inlet gas differential pressure sensor SUPPLY (sensor supply 1) pin and the carburetor inlet gas differential pressure sensor RETURN (sensor return 1) pin at the carburetor inlet gas differential pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the carburetor inlet gas differential pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 active?
YES NO

A damaged sensor has been detected.

Replace the carburetor inlet gas differential pressure sensor.

Refer to Procedure 019-457 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector A from the ECM.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the sensor RETURN 1 pin in the engine interface connector A and the carburetor inlet gas differential pressure sensor RETURN (sensor return 1) pin in the engine harnes sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connectors A and B from the ECM.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SIGNAL pin in the engine interface connector A and all other pins in the engine interface connector A and B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connectors A and B from the ECM.
  • Disconnect the carburetor inlet gas differential pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A and all the other pins in the engine interface connectors A and B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be completed again from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2798 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2012


FAULT CODE 2864 - Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the valve supply voltage. | 20 to 26-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2864 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2864 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the main engine harness from the fuel shutoff valve.
  • Connect INSITE™ electronic service tool.
  • Crank the engine.

Action

Check the fuel shutoff valve supply voltage.

NOTE: Make sure that the engine is not performing a purge cycle when making this measurement.

20 to 26-VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness.

Refer to the circuit diagram or wiring diagram for component identification.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel shutoff valve and the CM558/CM2358.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel shutoff valve.
  • Disconnect the engine harness from the engine interface connectors A and B.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connectors.
  • Measure the resistance from the fuel shutoff valve driver pin on the engine harness connector to all other pins in the engine harness connectors.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558/CM2358 response.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the fuel shutoff valve.
  • Crank the engine.

Action

Check for the appropriate CM558/CM2358 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2864 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2864 is inactive.

Fault Code 2864 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jun-2014


FAULT CODE 2865 - Power Relay Driver Diagnostics has Detected an Error - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the 35-pin connector (C4) pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Greater than 100k ohms?
 | STEP 1C. Check the customer interface box (CIB) panel and relays. | Any Issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2865 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 35-pin connector (C4).

Action

Inspect the 35-pin connector (C4) pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or connector, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from the ECM.
  • Disconnect the 35-pin connector (C4) from the customer interface box (CIB).

Action

Check for an open circuit.

  • Measure the resistance of the power relay driver command pin in the engine interface connector B to the power relay driver command pin in the 35-pin (C4) connector.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the customer interface box (CIB) panel and relays.

Conditions

  • Turn keyswitch OFF.

Action

Check the CIB, coils, and relays.

  • Refer to the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655.

Any issues?
YES NO

  • Use the following manual for instruction on how to resolve the issue. Refer to the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 35-pin connector (C4).
  • Disconnect the engine interface connecors A and B from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from the power relay driver command pin in the ECM connector to all of the other pins in the connectors.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the power relay driver command pin in the engine interface connector B to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components
  • Start the engine and let it idle for 1 minute.

Fault Code 2865 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO

Troubleshoot any remaining active fault codes.

 No Repair

Appropriate troubleshooting chart

Repair complete

Last Modified: 13-Jun-2014


FAULT CODE 2866 - Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2866 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3C. Check for an intermittent engine harness problem. | Fault Code 2866 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2866 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2866 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the engine electronic fuel valve 1 position SIGNAL pin and the engine electronic fuel valve 1 RETURN pin at the engine electronic fuel valve 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the engine electronic fuel valve 1 position SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine interface connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.
  • Disconnect the engine interface connector B from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance from the engine electronic fuel valve 1 position SIGNAL pin to all other pins in the engine interface connector B on the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2866 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2866 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2012


FAULT CODE 2867 - Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2867 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 2867 becomes active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2867 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2867 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the engine electronic fuel valve 1 position SIGNAL pin and the engine electronic fuel valve 1 RETURN pin at the engine electronic fuel valve 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-102in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the engine electronic fuel valve 1 position SIGNAL pin at the engine electronic fuel valve 1 connector in the engine harness and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine electronic fuel valve 1 connector to the engine harness connector.
  • Disconnect the engine harness connector B from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance between the engine electronic fuel valve 1 position SIGNAL pin and the engine electronic fuel valve 1 RETURN pin at the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.
  • Disconnect the engine harness connector B from the ECM.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the engine electronic fuel valve 1 position SIGNAL pin at the engine harness connector B and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 .

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2867 becomes active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2867 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2012


FAULT CODE 2995 - Intake Manifold Pressure 1 Sensor - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2995 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Read the fault codes. | Fault Code 2995 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2995 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2995 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible. The gauge must be able to read the same pressure range as the sensor.
  • Start the INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-099 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the intake manifold pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in the engine interface connector A to all other pins in the engine interface connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in the engine interface connector A to all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A to all other pins in the engine interface connector A.
  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A to all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2995 active?
YES NO

See the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS of the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021641.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2995 is inactive.

Fault Code 2995 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Oct-2014


FAULT CODE 2996 Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2996 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2996 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2996 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Fault Code 2996 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible. The gauge must be able to measure 345 kPa [50 psi].
  • Start INSITE™ Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-099 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the intake manifold pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the engine harness and engine control module (ECM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the engine harness or ECM connector pins.

Repair or replace the engine harness or the replace the ECM.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in the engine interface connector A to all other pins in the engine interface connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in the engine interface connector A to all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A to all other pins in the engine interface connector A.
  • Measure the resistance between the sensor SUPPLY 1 pin in the engine interface connector A to all other pins in the engine interface connector B.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2996 active?
YES NO

See the Intake Manifold Air Temperature Above Normal troubleshooting symptom chart in Section TS of the Service Manual KTA19GC CM558/CM2358, Bulletin 4021653.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2996 is inactive.

Fault Code 2996 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Oct-2014


FAULT CODE 2997 - Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ignition system |
 | STEP 1A. Check the ignition system for faults. | Ignition system faults?
 | STEP 1B. Check for ignition system misfire. | Ignition system misfire?
STEP 2. | Check the engine harness and heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check the heated oxygen sensor heater supply voltage. | Voltage greater than 12-VDC?
 | STEP 2E. Check for an inactive fault code. | Fault Code 2997 inactive?
STEP 3. | Check the fuel pressure. |
 | STEP 3A. Check for a stuck open fuel control valve. | Fuel valve position feedback match commanded position?
 | STEP 3B. Verify the secondary fuel pressure. | Pressure correct for engine family?
STEP 4. | Check the exhaust systems. |
 | STEP 5A. Check for high exhaust back pressure. | Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
STEP 5. | Verify emissions. |
 | STEP 5A. Measure the oxygen concentration. | In range?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2997 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ignition system.

Guided Step 1A - Check for ignition system faults.

Conditions

  • Turn keyswitch ON.

Action

Check for ignition system faults.

  • Refer to the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655.

Ignition system faults?
YES NO

  • Refer to the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655, for instruction on how to troubleshoot the ignition system.

 No Repair

Go to 6A

Go to 1B

Guided Step 1B - Check for ignition system misfire.

Conditions

  • Turn keyswitch ON.

Action

Check for ignition system misfire.

  • Refer to the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655, for instruction on how to check for ignition system spark voltage counts (CAVGs).

Ignition system misfire?
YES NO

  • Refer to the Master Repair Manual KTA19GC CM558/CM2358 Panel System, Bulletin 4021655, for instruction on how to troubleshoot the ignition system.

 No Repair

Go to 6A

Go to 2A

Guided Step 2 - Check the engine harness and heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connector A from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.
  • Disconnect the 35-pin (C4) connector from the customer interface box (CIB).

Action

Check for a pin short to ground.

  • Measure the resistance from the engine heated oxygen 13 volt supply pin in the 35-pin (C4) connector on the harness to engine block ground.
  • Measure the resistance between the engine harness engine interface connector A heated oxygen sensor SIGNAL pins and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine interface connectors A and B from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.
  • Disconnect the 35-pin (C4) connector from the customer interface box (CIB).

Action

Check for a pin-to-pin short.

  • Measure the resistance between the heated oxygen sensor SIGNAL pins to all other pins in the engine harness engine interface connectors A and B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 6A

Guided Step 2D - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heater SUPPLY pin and the heater RETURN pin at the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES NO
No Repair

An open circuit or shorted to ground has been detected on the heated oxygen sensor SUPPLY line in the engine harness. An open circuit in the heated oxygen sensor RETURN line can also be a possible fail mode.

Check for a blown, corroded or wet fuse in the heated oxygen heater SUPPLY line.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 6A

Guided Step 2E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2997 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 3A

Guided Step 3 - Check the fuel pressure.

Guided Step 3A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the fuel valve commanded position and position feedback while the keyswitch is ON.

Note: If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Fuel valve position feedback match commanded position?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Verify secondary fuel pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Install a water or digital manometer on the secondary fuel pressure regulator outlet.
  • Operate the engine at idle with no load.
  • The fuel pressure must be 127 to 152 mm H2O [5 to 6 in H2O]

Fuel pressure correct for engine family?
YES NO
No Repair

Troubleshoot the fuel pressure issues. Use the following procedure in the KTA19GC CM558/CM2358 Operation and Maintenance Manual, Bulletin 4021652. Refer to Procedure 307-001 in Section H.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust systems.

Guided Step 4A - Check for high exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for higher than specified exhaust back pressure.

  • Check the exhaust back pressure by installing a pressure gauge into the exhaust system just past the turbocharger outlet.
  • Use the following procedure in the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653. Refer to Procedure 011-009 in Section 11.

Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
YES NO
No Repair

Follow the troubleshooting steps in the following procedure in the KTA19GC CM558/CM2358 Service Manual, Bulletin 4021653. Refer to Procedure 011-009 in Section 11.

Go to 5A

Go to 6A

Guided Step 5 - Verify emmissions.

Guided Step 5A - Measure the oxygen concentration.

Conditions

  • Operate engine at highest load possible based on application derates.
  • Connect oxygen meter.

Action

Measure the oxygen concentration.

  • Measure the oxygen concentration and compare to value in the KTA19GC CM558/CM2358 Operation and Maintenance Manual, Bulletin 4021652. Refer to Procedure 307-001 in Section H.

In range?
YES NO

Replace the oxygen sensor. Refer to Procedure 019-100 in Section 19.

Check the engine setup. Refer to Procedure 307-001 in Section H.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2997 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2014


Fault Code 4686 - ECU Type - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4686 inactive?
STEP 2. | Check the 60-pin connector plug. |
 | STEP 2A. Inspect the 60-pin connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the 60-pin connector plug. | Greater than 100k ohms?
 | STEP 2C. Check for inactive fault code. | Fault Code 4686 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 4686 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4686 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the 60-pin connector plug.

Guided Step 2A - Inspect the 60-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 60-pin connector plug from the ECM.

Action

Inspect the 60-pin connector plug and ECM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector. Repair the damaged pins.

Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the 60-pin connector plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 60-pin connector plug from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the jumper wires in the 60-pin connector plug.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the 60-pin connector plug. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 2C

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect the 60-pin connector plug.
  • Turn keyswitch ON.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 4686 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3A

Go to 1A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 4686 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Dec-2013


INDEX
30-fc121.htm

30-t05-121.htm

30-fc135.htm

30-t05-135.htm

30-fc141.htm

30-t05-141.htm

30-fc142.htm

30-t05-142.htm

30-fc143.htm

30-t05-143.htm

30-fc144.htm

30-t05-144.htm

30-fc145.htm

30-t05-145.htm

30-fc146.htm

30-t05-146.htm

30-fc151.htm

30-t05-151.htm

30-fc153.htm

30-t05-153.htm

30-fc154.htm

30-t05-154.htm

30-fc155.htm

30-t05-155.htm

30-fc177.htm

30-t05-177.htm

30-fc187.htm

30-t05-187.htm

30-fc227.htm

30-t05-227.htm

30-fc234.htm

30-t05-234.htm

30-fc238.htm

30-t05-238.htm

30-fc239.htm

30-t05-239.htm

30-fc244.htm

30-t05-244.htm

30-fc254.htm

30-t05-254.htm

30-fc277.htm

30-t05-277.htm

30-fc343.htm

30-t05-343.htm

30-fc346.htm

30-t05-346.htm

30-fc352.htm

30-t05-352.htm

30-fc354.htm

30-t05-354.htm

30-fc355.htm

30-t05-355.htm

30-fc386.htm

30-t05-386.htm

30-fc415.htm

30-t05-415.htm

30-fc426.htm

30-t05-426.htm

30-fc441.htm

30-t05-441.htm

30-fc442.htm

30-t05-442.htm

30-fc477.htm

30-t05-477.htm

30-fc478.htm

30-t05-478.htm

30-fc488.htm

30-t05-488.htm

30-fc512.htm

30-t05-512.htm

30-fc513.htm

30-t05-513.htm

30-fc689.htm

00-t05-689.htm

30-fc697.htm

30-t05-697.htm

30-fc698.htm

30-t05-698.htm

30-fc752.htm

30-t05-752.htm

30-fc783.htm

30-t05-783.htm

30-fc1739.htm

30-t05-1739.htm

30-fc1776.htm

30-t05-1776.htm

30-fc1777.htm

30-t05-1777.htm

30-fc1791.htm

30-t05-1791.htm

30-fc1978.htm

30-t05-1978.htm

30-fc1979.htm

30-t05-1979.htm

30-fc2188.htm

30-t05-2188.htm

30-fc2192.htm

30-t05-2192.htm

30-fc2217.htm

30-t05-2217.htm

30-fc2219.htm

30-t05-2219.htm

30-fc2221.htm

30-t05-2221.htm

30-fc2311.htm

30-t05-2311.htm

30-fc2315.htm

30-t05-2315.htm

30-fc2316.htm

30-t05-2316.htm

30-fc2317.htm

30-t05-2317.htm

30-fc2455.htm

30-t05-2455.htm

30-fc2456.htm

30-t05-2456.htm

30-fc2544.htm

30-t05-2544.htm

30-fc2661.htm

30-t05-2661.htm

30-fc2789.htm

30-t05-2789.htm

30-fc2793.htm

30-t05-2793.htm

30-fc2794.htm

30-t05-2794.htm

30-fc2795.htm

30-t05-2795.htm

30-fc2797.htm

30-t05-2797.htm

30-fc2798.htm

30-t05-2798.htm

30-fc2864.htm

30-t05-2864.htm

30-fc2865.htm

30-t05-2865.htm

30-fc2866.htm

30-t05-2866.htm

30-fc2867.htm

30-t05-2867.htm

30-fc2995.htm

30-t05-2995.htm

30-fc2996.htm

30-t05-2996.htm

30-fc2997.htm

30-t05-2997.htm

30-fc4686.htm

30-t05-4686.htm